LAB 01 CIT Troubleshooting 1 by xenor88

VIEWS: 5 PAGES: 9

LAB 01 CIT Troubleshooting 1

More Info
									                                                                                             CIT LAB 1
                                                        Troubleshooting Basic Connectivity


       CIT Labs
       Lab 1: Troubleshooting Basic Connectivity
       Objective
       Isolate, identify, and correct Layer 1, Layer 2, and Layer 3 connectivity problems.

       Lab Topology
       For this lab, your network design will include two pods of devices. Both pods will be configured
       upon the initial loading of the lab. The Topology diagram below represents the NetMap in the
       Simulator. To access each of the devices from within the Simulator, select the device name from
       the appropriate menu in the Simulator. For example, to access P1R1, click the eRouters button
       and select P1R1 from the drop-down menu.

                       Pod 1                                                     Pod 2



                       P1R3                                                     P2R3
                                 Fast Ethernet 0/0                                           Fast Ethernet 0/0
                                    10.40.1.2                                                   10.40.2.2




                  Switch 1                                                 Switch 2

                                 Fast Ethernet 0/0                                           Fast Ethernet 0/0
                                    10.40.1.1                                                   10.40.2.1

Loopback 0                                            Loopback 0
 10.10.1.1                                             10.10.2.1
                       P1R2                                                     P2R2
                                Serial 0/0                                                   Serial 0/0
                                10.30.1.6                                                    10.30.2.6

                                Serial 0/0                                                   Serial 0/0
                                10.30.1.5                                                    10.30.2.5


Loopback 0                                            Loopback 0
 10.20.1.1                                             10.20.2.1
                       P1R1                                                     P2R1
                                 Fast Ethernet 0/0                                           Fast Ethernet 0/0
                                   10.100.100.1                                                10.100.100.2



                                                   Backbone
         CIT LAB 1
            Troubleshooting Basic Connectivity

Command Summary
                   Command                                                   Description
configure terminal                                  enters global configuration mode
ping ip_address                                    requests a reply packet from a destination host to test network
                                                   reachability
interface type number                              changes from global config mode to interface config mode
ip address ip_address subnet_mask                  sets the IP address to the specified value
shutdown; no shutdown                              disables an interface; enables an interface
enable                                             enters privileged EXEC mode
disable                                            returns to user EXEC mode
exit                                               exits one level in the menu structure
encapsulation [hdlc | ppp]                         sets the Data Link layer protocol for an interface
no ip domain-lookup                                disables DNS lookups
router routing_protocol                            changes to router configuration mode
network network_address                            enables a routing protocol to route for an attached network
show controllers interface_type interface_num      shows cable orientation for serial interfaces
clock rate clock_rate                              sets the clock rate for a DCE interface
show ip protocols                                  displays the loaded routing protocols
show interface                                     displays the interface’s Data Link layer status
show startup-config                                 displays the backup configuration file
show running-config                                 displays the active configuration file
show controller                                    displays the interface’s Physical layer status
traceroute                                         displays the network path to a given destination


          Lab Tasks
          Task 1: Loading the Lab 1 Initial Configuration
              1. Make sure the correct topology and configuration files for this lab are loaded. This should
                 occur automatically when you select this lab from the Lab Navigator. Review the Lab
                 Topology diagram, and note that you will be required to analyze the network and identify,
                 isolate, and correct various configuration errors.
          Task 2
          A. Analyzing the Network
              1. From P1R3, try to ping the FastEthernet 0/0 interface of P2R3. Is the ping successful?
                 _____________________________________________________________
              2. Attempt to isolate the problem by determining whether network traffic can travel across
                 the classroom backbone. What command should you use?
                 _____________________________________________________________
                                                                               CIT LAB 1
                                               Troubleshooting Basic Connectivity

    3. What is the most distant part of the network you can reach from P1R3?
       _____________________________________________________________
    4. What command(s) did you use to determine this?
       _____________________________________________________________
B. Isolating the Problem
    1. What is the next hop beyond the last reachable part of the network? How did you
       determine this?
       _____________________________________________________________
    2. Specifically, which router and interface is this?
       _____________________________________________________________
    3. What is the state of the interface?
       _____________________________________________________________
    4. How did you determine the interface state?
       _____________________________________________________________
    5. Would you categorize this as a Layer 1, Layer 2, or Layer 3 problem, and why?
       _____________________________________________________________
    6. Based on your analysis of the network and isolation of the problem, what is the first pair
       of connected interfaces that are not passing traffic?
       _____________________________________________________________
    7. How did you determine this?
       _____________________________________________________________
C. Correcting the Error
    1. Carefully examine the configuration of each of the two connected interfaces. Focus on
       configuration issues appropriate to Layer 1, Layer 2, or Layer 3 as determined in B5.
       What problem do you see?
       _____________________________________________________________
    2. What should you do to correct the problem?
       _____________________________________________________________
Task 3
A. Analyzing the Network
    1. After completion of Task 2, how has the state of the network changed? What is the most
       distant part of the network that is now reachable?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
B. Isolating the Problem
    1. What is the next hop of the network beyond the last reachable part of the network?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
    3. Specifically, which router and interface is this?
       _____________________________________________________________
CIT LAB 1
  Troubleshooting Basic Connectivity

    4. What are the states of these two interfaces?
       _____________________________________________________________
    5. How did you determine the interface states?
       _____________________________________________________________
    6. Based on your examination, at what OSI layer is the problem occurring?
       _____________________________________________________________
    7. From your analysis of the network and isolation of the problem, what is the first pair of
       connected interfaces that are not passing traffic?
       _____________________________________________________________
    8. How did you determine this?
       _____________________________________________________________
C. Correcting the Error
    1. Carefully examine the configuration of each of the two connected interfaces. Focus on
       configuration issues appropriate to Layer 1, Layer 2, or Layer 3 as determined in B6. What
       problem do you see?
       _____________________________________________________________
    2. What should you do to correct the problem?
       _____________________________________________________________
Task 4
A. Analyzing the Network
    1. After the completion of Task 3, what is the most distant part of the network that is now
       reachable?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
B. Isolating the Problem
    1. What is the next hop of the network beyond the last reachable part of the network?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
    3. Specifically, which router and interface is this?
       _____________________________________________________________
    4. What are the states of these two interfaces?
       _____________________________________________________________
    5. How did you determine the interface states?
       _____________________________________________________________
    6. Based on your examination, at what OSI layer is the problem occurring?
       _____________________________________________________________
C. Correcting the Error
    1. Carefully examine the configuration of each of the two connected interfaces. Focus on
       configuration issues appropriate to Layer 1, Layer 2, or Layer 3 as determined in B6. What
       problem do you see?
       _____________________________________________________________
                                                                                 CIT LAB 1
                                                Troubleshooting Basic Connectivity

    2. What should you do to correct the problem?
       _____________________________________________________________
Task 5
A. Analyzing the Network
    1. After the completion of Task 4, what is the most distant part of the network that is now
       reachable?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
B. Isolating the Problem
    1. What is the next hop of the network beyond the last reachable part of the network?
       _____________________________________________________________
    2. How did you determine this?
       _____________________________________________________________
    3. Specifically, which router(s) and interface(s) make up this link?
       _____________________________________________________________
    4. What are the states of these two interfaces?
       _____________________________________________________________
    5. How did you determine the interface states?
       _____________________________________________________________
    6. Based on your examination, at what OSI layer is the problem occurring?
       _____________________________________________________________
    7. From your analysis of the network and isolation of the problem, what is the first pair of
       connected interfaces that are not passing traffic?
       _____________________________________________________________
    8. How did you determine this?
       _____________________________________________________________
C. Correcting the Error
    1. Carefully examine the configuration of each of the two connected interfaces. Focus on
       configuration issues appropriate to Layer 1, Layer 2, or Layer 3 as determined in B6.
       What problem do you see?
       _____________________________________________________________
    2. What should you do to correct the problem?
       _____________________________________________________________
Task 6: Verifying the Configuration
    1. Refer to the Lab Topology diagram.
    2. From the console of each router, make sure you can ping all other routers in Pod 1 and Pod
       2.
    3. Use the Save Multi Devices Configs option from the File menu. Name the files CIT
       Lab 1.
CIT LAB 1
  Troubleshooting Basic Connectivity

Lab Solutions
Task 2
A. Analyzing the Network
    1. The ping to 10.40.2.2 is not successful.
    2. traceroute 10.40.2.2
    3. 10.40.1.1 (FastEthernet 0/0 on P1R2)
    4. traceroute 10.40.2.2 and ping 10.40.1.1
B. Isolating the Problem
    1. The next hop beyond the last reachable part of the network is 10.30.1.6. This can be
       determined by consulting the network documentation, which is the Lab Topology diagram
       in this case.
    2. serial 0/0 on P1R2
    3. interface is up, line protocol is down
    4. by using the show interface serial 0/0 command
    5. This is a Layer 2 problem because the physical interface (Layer 1) is up, but the interface
       protocol (HDLC – Layer 2 in this case) is down.
    6. serial 0/0 on P1R2 and serial 0/0 on P1R1
    7. by consulting the Lab Topology diagram and using the show interface command
C. Correcting the Error
    1. Since the serial link between P1R1 and P1R2 is experiencing a Layer 2 problem, the most likely
       issue is a timing or encapsulation error. Check to make sure the serial interfaces on each end
       of the P1R1/P1R2 link are running the same encapsulation. In this case, they are both running
       default HDLC encapsulation. Since these serial interfaces are connected back-to-back, the
       data communications equipment (DCE) end of the connection must provide clocking.
    2. Use the show controller serial 0/0 command on both P1R1 and P1R2 to determine
       which end of the link is the DCE. Add the missing clock rate 64000 command to the
       DCE end of the serial link.
Task 3
A. Analyzing the Network
    1. Serial 0/0 on P1R1 is reachable now that the serial link between P1R1 and P1R2 is up.
    2. by pinging the far end of the serial link (10.30.1.5) after correcting the configuration error
B. Isolating the Problem
    1.   10.100.100.1
    2.   by consulting the Lab Topology diagram
    3.   FastEthernet 0/0 on P1R1
    4.   Interface and line protocol are up/up on both.
    5.   by using the show interface command
    6.   Since the interface and line protocol are up on both interfaces that make up this link,
         this is likely to be a Layer 3 problem.
                                                                                 CIT LAB 1
                                                Troubleshooting Basic Connectivity

    7. FastEthernet 0/0 on P1R1 and FastEthernet 0/0 on P1R2
    8. Attempts to ping to and through this link fail.
C. Correcting the Error
    1. Since this is a Layer 3 problem, start with IP configuration basics. Think about the
       following questions. Are both interfaces in the same network? Is the subnet mask correct?
    2. FastEthernet 0/0 on P1R1 has a misconfigured IP address that is not in the same network
       as the IP address configured on the interface at the other end of the link. Remove the
       incorrect IP address, and replace it with the correct IP address, which is 10.100.100.1.
Task 4
A. Analyzing the Network
    1. FastEthernet 0/0 on P2R1
    2. by consulting the Lab Topology diagram and attempting to ping through the P1R1
       FastEthernet 0/0 – P2R1 FastEthernet 0/0 link
B. Isolating the Problem
    1.   10.30.2.5
    2.   by consulting the Lab Topology diagram and attempting to ping further along the path
    3.   serial 0/0 on P2R1
    4.   Both interfaces are up/down (interfaces are up, protocol is down).
    5.   by using the show interface command on serial 0/0 on P2R1 and serial 0/0 on P2R2
    6.   This is a Layer 2 problem because the interfaces are connected and physically active;
         however, the line protocol is down, indicating keepalive packets are not being sent due
         to a timing or encapsulation problem.
C. Correcting the Error
    1. One end of the link (P2R1) is using the default encapsulation, which is HDLC. The other end
       of the link (P2R2) is using PPP encapsulation. Each interface can communicate with another
       interface only by using the same encapsulation method, so both interfaces are up/down.
    2. Use no encap ppp then encap hdlc on P2R2 to return this interface to its default
       HDLC encapsulation method to match the interface at the other end of the link.
Task 5
A. Analyzing the Network
    1. 10.40.2.1, which is the FastEthernet 0/0 interface on P2R2
    2. by pinging beyond the P2R1/P2R2 serial link to P2R2 FastEthernet 0/0
B. Isolating the Problem
    1.   10.40.2.2
    2.   by consulting the Lab Topology diagram
    3.   Fast Ethernet 0/0 on P2R3 and Fast Ethernet 0/0 on P2R2
    4.   FastEthernet 0/0 on P2R2 is up/up, and FastEthernet 0/0 on P2R3 is down/down.
    5.   by using the show interface command
          CIT LAB 1
             Troubleshooting Basic Connectivity

               6. The problem is occurring at Layer 1; the interface is down.
               7. FastEthernet 0/0 on P2R2 and FastEthernet 0/0 on P2R3
               8. by consulting the Lab Topology diagram and attempting to ping to and through the
                  appropriate links
           C. Correcting the Error
               1. Interface FastEthernet 0/0 on P2R3 has been shut down by the administrator (it is
                  administratively down).
               2. Issue the no shutdown command on FastEthernet 0/0 on P2R3. This will bring the
                  interface back up.

Sample Configuration Scripts
               P1R1                                  P1R2                                      P1R3
hostname P1R1                          hostname P1R2                          hostname P1R3
!                                      !                                      !
enable secret cisco                    enable secret cisco                    enable secret cisco
enable password cisco                  enable password cisco                  enable password cisco
!                                      !                                      !
no ip domain-lookup                    no ip domain-lookup                    no ip domain-lookup
!                                      !                                      !
interface Loopback0                    interface Loopback0                    interface FastEthernet0/0
  ip address 10.20.1.1 255.255.255.0     ip address 10.10.1.1 255.255.255.0     ip address 10.40.1.2 255.255.255.0
!                                      !                                        no ip directed-broadcast
interface FastEthernet0/0              interface FastEthernet0/0              !
  ip address 10.100.100.1                ip address 10.40.1.1 255.255.255.0   router rip
   255.255.255.0                         speed auto                             version 2
!                                      !                                        network 10.0.0.0
interface Serial0/0                    interface Serial0/0                    !
  ip address 10.30.1.5 255.255.255.0     ip address 10.30.1.6 255.255.255.0   ip classless
  clockrate 64000                      !                                      !
!                                      router rip                             line con 0
router rip                               version 2                              exec-timeout 0 0
  version 2                              network 10.0.0.0                       logging synchronous
  network 10.0.0.0                     !                                        transport input none
!                                      ip classless                           !
ip classless                           !                                      line vty 0 4
!                                      line con 0                               exec-timeout 0 0
line con 0                               exec-timeout 0 0                       password cisco
  exec-timeout 0 0                       logging synchronous                    logging synchronous
  logging synchronous                  !                                        login
  transport input none                 line vty 0 4                           !
!                                        exec-timeout 0 0
line vty 0 4                             password cisco
  exec-timeout 0 0                       logging synchronous
  password cisco                         login
  logging synchronous                  !
  login
!
                                                                                        CIT LAB 1
                                                         Troubleshooting Basic Connectivity

Sample Configuration Scripts
               P2R1                                   P2R2                                   P2R3
version 12.1                           version 12.1                           version 12.1
service timestamps debug uptime        service timestamps debug uptime        service timestamps debug uptime
service timestamps log uptime          service timestamps log uptime          service timestamps log uptime
no service password-encryption         no service password-encryption         no service password-encryption
!                                      !                                      !
hostname P2R1                          hostname P2R2                          hostname P2R3
!                                      !                                      !
ip subnet-zero                         ip subnet-zero                         ip subnet-zero
!                                      !                                      !
interface Loopback0                    interface Loopback0                    interface FastEthernet0/0
  ip address 10.20.2.1 255.255.255.0     ip address 10.10.2.1 255.255.255.0     ip address 10.40.2.2 255.255.255.0
  no ip directed broadcast               no ip directed broadcast               no ip directed-broadcast
!                                      !                                      !
interface Serial0/0                    interface Serial0/0                    router rip
  ip address 10.30.2.5 255.255.255.0     ip address 10.30.2.6 255.255.255.0     version 2
  no ip directed-broadcast               no ip directed-broadcast               network 10.0.0.0
  clock rate 64000                     !                                      !
!                                      interface FastEthernet0/0              ip classless
interface Serial0/1                      ip address 10.40.2.1 255.255.255.0   no ip http server
  no ip address                          no ip directed-broadcast             !
  no ip directed-broadcast             !                                      line con 0
!                                      router rip                               transport input none
interface FastEthernet0/0                version 2                            line aux 0
  ip address 10.100.100.2                network 10.0.0.0                     line vty 0 4
   255.255.255.0                       !                                      !
  no ip directed-broadcast             ip classless                           no scheduler allocate
!                                      no ip http server                      end
router rip                             !
  version 2                            line con 0
  network 10.0.0.0                       transport input none
!                                      line aux 0
ip classless                           line vty 0 4
no ip http server                      !
!                                      no scheduler allocate
line con 0                             end
  transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

								
To top