Advanced-MultiSiteFrameAndPolicyMap

Document Sample
Advanced-MultiSiteFrameAndPolicyMap Powered By Docstoc
					                                          Multi-Site Frame Relay and Policy Routing



Objectives
This lab will allow you to develop your ability to combine multiple technologies to create a network
infrastructure that is typical of a medium-size enterprise with multiple sites. You will use your
knowledge of VLANs, Layer 2 switching, Layer 3 routing, and dynamic routing protocols to build

connectivity in the event of failure of the primary WAN connection.

Simulated Network Overview
The simulated network that you will create spans two geographically separate sites, Pod 1 and Pod
2, with one router, one switch, and four PC hosts in each site. In each site, two of the PC hosts will
be connected to one VLAN, and the other two PC hosts will be connected to a different VLAN.
Each router will have a subinterface for each VLAN, and 802.1q trunking will be used to connect
each subinterface to the appropriate VLAN on the switch. The routers in each site will be connected
to each other by a point-to-point Frame Relay WAN link.

connection between the two sites.
You should be able to combine and use skills learned in prior labs to build out this network.

Lab Topology
For this lab, your network design will include the devices shown in the Topology diagram below.

Simulator. To access each of the devices from within the Simulator, select the device name from
the appropriate menu in the Simulator. For example, to access P1R1, click the eRouters button
and select P1R1 from the drop-down menu.

                                               Frame
                                               Relay
            Serial0.1                                                        Serial0.1
     IP Address 10.100.10.1                                           IP Address 10.100.10.2
           DLCI 102                                                         DLCI 201

                         Dialer1                               Dialer1
                       172.16.10.1    ISDN DDR Backup
                                                             172.16.10.2
                          Serial                                Serial
             P1R1      10.200.20.1   Point-to-Point Leased                  P2R1
                                                             10.200.20.2

                  FastEthernet0/0.1 192.168.110.1 VLAN 1                            FastEthernet0/0.1 192.168.210.1 VLAN 1
                  FastEthernet0/0.20 192.168.120.1 VLAN 20                          FastEthernet0/0.20 192.168.220.1 VLAN 20
                  FastEthernet0/0.30 192.168.130.1 VLAN 30                          FastEthernet0/0.30 192.168.230.1 VLAN 30


          P1SW1         Vlan 1 192.168.110.2                               P2SW1         Vlan 1 192.168.210.2




        P1PC1         P1PC2         P1PC3         P1PC4                P2PC1            P2PC2           P2PC3           P2PC4
     192.168.120.2 192.168.130.2 192.168.120.4 192.168.130.4        192.168.220.2    192.168.230.2   192.168.220.4   192.168.230.4
       VLAN 20       VLAN 30       VLAN 20       VLAN 30              VLAN 20          VLAN 30         VLAN 20         VLAN 30
         Fa0/2         Fa0/3         Fa0/4         Fa0/5                Fa0/2            Fa0/3           Fa0/4           Fa0/5

             Pod 1                                                               Pod 2
            Multi-Site Frame Relay and Policy Routing

Command Summary
                Command                                                      Description
configure terminal
hostname host_name                               assigns a host name to a router or switch
show run
erase startup-config
ip address ip_address subnet_mask                assigns an IP address and subnet mask to an interface
vlan vlan_id name vlan_name                      creates and/or names a VLAN
show vlan                                        displays VLAN information
interface type number
switchport access vlan vlan_id                   assigns a switch port to a VLAN
speed {10 | 100 | 1000 | auto | nonegotiate}     sets the interface speed
duplex {auto | full | half}
show ip interface brief                          displays information for IP interfaces
interface type number subinterface_id            creates a subinterface
encapsulation dot1q vlan_id                      sets the encapsulation method of the interface for 802.1q VLAN trunking;

switchport mode trunk
switchport mode access
switchport trunk encapsulation dot1q             sets the encapsulation method used for a switch trunk port
enable password                                  enters privileged EXEC mode
exit                                             exits the current mode
router eigrp asn
network network_address
frame-relay interface-dlci dlci
                                                 subinterface that will connect to a Frame Relay network
encapsulation frame-relay

          Note: Please be aware of the following when using the Grade Lab function in the Lab Navigator. If
          you choose to use an IP addressing scheme other than that shown in the lab documentation, you

          these grading errors.
                                     Multi-Site Frame Relay and Policy Routing

Lab Tasks


         occur automatically when you select this lab from the Lab Navigator.

       What command should you use to accomplish this?
       ______________________________________________________________
    3. Per the Lab Topology diagram, change the host names of all routers and switches. What
       commands should you use to accomplish this?
       ______________________________________________________________
Task 2
A. Assigning IP Addresses to the PC Hosts
    1. By default, are the PC hosts already in a VLAN? If so, which VLAN? Write down the
       command you use to determine this.
       ______________________________________________________________
    2. Use the Lab Topology diagram to determine the correct IP addresses and default
       gateways for P1PC1, P1PC2, P1PC3, P1PC4, P2PC1, P2PC2, P2PC3, and P2PC4.

       a 24-bit subnet mask (255.255.255.0). Remember that the gateway for each PC host is
       the router subinterface that will be assigned to the VLAN of which the PC host will be a
       member. Write down the commands you use to accomplish this.
       ______________________________________________________________
    3. From the console of each PC host in a given site, can you ping all other PC hosts in the
       same site? Why or why not?
       ______________________________________________________________
    4. From the console of P1PC1, can you ping any of the PC hosts in Pod 2? Why or why not?
       ______________________________________________________________
B. Assigning IP Addresses to the Management VLANs on P1SW1 and P2SW1
    1. Use the Lab Topology diagram to determine the correct IP addresses for the management
       VLANs on P1SW1 and P2SW1. Assign the correct IP address to the management VLAN on
       each switch. Remember to use a 24-bit subnet mask (255.255.255.0). Write down the
       commands you use.
       ______________________________________________________________

         the switches. What commands should you use to accomplish this?
         ______________________________________________________________
Task 3
A. Creating VLANs on P1SW1 and P2SW1 and Assigning the Appropriate Switch Ports to
   These VLANs
    1. Examine the Lab Topology diagram. How many VLANs will you need to create, and what

         ______________________________________________________________
  Multi-Site Frame Relay and Policy Routing

    2. Issue the commands necessary to create these VLANs. Write down the commands you use.
       ______________________________________________________________
    3. Verify that you have created the VLANs correctly. What command should you use?
       ______________________________________________________________
B. Placing the PC Hosts in Both Sites in the Correct VLANs
    1. Refer to the Lab Topology diagram, and write down which PC hosts should go into which
       VLANs.
       ______________________________________________________________

         half duplex for all PC hosts, and make sure each port is an access port. Write down the
         commands you use.
         ______________________________________________________________


         commands you use.
         ______________________________________________________________
Task 4
A. Creating the FastEthernet Subinterfaces on P1R1 and P2R1
    1. You will need to create a subinterface on each router for each VLAN. Write down the
       names of the subinterfaces you plan to create. What rationale did you use when deciding
       on names for the subinterfaces?
       ______________________________________________________________
    2. On P1R1 and P2R1, create the subinterfaces that you listed in the previous step.
       Remember that the router interface may be in a shutdown state in the default

         down the commands you use.
         ______________________________________________________________
B. Assigning IP Addresses to the FastEthernet Subinterfaces on P1R1 and P2R1
    1. Refer to the Lab Topology diagram, and write down the IP addresses that you will assign
       to each subinterface.
       ______________________________________________________________
    2. Per your list above, assign the appropriate IP address to each subinterface. Remember to
       use a 24-bit subnet mask (255.255.255.0). Write down the commands you use.
       ______________________________________________________________
    3. Be sure to verify that you have assigned the correct IP address and subnet mask to each
       subinterface. Check your work, and write down the commands you use to perform this

         ______________________________________________________________


    1. When the Ethernet frames leaving FastEthernet0/0 on P1R1 and P2R1 arrive at
       FastEthernet0/1 on P1SW1 and P2SW1, respectively, the switches will examine the 4-byte
       VLAN tag in each Ethernet frame to determine which virtual LAN should receive the
                                       Multi-Site Frame Relay and Policy Routing

         frame. In order for the frames leaving the routers’ Fa0/0 interface to be tagged correctly,

         identify the VLAN to which each subinterface belongs.

         to accomplish this.
         ______________________________________________________________


   1. Which port on P1SW1 is used to connect to P1R1?
      ______________________________________________________________
      Which port on P2SW1 is used to connect to P2R1?
      ______________________________________________________________


         carries only Ethernet frames of the VLAN of which the port is a member.


         _______________________________________________________
Task 5: Verifying Network Connectivity
   1. You should be able to ping every node in each site from every other node in the same site.
      From the console of each PC host, attempt to ping all other PC hosts in the same site. Are
      you able to do so?
      ______________________________________________________________
   2. From the console of P1SW1, you should be able to ping all subinterfaces on P1R1 as well
      as all PC hosts in Pod 1. Verify that this is the case. Write down the commands you use.
      ______________________________________________________________
   3. From the console of P1R1, you should be able to ping all PC hosts in Pod 1 as well as the
      management VLAN on P1SW1. Verify that this is the case. Write down the commands you use.
      ______________________________________________________________
Task 6
A. Reviewing WAN Connectivity
   1. At present, you should have full connectivity within each site. Every node in each site
      should be able to ping every other node in the same site.

      one site to be able to ping nodes in the other site.
   3. The two sites are connected by a point-to-point Frame Relay WAN link. Because network

         the router in the other site about all of its directly connected networks.
B. Preparing for Frame Relay


         switches in the provider’s cloud to route the customer’s data along the virtual circuit that
         connects the two sites.
  Multi-Site Frame Relay and Policy Routing

                                                NetMap button in the NetSim Control Panel,
         right-click the Frame Relay cloud, and select the Set Frame Relay Parameters menu




         P1R1 and P2R1.
         ______________________________________________________________

         interfaces on P1R1 and P2R1 for Frame Relay encapsulation. Cisco routers support both
         Cisco’s own proprietary Frame Relay encapsulation and RFC 1490 IETF encapsulation.

      interfaces on both P1R1 and P2R1 for Frame Relay encapsulation. Also, make sure the
      interfaces are not administratively down. Write down the commands you use.
      ______________________________________________________________
   3. On each router, create a serial subinterface at which to terminate the Frame Relay virtual

         that you listed in step C1. Be sure to use a 24-bit subnet mask (255.255.255.0). Write
         down the commands you use.
         ______________________________________________________________
D. Testing WAN Connectivity

         created subinterfaces to terminate each end of the Frame Relay virtual circuit that will


   2. From the console of P1R1, attempt to ping the IP address of the Frame Relay subinterface
      on P2R1. Write down the command you use. Is the ping successful?
      ______________________________________________________________
   3. From the console of P2R1, attempt to ping the IP address of the Frame Relay subinterface
      on P1R1. Write down the command you use. Is the ping successful?
      ______________________________________________________________
   4. From the console of P1PC1, try to ping P2PC2. Is the ping successful?
      ______________________________________________________________
Task 7

   1. As you have probably determined by now, connectivity exists within each site. Each
      node in a site can ping any other node in the same site. From the consoles of both P1R1
      and P2R1, you should also be able to ping across the WAN to the serial interface on
      the opposite end of the link. However, pings from any of the PC hosts in one site to any
      PC host in the other site fail. Perform some basic troubleshooting, and write down your
      thoughts as to what is causing this.
      ______________________________________________________________
                                                 Multi-Site Frame Relay and Policy Routing


                   ______________________________________________________________

                   so that it tells the other router about its directly connected networks. Write down the
                   commands you use.
                   ______________________________________________________________
         B. Verifying Dynamic Routing and Network Connectivity

                   now be sending information regarding its directly connected networks to the other router.
                   Verify that this is indeed happening, and write down the command you use to perform

                  ______________________________________________________________
               2. From the console of P1PC1, try to ping P2PC2 again. Is the ping successful?
                  ______________________________________________________________
               3. Why is the ping successful now, whereas it failed before?
                  ______________________________________________________________
               4. Verify that you can ping any node in the network from the console of any other node, both
                  within and between sites.




               1. In order to provide connectivity between sites in the event of WAN failure, you will



 Pod    Router           SPID 1                 SPID 2           Dial #     ISDN Switch      User Name      Password
Pod 1   P1R1       321778201000100 321778201100100 7782020 BASIC-NI                        P2R1             cisco
Pod 2   P2R1       321778202000100 321778202100100 7782010 BASIC-NI                        P1R1             cisco
                   Issue the commands necessary to assign these parameters to the BRI interfaces on each
                   router. Be sure to make the Bri0 interface on each router a member of a dialer pool. Write
                   down the commands you use.
                   ______________________________________________________________


                   interesting. Write down the command you use on each router. You should then reference
                   this access list in a dialer-list

                   ______________________________________________________________

                   differently?
                   ______________________________________________________________
  Multi-Site Frame Relay and Policy Routing

   5. On each router, create a dialer interface that references the dialer pool of which the Bri0
      interface is a member. You should specify PPP encapsulation and CHAP authentication.
      Be sure to assign an IP address to the interface as indicated in the Lab Topology


       ______________________________________________________________

       (172.16.10.2). Are you able to do so? Then log on to the console of P2R1, and verify that

       ______________________________________________________________
                                               show commands might you
       use to determine this?
       ______________________________________________________________
B. Routing Considerations for DDR WAN Failover


       and sometimes on a per-connect, basis. It is advantageous to minimize line use in these

       over the BRI link. Why do you think advertising the BRI interface network using a dynamic
       routing protocol might be a bad idea?
       ______________________________________________________________

       the remote site across the BRI link. Take the necessary steps to ensure that the router
       will only use the static routes if the Frame Relay WAN link goes down. Write down the
       commands you use to create the static routes.
       ______________________________________________________________
C. Verifying DDR Operation
   1. From the console of P1PC1, make sure you can ping P2PC2. After verifying connectivity,
      use the tracert command on P1PC1 to observe the path to P2PC2. Under normal
                                                                                      ping
      and tracert commands you use.
      ______________________________________________________________

      ______________________________________________________________
   3. Observe the routing tables on P1R1 and P2R1, and then issue the shutdown command
      on the Serial0.1 interface on P1R1. This will disable the Frame Relay link between P1R1
      and P2R1 and cause the interfaces to go down. Wait at least a minute, and then display
      the routing table again and describe what changes have occurred.
      ______________________________________________________________

       Frame Relay link has been disabled? Why or why not?
       ______________________________________________________________
                                      Multi-Site Frame Relay and Policy Routing

Task 9
A. Establishing Point-to-Point Leased Line Connectivity
    1. Refer to the Lab Topology diagram, and note the existence of a point-to-point leased line
       between P1R1 and P2R1. On which interface does this line terminate on P1R1? On which
       interface does this line terminate on P2R1?
       ______________________________________________________________
    2. Because this is a point-to-point link, only two IP addresses will be required for the
       network formed when these two interfaces are connected. Use 10.200.20.1 as the IP
       address on P1R1. Use 10.200.20.2 as the IP address on P2R1. In order to conserve IP
       addresses for possible future point-to-point links in the network, select an appropriate




         ______________________________________________________________


         CHAP authentication? Why or why not?
         ______________________________________________________________
B. Verifying Point-to-Point Leased Line Connectivity
    1. From the console of P1R1, try to ping the other end of the point-to-point link that you just

       ______________________________________________________________
    2. Issue the shutdown command on interface Serial0.1 on P1R1, and wait 60 seconds for
       the routing table to reset. Next, use the tracert command from P1PC1 to P2PC3. What
       path do the packets take? Why?
       ______________________________________________________________
    3. Issue the shutdown command on interface Serial1 on P1R1, and wait 60 seconds for the
       routing table to reset. Next, use the ping and tracert commands from P1PC1 to P2PC3.
       Is the ping successful? What path did the packets take? Why?
       ______________________________________________________________
    4. Issue the no shutdown command on both Serial0.1 and Serial1 on P1R1.
C. Manipulating Path Selection with Route Maps
    1. In the simulated network, assume that only IP telephony equipment, including IP
       telephones, gateways, and voice mail systems, resides in VLAN 30 in each site. You will use


    2. What IP network address is used on VLAN 20 in Pod 1?
       ______________________________________________________________
    3. What IP network address is used on VLAN 20 in Pod 2?
       ______________________________________________________________

         What command should you use?
         ______________________________________________________________
  Multi-Site Frame Relay and Policy Routing

         What command should you use?
         ______________________________________________________________

       the distant end of the Frame Relay link as the next hop. Write down the commands you
       use to accomplish this.
       ______________________________________________________________
    7. Assign the policies you created in the previous step to the appropriate interfaces on P1R1
       and P2R1. Write down the commands you use.
       ______________________________________________________________
D. Verifying Policy Routing and Route Maps
    1. Verify that you can ping P2PC2 from P1PC2. Also, make sure that you can ping P2PC1
       from P1PC1. Are these pings successful? If not, check your work and correct the

       ______________________________________________________________
    2. Use the tracert command on P1PC2 to trace the path to P2PC2. Which link does the

       ______________________________________________________________
    3. Use the tracert command on P1PC1 to trace the path to P2PC1. Which link does the

       ______________________________________________________________
    4. Remove the route map from the interfaces to which you assigned it earlier. Now trace the

       ______________________________________________________________
    5. Re-apply the route map to the interfaces to which you assigned it earlier. Verify that VLAN


Lab Solutions

    2.   Issue the erase startup-config command on P1R1, P2R1, P1SW1, and P2SW1.
    3.   P1R1:                         P2R1:
         config t                       config t
         hostname P1R1                 hostname P2R1
         P1SW1:                        P2SW1:
         config t                       config t
         hostname P1SW1                hostname P2SW1
Task 2
A. Assigning IP Addresses to the PC Hosts
    1. You should issue the show vlan command to see that the PC hosts are already in VLAN 1.
                                    Multi-Site Frame Relay and Policy Routing

   2. P1PC1:
      ipconfig /ip 192.168.120.2 255.255.255.0
      ipconfig /dg 192.168.120.1
      P1PC2:
      ipconfig /ip 192.168.130.2 255.255.255.0
      ipconfig /dg 192.168.130.1
      P1PC3:
      ipconfig /ip 192.168.120.4 255.255.255.0
      ipconfig /dg 192.168.120.1
      P1PC4:
      ipconfig /ip 192.168.130.4 255.255.255.0
      ipconfig /dg 192.168.130.1
      P2PC1:
      ipconfig /ip 192.168.220.2 255.255.255.0
      ipconfig /dg 192.168.220.1
      P2PC2:
      ipconfig /ip 192.168.230.2 255.255.255.0
      ipconfig /dg 192.168.230.1
      P2PC3:
      ipconfig /ip 192.168.220.4 255.255.255.0
      ipconfig /dg 192.168.220.1
      P2PC4:
      ipconfig /ip 192.168.230.4 255.255.255.0
      ipconfig /dg 192.168.230.1

       with different IP network addresses; therefore, pings between these two PC hosts fail. The
       same is true for P2PC1 and P2PC2. They are also currently in VLAN 1, but because they



B. Assigning IP Addresses to the Management VLANs on P1SW1 and P2SW1
   1. P1SW1:
      config t
      interface vlan 1
      ip address 192.168.110.2 255.255.255.0
      P2SW1:
      config t
      interface vlan 1
      ip address 192.168.210.2 255.255.255.0
   2. On both P1SW1 and P2SW1, you should use the show ip interfaces brief and show
      running-config commands.
  Multi-Site Frame Relay and Policy Routing

Task 3
A. Creating VLANs on P1SW1 and P2SW1 and Assigning the Appropriate Switch Ports to
   These VLANs
    1. You will need to create two VLANS: VLAN 20 and VLAN 30.
    2. P1SW1 and P2SW1:
       config t
       vlan 20
       vlan 30
    3. You should use the show vlan command on both P1SW1 and P2SW1.
B. Placing the PC Hosts in Both Sites in the Correct VLANs
    1. P1PC1, P1PC3, P2PC1, and P2PC3 should be included in VLAN 20.
       P1PC2, P1PC4, P2PC2, and P2PC4 should be included in VLAN 30.
    2. P1SW1 and P2SW1:
       config t
       int fa0/2
       switchport mode access
       switchport access vlan 20
       speed 100
       duplex half
       int fa0/3
       switchport mode access
       switchport access vlan 30
       speed 100
       duplex half
       int fa0/4
       switchport mode access
       switchport access vlan 20
       speed 100
       duplex half
       int fa0/5
       switchport mode access
       switchport access vlan 30
       speed 100
       duplex half
    3. P1SW1 and P2SW1:
       conf t
       int fa0/1
       speed 100
       duplex full
                                   Multi-Site Frame Relay and Policy Routing

Task 4
A. Creating the FastEthernet Subinterfaces on P1R1 and P2R1

      Thus, you should create subinterfaces FastEthernet0/0.1, FastEthernet0/0.20, and
      FastEthernet0/0.30 on both P1R1 and P2R1.
   2. P1R1 and P2R1:
      config t
      interface FastEthernet0/0
      no shutdown
      interface FastEthernet0/0.1
      interface FastEthernet0/0.20
      interface FastEthernet0/0.30
B. Assigning IP Addresses to the FastEthernet Subinterfaces on P1R1 and P2R1
   1. P1R1:
      FastEthernet0/0.1      192.168.110.1
      FastEthernet0/0.20     192.168.120.1
      FastEthernet0/0.30     192.168.130.1
      P2R1:
      FastEthernet0/0.1      192.168.210.1
      FastEthernet0/0.20     192.168.220.1
      FastEthernet0/0.30     192.168.230.1
   2. P1R1:
      config t
      int fa0/0.1
      ip address 192.168.110.1 255.255.255.0
      int fa0/0.20
      ip address 192.168.120.1 255.255.255.0
      int fa0/0.30
      ip address 192.168.130.1 255.255.255.0
      P2R1:
      config t
      int fa0/0.1
      ip address 192.168.210.1 255.255.255.0
      int fa0/0.20
      ip address 192.168.220.1 255.255.255.0
      int fa0/0.30
      ip address 192.168.230.1 255.255.255.0
   3. You should use the show ip interfaces brief and show running-config commands
      on P1R1 and P2R1.
  Multi-Site Frame Relay and Policy Routing


   2. on P1R1 and P2R1:
      config t
      interface FastEthernet0/0.1
      encapsulation dot1q 1
      interface FastEthernet0/0.20
      encapsulation dot1q 20
      interface FastEthernet0/0.30
      encapsulation dot1q 30


   1. The FastEthernet0/1 port on P1SW1 is used to connect to P1R1, and theFastEthernet0/1
      port on P2SW1 is used to connect to P2R1.
   3. P1SW1 and P2SW1:
      config t
      interface FastEthernet0/1
      switchport mode trunk
      switchport trunk encapsulation dot1q
Task 5: Verifying Network Connectivity
   1. Yes. From the console of each PC host in a site, you should be able to ping all other PC
      hosts in the same site.
   2. ping 192.168.110.1, ping 192.168.120.1, ping 192.168.130.1, ping
      192.168.120.2, ping 192.168.130.2, ping 192.168.120.4, ping
      192.168.130.4
   3. ping 192.168.120.2, ping 192.168.130.2, ping 192.168.120.4, ping
      192.168.130.4, ping 192.168.110.2
Task 6




   2. P1R1 and P2R1:
      config t
      interface Serial0
      no shutdown
      encapsulation frame-relay
   3. P1R1:
      conf t
      interface Serial0.1 point-to-point
      ip address 10.100.10.1 255.255.255.0
      frame-relay interface-dlci 102
                                      Multi-Site Frame Relay and Policy Routing

         P2R1:
         conf t
         interface Serial0.1 point-to-point
         ip address 10.100.10.2 255.255.255.0
         frame-relay interface-dlci 201
D. Testing WAN Connectivity
    2. From the console of P1R1, you should use the ping 10.100.10.2 command; the ping
       should succeed.
    3. From the console of P2R1, you should use the ping 10.100.10.1 command; the ping
       should succeed.
    4. From the console of P1PC1, you should use the ping 192.168.230.2 command; the
       ping should fail because P1R1 has no information about the other networks to which
       P2R1 is directly connected.
Task 7

    1. Issuing the show ip route
       routes to their own directly connected networks but they do not have routes to the other
       router’s directly connected networks. Therefore, a ping to a host in the other site fails
       because the router in the site where the ping was issued does not have a route to which
       the ping packets should be forwarded. In order for connectivity to exist between sites,

       router to send updates to, and receive updates from, the router in the other site.
    2. P1R1 and P2R1:
       config t
       router eigrp 100
    3. P1R1:
       config t
       router eigrp 100
       network 10.0.0.0
       network 192.168.110.0
       network 192.168.120.0
       network 192.168.130.0
       P2R1:
       config t
       router eigrp 100
       network 10.0.0.0
       network 192.168.210.0
       network 192.168.220.0
       network 192.168.230.0
  Multi-Site Frame Relay and Policy Routing

B. Verifying Dynamic Routing and Network Connectivity
   1. You should use the show ip route command on both P1R1 and P2R1.
   2. Yes. The ping should succeed.
   3. When a host in one site pings a host in another site, the sending host forwards the packet
      to its default gateway, either P1R1 or P2R1 depending upon which host initiates the ping.

       been updated with the other router’s directly connected networks.




   2. P1R1:
      config t
      int Bri0
      no ip address
      isdn switch-type basic-ni
      isdn spid1 321778201000100
      isdn spid2 321778201100100
      dialer pool-member 1
      encapsulation ppp
      ppp authentication chap
      P2R1:
      config t
      int Bri0
      no ip address
      isdn switch-type basic-ni
      isdn spid1 321778202000100
      isdn spid2 321778202100100
      dialer pool-member 1
      encapsulation ppp
      ppp authentication chap
   3. P1R1 and P2R1:
      config t
      access-list 101 permit ip any any
      dialer-list 1 protocol ip list 101


   5. PIR1:
      username P2R1 password cisco
       interface Dialer1
        ip address 172.16.10.1 255.255.255.0
        encapsulation ppp
                                     Multi-Site Frame Relay and Policy Routing

        dialer pool 1
        dialer remote-name p2r1
        dialer string 7782020
        dialer-group 1
        ppp authentication chap
       P2R1:
       username P1R1 password cisco
      interface Dialer1
       ip address 172.16.10.2 255.255.255.0
       encapsulation ppp
       dialer pool 1
       dialer remote-name p1r1
       dialer string 7782010
       dialer-group 1
       ppp authentication chap
   6. From the console of each router, you should now be able to ping the dialer interface of the
      other router.

       P1R1 and P2R1:
       show isdn status
       show isdn active
B. Routing Considerations for DDR WAN Failover
   1. If the network associated with a BRI or dialer interface is to be successfully advertised




   2. P1R1:
      ip route 192.168.210.0 255.255.255.0 172.16.10.2 200
      ip route 192.168.220.0 255.255.255.0 172.16.10.2 200
      ip route 192.168.230.0 255.255.255.0 172.16.10.2 200
      P2R1:
      ip route 192.168.110.0 255.255.255.0 172.16.10.1 200
      ip route 192.168.120.0 255.255.255.0 172.16.10.1 200
      ip route 192.168.130.0 255.255.255.0 172.16.10.1 200
C. Verifying DDR Operation
   1. ping 192.168.230.2
      tracert 192.168.230.2
   2. Yes. Because the Frame Relay link is up/up and the RIP routes to the networks in each
      site have lower administrative distances than the static routes, the RIP routes are
      inserted into the routing table.
  Multi-Site Frame Relay and Policy Routing

    3. The static routes with an administrative distance of 200 have been inserted into the
       routing table.
    4. Yes. Even though the Frame Relay link has been disabled, connectivity still exists

         caused the removal of the routing table entries learned via the Frame Relay link. When
         these entries were removed, the static routes with an administrative distance of 200



Task 9
A. Establishing Point-to-Point Leased Line Connectivity
    1. The point-to-point leased line terminates on interface Serial1 on both P1R1 and P2R1.
    2. P1R1:
       config t
       interface serial1
       ip address 10.200.20.1 255.255.255.252
       clock rate 64000
       P2R1:
       config t
       interface serial1
       ip address 10.200.20.2 255.255.255.252
    3. P1R1 and P2R1:
       config t
       interface serial1
       encapsulation ppp
       ppp authentication chap

         use with the BRI link between the two sites.
B. Verifying Point-to-Point Leased Line Connectivity

         everything correctly so far.

       link. It follows this link because the IP addresses of the Serial1 interfaces on both ends of
       the link (10.200.20.1 and 10.200.20.2) are advertised as the next hop when Serial0.1 is
       shut down.
    3. Yes, the ping from P1PC1 to P2PC3 should still be successful after Serial1 on P1R1

         Serial0.1 and Serial1 are both shut down, the next hop addresses used in the routing

         static routes on both routers that list the dialer interfaces as the next hop have an
         administrative distance of 200 assigned to them. With Serial1 and Serial0.1 shut down,

         the top where they are then inserted into the routing table.
                                    Multi-Site Frame Relay and Policy Routing

C. Manipulating Path Selection with Route Maps
   2. The 192.168.120.0 /24 IP address is the network address for VLAN 20 in Pod 1.
   3. The 192.168.220.0 /24 IP address is the network address for VLAN 20 in Pod 2.
   4. access-list 10 permit 192.168.120.0 0.0.0.255
   5. access-list 10 permit 192.168.220.0 0.0.0.255
   6. P1R1:
      route-map VLAN20 permit 10
      match ip address 10
      set ip next-hop 10.100.10.2
      P2R1:
      route-map VLAN20 permit 10
      match ip address 10
      set ip next-hop 10.100.10.1
   7. P1R1 and P2R1:
      interface FastEthernet0/0.20
      ip policy route-map VLAN20
D. Verifying Policy Routing and Route Maps
   1. Yes, the ping from P1PC2 to P2PC2 should be successful. The ping from P1PC1 to P2PC1
      should also be successful.


       is routed based on the routes in the routing table.

       access list 10, which triggers the route map. The route map sets the next hop IP address
             Multi-Site Frame Relay and Policy Routing


                         P1R1                                   P1R1 (Continued)
version 12.1                                    no ip directed-broadcast
service timestamps debug uptime                 isdn switch-type basic-ni
service timestamps log uptime                   isdn spid1 321778201000100
no service password-encryption                  isdn spid2 321778201100100
!                                               dialer pool-member 1
hostname P1R1                                   encapsulation ppp
!                                               ppp authentication chap
username P2R1 password cisco                    !
!                                               interface Dialer1
ip subnet-zero                                    ip address 172.16.10.1 255.255.255.0
!                                                 encapsulation ppp
interface Serial0                                 dialer pool 1
no ip address                                     dialer remote-name p2r1
encapsulation frame-relay                         dialer string 7782020
!                                                 dialer-group 1
interface Serial0.1 point-to-point                ppp authentication chap
  ip address 10.100.10.1 255.255.255.0          !
  frame-relay interface-dlci 102                router eigrp 100
no frame-relay inverse-arp                        network 10.0.0.0
!                                                 network 192.168.110.0
interface Serial1                                 network 192.168.120.0
  ip address 10.200.20.1 255.255.255.252          network 192.168.130.0
  no ip directed-broadcast                      !
  clock rate 64000                              ip classless
  encapsulation ppp                             no ip http server
  ppp authentication chap                       !
!                                               route-map VLAN20 permit 10
interface FastEthernet0/0                         match ip address 10
  no ip address                                   set ip next-hop 10.100.10.2
  no ip directed-broadcast                      !
!                                               ip route 192.168.210.0 255.255.255.0 172.16.10.2 200
interface FastEthernet0/0.1                     ip route 192.168.220.0 255.255.255.0 172.16.10.2 200
  encapsulation dot1q 1                         ip route 192.168.230.0 255.255.255.0 172.16.10.2 200
  ip address 192.168.110.1 255.255.255.0        access-list 10 permit 192.168.120.0 0.0.0.255
!                                               access-list 101 permit ip any any
interface FastEthernet0/0.20                    !
  encapsulation dot1q 20                        dialer-list 1 protocol ip list 101
  ip address 192.168.120.1 255.255.255.0        !
  ip policy route-map vlan20                    isdn switch-type basic-ni
!                                               line con 0
interface FastEthernet0/0.30                      transport input none
  encapsulation dot1q 30                        line aux 0
  ip address 192.168.130.1 255.255.255.0        line vty 0 4
!                                               !
interface Bri0                                  no scheduler allocate
no ip address                                   end
                                         Multi-Site Frame Relay and Policy Routing

                          P1SW1                                  P1SW1 (Continued)
version 12.1                                     interface FastEthernet0/6
service timestamps debug uptime                  !
service timestamps log uptime                    interface FastEthernet0/7
no service password-encryption                   !
!                                                interface FastEthernet0/8
hostname P1SW1                                   !
!                                                interface FastEthernet0/9
ip subnet-zero                                   !
spanning-tree extend system-id                   interface FastEthernet0/10
!                                                !
interface FastEthernet0/1                        interface FastEthernet0/11
  switchport trunk encapsulation dot1q           !
  switchport mode trunk                          interface FastEthernet0/12
  speed 100                                      !
  duplex full                                    vtp Server
!                                                vtp domain bigdomain
interface FastEthernet0/2                        !
  switchport access vlan 20                      interface Vlan 1
  speed 100                                        ip address 192.168.110.2 255.255.255.0
  duplex half                                      no ip route-cache
!                                                !
interface FastEthernet0/3                        vlan 20 name VLAN0020
  switchport access vlan 30                      vlan 30 name VLAN0030
  speed 100                                      !
  duplex half                                    ip classless
!                                                no ip http server
interface FastEthernet0/4                        !
  switchport access vlan 20                      line con 0
  speed 100                                        transport input none
  duplex half                                    line aux 0
!                                                line vty 0 15
interface FastEthernet0/5                        !
  switchport access vlan 30                      no scheduler allocate
  speed 100                                      end
  duplex half
!
             Multi-Site Frame Relay and Policy Routing

                         P2R1                                   P2R1 (Continued)
version 12.1                                    no ip directed-broadcast
service timestamps debug uptime                 isdn switch-type basic-ni
service timestamps log uptime                   isdn spid1 32177820200100
no service password-encryption                  isdn spid2 32177820210100
!                                               dialer pool-member 1
hostname P2R1                                   encapsulation ppp
!                                               ppp authentication chap
username P1R1 password cisco                    !
!                                               interface Dialer1
ip subnet-zero                                    ip address 172.16.10.2 255.255.255.0
!                                                 encapsulation ppp
interface Serial0                                 dialer pool 1
no ip-address                                     dialer remote-name p1r1
encapsulation frame-relay                         dialer string 7782010
!                                                 dialer-group 1
interface Serial0.1 point-to-point                ppp authentication chap
  ip address 10.100.10.2 255.255.255.0          !
  frame-relay interface-dlci 201                router eigrp 100
no frame-relay inverse-arp                        network 10.0.0.0
!                                                 network 192.168.210.0
interface Serial1                                 network 192.168.220.0
  ip address 10.200.20.2 255.255.255.252          network 192.168.230.0
  no ip directed-broadcast                      !
  encapsulation ppp                             ip classless
  ppp authentication chap                       no ip http server
!                                               !
interface FastEthernet0/0                       route-map VLAN20 permit 10
  no ip address                                   match ip address 10
  no ip directed-broadcast                        set ip next-hop 10.100.10.1
!                                               !
interface FastEthernet0/0.1                     ip route 192.168.110.0 255.255.255.0 172.16.10.1 200
  encapsulation dot1q 1                         ip route 192.168.120.0 255.255.255.0 172.16.10.1 200
  ip address 192.168.210.1 255.255.255.0        ip route 192.168.130.0 255.255.255.0 172.16.10.1 200
!                                               access-list 10 permit 192.168.220.0 0.0.0.255
interface FastEthernet0/0.20                    access-list 101 permit ip any any
  encapsulation dot1q 20                        !
  ip address 192.168.220.1 255.255.255.0        dialer-list 1 protocol ip list 101
  ip policy route-map vlan20                    !
!                                               isdn switch-type basic-ni
interface FastEthernet0/0.30                    line con 0
  encapsulation dot1q 30                          transport input none
  ip address 192.168.230.1 255.255.255.0        line aux 0
!                                               line vty 0 4
interface Bri0                                  !
  no ip address                                 no scheduler allocate
                                                end
                                         Multi-Site Frame Relay and Policy Routing

                          P2SW1                                  P2SW1 (Continued)
version 12.1                                     interface FastEthernet0/6
service timestamps debug uptime                  !
service timestamps log uptime                    interface FastEthernet0/7
no service password-encryption                   !
!                                                interface FastEthernet0/8
hostname P2SW1                                   !
!                                                interface FastEthernet0/9
ip subnet-zero                                   !
spanning-tree extend system-id                   interface FastEthernet0/10
!                                                !
interface FastEthernet0/1                        interface FastEthernet0/11
  switchport mode trunk                          !
  switchport trunk encapsulation dot1q           interface FastEthernet0/12
  speed 100                                      !
  duplex full                                    vtp Server
!                                                vtp domain bigdomain
interface FastEthernet0/2                        !
  switchport access vlan 20                      interface Vlan 1
  speed 100                                        ip address 192.168.210.2 255.255.255.0
  duplex half                                      no ip route-cache
!                                                !
interface FastEthernet0/3                        vlan 20 name VLAN0020
  switchport access vlan 30                      vlan 30 name VLAN0030
  speed 100                                      !
  duplex half                                    ip classless
!                                                no ip http server
interface FastEthernet0/4                        !
  switchport access vlan 20                      line con 0
  speed 100                                        transport input none
  duplex half                                    line aux 0
!                                                line vty 0 15
interface FastEthernet0/5                        !
  switchport access vlan 30                      no scheduler allocate
  speed 100                                      end
  duplex half
!

				
DOCUMENT INFO
Shared By:
Stats:
views:19
posted:9/26/2011
language:English
pages:23
Description: Advanced-MultiSiteFrameAndPolicyMap