Docstoc

CCNP BCMSN Layer 3 Switching

Document Sample
CCNP BCMSN Layer 3 Switching Powered By Docstoc
					                                                                                   BCMSN LAB 7
                                                                                Layer 3 Switching

          Lab 7: Layer 3 Switching
          Objective
          Configure DSW switches for routing, and re-address the network for routing.

          Lab Topology
          For this lab, your network design will include two pods of devices. You will be responsible for
          configuring the devices in both pods. The devices on the left side of the topology are in Pod 1.
          The devices on the right side of the topology are in Pod 2. P1PC1 and P2PC2 are PC workstations.
          P1ASW1 and P2ASW2 are access-layer switches. P1DSW1 and P2DSW2 are distribution-layer
          switches. The access and distribution layers are two of the three layers in the Cisco three-layer
          hierarchical network model, which also includes the core layer.
          The Topology diagram below represents the NetMap in the Simulator. To access each of the devices
          from within the Simulator, select the device name from the appropriate menu in the Simulator.
          For example, to access P1ASW1, click the eSwitches button and select P1ASW1 from the drop-
          down menu.


                               VLAN 11                                             VLAN 12
                              172.16.11.1                                         172.16.12.2

        Note:                     P1PC1                    Note:                       P2PC2
     ASW has a                                          ASW has a
        VLAN                                               VLAN
    interface for                                      interface for
   each VLAN; IP                                      each VLAN; IP
     address is                                         address is
  172.16.x.10 /16,                                   172.16.x.20 /16,
     where x is                                         where x is
     the VLAN                                           the VLAN
      number
                      P1ASW1                             number
                                                                         P2ASW2
                      172.16.1.10                                            172.16.1.20




      Note:                                                                                                  Note:
   DSW has a                                                                                              DSW has a
      VLAN                                                                                                   VLAN
  interface for                                                                                          interface for
 each VLAN; IP                                                                                          each VLAN; IP
   address is                                                                                             address is
172.16.x.100 /16,
   where x is         P1DSW1                                             P2DSW2                        172.16.x.200 /16,
                                                                                                          where x is
   the VLAN                                                                                               the VLAN
    number            172.16.1.100                                      172.16.1.200                       number
         BCMSN LAB 7
           Layer 3 Switching

Command Summary
            Command                                                   Description
configure terminal                     enters global configuration mode
enable                                enters privileged EXEC mode
exit                                  exits from current mode
end                                   returns to privileged EXEC mode
interface fastethernet slot/port      enters interface configuration mode for the specified Fast Ethernet interface
interface vlan interface number       enters interface configuration mode for the specified virtual interface
ip address ip_address subnet_mask     assigns an IP address to an interface
ping ip_address                       sends an ICMP echo request
show ip                               displays IP configuration
shutdown; no shutdown                 disables an interface; enables an interface
ip routing                            enables Layer 3 processing
router routing_protocol               enables a routing protocol and defines which networks to route for
network network_address
no switchport                         disables Layer 2 on a port
show ip interface                     displays IP information for an interface
show protocols                        displays Layer 3 protocols enabled for a device
show ip protocols                     displays routing protocols enabled for a device
show ip route                         displays the IP routing table


         Lab Tasks
         PC IP Configuration
                PC       VLAN   IP ADDRESS       DEFAULT GATEWAY
                P1PC1 11        172.16.11.1/24   172.16.11.100
                P2PC2 12        172.16.12.1/24   172.16.12.200
         ASW IP Configuration
                ASW      VLAN   IP ADDRESS       DEFAULT GATEWAY
                P1ASW1 1        172.16.1.10/24   172.16.1.100
                P2ASW2 1        172.16.1.20/24   172.16.1.200
         DSW IP Configuration
                P1DSW1 INTERFACE        VLAN               IP ADDRESS
                VLAN1                   1                  172.16.1.100/24
                VLAN11                  11                 172.16.11.100/24
                VLAN1                   1                  172.16.1.200/24
                VLAN12                  12                 172.16.12.200/24
                                                                       BCMSN LAB 7
                                                                    Layer 3 Switching

   1. On each PC, reconfigure the IP address as shown in the table above.
   2. On each PC, configure the default gateway as shown in the table above.
   3. On each ASW, configure the VLAN 1 interface with the appropriate IP address, and enable
       the interface. Remove all VLAN interfaces except for VLAN 1.
   4. On each ASW, configure the appropriate default gateway.
   5. On each DSW, configure the VLAN interfaces with the appropriate IP addresses, and
       enable the interfaces.
   6. Verify that each PC can successfully ping its default gateway.
   7. Attempt to ping the VLAN 1 interface on the ASWs from the PCs. Were the pings
       successful? Why or why not?
       _____________________________________________________________
   8. On each DSW, enable IP routing.
   9. On each DSW, use the show protocols command to verify that IP routing is enabled.
   10. From P1PC1, attempt to ping the VLAN 1 interface. The ping should now be successful.
   11. On the DSWs, display the routing table to verify that all of the VLAN routes are present.
   12. From P1PC1, attempt to ping P1PC2. Was the ping successful? Why or why not?
       ______________________________________________________________
   13. On each DSW, enable EIGRP. Use autonomous system number 100.
   14. Display the routing tables on the DSWs to verify that the DSWs have learned the unknown
       networks.
   15. From P1PC1, attempt to ping P2PC2. The ping should succeed. If it does not, try using
       the clear arp command to clear P1PC1’s ARP cache.

Lab Solutions
   1. ipconfig /ip 172.16.11.1 255.255.255.0
   2. ipconfig /dg 172.16.11.100
   3. interface vlan 1
      ip address 172.16.1.10 255.255.255.0
      no shut
      no interface vlan 11 (repeat for all VLAN interfaces except VLAN 1)
   4. ip default-gateway 172.16.1.100
   5. P1DSW1(config)#interface Vlan11
      P1DSW1(config-if)#ip address 172.16.11.100 255.255.255.0
      P1DSW1(config-if)#no shutdown
       P2DSW2(config)#interface Vlan12
       P2DSW2(config-if)#ip address 172.16.12.200 255.255.255.0
       P2DSW2(config-if)#no shutdown
BCMSN LAB 7
 Layer 3 Switching

   6. C:> 172.16.11.100
       Type escape sequence to abort.
       Sending 5, 100-byte ICMP Echos to 172.16.11.100, timeout is 2 seconds:
       !!!!!
       Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
   7. The pings fail because routing is not configured on the DSWs.
   8. ip routing
   9. P1DSW1#show protocols
      Global values:
      Internet Protocol routing is enabled
   10. C:>ping 172.16.1.10
       Type escape sequence to abort.
       Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
       !!!!!
       Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms
   11. P1DSW1#show ip route
       Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
       Gateway of last resort is not set
           172.16.0.0/24 is subnetted, 5 subnets
       C     172.16.11.0 is directly connected, Vlan11
       C     172.16.1.0 is directly connected, Vlan1
       P2DSW2#show ip route
       Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
       Gateway of last resort is not set
           172.16.0.0/24 is subnetted, 5 subnets
       C     172.16.12.0 is directly connected, Vlan12
       C     172.16.1.0 is directly connected, Vlan1
                                                                    BCMSN LAB 7
                                                                 Layer 3 Switching

12. The ping fails because the default gateway does not know a route to the destination
    network.
13. router eigrp 100
    network 172.16.0.0
14. P1DSW1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
        * - candidate default, U - per-user static route, o - ODR
        P - periodic downloaded static route
    Gateway of last resort is not set
        172.16.0.0/24 is subnetted, 3 subnets
    D     172.16.12.0 [90/3072] via 172.16.1.200, 00:02:03, Vlan1
    C     172.16.11.0 is directly connected, Vlan11
    C     172.16.1.0 is directly connected, Vlan1
15. C:>ping 172.16.12.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms
           BCMSN LAB 7
              Layer 3 Switching

Sample Configuration Scripts
                           P1PC1                         P1PC1 (Continued)
version 12.1                             ip classless
service timestamps debug uptime          no ip http server
service timestamps log uptime            !
no service password-encryption           ip route 0.0.0.0 0.0.0.0 172.16.11.100
!                                        !
hostname C:                              line con 0
!                                          transport input none
ip subnet-zero                           line aux 0
!                                        line vty 0 4
interface Ethernet0                      !
  ip address 172.16.11.1 255.255.255.0   no scheduler allocate
  no ip directed-broadcast               end
  bandwidth 10000                        exit
!



                          P1ASW1                        P1ASW1 (Continued)
version 12.1                             !
service timestamps debug uptime          interface FastEthernet0/6
service timestamps log uptime            !
no service password-encryption           interface FastEthernet0/7
!                                        !
hostname P1ASW1                          interface FastEthernet0/8
!                                        !
ip subnet-zero                           interface FastEthernet0/9
spanning-tree extend system-id           !
!                                        interface FastEthernet0/10
ip default-gateway 172.16.1.100          !
!                                        interface FastEthernet0/11
interface FastEthernet0/1                !
  description P1ASW1 to P1DSW1           interface FastEthernet0/12
  switchport mode trunk                  !
  switchport trunk encapsulation dot1q     vtp Server
!                                          vtp domain bigdomain
interface FastEthernet0/2                !
  description P1ASW1 to P1DSW1           interface Vlan 1
  switchport mode trunk                    ip address 172.16.1.10 255.255.255.0
  switchport trunk encapsulation dot1q     no ip route-cache
!                                          no shutdown
interface FastEthernet0/3                !
  description P1ASW1 to P2DSW2           vlan 11 name 11
  switchport mode trunk                  !
  switchport trunk encapsulation dot1q   ip default-gateway 172.16.1.100
!                                        ip classless
interface FastEthernet0/4                no ip http server
  description P1ASW1 to P2DSW2           !
  switchport mode trunk                  line con 0
  switchport trunk encapsulation dot1q     transport input none
!                                        line aux 0
interface FastEthernet0/5                line vty 0 15
  description P1PC1 to P1ASW1            !
  switchport mode access                 no scheduler allocate
  switchport access vlan 11              end
                                                            BCMSN LAB 7
                                                          Layer 3 Switching

Sample Configuration Scripts
                         P1DSW1                        P1DSW1 (Continued)
version 12.1                            interface FastEthernet0/10
service timestamps debug uptime         !
service timestamps log uptime           interface FastEthernet0/11
no service password-encryption            description P1DSW1 to P2DSW2
!                                         switchport mode trunk
hostname P1DSW1                           switchport trunk encapsulation dot1q
!                                       !
ip subnet-zero                          interface FastEthernet0/12
ip routing                                description P1DSW1 to P2DSW2
spanning-tree extend system-id            switchport mode trunk
!                                         switchport trunk encapsulation dot1q
interface FastEthernet0/1               !
 description P1DSW1 to P1ASW1           interface GigabitEthernet0/1
 switchport mode trunk                  !
 switchport trunk encapsulation dot1q   interface GigabitEthernet0/2
!                                       !
interface FastEthernet0/2                 vtp Server
 description P1DSW1 to P1ASW1             vtp domain bigdomain
 switchport mode trunk                  !
 switchport trunk encapsulation dot1q   interface Vlan 1
!                                         ip address 172.16.1.100 255.255.255.0
interface FastEthernet0/3                 no ip route-cache
 description P1DSW1 to P2ASW2             no shutdown
 switchport mode trunk                  !
 switchport trunk encapsulation dot1q   interface Vlan0011
!                                         ip address 172.16.11.100 255.255.255.0
interface FastEthernet0/4                 no ip route-cache
 description P1DSW1 to P2ASW2             no shutdown
 switchport mode trunk                  !
 switchport trunk encapsulation dot1q   router eigrp 100
!                                         network 172.16.0.0
interface FastEthernet0/5               !
 switchport mode access                 ip classless
!                                       no ip http server
interface FastEthernet0/6               !
!                                       line con 0
interface FastEthernet0/7                 transport input none
!                                       line aux 0
interface FastEthernet0/8               line vty 0 4
!                                       !
interface FastEthernet0/9               no scheduler allocate
!                                       end

				
DOCUMENT INFO
Shared By:
Stats:
views:21
posted:9/26/2011
language:English
pages:7
Description: CCNP BCMSN Layer 3 Switching