Web Design Quotes Template - DOC

Document Sample
Web Design Quotes Template - DOC Powered By Docstoc
					           Using the WebCase Word Template to
           prepare and upload a Case Study to a
                        web site1
    1.          Summary ..................................................................................................................... 2
    2.          Introduction.................................................................................................................. 2
         Installing the WebCase Word Template ............................................................................. 3
         Requesting a WebCase CourseID for your Case Study .................................................... 3
    3.          Preparing the Case Study document in Word............................................................. 4
         Headings within the Text .................................................................................................... 4
         Text..................................................................................................................................... 4
         Additional notes .................................................................................................................. 5
         Inserting Images in the Text ............................................................................................... 5
         Link to Word or Excel documents ...................................................................................... 6
         Link to other file types ........................................................................................................ 6
         Check that the headings styles are consistent ................................................................... 6
    4.          Uploading your Word Case Study document and Supporting Files to a web site ...... 7
         Introduction ......................................................................................................................... 7
         Step 1: Upload the Title Page for your case study ............................................................. 8
         Step 2: Upload your case study Word HTML file ............................................................... 9
         Step 3: Uploading the Images and additional Supporting Files ......................................... 9
         Step 4: Preparing and Uploading a Glossary ................................................................... 10
         Viewing your Uploaded Case Study ................................................................................. 11
    5.          Editing and Updating your Case Study ..................................................................... 11
    6.          Creating an Image Map ............................................................................................. 12
    7.          Annexes .................................................................................................................... 14
         Annex 1 Change curly quotes to straight quotes and vice versa ..................................... 14



1
 Finlayson I and Heath S B (2004). Using the WebCase Word Template to prepare and
upload a Case Study to a web site. University of Newcastle, Newcastle upon Tyne, UK,
pp 12.
      1.    Summary
            This Manual will assist you in uploading your case study to the Web using the WebCase
            Word Template. There are three parts to this process:
                1. Designing your case study
                2. Embedding the case study in the WebCase Word Template and saving it as a HTML
                   file, and selecting additional files to be uploaded
                3. Uploading your Case Study to the Web, and editing and updating
            Guidance in designing your case study (part 1) is given in the WebCase Handbook Design,
            Development and Delivery of Web-based Case Study Resources, eds Cain P and Heath
            S (2004), University of Newcastle, UK which is downloadable from www.webcase-online.info
            Parts 2 and 3 are outlined in detail in this Manual.

      2.    Introduction
            You can use the WebCase Word Template to prepare your Case Study document in a
            suitable format for uploading to a web site. You can then upload your Case Study to the Web
                                                                                                    2
            so long as your Web server has been prepared by the installation of the WebCase Scripts .


            Figure 1 Overview of a WebCase Case Study web site, showing the main menu across
            the top of the screen, the two levels of sub-menu to the left of the screen and the main
             window containing the text under a particular menu combination (in this case <Case
                                        Description> and <Introduction>)




 st
1 Menu
Heading 1



 nd
2 Menu
Heading 2



 rd
3 Menu
Heading 3




            2
             The WebCase Scripts and Instructions for installing the Scripts can be downloaded from the
            WebCase web site www.webcase-online.info following the link to "Upload your own case"


            8938629e-0d79-4f6b-b025-31715b97ec5f.doc     2                                    21/09/2011
                                            st
A Case Study is displayed on the Web with 1 level menus across the top of the screen, and
 nd      rd
2 and 3 level menus on the left hand side of the screen, see figure 1 above. The main
text, images, downloadable files and URL links to external documents are displayed in the
main (white) window of the screen. See www.webcase-online.info for demonstration case
studies (note the WebCase Template does not upload the initial title page image shown for
these case studies, however you can upload a Title Page for your case study, see Section 4).
You can also mark a plan or map with arrowhead icons which can be clicked on to display
images (see Section 6). You can also upload a Glossary in several different languages (see
Section 4).

Installing the WebCase Word Template
To use the Template you will need to download the Template File (WebCase.dot) from the
WebCase website, www.webcase-online.info on the page Upload your own Case. Save it to
your Microsoft Office Templates folder. A typical location on Windows 2000 would be:
     C:\Documents and Settings\[user name]\Application Data\Microsoft\Templates
You can find the location in Word by selecting Options on the Tools menu and then the File
Locations tab.

Requesting a WebCase CourseID for your Case Study
Contact <your Web server manger> to ask for a new Case Study site to be set up for you.
Your Web server manager will give you a Case Study Course ID and Password which you will
need to use in order to access the WebCase Case Study web upload site on your server.




8938629e-0d79-4f6b-b025-31715b97ec5f.doc         3                                 21/09/2011
3.   Preparing the Case Study document in Word
     Only Word 2000 or more recent versions can be used.
     Open <WebCase.dot> from your Word templates folder and save it with the name of your
     Case Study <my-case-study.doc> in an appropriate folder on your computer.

     Headings within the Text
     When the document is uploaded to the web site the headings
     (with the appropriate style) are used by the WebCase Scripts on
     your server to create the menus in the Case Study web site.
     Thus, it is crucially important that the headings are entered
     with the correct style.
            st
     The 1 level menu headings, which appear across the top of the
     home page of the Case Study (see figure 1), are already in the
     Template. They use the style Heading 1 (the heading styles can
     be selected using the drop down style list on the word formatting toolbar). No other text in the
     document can use the Heading 1 style otherwise it will appear as a menu item on the home
     page.
     You can change the titles under Heading 1 style in the Template to suit your own particular
     requirements. For more information about the design of Web based Case Studies, in
     particular the structuring of your case study under these main menu headings, see WebCase
     Handbook Design, Development and Delivery of Web-based Case Study Resources, ed
     Cain P and Heath S (2004), University of Newcastle, UK which is downloadable from
     www.webcase-online.info .
     Under each Heading 1 title a number of titles can be created using the Heading 2 style.
     These will appear in the menu on the left in WebCase web site. Note that any text between
     the Heading 1 and Heading 2 will not be shown.
     The text under a Heading 2 can be further broken down by using the Heading 3 style. The
     Heading 3 titles will appear indented on the menu. Again note that any text between the
     Heading 2 and Heading 3 will not be shown. However, if you do not use the Heading 3 level
     then the text you entered under Heading 2 will be displayed.
     Any number of hierarchical combinations of Heading 2 and Heading 3 titles can be created so
     long as the above rules are observed. See figure 1 for the presentation of headings under the
     styles Heading 1, Heading 2 and Heading 3 in a case study displayed on the web.
     Heading 4 can be used to further subdivide the document within the main text but will not be
     used in the menus.

     Text
     The Normal style should be used for most of the text in the Case Study Word document.
     Adding links to external web pages
     Links to external web documents can be inserted using hyperlinked text. Go to Insert in the
     Word drop down menu and select Hyperlink. A dialog box will appear in which you can enter
     the text to be given a URL link and a box where you can enter the URL. Select OK and the
     hyperlinked text will appear in your Case Study Word document. Alternatively, you can just
     enter the URL in the text.
     Adding bullets and numbered lists
     Numbered lists and bullet lists can be added to the document – click the buttons on the Word
     toolbar, figure 2.




     8938629e-0d79-4f6b-b025-31715b97ec5f.doc       4                                       21/09/2011
                   Figure 2 Buttons for inserting bullets and numbered lists




Additional notes
Handling apostrophes in Word
When a curly „apostrophe‟ is uploaded to the web it is represented by „?‟. This can be got
round by following the instructions in Annex 1.

Inserting Images in the Text
If images are to be used in the Case Study they should not be included in the document but
the name of the file should be added after “Insert=” on a line by itself e.g.
Insert=honey.gif
   Figure 3 The developing Case Study Word Template with two levels of headings,
                   Normal style text, and a line to insert an image




The images do not appear in the document at this stage. You can only use image types
which can be displayed in a web browser (GIF, JPG and PNG). Spaces cannot be used in
the filename. The word "Insert" is case sensitive, as is the filename and extension. The
images should not be wider than 700 pixels (at a screen resolution of 1024x768). The size of
your images can be re-sized in appropriate software, e.g Photoshop or Paint Shop Pro.




8938629e-0d79-4f6b-b025-31715b97ec5f.doc      5                                      21/09/2011
Link to Word or Excel documents
To create a link to a Word document or an Excel spreadsheet the same method as for images
should be used e.g.
Insert=data.xls   (No spaces in the filename)

Link to other file types
Other file types can be used, but the student viewing the Case Study will need any software
required to view the file. If, for example, a PowerPoint file was included, someone without
PowerPoint installed would not be able to view the file.
Insert=presentation.ppt     (No spaces in the filename)

Check that the headings styles are consistent
When text is pasted from another document there is a danger that different styles will be
transferred across to the new document. It is best to save the text in the original document as
a text document <filename.txt> and paste the text from this file into your Word Case Study
file, as a text document, <filename.txt> will not have any formatting which might conflict with
the styles set by the WebCase Template.
It may be useful to display the style names in the left margin, see figure 4. If they are not
being shown this can be achieved as follows:
Switch to the normal view if using a different view and increase the style area width.
    1. Click Normal on the View menu.
    2. Click Options on the Tools menu.
    3. On the View tab set the Style area width to e.g. 2cm.
    4. Click OK and the styles will be shown on the left.
Any text which is in the wrong style can be selected with the mouse and changed using the
style drop down box on the toolbar.


   Figure 4 The Word WebCase Template showing the style names in the left margin




8938629e-0d79-4f6b-b025-31715b97ec5f.doc        6                                        21/09/2011
4.   Uploading your Word Case Study document and
     Supporting Files to a web site
     Introduction
     Before the Case Study can be uploaded it must be saved in HTML format. To do this in Word
     select Save as Web Page on the File menu, the file will then have the name
     <my-case-study.htm>
     Then go to the following URL:
     http://<this part of the URL will be given to you by your web server manager>/webcase/
     Select Upload to Standalone site, and enter the CourseID and Password (the CourseID
     and password are case sensitive.)
     The following screen, figure 5, will now appear. There are four options to the upload process:
         1. Upload a Title Page for your Case Study comprising Title, Summary and three
            images
         2. Upload your Word Case Study html document <my-case-study.html> by clicking on
            the Main Document button
         3. Upload the additional Supporting Files identified in the text of your Word Case Study
            document by the line
            insert=<filename.ext>
         4. Upload a Glossary


                           Figure 5 Title Page of the Case Study Upload site




     8938629e-0d79-4f6b-b025-31715b97ec5f.doc      7                                      21/09/2011
Step 1: Upload the Title Page for your case study
Click on the Title Page button and the screen in figure 6 will be displayed. You can then
directly enter the Title for your case study and the Summary, then click save Summary. The
Tiltle and Summary will be displayed. Click on Back to the Menu button.
If you would like to display up to three photos indicating the context of your case study, return
to the Title Page and upload three images. The size of the images will be automatically
adjusted to fit the pre-defined positions on the Title Page.


   Figure 6 Screen shot of the page on which to upload the Title, Summary and three
                     images for the Title Page of your case study




8938629e-0d79-4f6b-b025-31715b97ec5f.doc        8                                       21/09/2011
Step 2: Upload your case study Word HTML file
Return to the upload Title Page and select the Main Document button first to upload the
HTML version of your Word Case Study document, the screen as displayed in figure 7 will
appear.
Use the Browse button to find the my <case study.HTM> file you created with Word.
Then Click Upload File and wait until the page, displaying a list of the images and other files
to be uploaded is displayed – Figure 8.


                     Figure 7 Uploading the Case Study Word template




Step 3: Uploading the Images and additional Supporting Files
The image files and additional supporting files can now be uploaded in turn by clicking on the
Upload button and following the instructions. When a file has been uploaded the cross under
status will change to a tick. The Upload button will also change to show that uploading the
same file again will replace it - (useful if the wrong file has been uploaded).




8938629e-0d79-4f6b-b025-31715b97ec5f.doc       9                                       21/09/2011
 Figure 8 List of files needed for the Case Study, the first two have been uploaded and
                             the rest have still to be uploaded




Step 4: Preparing and Uploading a Glossary
The glossary must be a plain text file, e.g. <glossary.txt>.
The required format is to have a colon (:) followed by the English word on one line. The
following line (can be more than one line) contains the definition in the language to be
uploaded. One blank line should follow the definition. A separate file is created and displayed
for each language to be included, consequently the list of English words does not have to be
the same for each language.


             :Break Crop
             A crop grown in an arable rotation to break a
             cycle of crop pests, diseases or weeds, and
             sometimes, rebuild fertility levels.


             :Less Favoured Area (LFA)
             A designation applied to areas of land which,
             because of their high altitude, poor soil type
             and difficult climate, have low levels of
             agricultural productivity and are subject to
             additional levels of subsidisation.


             :Milking Parlour
             A building dedicated to the operation of milking
             dairy cows or other animals, containing milking
             equipment but not used for housing these animals.




8938629e-0d79-4f6b-b025-31715b97ec5f.doc        10                                    21/09/2011
     Figure 9 shows the procedure for uploading the glossary file. First select the Glossary
     Language to be uploaded. Then use the browse button to locate the Glossary file you created
     and click the Upload button. A page will then be displayed showing the Glossary words that
     have been uploaded.


                                Figure 9 Web page to upload a Glossary




     Viewing your Uploaded Case Study
     At each step in the process of uploading your case study you can view the case study by
     clicking on the View the Case Study button on the upload Title Page.
     When all the files have been uploaded you can view your Case Study at the web site
     http://<this part of the URL specific to your site>/webcase/data/<your courseID>



5.   Editing and Updating your Case Study
     All editorial changes to your Case Study should be done in the Word Case Study file
     <my-case-study.doc>. Having made your revisions you should then follow exactly the same
     procedure as you followed for uploading your Case Study the first time.
     You will not need to upload the images and additional files again unless you want to change
     them. For each image that has already been uploaded there is a button allowing you to
     Replace that image. New additional supporting files will need to be uploaded.




     8938629e-0d79-4f6b-b025-31715b97ec5f.doc     11                                      21/09/2011
6.   Creating an Image Map
     It may be useful to be able to show the location of where photographs were taken on a plan,
     e.g. on a farm building layout, on a map or on some other image. This can be achieved by
     placing arrowhead icons on a map and linking the arrowhead icon to a photograph. When the
     learner clicks on an arrowhead icon the photograph is displayed.
     A tool is available to add icons to an image to show this information. Note that this tool will not
     work with old browsers such as versions of Netscape before version 6 or versions of Internet
     Explorer earlier than 5. This also applies to the browser used to view the case study with an
     image map.


       Figure 10 Plan with location and direction of the camera when the photograph was
                          taken indicated by the black arrowhead icon




     To create the image map first click Supporting File button on the upload Title Page (see figure
     5) to show the list of files and click the Image Map button next to the image of the farm plan or
     map. If this image is used on more than one page select the one you wish to use and press
     continue.
     The approximate direction that the camera was pointing when the photograph was taken is
     <selected> on the panel at the left hand side of the screen and then the image is clicked to
     add it at the correct location (see figure 11). A black arrow then appears at that location on
     the image.
     Clicking on the arrow will bring up the form shown below (figure 9) to allow the photograph to
     be uploaded. The photographs should ideally be 800 pixels in width by 500 in height as this is
     the size of the box used to display them.




     8938629e-0d79-4f6b-b025-31715b97ec5f.doc        12                                       21/09/2011
   Figure 11 Form to allow selection of the image to be linked to the arrowhead icon




Select the relevant photograph, which will then appear on the screen. Above the image on
screen it will indicate “the point has been linked to this image”. Scroll down to the bottom of
the image and click on the link “back to the Map”. After a photo has been uploaded
successfully the black arrow on the image map will change to a red arrow. Clicking on the
arrow will display the photograph.
If an arrow has been added in error or in the wrong place click Delete Point below the
arrowhead icons in the left margin, followed by the arrow in question.


Contact for further information about uploading a Case Study:
Dr Simon B Heath email clues@abdn.ac.uk
__________________________________________________________________________
The WebCase Project has been carried with the support of the European Community in the
framework of the SOCRATES programme MINERVA project. Further information about the
WebCase Project can be found at http://www.webcase-online.info/. The content of this
project does not necessarily reflect the position of the European Community, nor does it
involve any responsibility on the part of the European Community
For further information about the WebCase project contact:
Dr Philip J Cain
School of Agriculture, Food and Rural Development, King George VI Building, University of
Newcastle, Newcastle upon Tyne, NE1 7RU, UK
Tel.: +44 191 222 6921,      email : p.j.cain@ncl.ac.uk




8938629e-0d79-4f6b-b025-31715b97ec5f.doc       13                                       21/09/2011
7.   Annexes
     Annex 1 Change curly quotes to straight quotes and vice versa
     Microsoft Word automatically changes straight quotation marks ( ' or " ) to curly (smart or

     typographer's) quotes (           or       ) as you type.

     To turn this feature on or off:

         1. On the Tools menu, click AutoCorrect Options, and then click the AutoFormat As
            You Type tab.

         2. Under Replace as you type, select or clear the "Straight quotes" with "smart
            quotes" check box.

     Note You can find and replace all instances of single or double curly quotes with straight
     quotes in your document. To do this, clear the "Straight quotes" with "smart quotes" check
     box on the AutoFormat As You Type tab (as in 1 above). On the Edit menu, click Replace.
     In both the Find what and Replace with boxes, type ' or ", and then click Find Next or
     Replace All.




     8938629e-0d79-4f6b-b025-31715b97ec5f.doc           14                                  21/09/2011

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:28
posted:9/21/2011
language:English
pages:14
Description: Web Design Quotes Template document sample