Docstoc

CLASS OVERVIEWS

Document Sample
CLASS OVERVIEWS Powered By Docstoc
					CLASS OVERVIEWS

Monday, Oct 27, 2008
We began the night by going over the syllabus, which can be found at:
http://westcompsci.pima.edu/~revans/CIS171 among other places.
Of note , is that there is a 15-lab notebook to hand in for this semester and we spend the
first few weeks covering two chapters per week. The last day of the semester is
December 17th.
We proceeded to go through the Chapter 1 powerpoints which can also be found at the
website above (among other places). In chapter 1 you must know things like: (a) the
boot sequence of the router, (b) where files like the IOS, the startup config, the running
config, and the bootstrap program are located. We looked at what information is
provided by the command: “sh version”.
We went through lab 1.5.3 Challenge Router Configuration. The word processing
document for this can be found at:
http://westcompsci.pima.edu/~revans/CIS171/PTlabsinWORD/ and the packet tracer file
for this can be found at: http://westcompsci.pima.edu/~revans/CIS171 under the
Zipped up packet tracer lab folder.
In this lab, we practiced using commands from the last chapter of the 1st semester such
as: configuring a hostname, configuring the serial and Ethernet interfaces, creating
passwords on the router, creating a message of the day (banner MOTD). We looked at
the “show ip route” command and how directly connected IP networks show up in the
routing table.

Wednesday, Oct 29, 2008
Tonight, we covered chapter 2- static routing by going through the powerpoints for the
chapter and doing Packet Tracer 2.8.2, both found at:

http://westcompsci.pima.edu/~revans/CIS171 and
http://westcompsci.pima.edu/~revans/CIS171/PTlabsinWORD/

Using the “show ip route” command, we find that the first networks appearing in a
routing table are networks directly connected to the router. After these routes are in the
routing table, we might configure a static route to a remote network.

The command to configure a static route is:

R(config)#ip route 172.3.4.0 255.255.255.0 s1

says if you get a packet destined for the network 172.3.4.0 then send it out interface s1.

In PT 2.8.2, we configured several static routes as with:

R(config)#ip route 172.3.4.0 255.255.255.0 s1
R(config)#ip route 172.3.5.0 255.255.255.0 s1
R(config)#ip route 172.3.6.0 255.255.255.0 s1
But found that we could summarize these static routes with one statement:

R(config)#ip route 172.3.0.0 255.255.0.0 s1

Which says that if a destination IP address looks like 172.3.0.0 in the first two octets, we
will send the packet out interface s1.

A gateway of last resort can be configured with the following command:

R(config)#ip route 0.0.0.0 0.0.0.0 s1

Which says that if the router is going to drop a packet because the router doesn’t contain
the destination network of the packet, instead of dropping the packet, the router will
snend the packet out the gateway of last resort s1.

Monday, November 03, 2008
Tonight, we:

   (1) review Chapter 2: Static Routing by viewing some of the module 2 assessment
       questions.
   (2) Static routing statements:
       ip route 172.3.2.0 255.255.255.0 s0/1 specifies exit interface to use to get to
                                                            network 172.3.2.0/24
       ip route 172.3.2.0 255.255.255.0 174.3.2.1 specifies next hop IP address
   (3) you can use summary routes to direct traffic across networks. Instead of using:
       ip route 172.3.2.0 255.255.255.0 s0/1
       ip route 172.3.1.0 255.255.255.0 s0/1
       you can summarize these routes as follows:
       ip route 172.3.0.0 255.255.252.0 s0/1

   (4) Chapter 3 – Introduction to Dynamic Routing we will:
       (a) go through the chapter 3 powerpoints
       (b) start doing PT 3.6.1 Skills Integration Activity
               which reviews subnetting and static routing


Wednesday, Nov 5, 2008
Tonight, we covered Chapter 4 by going through the powerpoints and doing PT 5.6.1 (the
only lab in Chapter 4 was a very long lab with subnetting and static routing. If you need
more practice with these two concepts, you should consider doing the chapter 4 PT lab).
We compared and contrasted “distance vector” routing protocols with “link-state” routing
protocols. Be aware of their advantages and disadvantages relative to one another. We
discussed “distance vector” protocols, RIP as an example, which send out routing updates
at timed intervals, as opposed to “link state” routing protocols, which only send out
updates when there are topology changes.
In PT 5.6.2, we explored the simple configuration of RIPv1 as well as using and
comparing commands such as “show ip route” and “debug ip rip”.




Monday, November 10, 2008
Tonight, we will start by finishing off some of the terminology from the end of chapter 4:
   (a) count to inifinity
   (b) split horizons
   (c) hold down timers
   (d) split horizons with poison reverse
   (e) TTL field in an IP packet

We will go through the chapter 5 powerpoints and then do PT 5.6.3: Troubleshooting
RIPv1. The picture below shows the setup for PT 5.6.3. We review what the routing
tables should hold by first realizing that all directly connected networks to a router should
show up in it’s routing table. Next, configuration of RIP is simple. We simply choose
rip routing following by mentioning all network directly connected to the router. For
example, with the HQ router below, we’d simply use the commands:

HQ(config)#router rip
HQ(config-if)#network 10.45.2.0
HQ(config-if)#network 10.45.1.0
HQ(config-if)#network 172.20.20.0




In PT 5.6.3, everything is already configured, but we must figure out what is wrong with
the configuration. We inspect the routing tables using “show ip route”. We learn we can
turn off the RIP routing broadcast out an interface by using the “passive interface”
command.
Wednesday, Nov 12, 2008
Tonight, we will be covering Chapter 6: VLSM (variable-length subnet masking) and
summarization. We will start by looking at the online chapter 6 and reviewing some IP
concepts (e.g., Classful vs classless (CIDR) IP addressing). We will review the
numbering of classful IP addresses to distinguish between Class A, B, C, and D
addresses. We will look at route summarization (examples shown in your online
chapter).
For lab work, we will start with the PT lab called Intro to VLSM Packet Tracer.
This lab (as are all DOC PT labs) is in
http://westcompsci.pima.edu/~revans/CIS171/PTlabsinWORD/

There are more complex labs in VLSM (see the list below from:
http://westcompsci.pima.edu/~revans/CIS171/CCNA%20II%204.0%20Packet%20Tracer
%20Labs%20from%20Study%20Guide/Chapter6/

), but the one above is good introductory material. Also, PTA 6.4.1 from below is good
for intro work with VLSM.
For router summarization work, try PTA 6.4.4




Monday, November 17, 2008

Tonight, we will be covering more VLSM in Chapter 6 and RIPv2 in Chapter 7.

   (1) We will start by doing only the VLSM design in PT 7.6.1 Skills Integration
       Activity (can be found as a word document in the CIS171 folder).
   (2) We will then look at approximately 5 questions from the Ch 6 quiz.
   (3) Will will then do PT 7.5.1 Basic RIPv2 Configuration (can be found as a word
       document in the CIS171 folder).

   In (3) above, pay attention to how router summarization (to the classful route or to a
   superroute) takes place and pay attention to how static routes (and default routes)
   may be distributed across the routing domain by the routing protocols.
Monday, November 24th, 2008
Tonight, we will be looking at Chapter 8, where we concentrate on routing tables and the
routing lookup process. We will begin by examining much of the terminology listed
below using the Chapter 8 powerpoint. Next, we’ll study this more by doing PT8.4.1
Investigating the Routing Table Lookup Process (a WORD file) along with the actual
packet tracer 8.4.1 pka file.
As we will do in the PT lab, you should be able to:

    (a) Look at a diagram/pt pictorial and tell how many networks/subnets are in the
        diagram
    (b) Understand/know what routes/networks should exist in a router’s routing table
        within such a diagram
For this chapter, we need to understand the “lookup” process in the routing table.
We will study terms such as: parent route, child route, level 1 & level 2 routes, ultimate
routes, “no autosummary” commands for classless routing protocols,

If your router is using CLASSFUL (as opposed to classless routing), then default routes
are not available to use.

NO IP CLASSLESS (ip classless is the default command which means routers can use a
default route or gateway of last resort

Wednesday, November 26th, 2008
Tonight, we concentrated on Chapter 8 . To support this, we went through PT 8.4.1
Investigating the Routing Table Lookup Process. In this lab we initially configure
RIPv1 as the dynamic routing protocol, and then change it to RIPv2. We review the idea
that RIPv1 is a CLASSFUL routing protocol, which means it doesn’t transmit mask
information in it’s routing updates. Thus, the first octet of an IP address can be used to
determine the classful mask (e.g., 172.3.5.1 would have a class B mask, or 255.255.0.0
or 192.3.2.1 would have a class C mask, or 255.255.255.0). We found that RIPv2 likes to
summarize to classful routes. That is, if router B has the two subnets 192.168.1.128/26
and 192.168.1.64/26, it would by default report to the next router that it is directly
connected (and thus the router it’s connected to is 1 hop away from) their classful
summary 192.168.1.0, i.e., router A is able to get packets to any network that looks like
192.168.1.0 in the first 24 bits.
In addition to this, we went through a number of assessment questions for Chapter 8.

Monday, Dec 1, 2008
Tonight, we begin Chapter 9 or EIGRP routing. We begin by going through most
Chapter 9 powerpoint slides. Then, we do PT 9.2.6 Basic EIGRP Configuration
together. In EIGRP, we pay attention to how to configure EIGRP (it can be quite
simple), the concept of Autonomous Systems (AS), process ID, the DUAL process for
finding routes used by EIGRP, how and when EIGRP sends out update to neighbors, the
“hello” process used by EIGRP to discover neighboring routers running EIGRP, PDM or
protocol dependant modules used by EIGRP to route various layer 3 protocols (IP, IPX,
Appletalk), and EIGRP metrics (the default metric using only Bandwidth & Delay as
parameters).

Wednesday, Dec 3, 2008
Tonight, we will finish Chapter 9: EIGRP by first doing PT 9.6.3 Troubleshooting
EIGRP Configuration Lab and then looking at some of the questions in the Chapter 9
assessment.

We will then begin Chapter 10: Link-State Routing Protocols by looking at some of the
powerpoint slides for Chapter 10.

Monday, Dec 8, 2008
Tonight, we will start with Chapter 11: OSPF Routing and work our way back to the
more general Chapter 10: Link-State Routing. OSPF routing is our specific introduction
to link-state routing protocols. We will first go through some of the Chapter 11
powerpoints to introduce specific concepts of OSPF and then we will do PT 11.6.1a:
Basic OSPF Routing. Click on the link to find the actual PT 11.6.1a pka file. If time
permits, we will look at some assessment questions from Chapter 10 and 11.


Wednesday, Dec 10th, 2008
The online final will be on M, T, W, and Th evenings of next week from 3pm until 11pm.
It is preferred that you come into A227 to take the online final (M, T, W of next week) If
you wish to take the online final at another time (e.g., this weekend), email me at
revans@pima.edu. Also, don’t forget to do the online feedback. Remember, the final
can be taken twice.

Tonight, we begin by finishing off Chapter 11 – OSPF. We will use the powerpoints to
look at the last few concepts:

   (1) Networks that do and don’t elect at DR/BDR (p-to-p, multi-access broadcast, non-
       broadcast multi-access)
   (2) The purpose of an OSPF router ID and it’s use (and that of the loopback interface)
       in electing a DR/BDR.
   (3) The static nature of BDR/DR elections
   (4) Using the bandwidth parameter or cost and computing the OSPF metric
   (5) Hello & dead interval timers as applied to interfaces, and how they complicate the
       management of OSPF (they bring down the whole OSPF process if not the same
       in the area)
After this, we will look at a number of the questions in the chapter 11 assessment.

We will finish off the class (and the lectures for the semester) by looking at some
questions from the Ch10 OSPF assessment.

Email me at revans@pima.edu with questions


------------------------------------------------------------------------------------------------------------
----


Below is from Spring 2008
Monday, March 24th –
Finishing up Semester I things (labs, finals, etc…); looking over the Syllabus for
Semester II; Chapter 1 is basically a review chapter for Semester I, so one could do some
of the packet tracers from Chapter 1 as well as the Labs from Chapter 1. In many
instances, the labs may be completed by setting up a representation in packet tracer, and
in many instance there is a packet tracer activity that corresponds to the specific lab.

Wednesday, March 26th- Working on Chapter 2 – static and default routing. Packet
Tracer Activity 2.8.2 is being used as a demonstration to present static and default
routing. You should think about taking the Chapter 1 assessment.

Monday, March 31 – Tonight, Chapter 3 is covered using the powerpoints from Chapter
2. Chapter 2 is an introduction to Dynamic routing protocols and their characteristics.
First, the distinction is made between Exterior Gateway Procotols (EGP) and Interior
Gateway Protocols (IGP), where exterior (e.g., BGP) permits routers from different
organizations to exchange IP routes/networks information and interior would refer to
within a single organization. In the CCNA, we focus only on interior or within an
organization. Next, the distinction is made between “distance-vector” routing protocols
and “link-state” routing protocols, and it is important to know these differences, as well
as the advantages/disadvantages of using dynamic vs static routing.
In class, we do PT 3.6.1 Skills Integration Challenge Activity, which requires static and
default routing to be set up, as well as subnetting to be done.
There are also about 3 other PT and labs which focus on setting up static routing, default
routing, and subnetting, and you might want to do a couple of these, if you’re having
problems.


Wednesday, April 2 – Today, we will review PT 3.6.1 if anyone has any questions. We
will be covering chapter 4. To do this, we will use the ch 4 powerpoints and then do
Packet Tracer 4.7.1, which is composed of subnetting, some router configuration, and
setting up static routes & default routes. If you haven’t started your quizzes, you should
try to get through the Chapter 3 quiz by the end of the weekend.
Monday, April 7 – Today, we are covering Chapter 5 – RIPv1. We will go through the
powerpoint slides for this chapter and do PT 5.6.1b. There are a few good chapter 5 labs
one could do. PT 5.6.2 and 5.7.1 are very good challenge labs, but are also quite long.
The topics most important in this chapter which we cover in class are:
   a.      RIP v1 as a distance vector routing protocol
           i.      broadcasts table every 30 seconds
           ii.     metric is hops; flush time, hold time, etc… what they mean
           iii.    it doesn’t pass mask information; it only handles classful networks
   b.      “default information originate” – RIP passing on default routing information
   c.      The specific commands to set up RIP v1 on a router and how they affect the
           passing of routing information;
   d.      The “passive interface fa 0/0” command so as NOT to pass RIP information
           out a specific interface

Wednesday, April 9 – In today’s class, we will be covering Chapter 6 – VLSM & CIDR.
We will start with the following:
     (1) We will complete PT 6.4.1, which includes a VLSM design, assignment of IP
         addresses to interfaces and PCs,.
     (2) We will start PT 6.5.1, which includes subnetting design, configuring RIPv2, and
         setting up static routes.
     (3) We will look at a few questions from the Chapter 6 Assessment
It’s important one understands the concept of CIDR, summarization of routes, and the
classful IP network boundaries for this chapter.

Monday, April 14 – Tonight, we begin Chapter 7 – RIPv2. We compare and contrast
RIPv2 with RIPv1 using the chapter 7 powerpoints. We use a sample packettracer lab at
http://westcompsci.pima/~revans/CIS171 in the Ch 7 folder to do some reviewing of
RIPv1 and it’s drawbacks of not passing mask information, being classful (not being able
to deal with VLSM). We look at some new concepts, such as creating a loopback
interface (a logical/not physical interface). We do some troubleshooting of a
configuration using PT 7.5.3 and some further work with PT 7.6.1.
RIPv2 has the ability to: deal with vlsm, autosummarize by default (or no autosummary),
redistribute static routes…
Finally, we’ll analyze a few questions from the Ch 7 assessment.

Wednesday, April 16 – Tonight, we begin Chapter 8, looking in more depth at the
routing table and how the routing table in a router is organized for more efficient searches
in order to forward packets. To do this, we’ll go through the power points and PT 8.4.1 –
Investigating the Routing Table Lookup Process. We’ll finish by analyzing a few
questions from the Chapter 8 Assessment. Important concepts are:
Level 1 route – has a subnet mask equal to or less than the classful mask – thus
192.6.6.0/16 would be a level 1 route because 192 indicates a class C mask = /24 and
/16 < /24
Level 2 route – has a subnet mask greater than the classful mask
Parent route –is a level 1 route and does NOT contain a next hop IP address or an exit
interface associated with it.
Child Route – is a level 2 route and is a subnet of a classful route
Ultimate route – has a next hop gateway or exit interface associated with it.
“ip classless” and “no ip classless” are products of the routing table and NOT the routing
protocol.
“no ip classless” is implement by default on old IOS’s. This means the router will not
use a default route if it cannot find the exact subnet matching the destination IP because
the router assumes it has all the subnets for that classful IP network in it’s table.


Monday, April 21 – Tonight, we begin coverage of Chapter 9 – EIGRP. EIGRP is a
cisco proprietary routing protocol, so the IOS of a non-cisco router would not handle
EIGRP routing. Although EIGRP is a distance-vector routing protocol, it does not
broadcast/multicast it’s routing table every 30 or 90 seconds. It sends out bounded partial
“update”s to it’s neighboring routers when it notices a change in topology. EIGRP is a
classless routing protocol. It uses RTP (as opposed to TCP/IP) to send EIGRP
information, the DUAL Algorithm, feasible distance, feasible successors, a topology
table, a routing table, a neighbor table, the hello protocol (sent out every 5 seconds to
maintain adjacencies with it’s neighboring routers), queries, acknowledgments, etc….
We will use the Chapter 9 power points to introduce terminology and concepts
concerning EIGRP. We will use packet tracer labs to work through some of the EIGRP.
PT 9.6.1 is a simple simulation to introduce you to configuring the EIGRP protocol. PT
9.6.2 is more challenging and will have you completing a VLSM design for IP
Addressing, as well as configuring EIGRP and a few other things. Once you have a basic
understanding of EIGRP configuration, PT 9.6.3 has you troubleshooting EIGRP and
other routing issues. Finally, PT 9.7.1 has you doing VLSM design, configuring EIGRP,
and fine tuning EIGRP by changing parameters such as the HELLO INTERVAL.

Wednesday, April 23 – Tonight, we work more with EIGRP from Chapter 9. We begin
by completing PT 9.6.1, starting with Task 6 in order to explore more eigrp commands
(“sh ip eigrp ?”, “sh ip protocols”, “sh ip route”). We examine EIGRP metrics (from the
DUAL algorithm) where bandwith & delay are the default contributors to the EIGRP
route computation metric. We examine the concepts of “feasible successor routes” and
auto-summarization to a classful network as part of EIGRP routing.
As a follow-up to the concepts above, we use PT 9.6.3 to troubleshoot an EIGRP setup.
Finally, we look at some of the chapter 9 quiz questions.

Monday, April 28 – Tonight, we begin Chapter 10 – Link State Routing. We will start by
going through the Chapter 10 power points. Important terminology consists of: Dikstra
algorithm for SPF (shortest path first) or route determination based upon a COST, LSP
(link space packets) distributed to other routers which contain things like neighbor IDs,
link types and bandwidth; hello packets (also act like keep alives), adjacencies and
adjacency tables; building a topology map; fast convergence (relative to distance-
vector); initial flooding of the network (exchanging hello packets, etc…)

We will do PT 10.3.1 which has a long VLSM design component (this part is complete
with IP interface assignments if you look in
http;//westcompsci.pima.edu/~revans/CIS171 and then in the Chapter 10 folder for the
Word Document and the PT 10.3.1). In this PT 10.3.1 in class we will: complete static
routing assignments, IGRP routing, RIPv2 routing, passive interface assignments, and
configure and redistribute default routes.

Finally, we will look at some questions from the Ch 10 quiz.


Wednesday, April 30 – Tonight, we will start by completing PT 10.3.1 (saved in the Ch
10 folder along with the WORD document at
http://westcompsci.pima.edu/~revans/CIS171) from the previous class. Last time, we left
off at the part “Configure EIGRP routing in Region 1 and RIPv2 routing Region 2” and
we will review what we completed in this section (the EIGRP routing) and continue on
with configuring RIPv2. After completing this lab, we begin our introduction to the
OSPF Routing Protocol. We will use the powerpoint slides for introduction of OSPF
concepts. We will then do Packet Tracer 11.6.1a - Basic OSPF Configuration.
Concepts such as link-state protocol, simple configuration of OSPF, propagation of
default routes under OSPF, link-type (e.g., multi-access, point-to-point) and it’s effect on
DR (designate router) and BDR (backup designated router) elections in an OSPF area ,
OSPF Hello & dead intervals,

Monday, May 5 – Tonight, we look at Chapter 11, OSPF routing, using the Chapter 11
powerpoints and PT 11.6.1 Basic OSPF Configuration (look in the Ch 11 folder within
http://westcompsci.pima.edu/~revans/CIS171).
Important terminology and concepts consist of: Link-state routing protocol, hello
packets, Link-state update packets, developing adjacencies, neighbor table, NBMA, MA,
point-to-point WANs and elections of a DR and BDR OSPF router on MA and NBMA
network types.. DRs and BDRs listen at 224.0.0.6. Other OSPF routers listen at
224.0.0.5
Elections based upon: (1) router in the network type with highest OSPF priority, (2)
router with the highest OSPF Router ID. Router ID is defined as the highest IP address
assigned to ANY interface of a router. However, if the router has a LOOPBACK
interface, then the router’s loopback IP address becomes it’s Router ID, REGARDLESS
of the magnitude of the LOOPBACK interface IP.
Once an OSPF election occurs, there will only be another election if the DR goes down.

After looking at PT 11.6.1, we will look at some questions from the Ch 11 assessment.




Wednesday, May 7 – Tonight, we will finish up with Ch 11, OSPF routing. We will
review what types of networks/links require OSPF elections, the variables involved in
OSPF elections (ip ospf priority values (1 = default, 0 = not electable, 255 = max), OSPF
router IDs & comparisons). Review online page 11.2.4.1 to see if you can determine
OSPF Router ID values.
We will review the OSPF packet types (hello, Db description packet, LSR, LSU, &
LSAck).
OSPF has specific requirements that, unless met, will cause OSPF routing to go down.
For example, neighbors have to have their hello intervals, dead intervals, and network
types be equivalent, or else the OSPF process breaks down. If the interface IP that is the
router ID goes down, OSPF routing process will go down.
OSPF uses bandwidth to computer the cost of a path. Online page 11.3.1.1 shows the
integer cost value assigned to various link bandwidths. For example, a T1 line
(1.544mbps) has a cost of 64, and as cost increases, bandwidth should decrease. To set
the bandwidth or cost on an interfaces, use:
R(config-if)#bandwidth 64              (for 64 kbps)
R(config-if)#ip ospf cost 1010         (thus the bandwidth need not be specified in order
                                      to computer the cost of using that line/interface)

To finish this chapter, we will do PT 11.6.3 – OSPF Troubleshooting Lab. You can find
the word document equivalent for this lab (which can be used in your lab notebook) at
http;//westcompsci.pima.edu/~revans/CIS171 in the word documents folder.

May 12 – last day of the regular semester – Tonight, we will do a final
review. You can find a word document FINAL REVIEW at:
http://westcompsci.pima.edu/~revans/CIS171

The onlne final & online feedback can be taken May 12,13,14,15,19, or 20 in the evening
in A227

May 13,14,15,19,20 A227 is open for testing, questions, etc…

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:149
posted:9/18/2011
language:English
pages:11