Docstoc

Exporting Of Variables

Document Sample
Exporting Of Variables Powered By Docstoc
					Do you find information provided here useful
                                                                              RESOLUTION



Title:                                                                      Importing variables
Resolution Number: 157472                                                          Distribution: For Fee
Product Name: Software / Product Family: Vijeo Look

Goals and Vijeo Designer / XBTG software does not have an intuitive and or relatively simple process to im
Symptoms software package such as Concept. This resolution is designed to walk users through modifying a
          Vijeo Designer software package.

Causes
and Fixes Exporting variables with Vijeo Designer

             The format of the file Vijeo Designer exports its variables to is not directly compatible with the v
             packages. We must first create an exported variable list from Vijeo designer to create a format th
             copy and paste the compatible portions of the PLC programming variable export into the Vijeo D

             Open Vijeo designer and create a project.
             Under Tools open both the Navigator Panel [A] and the Inspector panel [B]
             Right click on IO manager in the Navigator panel and add a Driver Interface to the application I.
             Right click on the Driver Interface and add a new Equipment. A PLC that Vijeo Designer will be
             Equipment. To set the PLC's address highlight the Equipment and look to the Inspector window;
             Create at least one Access group for Equipment. The access group is a way to group like tags and




             In the above example the application has two network protocols installed.
             Under Modbus TCP/IP there are two controllers configured.
Under the Quantum 534 there are three access groups all with different polling rates which organ

Click on the Variable tab from the Navigator window.
Right click on Target and create a few new variables with a different datatypes.
In the Inspector window you will see the information available for each variable.




In this window you can change the name of the variable, it's datatype, whether it is an internal or
#1], 0X, 1X. 3X, 4X address, etc.
With the variable tab still opened in the Navigator window right click on the Target and export th

A .csv file like the one below will be created and can be viewed from Microsoft Excel.
Exporting variables with the PLC programming package

Concept
File> Export> Variables: Text Delimited
Export variables with a user defined Separator of , Not the default of ;
Save the export with a .csv extension instead of the default .txt
Proworx 32
Right click on the Project from the Navigation Panel
Export Documentation
Save the export as a Microsoft Excel .xls extension
Proworx Nxt
File>Utilities>Import/Export
Select the Export and the Spreadsheet .DIF file radio buttons
PL7 Pro
With a variable window open go to:
File>Export
Select Excel Compatible .txt
Launch Microsoft Excel
Go to File> Open> select Files of type Text files and browse to the location of the PL7 variable e
Choose delimited type and click Next
Choose a Tab delimiter click Next and Finish
File> Save as> and select the type Microsoft Excel Workbook
Unity
File> Export
Set the save file type as Data exchange Text file .txt
Launch Microsoft Excel
Go to File> Open> select Files of type Text files and browse to the location of the Unity variable
Choose delimited type and click Next
Choose a Tab delimiter click Next and Finish
File> Save as> and select the type Microsoft Excel Workbook
Modsoft
From a Ladder Logic Window> F1Utility> F5 Symbol Table> F4 File I/O> F2 Export and type a
Launch Microsoft Excel
Go to File> Open> select Files of type any and browse to the location of the Modsoft variable ex
Choose fixed width, start import at row 1, Windows ANSI, and click Next
Click Next and Finish
File> Save as> and select the type Microsoft Excel Workbook

Merging the exported variable files and importing back into Vijeo Designer

All of the above procedures will create similar variable exports like the one below. A comparison
the Vijeo Designer variable export has more columns to fill out than the programming software e
Open one of the PLC programming exported variable list with Excel and select the column of va
Designer variable file.




The first four columns {Type, Name, Data Type, and Data Source} of the Vijeo Designer variabl
before the merged file is imported back into Vijeo Designer. As you can see the PLC programmi
columns. The data in the four columns mentioned previous must be manually entered.
The other categories are either left blank and can be entered once inside Vijeo Designer such has
Other columns like the Access Group may be summarily assigned a default by Vijeo Designer an
the Vijeo Designer variable editor tab.
Open Vijeo designer.
Click on the Variable tab from the Navigator window.
With the variable tab still opened in the Navigator window right click on the Target and import t

Note:
Most users will also want to copy the address column into the merged file. This can be done, how
what type of protocol that access group is under. If the variable is assigned a location using Mod
group linked to a Unitelway protocol [%xx address format] is attached to the variable then the ta
Designer.

Pay particular attention to the Vijeo Designer supported datatypes. Many of the datatypes suppor
either not be supported or be named something different as in the case of Boolean / Discrete.

Vijeo Designer does not support Concept un-located variables.

The Vijeo Designer structured datatype is not the same as a Concept structured datatype. Vijeo D
into a structure for easier trouble shooting. This structure is just a linked list of regular variables

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:83
posted:9/10/2011
language:English
pages:5