Documents
Resources
Learning Center
Upload
Plans & pricing Sign in
Sign Out

R1_show glbp

VIEWS: 21 PAGES: 45

									R1#show glbp
FastEthernet0/0 - Group 47
 State is Active
   2 state changes, last state change 00:03:45
 Virtual IP address is 172.22.0.30
 Hello time 3 sec, hold time 10 sec
   Next hello sent in 0.043 secs
 Redirect time 600 sec, forwarder time-out 14400 sec
 Preemption disabled
 Active is local
 Standby is 172.22.0.4, priority 100 (expires in 9.671 sec)
 Priority 100 (default)
 Weighting 100 (configured 100), thresholds: lower 90, upper 100
   Track object 1 state Up decrement 15
   Track object 2 state Up decrement 15
 Load balancing: round-robin
 Group members:
   000d.2854.3920 (172.22.0.1) local
   001c.f682.8328 (172.22.0.4)
 There are 2 forwarders (1 active)
 Forwarder 1
   State is Active
    1 state change, last state change 00:03:35
   MAC address is 0007.b400.2f01 (default)
   Owner ID is 000d.2854.3920
   Redirection enabled
   Preemption enabled, min delay 30 sec
   Active is local, weighting 100
 Forwarder 2
   State is Listen
   MAC address is 0007.b400.2f02 (learnt)
   Owner ID is 001c.f682.8328
   Redirection enabled, 599.010 sec remaining (maximum 600 sec)
   Time to live: 14399.010 sec (maximum 14400 sec)
   Preemption enabled, min delay 30 sec
   Active is 172.22.0.4 (primary), weighting 100 (expires in 9.010 sec)
R1#sh glbp brie
Interface Grp Fwd Pri State Address            Active router Standby route
Fa0/0      47 - 100 Active 172.22.0.30 local              172.22.0.4
Fa0/0      47 1 7 Active 0007.b400.2f01 local              -
Fa0/0      47 2 7 Listen 0007.b400.2f02 172.22.0.4           -
R1#sh track
Track 1
 Interface Serial0/0 line-protocol
 Line protocol is Up
   1 change, last change 00:05:28
 Tracked by:
  GLBP FastEthernet0/0 47
Track 2
 IP route 172.22.5.0 255.255.255.0 reachability
 Reachability is Up (OSPF)
  1 change, last change 00:05:10
 First-hop interface is Serial0/0
 Tracked by:
  GLBP FastEthernet0/0 47
R1#

R4#sh glbp
FastEthernet0/0 - Group 47
 State is Standby
  1 state change, last state change 00:02:37
 Virtual IP address is 172.22.0.30
 Hello time 3 sec, hold time 10 sec
  Next hello sent in 1.992 secs
 Redirect time 600 sec, forwarder time-out 14400 sec
 Preemption disabled
 Active is 172.22.0.1, priority 100 (expires in 9.368 sec)
 Standby is local
 Priority 100 (default)
 Weighting 100 (configured 100), thresholds: lower 90, upper 100
  Track object 1 state Up decrement 15
  Track object 2 state Up decrement 15
  Track object 3 state Up decrement 15
 Load balancing: round-robin
 Group members:
  000d.2854.3920 (172.22.0.1)
  001c.f682.8328 (172.22.0.4) local
 There are 2 forwarders (1 active)
 Forwarder 1
  State is Listen
  MAC address is 0007.b400.2f01 (learnt)
  Owner ID is 000d.2854.3920
  Time to live: 14398.188 sec (maximum 14400 sec)
  Preemption enabled, min delay 30 sec
  Active is 172.22.0.1 (primary), weighting 100 (expires in 8.188 sec)
 Forwarder 2
  State is Active
   1 state change, last state change 00:02:45
  MAC address is 0007.b400.2f02 (default)
  Owner ID is 001c.f682.8328
  Preemption enabled, min delay 30 sec
  Active is local, weighting 100
R4#sh glbp brief
Interface Grp Fwd Pri State Address      Active router Standby route
Fa0/0     47 - 100 Standby 172.22.0.30 172.22.0.1      local
Fa0/0     47 1 7 Listen 0007.b400.2f01 172.22.0.1      -
Fa0/0     47 2 7 Active 0007.b400.2f02 local         -
R4#sh track
Track 1
 Interface Serial0/0/0 line-protocol
 Line protocol is Up
   1 change, last change 00:03:48
 Tracked by:
   GLBP FastEthernet0/0 47
Track 2
 Interface Serial0/1/0 line-protocol
 Line protocol is Up
   1 change, last change 00:03:38
 Tracked by:
   GLBP FastEthernet0/0 47
Track 3
 Interface FastEthernet0/1 line-protocol
 Line protocol is Up
   1 change, last change 00:03:29
 Tracked by:
   GLBP FastEthernet0/0 47
R4#

R1#deb glbp events
GLBP Events debugging is on
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int s0/0
R1(config-if)#shut
R1(config-if)#
*Mar 3 23:58:56.172: GLBP: Fa0/0 47 Track 1 object changed, state Up -> Down
*Mar 3 23:58:56.172: GLBP: Fa0/0 47 Weighting 100 -> 85
R1(config-if)#
*Mar 3 23:58:58.175: %LINK-5-CHANGED: Interface Serial0/0, changed state to
administratively down
*Mar 3 23:58:59.177: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0, changed state to down
R1(config-if)#
*Mar 3 23:58:59.689: GLBP: Fa0/0 47 Track 2 object changed, state Up -> Down
*Mar 3 23:58:59.689: GLBP: Fa0/0 47 Weighting 85 -> 70
R1(config-if)#
R1(config-if)#
*Mar 3 23:59:28.813: GLBP: Fa0/0 47.1 Active: i/Hello rcvd from higher pri Active
router (135/172.22.0.4)
*Mar 3 23:59:28.813: GLBP: Fa0/0 47.1 Active -> Listen
R1(config-if)#
*Mar 3 23:59:28.817: %GLBP-6-FWDSTATECHANGE: FastEthernet0/0 Grp 47 Fwd 1
state Active -> Listen
R1(config-if)#
*Mar 3 23:59:33.958: %OSPFv3-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Tunnel1 from
FULL to DOWN, Neighbor Down: Dead timer expired
R1(config-if)#
R1(config-if)#
R1(config-if)#
*Mar 3 23:59:39.459: %OSPFv3-5-ADJCHG: Process 1, Nbr 3.3.3.3 on OSPFv3_VL0
from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Mar 3 23:59:45.905: %MSDP-5-PEER_UPDOWN: Session to peer 172.22.124.2 going
down
R1(config-if)#


R1#show glbp
FastEthernet0/0 - Group 47
 State is Active
  2 state changes, last state change 00:07:31
 Virtual IP address is 172.22.0.30
 Hello time 3 sec, hold time 10 sec
  Next hello sent in 2.107 secs
 Redirect time 600 sec, forwarder time-out 14400 sec
 Preemption disabled
 Active is local
 Standby is 172.22.0.4, priority 100 (expires in 8.610 sec)
 Priority 100 (default)
 Weighting 70, low (configured 100), thresholds: lower 90, upper 100
  Track object 1 state Down decrement 15
  Track object 2 state Down decrement 15
 Load balancing: round-robin
 Group members:
  000d.2854.3920 (172.22.0.1) local
  001c.f682.8328 (172.22.0.4)
 There are 2 forwarders (0 active)
 Forwarder 1
  State is Listen
   2 state changes, last state change 00:01:00
  MAC address is 0007.b400.2f01 (default)
  Owner ID is 000d.2854.3920
  Redirection enabled
  Preemption enabled, min delay 30 sec
  Active is 172.22.0.4 (secondary), weighting 100 (expires in 9.792 sec)
 Forwarder 2
  State is Listen
  MAC address is 0007.b400.2f02 (learnt)
  Owner ID is 001c.f682.8328
  Redirection enabled, 599.796 sec remaining (maximum 600 sec)
  Time to live: 14399.792 sec (maximum 14400 sec)
  Preemption enabled, min delay 30 sec
  Active is 172.22.0.4 (primary), weighting 100 (expires in 9.792 sec)


R1#sh glbp brie
Interface Grp Fwd Pri State Address          Active router Standby route
Fa0/0     47 - 100 Active 172.22.0.30 local             172.22.0.4
Fa0/0     47 1 7 Listen 0007.b400.2f01 172.22.0.4          -
Fa0/0     47 2 7 Listen 0007.b400.2f02 172.22.0.4          -
R1#
R1#
R1#sh track
Track 1
 Interface Serial0/0 line-protocol
 Line protocol is Down (hw admin-down)
   4 changes, last change 00:00:34
 Tracked by:
   GLBP FastEthernet0/0 47
Track 2
 IP route 172.22.5.0 255.255.255.0 reachability
 Reachability is Down (no route)
   2 changes, last change 00:01:47
 First-hop interface is unknown
 Tracked by:
   GLBP FastEthernet0/0 47
R1#


R4#sh glbp brief
Interface Grp Fwd Pri State Address    Active router Standby route
Fa0/0     47 - 100 Standby 172.22.0.30 172.22.0.1    local
Fa0/0     47 1 7 Active 0007.b400.2f01 local       -
Fa0/0     47 2 7 Active 0007.b400.2f02 local       -
R4#




###############
# Device FS #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7-FS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
!
!
!
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
  description Networks for RIP
  ip address 2.2.2.2 255.255.255.0 secondary
  ip address 3.3.3.3 255.255.255.0 secondary
  ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
  ip address 172.22.0.7 255.255.255.192
  speed 100
 full-duplex
 no shutdown
!
interface FastEthernet0/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Serial1/0
  description To R1 Serial 0/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
  frame-relay intf-type dce
  frame-relay route 122 interface   Serial1/1   221
  frame-relay route 123 interface   Serial1/2   321
  frame-relay route 124 interface   Serial1/3   421
  frame-relay route 125 interface   Serial1/4   521
  frame-relay route 126 interface   Serial1/5   621
  no shutdown
!
interface Serial1/1
  description To R2 Serial 0/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
  frame-relay intf-type dce
  frame-relay route 221 interface   Serial1/0   122
  frame-relay route 223 interface   Serial1/2   322
  frame-relay route 224 interface   Serial1/3   422
  frame-relay route 225 interface   Serial1/4   522
  frame-relay route 226 interface   Serial1/5   622
  no shutdown
!
interface Serial1/2
  description To R3 Serial 0/0/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
  frame-relay intf-type dce
  frame-relay route 321 interface   Serial1/0   123
  frame-relay route 322 interface   Serial1/1   223
  frame-relay route 324 interface   Serial1/3   423
  frame-relay route 325 interface   Serial1/4   523
  frame-relay route 326 interface   Serial1/5   623
  no shutdown
!
interface Serial1/3
  description To R4 Serial 0/0/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
 frame-relay   intf-type   dce
 frame-relay   route 421   interface   Serial1/0   124
 frame-relay   route 422   interface   Serial1/1   224
 frame-relay   route 423   interface   Serial1/2   324
 frame-relay   route 425   interface   Serial1/4   524
 frame-relay   route 426   interface   Serial1/5   624
 no shutdown
!
interface Serial1/4
  description To R5 Serial 1/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
  frame-relay intf-type dce
  frame-relay route 521 interface      Serial1/0   125
  frame-relay route 522 interface      Serial1/1   225
  frame-relay route 523 interface      Serial1/2   325
  frame-relay route 524 interface      Serial1/3   425
  frame-relay route 526 interface      Serial1/5   625
  no shutdown
!
interface Serial1/5
  description To R6 Serial 0/0/0
  no ip address
  encapsulation frame-relay
  no fair-queue
  clock rate 128000
  frame-relay intf-type dce
  frame-relay route 621 interface      Serial1/0   126
  frame-relay route 622 interface      Serial1/1   226
  frame-relay route 623 interface      Serial1/2   326
  frame-relay route 624 interface      Serial1/3   426
  frame-relay route 625 interface      Serial1/4   526
  no shutdown
!
interface Serial1/6
  no ip address
  shutdown
!
interface Serial1/7
  no ip address
  shutdown
!
router rip
  version 2
  network 1.0.0.0
  network 2.0.0.0
  network 3.0.0.0
  network 172.22.0.0
  no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
!
end

###############
# Device R1 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 1 interface Serial0/0 line-protocol
!
track 2 ip route 172.22.5.0 255.255.255.0 reachability
!
!
!
!
!
interface Loopback0
  ip address 172.22.81.1 255.255.255.0
  ip pim sparse-dense-mode
  ip ospf network point-to-point
  ipv6 address 2001:22:81::1/64
  ipv6 ospf 1 area 0
!
interface Loopback1
  ip address 1.1.1.1 255.255.255.0
  ipv6 address 2006:1:1::/128
!
interface Loopback2
  ip address 223.255.255.254 255.255.255.255
  ip pim sparse-dense-mode
!
interface Tunnel1
  no ip address
  ipv6 address 2005:22:13::1/64
  ipv6 address FE80::1 link-local
  ipv6 ospf mtu-ignore
  ipv6 ospf 1 area 13
  keepalive 10 3
  tunnel source Loopback0
  tunnel destination 172.22.83.1
  tunnel mode ipv6ip
  no shutdown
!
interface FastEthernet0/0
  ip address 172.22.0.1 255.255.255.192
  ip pim sparse-dense-mode
  speed 100
 full-duplex
 ipv6 address 2005:22:1::1/64
 ipv6 address FE80::1 link-local
 ipv6 ospf 1 area 11
 glbp 47 ip 172.22.0.30
 glbp 47 weighting 100 lower 90
 glbp 47 weighting track 1 decrement 15
 glbp 47 weighting track 2 decrement 15
 no shutdown
!
interface Serial0/0
  ip address 172.22.124.1 255.255.255.224
  ip pim nbma-mode
  ip pim sparse-dense-mode
  encapsulation frame-relay
  ip ospf authentication
  ip ospf authentication-key CISCO
  ipv6 address 2005:22:124::1/64
  ipv6 address FE80::1 link-local
  frame-relay map ipv6 FE80::2 122
  frame-relay map ip 172.22.124.2 122 broadcast
  frame-relay map ip 172.22.124.4 124 broadcast
  frame-relay map ipv6 2005:22:124::2 122
  frame-relay map ip 172.22.124.1 122
  no frame-relay inverse-arp
  no shutdown
!
interface FastEthernet0/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Serial0/1
  no ip address
  shutdown
!
router ospf 1
  router-id 1.1.1.1
  log-adjacency-changes
  redistribute rip metric 50000 subnets route-map RIP2OSPF
  passive-interface FastEthernet0/0
  network 172.22.0.1 0.0.0.0 area 0
  network 172.22.81.1 0.0.0.0 area 0
  network 172.22.124.1 0.0.0.0 area 0
  network 223.255.255.254 0.0.0.0 area 0
  neighbor 172.22.124.2
  neighbor 172.22.124.4
  distance 130 0.0.0.0 255.255.255.255 LOOPFREE-RIP-ROUTES
!
router rip
  version 2
  redistribute ospf 1 metric 5 match internal external 2 route-map
OSPF2RIP
  passive-interface default
  network 172.22.0.0
  neighbor 172.22.0.4
 distance 255
 distance 120 172.22.0.4 0.0.0.0
 no auto-summary
!
router bgp 200
  bgp router-id 1.1.1.1
  bgp log-neighbor-changes
  neighbor 2001:22:83::3 remote-as 200
  neighbor 2001:22:83::3 update-source Loopback0
  neighbor 2005:22:124::2 remote-as 100
  neighbor 172.22.84.1 remote-as 200
  neighbor 172.22.84.1 update-source Loopback0
  neighbor 172.22.124.2 remote-as 100
  !
  address-family ipv4
  no neighbor 2001:22:83::3 activate
  no neighbor 2005:22:124::2 activate
  neighbor 172.22.84.1 activate
  neighbor 172.22.124.2 activate
  no auto-summary
  no synchronization
  network 1.1.1.0 mask 255.255.255.0
  exit-address-family
  !
  address-family ipv4 multicast
  neighbor 172.22.124.2 activate
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family ipv6
  neighbor 2001:22:83::3 activate
  neighbor 2001:22:83::3 next-hop-self
  neighbor 2005:22:124::2 activate
  network 2006:1:1::/128
  exit-address-family
!
!
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
ip pim send-rp-announce Loopback2 scope 1 interval 5
ip pim send-rp-discovery Loopback0 scope 5
ip msdp peer 172.22.124.2 remote-as 100
!
ip access-list standard LOOPFREE-RIP-ROUTES
  permit 172.22.34.0
  permit 172.22.0.0
  permit 172.22.83.0
!
ipv6 router ospf 1
  router-id 1.1.1.1
  log-adjacency-changes
  area 13 virtual-link 3.3.3.3
!
!
route-map RIP2OSPF permit 10
  set tag 111
!
route-map OSPF2RIP deny 10
  match tag 333 444
!
route-map OSPF2RIP permit 20
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
!
end

###############
# Device R2 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 172.22.82.1 255.255.255.192
  ip pim sparse-dense-mode
  ip ospf network point-to-point
  ipv6 address 2001:22:82::2/64
  ipv6 rip R2-RIP enable
!
interface Loopback1
  ip address 2.2.2.2 255.255.255.0
  ipv6 address 2006:2:2::/128
!
interface Loopback2
  ip address 223.255.255.254 255.255.255.255
  ip pim sparse-dense-mode
!
interface FastEthernet0/0
  ip address 172.22.5.2 255.255.255.0
  ip pim sparse-dense-mode
  speed 100
  full-duplex
  ipv6 address 2005:22:5::2/64
  ipv6 address FE80::2 link-local
  ipv6 rip R2-RIP enable
  no shutdown
!
interface Serial0/0
  ip address 172.22.124.2 255.255.255.224
  ip pim dr-priority 0
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf authentication
 ip ospf authentication-key CISCO
 ip ospf priority 0
 ipv6 address 2005:22:124::2/64
 ipv6 address FE80::2 link-local
 ipv6 rip R2-RIP enable
 frame-relay map ip 172.22.124.2 221
 frame-relay map ip 172.22.124.4 221 broadcast
 frame-relay map ipv6 2005:22:124::1 221
 frame-relay map ipv6 FE80::1 221
 frame-relay map ip 172.22.124.1 221 broadcast
 no frame-relay inverse-arp
 no shutdown
!
interface FastEthernet0/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Serial0/1
  no ip address
  shutdown
!
interface Serial0/2
  ip address 172.22.26.2 255.255.255.0
  ip pim sparse-dense-mode
  ipv6 address 2005:22:26::2/64
  ipv6 address FE80::2 link-local
  ipv6 rip R2-RIP enable
  clock rate 128000
  no shutdown
!
router eigrp 100
  redistribute ospf 1 metric 32 1000 255 1 1500 route-map OSPF2EIGRP
  network 172.22.5.0 0.0.0.255
  network 172.22.26.0 0.0.0.255
  no auto-summary
  eigrp router-id 2.2.2.2
!
router ospf 1
  router-id 2.2.2.2
  log-adjacency-changes
  redistribute eigrp 100 metric 75000 metric-type 1 subnets route-map
EIGRP2OSPF
  network 172.22.82.1 0.0.0.0 area 0
  network 172.22.124.2 0.0.0.0 area 0
  network 223.255.255.254 0.0.0.0 area 0
!
router bgp 100
  bgp router-id 2.2.2.2
  bgp log-neighbor-changes
  neighbor 2001:22:86::6 remote-as 100
  neighbor 2001:22:86::6 update-source Loopback0
  neighbor 2005:22:124::1 remote-as 200
 neighbor 172.22.86.1 remote-as 100
 neighbor 172.22.86.1 update-source Loopback0
 neighbor 172.22.124.1 remote-as 200
 !
 address-family ipv4
 no neighbor 2001:22:86::6 activate
 no neighbor 2005:22:124::1 activate
 neighbor 172.22.86.1 activate
 neighbor 172.22.124.1 activate
 no auto-summary
 no synchronization
 network 2.2.2.0 mask 255.255.255.0
 exit-address-family
 !
 address-family ipv4 multicast
 neighbor 172.22.124.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:22:86::6 activate
 neighbor 2005:22:124::1 activate
 network 2006:2:2::/128
 exit-address-family
!
!
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
ip pim send-rp-announce Loopback2 scope 1 interval 5
ip pim send-rp-discovery Loopback0 scope 5
ip msdp peer 172.22.124.1 remote-as 200
!
ip access-list standard EIGRP-ROUTES-ONLY
  permit 172.22.86.0 0.0.0.255
  permit 172.22.26.0 0.0.0.255
  permit 172.22.36.0 0.0.0.255
  permit 172.22.4.0 0.0.1.255
  permit 139.100.1.0 0.0.0.255
!
ipv6 router rip R2-RIP
!
!
route-map OSPF2EIGRP deny 10
  match ip address EIGRP-ROUTES-ONLY
!
route-map OSPF2EIGRP permit 9999
!
route-map EIGRP2OSPF permit 10
  match ip address EIGRP-ROUTES-ONLY
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
!
end

###############
# Device R3 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
no ip domain lookup
ip multicast-routing
!
ipv6 unicast-routing
frame-relay switching
!
voice-card 0
  no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 172.22.83.1 255.255.255.0
  ip ospf network point-to-point
  ipv6 address 2001:22:83::3/64
  ipv6 ospf 1 area 0
!
interface Loopback1
  ip address 3.3.3.3 255.255.255.0
  ipv6 address 2006:3:3::/128
!
interface Loopback120
  ip address 172.22.33.3 255.255.255.255
!
interface Tunnel0
  ip address 34.34.34.3 255.255.255.0
  ip pim sparse-dense-mode
  ip ospf message-digest-key 1 md5 CISCO
  ip ospf 1 area 2
  tunnel source Loopback120
  tunnel destination 172.22.44.4
  no shutdown
!
interface Tunnel1
  no ip address
  ipv6 address 2005:22:13::3/64
  ipv6 address FE80::3 link-local
  ipv6 ospf mtu-ignore
  ipv6 ospf 1 area 13
  keepalive 10 3
  tunnel source Loopback0
  tunnel destination 172.22.81.1
  tunnel mode ipv6ip
  no shutdown
!
interface FastEthernet0/0
  ip address 172.22.3.3 255.255.255.0
  ip pim sparse-dense-mode
  speed 100
  duplex full
  ipv6 address 2005:22:3::3/64
 ipv6 address FE80::3 link-local
 no shutdown
!
interface FastEthernet0/1
  ip address 172.22.34.3 255.255.255.0
  ip pim sparse-dense-mode
  speed 100
  duplex full
  no shutdown
!
interface Serial0/0/0
  no ip address
  shutdown
!
interface Serial0/0/1
  no ip address
  shutdown
  clock rate 2000000
!
interface Serial0/1/0
  no ip address
  encapsulation frame-relay
  ipv6 address 2005:22:36::3/64
  ipv6 address FE80::3 link-local
  clock rate 128000
  frame-relay map ipv6 2005:22:36::6 326
  frame-relay map ipv6 FE80::6 326
  frame-relay interface-dlci 326 ppp Virtual-Template1
  no frame-relay inverse-arp
  frame-relay intf-type dce
  no shutdown
!
interface Virtual-Template1
  ip address 172.22.36.3 255.255.255.0
  ip pim sparse-dense-mode
  no shutdown
!
router eigrp 100
  redistribute ospf 1 metric 16 1000 255 1 1500 route-map OSPF2EIGRP
  network 172.22.36.0 0.0.0.255
  no auto-summary
  eigrp router-id 3.3.3.3
!
router ospf 1
  router-id 3.3.3.3
  log-adjacency-changes
  area 2 authentication message-digest
  area 2 virtual-link 4.4.4.4
  redistribute rip metric 50000 subnets tag 333 route-map NO_RIP_SUMMARY
  redistribute eigrp 100 metric 75000 metric-type 1 subnets route-map
EIGRP2OSPF
  network 172.22.3.3 0.0.0.0 area 3
  network 172.22.83.1 0.0.0.0 area 3
  distance 255 0.0.0.0 255.255.255.255 NO_LOOPBACK_120
!
router rip
  version 2
 redistribute ospf 1 metric 5 match internal external 2
 passive-interface FastEthernet0/0
 passive-interface Serial0/1/0
 passive-interface Loopback0
 passive-interface Loopback120
 network 172.22.0.0
 no auto-summary
!
router bgp 200
  bgp router-id 3.3.3.3
  bgp log-neighbor-changes
  neighbor 2001:22:81::1 remote-as 200
  neighbor 2001:22:81::1 update-source Loopback0
  neighbor 2005:22:36::6 remote-as 100
  neighbor 172.22.36.6 remote-as 100
  neighbor 172.22.84.1 remote-as 200
  neighbor 172.22.84.1 update-source Loopback0
  !
  address-family ipv4
  no neighbor 2001:22:81::1 activate
  no neighbor 2005:22:36::6 activate
  neighbor 172.22.36.6 activate
  neighbor 172.22.36.6 route-map LOCAL-PREF in
  neighbor 172.22.84.1 activate
  no auto-summary
  no synchronization
  network 3.3.3.0 mask 255.255.255.0
  exit-address-family
  !
  address-family ipv6
  neighbor 2001:22:81::1 activate
  neighbor 2001:22:81::1 next-hop-self
  neighbor 2005:22:36::6 activate
  network 2006:3:3::/128
  exit-address-family
!
!
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
!
ip access-list standard EIGRP-ROUTES-ONLY
  permit 172.22.86.0 0.0.0.255
  permit 172.22.26.0 0.0.0.255
  permit 172.22.36.0 0.0.0.255
  permit 172.22.4.0 0.0.1.255
  permit 139.100.1.0 0.0.0.255
ip access-list standard NO_LOOPBACK_120
  permit 172.22.44.4
!
!
ip prefix-list NO_RIP_SUMMARY seq 5 permit 172.22.0.0/24
ipv6 router ospf 1
  router-id 3.3.3.3
  log-adjacency-changes
  area 13 virtual-link 1.1.1.1
!
!
route-map NO_RIP_SUMMARY deny 10
  match ip address prefix-list NO_RIP_SUMMARY
!
route-map NO_RIP_SUMMARY permit 9999
!
route-map LOCAL-PREF permit 10
  set local-preference 75
!
route-map OSPF2EIGRP deny 10
  match ip address EIGRP-ROUTES-ONLY
!
route-map OSPF2EIGRP permit 9999
!
route-map EIGRP2OSPF permit 10
  match ip address EIGRP-ROUTES-ONLY
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
scheduler allocate 20000 1000
!
end

###############
# Device R4 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
no ip domain lookup
ip multicast-routing
!
!
voice-card 0
  no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 1 interface Serial0/0/0 line-protocol
!
track 2 interface Serial0/1/0 line-protocol
!
track 3 interface FastEthernet0/1 line-protocol
!
!
!
!
!
interface Loopback0
  ip address 172.22.84.1 255.255.255.0
  ip ospf network point-to-point
!
interface Loopback1
  ip address 4.4.4.4 255.255.255.0
!
interface Loopback120
  ip address 172.22.44.4 255.255.255.255
!
interface Tunnel0
  ip address 34.34.34.4 255.255.255.0
 ip pim sparse-dense-mode
 ip ospf message-digest-key 1 md5 CISCO
 ip ospf 1 area 2
 tunnel source Loopback120
 tunnel destination 172.22.33.3
 no shutdown
!
interface FastEthernet0/0
  ip address 172.22.0.4 255.255.255.192
  ip pim sparse-dense-mode
  speed 100
  duplex full
  glbp 47 ip 172.22.0.30
  glbp 47 weighting 100 lower 90
  glbp 47 weighting track 1 decrement 15
  glbp 47 weighting track 2 decrement 15
  glbp 47 weighting track 3 decrement 15
  no shutdown
!
interface FastEthernet0/1
  ip address 172.22.34.4 255.255.255.0
  ip pim sparse-dense-mode
  ip summary-address rip 172.22.0.0 255.255.255.0
  speed 100
  duplex full
  no shutdown
!
interface Serial0/0/0
  ip address 172.22.124.4 255.255.255.224
  ip pim dr-priority 0
  ip pim sparse-dense-mode
  encapsulation frame-relay
  ip ospf authentication
  ip ospf authentication-key CISCO
  ip ospf priority 0
  frame-relay map ip 172.22.124.2 421 broadcast
  frame-relay map ip 172.22.124.4 421
  frame-relay map ip 172.22.124.1 421 broadcast
  no frame-relay inverse-arp
  no shutdown
!
interface Serial0/0/1
  no ip address
  shutdown
!
interface Serial0/1/0
  ip address 172.22.45.4 255.255.255.0
  ip pim sparse-dense-mode
  ip ospf message-digest-key 1 md5 CISCO
  no shutdown
!
interface Serial0/1/1
  no ip address
  shutdown
!
router ospf 1
  router-id 4.4.4.4
 log-adjacency-changes
 area 2 authentication message-digest
 area 2 virtual-link 3.3.3.3
 area 2 virtual-link 5.5.5.5
 redistribute rip metric 50000 subnets tag 444
 network 172.22.45.4 0.0.0.0 area 2
 network 172.22.84.1 0.0.0.0 area 0
 network 172.22.124.4 0.0.0.0 area 0
 distance 255 0.0.0.0 255.255.255.255 NO_LOOPBACK_120
!
router rip
  version 2
  redistribute ospf 1 metric 5 match internal external 2 route-map
OSPF2RIP
  passive-interface FastEthernet0/0
  passive-interface Serial0/0/0
  passive-interface Serial0/1/0
  passive-interface Loopback0
  network 172.22.0.0
  neighbor 172.22.0.1
  distance 255
  distance 120 172.22.0.1 0.0.0.0
  distance 120 172.22.34.3 0.0.0.0
  no auto-summary
!
router bgp 200
  no synchronization
  bgp router-id 4.4.4.4
  bgp log-neighbor-changes
  network 4.4.4.0 mask 255.255.255.0
  neighbor 172.22.45.5 remote-as 300
  neighbor 172.22.45.5 send-community extended
  neighbor 172.22.45.5 capability orf prefix-list send
  neighbor 172.22.45.5 soft-reconfiguration inbound
  neighbor 172.22.45.5 prefix-list No_55 in
  neighbor 172.22.45.5 filter-list 11 out
  neighbor 172.22.81.1 remote-as 200
  neighbor 172.22.81.1 update-source Loopback0
  neighbor 172.22.81.1 route-reflector-client
  neighbor 172.22.83.1 remote-as 200
  neighbor 172.22.83.1 update-source Loopback0
  neighbor 172.22.83.1 route-reflector-client
  no auto-summary
!
!
ip as-path access-list 11 deny _100$
ip as-path access-list 11 permit .*
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
!
ip access-list standard NO_LOOPBACK_120
  permit 172.22.33.3
!
!
ip prefix-list No_55 seq 5 deny 55.55.55.0/24
ip prefix-list No_55 seq 10 permit 0.0.0.0/0 le 32
!
route-map OSPF2RIP deny 10
  match tag 111
!
route-map OSPF2RIP permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
scheduler allocate 20000 1000
!
end

###############
# Device R5 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 172.22.85.1 255.255.255.0
  ip ospf network point-to-point
!
interface Loopback1
  ip address 5.5.5.5 255.255.255.0
!
interface Loopback55
  ip address 55.55.55.55 255.255.255.0
!
interface FastEthernet0/0
  ip address 172.22.2.5 255.255.255.224
  ip pim sparse-dense-mode
  ip igmp join-group 224.5.5.5
  ip igmp access-group MYGROUPS
  speed 100
  full-duplex
  no shutdown
!
interface FastEthernet0/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface FastEthernet1/0
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Serial1/0
  no ip address
  shutdown
!
interface FastEthernet1/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Serial1/1
  no ip address
  shutdown
!
interface Serial1/2
  ip address 172.22.45.5 255.255.255.0
  ip pim sparse-dense-mode
  ip ospf message-digest-key 1 md5 CISCO
  clock rate 128000
  no shutdown
!
interface Serial1/3
  no ip address
  shutdown
  clock rate 2000000
!
router ospf 1
  router-id 5.5.5.5
  log-adjacency-changes
  area 2 authentication message-digest
  area 2 virtual-link 4.4.4.4
  network 172.22.2.5 0.0.0.0 area 3
  network 172.22.45.5 0.0.0.0 area 2
  network 172.22.85.1 0.0.0.0 area 2
!
router bgp 300
  no synchronization
  bgp router-id 5.5.5.5
  bgp log-neighbor-changes
  network 5.5.5.0 mask 255.255.255.0
  network 55.55.55.0 mask 255.255.255.0
  neighbor 172.22.45.4 remote-as 200
  neighbor 172.22.45.4 capability orf prefix-list receive
  no auto-summary
!
!
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
!
ip access-list standard MYGROUPS
  permit 224.20.73.1 15.128.20.0
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line aux 0
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
!
end

###############
# Device R6 #
###############

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 139.100.1.9
!
ip dhcp pool DHCP-POOL
   network 139.100.1.0 255.255.255.0
   domain-name mypod.com
   dns-server 10.10.10.10 20.20.20.20
   default-router 139.100.1.9
   lease 2
!
!
no ip domain lookup
ip multicast-routing
!
ipv6 unicast-routing
voice-card 0
  no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 172.22.86.1 255.255.255.0
  ipv6 address 2001:22:86::6/64
  ipv6 rip R6-RIP enable
!
interface Loopback1
  ip address 6.6.6.6 255.255.255.0
  ipv6 address 2006:6:6::/128
!
interface GigabitEthernet0/0
  ip address 172.22.4.6 255.255.255.0
  ip pim sparse-dense-mode
  speed auto
  duplex auto
  media-type rj45
  ipv6 address 2005:22:4::6/64
  ipv6 address FE80::6 link-local
  ipv6 rip R6-RIP enable
  no keepalive
  no shutdown
!
interface GigabitEthernet0/1
  no ip address
  shutdown
  speed auto
 duplex auto
 media-type rj45
 no keepalive
!
interface Serial0/0/0
  no ip address
  shutdown
!
interface Serial0/0/1
  no ip address
  shutdown
  clock rate 2016000
!
interface Serial0/0/2
  ip address 172.22.26.6 255.255.255.0
  ip pim sparse-dense-mode
  ipv6 address 2005:22:26::6/64
  ipv6 address FE80::6 link-local
  ipv6 rip R6-RIP enable
  no shutdown
!
interface Serial0/0/3
  no ip address
  encapsulation frame-relay
  ipv6 address 2005:22:36::6/64
  ipv6 address FE80::6 link-local
  ipv6 rip R6-RIP enable
  frame-relay map ipv6 2005:22:36::3 326
  frame-relay map ipv6 FE80::3 326
  frame-relay interface-dlci 326 ppp Virtual-Template1
  no frame-relay inverse-arp
  no shutdown
!
interface FastEthernet1/0
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface FastEthernet1/1
  no ip address
  shutdown
  speed auto
  duplex auto
!
interface Virtual-Template1
  ip address 172.22.36.6 255.255.255.0
  ip pim sparse-dense-mode
  no shutdown
!
router eigrp 100
  network 172.22.4.0 0.0.0.255
  network 172.22.26.0 0.0.0.255
  network 172.22.36.0 0.0.0.255
  network 172.22.86.0 0.0.0.255
  no auto-summary
  eigrp router-id 6.6.6.6
!
router bgp 100
  bgp router-id 6.6.6.6
  bgp log-neighbor-changes
  neighbor 2001:22:82::2 remote-as 100
  neighbor 2001:22:82::2 update-source Loopback0
  neighbor 2005:22:36::3 remote-as 200
  neighbor 172.22.36.3 remote-as 200
  neighbor 172.22.82.1 remote-as 100
  neighbor 172.22.82.1 update-source Loopback0
  !
  address-family ipv4
  no neighbor 2001:22:82::2 activate
  no neighbor 2005:22:36::3 activate
  neighbor 172.22.36.3 activate
  neighbor 172.22.82.1 activate
  no auto-summary
  no synchronization
  network 6.6.6.0 mask 255.255.255.0
  exit-address-family
  !
  address-family ipv6
  neighbor 2001:22:82::2 activate
  neighbor 2005:22:36::3 activate
  network 2006:6:6::/128
  exit-address-family
!
!
!
ip http server
no ip http secure-server
ip pim spt-threshold 1000
!
ipv6 router rip R6-RIP
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
  stopbits 1
line aux 0
  stopbits 1
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
scheduler allocate 20000 1000
!
end

###############
# Device S1 #
###############

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
!
no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
!
macro name test
do ping 172.22.81.1
do ping 172.22.0.1
do ping 172.22.124.1
do ping 172.22.82.1
do ping 172.22.5.2
do ping 172.22.124.2
do ping 172.22.26.2
do ping 172.22.83.1
do ping 172.22.3.3
do ping 172.22.34.3
do ping 172.22.36.3
do ping 172.22.84.1
do ping 172.22.0.4
do ping 172.22.34.4
do ping 172.22.124.4
do ping 172.22.45.4
do ping 172.22.85.1
do ping 172.22.2.5
do ping 172.22.45.5
do ping 172.22.86.1
do ping 172.22.4.6
do ping 172.22.26.6
do ping 172.22.36.6
do ping 139.100.1.9
do ping 172.22.4.9
do ping 34.34.34.3
do ping 34.34.34.4
@
!
macro global description test | test
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
  description R1-Fa0/0
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/2
  description R2-Fa0/0
  switchport access vlan 2
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/3
  description R3-Fa0/0
  switchport access vlan 3
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/4
  description R4-Fa0/0
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/5
  description R5-Fa0/0
  switchport access vlan 5
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/6
  switchport mode dynamic desirable
!
interface FastEthernet0/7
  description R7-FS-Fa0/0
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/8
  switchport mode dynamic desirable
!
interface FastEthernet0/9
  switchport mode dynamic desirable
!
interface FastEthernet0/10
  switchport mode dynamic desirable
!
interface FastEthernet0/11
  switchport mode dynamic desirable
!
interface FastEthernet0/12
  description Dot1q Trunk to S3
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/13
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/14
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/15
  switchport mode dynamic desirable
!
interface FastEthernet0/16
  switchport mode dynamic desirable
!
interface FastEthernet0/17
  switchport mode dynamic desirable
!
interface FastEthernet0/18
  switchport mode dynamic desirable
!
interface FastEthernet0/19
  switchport mode dynamic desirable
!
interface FastEthernet0/20
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/21
  switchport mode dynamic desirable
!
interface FastEthernet0/22
  description Dot1q Trunk to S2
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/23
  description Dot1q Trunk to S2
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/24
  description Dot1q Trunk to S2
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/1
  switchport mode dynamic desirable
!
interface GigabitEthernet0/2
  switchport mode dynamic desirable
!
interface Vlan1
  no ip address
  shutdown
!
interface Vlan34
  ip address 172.22.34.7 255.255.255.0
  no shutdown
!
router rip
  version 2
  network 172.22.0.0
  no auto-summary
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
end

###############
# Device S2 #
###############

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S2
!
!
no aaa new-model
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
macro name test
do ping 172.22.81.1
do ping 172.22.0.1
do ping 172.22.124.1
do ping 172.22.82.1
do ping 172.22.5.2
do ping 172.22.124.2
do ping 172.22.26.2
do ping 172.22.83.1
do ping 172.22.3.3
do ping 172.22.34.3
do ping 172.22.36.3
do ping 172.22.84.1
do ping 172.22.0.4
do ping 172.22.34.4
do ping 172.22.124.4
do ping 172.22.45.4
do ping 172.22.85.1
do ping 172.22.2.5
do ping 172.22.45.5
do ping 172.22.86.1
do ping 172.22.4.6
do ping 172.22.26.6
do ping 172.22.36.6
do ping 139.100.1.9
do ping 172.22.4.9
do ping 34.34.34.3
do ping 34.34.34.4
@
!
macro global description test
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
  switchport mode dynamic desirable
!
interface FastEthernet0/2
  switchport mode dynamic desirable
!
interface FastEthernet0/3
  description R3-Fa0/1
 switchport access vlan 34
 switchport mode access
 speed 100
 duplex full
!
interface FastEthernet0/4
  description R4-Fa0/1
  switchport access vlan 34
  switchport mode access
  speed 100
  duplex full
!
interface FastEthernet0/5
  switchport mode dynamic desirable
!
interface FastEthernet0/6
  switchport mode dynamic desirable
!
interface FastEthernet0/7
  switchport mode dynamic desirable
!
interface FastEthernet0/8
  switchport mode dynamic desirable
!
interface FastEthernet0/9
  switchport mode dynamic desirable
!
interface FastEthernet0/10
  switchport mode dynamic desirable
!
interface FastEthernet0/11
  switchport mode dynamic desirable
!
interface FastEthernet0/12
  description Dot1q Trunk to S4
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/13
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/14
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/15
  switchport mode dynamic desirable
!
interface FastEthernet0/16
  switchport mode dynamic desirable
!
interface FastEthernet0/17
  switchport mode dynamic desirable
!
interface FastEthernet0/18
  switchport mode dynamic desirable
!
interface FastEthernet0/19
  switchport mode dynamic desirable
!
interface FastEthernet0/20
  switchport mode dynamic desirable
  shutdown
!
interface FastEthernet0/21
  switchport mode dynamic desirable
!
interface FastEthernet0/22
  description Dot1q Trunk to S1
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/23
  description Dot1q Trunk to S1
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface FastEthernet0/24
  description Dot1q Trunk to S1
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/1
  switchport mode dynamic desirable
!
interface GigabitEthernet0/2
  switchport mode dynamic desirable
!
interface Vlan1
  no ip address
  shutdown
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
end
###############
# Device S3 #
###############

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S3
!
!
no aaa new-model
vtp domain CCIE
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
!
macro name test
do ping 172.22.81.1
do ping 172.22.0.1
do ping 172.22.124.1
do ping 172.22.82.1
do ping 172.22.5.2
do ping 172.22.124.2
do ping 172.22.26.2
do ping 172.22.83.1
do ping 172.22.3.3
do ping 172.22.34.3
do ping 172.22.36.3
do ping 172.22.84.1
do ping 172.22.0.4
do ping 172.22.34.4
do ping 172.22.124.4
do ping 172.22.45.4
do ping 172.22.85.1
do ping 172.22.2.5
do ping 172.22.45.5
do ping 172.22.86.1
do ping 172.22.4.6
do ping 172.22.26.6
do ping 172.22.36.6
do ping 139.100.1.9
do ping 172.22.4.9
do ping 34.34.34.3
do ping 34.34.34.4
@
!
macro global description test | test | test
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2-3,5-6
!
vlan 11
   private-vlan isolated
!
vlan 22
   private-vlan community
!
vlan 33
   private-vlan primary
   private-vlan association 11,22
!
vlan 34
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
  description R6-G0/0
  switchport access vlan 6
  switchport mode access
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
  description MAIL SERVER
  switchport private-vlan mapping 33 11,22
  switchport mode private-vlan promiscuous
!
interface GigabitEthernet0/9
  description CLIENT-A
  switchport private-vlan host-association 33 11
  switchport mode private-vlan host
!
interface GigabitEthernet0/10
  description CLIENT-B
  switchport private-vlan host-association 33 11
  switchport mode private-vlan host
!
interface GigabitEthernet0/11
  description CLIENT-E
  switchport private-vlan host-association 33 22
  switchport mode private-vlan host
!
interface GigabitEthernet0/12
  description Dot1q Trunk to S1
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/13
  shutdown
!
interface GigabitEthernet0/14
  shutdown
!
interface GigabitEthernet0/15
  description Dot1q Trunk to S4
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/16
  shutdown
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
  shutdown
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
  no ip address
  shutdown
!
interface Vlan6
  ip address 172.22.4.9 255.255.255.0
  no shutdown
!
interface Vlan33
  ip address 139.100.1.9 255.255.255.0
  ip helper-address 172.22.4.6
  private-vlan mapping 11,22
  no shutdown
!
router eigrp 100
  network 139.100.1.0 0.0.0.255
  network 172.22.4.0 0.0.0.255
  no auto-summary
  eigrp router-id 9.9.9.9
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
end

###############
# Device S4 #
###############

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S4
!
!
no aaa new-model
vtp domain CCIE
vtp mode transparent
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
macro name test
do ping 172.22.81.1
do ping 172.22.0.1
do ping 172.22.124.1
do ping 172.22.82.1
do ping 172.22.5.2
do ping 172.22.124.2
do ping 172.22.26.2
do ping 172.22.83.1
do ping 172.22.3.3
do ping 172.22.34.3
do ping 172.22.36.3
do ping 172.22.84.1
do ping 172.22.0.4
do ping 172.22.34.4
do ping 172.22.124.4
do ping 172.22.45.4
do ping 172.22.85.1
do ping 172.22.2.5
do ping 172.22.45.5
do ping 172.22.86.1
do ping 172.22.4.6
do ping 172.22.26.6
do ping 172.22.36.6
do ping 139.100.1.9
do ping 172.22.4.9
do ping 34.34.34.3
do ping 34.34.34.4
@
!
macro global description test
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2-3,5-6
!
vlan 22
  private-vlan isolated
!
vlan 33
  private-vlan primary
  private-vlan association 22
!
vlan 34
!
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
  description CLIENT-C
  switchport private-vlan host-association 33 22
  switchport mode private-vlan host
!
interface GigabitEthernet0/9
  description CLIENT-D
  switchport private-vlan host-association 33 22
  switchport mode private-vlan host
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
  description Dot1q Trunk to S2
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/13
  shutdown
!
interface GigabitEthernet0/14
  shutdown
!
interface GigabitEthernet0/15
  description Dot1q Trunk to S3
  switchport trunk encapsulation dot1q
  switchport mode trunk
!
interface GigabitEthernet0/16
  shutdown
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
  shutdown
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
  no ip address
  shutdown
!
interface Vlan33
  ip address dhcp
  no shutdown
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line vty 0 4
  password cisco
  login
line vty 5 15
  password cisco
  login
!
end

								
To top