Docstoc

lab14-fragstats-hawthstools

Document Sample
lab14-fragstats-hawthstools Powered By Docstoc
					RESM 575 Spatial Analysis

Lab 14              Fragstats and Hawth’s Tools


This lab is designed to get you familiar in using two very useful software products called
Fragstats and Hawth’s Tools for doing spatial analysis. There are many different components
to these software products that you can explore more on your own if you are interested. For
today’s lab, we will focus on some of the more common uses.

Part A. Fragstats
Part B. Hawth’s Tools


Part A. Fragstats

As introduced in the class lecture, Fragstats is a very powerful landscape analysis program that
runs with spatial data to calculate many metrics that can be compared or used to increase the
spatial models that you build for a study area. This part A of the lab will show you how to
Download and Install Fragstats, Extract Land Cover and Create a Study Area, Set Parameters,
Select Metrics, and Run and Decipher Results.


Step 1. Downloading and installing Fragstats

          □ Point your internet browser to the following website below

http://www.umass.edu/landeco/research/fragstats/fragstats.html

Or, if you Google on “Fragstats” it will be the first item to appear on the search list.

          □ Once on the website, select Downloads and look for the file called
            FragSetup33.zip. Right click on this file and save or copy it to the c:/temp folder.

          □ Once the file has been downloaded, go to the c:/temp folder and extract all the files
            by double clicking on the zip file. Allow the extraction program to create a folder
            called Fragstats33 in the c:/temp directory. If you are having trouble extracting the
            file, look in the up left corner off the display for something that says “Extract all
            Files.”

          □ If you have done everything correct, you should see a file in the c:/temp/Fragstats33
            folder or wherever you extracted the files called Fragstats.exe. If you don’t see
            the exe extension on the Fragstats file name, look for the type of file to say
            application. When you double click on this file, you should see the Fragstats
            program start up as shown on the next page.




RESM 575 Spatial Analysis                     Lab 14                                               1
If you are not able to get to this point, please raise your hand and I will try to help you.

You may close Fragstats because we won’t need it again until step 3 of this lab.



Step 2. Extract Land Cover and Create a Study Area

Fragstats is not a GIS program, so you can’t display, query, or do any spatial queries with it.
You will need to use ArcMap with the Spatial Analyst extension to create a grid for running
Fragstats.

          □ Open ArcMap and make sure the Spatial Analyst extension is turned on and the
            toolbar is added to ArcMap.

          □ Go to the c:/temp/gisdata/grids/nlcd directory and add the Land Cover, NLCD
            2001.lyr grid to ArcMap. This is a statewide grid of landcover from for WV. For
            this example we will use it since it has fewer land cover features to work with and
            will make this example and introduction to Fragstats easier.




          □ You should also add the public_land.shp found in the c:/temp/gisdata/data_wv/
            directory.


RESM 575 Spatial Analysis                    Lab 14                                               2
          □ Select the Pruntytown WMA by either opening the table for the publand shapefile
            and selecting the record or by using the Select by Attributes … under the Selection
            pull down menu choice. Once you have the Pruntytown WMA selected, convert it
            its own shapefile boundary by right clicking on the publand shapefile and choose
            Data -> Export Data… exporting to shapefile. You may call the new shapefile
            ptownwma and place it in the c:/temp or another folder under your name.




          □ Choose Yes to add the shapefile to your ArcMap display.




          □ With the ptownwma shapefile added to your view, right click on the shapefile name
            and select Zoom to Layer.

          □ Change the fill of the polygon of the layer so you can see the land cover underneath
            as shown below.




Our goal is to create a grid of land cover just for the Pruntytown WMA and perform some
landscape metrics. To create the grid, we need to use the Spatial Analyst toolbar and select



RESM 575 Spatial Analysis                   Lab 14                                             3
Options to set the analysis mask, analysis extent, and analysis cell size as shown below. Please
ask me if you have a question about this step.




          □ With these options set, we now can use the Raster Calculator found in the Spatial
            Analyst pulldown toolbar to make a copy of the epamrlc93. Because the options
            were set above, the result will give us a copy of the epamrlc93 grid but just for the
            Pruntytown WMA polygon we created. We used the polygon boundary to “mask
            out” the statewide grid we did not want.




If you did everything correctly, you should have a grid of landcover just for the Pruntytown
WMA as shown below called Calculation.




The “Calculation” grid you just created is a temporary grid meaning that if you closed
ArcMap, it would delete itself. Since we want to use this grid for use in Fragstats, right click
on the Calculation grid and Make Permanent by saving it as ptowngrid in the
c:/temp/yourname folder.


RESM 575 Spatial Analysis                    Lab 14                                                 4
IMPORTANT: Before leaving ArcMap and using Fragstats, make note of the different values
in the ptowngrid layer. (it may still say Calculation in your table of contents).




                             These numbers correspond to the
                             landcover classes found in this study
                             area.




RESM 575 Spatial Analysis               Lab 14                                            5
You should make note of these numbers and land cover types somewhere for future reference
when using Fragstats. To find out what the 21, 41, 81, 82 values correspond to, you need to
open the layer properties of the Land Cover, NLCD 2001 grid which should still be in your
ArcMap table of contents.




We see from the above that:

21 is for developed, open space
41 is for deciduous forest
81 is for pasture/hay
82 is for cultivated crops


Ok, that is it for this step. On to Fragstats.



Step 3. Setting the Parameters in Fragstats.

          □ If you don’t have Fragstats running, navigate to the location in which you extracted
            the c:/temp/Fragstats33 folder or wherever you extracted the files called
            Fragstats.exe. If you don’t see the exe extension on the Fragstats file name, look
            for the type of file to say application. When you double click on this file, you
            should see the Fragstats program start up as shown on the next page.




RESM 575 Spatial Analysis                        Lab 14                                        6
          □ The first step to use Fragstats is to specify the Run Parameters.

          □ Under the Fragstats menu choice, select Set Run Parameters.




          □ Change the Input Data Type to Arc Grid

The ASCII file name input box in the top left will change to Grid Name.




RESM 575 Spatial Analysis                    Lab 14                             7
          □ Specify the Grid name to the grid we created for the Prunytown WMA. I called
            mine ptowngrid and put it in the c:/temp/mike2 folder

          □ Specify a “basename” for the output files by clicking on the Output File button and
            navigating to the desired folder, and then entering a “basename” or selecting an
            existing file to overwrite. This basename will be given the extensions .patch, .class,
            .land and .adj for the corresponding patch, class, and landscape metrics and
            adjacency matrix. I decided to name mine Run1 and I put it in the same directory
            as the ptowngrid, in my case this is the c:/temp/mike2 folder.

Class Properties file

To create the class properties, file, we need to make a text file in notepad (Start Button -> All
Programs -> Accessories -> Notepad) that contains four different items of information.

The syntax for this comma-delimited ASCII file is as follows:

ClassID, ClassName, Status, isBackground

ClassID is an integer value corresponding to a class value in the landscape.

ClassName is a descriptive name of the class; descriptive names can be any length and contain
any characters, including spaces, but cannot include commas. This descriptive name is reported
in all patch and class output files for the variable TYPE.

Status can take on the values: true, or t; and false, or f., and determines whether the
corresponding class should be processed and added to the results or simply ignored in the
output files. A “true” or “t” indicates that the class is enabled and should be output in the patch


RESM 575 Spatial Analysis                    Lab 14                                                 8
and class output files. A “false” or “f” indicates that the class is disabled and should not be
output. Note, class status does not effect the computation of landscape metrics; disabled
classes are still included, as necessary, in the computation of landscape metrics. Although
there is some savings of computer processing by disabling a class, the primary effect is on the
output. This feature allows you to “turn off” classes that you are not interested in so that you
don’t have to view their statistics in the output files.

isBackground can take on the values: true, or t; and false, or f, and determines whether the
corresponding class should be reclassified and treated as background (i.e., assigned the
background value specified in the Grid Attributes. Note, classifying a class as background will
have an effect on many landscape metrics (see Overview discussion).

The class properties file should contain a record for each class in the input landscape, and all
arguments should be separated by a comma or space(s).

For example, in this lab exercise in step 2 we found that for ptowngrid;

21 is for developed, open space
41 is for deciduous forest
81 is for pasture/hay
82 is for cultivated crops

We need to create a file in notepad that has the following information:

21, developed open space, false, false
41, deciduous forest, true, false
81, pasture hay, false, false
82, cultivated crops, false, false

In notepad, the file looks like this:




Because, deciduous forest is assigned a true for the status, I am most interested in the patterns
with this type only.




RESM 575 Spatial Analysis                   Lab 14                                                  9
I will save this information as an fdc file in Notepad by choosing Save as and changing the file
type to All files and putting the fdc extension to my file name called propfilerun1

Note, FRAGSTATS uses the file extension .fdc for class properties files and will look for files
with this extension by default when navigating. The .fdc extension is not mandatory, but using
it can help keep files organized.




RESM 575 Spatial Analysis                  Lab 14                                             10
In summary, the class properties file allows you to do three things: (1) specify character
descriptors for each class in order to facilitate interpretation of the output files, (2) limit the
output files to only the classes of interest, and (3) reclassify classes to background.

Keep the rest of the options default for now. You can read more about the other options on the
Fragstats website if you want.



Step 4. Select Metrics

Ok, we are almost there. In this step we will select the metrics we want Fragstats to calculate.
As I have mentioned, there are many, many, many metrics that Fragstats calculates. In the
lecture I gave you a slide outlining how to select a particular metric to calculate. Another way
is to look at refereed journal articles to determine what has been done and made sense in
other’s work.

In this lab exercise, we will calculate some of the more common landscape metrics that are
found in papers ranging from wildlife modeling, landscape ecology, forestry and ecosystem
modeling. They include the Number of patches, Total edge, Total core area, and the
Shannon’s diversity index.

          □ These are all Landscape metrics so you should check the Landscape box as shown
            below.




RESM 575 Spatial Analysis                     Lab 14                                                  11
          □ Next, on the Fragstats window, select the Select Land Metrics (since we want to
            calculate these metrics for our entire study area or the entire landscape).

          □ On the Area/Density/Edge tab, check the box for the Number of Patches (NP), Total
            Edge (TE) and Count all as edge.




          □ Under the Core Area tab, check the Total Core Area (TCA) box and Use fixed edge
            depth of 30 (since our grid cell size is 30).




RESM 575 Spatial Analysis                  Lab 14                                             12
          □ Using the Diversity tab, check the box for the Shannon’s Diversity Index (SHDI).




TIP: it is always a good idea to write down or keep note of the abbreviations for the metrics
you want to calculate. This way it makes it easier to find them in the output. Our four metrics
and associated abbreviations are listed below:

NP        =         Number of patches
TE        =         Total edge
TCA       =         Total core area
SHDI      =         Shannon’s diversity index




Step 5. Running and Deciphering the Results


Running Fragstats is easy once you put all the work into setting it up.

          □ To run Fragstats, after you have selected all the metrics you want, simply choose
            Execute from the Fragstats pulldown menu choice.

If all is good, you will get a message indicating that the execution finished.




RESM 575 Spatial Analysis                       Lab 14                                          13
To examine our output, we have to remember the output files we specified. Back in step 3 we
called the file run1 which will be given the extensions .patch, .class, .land and .adj for the
corresponding patch, class, and landscape metrics and adjacency matrix.

Since we only calculated landscape metrics, we will only have a run1.land file. The run1.adj
is always calculated but will have little use to us in this lab.




There are many ways to view the output file run1.land. You can open it in Microsoft Word,
Notepad, Excel or by using the Browse Results icon on the Fragstats interface.




This allows you to see the numbers for this particular run.

          □ You may have to hit the Land tab because we only calculated landscape metrics.




RESM 575 Spatial Analysis                  Lab 14                                            14
This output is for the landscape. It is useful to compare different landscapes and relate the
information to habitat or species requirements. You may want to look at two different land
cover grids over time for a study area or compare metrics across different areas to rate or
quantify one location being more suitable than another.

These metrics can also be calculated for various buffer zones around species and to test for
correlations on the species distributions.

Try going back into the Run Parameters and select other output statistics for class and patch
metrics or alter the Class properties file by saying true for more land cover types in the status
line.

You may also want to create an output grid to view the patches in ArcMap. To do this, make
sure to highlight the Create and Output Id Image. This will create a grid that can be added to
ArcMap.




This will create an output grid as noted in the Fragstats Event log.

When added to ArcMap, we can view the patches by making the legend display unique values.




RESM 575 Spatial Analysis                   Lab 14                                              15
Part B. Hawth’s Tools

Hawth’s tools is a free ArcGIS 9 extension that is available from the
www.spatialhydrology.com website. I have already downloaded this extension and installed it
on the machines in room 317 Percival.

Step 1.
          □ Make sure the extension is turned on in ArcMap by checking Tools ->
            Extensions….




          □ The Spatial Analyst extension should also be turned on as well.

          □ The toolbar can be added by choosing View -> Toolbars and making sure there is a
            check next to Hawth’s tools. The toolbar looks like the one below.




RESM 575 Spatial Analysis                   Lab 14                                        16
Step 2. Load Point Data

The animal movement tools in Hawth’s tools for minimum convex polygon and Kernal density
require point locations.

          □ Go to the RESM 575 class website and on the class schedule for today’s date you
            will find a zip file called speciespoints2.zip.

          □ Download this file to your c:/temp/yourname folder or the c:/temp folder and
            extract all the files into the same folder

          □ Add this speciespoints shapefile to your ArcMap display.



Step 3. Calculating Minimum Convex Polygons

          □ Select the Create Minimum Convex Polygons from the Hawth’s Tools menu.




          □ Specify the point locations layer as the speciespoitns2 and provide a name for the
            output polygon it will create.




RESM 575 Spatial Analysis                   Lab 14                                               17
Your result should look like the one below.




Note that with this polygon, you could use it to clip the land cover and investigate any
landscape metrics that may be unique for this area of most common use by the species.


Step 4. Calculating Kernal Density

The Kernal Density Estimator is found in Hawth’s tools under the Kernal Tools (duh).




RESM 575 Spatial Analysis                  Lab 14                                          18
          □ Specify the dialog values for this example as shown below. We want to create the
            percent contours for 50, 90, and 95.




RESM 575 Spatial Analysis                  Lab 14                                          19
          □ To view the results, you will have to add the kde grid, and three shapefiles (one for
            each of the 50, 90, and 95 percentiles) from the directory you specified as the output
            folder.

Your display should look like the one below if you change the color ramp and make the lines
darker to see them better.




Try it again but this time use one of the landscape metric weights which were calculated for
each of these points such as dis2nhd (distance of points to a water feature).

Does the kernel density change significantly (for the 90 or 95 percentile)?




RESM 575 Spatial Analysis                    Lab 14                                            20
Assignment

RESM 575 Advanced Spatial Analysis

Lab 14              Fragstats and Hawth’s Tools

Assigned:           Monday April 19
Due:                not graded


30 total points

Question 1.
When calculating the kernel density on the previous page, did the kernel density change
significantly (for the 90 or 95 percentile)? Explain.


Question 2.
Calculate the same landscape metrics you found for Pruntytown WMA but this time calculate
them for Handley WMA (it is also found in the publicland.shp). Print the output for each and
turn it in with this assignment.


Question 3.
Discuss in a paragraph the major landscape differences (if any) between these two WMAs.


Question 4.
Find the FRAGSTATS manual on the www and discuss how the Shannon’s Diversity Index is
calculated.


Question 5.
Can you think of any particular species that may prefer one WMA over the other due to habitat
preferences?


Question 6.
Explain how ArcGIS and Fragstats was used in the Kie et al. (2005) paper on the class website.




RESM 575 Spatial Analysis                     Lab 14                                       21

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:94
posted:5/25/2011
language:English
pages:21