Sup RP Maya Guide

Document Sample
Sup RP Maya Guide Powered By Docstoc
					                                            Rapid Prototyping Service
ADVANCED MEDIA STUDIO New York University


                                            	
                                            .. Maya VRML Output
                                            AMS Supplementary Service Guide
                                            www.nyu.edu/its/ams
                                            its.rp@nyu.edu




                                            Notes for NURBS Models                                           Checking Surface Normals


                                            To increase the quality of VRML output of NURBS models,          Check for proper orientation of surface normals.
                                            add Isoparms to the object, particu-
                                            larly in areas of high curvature.                                                     1. Select all Surfaces (Polygon or
                                                                                                                                  NURBS).
                                            1. Right-click on the model and                                                       2. Go to the ‘Display’ menu and choose
                                            select ‘Isoparms.’                                                                    either ‘NURBS components’ or ‘Polygon
                                            2. Hold ‘shift,’ left-click and drag                                                  components’ and select ‘Normals.’
                                            from existing isoparms (highlighted                                                   3. All lines indicating normals should
                                            in cyan) to create new isoparms (in                                                   point outside and not towards the inside
                                            yellow). Do this for both U and V                                                     of the model.
                                            directions.
                                            3. While the new isoparms are still                                                   Exporting VRML Files
                                            yellow, go to the ‘Edit NURBS’
                                            menu and choose ‘Insert Isoparms.’                                                    To export VRML files the built-in plug-in
                                                                                                                                  must first be activated and loaded.
                                            Manually convert the NURBS
                                            model to polygons to control tessel-                                                  1. Go to the ‘Window’ menu select
                                            lation.                                                                               ‘Settings/Preference’ and choose ‘Plug-in
                                                                                                                                  Manager.’
                                            1. Select the parts to convert to                                                     2. Check the ‘loaded’ and ‘auto load’
                                            polygons.                                                                             check boxes next to the ‘vrml2export.lib’
                                            2. Go to the ‘Modify’ menu, select                                                    plug-in.
                                            ‘convert’ and choose ‘NURBS to
                                            polygons.’                                                                            Export VRML files using the default set-
                                            3. In the options dialogue box, set                                                   tings, then convert the attached texture
                                            ‘Type’ to ‘quads,’ ‘Tessellation                                                      file into JPEG file format (if applicable).
                                            Method’ to ‘count,’ and set a num-                                                    The VRML file will require editing to
                                            ber for count (will depend on                                                         reference the new JPEG texture file.
                                            model).
                                            4. The convert to polygons function                                                   1. Go to the ‘File’ menu and choose ‘Ex-
                                            duplicates the selected parts, so go                                                  port All’ or ‘Export Selection,’ select
                                            back and remove all NURBS com-                                                        ‘vrml2’ and save the file.
                                            ponents.                                                                              2. Open the VRML2 file (.wrl) using
                                                                                                                                  ‘Text Edit’ or ‘Notepad’ and do a ‘Find
                                            Notes on Boolean Operations                                                           and Replace’. Replace the original tex-
                                                                                                                                  ture file paths with just the texture file
                                            Polygon models built using Boolean                                                    names and extensions (no path).
                                            operations will not print until con-                                                  3. Place the original texture files in the
                                            verted to polygonal surfaces.                                                         same folder as the .wrl (should be jpeg).

                                            1. Select any polygon components
                                            built with Boolean operations.
                                            2. Go the the ‘Modify’ menu, ‘Con-
                                            vert’, and then choose ‘Displace-
                                            ment to Polygons.’
                                                                                   Maya VRML Output Settings Window

				
DOCUMENT INFO
Shared By:
Tags: maya
Stats:
views:3
posted:3/30/2011
language:English
pages:1