Docstoc

White Paper

Document Sample
White Paper Powered By Docstoc
					  www.translationzone.com -> Downloads




                                                                     White Paper


TTX Compatibility Guide for SDL Trados
Studio 2009 Users

This guide is designed to advise SDL Trados Studio 2009 users
on best practices when working with the legacy TRADOStag
XML (TTX) and bilingual RTF format produced by previous
SDL Trados versions. We will look at various scenarios and
provide extensive information on how to make best use of
the many new Studio features while still being able to satisfy
your customer requirements in terms of providing backward
compatible TTX files and translation memories while your
customers are still requiring these legacy formats.
In this guide, it is assumed that the reader is familiar with
both SDL Trados 2007 and SDL Trados Studio 2009, above all
in terms of the bilingual file formats and batch processing
concepts used.



                                                                 Daniel Brockmann
                                                                 Senior Product Manager
                                                                 SDL TRADOS Technologies
 www.sdl.com
    Background Information - SDL Trados 2007 and Its Use of TTX and Bilingual
    RTF vs. SDL Trados Studio 2009 and Its Use of SDLXLIFF

    SDL Trados 2007 featured two main ways of working:

    •	 When pre-translating files in SDL Translator's Workbench or SDL Trados Synergy, or when
       opening files for translation in SDL Trados TagEditor, the file was converted to a bilingual
       format for translation. This file format was referred to as TTX (TRADOStag XML).

    •	 When using SDL Trados Translator’s Workbench with Microsoft Word, all files were
       converted to bilingual Rich Text Format (RTF). If the file was in native Word .doc format, this
       process happened behind the scenes.

    By contrast, in SDL Trados Studio, when you open a document for translation or create a
    project, files are converted to SDLXLIFF, a new generation of a bilingual format that is more
    powerful, flexible and standards-based than TTX. SDLXLIFF stands for SDL XML Localization
    Interchange File Format. It is an XML-based bilingual file format, especially developed for use in
    localization. For more information on XLIFF files, refer to http://xml.coverpages.org/xliff.html.
    SDLXLIFF files are compliant with version 1.2 of the XLIFF standard.

    This guide provides information on how to plug into the SDL Trados 2007 (and earlier) supply
    chain by explaining how to provide TTX files and translation memories to users of the legacy
    SDL Trados product generations wherever required.


    Before Starting: Options for TTX Support in SDL Trados Studio
    2009

    Compatibility Settings for TTX

    SDL Trados Studio 2009 can work with TTX using two modes, a smart tag pairing mode and a
    compatibility mode.

    To get to this setting, with no document or project open in SDL Trados Studio, go to Tools -
    Options - File Types - TRADOStag - Compatibility:




                                                                                Figure 1: Compatibility
                                                                                Settings for TRADOStag
2
In smart tag pairing mode, SDL Trados Studio 2009 attempts to convert tags in the TTX in such
a way that an opening and closing tag in the TTX file becomes a tag pair in SDL Trados Studio,
and also attempts to preserve the semi-WYSIWYG formatting from TTX (                    ). It can
also happen that an opening tag in a TTX file actually does not have a closing tag in the same
segment. Because this is no longer supported in SDL Trados Studio, in such cases Studio will
insert an extra closing tag to ensure the integrity of all tag pairs.




             Figure 2: Tag pairs in TTX after opening a file in Studio using Smart Tag Pairing Mode


This smart tag pairing approach will work in most cases, providing for more user friendly
translation of TTX files. However, in rare instances, the back conversion of TTX files manipulated
in this way may fail. If this is the case, it is recommended to activate the compatibility mode
for TTX as depicted above. In this mode all tags from the TTX files become placeholder tags
( - see picture below) during translation in SDL Trados Studio, so each tag in the TTX file will
correspond to exactly one tag in Studio, with no extra tags inserted. Moreover, formatting from
the source file will not be shown in Studio. This approach ensures the maximum possible tag
integrity and maximum legacy support for TTX:




             Figure 3: Compatibility mode for TTX files using placeholder tags and no formatting

Before you start work on TTX files, it is useful to test TTX compatibility by doing a "dummy"
translation of a representative TTX file from your project. To do this, copy all source segments
to target in Studio (Alt+Shift+Ins), then use the Save As Target command in Studio to produce
both a "translated" version of the TTX file and also a target version of the original file format
from the TTX (referred to as "Original File"). This works for all file formats that are supported in
SDL Trados 2007, including customisable file formats such as XML or SGML. In the latter case,
it is important to ensure that you have access to additional files that are needed for smooth
translation, such as tag settings files (.INI).

                                                                                                       3
                                    Figure 4: Options for saving TTX as target


If saving both output file formats (TRADOStag document and Original File) is possible, you can
use smart tag pairing mode. If not, use the compatibility mode.

Tip 2: Tag Verification Settings

You can fine tune the way tags should be checked in a TTX file by going to Tools - Options - File
Types - TRADOStag - Tag Verification and changing the default settings to your liking.




                           Figure 5: Tag Verification Settings for TRADOStag Files

Scenario 1: Client Sends TTX Files and Would Like TTX Files Back

           Receive a TTX    Open TTX in            Translate the file    Save your work   Finalize
           file                                     in Studio

               •                •                                           •                 •




  This scenario is the most straightforward one. SDL Trados Studio 2009 provides full support
  for TTX files as input and output, so you can easily return TTX files sent to you after doing
  the translation in Studio. You can use both single-file translation (using the Open Document
  command) as well as standard projects (using the New Project command) if you are to working
4
  with multiple TTX files in a bigger project, as itallows you to batch analyze and pre-translate as
  you see fit before working on the files in Studio.
The basic workflow is as follows:
1.    Receive TTX files from customer.
2.    Decide if you wish to use smart tag pairing or full compatibility mode for TTX files and
      define the tag verification settings for TTX (see "Before Starting: Options for TTX Support in
      Studio" above).
3.    In Studio:
   a. Use Open Document for translating single TTX files in Studio, or
   b. Use New Project if you would like to use the project preparation options available in
      Studio if you are dealing with several TTX files and would like to benefit from the rich
      project automation features in Studio, such as doing an analysis prior to translation etc.
      All relevant project automation features are supported not only for source files, but also
      bilingual input files in TTX format.
4.    Translate the file(s) as usual in Editor view.
5.    After translation is finished, use one of the following:
   a. the Save Target As command from the File menu if you would like to save single files as
      target. You can save target files in both TTX or native format or both. (Please note that be
      able to save the target in native format you will need SDL Trados 2007 Suite installed on
      your pc; V.2007 Suite is included in V.2009)




                           Figure 6: Options for saving TTX files as target in Studio

   b. the Finalize batch task if you are in the project context. The Finalize task will produce TTX
      files as target files and put them into the target language folder of your project.
6.    Deliver the translated TTX files back to your customer.

Scenario 2: Client Sends New Source Files and Would Like Translated Files and
TTX Files Back




In this scenario, you can use SDL Trados 2007 Suite to batch convert files to the TTX format, then
SDL Trados Studio 2009 as per scenario 1 above.
The workflow is as follows:
                                                                                                       5
    1.      Receive new source files from customer.
    2.      Batch convert the files to TTX in SDL Trados 2007 Suite. To do this, you typically follow
            these steps:
         a. Start SDL Trados Translator's Workbench.
         b. If you are translating Word documents, select Options - Translation Memory Options
            - Tools and check the TRADOStag XML workflow for Word documents box. This will
            ensure that Word documents (just like any other file type) will be converted to TTX during
            the batch conversion. For more information on file type support in SDL Trados 2007, refer
            to the File Formats Reference Guide shipped with SDL Trados 2007 Suite.
         c. In Translator's Workbench, create a new translation memory with a source and target
            language that match the language direction you want to work with. (You can also re-use
            an existing translation memory with a matching language pair; in this case the TTX file will
            be partially translated after the batch conversion.)
         d. In Translator's Workbench, select Tools -> Translate. Translation will do two things: it will
            convert the files to TTX, and it will set the correct source and target language for later
            translation in Studio. If you leave Segment unknown sentences unchecked and use a new
            translation memory, you will get a "clean" TTX document with just the source document
            converted to TTX.
            (If you want to keep the segmentation fully consistent with SDL Trados 2007 Suite, it may
            make sense to activate the Segment unknown sentences option. However in this case the
            target side in Studio will be populated with copied source segments. To clear these, you
            can use the Clear all draft translations command in Studio.)




             This completes the batch conversion steps in Translator's Workbench. You can now move
             over to Studio as in scenario 1.

4
3.    Decide if you wish to use smart tag pairing or compatibilty mode for TTX files and define
      the tag verification settings for TTX (see "Before Starting: Options for TTX Support in
      Studio" above).
4.    In Studio
   a. Use Open Document for translating single TTX files in Studio, or
   b. Use New Project if you would like to use the project preparation options available in
      Studio if you are dealing with several TTX files and would like to benefit from the rich
      project automation features in Studio, such as doing an analysis prior to translation etc.
      All relevant project automation features are supported not only for source files, but also
      bilingual input files in TTX format.
5.    Translate the TTX file(s) as usual in Editor view.




                                   Figure 7: TTX Document in SDL Trados Studio


6.        After translation is finished, use one of the following:
     a.   the Save Target As command from the File menu if you would like to save single files as
          target. You can save target files in both TTX or native format, or both. This applies to all file
          formats supported by SDL Trados 2007.




                              Figure 8: Options for saving TTX files as target in Studio

     b. the Finalize batch task if you are in the project context. The Finalize task will only produce
        TTX files as bilingual files and put them into the target language folder of your project.     5
         c.   If you wish to batch create native target documents from the TTX files, you can now run
              a batch cleanup in Translator's Workbench in SDL Trados 2007 Suite, as shown below. If
              you select Update TM, then any new translations you did in Studio will also be imported
              into your legacy SDL Trados translation memories, effectively keeping both your new
              Studio and old SDL Trados TMs up to date.




    7.        You are now ready to deliver the translated TTX files and target documents back to your
              customer.

    Scenario 2 can also be used when a client sends source files and would like to have extra
    reassurance that the translation can be done successfully even if a translator can't complete the
    job and it has to be passed over to another translator to finish. In such a scenario, TTX can be a
    used as a document format to work with as the translator who finishes the job may not yet have
    SDL Trados Studio 2009 and so can then work on the TTX file in SDL Trados 2007 Suite.

    Scenario 3: Client Wants Bilingual TTX files for Review Purposes




    This scenario is similar to scenarios 1 and 2 in so far as you can deliver TTX files for reviewing
    purposes at step 6 or 7 respectively. However, it should be noted that SDL Trados Studio 2009
    features new reviewing capabilities that were not available in legacy SDL Trados versions and
    that offer new possibilities. These are covered below and work with TTX files just as well as with
    new source files that go via the SDLXLIFF route. So it can be of interest to follow a Studio based
    process for reviewing TTX files just as for any other type of project. The process is as follows:

4
1.    Work through the process in scenario 1 until step 4 (fully translated TTX files).
2.    In SDL Trados Studio, go to the Projects view and select your project. Create a project
      package using the Review task and send it to the review user.




                         Figure 9: Creating a review project package with TTX files

3.    The review user can open the project package in Studio and do the review using the many
      new reviewing features.
4.    When the review is finished, they can create a return package and send it back to you.
5.    You can now continue the scenario 1 process at step 6 and 7.
Note: in SDL Trados Studio 2009, it is possible to work with project and return packages, as
described in steps 3 and 4 above. This is the recommended way of working as it ensures that all
relevant settings and project resources (such as documents, translation memories, termbases
AutoSuggest dicionaries etc.) can all be packaged up into one single file, making it easy and safe
to pass project work on to the next project participant. However, similar to what was possible
with TTX and ITD, it is also still possible to send SDLXLIFF files without creating project packages
first. These SDLXLIFF are self-sufficient and can be opened in Studio in the same way as any other
document. However, in this case, the project participant needs to manually open other resources
belonging to the project, such as the translation memory or termbase.

Tip: Use HTML-Based Bilingual Preview for Review Purposes

Even without using the package process described above, there are useful new review features
in Studio which can be used to optimize the review process. For instance, if you wish to review
a translated document on paper, you can use the Print Preview feature in Studio to print the
currently open document using your browser. A wide range of options is available to fine-tune
what will be printed and how. For more information on this, refer to the online help in Studio.




                                                                                                       5
                Figure 10: Bilingual TTX document open in browser using Print Preview feature in Studio

    Scenario 4: Client Would Like Bilingual TTX Files to Update Their TM

    This scenario is an extension to scenario 2. Refer to "Scenario 2: Client sends new source files and
    would like translated files and TTX files back" and "Tip: Keeping both Studio (.sdltm) and legacy
    SDL Trados (.tmw) translation memories up to date" below for more information on how to
    ensure that both Studio and legacy SDL Trados TMs can be kept up to date.

    Scenario 5: Client Sends Source Documents in Word Format (.doc) and Would
    Like Bilingual .doc and Target .doc Files Back




    There are two ways to work in this scenario: Firstly, since SDL Trados 2007 Suite is shipped with
    SDL Trados Studio 2009 at no extra cost, it is perfectly possible to use the legacy Microsoft
    Word workflow for this type of task. For more information on this way of working, refer to the
    documentation shipped with SDL Trados 2007 Suite. This way of working should also be used
    if clients send you bilingual Word documents as per the legacy SDL Trados 2007 Suite workflow
    when using Word. In this case, Microsoft Word must be used as it is the only application that
    supports bilingual Word documents in .doc format.

    Secondly, if you do wish to use SDL Trados Studio for this scenario, you would follow these
    additional steps:
    1.     As per scenario 2, batch convert the files to TTX in SDL Trados 2007 Suite, translate the files
           in SDL Trados Studio, convert the files to target .doc.
    2.     Clean up the translated TTX files into legacy SDL Trados 2007 Suite TMs, as per "Tip:
           Keepingboth Studio (.sdltm) and legacy SDL Trados (.tmw) translation memories up to
           date" below. This adds the translations to your legacy TMs for use in SDL Trados 2007.
    3.     As per the above first suggested workflow, open the source document(s) in Microsoft
           Word. Re-translate them using the legacy SDL Trados 2007 Suite translation memory just
           updated in step 2. It is recommended to use Translate to Fuzzy to ensure that you only


4
       touch the segments that don't have a 100% match in your legacy TM. Such differences
       can be introduced due to the segmentation and tagging differences between SDL
       Trados Studio 2009 and legacy Translator's Workbench when using the Microsoft Word
       environment.

Tip: Keeping Both Studio (.sdltm) and Legacy SDL Trados (.tmw) Translation
Memories Up to Date

The best approach to keeping both Studio and legacy SDL Trados translation memories up to date
is as follows:

•	 SDL Trados Studio TM (.sdltm): Translate the TTX documents in Studio and run the Finalize
   batch task at the end of translation. This will ensure that the Studio TM will be kept up to date
   at all times. (Note: if you work with the master TM throughout the project lifecycle - this is the
   case if you don't use project TMs or work with single document translation only using the
   Open Document rather than the New Project command - then it is not necessary to run the
   Finalize task, as the TM is already up to date based on your work in the Editor.)
•	 SDL Trados Workbench TM (.tmw): After finalizing the files in SDL Trados Studio, Studio will
   place the final version of the TTX files in the target language folder of your project location in
   Studio. In Translator's Workbench, open the legacy translation memory you want to update.
   Then add the final TTX files to the Cleanup dialog box in Translator's Workbench as described
   above under "Scenario 2: Client sends new source files and would like translated files and TTX
   files back". Ensure that Update TM is selected, then click Clean Up. Translator's Workbench
   will now update the TM based on the latest version of the TTX file as well as produce the final
   target language version.




                         Figure 11: Updating a legacy SDL Trados TM with trans-
                                    lations of TTX files done in Studio

                                                                                                        5
SDL is the leader in Global Information Management (GIM) solutions that empower
  organizations to accelerate the delivery of high-quality multilingual content to
     global markets. Its enterprise software and services integrate with existing
  business systems to manage the delivery of global information from authoring
      to publication and throughout the distributed translation supply chain.

   Global industry leaders rely on SDL to provide enterprise software or hosted
   services for their GIM processes, including ABN-Amro, Best Western, Bosch,
      Canon, Chrysler, CNH, Hewlett-Packard, Microsoft, Philips, SAP, Sony,
                       Sun Microsystems and Virgin Atlantic.

   SDL has implemented more than 500 enterprise GIM solutions, has deployed
   over 170,000 software licenses across the GIM ecosystem and provides access
      to on-demand translation portals for 10 million customers per month.
        Over 1,000 service professionals deliver consulting, implementation
          and language services through its global infrastructure of more
            than 50 offices in 32 countries. For more information, visit
                                   www.sdl.com

				
DOCUMENT INFO