TestCase _Application_ _Autosaved_ by ofstudy

VIEWS: 145 PAGES: 21

									                                                     Notepad T
Test   Enveronment      Form/Dialog       Function
Case       Test          is Lauched         Test

   1 Windows XP SP2   Notepad         Open App




   2                  Notepad         GUI
   3                                  Main Menu




   4                                  File Menu




   5                  Main Menu       Edit Menu
 6                     Format Menu




 7                     View Menu

 8                     Help Menu




 9   Notepad           Function "New"



     Function "New"    Case 1 of "New"
                       Function


10   Alert Dialog      OK button
11   Alert Dialog      No button



12   Alert Dialog      Cancel button
13   Function "New"    Case 2 of "New"
                       Function
14   Notepad           Function "Open"

15   Function "Open"   Case 1 of "Open"
                       Function

16   Function "Open"   Case 2 of "Open"
                       Function


17   Function "Open"   Case 3 of "Open"
                       Function
18   Notepad           Function "Save"

19   Function "Save"   Case 1 of "Save"
                       Function


20   Function "Save"   Case 2 of "Save"
                       Function
21   Notepad           Function "Save
                       As"
22   Function "Save     Case 1 of "Save
     As"                As" Function


23   Function "Save     Case 2 of "Save
     As"                As" Function




24   Case 2 of "Save    Case "Yes"
     As" Function
25   Case 2 of "Save    Case "No"
     As" Function
26   Notepad            Function "Page
                        Setup..."




27   Function "Page     Case "Yes"
     Setup"


28   Case "Yes"         "Page Setup" ->
                        Paper
29   "Page Setup" ->    Size function
     Paper


30   "Page Setup" ->    Source function
     Paper


31   Case "Yes"         "Page Setup" ->
                        Orientation
32   "Page Setup" ->    Portrait function
     Orientation

33   "Page Setup" ->    Landscape
     Orientation        function

34   Case "Yes"         "Page Setup" ->
                        Margins (Inches)
35   "Page Setup" ->    Left function
     Margins (Inches)
36   "Page Setup" ->    Right function
     Margins (Inches)
37   "Page Setup" ->    Top function
     Margins (Inches)
38   "Page Setup" ->    Bottom function
     Margins (Inches)
39   Case "Yes"         "Page Setup" ->
                        Header
40   Case "Yes"         "Page Setup" ->
                        Header
41   Case "Yes"         "Page Setup" ->
                        OK
42   Case "Yes"         "Page Setup" ->
                        Cancel
43   Case "Yes"         "Page Setup" ->
                        Printer...

44   Function "Page     Case "No"
     Setup"
45   Notepad            Function
                        "Print..."
46   Function           Function
     "Print..."         "Print..." ->
                        Select Printer


47   Function           Function
     "Print..."         "Print..." ->
                        Preferences

48   Function           Function
     "Print..."         "Print..." -> Find
                        Printer...

49   Notepad            Function "Exit"


50   Function "Exit"    Case 1




51   Function "Exit"    Case 2

52   Notepad            Function "Undo"
53   Function "Undo"     Disable status

54   Function "Undo"     Enable status




55   Notepad             Function "Cut"
56   Function "Cut"      Disable status
57   Function "Cut"      Enable status



58   Notepad             Function "Copy"
59   Function "Copy"     Disable status
60   Function "Copy"     Enable status


61   Notepad             Function "Paste"
62   Function "Paste"    Case 1




63   Function "Paste"    Case 2
64   Case 2 of "Paste"   Disable status
     Function
65   Case 2 of "Paste"   Enable status
     Function

66   Notepad             Function
                         "Delete"
67   Function            Disable status
     "Delete"
68   Function            Enable status
     "Delete"

69   Notepad             Function "Find"
70   Function "Find"     Disable status

71   Function "Find"     Enable status




72   Enable status       "Find" dialogbox
73   "Find" dialogbox

74   "Find" dialogbox   Direction

75   "Find" dialogbox   "Find" dialogbox




76   Notepad            Function "Find
                        Next"

77   Function "Find
     Next"
78   Notepad            Function
                        "Replace"
79   Function           "Replace"
     "Replace"          dialogbox




80   Function           "Replace"
     "Replace"          dialogbox




81   Notepad            Function "Go To"
82   Function "Go To"   Disable status

83   Function "Go To"   Enable status




84   Enable status




85   Notepad            Function "Select
                        All"
86   Notepad   Funtion "Time/
               Date"
                           Notepad Test
                      Description                             Expect
                         Test                                 Result

Open this App, we have 2 way:              This Application is lauched crrectly
Way 1: Open from windows startmenu
1. Click on "start" button.
2. Choose "All Programs".
3. Choose "Accessories".
4. Click on menu item "Notepad".

Way 2: Open from Run dialog
1. Click on "start" button.
2. Choose "Run" item.
3. Type "Notepad" or "Notepad.exe".
4. Press "Enter" or click on "OK" button
Its interface is showed up                 Like the image we got.
                                           Notepad has 5 main menus:
                                           + "File" menu (hotkey: Alt + F)
                                           + "Edit" menu (hotkey: Alt + E)
                                           + "Format" menu (hotkey: Alt + O)
                                           + "View" menu (hotkey: Alt + V)
                                           + "Help" menu (hotkey: Alt + H)
                                           "File" Menu has 7 items:
                                           + "New" item (hotkey: Ctrl + N)
                                           + "Open..." item (hotkey: Ctrl + O)
                                           + "Save" item (hotkey: Ctrl + S)
                                           + "Save as..." item
                                           + "Page setup..." item
Click on File menu                         + "Print..." item (hotkey: Ctrl + P)
                                           "Edit" Menu has 11 items:
                                           + "Undo" item (hotkey: Ctrl + Z)
                                           + "Cut" item (hotkey: Ctrl + X)
                                           + "Copy" item (hotkey: Ctrl + C)
                                           + "Paste" item (hotkey: Ctrl + V)
                                           + "Delete" item (hotkey: Del button)
                                           + "Find..." item (hotket: Ctrl + F)
                                           + "Find Next" item (hotkey: F3 button)
                                           + "Replace..." item (hotkey: Ctrl + H)
                                           + "Go to..." item (hotkey: Ctrl + G)
                                           + "Select All..." item (hotkey: Ctrl + A)
                                           + "Time/Date" item (hotkey: F5 button)
Click on Edit Menu
                                                             "Format" Menu has 2 items:
                                                             + "Word Wrap" item (hotkey: Alt + O + W)
                                                             + "Font..." item (hotkey: Alt + O + F)
Click on Format Menu
Click on View Menu                                           "View" Menu has 1 item:
                                                             + "Status Bar" item (hotkey: Alt + V + S)
                                                             "Help" Menu has 2 items:
                                                             + "Help Topics" item (hotkey: Alt + H + H)
                                                             + "About Notepad" item (hotkey: Alt + H +
                                                             A)
Click on Help Menu
File -> New or Press Ctrl + N to opening this function.
When this function is opened, 2 case appear.

1. Change somethingelse on Editing Window such as:           A dialogbox appearance to ask you.
writring, copying, deleting, pasting...etc.                  The content of this dialog is "The text in the
2. Open "New" function.                                      Untitled file has change. Do you want to
                                                             save the change ?".
Click on "Yes" button                                        "Save as" dialogbox appear.
Click on "No" button                                         A new Editing Window appear. And the
                                                             previous.
                                                             text will not be save.
Click on "Cancel" button                                     Nothing happen.
1. Do nothing on Editing Window.                             Nothing happen.
2. Open "New" function.
File -> Open or Press Ctrl + O to opening this function.     The "Open" dialogbox is showed up.

1. Select the path from "Look in: " combobox.                The content of text file is showed up at
2. Choose exactly the folder contain the text file.          Editing Window.
3. Click "Open" button or Press "Enter".
1. Type exactly the path of the text file at                 The content of text file is showed up at
"File name" textbox.                                         Editing Window.
 Ex: "C:\Doc\Test.txt"
2. Click "Open" button or Press "Enter".
Click "Cancel" button.                                       Back into previous Editing Window.

File -> Save or Press Ctrl + S to opening this
function.
The first time choose "Save" Function.                   "Save as" dialogbox appear.
1. Type the name of this file at "File name: " combobox.
2. Click "Save" to save the content of this file.

1. Change something on your writing area.                    Nothing happen. But inside the text file
2. Choose File -> Save or Press Ctrl + S.                    the content is changed.
1. File -> Save As... or Press Alt + F + A to opening this   "Save as" dialogbox appear.
function.
"Save As" dialogbox is showed up.                            The text file is saved by the name
1. Type text file name at "File name: " textbox.             "abc.txt"
 Ex: "abc.txt"
2. Click on "Save" or press "Enter".
1. Open "Save As" dialogbox again.                           A dialogbox appearance to ask you.
2. Type nothing at "File name: " textbox.                    The content of this dialog is "C:\Documents
3. Click on "Save" or press "Enter".                         and Settings\My Documents\abc.txt
                                                             already exists Do you want to replace it?".

1. Click "Yes" button.                                       The File is overwriten.

1. Click "No" button                                         Back to "Save As" dialogbox.

1. File -> Page Setup... Or Press Alt + U to opening         The first time you open this function, a
this function.                                               dialogbox appear with content:
                                                             "Before you can perform printer-related
                                                             tasks such as page setup or printing a
                                                             document, you need to intall a printer. Do
                                                             you want to intal a printer now?"

1. Intall a printer to unlock this function.
2. After intall printer. ("Page Setup" dialogbox is showed
up).
3.


1. At "Paper" area choose one item in "Size"                 In "Preview" area the virtual paper will
combobox.                                                    be changed into style chosen.
 Ex: "A4" item.
2. Click "OK" button
1. At "Paper" area choose one item in "Source"
combobox.
 Ex: "Cassette" item.
2. Click "OK" button


1. At "Orientation" area choose "Portrait" radiobox.         In "Preview" area the virtual paper will
                                                             be changed into "Portrait" style.

1. At "Orientation" area choose "Landscape"                  In "Preview" area the virtual paper will
radiobox.                                                    be changed into "Landscape" style.




1. Type the number on Left textbox.                          In "Preview" area the virtual paper will
                                                             be changed with new left magins.
1. Type the number on Right textbox.                      In "Preview" area the virtual paper will
                                                          be changed with new right magins.
1. Type the number on Top textbox.                        In "Preview" area the virtual paper will
                                                          be changed with new top magins.
1. Type the number on Bottom textbox.                     In "Preview" area the virtual paper will
                                                          be changed with new bottom magins.
1. Type everything on "Header" textbox.                   This change will be saw when this text
Ex: "This is just testing".                               is printing.
1. Type everything on "Footer" textbox.                   This change will be saw when this text
Ex: "This is just testing".                               is printing.
Click on "Ok" button.                                     Save all change in "Page Setup"
                                                          dialogbox.
Click on "Cancel" button                                  Unsave all change in "Page Setup"
                                                          dialogbox.
Click on "Printer..." button                              Open "Page Setup" dialogbox with
                                                          content describe about Printer connected
                                                          to PC.
Printer will not be intalled.                             Nothing happen. Back into Editing
                                                          Window.
1. File -> Print... Or Press Ctrl + P to opening          "Print" dialogbox is showed up.
this function.
1. At "Select Printer" Area choose 1 printer.             Printer will print the text file.
2. Click "Print" button.
Notes: to intalling a new printer choose "Add Printer".


1. Click "Preferences" button.                            "Printing Preferences" dialogbox is
                                                          showed up


1. Click "Find Printer..." button.                        Find the printer with exactly name.
2. Type the name of printer at "Printer: " textbox in
"Connect to Printer" dialogbox.
3. Click "Ok" button.
File -> Exit or press Alt + F4 to opening this
function.
Two case in this function.
File -> Exit or press Alt + F4 to opening this            If this file is not be saved before. A
function.                                                 dialogbox appearance to ask you.
                                                          The content of this dialog is "The text in the
                                                          Untitled file has change. Do you want to
                                                          save the change ?".
File -> Exit or press Alt + F4 to opening this            The file is saved.
function.                                                  This Application is turned off.
Open notepad choose "Edit" menu.                          When notepad running this function is
                                                          Disable to use.
1. Type some text on Editing Window                       "Undo" function is enabled. When
Ex: "Notepad testing"                                     this function is chosen, the text has just
2. Clear all the text.                                    written is disappear and way back into the
3. Click "Undo" on Edit menu or Press "Ctrl + Z".         previous text.


Open notepad choose "Edit" menu.                          The function "Cut" is disabled to use.
1. On Editing Window select a text or paragraph.          "Cut" function is enabled. When
2. Click "Cut" on Edit menu or press "Ctrl + X"           this function is chosen, the text or
                                                          paragrahp in block disappear.

Open notepad choose "Edit" menu.                          This function is disable to use.
1. On Editing Window select a text or paragraph.          "Cut" function is enabled. When
2. Click "Copy" on Edit menu or press "Ctrl + C"          this function is chosen, the text or
                                                          paragrahp in block is copied.
Two case can happen.
1. Copy some text or paragraph in other software      The copy of the text or paragrahp is showed
such as: Word 2003, Excel, Access, ....               up at Editing Window.
 Notes: just copy text only.
2. Open notepad and choose "Paste" function on "Edit"
menu.

Open notepad choose "Edit" menu.                          When notepad running this function is
                                                          Disable to use.
1. On Editing Window select a text or paragraph.          "Paste" function is enabled the copy of the
2. Click "Copy" on Edit menu or press "Ctrl + C"          text or paragrahp is
3. Click "Paste" on Edit menu or press "Ctrl + V"         showed up at Editing Window.


Open notepad choose "Edit" menu.                          When notepad running this function is
                                                          Disable to use.
1. On Editing Window select a text or paragraph.          "Delete" function is enabled. When
2. Click "Delete" on Edit menu or press "Del" button      this function is chosen, the text or
                                                          paragrahp in block is deleted.

Open notepad choose "Edit" menu.                          When notepad running this function is
                                                          Disable to use.
1. Type some text on Editing Window.                      "Find" function is enabled. "Find"
Ex: "Notepad testing"                                     dialogbox appear.
2. Choose "Find" function on Edit menu or press "Ctrl +
F".
1. Type the text at "Find what: " textbox.                The text will be selected.
Ex: "Notepad".
2. Click "Find Next" button
1. Click "Find Next" button until can't click.                A dialogbox show up to alert:
                                                              "Can't find "Notepad"".
1. Choose 1 radio button "Up" or "Down".                      "Find" function will find the text follow
2. Click "Find Next" button.                                  the direction.
1. Type the text at "Find what: " textbox (this text is not   A dialogbox show up to alert:
located in the Editing Window).                               "Can't find "abc"".
 Ex: "abc".
2. Click "Find Next" button
1. Close the "Find" dialogbox.                                The text will be selected.
2. choose "Find Next" function on "Edit" menu or
press F3.
1. Click "Find Next" function or press F3                     A dialogbox show up to alert:
until can't click.                                            "Can't find "Notepad"".
Edit -> Replace or press Ctrl + H to opening this             The "Replace" dialogbox is showed up.
function.
1. Type some text at "Find what: " textbox.                   The text will be replaced.
 Ex: "Notepad".
2. Type some text at "Replace with: " textbox.
 Ex: "NOTEPAD".
3. Return "Find" function. ("Find Next" button to find
the word want to replace).
4. Click "Replace" button.
1. Type some text at "Find what: " textbox.                   All text in this file will be replaced.
 Ex: "Notepad".
2. Type some text at "Replace with: " textbox.
 Ex: "NOTEPAD".
3. Return "Find" function. ("Find Next" button to
find the word want to replace).
4. Click "Replace All" button.

Open notepad choose "Edit" menu.                              When "Wrap word" function is checked this
                                                              function is Disable to use.
1. Choose this function on "Edit" menu.                       The pointer will focus at the number of
2. Type digit of lines on "Line number: " textbox.            line.
Notes: the digit from 0 to the last lines.
3. Click on "OK" button.
1. Choose this function on "Edit" menu.                       A dialogbox is showed up to alert:
2. Type digit out of lines on "Line number: " textbox.        "Line number out of range".
Ex: There are 10 lines in this text file.
Type 0 or a digit larger than 10.
3. Click on "OK" button.

1. Choose this function on "Edit" menu or press               All text in Editing Window will be
"Ctrl + A".                                                   selected. This function is disable.
1. Choose this function on "Edit" menu or press   In Editing Window, the system
"F5".                                             date/time will be insert at pointer focus
Actual Testing
                 Note   Date   Tester
    Result
Working with a
printer...
This case is the
same property as
"Page Setup"
function




Return function
Save.

								
To top