Documents
Resources
Learning Center
Upload
Plans & pricing Sign in
Sign Out

Star-Design and Star-CCM+

VIEWS: 120 PAGES: 5

									                          The University of Edinburgh

                      Computational Fluid Dynamics 5

                           Star-Design and Star-CCM+

                             First tutorial: Flat plates
Objective: Familiarisation with the software environment

The object will be flow between two flat plates, 10mm apart and 100mm long.
Because of the symmetry, we only need a domain which is 5mm wide.

Note: Star-CCM+ is designed primarily as a 3D flow modeller. As a result, the
imported object will be 3 dimensional. We will reduce it to 2 dimensions after
meshing.

Creating the geometry

In order to create a 2D mesh in this software, it is necessary to create a 3D mesh with
one plane on z=0. Traditionally we would have x as the direction of flow and y as the
width of the pipe.

   1) create a directory called channel
   2) launch Star-Design (Command: stardesign)
   3) Accept the option gl <return>
   4) Using the left, middle and right buttons, check their function
   5) Under Edit > Preferences select mm as the units
   6) Use the ‘create block’ icon to create a plane in the xy plane measuring
      x=100mm, y=5mm, with the first corner at (0,0,0). Extrude that plane to
      z=5mm. (If you need to re-size the image whilst doing this, hold down <ctrl>
      and the rotate,pan,zoom are used as in (4).
   7) Click on Block and check its dimensions. Ensure it is centred on (50,2.5,0)
      with dimensions (100,5,5).
   8) Export the geometry as a Parasolid file.
   9) Save this simple geometry and close Star-Design

Importing the geometry

The geometry is imported as a surface. Be careful not to import it as a volume. It is a
single surface and since we want to name the walls, the symmetry plane, the inlet and
the outlet, we will have to separate these.

   1)   Open Star-CCM+ (Command: starccm+)
   2)   Start a new simulation (File>New Simulation). Use the default values.
   3)   Import the surface geometry previously saved. Use default settings.
   4)   Check the rotate zoom and pan functions in the Geometry Scene.
   5)   Open Regions>Body 1>Boundaries. There is only one boundary.
   6)   RC on Boundary 1>Split by angle. Note the default value. Apply & Close.
   7) Examine the 6 new surfaces. Rename the inlet and the outlet. Click on the four
      walls and name them wall 1 to 4. Note the default boundary type in the
      Properties window is Wall. Change this to Velocity inlet for the Inlet and
      Pressure outlet for the outlet.
   8) Save the simulation as Channel3D.

Creating the mesh

   1) Open ‘Continua’. Here you will find the meshing and Physics options.
   2) Right Click (RC) on Mesh1>Select Meshing Models
   3) Select surface remesher and trimmer. This will create a rectangular grid.
   4) Now open Mesh > Reference Values. Set
          a. base size to 10mm (width of the inlet)
          b. Maximum Cell Size to 10%
   5) Mesh>Volume Mesh
   6) RC Scenes>New Scene>Mesh will bring up another window in which you can
      examine the mesh.
   7) Save the simulation as channel3D

Creating the 2d mesh and conditions

Note that there is no going back at this stage. That’s why you saved the 3D example.

   1) Click on Mesh>Convert to 2D
   2) Use the mouse – you will see that the object can no longer be rotated in 3D
   3) Open Regions>Body 1 2>Boundaries. Check that the names of the boundaries
      have been transformed correctly. For this simulation the top boundary should
      be a wall, the bottom a symmetry line, left a velocity inlet & right a pressure
      outlet. Change the names appropriately and assign types in the ‘Properties’
      box (bottom left).
 Inlet                                 Wall                                  Outlet


                                       Symmetry




Setting up the physics model and values

Here we will choose the laminar flow simulation, the solver type and the fluid (water)
in the pipe.

   1) Open Continua and RC Physics1>Select Models.
   2) Select 2D, Liquid, Segregated, Stationary, Steady State, Laminar, Constant
      density
   3) Open the new ‘Models’ list. Check that the fluid is water.
   4) Regions>Body 1 2>Boundaries>Inlet>Physics Values
   5) Set the Value of the Velocity magnitude (in Constant) to 0.05m/s.
   6) Open the list ‘Stopping Criteria’ and set the maximum number of iterations to
      100.
   7) Save as channel2D

Running the simulation

The ‘runner’ icon on the top will start the simulation for you. During the simulation a
new Scene will appear on the right, showing the progress of the residuals. The
simulation may be stopped and re-started at any time.

Post processing

There are a number of things which you may wish to look at during post-processing,
such as the velocity field, pressure changes and so on. Here are some examples:
1) Create a velocity vector plot
      a. Choose ‘vector scene’ from the drop-down list or RC Scenes>New
          Scene>Vector
      b. The new scene will appear in a new window
      c. Only half the channel is visible because of the symmetry
      d. In the Vector Scene 1 panel click on Vector 1
      e. Scroll down to the bottom of the Properties panel and change
          Transform to Symmetry 1
      f. The outline is now the wrong shape. To change it click on Outline 1
          and do the same.




2) Create an xy plot
           a.   RC Plots>New Plot
           b.   Click XY Plot 1. In XY Plot 1 select Symmetry
           c.   Open Y Type>Y Type 1>Scalar
           d.   In Properties select velocity magnitude

Save your solution and try generating other forms of data report, such as the velocity
profile at the outlet. Is it parabolic?

WJE 1/10/08

								
To top