Docstoc

Open Source Spreadsheet - PDF

Document Sample
Open Source Spreadsheet - PDF Powered By Docstoc
					  Open Source and
 Web 2.0 Software:
Where Can It Fit in Your School?




                       Workshop by:
                        Jim Hirsch
                 Table of Contents – Open Source and Web 2.0 Workshop


          Firefox – Internet browser ......................................................................................... page 2




Word Processing
              Open Office (Writer) ...................................................................................... page 5
              Google Docs (Documents) ............................................................................. page 8
              Zoho Office (Writer) ...................................................................................... page 9
Presentations
              Open Office (Impress) ................................................................................. page 11
              Google Docs (Presentation) ......................................................................... page 13
              Zoho Office (Show) ..................................................................................... page 14
Spreadsheets
              Open Office (Calc) ....................................................................................... page 16
              Google Docs (Spreadsheet) ......................................................................... page 18
              Zoho Office (Sheet) ..................................................................................... page 19
Open Office
              Clip Art (installing) ...................................................................................... page 20
              Draw (drawing - “Big Idea” book) .............................................................. page 22


           The GIMP – image manipulation ........................................................................... page 23


          KompoZer – web page authoring ........................................................................... page 26


          Audacity – audio editing ......................................................................................... page 27


         VLC Media Player ................................................................................................... page 27


          CamStudio – video streaming ................................................................................ page 28




                   Open Source and Web 2.0 Workshop – Jim Hirsch, 2008
Open Source and Web 2.0 Software: Where Can It Fit in Your School?

The workshop today will involve the use of a wide variety of open source and Web 2.0 software
applications. Each participant will receive the Open Education Disc – a CD compilation of the
most useful open source software packages available today and the Open Source Education
Software CD – both for Windows OS. In addition, each participant will receive a flash drive
containing the Portable Apps library, the workshop data files and the first semester Business
Computer Information Systems high school course designed for use with Open Office and
licensed under Creative Commons. Macintosh users will have the option of using these portable
applications from a separate flash drive.

During the workshop, we will use the
Portable Apps library of software, but
from the folder titled Flash_Drive which
can be found on the desktop of your
workshop computer. These applications
will run slightly faster from the hard drive
than a flash drive, but all activities can be
used successfully from either source.

Launching the “StartPortableApps” icon
provides a menu of open source programs
to choose from. This menu will remain
available for your use on the task bar.

The Web 2.0 applications will be accessed
using Firefox from the Portable Apps menu. The applications we will
use during the workshop can be found as Bookmarks within the
program.

Starting the Workshop

Find the Flash_Drive folder on your computer and start the “StartPortableApps” program. From
the menu, select Mozilla Firefox. Notice the browser is configured to start with two tabs open.
The “Open Technology Resources” page is provided as your reference point for many resources
providing further information regarding the use of open technologies. Feel free to browse
through the page and sample what's available. (tip: that page was created with KompoZer, an
open source web editor)

Interested in seeing the history of your district web site? Choose the bookmark “Internet
Archive” to visit the Wayback Machine and type your URL into the “Take Me Back” text field.

Reminder: all of these portable open source applications are also available in standard
program format for typical installations.


               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                        page 1
              Firefox – Internet Browser

Firefox has a number of features that may make your Internet browsing more effective and more
fun! We'll use Firefox to take a quick tour of some interesting open source sites. In addition,
these examples will give you an idea of some of the most used features of the application.

Example 1:    Firefox Add-ons
   1. Go to Tools/Add-ons.
   2. Click on “Browse All Add-ons” in the upper
      right corner.
   3. Search for “gTranslate”. Click the “Add to
      Firefox” button followed by “Install Now”.
   4. Restart Firefox and close the Add-ons window.
      Browse to Google News (or whatever site you'd
      like). Select some text on the page and right-
      click.
   5. Choose “Translate” from the pop-up menu and
      select English to whatever language you'd like.
   6. Right-click again on the selected text and choose the translation on the first line - notice
      how the Add-on has opened a new tab using Google Translate for the phrase you
      highlighted.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                             page 2
Example 2:    Pandora – Internet Radio
   1. Open a new tab in Firefox by pressing Control-T or use the File Menu and choose New
      Tab.
   2. Choose Pandora Radio from the Bookmarks Toolbar or use the Bookmarks Menu.
   3. You can log-in using the username (email address) and password supplied to you for this
      workshop. Type in the name of one of your favorite artists or songs, click “Listen Now”
      and let Pandora create your own personal radio station.




Example 3:    Your choice of browsing
   1. While you're waiting for the next workshop activity, go ahead and take a look at one of
      these sites to catch up on your tech reading or playing:
      ◦ Wired @ wired.com
      ◦ BoingBoing @ boingboing.net
      ◦ The Pacman add-on (complete with retro graphics) @
          addons.mozilla.org/en-US/firefox/addon/2053

One of the neat things about Mozilla Firefox Portable is that it takes your bookmarks, history
and all of your settings along with you!




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 3
                   Open Source and Web 2.0 Productivity Software


         Open source – a culture where it is unacceptable not to share what you know
    Web 2.0 – a collaborative environment where “co-labor” works towards a common goal

It's not surprising that these two technologies have a great deal in common given the underlying
philosophies. This next portion of the workshop provides you the opportunity to compare and
contrast the capabilities of the most popular open source desktop productivity application – Open
Office – along with the most popular Web 2.0 open use productivity applications – Google Docs
and Zoho Office.

Each of these applications has three core tools in common – word processing, spreadsheets and
presentations. The activities provided below give you the opportunity to work with each of the
three tools while completing the same task. In addition, the Web 2.0 applications provide
collaboration capabilities among identified users – a key feature in the consideration of the use of
these technologies within classrooms.

Open Office can be accessed from the PortableApps menu. Notice that each of the tools within
Open Office are accessed individually (Writer – word processing, Calc – spreadsheet, Impress –
presentation). Google Docs and Zoho Office are accessed via Bookmarks with Firefox. The
Web 2.0 applications require that you have an active account – you can use the username (email
address) and password supplied to you for this workshop.

The first activity will use the word processing tool in each application. You will have the
opportunity to explore how typical formatting options compare as well as using images within
documents.

The second activity will use the presentation tool in each application. You will have the
opportunity to explore how text, video, audio and hyperlinks are handled within documents.

The third activity will use the spreadsheet tool in each application. You will have the
opportunity to explore how formula options compare as well as creating charts and graphs within
documents.

Finally, there are additional activities for you to use with Open Office to explore how the
Drawing tool functions as well as how to install additional clip art in the gallery.




               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                            page 4
              Activity 1: Word Processing
              OpenOffice – Writer


The first time a new user encounters Open Office, other impressions probably will be lost in the
overwhelming sense of difference. If you are used to working another way, you also may jump to
the conclusion that Open Office's way of doing things is inferior.

If you are interested in learning Open Office, get to know these quirks. Then work with them for
a couple of weeks before deciding what you think of them. Only then will you have a chance of
getting beyond your initial impression. However, if you know what to expect going in, you can
work with Open Office's quirks instead of being puzzled by them – and make an informed
decision rather than one based on the comfort of familiarity.

This workshop is designed to have you experience both common and unique features contained
within Open Office, and specifically, the word processing (Writer), presentation (Impress) and
spreadsheet (Calc) modules. Sample documents are contained in the
Documents/Workshop_files/OpenOffice directory. Feel free to use them as you see fit during
the workshop.

Start the Open Office Writer program from the PortableApps menu.

   5. Open the file titled “Old_bubbles” in the OpenOffice folder.
   6. Select the first paragraph (or any text). Typical changes can be accessed from the toolbar
      – font selection, some styles, size, color, etc. – be sure you can identify those options.
      Apply any changes you wish.
   7. Add the title “Old Bubbles Back Global Warming Theory” to the page. Use the toolbar
      to center the title, increase its font size and provide a different text color.
   8. Use Format/Character to review additional options you can apply to text within
      OpenOffice. These include Font Effects – go ahead and try the various options; Position
      – super/subscripting and more; Hyperlink – to URLs or even other documents;
      Background colors – of any text. Again, practice applying any of these options.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                          page 5
9. Use Format/Paragraph to review options that can be applied at the paragraph level. These
   include: Indents & Spacing; Text Alignment; Text Flow; Numbering; Tabs; Drop Caps;
   and Borders.




10. Change the alignment of the third paragraph to justified and make the last line justified
    as well. Now you see what some editors forget to do when finalizing articles that use
    justified text.
11. Highlight the fifth paragraph and place a double-line border around it and increase the
    spacing to contents to .1”.
12. Use Format/Page to review options that can be applied at the page level (note: this is
    where the margin settings can be found – under the Page tab). These include: Page,
    Background, Header, Footer, Borders, Columns, Footnote.




13. Change the margins on the document to .75” all around.
14. Headers and footers are accessed via Insert/Header/Default and Insert/Footer/Default.
    Options other than entering text are accessed via Format/Page as described above – be
    sure to check the additional options with the More button. Feel free to add either or both
    to your document.
15. Drawing tools can be accessed in Writer by clicking on the Draw Functions icon or using
    View/Toolbars/Drawing. Try these tools in the document – particularly the Callout and

           Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                           page 6
   FontWork options.




16. Bullets and numbering. The sixth paragraph includes two items that should be bulleted.
    Select those two items and use Format/Bullets and Numbering (or the floating palette) to
    add bullets and/or numbers. Spend some time changing the formatting options available
    for each type.




17. Inserting images. Use Insert/Picture/From File to add an image to your document. Open
    Office adds the image where you have your cursor positioned. Position your cursor at the
    end of the ninth paragraph (which begins with “Deep Antarctic ice...”). Insert the image
    titled “drill” which can be found in the OpenOffice folder inside the Workshop folder.
    This image is large and may force itself to the next page. When images are first added to
    a document, they “anchor” themselves to the paragraph where the cursor was located –
    notice the small anchor icon. The familiar “handles” allow you to re-size the image as
    you would expect – go ahead and make the image smaller by using the handles – in fact,
    make it small enough so that it fits back on the same page.
18. Although you can change the text wrap effect from the toolbar, now is a good time to see
    all of the image options available in Open Office. Use Format/Picture (or double-click
    on the image) to bring up the Picture options. In the Wrap tab, choose “Before” for the
    setting and click OK. Notice how the other paragraph text is now able to “wrap” itself
    back to the page. Go ahead and move the image to the right margin of the paragraph.




           Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 7
   19. Double-click on the image to bring up the Picture options again. In the Crop tab, set the
       scale to 35%. We also should crop the bottom portion of the image to eliminate the extra
       size. Set the “bottom” crop value to 1.24” - notice how the preview image shows you the
       result of the crop before you click OK.




   20. One of the great features in open source software is the ability to save documents in many
       formats. Save your changes under a new name using Save As in the File menu and then
       use the built-in PDF features in Open Office by exporting your file as a PDF in the File
       menu. Your file should now look like “Old_bubbles_final” located in the workshop
       folder.


                         Google Docs – Documents


Start the Mozilla Firefox browser, launch Google Docs from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.
    1. Open the file titled “Old_bubbles” in the documents list.
    2. Select the first paragraph (or any text). Typical changes can be accessed from the toolbar
        – font selection, some styles, size, color, etc. – be sure you can identify those options.
        Apply any changes you wish.
    3. Add the title “Old Bubbles Back Global Warming Theory” to the page. Use the toolbar
        to center the title, increase its font size and provide a different text color.
    4. Use the Format menu to review additional options you can apply to text within Google
        Docs. While not as exhaustive a list as in Open Office, these features provide typical
        formatting needed when word processing. Again, practice applying any of these options.
    5. Notice the toolbar allows paragraph level formatting including: indents; text alignment;
        numbering; and tabs.



   6. Change the alignment of the fifth paragraph to centered.



              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                           page 8
   7. Insert a horizontal line above and below the paragraph to feature
       it on the page using the Insert menu.
   8. Change the margins to .75” all around using the Print Settings
       option in the File menu.
   9. Headers and footers are accessed via the Insert menu. Feel free
       to add either or both to your document.
   10. The sixth paragraph includes two items that should be bulleted.
       Select those two items and use the bullet option on the toolbar to
       add bullets or the number option to add numbers.
   11. Inserting images. Use Insert/Picture to add an image to your
       document. Google Docs adds the image where you have your cursor positioned. Position
       your cursor at the end of the ninth paragraph (which begins with “Deep Antarctic ice...”).
       Notice that Google Docs can use images on a hard drive or add them directly from the
       Web using the URL. Insert the image titled “drill” which
       can be uploaded from the OpenOffice folder by clicking the
       Browse button (from this computer). This image is large
       and takes up more room than wanted in the document.
       Click on the image to bring up the familiar “handles” that
       allow you to re-size the image as you would expect – but do
       not change the image size yet since we have other tasks to
       complete with the image.
   12. To change the text wrap effect and the size, right-click on
       the image. Select “Change Image”. Change the size to
       “Thumbnail, up to 160 pixels wide”, the position to “Right-
       aligned” and check “Wrap text around image”. Notice how
       the other paragraph text is now able to “wrap” itself back to
       the page. You'll notice that you don't have the fine control
       over images as in Open Office.
   13. Save your changes. In the File menu, notice that you can
       “Download file as” to save the document locally in a variety of formats, including Open
       Office and PDF. This allows the use of the file with other programs and when not
       connected to the Internet.


                       Zoho Office – Writer


Start the Mozilla Firefox browser, launch Zoho Personal from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.
    1. Select Writer from the list of applications on the left and open the file titled
        “Old_bubbles” in the My Docs list.
    2. Click the icon to the right of the Delete button to hide the file list and maximize the work
        area.
    3. Select the first paragraph (or any text). Typical changes can be accessed from the toolbar
        – font selection, some styles, size, color, etc. – be sure you can identify those options.

               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                           page 9
      Apply any changes you wish.
   4. Add the title “Old Bubbles Back Global Warming Theory” to the page. Use the toolbar
      to center the title, increase its font size and provide a different text color.
   5. Formatting is accomplished through the many options on the toolbar. Again, practice
      applying any of these options.




   6. Notice the toolbar allows paragraph level formatting including: indents; text alignment;
       numbering; and tabs.
   7. Change the alignment of the third paragraph to justified and make the last line justified
       as well. Now you see what some editors forget to do when finalizing articles that use
       justified text.
   8. Insert a horizontal line above and below the paragraph to feature it on the page using the
       horizontal line icon in the toolbar.
   9. Change the margins to 10% all around
       using the Page Setup menu.
   10. Headers and footers are also accessed
       via this menu. Feel free to add either or
       both to your document.
   11. The sixth paragraph includes two items
       that should be bulleted. Select those two
       items and use the bullet option on the
       toolbar to add bullets or the number
       option to add numbers.
   12. Inserting images. Click the image icon
       on the toolbar to add an image to your
       document. Zoho Office adds the image
       where you have your cursor positioned.
       Position your cursor at the end of the
       ninth paragraph (which begins with “Deep Antarctic ice...”). Notice that Zoho Office can
       use images on a hard drive or add them directly from the Web using the URL. Insert the
       image titled “drill” which can be uploaded from the OpenOffice folder by clicking the
       Browse button (from this computer). This image is large and takes up more room than
       wanted in the document. Click on the image to bring up the familiar “handles” that allow
       you to re-size the image as you would expect – feel free to make it smaller now.
   13. To change the text-wrap effect, right-click on the image and choose “Image
       Properties”.Choose “Right” for the alignment and OK the change.
   14. Save your changes. Notice the Export option in the upper right allows you to save the
       document locally in a variety of formats, including Open Office and PDF. This allows
       the use of the file with other programs and when not connected to the Internet.
This completes a short comparison of typical word processing tasks using three open source/use
applications. I think you 'll agree that the flexibility these programs allow in terms of file
formats and open standards provides great value when compared with proprietary versions.

              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                        page 10
              Activity 2: Presentations
              OpenOffice – Impress


The presentation portion of Open Office is named “Impress”. This example will provide you
with an overview of the manner in which you create presentations with the tools.

Example 1: Starting a presentation
   1. Start Open Office Impress from the Portable Apps menu to open the presentation wizard.
      Choose From template and in the Presentations list you should find “Pushpins”. Click
      Create (not Next) to begin your presentation using that template.




   2. Notice the tabs at the top of the current slide that allow you to choose different views –
      Normal, Outline, Notes, Handout and Slide Sorter. Their use will be apparent once you
      have additional slides created. Notice the drawing tools located at the bottom of the
      screen. These are available for your use throughout Impress. To the right is the “Tasks”
      area. This provides a quick and easy way to view a variety of options used in your
      presentations – the Layouts view provides the choices of pre-designed text, image and
      chart formats for slides; the Custom Animation view provides options for affecting the
      behavior of any item contained on a slide; the Slide Transition view provides for control
      over the manner in which slides display following the preceding ones. Use Tools/Gallery
      to display built-in art. Feel free to practice using any of these tools and views to create a
      few slides at this time.
   3. Type “OpenOffice Impress” as the title. Type “Creating Presentations” as the subtitle. If
      you feel the white type is too light on this page, choose black or another color.
   4. Go to Slide 2. Type “Presentation Effects” as the title on this slide. In the outline
      section, type “Movies” on the first line, “Sounds” on the second line and “Hyperlinks” on
      the third line. Use the Custom Animation view to add an entrance effect to each of those
      lines. Hint – if you click on the text field and click Add, the effect will be applied to the
      group by default. Once you've created the effect, double-click on the “Outline Text” item
      and in the Text Animation tab you can select “By first level paragraphs”.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                           page 11
5. Add a new slide by using Insert/Slide or clicking on the Slide button in the toolbar.
   Choose a Layout with only a title and type “Movies”. Use Insert/Movie and Sound and
   choose “think_different” from the OpenOffice folder. The movie is placed as a rectangle
   on the screen that can be moved to whatever location you wish. As it is first inserted, it is
   set to play automatically when the slide show runs.
6. Add a new slide by using Insert/Slide or clicking on the Slide button in the toolbar.
   Choose a layout with only a title and type “Sounds”. Use Insert/Movie and Sound and
   choose “ernestine” from the OpenOffice folder. The sound is placed as a rectangle on the
   screen that can be moved to whatever location you wish. As it is first inserted, it is set to
   play automatically when the slide show runs. The sound plays consistently when the
   slide is displayed, but no custom animation controls are possible at this time.
7. Add a new slide. Choose a layout with a only a title and type “Hyperlinks”. Use
   Insert/Hyperlink and type “http://www.openoffice.org” in the Target field. This embeds
   the hyperlink on the slide. Remember to save your presentation as you complete it.




           Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                           page 12
                         Google Docs – Presentation


Start the Mozilla Firefox browser, launch Google Docs from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.
    1. Open the file titled “Pushpins” in the documents list.
    2. You'll notice immediately that the tools available in Google Docs are very minimal. Like
        the document component of Google Docs, the presentation component can upload image
        files or use web-based URLs. There are no means however to upload video or audio
        files.




   3. Follow the same design as in Open Office. For Google Docs, you will only need to
      create slides for movies and hyperlinks as audio files are not supported unless they are in
      video format. Create the same first two introductory slides as in the previous example.
      Type “Creating Presentations” on slide 1. Type “Presentation Effects” as the title on
      slide 2. In the outline section, type “Movies” on the first line and “Hyperlinks” on the
      second line.



              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                          page 13
   4. Add a new slide by clicking the “+” button. Choose a layout with only a title and type
      “Movies”. Movies are added via the Insert Menu. Google Docs uses YouTube as the
      only video source. For this movie slide, search for “think different apple” and you'll be
      able to have an online version of the video you used in the previous example. Notice that
      Google Docs does give more control over the operation of the video once it is placed on
      the slide when compared to Open Office.




   5. Add a new slide. Choose a layout with a only a title and type “Hyperlinks”. Highlight
      the word “HyperLinks” and click the “Link” option in the toolbar. Type
      “http://www.google.com” in the text field.




   6. Test your presentation to see that all options work.
   7. Notice in the File menu that Google Docs allows you to download your presentation in a
      variety of formats for use locally.


                       Zoho Office – Show


Start the Mozilla Firefox browser, launch Zoho Personal from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.
    1. Select Show from the list of applications on the left and open the file titled “Pushpins” in
        the My Docs list.



               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                          page 14
   2. Notice the tools and interface screen within Zoho Office provide for a significant number
      of features when using the Show module.




   3. As with Google Docs, Zoho Office Show allows you to upload images from a local drive
      or use a web address or even Flickr to bring graphics into your presentation. It includes
      the capability of using a wide variety of shapes and even has built-in clip art.
   4. Follow the same slide design as in the previous two exercises for the first two slides.
   5. Add a new slide by clicking the New Slide
      button. Choose a layout with only a title and
      type “Movies”. Movies are added via the Insert
      button. Zoho Office uses only online videos, so
      you must choose “HTML code” and then copy
      and paste the html code snippet that YouTube
      and similar services provide. Audio files can
      only be played in this manner as well.
   6. Add a new slide. Choose a layout with only a
      title and type “Hyperlinks”. Highlight the word
      and right-click. Choose Hyperlink and type
      “http://www.google.com” in the text field.
   7. Test your presentation to see that all options
      work.
   8. Notice in the Export menu that you have a wide
      variety of options with which to save your
      presentation locally.

These presentation tools are in a constant state of
improvement – look for updates often!


               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                       page 15
              Activity 3: Spreadsheets
              OpenOffice – Calc


The spreadsheet portion of Open Office is named “Calc”. This example will provide you with an
overview of the manner in which you create spreadsheets with the tools.

Example 1: Using formulas and creating graphs
   1. Open the file titled “M&M” in the OpenOffice folder. The file contains the results from
      5 groups of students who were given packs of M&Ms and asked to collect the number of
      each color contained in the pack.
   2. Start by completing the formula that will provide the averages in column G. Place your
      cursor in cell G2. Use Insert/Function to begin the Function Wizard. Choose Average
      from the function list and click Next. Click and drag on your spreadsheet from cell B2 to
      cell F2 and click OK.




   3. Have the result rounded to the nearest whole number by selecting cell G2 and use
      Format/Cells. Choose Number and “-1234” to specify numbers and select 0 decimal
      places.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                       page 16
   4. Complete the remaining average formulas by clicking on cell G2 and highlighting down
      to cell G8. Use Edit/Fill/Down to complete the formulas.
   5. Complete the Total formula for each column using the summation function and filling to
      the right. Yes, Group 3 had the best pack!
   6. Complete a pie graph of the average # of colors in a pack of M&Ms.
      •   Click and drag to highlight the names of the colors (A2 through A7).
      •   Hold down the Control key as you click and drag to select G2 through G7 (this same
          procedure can be used to select results of a specific group).
      •   Click on the Chart Wizard button in the toolbar (looks like a pie graph) and draw an
          area on your spreadsheet to place the chart.
      •   Click the Next button on the AutoFormat Chart since you already selected the first
          column for labels.
      •   Select the 3D pie chart type (last one available in the list) and click Next (twice).
      •   Type “Average # of colors in M&Ms” as the Main Title and click Create.
   7. Complete the graph by changing the default colors to the colors of the M&Ms in the
      pack.
      •   Click on the 3D pie graph to select it.
      •   Select each pie piece in turn.
      •   Double-click the selected piece to change the color.




Example 2: Sorting and more graphs and charts
   1. Open the file titled “Temperature” in the OpenOffice folder.
   2. Select columns A and B and use Data/Sort and choose Column B in the Sort to:
      dropdown. This quickly rearranges the temperatures by lowest to highest along with the
      time of day (or highest to lowest depending on your choice of ascending or descending).
   3. Sort by Column A to put the data back into chronological order. Create a bar graph
      showing the hourly temperatures for the day. If necessary, you can view a sample with
      the file titled “Temperature_graph”.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                        page 17
                         Google Docs – Spreadsheet


Start the Mozilla Firefox browser, launch Google Docs from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.

Example 1: Using formulas and creating graphs
   1. Open the file titled “M&M” in the documents list. The file contains the results from 5
      groups of students who were given packs of M&Ms and asked to collect the number of
      each color contained in the pack.




   2. Start by completing the formula that will provide the averages in column G. Place your
      cursor in cell G2. Click on the summation icon and choose Average from the function
      list. Click and drag on your spreadsheet from cell B2 to cell F2, close the parentheses
      and press the enter key.
   3. Have the result rounded to the nearest whole number by selecting the “123” icon.
      Choose Rounded to specify numbers and select 0 decimal places.
   4. Complete the remaining average formulas by clicking on cell G2 and dragging the “fill
      handle” down to cell G8.
   5. Complete the Total formula for each column using the sum function and filling to the
      right. Yes, Group 3 had the best pack!
   6. Complete a pie graph of the average # of colors in a pack of M&Ms.
      •    Click and drag to highlight the names of the colors (A1 through F7).
      •    Choose “Chart” from the Insert menu.
      •    Choose “Pie” as the chart type. Group the data by columns and use column A as
           labels.
      •    Type “Average # of colors in
           M&Ms” as the Chart Title
           and click Save Chart. You
           may need to insert rows in
           your spreadsheet to allow
           room for your chart.
   7. Follow example 2 in the Open
      Office activity and perform the
      same tasks in Google Docs with
      the “Temperature” spreadsheet.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                       page 18
                       Zoho Office – Sheet


Start the Mozilla Firefox browser, launch Zoho Personal from the Bookmarks toolbar and login
using the username and password assigned to you for this workshop.

Example 1: Using formulas and creating graphs
   1. Select Sheet from the list of applications on the left and open the file titled “M&M” in the
      My Sheets list. The file contains the results from 5 groups of students who were given
      packs of M&Ms and asked to collect the number of each color contained in the pack.



   2. Start by completing the formula that will provide the averages in column G. Place your
      cursor in cell G2. Click on the function icon (Fx) and choose Average from the function
      list. Click and drag on your spreadsheet from cell B2 to cell F2 and press the enter key.
   3. Have the result rounded to the nearest whole number by selecting the G2 cell. Choose
      “Decrease Decimal” from the other formats icon.
   4. Complete the remaining average formulas by clicking on cell G2 and dragging the “fill
      handle” down to cell G8.
   5. Complete the Total formula for each column using the sum function and filling to the
      right. Yes, Group 3 had the best pack!
   6. Complete a pie graph of the average # of colors in a pack of M&Ms.
      •    Click and drag to highlight the
           names of the colors (A1 through
           F7).
      •    Choose the “Chart” icon.
      •    Choose “Pie Chart” as the chart
           type and 3D as the subtype. Click
           Next and choose the Series in Cols
           (columns).
      •    Click Next and type “Average # of
           colors in M&Ms” as the Chart Title
           and click Done.
   7. Follow example 2 in the Open Office
      activity and perform the same tasks in
      Zoho Office with the “Temperature” spreadsheet.

Notice that all three spreadsheets offer a great amount of functionality in addition to using open
standard formats which makes sharing files easy.




               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                          page 19
              Installing Clip Art in the OpenOffice Gallery


Using clip art in Open Office differs a little bit from what you may be used to in Microsoft
Office. Although it doesn’t contain a “clip art index” like Microsoft, you can use the
Gallery Tool very effectively to add pictures to documents. These steps will help you
successfully add collections of clip art to your Open Office Gallery.

   1. In any Open Office document, use Tools/Gallery to make the Gallery visible.
   2. Click the New Theme button.




   3. Change the name to something
      reflective of the contents you
      plan to add to the Gallery. Type
      “Transportation Symbols” for
      this example.




               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 20
4. Click the Files tab, then the Find Files button.
   Locate the clip art folder that contains the
   images you wish to add to this new Gallery.

   Notice from the example at right that the folder
   titled “Aiga_transportation_symbols” is located
   within the Workshop folder.

   Once you click OK, OpenOffice will list all of
   the files that it can recognize. This may take a
   little time.

   Click the Add All button to link all of these files to the
   new Gallery. You are now ready to use the images.




5. Anytime you wish to add an
   image to a document, simply
   open the Gallery Tool, choose
   the Gallery you wish to use and
   “drag and drop” the image onto
   your page.

   Of course, you can always add
   pictures using
   Insert/Picture/From File and
   browsing directly for the clip
   art images.




           Open Source and Web 2.0 Workshop – Jim Hirsch, 2008   page 21
               Creating Your Own “Big Idea” Book


Don’t just read about Big Ideas, generate them! With this patent-pending open source Big Idea
Book Generator, you’re provided options for a title, subtitle, and premise. All you need to do is
pick a random image to serve as a cryptic representation of your Big Idea on the cover (see
sample book cover below). Well, all this and of course, actually writing the tome!

                                                    Step 1 – Select a book cover.
                                                    Open a new Drawing document in Open Office.
                                                    Instructions: Using the Insert/Picture/From File
                                                    option, choose from one of the three
                                                    backgrounds in the Workshop folder:
                                                    book_cover_a; book_cover_b; or
                                                    book_cover_c. Size the book cover to fit your
                                                    page. Save this file as “My Big Idea Book”.

                                                    Step 2 – Create a title-as-theory.
                                                    Your title needs to both summarize your
                                                    Big Idea and introduce a new term.
                                                    Instructions: Open the spreadsheet file
                                                    titled “Big_Idea”. Choose a word from
                                                    Set A and combine it with one from Set B.
                                                    Feel free to use one or two connectors
                                                    from the middle and start with “The” if
                                                    necessary. Or let the built-in random
                                                    generator do your picking for you! Go
                                                    back to your drawing and place your title
                                                    in a text field on your book background.

Step 3 – Subtitle it!
Since your Big Idea is an entirely new concept, you’ll need a subtitle that can do some
heavy lifting and explain things a bit. It should be both specific and vague, expressing
your Big Idea in a simple catchphrase while not giving away too much. Instructions: Go
back to the “Big_Idea” spreadsheet and pick one or more clauses from Set C, followed by
one from Set D.

Step 4 – Pick a premise.
Your book needs what seems like a premise. Not every nitwit will pick up on your Big
Idea from the subtitle, so this is a little helper that your publisher can send out in a letter to
reviewers. Instructions: Select one word or phrase from Sets E-H to sum up your brilliant
idea.
    Add an image to the cover along with your name and you're ready to publish!

                Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                              page 22
              The GIMP – GNU Image Manipulation Program

Since most of us are not artists, these exercises will acquaint you with a few of the filters and
features that the GIMP supports. Although the interface is not the same as Photoshop, you'll find
that the two programs share many of the same features and power user controls.

The examples are all contained in the GIMP_Files folder contained in the Workshop folder. This
handout will guide you to using some of the features available in the program. Feel free to
experiment as you wish.

Start the GIMP program.

Example 1: Blurred Backgrounds
   1. Open the file titled “Teens”.
   2. Select the girl in the center of the picture using the oval selection tool.
   3. Use the Select Menu and choose “Invert”.
   4. Use the Filters/Blur/Motion Blur.
   5. Check the Preview button, Radial Blur and a small amount of angle to get the effect you
      want.




Example 2: Sampling “Toned” Pictures
   1. Open the file titled “Girl_in_Hat”.
   2. Convert the image to B&W – select Image/Mode/Grayscale.
   3. Open a tone sample from the GIMP_Files folder – either “silver_gelatin” or “cyanotype”
   4. Move your cursor focus back to the image to be toned and run the Sample Colorize filter
      (Filters/Colors/Map/Sample Colorize).
   5. In the sample side options, choose the appropriate toning image in the drop down box (if
      it's not already showing). You probably want to keep the "Smooth Samples" checkbox
      checked and the "Use subcolors" unchecked.
   6. In the destination side options, you probably want to keep the "Hold Intensity" and
      “Original Intensity” checked.
   7. Click "Get Sample Colors" to get the sample colors into the destination preview.

              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 23
   8. If you want to adjust the luminosity (brightness or darkness) of the destination image then
      uncheck the "Original Intensity" option and adjust the In Level sliders accordingly. If
      Original Intensity is checked, then adjusting the In Level sliders just changes the
      distribution of sample colors without affecting luminosity.




Example 3: Transforming a new photo into an old photo (GIMP scripts)
   1. Open the file titled “Beach”
   2. Choose Script-Fu/Decor/Old Photo




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 24
Example 4: Layers – creating an image depicting a night sky without any drawing!
   1. Open the file titled “Layer_practice” - a black background for your image.
   2. Create a new layer named “Clouds” using Layer/New Layer and let the Layer Fill Type
      be “Transparency”.
   3. Create the actual clouds using Filters/Render/Clouds/Plasma. Choose a “Turbulence” of
      2.5 (actually, anything between 2 and 3 will work great).
   4. Remove the random colors by using Layer/Colors/Desaturate. This leaves a black &
      white cloud formation.
   5. Add some color back to create a more realistic scene using Layer/Colors/Color Balance.
      Set the color levels to Red: -24; Green: -16; Blue: 32 to achieve a nice night hue.
   6. Apply a more natural color gradation to the image by adding a new layer using
      Layer/New Layer and name it “Gradient” - let the Fill Type remain “Transparency”.
      Select the gradient color tool in GIMP (fourth tool row, second tool in) and draw a
      gradient path on your image from the top to the bottom. In the Layers dialog box, set the
      mode to “Multiply” to see the final effect.
   7. Add some stars to your image by creating a new layer using Layer/New Layer and name
      it “Stars” but this time make it black by using the Fill Type
      “Foreground color”. Create the stars by using Filters/Noise/Scatter
      RGB. Uncheck the “Independent RGB” option so you just have
      black & white stars. Brighten the stars using
      Layer/Colors/Auto/Stretch Contrast.
   8. To remove most of these stars (noise) and make it look more realistic
      use Layer/Colors/Curves. Adjust the curve by clicking and dragging
      the line to approximately the location shown here.
   9. To see the clouds in the image, change the layer mode to “Lighten
      only”. That's it – a nice image with no drawing!




                                                                                            With options
                                                                                            below




If you want to add a couple of nice “options”, try these:
   1. Choose the Clouds layer in the Layers dialog box. Soften the clouds using Filters/Blur/Gaussian Blur.
      Unlink the horizontal and vertical blur. Choose 32 for the horizontal blur radius and 0 for the vertical
      blur radius.
   2. Set one larger, brighter star in the image by adding a new layer using Layer/New Layer and name it
      “Bright” and make the Fill Type “Transparency”. Use Filters/Light Effects/Supernova to add the single
      bright star. The default radius is too large – set it to 4 or 5 and lower the number of spokes to 60.


               Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                                      page 25
              KompoZer – Web Authoring System

Since most of us are not professional web designers, these exercises will acquaint you with a few
of the features that KompoZer supports. Although the interface is not the same as
Dreamweaver, you'll find that the two programs share many of the same features and power user
controls.

The example web page (KompoZer_Page_Sample) is contained in the Workshop folder if you'd
like to review it at any time. Your task is to complete a web page displaying the following
elements and links. This handout will guide you to some of the techniques necessary.

Start the Nvu program.

   1. Add an image to the top of your page. Click on the Image icon and select the file titled
      “open_source_logo” found in the Images folder in the Workshop folder.
   2. Start a new line and add the introductory text for these two sites providing open source
      licensing information. Make a bulleted list on your page. The sites are Creative
      Commons at http://creativecommons.org/ and GNU General Public License at
      http://www.gnu.org/copyleft/gpl.html
   3. Place a line to start a separate section – Insert/Horizontal Line.
   4. Add a left-justifed image and linked text to the OpenOffice site. Choose the image titled
      “openoffice” and use the Appearance tag to left align the image. Add the text
      “OpenOffice” and place the link http://www.openoffice.org/ on the text.
   5. Press return to move the cursor below the image and add another horizontal line.
   6. Add the image titled “firefox” and place the link
      http://www.mozilla.org/products/firefox/ on the image.
   7. Save your HTML file in the Workshop folder.
   8. Start your Internet browser and open the local file you've just created to see if the
      formatting looks correct and if the links work.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 26
                  Audacity and VLC Media Player – Audio/Video Applications

Take a few moments and investigate the audio editing capabilities of Audacity as well as the
VideoLAN VLC media player.

Start the Audacity program.
    1. Open the file titled “Tryad - 08 - Bridge (a.k.a., Presidential Address)” found in the
        Documents/Music folder (the actual location and name of this folder depends on whether
        you're using the Portable Apps and PC or Macintosh versions – you may need to search!).




   2. Listen to the clip and then create a new “remix” by selecting portions of the audio and
      copying and pasting to a new file.
   3. Save your remix (actually “Export As MP3”).

Exit the Audacity program and start VLC Media Player.
   1. Open the file (try “Quick Open File”) titled “How_Did_I_Google_This” found in the
        Documents/Video folder (the actual location and name of this folder depends on whether
        you're using the Portable Apps and PC or Macintosh versions
        – you may need to search!).
   2. VLC reads all formats of video files – open the “Suki” Flash
        video, the “think_different” video (Open Office folder) or the
        “elephants dream” video – an open source video production
        – as examples.
   3. VLC also is a DVD player.




For those of you who have been accessing these applications in “portable” mode, I hope
you've been impressed with how convenient and mobile this option could be for students.


              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                        page 27
           CamStudio – Open Source Streaming Video Software

CamStudio is able to record all screen and audio activity on your computer and create industry-
standard AVI video files and using its built-in SWF Producer can turn those AVIs into lean,
mean, bandwidth-friendly Streaming Flash videos (SWFs).

CamStudio can also add high-quality, anti-aliased (no jagged edges) screen captions to your
recordings in seconds and with the unique Video Annotation feature you can even personalize
your videos by including a webcam movie of yourself "picture-in-picture" over your desktop.

   1. Preview an existing quick demo of using spreadsheets in Google Docs created with
      CamStudio by starting VLC Player from the PortableApps menu.
   2. Use the Open File option from the Media menu and open the file “Google_spreadsheet”
      from the Video folder. This gives you an idea of the quality provided by the program.
   3. Create your own training video by starting CamStudio from the icon on your desktop (no,
      CamStudio is not a Portable Apps program – it must be installed separately).




   4. Minimize the CamStudio window. It will continue running in the background. Decide
      what activity you wish to record and then simply remember two keyboard shortcuts.
      Function 8 (F8) to start/pause recording and Function 9 (F9) to stop recording and create
      the video file. That's all there is to it!
   5. There are a number of advanced features available on the software that you can try if you
      wish.




              Open Source and Web 2.0 Workshop – Jim Hirsch, 2008                         page 28

				
DOCUMENT INFO
Description: Open Source Spreadsheet document sample