Docstoc

Panduan Mikrotik RB 750

Document Sample
Panduan Mikrotik RB 750 Powered By Docstoc
					                                                                                               SLIC




                                             DAFTAR ISI



A.      PENDAHULUAN ....................................................................................... 2
B.      WINBOX .................................................................................................. 3
C.      MIKROTIK SEBAGAI NAT .......................................................................... 9
D.      MIKROTIK SEBAGAI TRANSPARENT WEB PROXY..................................... 11
E.      MIKROTIK DHCP .................................................................................... 15
F.      MIKROTIK SEBAGAI BANDWIDTH LIMITER.............................................. 17
G.      MIKROTIK FIREWALL .............................................................................. 23
H.      MIKROTIK SEBAGAI MRTG / GRAPHING ................................................. 25
LAMPIRAN ...................................................................................................... 30




Mikrotik v3.x RouterBOARD
                                                                                                         1
                                                      SLIC




A. Pendahuluan

    Mikrotik sekarang ini banyak digunakan oleh ISP, provider
hotspot, ataupun oleh pemilik warnet. Mikrotik OS menjadikan
komputer menjadi router network yang handal yang dilengkapi
dengan berbagai fitur dan tool, baik untuk jaringan kabel maupun
wireless.
    Modul ini menyajikan pembahasan dan petunjuk sederhana dan
simple dalam mengkonfigurasi mikrotik untuk keperluan-keperluan
tertentu dan umum yang biasa dibutuhkan untuk server/router warnet
maupun jaringan lainnya, konfigurasi tersebut misalnya, untuk NAT
server, Bridging, Bandwidth manajemen, dan MRTG.
Versi mikrotik digunakan untuk tutorial ini adalah MikroTik
routerOS 3.x
        Routing memegang peranan penting dalam suatu network
terutama dalam mengatur jalur data dari satu komputer ke komputer
lain. Komputer yang bertugas mengatur routing di sebut Router.

        MIKROTIK mempunyai banyak service atau tool sehingga
bisa dijadikan DHCP server, PROXY server, RADIUS server, DNS
server, VPN server selain sebagai router.




Mikrotik v3.x RouterBOARD
                                                             2
                                                     SLIC




B. Winbox

    Dengan Winbox ini kita bisa mendeteksi System Mikrotik yang
sudah di install asalkan masih dalam satu network, yaitu dengan
mendeteksi MAC address dari ethernet yang terpasang di Mikrotik.
Tampilan awal pertama kali mengaktifkan winbox adalah seperti
berikut :




        Kita tinggal pilih MAC address yang sudah terdeteksi dan
klik tombol Connect. Maka akan muncul tampilan seperti di bawah :


Mikrotik v3.x RouterBOARD
                                                            3
                            SLIC




Memberi nama Mirotik
Klik System → Identity




Mikrotik v3.x RouterBOARD
                                   4
                                          SLIC




Edit nama identity yang kita inginkan :




Mikrotik v3.x RouterBOARD
                                                 5
                                                        SLIC



Mengganti nama interface:




Pilih menu interface, klik nama interface yg ingin di edit, sehingga
muncul jendela edit interface.

Setting IP Address :




Mikrotik v3.x RouterBOARD
                                                               6
                                                        SLIC




        Untuk menambahkan ip address klik menu + , kemudian kita
tuliskan ip address yang akan digunakan dan untuk ethernet nomor
berapa. Setelah itu klik tombol ok

Setelah ip sudah di setting maka di daftar ip muncul nomor ip nya

Setting Gateway
       Langkah selanjutnya adalah menentukan default gatewaynya,
yaitu melalui menu ip  Routes , kemudian akan ditampilkan
windows seperti di bawah.




Mikrotik v3.x RouterBOARD
                                                               7
                            SLIC




Setting DNS




Mikrotik v3.x RouterBOARD
                                   8
                                                       SLIC




C. Mikrotik Sebagai NAT

    Network Address Translation atau yang lebih biasa disebut
dengan NAT adalah suatu metode untuk menghubungkan lebih dari
satu komputer ke jaringan internet dengan menggunakan satu alamat
IP. Banyaknya penggunaan metode ini disebabkan karena
ketersediaan alamat IP yang terbatas, kebutuhan akan keamanan
(security), dan kemudahan serta fleksibilitas dalam administrasi
jaringan.

    Saat ini, protokol IP yang banyak digunakan adalah IP version 4
(IPv4). Dengan panjang alamat 4 bytes berarti terdapat 2 pangkat 32
Mikrotik v3.x RouterBOARD
                                                              9
                                                         SLIC

= 4.294.967.296 alamat IP yang tersedia. Jumlah ini secara teoretis
adalah jumlah komputer yang dapat langsung koneksi ke internet.
Karena keterbatasan inilah sebagian besar ISP (Internet Service
Provider) hanya akan mengalokasikan satu alamat untuk satu user
dan alamat ini bersifat dinamik, dalam arti alamat IP yang diberikan
akan berbeda setiap kali user melakukan koneksi ke internet. Hal ini
akan menyulitkan untuk bisnis golongan menengah ke bawah. Di
satu sisi mereka membutuhkan banyak komputer yang terkoneksi ke
internet, akan tetapi di sisi lain hanya tersedia satu alamat IP yang
berarti hanya ada satu komputer yang bisa terkoneksi ke internet. Hal
ini bisa diatasi dengan metode NAT. Dengan NAT gateway yang
dijalankan di salah satu komputer, satu alamat IP tersebut dapat
dishare dengan beberapa komputer yang lain dan mereka bisa
melakukan koneksi ke internet secara bersamaan.

    Misal kita ingin menyembunyikan jaringan local/LAN
192.168.0.0/24 dibelakang satu IP address 202.51.192.42 yang
diberikan oleh ISP, yang kita gunakan adalah fitur Mikrotik source
network address translation (masquerading) . Masquerading akan
merubah paket-paket data IP address asal dan port dari network
192.168.0.0/24 ke 202.51.192.42 untuk selanjutnya diteruskan ke
jaringan internet global.

    Untuk menggunakan masquerading, rule source NAT dengan
action 'masquerade' harus ditambahkan pada konfigurasi firewall:




Mikrotik v3.x RouterBOARD
                                                                10
                                                      SLIC




D. Mikrotik sebagai Transparent web proxy

    Salah satu fungsi proxy adalah untuk menyimpan cache. Apabila
sebuah LAN menggunakan proxy untuk berhubungan dengan
Internet, maka yang dilakukan oleh browser ketika user mengakses
sebuah url web server adalah mengambil request tersebut di proxy
server. Sedangkan jika data belum terdapat di proxy server maka
proxy mengambilkan langsung dari web server. Kemudian request
tersebut disimpan di cache proxy. Selanjutnya jika ada client yang
melakukan request ke url yang sama, akan diambilkan dari cache
tersebut. Ini akan membuat akses ke Internet lebih cepat.

   Bagaimana agar setiap pengguna dipastikan mengakses Internet
melalu web proxy yang telah kita aktifkan? Untuk ini kita dapat
Mikrotik v3.x RouterBOARD
                                                             11
                                                   SLIC

menerapkan transparent proxy. Dengan transparent proxy, setiap
Browser pada komputer yang menggunakan gateway ini secara
otomatis melewati proxy.

Pada winbox:




Setting web proxy transparent




Mikrotik v3.x RouterBOARD
                                                          12
                                                           SLIC




3. Membuat rule             untuk   transparent   proxy   pada    menu
IP>Firewall>NAT



Mikrotik v3.x RouterBOARD
                                                                  13
                            SLIC




Mikrotik v3.x RouterBOARD
                                   14
                            SLIC

E. Mikrotik DHCP

DHCP SERVER

   1.Membuat address pool




Mikrotik v3.x RouterBOARD
                                   15
                                                 SLIC

2. Tentukan interface yang dipergunakan dan aktifkan DHCP
Server.




Mikrotik v3.x RouterBOARD
                                                        16
                                                       SLIC

DHCP CLIENT




F. Mikrotik sebagai Bandwidth Limiter
    Mikrotik juga dapat digunakan untuk bandwidth limiter (queue) .
Untuk mengontrol mekanisme alokasi data rate. Secara umum ada 2
jenis manajemen bandwidth pada mikrotik, yaitu simple queue dan
queue tree. Silahkan gunakan salah satu saja.
Mikrotik v3.x RouterBOARD
                                                              17
                                                    SLIC



Simple queue:
Misal kita akan membatasi bandwidth client dengan ip 192.168.0.3
yaitu untuk upstream 128kbps dan downstream 128kbps
Setting pada menu Queues → Simple Queues.




Queue tree




Mikrotik v3.x RouterBOARD
                                                           18
                            SLIC




Mikrotik v3.x RouterBOARD
                                   19
                                          SLIC




Sehingga hasil mangle seperti berikut :




Klik menu Queues>Queues Tree

Mikrotik v3.x RouterBOARD
                                                 20
                            SLIC




Mikrotik v3.x RouterBOARD
                                   21
                                                  SLIC




Ketika client mengakses internet dengan melakukan downloading
file maka telah di limit berdasarkan queue tree yang dibuat.




Mikrotik v3.x RouterBOARD
                                                         22
                                                      SLIC




G. Mikrotik Firewall
        Mikrotik sebagai firewall dengan berdasarkan pada stateful
   filtering technology dapat mendeteksi dan memblocking stealth
   scan,serangan DoS, SYN flood, dan bentuk serangan lainnya
   yang dapat membahayakan network internal/lokal. Firewall pada
   mikrotik cukup mudah untuk di manage.




Mikrotik v3.x RouterBOARD
                                                             23
                                                        SLIC

   Contoh dibawah ini digunakan untuk memblok jenis virus
   yang dapat berkeliaran dinetwork lokal kita:

   /ip firewall filter
   add chain=forward connection-state=established
   comment=”allow established connections”

   add chain=forward connection-state=related
   comment=”allow related connections”

   add chain=forward connection-state=invalid
   action=drop comment=”drop invalid connections”

   add chain=virus protocol=tcp dst-port=135-139
   action=drop comment=”Drop Blaster Worm”



       Script untuk mencegah virus diatas cukup di copy lalu dipaste
   diterminal melalui Winbox, seperti berikut:




   Sehingga pada IP→Firewall→Filter Menjadi




Mikrotik v3.x RouterBOARD
                                                               24
                                                    SLIC

   Firewall agar router tidak bisa di ping?


H. Mikrotik sebagai MRTG / Graphing
   Graphing adalah tool pada mokrotik yang difungsikan untuk
memantau perubahan parameter-parameter pada setiap waktu.
Perubahan perubahan itu berupa grafik uptodate dan dapat diakses
menggunakan browser.
Graphing dapat menampilkan informasi berupa:
  * Resource usage (CPU, Memory and Disk usage)
  * Traffic yang melewati interfaces
  * Traffic yang melewati simple queues

Mengaktifkan fungsi graping
        Klik menu Tool >Graphing>Resource Rules
Adalah mengaktifkan graphing untuk resource usage Mikrotik.
Sedangkan allow address adalah IP mana saja yang boleh mengakses
grafik tersebut. 0.0.0.0/0 untuk semua ip address.




Mikrotik v3.x RouterBOARD
                                                           25
                                                    SLIC




Klik menu Tool>Graphing>Interface Rules
Adalah mengaktifkan graphing untuk monitoring traffic yang
melewati interface, silahkan pilih interface yg mana yang ingin
dipantau, atau pilih “all” untuk semua.




Mikrotik v3.x RouterBOARD
                                                           26
                                                   SLIC




        Graphing terdiri atas dua bagian, pertama mengumpulkan
informasi/ data yang kedua menampilkanya dalam format web.
Untuk mengakses graphics, ketik URL dengan format
http://[Router_IP_address]/graphs/ dan pilih dari menu-menu
yang ada, grafik mana yang ingin ditampilkan.
Contoh hasil grafik untuk traffic interface public:




Mikrotik v3.x RouterBOARD
                                                          27
                            SLIC




Mikrotik v3.x RouterBOARD
                                   28
                                                SLIC



                            REFERENSI


   1. http://www.mikrotik-id.blogspot.com

   2. http://www.indonesiacyber.net/

   3. http://www.mikrotik.com

   4. http://wiki.mikrotik.com/wiki/Main_Page




Mikrotik v3.x RouterBOARD
                                                       29
                                                        SLIC

LAMPIRAN:


Kebutuhan hardware minimal untuk Router PC :
      Pentium II
      RAM 64 Mb
      Harddisk IDE 400 Mb

1. INSTALASI MikrotikOS ISO




        Pada menu instalasi di tampilkan service apa saja yang ingin
kita install. Untuk lebih mudahnya kita pilih semua service yang di
sediakan dengan menekan tombol „a‟. maka semua service akan
terpilih.


Mikrotik v3.x RouterBOARD
                                                               30
                                                      SLIC




       Apabila kita menginstall baru tekan tombol „n‟ atau apabila
kita hanya menambahkan service baru tekan tombol „y‟ agar
konfigurasi yang sudah di buat tidak hilang.

Langkah berikutnya akan disiapkan ruang harddisk yang akan di
pakai oleh MIKROTIK dengan memformatnya dan mengkopikan
file-file yang dibutuhkan.




Mikrotik v3.x RouterBOARD
                                                             31
                                                      SLIC




        Setelah proses pengkopian file selesai kemudian proses
instalasi membutuhkan reboot ulang. Apabila semua proses instalasi

Mikrotik v3.x RouterBOARD
                                                             32
                                                     SLIC

tidak mengalami error setelah reboot ulang di layar akan muncul
tampilan user login dan password, seperti gambar di bawah :




        Secara default user yang dipakai adalah user admin dengan
password yang masih kosong. Setelah login tampilan awal seperti
berikut :




Mikrotik v3.x RouterBOARD
                                                            33
                                                   SLIC




Akses mirotik:
via console
Mikrotik router board ataupun PC dapat diakses langsung via
console/shell maupun remote akses menggunakan putty
(www.putty.nl)
via winbox
Mikrotik bisa juga diakses/remote menggunakan software tool
winbox.
via web
Mikrotik juga dapat diakses via web/port 80 dengan menggunakan
browser.




Mikrotik v3.x RouterBOARD
                                                          34
                                                       SLIC



2. BASIC COMMAND LINE

Perintah untuk shutdown restart computer

[admin@MikroTik]>system shutdown (Untuk shutdown komputer
)

[admin@MikroTik]>system reboot (Untuk restart computer )

[admin@MikroTik]>system reset (Untuk meret konfigurasi yang
sudah dibuat sebelumnya). Dan perlu diperhatikan bahwa perintah –
perintah tersebut harus dilakukan pada direktori admin.

Untuk menampilkan informasi tabel routing




       Command di console mikrotik bersifat auto completion
dimana setiap command yang kita ketik belum lengkap maka ketika
kita menekan tombol tab pada keyboard, command tersebut akan
lengkap penulisannya.Misal: anda mengetik ip rou lalu menekan
tombol tab, maka otomatis menjadi ip route.
       System direktori pada mikrotik model nya seperti tree.Ketika
kita aktif di direktori tertentu kita dapat langsung memanggil
Mikrotik v3.x RouterBOARD
                                                              35
                                                     SLIC

command pada direktori yang lain.Misal anda berada pada direktori
ip route maka diposisi tersebut anda dapat langsung memanggil
command yang lain dengan format penulisan /ping. Tanda “/” harus
berada terdepan lalu diikuti command.

Contohnya seperti berikut:




Untuk Mengecek ip address dan interfacess




Mikrotik v3.x RouterBOARD
                                                            36

				
DOCUMENT INFO
Shared By:
Stats:
views:43046
posted:10/5/2010
language:Indonesian
pages:36