Docstoc

Challenge Inter-VLAN Routing

Document Sample
Challenge Inter-VLAN Routing Powered By Docstoc
					6.4.2 Challenge Inter-VLAN Routing




R1
Router#conf t
Router(config)#hostname R1
R1(config)#enable secret class
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 15
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface fa 0/1.1
R1(config-subif)#encapsulation dot1Q 1
R1(config-subif)#ip address 192.168.1.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa 0/1.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa 0/1.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa 0/1.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa 0/1.99
R1(config-subif)#encapsulation dot1Q 99 native
R1(config-subif)#ip address 192.168.99.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fa 0/1
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fa 0/0
R1(config-if)#ip address 192.168.50.1 255.255.255.0
R1(config-if)#description server interface
R1(config-if)#no shutdown
R1(config-if)#end
R1#cop r s
R1#



S1
Switch>en
Switch#configure terminal
Switch(config)#hostname S1
S1(config)#no ip domain-lookup
S1(config)#enable secret class
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#vtp mode server
S1(config)#vtp domain Lab6
S1(config)#vtp password cisco
S1(config)#vlan 99
S1(config-vlan)#name Management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name R&D
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Engineering
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Sales
S1(config-vlan)#exit
S1(config)#interface vlan 99
S1(config-if)#ip address 192.168.99.11 255.255.255.0
S1(config-if)#exit
S1(config)#interface range fastethernet 0/1 - fastethernet 0/5
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdow
S1(config-if-range)#exit
S1(config)#ip default-gateway 192.168.99.1
S1(config)#




S3
Switch>en
Switch#configure terminal
Switch(config)#hostname S3
S3(config)#enable secret class
S3(config)#no ip domain-lookup
S3(config)#line console 0
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#exit
S3(config)#line vty 0 15
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#exit
S3(config)#interface vlan 99
S3(config-if)#ip address 192.168.99.13 255.255.255.0
S3(config-if)#exit
S3(config)#ip default-gateway 192.168.99.1
S3(config)#vtp mode client
S3(config)#vtp domain Lab6
S3(config)#vtp password cisco
S3(config)#interface range fa 0/1 - fa 0/5
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdow
S3(config-if-range)#end
S3#



S2
Switch>en
Switch#configure terminal
Switch(config)#hostname S2
S2(config)#enable secret class
S2(config)#no ip domain-lookup
S2(config)#line console 0
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#exit
S2(config)#line vty 0 15
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#exit
S2(config)#interface vlan 99
S2(config-if)#ip address 192.168.99.12 255.255.255.0
S2(config-if)#exit
S2(config)#ip default-gateway 192.168.99.1
S2(config)#vtp mode client
S2(config)#vtp domain Lab6
S2(config)#vtp password cisco
S2(config)#interface range fastethernet 0/6 - fastethernet 0/10
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#exit
S2(config)#interface range fastethernet 0/11 - fastethernet 0/17
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#exit
S2(config)#interface range fastethernet 0/18 - fastethernet 0/24
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#exit
S2(config)#interface range fastethernet 0/1 - fastethernet 0/5
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdow
S2(config-if-range)#
S2#

assign IP addresses on webserver and PCs