modem-ppp by khn19658

VIEWS: 13 PAGES: 7

									ppp                                                              Commands                                                        Configuration



Cisco commands summary                                                                                  Comments
      Configure ppp with dialup (dedicated)
         int s0/1
         physical-layer async
         ip address 192.168.0.1 255.255.255.0                                                ip address since dedicated
         asunc mode dedicated
         no cdp enable                                                                          to limit overhead traffic
         dialer in-band                                                                               for ddr suport
         dialer wait-for-carrier-time 60
         dialer hold-queue 50                                                          number of ip packets kept in queue
         dialer group 1                                                             dialer list assignment for interesting traffic
         dialer map ip 192.168.0.3 name sj1 modem-script hayes56k broadcast 5556001
         exit
         chat-script hayes56k ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT
         dialer-list 1 protocol ip permit
         ip route 192.168.0.0 255.255.255.0 192.168.0.3

      Configure PPP with dialup (interactive)
         int s0/1
         physical-layer async
         peer default ip address 192.168.0.5
         asunc mode interactive
         autoselect ppp

      Authentification and compression
          int s0/1
          ppp auth pap
          exit
          username host password cisco

          int s0/1
          ppp compression stacker

      useful debug commands
          debug confmodem
          modem autoconfigure discovery
          clear line x
          disconnect
          show dialer
          show modemcap
          debug ppp nego
          debug ppp auth
          show compress

      Configure PPP with dialup (aux on 2500)
         int async 1
         ip address 192.168.0.1
         peer default ip address 192.168.0.5
         asunc mode dédicated                                                                 or "autoselect ppp during-login"
         encap ppp
         ppp auth chap (optional)

      Local pool                                                                               add the following commands
          ip local pool DIAL-IN 10.1.1.2 10.1.1.254
          interface group-async 1
          ip peer default ip address pool DIAL-IN
          async dynamic address




8:37 PM8/28/2010                                                                                                                            1
BRI                                                              Commands                                               Configuration



Cisco commands summary                                                                        Comments
      typical config (legacy)
           conf t
           isdn switch-type basic-ni
           username sj1 password cisco
           enable password cisco

          dialer-list protocol ip permit

          int bri0/0
          ip address 192.168.0.3 255.255.255.0
          encapp ppp
          ppp auth chap
          dialer group 1
          isdn spid1 51055540000001 broadcast 5554000
          isdn spid2 51055540010001 5554001
          dialer idle-timeout 60
          dialer map ip 192.168.0.1 name sj1 broadcast 5551234
          no shut

      for debugging
           show isdn status
           clear int bri0/0
           debug dialer
           show dialer
           dbug isdn events
           debug ppp auth
           debug ppp nego

      for disconnecting
           disconnect int bri0/0

      Snapshot routing                                                                    add these command
         snapshot server 5                                                                 put on server side
                                                                                            put on client side
          snapshot client 5 720 suppress-state-change-update dialer         [timer on][timer quiet], dialer keyword to en dial
          dialer map snapshot 1 name SJ1 broadcast 5551234

          show snapshot                                                                         ; to verify
      ppp multilink
          int bri0/0
          ip address 192.168.0.3 255.255.255.0
          encapp ppp
          ppp auth chap                                                     ; do not forget username and password in global
          dialer group 1
          isdn spid1 51055540000001 5554000
          isdn spid2 51055540010001 5554001
          dialer idle-timeout 60
          dialer map ip 192.168.0.1 name sj1 broadcast 5551234
          dialer map ip 192.168.0.1 name sj1 broadcast 5551235
          ppp multilink                                                                     on both routers
          dialer load-threshold 1 either                                                    on both routers
          no shut

      configuring backup isdn
          int s0/0
          backup interface bri0/0
          backup delay 6 8 (also backup load 2 1,% of bw)                    6 number of sec before isdn dialup on s0 fail
                                                                             8 secs after s0 is up again, isdn is deactivited




8:37 PM8/28/2010                                                                                                                   2
Modem                                                         Commands                                                        Configuration



Cisco commands summary                                                                               Comments
   async mode
       interface s0/1
       physical-layer async

   Line configuration
       line 2
       login
       password cisco
       speed 9600
       flowcontrol hardware
       modem inout
       transport input all
       stopbits 1

   Reverse Telnet
      int lo0                                                                               or use another valid interface
      ip address 192.168.0.1 255.255.255.255
      line vty 0 4                                                                         mettre un password pour telnet
      login
      password cisco
      exit

        telnet 192.168.01 2002                                                              reverse telnet add 2000 to line
                                                                                           note clear line x and disconnect

   Useful modem commands (COMMON)
      AT H                                                                                             hangup
      AT&F                                                                                       load factory setting
      ATS0=1                                                                                     answer after 1 ring
      AT&W                                                                                      write config to nvram
      ATE1                                                                                      put echo on, 0 = off
      ATZ
   commands specific to vendor
                    HAYES                               USR
                 AT&V                                  ATI4                                          show config
                 AT$H                                  AT$                                           Getting help
                 AT&K3                                 AT&H1&R2                                 Hardware flow control
                 AT&Q6                                 AT&B1                                      lock to dte speed
   Configure ppp with dialup (dedicated)
      int s0/1
      physical-layer async
      ip address 192.168.0.1 255.255.255.0                                                ip address since dedicated
      asunc mode dedicated
      no cdp enable                                                                          to limit overhead traffic
      dialer in-band                                                                               for ddr suport
      dialer wait-for-carrier-time 60
      dialer hold-queue 50                                                          number of ip packets kept in queue
      dialer group 1                                                             dialer list assignment for interesting traffic
      dialer map ip 192.168.0.3 name sj1 modem-script hayes56k broadcast 5556001
      exit
      chat-script hayes56k ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT
      dialer-list 1 protocol ip permit
      ip route 192.168.0.0 255.255.255.0 192.168.0.3




8:37 PM8/28/2010                                                                                                                         3
Dialer Profile                                     Commands                                               Configuration



Cisco commands summary                                                           Comments

    Configuring Dialer profiles and map class SJ
       isdn switch-type basic-ni                                            ; configure global stuff
       username capetown password cisco
       username juliet password cisco
       dialer list 5 protocol ip permit

        interface bri0/0
        isdn spid1 51055512340001 5551234
        isdn spid1 51055512350001 5551235
        encap ppp
        ppp auth chap
        ppp chap hostname romeo                               will be able to authenticate as both sj and romeo
        dialer pool member 1
        no shut

        map-class dialer AGG
        dialer idle-timeout 30
        dialer fast-idle 10
        dialer wait-for-carrier-time 25
        exit

        int dialer 0
        ip address 192.168.16.1 255.255.255.0
        dialer pool 1
        encap ppp
        ppp auth chap
        dialer remote-name capetown                                      ;to detect wich int to bind to
        dialer-group 5
        dialer string 5554000 class AGG
        dialer string 5554001 class AGG

        int dialer 1
        ip address 172.16.0.1 255.255.255.0
        dialer pool 1
        encap ppp
        ppp auth chap
        ppp chap hostname romeo                                   since not using local assigned hostname
        dialer remote-name juliet                             capetown must have chap hostname juliet to bind
        dialer-group 5
        dialer string 5554000 class AGG
        dialer string 5554001 class AGG


Configuring pri
       controller t1 1/0                                                     configure controller
       framing esf
       linecode bzs
       pri-group timeslots 1-24

        int s 1/0:23                                             configure the d channel, cloned to all other
        ip address 192.168.16.1 255.2555.255.0
        dialer group 1
        encap ppp
        ppp auth chap

        dilaer map ip xxxxx name xxxx 55570001                 put dialer maps and secondary address to dial




8:37 PM8/28/2010                                                                                                     4
Frame                                                       Commands                                               Configuration



Cisco commands summary                                                 Comments

   Frame relay switch
      frame-relay switching
      int s0
      encap frame-relay
      frame-relay intf-type dce
      frame-relay route 18 int s1 16
      int s1
      frame-relay route 16 int s0 18                                   sh frame-relay route
   Frame-relay                                                         using inv arp for mapping
      int s0/0                                                         sh frame-relay pvc
      encap frame-relay                                                sh frame- relay map
      ip address 192.168.192.1 255.255.255.0
      no shut
      exit
   Frame-relay with static maps
      int s0/0
      encap frame-relay
      ip address 192.168.192.1 255.255.255.0
      frame-relay map ip 192.168.192.2 18 broadcast
      frame-relay lmi-type ansi
      no shut
   Frame-relay with sub int
      int s0/0
      encap frame-relay
      no ip address
      frame-relay lmi-type ansi
      no shut
      int s0/0.17 point-to point (or multipoint see note)              use point to point with sub interface
      ip address x.x.x.x 255.255.255.0                                 use multipoint if hub and spoke,sub- interafce will
      frame-relay interface-dlci 17                                    be able to use more than 1 pvc
   Configuring ODR
      router odr                                                       make sure that cdp is enable
      cdp run                                                          note vlsm is supported
      router ospf 1
      redistribute odr metric 100 subnets




8:37 PM8/28/2010                                                                                                              5
NAT/DHCP                                                         Commands                                                  Configuration



Cisco commands summary                                                                          Comments
   Dynamic NAT
       ip nat pool [name] [start priv addr range ] [end priv addr range] [net mask]              define pool
   ex: ip nat pool [net-172] [200.16.1.10 ] [200.16.1.200] [255.255.255.0]

       access-list 2 permit 172.16.0.0 0.0.255.255                                      permit addr to be translated
       ip nat inside source list 2 pool net-172 [overload]                                   enable translation
                                                                                         (add oveload key for PAT)
       int fa0/0                                                                         specify inside interface(s)
       ip nat inside

       int s0/0                                                                           specify outside interface
       ip nat outside

   Static Case
       ip nat inside source static 10.10.10.2 202.206.154.2                                      static case
       int fa0/0                                                                         specify inside interface(s)
       ip nat inside
       int s0/0                                                                           specify outside interface
       ip nat outside

   DHCP
      ip dhcp pool [name]
      network a.b.c.d /nn                                                             specify the net pool of addr avail
      ip dhcp exclude a.b.c.d    d.e.f.g                                                 specify the exclude range
      default-router a.b.c.d                                                                specify the gateway
   IP HELPER                                                                            Use when dhcp server not
       int e0                                                                          accessible via udp broadcast
       ip helper addr a.b.c.d                                                           put addr of intf doing dhcp
   Loopbacks                                                                                creating loopbacks
      int loN                                                                              N maybe any number
      ip addr x.x.x.x 255.255.255.0




8:37 PM8/28/2010                                                                                                                      6
Radius                                                            Commands                                           Configuration



Cisco commands summary                                                       Comments


         aaa new-model
         radius-server host 10.1.1.254
         radius-server key cisco

         aaa authentification login default group radius enable none         name of list of method her is default

         aaa uthentification ppp CCC group tacas+ none                       ccc is name of list of method
         Iint bri0/0
         ppp authen chap CCC

								
To top