gta3 codes

Document Sample
gta3 codes Powered By Docstoc
					                   Tutorial on:
      “How to convert cars to San Andreas with
                      Gmax”
These are the tools required:
Gmax1.2 – Official site: http://www.turbosquid.com/
KAM’s Gmax script
TXDWorkshop
IMGTool2

To make it easier to download I packed everything but gmax’s setup file. Also
there is a Readme file how and where to extract the files...
You can download the ZIP HERE
The Gmax setup from THIS site.
(If any of these links doesn’t work Google is your friend!!)
A small problem during the tutorial

!!!THESE PROGRAMS ARE FREE, BUT THE GMAX WILL
NEED A CODE WICH IS GENERATED MONTHLY ON THE
GIVEN SITE. I ZIPPED MINE BUT IT WORKS ONLY FOR 30
DAYS, SO TO SOLVE THIS YOU CAN REGISTER FREE ON
THE SITE AND GET A CODE OR JUST PM ME ON THE
GTAFORUMS.COM!!!

It isn’t so hard but it takes some time to do it.
Start the IMGtool and open the gta3.img file located in the models
folder and choose a car. (I used the Mafia Sentinel from GTA3)
Export its DFF and TXD file in a prepared folder.
Now open TXDworkshop and select “Open txd” and select your file.
Click “Export” and “Export all textures to tga images”. Here select the
folder where you want to do all the work. (I suggest a separate folder
from the dff and txd files...)
Start Gmax (and enter the serial number if u haven’t done it yet).
And click the Tools menu which is marked with a small hammer like
this:

And click DFF I/O and a new menu will pop up. There click the
“import dff” button and select your DFF.
Now it’ll import you car into Gmax. The model is a bit far so we have
to “Zoom extends all” with this button in the right down corner:     I
suggest a saving here to that folder where you exported the TGA files!
Everything is fine but the textures aren’t shown in the model and there
are some differences in the GTA3 and SA cars’ hierarchy and the
script changes the name of some meshes. All we have to do is to
correct these problems… I suggest frequent saving here!!!
First we make the textures visible by the help of the Material
Navigator which is located on the top right corner of Gmax marked
with this icon:
And a new window will pop up. There you should check the
“Applied” radio button and many small spheres would be shown
which shows the material applied on this sphere.
There are small blue dots before the spheres which means that the
material isn’t visible. Click double on the first “sphere” and the
“material editor” will pop up.
There you should click to the first sub-material. The material editor
will switch to this sub-material. There you should click this button:
Now the texture will show on that part which has this material. We
have to do this with all the sub-materials until all the blue-white box is
pressed. We can easily shift to the next sub material by this button:
If you finished with this Material switch back to the material navigator
and you will se that the blue dot now red. Click to the next material
and do this operation until all the sub-materials have red dots…
The end of this process should look similar to this:
Now we have to remove the unnecessary dummies and rename that
parts. If you worked with a different car I show you a default SA
hierarchy:




You can edit the names by pressing H and tick “Display sub tree” and
select all objects which contains “_hi” in their name and press Select.
Now in the viewport where the model is click with right mouse button
and click “Hide unselected”




NOTE: If you have characters something like wingdings in this menu
you can correct it by going to the “Customize” menu and select
“Customize User Interface”. There select Quads and click advanced
options.
A new window will pop up there switch the font styles from Arial
Bold to Arial. That should do the trick…




If you have done the hiding of the unselected objects you can see only
that parts which have _hi tag in their name. Click on one of them and
correct its name in here by deleting the _hi part.
Do this with all these objects EXCEPT the “wing_rf_ok” and
“wing_lf_ok” meshes because the SA doesn’t use these. Later we will
Attach it to the chassis!

If you finished this boring work you can delete the wing_rf_dam and
wing_lf_dam because SA doesn’t use these too. Now we’ll Attach the
fenders to the chassis. Click on the chassis and select Modify menu
marked with this icon:
Here you can see many options. Find the Attach List button and click
on it. In the new window select wing_lf_ok and wing_rf_ok.
Click Attach and in the new menu leave everything alone and click
OK.




Now the fender is added to the chassis. Now we have to unhide all the
objects by right click in the viewport and select Unhide all. Now we
have to delete some objects. I show you a picture where all the deleted
parts are marked:
We almost finished with the 3D model but we need wheels… Don’t
worry you don’t have to make it because I packed one for you and you
only have to do the Merging. With this we can merge 2 different gmax
files. Just click on file and select “Merge…” and select the
wheel.gmax file where you unzipped that and in the new window
select the “wheel” and click ok. After this another dialogue box
appears because there are two same named materials. I suggest you
clicking on Auto-rename material.




Now the wheel is in the scene but not on the right place and not linked
to the wheel_rf_dummy. First we select the wheel and align it to the
dummy by pressing the align icon:
Now press “H” key and select wheel_rf_dummy and click Pick. In the
new window do the same as in this picture:
Now the wheel is in place:




Now we have to link it to the dummy. Select the wheel and press the
link button:   Next to the Undo/Redo button. Press “H” key and
select wheel wheel_rf_dummy and click Link and the click on the
“Select object button”:      You can see that the wheel is under the
dummy:
If you have hidden some objects right click in the viewport and select
Unhide all. Now we are ready to EXPORT!!! Go to the
gmax/scripts/GTA_Tools/ folder and start GTAMax.exe

A small icon will display on the right corner of the tray.



Now go back to gmax and select all the objects by pressing h key and
select all of them…
In the tools menu ( ) click DFF I/O and click                 under the
export part and select my packed sultan.dff file and then click Export.
Here set the name of the car which you want to replace. I replaced
“sentinel” because they are similar. So type sentinel in the saving
location and click save.




Now Gmax will for some mins dependant on your computer and then
gtamax.exe will create the dff file. After it finished save your work
and exit gmax.
The dff file is OK but we have to convert the txd to the SA’s format.
Open TXDWorkshop and open Mafia.txd
And in the corner whicj shows GTA3 select SA.




And in the Image menu select Compress All images.




Now the txd file is in the correct SA format. In file menu select save
as and type “sentinel”.
Now everything is OK we just have to add these files to the
SA/models/gta3.img file by the help of the IMGTool2.
Now open this program and select the gta3.img in the previous folder.
By pressing F2 you can find by name. Type sentinel and it will jump
to the sentinel.dff and rename it by pressing F4 (something like
sentinel_old.dff) Now press F3 now it will jump to the next sentinel
file which is its txd. Rename it also! We have to rename these because
we don’t want to loose the original file.




Now click Commands and add. First select the sentinel.dff file and
again click add and select the txd file. The program will add them to
the end of its list (if it is sort by Offset). Now we are ready so close
everything and test it in the game!




I hope you like this tutorial! If you want some modification on the
model try some Gmax or 3DsMax tutorials. Sorry for my English…

PM me on GtaForums if you have some question.

Plunk89

NOTE:
I had something like a bug during the makin of the tutorial. I couldn’t
make visible the “white64.tga” in the materials and once
“white128.tga” because Gmax shut down... So I suggest frequent
saving and leaving these images alone during this process! And this
process not so necessary so the reason why i put in this tutorial is that
to make it easier to modify the model in the future converting....