Docstoc

ArcView

Document Sample
ArcView Powered By Docstoc
					                                        Exercise 1: Making a Buffer

Step 1   Start ArcView and open the project

         Open ArcView 3.2 by going to the Start Menu -> Class Software -> ESRI 3.2 -> ArcView ->
         ArcView 3.2. Due to the way the network is set up, you may have to wait several minutes
         while the appropriate files are downloaded to the computer you are working at.

         When ArcView opens, you will want to open an existing project. You can do this by
         selecting the appropriate option from the “Welcome to ArvView GIS” prompt when you open
         the program or by selecting Open Project from the File menu. When the Open Project
         window opens, select Mlabafs(U:) in the drive box. Then navigate to the course AFS space
         by typing msu/course/rd/415/vevay in the filename box. ArcView projects have an .apr
         suffix. Double-click on proposed sites.apr to open the project.

         When the project opens, you see a view called Vevay Township. Open Vevay Township and
         you will see that contains four themes: Proposed Sites, Roads, Current Zoning, and Vevay
         boundaries. Proposed Sites is a polygon feature we created for your group project. Roads is
         a linear feature showing all the roads in Vevay Township. Current Zoning is a polygon
         feature we digitized from the Vevay Township Development Plan. Vevay Boundaries is a
         polygon feature showing the outline of Vevay Township that we used to create the Roads
         shapefile from a shapefile showing the roads of Ingham County using theme-on-theme
         selection (we'll get to that later).

Step 2   Select Proposed Site #4

         The purpose of this exercise is to use ArcView to help us find out more about the proposed
         sites and the area surrounding them. We will be focusing on two methods of spatial queries:
         theme-on-theme selection and buffers. We will be conducting a proximity analysis (i.e.,
         looking at features within a certain distance of the sites we are interested in).

         We will start by using theme-on-theme selection to find all the properties in one of the
         proposed sites.

         First we will select one of the proposed sites, Site #4.

         To do this, make sure that the Proposed Sites theme is active and do one of the following:

         Click on the Select Feature button and draw a rectangle around the proposed site in
         the northwest corner of the township

         or:

         Click on the Find button, type in Site #4, and hit enter.

         You will know that you have selected the site when the fill design turns yellow.

Step 3   Select Features in Proximity to Site #4

         Now that you've selected Site #4, you must make active whichever theme you want to find
         features from.
         We want to find all the properties shown in the Current Zoning theme that are within 500 m
         of Site #4.

         Therefore, we must make Current Zoning the active theme by clicking on it in the Table of
         Contents.

         Then choose Select by Theme from the Theme menu.

         In the "Select features of active themes that" dropdown menu select "Are within
         distance of"

         In "the selected features of" dropdown menu select "Proposed Sites"

         In the "Selection Distance" box type 500 (the unit of distance is already set to meters).

         Click New Set.

         You should see that all of the polygons in the Current Zoning theme that touch any point
         within 500 meters of Site #4 have been selected

         In this case, that isn't very helpful, since some of the polygons are rather large, including the
         entire City of Mason. Instead we'll use buffers that will select only portions of features within
         500 meters of the sites.

         Before we go on, unselect the properties that are currently highlighted in Current Zoning by
         clicking on the Clear Selected Features button.

Step 4   Load the Geoprocessing extension

         Creating buffers is one type of geoprocessing.

         Before you do any processing, you'll need to load the Geoprocessing extension.

         From the File menu, choose Extensions. In the Extensions dialog, check the box next
         to Geoprocessing.

         Click OK.

Step 5   Buffer the proposed sites

         In this step, you'll find the areas around the four proposed sites by creating a buffer that
         extends to 500 meters. By finding the total area covered by the buffer polygon, you'll have
         found the total area within 500 meters of the proposed sites.

         While you're working through the Buffer Wizard, you can check your settings at any time by
         clicking Back to return to a previous panel. The buffers will not be created until you click
         Finish.

         Make sure that Proposed Sites is the active theme.

         From the Theme menu, choose Create Buffers to display the first panel of the Buffer
         Wizard.

         Choose the option to buffer the features of a theme. In the dropdown list, choose
         Proposed Sites as the theme to buffer.
         A checkbox appears at the bottom indicating that you will use only the selected features of
         Proposed Sites. If we wanted to buffer only one of the sites, we could do so simply by
         selecting the site beforehand and then leaving this box checked. In fact, if you didn't
         specifically clear the selection of Site #4, leaving the check in this box would create a buffer
         for only that site. Instead, remove this check so that we can buffer all four proposed
         sites.

         Click Next.

         In the second panel of the Buffer Wizard, choose the option to create the buffers at a
         specified distance of 500. Make sure the Distance units are set to Meters in the bottom
         dropdown list.

         This will create a buffer area 500 meters around the sites.

         Click Next to display the final panel of the Buffer Wizard.

         Click No so that you do not dissolve barriers between buffers. Since we are interested in
         each of these sites individually, we want to be able to identify exactly where any overlaps
         occur.

         Choose the option to create buffers so they are only outside the polygon.

         Select "Save the buffers in a new theme". Click the Browse button (in the lower right
         corner of the window) and navigate to your personal AFS folder (select the P:/ drive). Keep
         the default filename buff1.shp. Click OK.

         Click Finish.

         It may take a few moments for ArcView to process the buffers. When the process is complete,
         the buffers are created in a new theme called Buffer 1 of Proposed Sites.

         Notice that the buffer zones cover the areas you are interested in. In the next step, you'll
         change the symbol used to display the buffers so that you can see the underlying data.

Step 6   Change the buffer's symbology

         With Buffer 1 of Proposed Sites active, from the Theme menu, choose Properties.
         Change the name of Buffer 1 of Proposed Sites by highlighting the text in the box for
         Theme Name and typing “Site Buffer”. Click OK. (Okay, that was kind of a lame change,
         but I wanted to make sure that you know that you can edit the theme in this way.)

         Double-click on Site Buffer to display the Legend Editor.

         In the Legend Editor, double-click on the symbol to open the Symbol Window.

         In the Symbol Window, click the Fill Palette button. Click the first symbol (top left
         square) to indicate you want no fill and in the Outline dropdown list, choose 2 to make
         the width of the outline thicker and easier to see.

         In the Symbol Window, click the Color Palette button. In the Color dropdown list,
         choose Outline. Click on a bright red square.

         The symbol is updated in the Legend Editor.
         In the Legend Editor, click Apply.

         Now you can see the selected site as well as the extent of the 500-meter buffer around this
         area.

         Close the Legend Editor and the Symbol Window.

Step 7   Clip Current Zoning with Buffer of Site 1

         To calculate the area of the township that falls within the 500-meter buffer zone, you'll clip
         Current Zoning using the buffer theme like a cookie cutter. This will create a theme
         containing only the area that falls within 500 meters of the proposed sites.

         The clip operation is a part of the Geoprocessing extension. To access it, from the View
         menu, choose GeoProcessing Wizard.

         Choose the option to clip one theme based on another and click Next.

         For the input theme to clip, choose Current Zoning in the dropdown list.

         For the polygon overlay theme, choose Site Buffer in the dropdown list.

         For the output file, click the Browse button and navigate to your personal AFS folder
         (change the drive to P:/). Name the new shapefile total.shp. Click OK.

         Click Finish.

         The clip process may take a few moments. ArcView reports on the processing in the status
         bar (in the lower-left corner of the ArcView window). When the process is complete, a new
         shapefile called Total.shp is added to the view. Turn on Total.shp.

         The area covered by Total.shp represents all the areas in Vevay Township that are 500
         meters from the proposed sites.

Step 8   Update the Area and Perimeter fields

         When you clip a theme using another theme, new shapes are created in the output theme.
         The new shapes need to have their Area and Perimeter fields updated.

         Make Total.shp active and open its theme attribute table.

         If you compare this to the Current Zoning theme, you will notice that all the polygons have
         the same values for Area and Perimeter, even though some of the polygons are only partially
         within proximity to our sites.

         Close the Attributes of Total.shp table and make the Vevay Township view active.

         Make Total.shp the active theme if it isn't already.

         To calculate the proper areas, you'll run the script called Calcapl.ave.

         Make the Calcapl.ave script window active. To do this, first make the project window
         active by selecting proposed sites.apr from the Window menu.
         Choose Scripts from the left-hand side of the project window, and double-click on
         Calcapl.ave.

         Relax, you don’t have to know any code. The first few lines of this program tell you what it
         does, figure out Area and Perimeter of polygon features and Length of lines features. When
         you run a script, it is applied to the last window that was open. Right now, that would be
         the project window, and the result would be an error message. You need to make that the
         View window active. Do this by choosing Vevay Township from the Window menu.

         Make sure that Total.shp is the active theme.

         Return to the script by choosing Calcapl.ave from the Window menu.

         Click the Run button to run Calcapl.ave. In the Calculate dialog that appears, click Yes
         to update the Area field and the Perimeter field.

         Make the Vevay Township view active and open the Total.shp theme table.

         The Area and Perimeter fields now contain the correct values.

Step 9   Summarize Zoning to find the total areas

         To find out how much area is residential and how much is agricultural, you'll summarize the
         Zoning field.

         In the Attributes of Total.shp table, click on the Zoning field name so that it is the
         active field. Click the Summarize button to open the Summary Table Definition
         dialog.

         Click the Save As button and change the drive to P:/. Accept the default name of
         sum1.dbf.

         In the Field dropdown list, choose Area.

         In the Summarize by dropdown list, choose Sum.

         Click Add, then click OK.

         A summary table called sum1.dbf is created.

         By looking at this table, you can find out how much of the area within 500 meters of the
         proposed sites is residential and how much is agricultural.

         This makes it clear that there is more land zoned for agriculture within 500 meters of these
         four sites than there is residential property (although note that there are several categories of
         residential).

         To see each land use type, double-click on Total.shp in the Table of Contents.

         Change the Legend Type to Unique Value and the Value Field to Zoning. Click Apply,
         and close the Legend Editor.

         Uncheck Current Zoning to turn off its display and move the roads and proposed sites
         themes to the top of the Table of Contents.
        Now you can see all the land use types and the roads within 500 meters of the proposed
        sites. However, again this may not be very helpful for this project. You could go on to do
        theme-on-theme selections to see, for example, how many residential properties (and
        therefore how many landowners you may have to deal with) within this buffer, but you would
        be looking at all four proposed sites at once. A better alternative may be to combine
        buffering with theme-on-theme selection by creating individual buffers for all four sites.
        When doing this, you could also choose to make multiple buffers, so that you could see how
        many residential sites are within 500 meters (perhaps for odor impacts) and how many
        leaking underground storage tank sites are within 1 mile (for liability and health purposes).

Step 10 Close the project

        If you want to save your changes, you will have to choose Save As from the File menu and
        save to your personal AFS space.

        From the File menu, choose Close All. Again from the File menu, choose Close Project.

				
DOCUMENT INFO