Macromedia Flash Some of the Basics

Document Sample
Macromedia Flash Some of the Basics Powered By Docstoc
					Macromedia Flash: Some of the Basics
Frames
Frames make up the timeline in a Flash movie. There are three types of frames:

Protoframe
Essentially a frame that does not yet exist
(just a placeholder)

Frame
Regular garden-variety frame

Keyframe
Indicates a change or action occurring.

Symbols
Symbols are used to maximize the efficiency for object usage throughout a movie, editing the
symbol will update all instances based on that symbol throughout the movie. To view you’re your
current symbols, open the library panel (Cmd-L). Double-click on a symbol to enter symbol-
editing mode. There are three types of symbols:


Graphic Symbol
Used to turn an editable shape, text
or a bitmap image into a graphic symbol.
Required for good motion tweens.

Button
Used to create visually-dynamic buttons that respond to user cues (rollover and click). Contain
their own four-frame timeline in which you define the up state (normal state), over state (pointer
is over), down state (mouse button has been clicked), and hit area (active area over which
button will function).

Movie Clip
Contains its own independent timeline. Used to consolidate animations and for more advanced
Flash development, particularly in regard to ActionScript.

Tweens
Motion Tween
Used to animate an object across time and space.
Requires two keyframes, a valid symbol instance,
and a the tween itself.

Shape Tween
Used to “morph” editable shapes. Requires two keyframes, two editable shapes, and the tween
itself. Use Modify > Break Apart to change a graphic symbol or text object into an editable shape.

Transformation Point vs. Registration Mark
Registration Mark (small crosshair symbol)
0,0 coordinate for the symbol – used to locate
a symbol instance on the stage via coordinates.
Stays the same for all instances of the symbol.

Transformation Point (small circle)
Used for snapping operations like motion guides. Move it in any given symbol instance by using
the free-transform tool
Importing Vectors and Bitmaps
To import a bitmap graphic into a Flash movie, select File > Import > Import to Stage. Size and
optimize your image prior to placing it in your Flash movie. To import vector artwork from
Illustrator, use the Export function in Illustrator and select the Macromedia Flash (.swf) format.


Motion Guide Layer
To create a motion guide, click on
the “Add Motion Guide” button on
the bottom of the timeline. Draw
your path as one continuous line
using the pencil tool (“Smooth”
option). Then in the guided layer,
select each keyframe containing
the symbol instance you wish to
guide, and align the object to the
path with the Transformation Point.


Mask Layer
A mask works like a window in flash, revealing the objects beneath it. To create a mask layer,
                                        add a layer above the layer you wish to mask. Select the
                                        new layer, and then right-click/ctrl-click on it and select
                                        “Mask”. Use a color you designate for your masks, and
                                        draw your mask on the layer. Convert it to a symbol and
                                        animate it with a motion tween and watch how it reveals
                                        your other artwork as it moves.
Flash MX 2004

Using Basic Action Script to Control Navigation and Stop Playback

ActionScript is a comprehensive scripting language created to let authors have very specific control over the
interactive functionality of their Flash movies. The scope of this class provides a brief introduction to the
powerful resource, which will allow you to create a functional navigation in your interactive movie
assignment. Below are listed some basic ActionScript concepts and techniques.

ActionScript provides a variety of functions within your movie. One of the simplest is the control of its
playback. Unless you specify otherwise, your movie will simply play its timeline from beginning to end,
proceeding through all scenes, and then start over at the beginning. Naturally this is not a particularly
“interactive” experience for the user. So you want to stop the movie at some point and allow the user to
make choices based on your interactive design. To accomplish this, a simple way is to place a little line of
ActionScript code in the frame on the Actions layer (it is good practice to create a new layer reserved for
your ActionScript) that corresponds to the point in the Timeline where you want the movie to stop.




Providing your navigation with the functionality to move from scene to scene is the other application for
which you will need to use ActionScript. In this case, you will associate your actions with the button symbols
corresponding with each scene.




The syntax must be precisely as indicated above. The event is in parentheses, the function is
within curly braces, and the objects of the function are within parentheses. Scenes must be
referred to within quotes, and each function must be terminated with a semicolon. My scene here
is called “Intro” – others might be called “Spring” or “Summer”, etc.
Working with complex shapes within one layer can be a bit tricky, as the shapes on a single layer interact. In
drawing two lines, the second line segments the first where they cross.

Fills and Strokes
     • When a fill object overlaps a line, the fill segments the line.
     • When a line is placed over a fill, the line cuts the fill, but the fill’s invisible outline cuts the line.

Intersecting Shapes and Fills
    • If the intersecting fills (i.e. brushstrokes) are the same color, the two fills are merged into one shape.
    • If different colored fills intersect, the newer fill replaces the older one where they overlap, but the two
        fills remain separate.

One way to manage the complexity of interactions between lines and fills on a layer is to use grouping.
Grouping objects stops them from interacting with other objects or groups of objects. Group a single object to
immediately establish its place in the stacking order. Grouped objects adhere to the following stacking order,
listed from bottom to top. Visualize a stack of acetate pages with objects on each):

To create a group, select one or more objects. Cmd-G (or Ctrl-G on the PC) creates a group, as evidenced by
the new boundary line drawn around the object(s). To ungroup, add shift to the shortcut or use Break Apart
(Cmd-B). In order to edit a group select it and go to Edit > Edit Selected (you are now in a special mode – group
editing mode).