JCSS Version 9.0 Software Release Bulletin (SRB)

Document Sample
JCSS Version 9.0 Software Release Bulletin (SRB) Powered By Docstoc
					       JCSS Version 9.0
Software Release Bulletin (SRB)




            March, 2009




               Prepared by:
   Defense Information Systems Agency




                   i
                                Document change history

       Version Number                            Date                            Description
JCSS 9.0                         March, 2009                       JCSS 9.0 SRB Update
JCSS 8.0                         August, 2008                      JCSS 8.0 SRB Update
JCSS 7.0                         January, 2008                     JCSS 7.0 SRB Update
NETWARS 2006-2.1                 March, 2007                       NETWARS 2006-2.1 Updated SRB




Disclaimer: As of October 2007, NETWARS was re-designated by the Program Manager Office
as the Joint Communications Simulation System (JCSS). JCSS was selected as the new industry
name to better reflect the inherent joint communication capabilities of the software. Users should
be aware that no software updates were conducted as part of the software name change.




                                                  ii
TABLE OF CONTENTS
1. INTRODUCTION TO JCSS 9.0 ............................................................................................................. 2
    1.1      WHAT IS THIS DOCUMENT? .......................................................................................................... 2
    1.2      WHAT IS JCSS?............................................................................................................................ 2
       1.2.1  JCSS Capabilities ................................................................................................................... 2
2. WHAT’S NEW IN JCSS 9.0.................................................................................................................... 4
    2.1          WHAT’S NEW IN JCSS 9.0 ............................................................................................................ 4
    2.2          JCSS 9.0 DOCUMENT LIST ........................................................................................................... 6
    2.3          POINTS OF CONTACT .................................................................................................................... 8
3. KNOWN JCSS 9.0 SOFTWARE ISSUES ............................................................................................. 9
    3.1          CRITICAL SOFTWARE PROBLEM REPORTS .................................................................................... 9
4. JCSS V9.0 INSTALLATION INFORMATION.................................................................................. 11
    4.1          JCSS V9.0 INSTALLATION INFORMATION ................................................................................... 11
       4.1.1       Contents of the JCSS Scenario Builder v9.0 CD .................................................................. 11
       4.1.2       Prerequisites......................................................................................................................... 11
       4.1.3       VOACAP Installation ........................................................................................................... 11
       4.1.4       Licensing Issues.................................................................................................................... 11
       4.1.5       Un-Installation...................................................................................................................... 12
       4.1.6       JCSS Help and Assistance .................................................................................................... 12
    4.2          NEW INSTALLATION OF JCSS V9.0 ............................................................................................ 12
       4.2.1       Installation of JCSS v9.0....................................................................................................... 12
    4.3          UPGRADING FROM A PREVIOUS JCSS TOOLKIT TO JCSS V9.0 ................................................... 14
       4.3.1       Upgrading from a previous JCSS Toolkit to JCSS v9.0........................................................ 14
    4.4          POSSIBLE INSTALLATION ISSUES ................................................................................................ 15
       4.4.1       Possible Installation Issues................................................................................................... 15
5. TROUBLESHOOTING......................................................................................................................... 16
    5.1          DEFINITIONS .............................................................................................................................. 16
    5.2          SUBMITTING ERROR LOG FILES .................................................................................................. 17
6. JCSS HELP DESK AND PROBLEM REPORTING ......................................................................... 17
7. ACRONYMS .......................................................................................................................................... 18




                                                                             1
1. INTRODUCTION TO JCSS 9.0

1.1     What is this Document?
The JCSS 9.0 Software Release Bulletin (SRB) provides an overview of v 9.0 Software
Release. Specifically, it provides an overview of some of the new features, known errors,
and provides usability guidelines. The SRB also gives JCSS users detailed instructions
for installing the software and getting JCSS-specific software support.

This document contains the following:
          An overview of JCSS 9.0
           A list of JCSS contacts for questions or comments
           Additional notes on important topics relating to the use of JCSS
           Information on how to use the JCSS help desk and report problems
           A glossary of terms and acronyms used in JCSS
           A list of known issues in the current JCSS release
The JCSS Web page can be accessed at http://www.disa.mil/jcss/
For software CM support, please contact JCSS Configuration Manager via email at
JCSS@disa.mil.

1.2     What is JCSS?

Joint Communication Simulation System (JCSS) is the Joint Chiefs of Staff and DISA
standard for modeling military communications networks. It is a desktop software
application that provides modeling and simulation capabilities for measuring and
assessing the information flow through Strategic, Operational, and Tactical military
communications networks.

During the 1997 Quadrennial Defense Review (QDR), the Joint Staff discovered that the
effects of improved communications on battle outcome could not be adequately
represented by any of the current models. The Director for Command, Control,
Communications and Computer (C4) Systems (DJ6) initiated JCSS to address this shortfall.


1.2.1      JCSS Capabilities
Enable C4 planners and analysts to
           Conduct high-level planning
           Conduct end-to-end performance assessments
           Network traffic analysis



                                             2
           Evaluation of emerging technologies
           Rapid contingency planning support
           Wargaming (force-on-force) support
JCSS allows users to:
           Simulate realistic battlefield communication systems and networks
           Assesses communications at all levels of conflict and organizational Constructs
           Performs validation for current and future joint and service acquisitions
           Conduct network “battle drills” through the use of simulated outages and
           destruction of key network nodes and/or links
           Modifications to war fighter architectures and Operations Plans (OPLAN)


                         Figure 1 - JCSS Functional Architecture




                                              3
2. WHAT’S NEW IN JCSS 9.0

The following section provides an overview of some of the new GUI features and
models introduced in JCSS 9.0.

2.1      What’s new in JCSS 9.0

      JCSS v9.0 is based on the latest OPNET CORE 15.0 PL1.

      EPLRS Model Enhancement: As a continued effort to improve upon the
      current JCSS EPLRS model, further enhancements were made to the EPLRS
      model including adding Dynamic Routing for OSPF and Antenna characteristics.
      Please refer to the EPLRS Model User Guide for further assistance.

      DoDAF Import/Export The Department of Defense (DoD) Architecture
      Framework (DoDAF) provides a standard for description, development,
      presentation, and integration of systems for the DoD. DoDAF is a large standard
      consisting of many products some of which will be integrated into JCSS in future
      releases.
      JCSS v9.0 provides supports for DoDAF OV-3 and SV-6 products as they
      closely resemble the JCSS Information Exchange Requirements (IERs)
      workflow. The interface consists of the ability to take already existing DoDAF
      OV-3 and SV-6 products and merge them into a JCSS scenario in the form of
      IERs. The user will be able to import the products, test the configuration using
      simulations, modify the configuration, and export the modified information to a
      valid OV-3 or SV-6 product. The advantage of providing this capability allows
      the user to quickly fill-in missing information and test the validity of the
      configuration. In the end, this allows the user to have more complete DoDAF
      products which will allow the military to make better comparisons and decisions.
      Please refer to the JCSS IER Model Userguide for additional information.

      IER Model Enhancements: A major update was made to the JCSS IERs in
      v9.0. JCSS now makes use of demand objects to represent IERs and Threads in
      Scenario Builder as an alternative to the custom data structure that was
      previously used. The new IERs allows for better visualization, editing and offers
      several new capabilities including the use of various distribution attributes.

      With the implementation of IER demands, the user will be able to create IERs by
      deploying a demand from the Object Palette or through a GUI interface. All IERs
      created by users in previous software releases will be automatically converted to
      the new format. For further information please see the IER Model Userguide.

      VNE SERVER Import: (VNESI): JCSS v9.0 now offers support for VNE
      server. VNESI is an OPNET COTS product that allows you to create a network
      model from information from VNE Server data. Please note that JCSS imposes
      an OPFAC and Organization hierarchy on all devices. Devices must live within


                                              4
an OPFAC in a JCSS environment. A VNE license is required to operation this
capability and Users must contact OPNET Technologies.

NetMapper Support: JCSS v9.0 offers OPNET CORE NetMapper support.
NetMapper provides up-to-date Microsoft Office Visio network diagrams “on
demand.” These diagrams extend beyond simple topology to feature detailed
logical views of the network including: Layer 2-3, VPNs, OSPF, VLANs, etc.

Network Layouts: OPNET CORE 14.5 and 15.0 introduces several new
Network Layout Wizards that allow users to quickly build network models, setup
wireless devices and run network difference reports. JCSS v9.0 provides support
for these wizards and include support for the following:

          Under Menu                        Wizard Name
           Topology             Rapid Configuration
           Topology             Deploy Wireless Network
           Topology             Open Edge Connectivity Wizard
           Topology             Clear Trajectory Assignment
           Topology             Random Mobility
           Topology             Import STK Orbit
           Topology             Shared Risk Groups
           Scenario             View Associated Output Tables
           Scenario             User-Defined Reports
           Scenario             Network Difference Report
           Scenario             Object/Attribute Difference Report
           Scenario             Live Object/Attribute Difference

New Project Wizard: JCSS v9.0 has a more streamlined Project Wizard will be
simplified to make the workflow more intuitive, while increasing functionality.
Overall, the dialog boxes will be combined, new import options added, as well
as, utilizing the new OPNET 14.0 mapping capabilities. This New Project
Wizard will not affect the existing Task Assistant.

Explicit Setting of BER, ECC Threshold and Antenna Pattern in wireless
Models: Currently in JCSS users can model the bit error rate (BER) for wireless
communication channels which is calculated from the SINR by looking up the
BER curve for the modulation used by the transmitter and receiver pair. This
framework provides an accurate modeling of the parameters which can affect the
reception of the packets. However, in some R&D applications the users demand
more control over the channel properties particularly over the channel BER to
study different protocols and settings. Also, some JCSS users have expressed the
need to use the BER values measured from actual wireless networks in the
simulation model for further studies of their network architectures.

In support of this activity, this feature introduces a new node model and the
supporting software to allow the JCSS user to modify the BER, ECC Threshold


                                        5
      and Antenna Pattern for individual wireless nodes in a scenario and override the
      default settings of corresponding node models. The new model not only provides
      the ability to “playback” the previously defined BER and ECC Threshold values
      over time, but also it allows the JCSS user to set those values plus possibly the
      Antenna Patterns on selected nodes without the need to open and modify the
      corresponding node models

2.2      JCSS 9.0 Document List

The JCSS program develops and maintains a library of documents. These
documents are intended to help the user understand what JCSS is and how they can
use it. A portion of the JCSS document library is included with each release. Users
can find these documents on the first installation disk under the
<Drive>:\JCSS\Documents folder. The following table lists the documents
provided with JCSS v9.0.


          Title                      Purpose                             Summary of Contents
JCSS 9.0 Software Release Overview of the JCSS 9.0                    New Features
Bulletin                  Software Release                            Usability Guidelines
                                                                      Known Errors
JCSS 9.0 User Manual            Guide to basic aspects of JCSS        Topology Building
                                operation and use                     Traffic Specification
                                                                      Capacity Planning
                                                                      Simulation Execution
                                                                      Result Analysis
                                                                      Glossary
JCSS 9.0 Technical              The JCSS Technical Reference          JCSS Editor Descriptions
Reference Manual                Manual is a comprehensive             Menu Descriptions
                                reference and guide that covers       Visual examples of the JCSS
                                all aspects of JCSS operation         interfaces
                                and use                               Step-by-step procedures, and
                                                                      other important JCSS features
                                                                      and concepts
                                                                      Glossary
JCSS System Security            Current draft SSAA for your           System Security
Authorization Agreement         reference in preparing                Requirements and
(SSAA) (Table of                DITSCAP requirements for              Appendices
Contents Only)                  your own site. Since, the full
                                SSAA is For Official Use Only
                                (FOUO), only the Table of
                                Contents in included.
JCSS 9.0 Code of Best           Documents lessons learned and         Guide for JCSS Study Lead
Practices                       best practices from past studies      Guide for JCSS User/Analyst
                                to provide to future JCSS study       Detailed information on JCSS
                                teams proven processes,               capability scenarios


                                              6
          Title                        Purpose               Summary of Contents
                           insights and guidelines.
JCSS Model                 Standards documents for         Functional overview includes.
Development Guide (3.1)    designers and developers of     Overview of the system,
                           communication device models.    technical introduction to
                                                           JCSS modeling
                                                           “Building & Testing JCSS
                                                           Models” (End-System,
                                                           Networking, Circuit-Switch,
                                                           Radio, Link, Operational
                                                           Element)
JCSS 9.0 Communications Results of V&V activities          Executive Summary
Device Model V&V        conducted to determine if the      Model by Model Results and
Report                  developed communications           Recommendations for JCSS
                        models meet specific               Standard Models
                        documented requirements and        Dynamic and Static MDG
                        if they reasonably represent the   Test Results
                        implicit functional performance
                        of the actual systems.
JCSS 9.0 Capacity       Results of V&V activities          Capacity Planning Overview
Planning V&V Report     conducted to determine if the      Test Results
                        developed Capacity Planner         Validation results
                        and associated features meet       Conclusions
                        specific documented
                        requirements and if they
                        reasonably represent the
                        performance of actual
                        networks.
JCSS 9.0 Model User-    Detailed descriptions on many      CTP Model User Guide
guides                  of the existing and new JCSS       H.323 Model User Guide
                        communication models.              EPLRS Model User Guide
                                                           Link16 Model User Guide
                                                           Promina Model User Guide
                                                           PEP Model User Guide
                                                           Voice Model User Guide
                                                           UHF SATCOM User Guide
                                                           IER Model User Guide




                                       7
2.3   Points of Contact

                       Table 2 – JCSS Points of Contacts

Maj. Charles Johnson                        Mr. Scott Tran
JCSS Project Manager, DISA / GE344          Branch Chief , DISA / GE344

P.O. Box 4502                               P.O. Box 4502
Arlington, VA 22204-2364                    Arlington, VA 22204-4502
Email:Charles.Johnson3@disa.mil             E-Mail: scott.tran@disa.mil
Telephone: 703-681-0399                     Telephone: 703-681-4676

 For all JCSS inquiries, including, new Software Releases, User Conference, Tech
                     Support, please contact the JCSS CM at
                                  JCSS@disa.mil
                                www.disa.mil/JCSS




                                        8
    3. KNOWN JCSS 9.0 SOFTWARE ISSUES

    3.1    Critical Software Problem Reports
    The following are some of the software problems that were identified during software
    testing and model verification. These software problems will be addressed in later version
    of the software.

    For more information on the severity ranking of these problems, please refer to the CDM
    V&V. For more information on any of the problems shown below, please contact the
    JCSS CM at JCSS@disa.mil.


#    SPR ID                             Description                             Problem   Severity
                                                                                 Type
1     6038          Problem: Users might experience a software                  OPNET            1
                    exception when trying to import from VNES after it           CORE
                    fails to connect the first time around
                    Recommendation: Ensure your project is backed up
                    and when trying to connect to VNE. Make sure you
                    have a connection to the VNE server before trying to
                    import the files.
2     6124          Problem: PRC Radios high priority IERs take longer           JCSS            2
                    to send and received then lower priority
                    Recommendation: This is a problem with the NAD
                    scheme and will be addressed in future software
                    releases. If you are getting inconsistent results, please
                    contact Tech Support for assistance.
3     6086           Problem: Demux group doesn’t reset when circuit is          JCSS            2
                    deleted for Sat_Term_TSSP Models using the right
                    click menu 'Edit Similar Paths'
                    Recommendation: Delete each circuit path
                    individually in your network scenario
4     6266          Problem: Simulation abort when running DES over a            JCSS            2
                    PSC failure recovery scenario using optimized kernel
                    Solution: This only occurs on a 64 bit platform and
                    should work fine on a 64 bit installation
5     4871          Problem: Project file gets deleted when renaming             JCSS            2
                    project name through Manage Scenarios
                    Recommendation: Duplicate your scenario and
                    rename it rather then renaming an existing scenario
                    via manage scenario
6     6042          Problem: Terrain shading is not updated (when                JCSS            2
                    altitude is changed) from OPFAC's COTS attribute
                    dialog box (launched from "Edit Attributes").
                    Recommendation: Do not use the OPFAC COTS



                                                 9
            attribute to update Terrain Shading

7    6002   Problem: Simulation Errors encountered in a              JCSS   2
            scenario with several TSSP/Promina circuits
            Recommendation: We have seen this problem
            happen intermittently but not consistently. We
            recommend that if you do encounter this problem,
            please contact tech support.
8    6268   Problem: Canceling Path Redefinition for a circuit       JCSS   2
            makes the path object unstable
            Recommendation: Make sure you save a copy of
            your project while before redefining circuit path
            objects
9    5279   Problem: Unusual behavior in the radio network           JCSS   2
            related to propagation. Your simulation results may
            be inconsistent with TMM traffic flows
            Recommendation: This issue is being investigated
            and if you are seeing problems related to such, please
            contact technical support
10   6068   Problem: IERs are not updated when the running           JCSS   2
            simulations with the Manage Scenario functionality.
            Solution: Run each scenario individually where
            possible when using IERs
11   3950   Problem: TNAPS to XML scenario fails link                JCSS   2
            consistency check
            Solution: Please contact technical support if you plan
            on using TNAPS XML with JCSS




                                       10
4. JCSS V9.0 INSTALLATION INFORMATION



4.1      JCSS v9.0 Installation Information
4.1.1           •   Scenario Builder
Contents of     •   Simulation Domain
the JCSS        •   HLA Commander
                •   VOACAP (Optional)
Scenario
Builder v9.0
CD
4.1.2           •   Disk space required for JCSS: ~700MB.
Prerequisites   •   Disk space required for VOACAP: ~12 MB.
                •   MSVC++ 6.0 for custom model development in 32-bit version of JCSS.
                •   MSVC++ 2005 for custom model development in 64-bit version of JCSS.

                Recommended Hardware Requirements: Pentium 1GHz, 512 MB RAM.
4.1.3           1. JCSS requires VOACAP to model long range HF radio propagation during ALE
VOACAP             (Automatic Link Establishment) for HF radios.
Installation    2. The VOACAP software has its own InstallShield script that is kicked off during
                   NETWARS installation. Users may or may not install this software.

                3. Note that the VOACAP software requires directory names that conform to the
                   old DOS 8.3 format, i.e., the directory name should be no more than 8 characters
                   and should not include spaces (e.g., C:\VOACAP).

                4. The un-installation of VOACAP is independent of JCSS.

                5. Required disk space: ~12MB.
4.1.4           JCSS v9.0 employs the same license server application as JCSS v8.0. No special
Licensing       reconfiguration is required -- simply specifying the name of the license server during
                the JCSS v9.0 installation will suffice.
Issues
                As JCSS v9.0 uses the OPNET 15.0 PL1 software, users will need to upgrade
                their existing pre-15.0 licenses to the new format before using JCSS v9.0. To
                perform this operation, use the “Edit > License Management” menu once the
                JCSS v9.0 software is installed. Once inside the License Manager, choose a
                license and select the “Convert Pre-15.0 License” button. For more information
                on this conversion, please contact the JCSS CM at JCSS@disa.mil or view the
                OPNET website (www.opnet.com).

                Note that users who convert their license files to the new 15.0 format will no
                longer be able to run pre-9.0 JCSS and pre-15.0 OPNET software in standalone
                mode.

                Also, for JCSS v9.0, to use Discrete Event Simulation (DES), both a Simulation


                                            11
                  Runtime (SRS) license and either an OPNET ITGuru or Modeler license must
                  exist. These licenses can be obtained by contacting OPNET directly
                  (www.opnet.com) or through the JCSS Program Office (JCSS@disa.mil).

                  If you have concerns, please contact the JCSS CM at JCSS@disa.mil
4.1.5             The un-installation process does not delete all the directories so it is strongly
Un-               recommended that you manually delete the JCSS directories prior to installing JCSS.
Installation
4.1.6             •   Users are no longer required to contact the JCSS CM for license permit numbers.
JCSS Help             The JCSS v9.0 license configuration is now embedded within the software and
                      will register upon installation completion. For more information, please refer to
and
                      the Software Release Bulletin (SRB).
Assistance
                  •   For issues regarding using the software, please contact the JCSS Help Desk
                      either at netwars@opnet.com or at 240.497.3000 x2699. Note that emails and
                      voice mails to the Help Desk are checked once a day.

                  •   The JCSS Program Manager (PM) from DISA is Maj. Charles Johnson, who can
                      be contacted as follows:

                  Maj. Charles Johnson Charles.Johnson3@disa.mil 703-681-2364
                  For any other issues, please contact the JCSS Configuration Manager (CM) at
                  JCSS@disa.mil


4.2      New Installation of JCSS v9.0
4.2.1             Before you Begin:
Installation of   1. If you are using your current machine as a license server for other OPNET
JCSS v9.0            software packages, please stop the license server. On Windows NT, go to Start
                     > Settings > Control Panel > Services. For Windows 2000 or Windows XP, go
                     to Start > Settings > Control Panel > Administrative Tools > Services to stop
                     the OPNET License Server.

                  2. Check the available disk space on the drives of your machine.

                  Steps to Install:
                  1. Insert the JCSS v9.0 CD.
                  2. Run the Setup.exe program that appears in the subsequent window.
                  3. Click Next to go through the main installation window.

                  4. Select the optional software components which you would like to install and
                     click Next.
                      a. The VOACAP software (ITS HF Propagation) is required by NETWARS to
                         model long range HF radio propagation during ALE.



                                              12
    b. Acrobat Reader is required to view the JCSS Scenario Builder
       documentation.

    c. HLA Commander is used by JCSS for co-simulation and federation
       purposes. This software does not require a separate installation program and
       will be installed with the main JCSS software.

    d. OPNET Modeler is an optional component which installs a Modeler shortcut
       into the JCSS menu. The user is then able to launch a special JCSS version
       of OPNET Modeler inside the JCSS tool or from the Windows start menu.
       This option will not install a standalone version of OPNET Modeler. Note
       that an OPNET Modeler license is required to utilize this feature.

5. Select the version of the software you would like to install and click Next.
    a. The 32-bit Version is meant for standard 32-bit Windows machines. The
       JCSS GUI and simulation engines (Capacity Planner and Discrete Event
       Simulation) will be setup to optimize this particular machine architecture.
       This option will be used for most users and is the default for the JCSS
       installer.

    b. The 64-bit Version is meant for AMD 64-bit Windows machines only. The
       JCSS GUI and simulation engines (Capacity Planner and Discrete Event
       Simulation) will be setup to optimize the extra performance characteristics
       of the 64-bit architecture (i.e., extra memory over 32-bit machines). Note
       that this option should only be selected if you are running 64-bit machine
       architecture.

6. Specify the destination location for the JCSS software and click Next.

7. View the Installation Summary menu and click Next if you are satisfied with
   your selections. If you need to make any modifications, click the Back button.

8. After the JCSS program has been installed, you may be prompted to copy over
   any user files from a previous version of NETWARS/JCSS (if one exists). Click
   Yes to copy these files to the new installation directory.

9. If you decided to install the Acrobat Reader, then the installation for this product
   will begin. Please follow the installation directions for this software.

10. Next, the install program prompts you for license server setup information. For
    users that had to stop the license server earlier, choose the floating: serve
    licenses from this computer option, which will restart the license server. Other
    users may select either standalone, floating: serve licenses from this
    computer, or floating: access licenses from remote server for the license
    setup. Standalone mode allows the software to use a local license server.

11. After specifying the licensing mode, specify the name of your license server.

12. If you decided to install the ITS HF Propagation software, then the installation
    for this software product will begin. Please specify a directory name that does


                             13
                      not include spaces and is no more than 8 characters as VOACAP follows the
                      old DOS 8.3 format.

                  13. If you decided to install the Adobe Acrobat software, then the installation for this
                      product will begin. Please follow the installation directions for this software.

                  14. Click the Finish button to complete installing the JCSS software.
                  15. If needed, you may then call the NETWARS/JCSS Help Desk or OPNET
                      Technical Support to assist you with any installation problems.

                  16. Finally, you may run the JCSS software from the Start > Programs menu
                      shortcut.


4.3      Upgrading from a previous JCSS Toolkit to JCSS v9.0
4.3.1         Before you Begin:
Upgrading     1. Copy all previously saved models (projects, scenarios and OPFACs) and
from a           IER/demand files, i.e., User_Data > Projects, User_Data > Opfac_Models,
previous JCSS    User_Data > Opfacs, and User_Data > IER_Text_Files, located in
Toolkit to       <drive>:\JCSS to a temporary location. The JCSS v9.0 installer will prompt you
                 to move these files to the new JCSS location, but it is also a good idea to create a
JCSS v9.0        backup.

                  Steps to Install:
                  2. Perform the steps listed in the New Installation of JCSS v9.0 section, 4.2.1. You
                     should not install the new version of JCSS to the same directory as a previous
                     version (i.e. overwrite the previous installation). This is not recommended and
                     can cause problems when running the new version.

                  After you Install:
                  3. Go to Start > Settings > Control Panel and open up the Add/Remove Programs
                     utility. Select the older version of JCSS entry that prompts you with the Confirm
                     File Deletion dialog box.

                  4. Once the un-installation process is complete, delete the <drive>:\JCSS directory
                     where the older JCSS version was installed.




                                               14
4.4      Possible Installation Issues
4.4.1           Microsoft Visual C++ 6.0:
Possible        •   Clients who use Microsoft Visual C++ 6.0 might see an error similar to
Installation        the one below when launching a discrete event simulation:
Issues
                    Errors reported by the binder program follow [....]
                    op_win_stdio_patch.obj : fatal error LNK1103: debugging information
                    corrupt; recompile module

                    To prevent this issue, rename the following files in the “<JCSS
                    Installation Directory>\Scenario_Builder\14.0.A\sys\pc_intel_win32\lib”
                    directory:

                    1.Rename the file “op_win_stdio_patch.obj” to
                    “op_win_stdio_patch.vc7.obj”
                    2.Rename the file “op_win_stdio_patch.vc6.obj” to
                    “op_win_stdio_patch.obj”

                    After making these changes, restart the software.

                Using JCSS without a compiler:
                    Clients who utilize JCSS without a compiler may need to install the latest
                    Microsoft Redistribution Package. Typically, if the user has an incorrect
                    setup, the software will not startup correctly. Please install the below
                    packages before contacting JCSS Technical Support.

                •   32-bit Installation and Hardware:

                    Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)

                    http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-
                    ae1a-4a14-984d-389c36f85647&displaylang=en


                •   64-bit Installation and Hardware:

                    Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)

                    http://www.microsoft.com/downloads/details.aspx?FamilyID=EB4EBE2
                    D-33C0-4A47-9DD4-B9A6D7BD44DA&displaylang=en

                JCSS integration with XMLLite:
                    Clients who work with JCSS may need to upgrade their Windows
                    operating system. The Capacity Planner simulation uses XMLLite which


                                          15
                     is a powerful, XML tool to generate fast results with less memory.
                     During JCSS startup, clients may see the message “The application has
                     failed to start because XmlLite.dll was not found. Re-installing the
                     application may fix this problem.” To prevent this issue, please install the
                     below packages before contacting JCSS Technical Support.

                 •   32-bit Installation and Hardware:

                     XMLLite for Windows XP (KB915865)

                     http://www.microsoft.com/downloads/details.aspx?FamilyId=D7B5DC81
                     -AD14-4DE2-8AD5-8C4A9AAB5992&displaylang=en

                 •   64-bit Installation and Hardware:

                     XMLLite for Windows XP x64 Edition (KB915865)

                     http://www.microsoft.com/downloadS/details.aspx?FamilyID=c7cb26e9-
                     68f1-4f80-b231-79d044431e8e&displaylang=en


5. TROUBLESHOOTING


The following pieces of information are suggestions and practices for troubleshooting
problems with JCSS. Please review the following before sending in a problem report.

5.1    Definitions
The following section contains the definitions for error messages that are sometimes seen
in JCSS.

       Stack imbalance: This is a memory-related error. As memory is allocated and de-
       allocated during the hierarchical calling of computer functions, this memory is
       added to and removed from the stack in a last-in/first-out basis. Therefore, the
       contents of memory on the stack should always be in sync with the nesting level
       of the code being called. When it is not, this results in a stack imbalance. This can
       be due to other memory problems, such as memory allocation failures, or in some
       cases, programming errors. Ensuring you have sufficient memory on your
       computer to run the scenario can usually reduce these errors.

       Program abort: This is the general-purpose term for a program “crash.” It can be
       due to any one of a number of reasons; one of the most common reasons is when
       memory is handled incorrectly (such as inserting an element into a list that has not
       been initialized) and the OPNET kernel traps that error.




                                            16
       Memory allocation failure: This is an error that occurs when JCSS cannot obtain
       more memory to create space to hold additional information. This could be due to
       a lack of available memory on the machine or a conflict in JCSS whereby it is
       trying to re-use memory that is already in use by another part of the program.


5.2    Submitting Error Log files
To help the developers pinpoint the cause of various errors (especially those defined in
the section above), it would be beneficial to submit your error log files along with your
trouble reports.

The Error Log file is named “err_log” and is located in
<drive>:\JCSS\Scenario_Builder\op_admin

The err_log file keeps a record of all the errors encountered in JCSS. This file can grow
very large over time. If the error you have found is repeatable, you can close
JCSS, delete the err_log (or rename it to save it), then run JCSS and repeat your error. At
this point, the err_log file will have the error you are reporting, without all the other items
from previous runs. This will help reduce the clutter when you send in the err_log file
(make the e-mail smaller), and give the developers a more focused look as to what the
problem is. When you submit your Trouble Report (see JCSS Help Desk and Problem
Reporting), mention that you have the corresponding err_log file along with any other
information you can provide.

If you experience a program abort (crash), an exception zip file should be created
<drive>:\JCSS\Scenario_Builder\op_admin. Please include this zip file with your trouble
report submittal.

6. JCSS HELP DESK AND PROBLEM REPORTING


The JCSS team is using a new, automated system for reporting problems or requesting
assistance. Users no longer need to fill out a paper Trouble Report Form.
There are several ways to report a problem or request assistance:

       1. You can e-mail your request / problem to jcss@opnet.com. Your e-mail will
          be logged into the JCSS Technical Support Tracking System.
       2. You can call: (240) 497-3313, extension 2699. The voice mail is checked at
          least once a day.

All two of these methods will result in your case being entered into the JCSS Technical
Support Tracking System. Upon review, the case will be assigned to a tech support
engineer who will contact you for more information, or with possible solutions.




                                              17
7. ACRONYMS


CCSD           Command Communications Service Designator.
DII/COE        Defense Information Infrastructure/ Common Operating Environment
DISA           Defense Information Systems Agency
IER            Information exchange requirement. An IER identifies each
               unique communication exchange that would normally take place
               during the successful accomplishment of each task that an
               organization could be assigned to accomplish
IER Priority   The IER priority options are Flash, Immediate, Priority, and Routine
IER Types      The IER types are Voice, Data, and Video
JMTK           Joint Mapping ToolKit, the standard mapping interface used on the GCCS.
               This software developed by NIMA and DISA contains a variety of
               applications and NIMA maps data
LOS            Line of Sight
MOE            Measure of effectiveness, a quantifiable metric that expresses the
               effectiveness of a system or concept under test. An MOE can also be defined
               as an algorithm that uses data to be collected to compute a quantity called the
               measure
MOP            Measure of performance, a quantitative or qualitative measure of a system’s
               capabilities or characteristics
MSVC++
               Microsoft Visual C++
NETWARS        Network Warfare Simulation
JCSS           Joint Communications Simulation System
OPFAC          Operational facility, a communications node that comprises one or more
               types of communications devices or systems. These devices may be
               military or may be commercial systems used (owned or leased) by
               military components or agencies. OPFACs comprise system elements
SDF            Simulation Description File
SRB            Software Release Bulletin
TMM            Terrain Mapping Module
V&V            Verification and Validation
WIPT           Working Integration Process Team




                                         18