Demonstration Video Surfer 9 - Part 8 Worksheets by zwy26015

VIEWS: 48 PAGES: 3

									                                   Demonstration Video
                                         Surfer 9 - Part 8
                                          Worksheets
PART 8
   1. Introduction
   2. Opening Data
   3. Transforming Data
   4. Spatial Analysis
   5. Calculating Statistics
   6. Assigning the XY and Z columns
   7. Converting the Projection or Coordinate System


   1. Welcome to Golden Software’s demonstration video for Surfer 9 – Part 8. In this demonstration I’ll
      be discussing some of the functionality available in the Surfer worksheet.

   2. Surfer contains a worksheet window to help you create, open, edit and save data files. There are
      many functions in the Surfer worksheet and I will go over some of the more important ones.

       To create a new data file by entering information into the worksheet, go to File | New |
       Worksheet. This will open a blank worksheet and you can start entering in data.

       If you already have a data file, you can go to File | Open. Select the data file you want to open. In
       this case, I’ll select a data file I created from an area in California, and click Open. The data file
       will automatically open in a new worksheet window.

       You have many of the common worksheet functions available to you under the Edit menu. You
       can cut, copy and paste information, you can clear, insert and delete cells, and you can find and
       replace data.

       Items under the Format menu allow you to format the cells, such as applying a background color
       and adjusting the cell size.

   3. The options under the Data menu allow you to work more thoroughly with your data and massage
      it to your needs. Surfer allows you to apply a transform equation to your data. For example, you
      can convert data units using a simple equation, calculate the log of the data, reverse the sign of
      the data (for example, make negative data positive or vice versa), or you can apply an IF
      statement to your data to apply a criteria and action.

           a. For example, to convert the Z units of this data from meters to feet, go to Data |
              Transform.

           b. I’ll enter the function D=C*3.2808. This tells Surfer to take the data in Column C, multiply
              it by 3.2808, and write the results to Column D. If I only wanted to apply this function to
              certain rows of data, I could enter the range of rows here under First row and Last row.

           c.   I click OK and the data is populated. I’ll type in a new header for this new data.




                                                                                                           1
4. Surfer also allows you to apply a spatial filter to your data. This gives you the option of eliminating
   some of the data based on certain criteria. This is useful if you want to create a post map of only
   certain information. You can filter your data first, save it, and then create the map.

        a. For example, I will go to Data | Spatial Filter.

        b. Let’s say I want to eliminate all data, except the data that has a Z value between 500 and
           1400 feet. I will enter the Data Exclusion Filter of z<500 or z>1400 to exclude this data.

        c.   I’ll verify and update my input and output columns, and click OK.

        d. The data is populated in the output columns. The filtered data is identified in the
           worksheet with the word (Filtered) in the header. I’ll go to File | Save to save the data file.

5. Calculating statistics is another function Surfer has that allows you to get the information you
   need from your data.

        a. Simply select a range of data, for example I’ll select this entire column by clicking on the
           column header, and go to Data | Statistics.

        b. Select the statistics you wish to calculate by checking or unchecking the boxes. You can
           choose to have the statistics results displayed in a new window or you can choose to
           paste them into the existing worksheet. I’ll create the new window and click OK.

        c.   The selected statistics are displayed in a new window. I could copy the results by clicking
             the Copy button and then paste them somewhere else, such as a Word document or as a
             text block in the plot window, or I can close the window by clicking the Close button.

6. Surfer will show you what columns in the data file are considered the X, Y and Z data by
   displaying a little X, Y and Z character to the right of the column letter designation. You can
   assign any three columns in a data file as the XY and Z columns. There are two reasons why you
   would assign the column in the data file:

        a. First, if you assign the columns in the data file, and leave the data file open in the Surfer
           worksheet, then the assigned columns are used as the default input X, Y, and Z columns
           when gridding or creating a post map. For example, I’ll go to Data | Assign XYZ
           Columns and assign the X, Y and Z columns to be E, F and G. I will click OK. See that
           the little X, Y and Z designations move to the E, F and G columns. Then I will go to the
           plot window and go to Map | New | Post Map, select the data file from the list of open
           worksheets at the bottom of the dialog (do not select the data file from the main window),
           and click Open. The post map is created. I’ll double click on the post map and see that
           the X and Y columns I assigned are used by default.

        b. The second reason assigning XYZ columns is useful is with the Track Cursor command.
           One of the functions of the Track Cursor command is to highlight the nearest data point
           in the data file to the position you click on a post map. This requires that the XYZ
           columns be specified properly in the worksheet window. For example, I’ll close the extra
           Sheet1 window. Then I’ll go to Window | Tile Vertical so we can see both the worksheet
           window and the plot window at the same time. I’ll scroll the windows so we can see the
           data points and the map. In the plot window, go to View | Track Cursor and click on the
           post map near a point. That point will automatically be highlighted in the worksheet. This
           makes it easy to find data points in a worksheet by picking them out on a map. This only
           works when the XYZ columns are assigned correctly in the worksheet. I’ll maximize the
           worksheet window again.



                                                                                                          2
    7. Surfer 9 adds a new functionality of being able to convert the projection of data in the worksheet.
       In this example, I will convert these UTM coordinates to latitude/longitude coordinates.

            a. To do this, go to Data | New Projected Coordinates.

            b. In the New Projected Coordinates dialog, the X Source Column and Y Source Column
               must be assigned the corresponding X and Y columns in the data. In this case, the
               columns are automatically entered correctly since I assigned the XYZ columns
               previously.

            c.   Click the (...) button to the right of Source Coordinate System to enter the source
                 coordinate system for the data. This is the current coordinate system for the data, which
                 in this case is UTM, Zone 10, NAD27.

            d. In the Assign Projection dialog, open the Projected Systems | UTM | North America
               section. I’ll expand the dialog to see the entire coordinate system names.

            e. Find and select North America NAD27 UTM zone 10N and click OK.

            f.   When you click OK in the Assign Projection dialog, the selected coordinate system is
                 entered as the Source Coordinate System.

            g. Designate the X and Y Target Columns where you want the re-projected latitude and
               longitude data to be entered. By default, the first two empty data columns are entered.

            h. Click the (...) button to the right of Target Coordinate System to enter the target
               coordinate system, which in this case is latitude and longitude.

            i.   In the Assign Projection dialog, open the Geographic (lat/long) category.

            j.   Under this category are listed many different datums. You can choose which datum you
                 want your lat/long coordinates to use. Most simple lat/long coordinates use World
                 Geodetic System 1984 (WGS84) as the datum. Select the datum you wish and click OK.
                 This coordinate system is entered as the Target Coordinate System.

            k.   Click OK and the coordinates in the designated source columns are converted and
                 entered into the designated target columns. I will add additional header information.

            l.   Use the File | Save or File | Save As commands to save the data. You can then use this
                 new data to create a grid file and a map.

This concludes my demonstration of some of the functionality in the Surfer worksheet.




                                                                                                             3

								
To top