sketchup tutorials by getfresh

VIEWS: 4,659 PAGES: 12

									Using SketchUp Pro 5 with Google Earth and the 3D Warehouse
Last Updated: June 2006

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -1-

Table of Contents I. Introduction II. Using SketchUp Pro 5 with Google Earth III. The KMZ Importer and Exporter IV. Other SketchUp/Google Earth Functionality V. Using SketchUp Pro 5 with the 3D Warehouse VI. Obtaining Technical Support 3 4 12 13 13 13

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -2-

I. Introduction
Google Earth allows you to view high resolution aerial and satellite imagery of the earth, including buildings, roads, mountains, and so on. Google Earth also allows you to export location data (latitude and longitude) along with other information (such as geometry) in the form of Google Earth’s proprietary Keyhole Markup Language (KML) or KMZ files. A KMZ file is simply a zipped KML file. Google Earth is available at http://earth.google.com/. Google Earth comes in three versions: Free, Plus, and Pro. The main difference between Google Earth free and Google Earth Plus is that Google Earth Plus offers GPS data import and drawing tools. The drawing tools are useful when exporting files for SketchUp, but not required. The main difference between Google Earth Plus and Pro is that the Pro version supports better print capabilities, image exporters, and various data imports, which are useful in the GIS realm. As the name suggests, primarily business professionals use Pro. The 3D Warehouse is a free repository where you can store, search, and share 3D models. Please note that the 3D Warehouse is in beta. The Google Earth/3D Warehouse Plugin is an extension to SketchUp allowing SketchUp to take snapshots of Google Earth terrain, import Google Earth KML files, export Google Earth KMZ files, and post models to and get models from the 3D Warehouse. In a nutshell, this plugin allows you to create a truly 3D earth.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -3-

II. Using SketchUp Pro 5 with Google Earth
The most common way to use Google Earth and SketchUp together is to use the plugin’s snapshot tools to bring location information and a satellite image from Google Earth to SketchUp, develop a 3D model within the context of that location, and export model back to Google Earth.

Preparation
There are a few configuration options you should set before using the plugin. These are as follows: • • • Google Earth 3.0.640 or higher must be installed (4.0 or higher to support textures). Elevation Exaggeration must be turned to 1 in Google Earth (Tools > Options > View) Terrain must be turned on in Google Earth. Click on the Terrain check box ( • ) toward the bottom middle of Google Earth to turn on terrain.

Change your image resolution in Google Earth to Large (Tools>Options>View>Detail Area) to ensure the best image snapshots in SketchUp.

Note – If your snapshot appears solid black in SketchUp, adjust your graphics mode option in Google Earth. Go to Tools > Options > View and change your graphics mode setting from Open GL to Direct X. Exit and restart Google Earth for this setting to take effect. • Install SketchUp Pro 5 and ensure your SketchUp Pro 5 is current (Help > Check Web For Update… on Microsoft Windows and SketchUp > Check web for Update… on Mac OS X). Install the plugin (GooglePluginyxxxxxEN.zzz - where y is the platform [“W” for Windows and “M” for Mac OS X], xxxxx is the version of the plugin, and zzz is the extension [exe for Microsoft Windows and dmg for Mac OS X).

•

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -4-

Workflow
Following are the details of this process. 1. Run Google Earth. 2. Find the location where you want your 3D model to appear. For example, type “Acorn Lane, Boulder, CO” in the Fly To text entry box in upper left-hand corner of Google Earth. This is a street in the foothills near Boulder, Colorado.

3. Click on the Search button to fly to the location in the Fly To text entry box. The location appears in the 3D viewer (the portion of Google Earth where the satellite images appear). 4. Zoom in on this location until you have a fairly detailed view of a building that you want to model. In this example you will build a new house model to the left of the house with the U-shaped driveway.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -5-

5. Open SketchUp Pro 5. 6. Click on the Get Current View button ( ) in the Google Earth toolbar within SketchUp. A 2D snapshot of the current image in Google Earth’s 3D viewer appears in SketchUp.

Note – If you are running SketchUp 5.150 and your initial snapshot (or import) appears far from origin, try updating to the SketchUp 5 Maintenance Release or closing and reopening SketchUp.

Note – The Snapshot button creates 2D and 3D snapshots of the current image in Google Earth’s 3D viewer. 2D snapshots are used primarily for creating your building footprint because it is easier to model on a flat surface than on a surface with terrain. The 3D terrain snapshot is used primarily for doing final positioning of a model to the terrain. 7. Model your building by drawing directly on the snapshot in SketchUp. If there are building footprints in your snapshot image, use the building footprints as your guide. For example, you could trace the building footprint of the house with the U-shaped driveway.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -6-

8. Click on the Toggle Terrain button ( ) in the Google Earth toolbar within SketchUp. A snapshot of the current image in Google Earth’s 3D viewer, this time with 3D terrain, appears in SketchUp. The terrain snapshot in this example will slope up over the model of the house (the following image shows the tip of the house poking through the terrain snapshot).

Note – The snapshot button actually takes two snapshots, one with terrain and one without terrain. Each snapshot is assigned a different layer in SketchUp whose visibility is togged using the Toggle Terrain button.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -7-

9. Adjust your model to match any terrain. The house in the example was grouped and moved up on top of the terrain. The foundation of the house was push/pulled down into the terrain to create a foundation that matches the slope of the terrain.

Note – The terrain in some locations in Google Earth is not as dramatic as in other areas. No matter how subtle the terrain, however, adjusting your building to the terrain ensures that your building does not appear to float above the ground (even in a seemingly flat location). 9. Click on the Place Model button ( ) to view your model in Google Earth. The Place Model button creates a temporary file for viewing in Google Earth.

Note – You will have to reverse the faces in your model (within SketchUp) if your model appears black in Google Earth. Select the faces to reverse and then context-click and select Reverse Faces from the context menu. 10. Once you have a model you want to export, select the 3D Model… submenu item from the Export menu item in the File menu. The Export Model dialog box is displayed. 11. Navigate to the location on your hard drive where you would like to save your KMZ file. For example, C:\.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -8-

12. Select Google Earth (*.kmz) from the Export type drop-down menu. 13. Type in a file name in the File name text-entry box. For example, “AcornHouse.kmz”

14. Click Export. A progress bar is displayed followed by a KMZ export results dialog box. 15. Click the OK button.

Opening Your Model in Google Earth
Now you can bring your final model into to Google Earth.

Note – You can skip this section if you are using the Launch Google Earth After Export option to automatically load the model into Google Earth. 1. Run Google Earth again (if it is not already running). 2. Select the Open menu item from the File menu. 3. Open your KMZ file. For example, “AcornHouse.kmz” 4. Google earth will place the contents of this file (your model) in the appropriate location and Fly To that location.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse -9-

Note - Google Earth will prompt you to save your KMZ file in the “My Places” folder when you exit Google Earth. Google Earth will automatically load any KMZ files from the “My Places” folder when it starts again. Click on the Yes button if you want your structure to appear in Google Earth every time you run Google Earth. Now you can post your model to the 3D warehouse (see Using SketchUp Pro 5 for further information), email it to friends, clients, and so on.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse - 10 -

III. The KMZ Importer and Exporter
The KMZ importer allows you to load KML and KMZ files. This importer is particularly useful if you have a model in Google Earth that was created in SketchUp, but do not have the original .SKP file. Simply import the model into SketchUp using the KMZ importer (File > Import > *.kmz, *.kml) The KMZ exporter allows you to export your SketchUp files as KMZ files for use in Google Earth (File > Export > 3D Model… > *.kmz).

Note – If you are running SketchUp 5.150 and your initial snapshot (or import) appears far from origin, try updating to the SketchUp 5 Maintenance Release (5.160 on the PC and 5.0162 on the Mac) or closing and reopening SketchUp.

IV. Other Google SketchUp/Google Earth Plugin Functionality
There is additional functionality built into the plugin. This functionality is as follows: • HTML (images, tables, basic formatting) placed into the model description, component description or a text note within SketchUp, appears as balloons in Google Earth. Pages in SketchUp appear as tour steps within the Tour folder… in Google Earth. You can select the Tour folder in Google Earth and click on the play button to cycle through the pages.

•

V. Using Google SketchUp Pro 5 with the 3D Warehouse
The Google Earth/3D Warehouse plugin allows you to easily get models from the 3D Warehouse for use in SketchUp or post your creations to the 3D Warehouse to share with others. To share a model by posting to the 3D Warehouse: 1. Click on the Share Model button ( The ) in the 3D Warehouse Toolbar.

2. Fill out the fields in the 3D Warehouse to post your model.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse - 11 -

Warning – If you reoriented the drawing axes during modeling, context-click on the SketchUp axes and select the Reset menu item. This proceedure will ensure that the model is oriented correctly when downloaded by other users. To get a model from the 3D Warehouse: 1. Click on the Get Models button ( ) in the 3D Warehouse Toolbar.

2. Navigate to the model you want to retrieve in the 3D Warehouse. 3. Click on the model’s name. 4. Click on the Download to Google SketchUp button. The model appears in Google SketchUp.

VI. Obtaining Technical Support
Technical support is available through our knowledge base and using email for the plugin. The knowledge base can be accessed at sketchup.google.com and will have the most up-to-date information on the plugin. For email support, send your questions to earth@sketchup.com.

Using SketchUp Pro 5 With Google Earth and the 3D Warehouse - 12 -


								
To top