Countries of the World Database (Access) by shameona

VIEWS: 35 PAGES: 2

									                 Countries of the World Database (Access)
Creating and Saving a Database
1. Open Access
2. Click the radio button for Blank Database and click OK
3. It will make you save the database so to SAVE:
    Save in: work your way into your folder (users99->your folder)
    File name: type in Social Studies
    Save as Type: leave it as Microsoft Access Databases
    Click the Create button

Creating a Table
1. Click on the Tables tab (it may already be chosen)
2. Click New on the right side of the window
3. Click on Design View and then click OK

Setting up Field Names and Data Types
1. Type in Country Name for the first title in the Field Name column. Hit Tab (or Enter or the arrow
    keys). Text will appear automatically for the Data Type, which is what you want for the name of a
    country. Skip the Description column unless you want to enter your own info here describing the
    field and its contents.
2. Hit Tab until the cursor is in the field below country name.
3. Type in Language as the field name and be sure that its data type is Text. Tab to the next row.
4. Make the third field name be Per Capita Income (GDP). Hit Tab. To change its data type, hold
    down the little arrow in the bottom right of that cell (box) and choose Currency.
5. Continue with the remaining field names and data types so that all of the below are included:
        Field Names                          Data Types
        Country Name                         Text
        Language                             Text
        Per Capita Income (GDP)              Currency
        Urban Population (%)                 Number
        Population                           Number
        Literacy Rate (%)                    Number
        Religion                             Text
        Ethnicity                            Text
6. View->Datasheet View so that we can begin to enter the data
7. It will first make you save this new table so click Yes
8. Name the table Countries of the World and click OK
9. It will ask you if you want a Primary Key so say Yes. It is a good idea to use a primary key.
10. You will now see your table with the appropriate field names.

Entering Data into the Table
1. Resize your ID field so that it is small and resize the other columns so that you can read the field
   names
2. Notice how some of the cells in the first row already have 0's and $'s. This is because of how we
   defined (formatted) them when we set up the data types.
3. Enter United States and its info as the first record:
      Field Names                        Info to Enter
      Country Name                       United States
      Language                           English
      Per Capita Income (GDP)            $31,500
      Urban Population (%)               76
      Population                         272,639,608
      Literacy Rate (%)                  97
      Religion                           Protestant
      Ethnicity                          Anglo

Creating a Form
1. Save. Close your Countries Table by doing File->Close OR by clicking on the BOTTOM X (top
   right corner. You will see that Countries table listed under Tables in your SS Database window.
2. Click on the Forms tab
3. Click New on the right side of the window
4. Choose Form Wizard from the top. Click on the little arrow at the bottom to see all of your tables
   in this database. Choose our Countries of the World Table. Then click OK.
5. Move ALL of our fields (for now) over to the right by clicking on the double right arrow (>>).
6. Click Next and then choose Columnar (but click on the 4 choices to see what they are like)
7. Click Next and then click once on each of the pretty backgrounds but choose International
8. Click Next and discuss but make no changes. Click Finish.

Entering Data using a Form
1. Use the arrows at the bottom, beside the word Record, to navigate from record to record.
2. Enter data for the given countries. Data is given on another sheet. You can't enter anything into
   the 1st field, which is the ID or primary key. Tab or Enter will move you from field to field.


EXTRAS (If done with all of the above)
Making Changes to the Form
1. Return to Design View (View->Design View)
2. Formatting with Commas: Double click on the right box containing Population so that another
   window appears. In that window, click in the box out to the side of Format so the little arrow
   appears. Choose Standard so that we will have commas. However, that will add 2 decimal places
   so click in the box by Decimal Places and change it to 0. Go look (View->Data sheet View). Yes
   to save!
3. Resizing boxes (so all text can be read): Be sure boxes are around that box(and that box only)
   that you want to resize. Click a middle side arrow and drag.
4. Return to Form View (View->Form View)

								
To top