Digital Sound and Music _c_ Tom by pengxiang

VIEWS: 30 PAGES: 10

									                         Digital Sound and Music
                      (c) Tom amd Mary O'Haver, Version 8, February, 2004

1. Recording and Writing Audio CDs
Why you would want to do this: Here you will learn here how can record particular songs from your
audio CDs onto your computer's hard drive, so that you can play them with your computer's sound player
program, without handling the original CDs. You can even set up "playlists" of the songs you have
recorded - great for parties and background music. If you have a CD-writer (CD-RW) on your computer,
you can burn custom CDs with any songs you have recorded, so you can play them on any regular CD
player. Or you can transfer these songs to a portable MP3 Player. (Songs that are recorded from a CD
onto your computer are automatically converted into a highly-compressed format called "MP3" so thay
don't take up so much disk space). Note: Please make recordings only of CDs that you own, and only for
your own use, in order to avoid copyright violations.
 a. Recording from an audio CD using MusicMatch. (Any version of Windows)
  1. Install and launch MusicMatch. (The installer is in the "MusicMatch CD recorder" in the
     "Windows software" folder on the workshop CD-ROM).
  2. Insert an audio CD into the computer's CD-ROM drive. If your computer is online at this
     time, the program will automatically look up the song titles in the Internet CD DataBase
     (CDDB). (If that particular CD is not in the CDDB, or if the CDDB is not working at the
     time you do this, the tracks will be titled simply Track 01, Track 02, etc, but you can
     re-name them later).
  3. If the disk starts playing, click the square blue "stop" button to stop it.
  4. If the RECORDER panel is not showing below the main MusicMatch window, click the red
     round button.
  5. The Recorder window will display the artist name and album name on the left side; you can
     edit these if you like. MusicMatch uses these names to create folders to save the recorded
     music files in. Only the tracks checked will be recorded; so you can un-check any that you
     don't want to record.
  6. Click on the red round button on the recorder panel to begin recording. You will not hear
     the music while it records, because the program spins the CD really fast. Recording a CD
     takes much less time than playing the CD normally.
  7. Once the recording is complete, each selected track on the CD will have been saved in MP3
     format into a folder in "My Documents" --> "My Music". The files will be in folders that
     MusicMatch automatically creates and names for each album that you record. You may
     re-name the folders if you like after the fact. Close MusicMatch when you have recorded
     everything you want
 b. Using MusicMatch to burn a custom audio CD from music tracks that you have
   previously recorded.
   (Note: to do this you must have a CD-writer on your PC).
  1. Open MusicMatch. Click the Burn button at the bottom of the playlist window to bring up
     the Burner window.
 2. Click the button that has a musical note on it if you are making a regular audio CD, or the
    MP3 icon to make an MP3 disk.
 3. Click the Explorer button at the top of the Burner window. Click on the + sign to the left
    of the My Music folder to display all the albums that have been recorded. Click on any
    album to display its music tracks.
 4. Drag the desired music tracks onto the Burner. You can add tracks from many albums.
 5. To rearrange the order of the tracks, just drag and drop the titles within the Burner window.
 6. The green bar at the bottom of the window tells you how much room you have left on the
    disk. If it's red it means that you have too many files; right-click and select Remove file to
    remove a track from the burner list.
 7. Insert a blank CD-R disk into the CD-R drive (do not use a CD-RW disk) and click the
    Burn button to begin burning. This may take several minutes. When it is finished, the CD
    will be ejected. Remove your CD and apply one of the round labels provided, using the
    round plastic alignment tool.. (The full version of MusicMatch can also print out both CD
    labels and jewel-case inserts complete with a list of tracks and song titles).
 8. Click Return to Burner Plus and leave the main program window open for the next group.
c. Recording and burning audio CDs using Windows Media Player 8 and Windows XP.
   (Note: to do this you must have a CD-writer on your PC).
 1. Insert an audio CD into the computer's CD-ROM drive.
 2. After a few moments, a dialog box will pop up that asks you "What you want Windows to
    do?" Click on "Copy music from audio CD using Windows Media Player".
 3. Windows Media Player will open up and the copying process will begin automatically. (If
    that does not happen, you can open Windows Media Player 8 yourself - click Start -->
    Programs --> Accessories --> Entertainment --> Windows Media Player - then click on
    the "Copy from CD" tab on the left, and click the red Copy Music button at the top). You
    will not hear the music while it records, because the program spins the CD really fast.
    Recording a CD takes much less time than playing the CD normally.
 4. Once the recording is complete, the audio disk is ejected. Each selected track on the CD
    will have been saved in WMA (Windows Media Audio) format into a folder in "My
    Documents" --> "My Music". The files will be in folders that Windows Media Player
    automatically creates and names for each album that you record.
 5. To burn an audio CD from these or any other tracks that you have previously recorded,
    insert a blank CD-R into your CD-R drive (do not use a CD-RW disk).
 6. After a few moments, a dialog box will pop up that asks you "What you want Windows to
    do?" Click on "Select media to copy to CD using Windows Media Player".
 7. Windows Media Player will open up in the "Copy to CD or Device" mode. (If that does
    not happen, you can open Windows Media Player 8 yourself - click Start --> Programs
    --> Accessories --> Entertainment --> Windows Media Player - then click on the "Copy
    to CD or Device" tab on the left).
 8. To select music tracks, click Start --> Documents --> My Music. This will display all the
    albums and tracks that you have previously recorded. To select an album or a music track
    for copying the the blank CD, simply drag the folder or the song track onto the left-hand
    panel of the Windows Media Player window. If you drag too many files than can fit on an
    audio CD, the ones that don't fit are labeled "Won't fit" in the Status column.
  9. Click the red Copy button to start the process. Windows Media Player will display the
     estimated time remaining to complete the process at the bottom of its window. When it is
     finished it will eject the completed audio CD.

2. Recording sound with your computer's sound inputs.
  a. Connecting and adjusting a microphone for recording spoken comments.
         1. For recording voice, use a headset with an attached microphone, rather than a
         separate hand-held microphone. This type of headset leaves your hands free and keeps
         the microphone at a fixed distance from the mouth. Position the microphone to the side
         of the mouth, not in front. (This will avoid pops and other noises caused by some
         consonants). For recording group singing or instrumental music, use a stereo
         microphone like the RadioShack 33-3028, $30.
         2. Plug in the microphone plug into the microphone jack on the back of the computer.
         Plug in the headphone plug into the speaker or headphone jack on the back of the
         computer. Usually the plugs and jacks are labeled with a picture or a word to indicate
         their function. Ignore the colors of the plugs and jacks; they won't usually match
         because different manufacturers use different color coding schemes..
  b. Check the sound settings.
     1. Double-click on the volume control (little loudspeaker icon) in the taskbar on the lower
        right corner of the screen.
     2. Make sure that the Mute box under Volume is not checked and that the volume is
        turned up.
     3. Select Options --> Properties and click on Recording and click OK. Then make sure
        the Select checkbox is checked under "Microphone" (it may be called "Mic.").
     4. If your computer has an Advanced button below "Microphone", click on it and make
        sure that the Mic Gain box is checked. Close all the boxes.
  c. Simple method for recording short soundbites, using the Windows Sound Recorder:
      1. Create a folder on the desktop to save your sounds in:
            1. Right-click on the desktop.
            2. Select New --> Folder.
            3. Type "Sounds" and press Enter.
      2. Select Start --> Programs --> Accessories --> Entertainment --> Sound Recorder.
      3. Click on the round red button to begin recording. Click on the black square button
         to stop. Click on the black triangle to hear what you have recorded.
      4. If you are satisfied, skip to step 5. If not, Select File --> New, click No, and repeat
         step 3.
   5. Select File --> Save, navigate to the "Sounds" folder on the desktop, type in the file
      name "test1" into the File Name box, and click Save.
   6. Select File --> New to clear the old sound and repeat steps 3 - 5 to record another
      sound, giving it the file name "test2". Close Sound Recorder when you are finished.
d. Making high-quality recordings the Cool Edit 96 sound editor program
  1. Install Cool Edit: Insert the workshop CD-ROM into the CD-ROM drive, open the
      "Windows software" folder and install Cool Edit 96 (Double-click on c96setup.exe in
      "CoolEdit sound editor installer" and follow the prompts.)
  2. Launch Cool Edit and select the buttons for "Save, external clipboard,..." and
     "Amplify, envelope, ..." and click OK.
  3. Select File --> New, then select one of these combinations of settings in the New
      Waveform window:
     For the smallest file size for voice recordings: set to "mono, 8 bits, 11025"
     For better quality voice: set to "mono, 16 bits, 22050"
     For CD-quality mono music: set to "mono, 16 bits, 44100"
     For CD-quality stereo music: set to "stereo, 16 bits, 44100"
     Click OK after making your selection.
  4. Click the Record button to begin recording, Stop to stop, Play to play what you have
      recorded.
  5. If you don't want to keep that sound, select File --> New, click No, click OK, then
       repeat set 4.
  6. Editing. To delete sections of the sound file that you don't want, drag the mouse
      pointer over that portion of the waveform and press the Delete key. To hear just one
      section of the sound file, drag the mouse pointer over that portion of the waveform and
      click the Play button. You can also Cut, Copy, and Paste sections of a sound file just
      like a text file.
  7. Adjusting volume. In order to compensate for differences in the volume (loudness) of
      several successive recordings, it's useful to use to normalize function (select
      Transform --> Amplitude --> Normalize and click OK) before saving each sound.
  8. Select File --> Save as... , navigate to the "Sounds" folder on the desktop, select
      "Windows PCM (.wav)" from the "Save as type" pop-up menu, type in a file name
      into the File name box, and click Save.
  9. To record another file, go to step 3. Close Cool Edit when you are finished.
e. Recording from a record player or tape player.
  1. Connect the output of the tape or record player into the "line in" input of the computer
     with a suitable patch cord (e.g. the Radio Shack 42-2387A shielded audio cable, with a
     1/8" stereo mini-plug at each end, works with most tape recorders and costs about
       $4.00).
     2. Double-click on the volume control in the taskbar on the lower right corner of the
        screen. Make sure that the Mute box under "Mic" is checked and that the one under
        "Line in" is not checked and that the "line-in" volume is turned up.
     3. Select Options --> Properties and click on Recording and click OK. Then make sure
        the Select checkbox is checked under "Line-in". Close the box.
     4. Launch Cool Edit by selecting Start --> Programs --> Syntrillium --> Cool Edit 96.
        Select the buttons for "Save ..." and "Amplify ..." and click OK.
     5. Select Options --> Monitor VU level. Start up the tape recorder and play the tape.
        Adjust the volume control on the tape recorder so that the two red pars at the bottom of
        the Cool Edit window do not exceed the right-hand limit on the loudest parts of the
        music; this will insure that the sound is loud enough but does not overload or distort.
     6. Select File --> New, then select "44100, stereo, 16 bits" in the New Waveform
         window: Click OK after making your selection.
     7. Start the tape or record player and then click the Record button, Stop to stop, Play to
         play what you have recorded.
     8. If you don't want to keep that sound, select File --> New, click No, click OK, then
          repeat set 6.
     Note: If the record or tape consists of several separate songs, stop the recording and the
     tape after each song, and save the resulting file as the name of that song. Later, these
     digitized songs can be assembled as you wish in a playlist, or thay can be burned onto an
     audio CD.

3. Playing back sound on your computer (WinAmp, Windows Media Player, etc).
     1. Once you have recorded a sound and saved it as a file, you can play it on any
       computer; you don't need Cool Edit to play recorded sound files - only to edit them.
       First, you should set up your computer so you can see the file extension, and thus the
       file type, of the files you'll be working with. Select Start --> Settings --> Folder
       Options. Click on the View tab. Make sure that "Hide file extentions for known file
       types" is not checked. If it is, click it to un-check it. Click the Reset All Folders
       button and close the Folder Options window.
     2. To play sound files directly on any computer, in most cases you can just double-click
        on a sound file and let the computer decide which sound player program to use. Most
        contemporary computers come with a built-in sound player program that will handle all
        common sound file formats. On most Windows computer, Windows Media Player is
        the default sound player. However, you can force another sound player program to
        play a sound by dragging the sound file and droping it onto the icon of the sound-player
        program of your choice. To edit a sound file, on the other hand, you'll have to open it
        in a suitable editor program (e.g. Cool Edit for WAV, AU, or AIFF files, Sweet MIDI
        player for MIDI files, or Finale Allegro for ETF or other music notation files). See the
        handout "Formats.doc" for more information on sound file types.
    3. Open the folder "Sound file examples" on the workshop CD-ROM and select List from
       the View menu so you can see the entire file name. Try playing some of the wav, au,
       aiff, and mid files by double-clicking on them. This will let the computer decide which
       sound player program to use to play the sound. Notice which sound player application
       is launched for each file type; this will vary depending on how the computers are set up.
       Some of the files can't be played by double-clicking on them because you have not yet
       installed the software required. When you are finished listening to these files, close all
       programs.
   Note: To play music loud enough to fill a room, you'll want decent speakers hooked to your
   computer: a good choice is a powered three-way computer speaker system that has a
   sub-woofer (for bass sounds) in addition to small left and right side speakers. The Altec
   Lansing among other manufacturers make speaker sets that sound great and that cost as little
   as $20.

4. Downloading sounds from Web pages.
        Downloading sounds and music from Web sites is easy. The folder "Sound and
      Music Web sites" on the Workshop CD-ROM contains many examples of Web sites
      containing downloadable sounds; look especially at the "Animal sounds",
      "Downloadable sound and music files", and "Sing-along and Karaoke" folders. Once
      you have located a link to a sound file (in wav, aif, mp3, au, mid or kar formats), just
      right-click on the link and select "Save Target As..." from the pop-up menu. Navigate to
      a location that you will remember and press Save. To play a sound you have
      downloaded, open it from within your choice of sound player, or drag and drop the
      sound file onto the sound player. (Double-clicking on the sound file will only work if a
      player application has been previously assigned for that file type).
        In some cases, a sound-producing Web page may not have a direct link to a sound file,
      so you can't use the above method to download the file. This will be the case for Web
      pages that use "streaming" audio, such as "real audio". In cases such as this, you can
      still capture the audio by using Cool Edit and your sound card's mixer function.
        1. Double-click on the volume control (little loudspeaker icon) in the taskbar on the
      lower right corner of the screen.
        2. Select Options --> Properties and click on Recording and click OK. Then make
      sure the Select checkbox is checked under "Mixer" (it may be called "Mix." or "Stereo
      Mix.") and make sure that its volume is turned up.
       3. Launch Cool Edit and select the buttons for "Save, external clipboard,..." and
      "Amplify, envelope, ..." and click OK.
       3. Select File --> New, then select one of these combinations of settings in the New
      Waveform window:
        For the smallest file size for voice recordings: set to "mono, 8 bits, 11025"
        For better quality voice: set to "mono, 16 bits, 22050"
        For CD-quality mono music: set to "mono, 16 bits, 44100"
        For CD-quality stereo music: set to "stereo, 16 bits, 44100"
        Click OK after making your selection.
        4. Click the Record button to begin recording, then switch to the Web page and start
      the sound that you wish to record.
        5. Stop to stop and Play to play what you have recorded. Before saving the sound, you
      will probably want to select and delete the silence at the beginning of the file. Use the
      Normalize function (select Transform --> Amplitude --> Normalize and click OK)
      before saving each sound. Note: this method can be used to capture sound from just
      about any sound-producing program.

5. Putting sounds on Web pages.
     Note: You will find this section useful if you are interested in making your own Web
      site. If not, skip this section.
     Sounds on Web pages are actually separate files, referred to by HTML links on the page.
      In both of the two following examples, the sound file is located in the same folder as the
      HTML file.
      Method 1: Link to file. Suppose you have a sound file called "s1.wav". One way to
       play this from a Web page is to add this to the HTML text:
       <a href="s1.wav">Click here to hear a sound bite</a>.
       This creates a hot link labeled "Click here to hear a sound bite"; when you click
       on it, your browser's sound player is launched and the sound is played. Depending on
       your sound player, this also works for other audio file formats such as ".au", ".aiff",
       ".mp3" and ".mid" files. Just change the file name in the HTML link to match the
       exact name of the audio file.
      Method 2: Embedded controller. Another way is to add this to the HTML text: :
       <embed src="s1.wav" width=144 height=45 autostart=false>
       This displays a sound controller on the Web page, with controls to start and stop the
       sound and adjust the volume. To hear the sound, click on the right arrow icon on the
       controller. If you want the sound to play automatically as soon as the page is opened,
       replace autostart=false with autostart=true. Depending on your sound player,
       this also works for other audio file formats such as ".au", ".aiff", ".mp3" and ".mid"
       files. Just change the file name in the HTML link to match the exact name of the audio
       file.
     To demonstrate these two methods, we'll create a test page that will play the sounds you
     recorded above:
        1. Open your "Sounds" folder and drag "Sound Test Page.htm" from the Workshop
        CD-ROM into it.
        2. Right-click on "Sound Test Page.htm" in your "Sounds" folder, select Properties,
           and un-check Read only. Make sure Read only is not checked, then click OK.
        3. Double-click on "Sound Test Page.htm" in your "Sounds" folder to launch
        Internet Explorer.
        4. Pull down the HTML Edit menu (the one on the right-hand side of the toolbar - not
              the usual Edit in the menu bar next to File) and select Edit with Windows
              Notepad. This will display the HTML for this page.
           5. You can see that this test page already has the HTML code for two sounds typed it,
              the first using method 1 (link to an external file) and the second using Method 2
              (embedded sound controller).
           6. Make sure that the file names in the text here, "test1.wav" and "test2.wav", match
              exactly the file names of the sounds that you saved in your "Sounds" folder
              (including the extension). If not, edit the names of the sound files so that thay do
              match, select File --> Save, close the Notepad window, switch to the Internet
              Explorer window, and click Refresh.
           7. Test the sounds by going to the Internet Explorer window. Clicking on the link that
              says "Click here" to test the first sound and on the triangle in the sound controller
              to test the second sound. Close the sound player window and the Internet Explorer
              window when you are finished.
       Adding sound to the multimedia alphabet books. If you have elementary grade
        children or grandchildren who are looking for a creative school project involving
        computers, here's a project you can both work on together: a computerized alphabet
        book with pictures and sounds for each letter. Directions are in the separate handout
        "Step-by-step Procedure for completing the Alphabet Book Web sites".
           Note 1: If you want to create your own multi-page Web sites with an embedded
            sound controller on each page, you can use the templates in the "Web templates
            with sound" folder on the workshop CD-ROM. See the ReadMe file in this folder
            for a description of the templates. Specific step-by-step instructions for each
            template are in the ReadMe files in each template folder. See
            http://www.wam.umd.edu/~toh/templates/ for more details.
           Note 2: If for any reason you want to replace a sound that is connected to an
            embedded sound controller on a Web page, you must move to a different Web page
            temporarily before deleting or replacing the sound, then move back to the page to
            test the new sound. If you don't do this you'll get an error message when you try to
            delete or replace the sound.

6. Sounds in Powerpoint presentations.
Powerpoint is a popular program for creating computer-based presentations at meetings. If you
are interested in adding sounds to Powerpoint, refer to the handout: "Adding music, sounds, and
videos to PowerPoint Presentations".

7. Computer music activities: you don't have to be a musician to have fun with
music.
  a. Arranging MIDI songs using the MegaMID MIDI Player.
    1. Open the "MegaMID MIDI player" folder in the "Windows software" folder and
       double-click on MegaMID.exe.
    2. Click on the Load button and navigate to the "Other MIDI examples" folder on the
       workshop CD.
 3. Double-click one of the MIDI files to the "Other MIDI examples" folder, such as
    "FlipFly.mid".
 5. You can change the instruments by clicking on the instrument names in the main window
    and selecting from the list of alternative instruments of that type. (Right-clicking allows
    you to change instrument types). You can change the tempo by clicking the left or right
    mouse buttons on the word "Tempo" at the bottom left of the main window. To stop the
    music, click on the square.
 6. Try some of the other MIDI files and experiment will different instruments. Close
    MegaMID when you are finished.
 Note: With most sound cards, you can record your MIDI creation as a WAV file by running
   Cool Edit at the same time as the MIDI player, and setting the recording properties to
   accept input from the "mixer". Set the recording parameters to "stereo, 16 bits, 44 KHz"
   and save the file in "Windows PCM (.wav)" format if you intend to make an audio CD.
b. Computer Karaoke: The "Karaoke examples" folder on the Workshop CD-ROM contains
over 85 examples of MIDI-Karaoke KAR files, which contain the lyrics and the music
accompaniment to a song. When played by a Karaoke program, the music will be played by
your MIDI sound card and the lyrics will be displayed on the screen, synchronized to the
music, for you to sing along with.
A simple Karaoke program called WinKaraoke Player is contained in the Windows software
folder. Here's what to do:
 1. First, install WinKaraoke Player: Open "WINkaraoke program" in the "Windows
    software" folder and double-click on "setup.exe". Follow the on-screen instructions and
    accept the default answers to the installation questions.
 2. Once the program is installed, run it: select Start --> Programs --> WinKaraoke Player
    1.5 --> WinKaraoke Player 1.5
 3. In the WinKaraoke Player window, navigate to "Karoke examples" on the CD-ROM.
 4. Choose one of these files and click the PLAY button to display the lyrics window.
 5. Click the right arrow to start playing. Click the square to stop.
 6. Note: To print out the lyrics, click the Export button, navigate to your sound folder, type
    in a file name, and click Save. Then double-click on the resulting text file to and Print it
    as usual.
 7. Close WinKaraoke Player's lyrics window to select another song.
 8. To change the size aof the displayed lyrics, click Options in the main WinKaraoke
    window and then click on the Font button. Select a font and size and click OK to return
    to the WinKaraoke window . Then click the PLAY button to display the lyrics.
c. Changing the musical arrangements. If you don't like the tempo, key, instrumentation, or
instrument balance of the song, you can change these things using the Sweet MIDI Player.
Here's how:
 1. Open the "Windows software" folder and open the "Sweet MIDI Player" folder.
    Double-click on "Swmipl32.exe".
 2. Select Load MIDI file... from the File menu, select "All Files" from the "Files of type"
    menu, navigate to the desired Karaoke (.kar) file, and click Open. (Or you can just drag
    and drop a Karaoke file onto Swmipl32.exe or its shortcut).
 3. Click on the right arrow to start the song.
 4. To change the volume (loudness) of an instrument, use the volume slider for that channel.
 5. To change the instrument assigned to a channel, click on the instrument name in the box
    below the volume slider and select another instrument.
 6. To change the tempo, right- or left-click on the Tempo Change box.
 7. To change the key, right- or left-click on the Transpose box.
 8. To set the left-right stereo position of an instrument, use the "Pan" knobs at the top of its
    volume slider.
 9. To save the resulting file, select Save MIDI file... from the File menu, then erase the
    ".mid" extension ion the file name and replace it with ".kar" before clicking Save.
    (The saved files must have a .kar extension to be opened by WinKaraoke Player).
Note: To find other Karaoke files to download, try searching on the Web. To download a
file, right-click on the link, select "Save target as...", change the file extension from "mid" to
".kar" extension so that they can be opened by WinKaraoke Player, then click Save.

								
To top