STS Template and Tools Set Up

Document Sample
STS Template and Tools Set Up Powered By Docstoc
					STS
Template
and Tools
Set Up
USFS Gypsy Moth STS
Project – Planning
Meetings for 2010

Mannin Dodd
Contents
Setting up a customized STS Planning Project .............................................................................................. 1

   Get Updated Tool Files.............................................................................................................................. 1

   Create new pSDE GDB or Check-Out ........................................................................................................ 2

   Get updated base data and catch data ..................................................................................................... 2

   Set Layer Source Data in ArcCatalog ......................................................................................................... 3

   Create Project ........................................................................................................................................... 3

What’s new in STS Tools for 2010 Planning Project ..................................................................................... 4

STS Menu Tools ............................................................................................................................................. 5

   Update Attribute Data Tools ..................................................................................................................... 5

   Geometry Editing Tools............................................................................................................................. 6

   Data Checking and Export Tools ............................................................................................................... 6

   Summary Tools.......................................................................................................................................... 6

   Code Tools................................................................................................................................................. 6

Editing Workflow .......................................................................................................................................... 6

   Overview ................................................................................................................................................... 6

   Detailed Notes .......................................................................................................................................... 7

       Create Project Bounds .......................................................................................................................... 7

       Create Delimit Grids and Treatment Blocks.......................................................................................... 8

       Check PPA Reasons for State ................................................................................................................ 9

       Export State Data .................................................................................................................................. 9

       State Report ........................................................................................................................................ 10
This document describes:

      the necessary steps for setting up an ArcMap project customized to create and edit trapping and
       treatment data for the Gypsy Moth STS Project

      what’s new in the 2010 version of the Roadshow tools

      the STS Menu tools

      an overview of the Roadshow editing workflow

      detailed notes on the editing process

Setting up a customized STS Planning Project
   In order to create and edit STS planning data (project bounds, delimits, treatments) using STS Tools,
   you will need to have specific data and directories, and updated code files. The code files required
   are the STSEditing09.mxt ArcMap Template file and the STS Toolbox.tbx file. The data required to
   run the tools are:

      STS.Actions group layer – contains ProjectBounds, Delimits, Treatments, and PPAs from your
       local Replica or Check-out

      STS.DA_Outputs group layer – contains Action Area, Monitoring Area, Mothlines, Krig
       (CatchSurface) from your local Replica or Check-out

      STS.Baselayers group layer – contains States, Counties, Quads (MCDs, townships for some
       states) from a local geodatabase or .sdc formatted file (See What’s New below for details)

      Current Trap Catch layer – moth catch points – this layer is not necessary for the code to run,
       but is necessary for making decisions on how to create the planning data. Catch data can be
       taken from the STS SDE by creating a one-way replica of the STS.Catch data set or can be
       downloaded in compressed format (.sdc) from the ftp site
       (http://fubyss.ento.vt.edu/FTP/project/gis_files/Catch_SDC/)

   The data are presented as Group Layers in the ArcMap project to aid in data management. The layer
   files that define the display of the data on the map and in the Table of Contents are part of the
   download package. You will need to reset their data sources to your local geodatabases after
   download (see Set Layer Source Data in ArcCatalog below for details).

Get Updated Tool Files
   The STSTemplate&Files.zip file is updated and available for download here:

   http://fubyss.ento.vt.edu/FTP/documents/

                                                                                                         1
  After downloading the file, extract all files to your C:\ drive.

  The file contains the following:

     Layer files - for STS Actions, DA Outputs, Current Trap Catch, and STS Baselayers
     STSEditing09.mxt - map template with STS customized tools - named the same as last year’s
      version for continuity
     STS Toolbox –Toolboxes folder containing tools and models used by the template
     scripts – folder and flies used by the template
     projection files – folder and albers8_sts_2.prj and parameters file
     IntermediateData – folder and personal geodatabase accessed by template code and models
      Geodatabases\DataByState folder - used to write state data geodatabase

Create new pSDE GDB or Check-Out
     This is necessary due to some schema changes implemented this year and a rebuild of the STS
      Actions dataset.
     See the ‘Creating STS Distributed Geodatabases’ document on the ftp site
      (http://fubyss.ento.vt.edu/FTP/documents/ ) for instructions if you haven’t done this before.
     If you want to maintain links to your pSDE data that are currently in ArcMap projects, you will
      need to name the new pSDE geodatabase and replicas the same as they were. See this
      document for help – http://fubyss.ento.vt.edu/FTP/documents/RecreatingReplicaGDB.doc
     If you have already created a new pSDE GDB, then synchronize your Replica with the STS SDE.
     If you prefer not to work with ArcSDE personal on your local machine, Check-out STS.Actions
      and STS.DA_Outputs, and optionally STS.Catch in ArcMap using the Create Replica Tool (Check-
      Out option).

Get updated base data and catch data
  Catch and Base datasets are now also stored in Smart Data Compression (SDC) format which can be
  used in the STS Planning Project. The SDC format requires less disk space to store and draws more
  quickly in ArcMap. Both datasets are stored on the ftp site
  (http://fubyss.ento.vt.edu/FTP/project/gis_files/).

  The Baselayers dataset includes States, Counties and Quads. Note that the Quads feature class has
  been simplified (number of vertices reduced) to aid in Project Bounds editing. You can extract the
  Quads feature class from the STS SDE Baselayers dataset or you can download the compressed
  version from the ftp site (http://fubyss.ento.vt.edu/FTP/project/gis_files/Baselayers_SDC).

  The Catch_SDC dataset includes the daily traps data from the database, PLSITES and INSPECT, as
  well as traps removed early and traps set late data. These data are updated nightly and include data
  for the entire project. If you prefer getting catch data for only your state,


                                                                                                        2
Set Layer Source Data in ArcCatalog
  Once the zip file has been extracted, you will need to set the source on the downloaded layer files.
  Follow these steps:

  1.   Open ArcCatalog
  2.   Go to C:\GM_STS\Layers
  3.   Go to the Properties of the STS Actions(GDS) layer
  4.   Go to the Group Tab
  5.   For each layer listed:
           a. Click Properties
           b. Go to the Source Tab
           c. Click Set Data Source
           d. Point it to the appropriate feature class in your Replica/Check-out
           e. Click OK
  6.   Go to the Properties of the DA Data(GDS) layer
  7.   Repeat steps 4& 5
  8.   Go to the Properties of the Current Trap Catch layer or the Trapping Data (SDC) group layer,
       depending on how you acquired your catch information – Current Trap Catch if you got it from
       SDE, Trapping Data if you got it from the ftp site.
  9.   Repeat steps 4&5

  While there are checks in the code to accommodate data not represented by these layer files, your
  editing workflow will be smoother and faster if you set these properties.

Create Project
  To create a new ArcMap project for STS planning:

      Open the STSEditing09.mxt template file by either
          o Clicking the Template radio button on the splash screen when ArcMap starts or
          o Changing the Files of type box to ArcMap template in the File-> Open wizard and
              navigating to C:\Project Files\ArcGIS\bin\templates\sts\
      Add Baselayers, DA Outputs, Actions as group layers from \GM_STS\layers\ folder
      Add Catch data as feature layer (Current Trap Catch) or group layer (Trapping Data (SDC))
      Rename and Save the ArcMap project as a map document file (.mxd)




                                                                                                         3
What’s new in STS Tools for 2010 Planning Project
     The Quad Feature Class in STS.Baselayers has been simplified (number of vertices reduced) to
      aid in Project Bounds editing. You can extract the Quads feature class from the STS SDE
      Baselayers dataset or you can download the compressed version from the ftp site
      (http://fubyss.ento.vt.edu/FTP/project/gis_files/Baselayers_SDC).

     Catch and Base datasets are now also stored in Smart Data Compression (SDC) format which
      can be used in the STS Planning Project. The SDC format requires less disk space to store and
      draws more quickly in ArcMap. Both datasets are stored on the ftp site
      (http://fubyss.ento.vt.edu/FTP/project/gis_files/).

     State dropdown list – On the Editing Toolbar, sets the state to clip to for all clip functions in the
      STS code

          o   There is now a dropdown list of abbreviations for all states in the STS Project. When you
              start editing, you will be prompted to select the state you are working in. All Clip
              functions in the STS code will use this value to clip your data.

     Selected to Project Bounds – On the STS Menu, converts selected features from a user-selected
      layer to a Project Bounds polygon. This is the preferred method for creating Project Bounds
      features as it insures there are no gaps or overlaps between features.

          o   Copies and merges the selected features into one polygon, clips it to the State border,
              erases any areas that overlap existing Project Bounds polygons, then assigns attribute
              values to the new Project Bounds feature.

          o   If there is another Project Bounds feature with Project and Gridtype attribute values
              that match the new feature, you will be asked if you want to merge the new polygon
              with the existing polygon.

     Clip Selected to State – On the STS Menu, clips any selected feature in the Edit Layer to the
      State border listed in the State dropdown list

          o   Scale Tool – On the Editing Toolbar, resizes the selected feature while maintaining the
              proportion of the feature shape.

          o   Caution: You should clear all selected features and then select only the feature you
              want to scale before using this tool. If more than one feature is selected in the map
              (multiple feature classes) this tool will not resize the selected features, but will allow
              you to move all selected features. This means you could accidentally move Project
              Bounds or Treatment features when you intended to only resize a delimit feature.



                                                                                                           4
     STS Customization – on the STS Menu, turns off/on the custom STS functions for editing

          o   Can be used to bulk copy/paste features into STS.Actions feature classes or for editing
              Non-STS data.

     Projected Data Frame – all STS Tools now work with the Data Frame projected in a spatial
      reference other than Geographic.

     PPA Reason Assignment – The code will ask for a DA Deviation Reason only for these scenarios:

          o   when a Treatment is created over a PPA that doesn’t recommend a treatment.

          o   when a Delimit is created over a PPA that recommends treatment.

     Check PPA Reasons for State – On the STS Menu, highlights all PPAs in the State that have not
      been addressed.

          o   This selection will include PPAs that recommend Delimit that have no Delimit grid over
              them even though we are no longer tracking reasons for this scenario. However, this
              tool is intended to insure that all PPAs have been addressed for the state, so these
              delimit PPAs need to be addressed by changing their reason values from ‘Not
              Addressed’ to ‘None Needed’.

     Export State Data – On the STS Menu, creates a file geodatabase for the selected State,
      Estimated Traps Summary by Project and Traptype, Acreage Summary by Treatment Type.

          o   The geodatabase contains the summary tables and feature classes for Allgrids and
              Treatments.

          o   The geodatabase is created in the C:\GM_STS\Geodatabases\DataByState\ folder.




STS Menu Tools
Update Attribute Data Tools
     Update Acres/EstTraps – updates the Acres or EstimatedTraps field of the selected features of
      the Edit Layer

     Update PPA/Reason – updates the PPA field of the selected features of the Edit Layer then
      updates the PPA Reason field

     Update Distance to AA – updates the Dist2AA field of the selected features of the Edit Layer



                                                                                                        5
       Update Geography Fields – updates the State, County, Quad fields of the selected features of
        the Edit Layer

Geometry Editing Tools
       Selected to Project Bounds – converts selected features of user-selected feature layer to a new
        Project Bounds feature

       Clip Selected to State – clips selected feature of the Edit Layer to the selected State border

Data Checking and Export Tools
       Check PPA Reasons for State – lists all PPAs that need to be addressed for the selected state

       Export State Data – exports allgrids, treatments to a file geodatabase, updates estimatedtraps
        for the allgrids feature class, creates estimatedtraps summary tables and acreage summary
        table

Summary Tools – These tools are run during the Export State Data process but can be run
individually

       Create EstTraps Summary

       Show estTraps Summary

       Create Acreage Summary

       Show Acreage Summary

Code Tools
       Re-set Editor Events – refreshes the Editor Events and sets the STS Customization value to true

       STS Customizations – turns on/off STS custom tools and functions




Editing Workflow
Overview
The general editing workflow for each state in the project:

    1. Create Project Bounds polygons based on the Decision Algorithm (DA) recommended areas –
       Action Area, Monitoring Areas.
    2. Create Delimit Grids and Treatment Blocks based on the DA Potential Problem Area (PPAs)
       recommendations.
                                                                                                          6
  3. Check that all PPAs in a state have been addressed.
  4. Export state planning data (allgrids and treatments) to a stand-alone geodatabase for backup
     purposes.
  5. Report state’s summary data – estimated traps by trap type and by project area, acreage by
     treatment type.

Detailed Notes

Create Project Bounds
  1. The new Selected to ProjectBounds tool on the STS drop-down menu should be used to create
     the polygons. This tool ensures that there are no gaps or overlaps between ProjectBounds
     polygons that can result from sloppy digitizing and/or a projected data frame. The tool takes the
     selected features from a user-selected feature layer, dissolves them, clips the resulting polygon
     to the state border and erases any areas that overlap existing ProjectBounds polygons.
  2. Setup for running the Selected to ProjectBounds tool:
         a. Set the layer from which features will be selected (usually quads or counties) to be the
              only selectable layer;
         b. Select features that cover the area to be assigned to the ProjectBounds layer;
         c. Make sure an Edit Session is active and the Target is set to ProjectBounds.
  3. Launch the tool.
  4. Choose the layer with selected features from the drop-down list.
  5. Assign Project, Gridtype, Traptype attributes for the ProjectBound polygon to be created.
  6. Repeat steps 2 through 5 for each ProjectBound in the state.
  7. Any edits to the ProjectBounds polygons using the sketch tool should include the following
     steps:
         a. Set the Snapping Environment so that ProjectBounds vertices are snappable;
         b. Set the appropriate snapping tolerance using the Snap Tolerance tool on the Editor
              toolbar (the tolerance may need to be changed if the scale at which edits are made is
              changed);
         c. Use the Reshape Feature Task from the Editor toolbar to draw the desired changes, or
              the Create New Feature Task to make a new feature;
         d. Check that there are no gaps or overlaps between the edit polygon and adjacent
              features.
   The EstimatedTraps field is updated any time the shape of a ProjectBound is changed and any
     time the Gridtype attribute is changed.
   The StateFIPS and Year fields are filled at the time the polygon is created.




                                                                                                     7
Create Delimit Grids and Treatment Blocks
  8. Map Navigation – Delimits and Treatments are usually drawn over PPAs, so the map is usually
      navigated by locating PPAs and then creating features. The easiest way to accomplish this is to:
          a. Open the PPAs attribute table
          b. Move the Reason Field next to the ID field
          c. Resize the table so that only those two fields are visible
          d. Sort the table on the ID field
          e. Optionally, set the Definition Query of the PPA layer to draw only one state’s PPAs –
               Left(ID,2) = ‘OH’
          f. Scroll through the table to locate the desired PPA
          g. Right-click the record box in the table and select Zoom To or Pan To
          h. Adjust the Map Scale to view the desired area
          i. Set Reference Scale of the Data Frame
  9. Create Delimit Grids – delimits can be created using three different tools
          a. Sketch Tool from Editor Toolbar
                      Draw outline of the delimit grid
          b. Rectangle Tool from Editor Toolbar
                      Click and Drag a rectangle to define the delimit grid extent
          c. Auto-Grid Tool from Auto-Grid Toolbar
                      Click the map where the center of the delimit grid should be
       Be sure that the Target on the Editor Toolbar is set to Delimits and the Task is set to Create
          New Feature.
       For the Sketch and Rectangle tools, after the sketch (or rectangle) is completed, the user is
          prompted for the Project, Gridtype, Traptype attribute values.
       For the Auto-Grid tool, the user sets the attribute values for Project, Gridtype, and Traptype
          fields by selecting the values from the drop-down lists on the Auto-Grid toolbar before
          clicking on the map with the Auto-Tool.
       The EstimatedTraps field is updated any time the shape of a Delimit Grid is changed and any
          time the Gridtype attribute is changed.
       The Quadcode, CountyFIPS, StateFIPS, Year fields are updated when a Delimit Grid is
          created.
       The Dist2AA (Distance to back of Action Area) is updated when the Delimit grid is created or
          the shape is changed.
       The PPA field is updated when the Delimit Grid is created – if the PPA associated with the
          new Delimit recommends Treatment, the user will be prompted to enter a reason for
          deviating from the DA’s recommendation. The reason value is stored in the PPA table.
       If there is no PPA intersecting the new Delimit, a new PPA will be created.
  10. Create Treatment Blocks – treatments can be created using two tools:
          a. Sketch Tool from Editor Toolbar, or
          b. Rectangle Tool from Editor Toolbar
                                                                                                     8
        Be sure the Task on the Editor Toolbar is set to Create New Feature.
        Treatments are based on subtypes, so be sure that you have selected the appropriate
         Treatment subtype (treatment type) in the Target box of the Editor Toolbar.
      After the sketch (or rectangle) is completed, the user is prompted for the Trtcode, Dosage,
         Lifestages attributes .
      The user is then prompted for the name of the block, the code suggests the name of the
         USGS Quad at the center of the new Treatment.
      The PPA field is updated when the Treatment is created – if the PPA associated with the new
         block recommends an action other than Treat, the user will be prompted to enter a reason
         for deviating from the DA’s recommendation. The reason value is stored in the PPA table.
      If there is no PPA intersecting the new Treatment, a new PPA will be created and the user
         will be prompted for a reason for deviating from the DA’s recommendation.
      The ID field is based on the PPA associated with the block and is filled when the block is
         created.
      The Rank field is filled after the PPA field is calculated and is based on the Priority value of
         the associated PPA.
      The Program field defaults to STS – it can be changed after the block is created through the
         Attribute Window on the Editor Toolbar or through the Treatment attribute table.
      The StateFIPS, Quadcode, CountyFIPS, and Year fields are filled when the Treatment is
         created.
      The Acres field is calculated whenever the Treatment block is created or has its shape
         altered.
      The TrtAcres field is filled when the block is created, the user is prompted to choose to fill it
         with the Acres field value, a user-defined value, or zero.
    The Scale Tool on the Editor Toolbar can be used to proportionally change the size of a Delimit
     or Treatment – Acres/EstTraps fields are updated automatically after the tool is used.
    The RotateTool on the Editor Toolbar can be used to rotate a Delimit or Treatment.

Check PPA Reasons for State item on the STS menu runs a model to locate any PPAs that have
not been addressed (Reason value of ‘Not Addressed’ for the PPA.

Export State Data item on the STS menu performs the following actions:
   11. Prompts user for the state abbreviation
   12. Creates a new file geodatabase in C:\GM_STS\Geodatabases\DataByState\ named
       <state>_RoadshowData_<date>_<time>
   13. Selects ProjectBounds and Delimits within the selected state, then performs an update
       operation to create the allgrids_<state> feature class
   14. Selects Treatments within the selected state and exports them to the treatments_<state>
       feature class
   15. Recalculates the EstimatedTraps field for the allgrids_<state> features
                                                                                                      9
   16. Creates summary tables for State Report
           a. EstTraps_byProject_<state>
           b. EstTraps_byTraptype_<state>
           c. AcreageSummary_<state>
   17. Displays the State Report Tables



State Report – individual tables
   18. The Create Estimated Traps Summary and Create Acreage Summary items on the STS menu
       launch tools to allow summary statistics to be run on any table and any field.
   19. The Show Estimated Traps Summary and Show Acreage Summary items on the STS menu will
       open all appropriately named tables (EstTraps/Acreage) in the Table of Contents.




                                                                                              10

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:17
posted:5/13/2010
language:English
pages:12
Lingjuan Ma Lingjuan Ma MS
About work for China Compulsory Certification. Some of the documents come from Internet, if you hold the copyright please contact me by huangcaijin@sohu.com