Docstoc

Routers

Document Sample
Routers Powered By Docstoc
					                        Routers
• A router is a computer
• Computers have four basic components:
  –   a CPU,
  –   memory,
  –   interfaces, and
  –   a bus
• The router is a computer that selects the
  best paths, and manages the switching of
  packets between two different networks
                                              1
Cisco Routers




                2
  Router - internal components
• RAM/DRAM
 – Stores routing tables, ARP cache, fast-
   switching cache, packet buffering (shared
   RAM), and packet hold queues.
 – also provides temporary and/or running
   memory for the router’s configuration file
   while the router is powered on.
 – RAM content is lost when you power down or
   restart.
                                            3
  Router - internal components
• NVRAM
 – non-volatile RAM
 – stores a router’s backup/start-up configuration
   file;
 – content remains when you power down or
   restart



                                                     4
  Router - internal components
• Flash
  – erasable, reprogrammable ROM
  – holds the operating system image and
    microcode
  – allows you to update software without
    removing and replacing chips on the processor
  – content remains when you power down or
    restart
  – multiple versions of IOS software can be stored
    in Flash memory                                5
  Router - internal components
• ROM
 – contains power-on diagnostics,
 – a bootstrap program, and
 – operating system software
 – software upgrades in ROM require replacing
   pluggable chips on the CPU


                                                6
   Router - internal components
• Interface
  – network connection through which packets
    enter and exit a router
  – it can be on the motherboard or on a separate
    interface module




                                                7
Routing




          8
     Router Configuration
• A router is made up of configurable
  components.
• A router has modes
  –examining,
  –maintaining, and
  –changing the components.

                                        9
         Router Configuration
• show commands are used for examination.
• You use cdp to show entries about
  neighbours.
• You access other routers by using telnet.
• You test network connectivity layer by
  layer.
• Testing commands include ping, trace, telnet,
  and debug
                                                  10
          Router Configuration
• A router can be configured from many locations:
    Upon initial installation, it is configured from the
     console terminal. The console terminal is a computer
     connected to the router through the console port.
    It can be connected via modem by using the
     auxiliary port.
    After it is installed on the network, it can be
     configured from Virtual Terminals 0 through 4.
• Files can also be downloaded from a TFTP server
  on the network
                                                       11
            Router Modes
• Whether accessed from the console or by a
  Telnet session through a TTY port, the router
  can be placed in several modes.
• Each mode provides different functions:
     – User EXEC mode
     – Privileged EXEC mode
     – Set-up mode
     – Global configuration mode
     – Other configuration modes
  – RXBOOT mode                               12
          Router Modes
 User EXEC mode
   A ―look-only‖ mode in which the user can view
    some information about the router, but cannot
    change anything.
 Privileged EXEC mode
   Supports the debugging and testing commands,
    detailed examination of the router, manipulation of
    configuration files, and access to configuration
    modes.

                                                          13
          Router Modes
 Set-up mode
   Presents an interactive prompted dialog at the
    console that helps the new user create a first-time
    basic configuration.
 Global configuration mode
  • Implements powerful one-line commands that
    perform simple configuration tasks.




                                                          14
            Router Modes
 Other configuration modes
   Provide more detailed multiple-line
    configurations.
 RXBOOT mode
  – A maintenance mode that can be used, among
    other things, to recover lost passwords.



                                                 15
 Router Status Commands
 show version
   Displays the configuration of the system
    hardware,
   the software version,
   the names and sources of configuration files,
    and
   the boot image.
 show processes
   Displays information about the active           16
    processes.
     Router Status Commands
 show protocols
   Displays the configured protocols.
   This command shows the status of all
    configured Layer 3 protocols.
 show mem
   Shows statistics about the router’s memory,
    including memory free pool statistics.


                                                  17
     Router Status Commands
 show stacks
   Monitors the stack use of processes and
    interrupt routines and displays the reason for
    the last system reboot.
 show buffers
   Provides statistics for the buffer pools on the
    router.
 show flash
   Shows information about the Flash memory          18
    device.
     Router Status Commands
 show running-config
   Displays the active configuration file.
 show startup-config
   Displays the backup configuration file.
 show interfaces
  – Displays statistics for all interfaces configured
    on the router.

                                                        19
  Cisco Discovery Protocol
           (CDP)
• CDP provides a single proprietary
  command that enables network
  administrators to access a summary of
  what the configurations look like on
  other directly connected routers.
• CDP runs over a data link layer connecting
  lower physical media and upper-network-
  layer protocols.
                                               20
                   CDP
• Because CDP operates at this level, CDP
  devices that support different network-layer
  protocols can learn about each other.
• CDP starts up automatically at boot up.
  CDP can then automatically discover
  neighbouring Cisco devices running CDP.


                                             21
                   CDP
• Discovered devices extend beyond those
  having TCP/IP.
• CDP discovers directly connected Cisco
  devices regardless of which Layer 3 and 4
  protocol suite they run.



                                              22
                            CDP
• CDP provides information about each CDP neighbour
  device. Values include the following:
       Device identifiers—For example, the router’s configured
        host name and domain name (if any)
       Address list—At least one address for SNMP, up to one
        address for each protocol supported
       Port identifier—Such as Ethernet 0, Ethernet 1, and Serial
        0
       Capabilities list—If, for example, the device acts as a source
        route bridge as well as a router
       Version—Information such as that provided by the local
        command show version
      • Platform—The device’s hardware platform; for example,
        Cisco 7000                                                   23
    Cisco Router Configuration
• We have seen
  – show and
  – cdp commands
• show startup-config - display the backup
  configuration file
• show running-config—display active
  configuration file.

                                             24
    Cisco Router Configuration
• erase startup-config - deletes the backup
  configuration file in NVRAM.
• reload - reloads the router, causing it to run
  through the entire configuration process.
• Setup - to enter setup mode from the
  privileged EXEC prompt.


                                               25
    Cisco Router Configuration
• configure terminal—Configures manually
  from the console terminal.
• copy tftp running-config—Loads
  configuration information from a network
  TFTP server.
• copy running-config startup-config—
  Stores the current configuration from RAM
  into NVRAM.
                                          26
   Cisco Router Configuration
• copy running-config tftp — Stores the
  current configuration from RAM on a
  network TFTP server.




                                          27
    Cisco Router Configuration
Router> enable
password:
Router# configure terminal
Router(config)# [configure mode command]
• e.g. interface, subinterface, controller, line,
  router etc.

                                                    28
    Cisco Router Configuration
• Specific configuration modes:
  – interface mode - for configuring interfaces
  – subinterface mode - for configuring multiple
    virtual interfaces on a single physical interface
  – line mode - for configuring the operation of a
    terminal line
  – router mode - for configuring an IP routing
    protocol
  – etc.
                                                        29
    Cisco Router Configuration
• Configuring router identification
Router# config term
Router(config)# hostname LABA
LABA#
ctrl-z : back to privileged exec mode
exit : back out one level

                                        30
   Cisco Router Configuration
• Message of the day banner
LABA(config)#banner motd # message #

• Interface description
LABA(config)#interface ethernet 0
LABA(config-if)#description my LAN, BG

                                         31
      Password configuration
• Console password
• Virtual terminal password
• Privileged exec password




                               32
         Console password
LABA(config)#line console 0
LABA(config-line)#login
LABA(config-line)#password cisco




                                   33
    Virtual Terminal password
LABA(config)#line vty 0 4
LABA(config-line)#login
LABA(config-line)#password cisco

• Enable Password
LABA(config)#enable password class
or prefer
LABA(config)#enable secret class     34
       Configuring interfaces
LABA(config)#int s 0
LABA(config-if)#clock rate 56000
• clk rate is set for DCEs
LABA(config-if)#bandwidth 56
• no clock rate removes clock rate
• shut down/no shut down

                                     35
  Configuring routing protocols
LABA(config)#router rip
LABA(config-router)#network 1.0.0.0
LABA(config-router)# network 2.0.0.0
LABA(config-router)#ctrl-z
LABA(config)#ctrl-z
LABA#show ip protocol
LABA#show ip route [routing table]
                                       36
  Configuring routing protocols
LABA>show ip interfaces
LABA#debug ip rip




                                  37
  Exercise - Configuring LABA
• Hostname:
Router>ena
password:
Router#config term
Router(config)#hostname lab-a



                                38
  Exercise - Configuring LABA
• Enable secret password - class
lab-a(config)#enable secret class




                                    39
  Exercise - Configuring LABA
• All appropriate interfaces with IP addresses
  and subnet masks
lab-a(config)#int s 0
lab-a(config-if)#ip address 201.100.11.1
  255.255.255.0
lab-a(config-if)#clockrate 56000
lab-a(config-if)#bandwidth 56
                                             40
  Exercise - Configuring LABA
lab-a(config)#int e 0
lab-a(config-if)#ip address 192.5.5.1
  255.255.255.0
lab-a(config-if)#bandwidth 56
lab-a(config)#int e 1
lab-a(config-if)#ip address 205.7.5.1
  255.255.255.0
lab-a(config-if)#bandwidth 56           41
  Exercise - Configuring LABA
• Configure rip
lab-a(config)#router rip
lab-a(config)#network 205.7.5.0
lab-a(config)# network 192.5.5.0
lab-a(config)# network 201.100.11.0



                                      42
  Exercise - Configuring LABA
• Console login password - cisco
lab-a(config)#line console 0
lab-a(config-line)#login
lab-a(config-line)#password cisco




                                    43
  Exercise - Configuring LABA
• Vty login password - cisco
lab-a(config)#line vty 0 4
lab-a(config-line)#login
lab-a(config-line)#password cisco




                                    44

				
DOCUMENT INFO