Mentor Graphics PCB Layout Tips - PDF by een19057

VIEWS: 45 PAGES: 17

									PCB Layout Tips                                                                                   1/17




Mentor Graphics: PCB Layout Tips
        - Prepared by Kityee Au-Yeung, last updated on October 1, 2004.




There are 5 steps in PCB layout design:
   1. Design Architect: schematic entry
   2. Librarian: PCB footprints, component geometry, catalog files creation
   3. Package: read in data from and create viewpoint for the schematic, create netlist
   4. Layout: PCB component placement and routing
   5. Fablink: generate manufacturing data and documentation for a PCB design


Useful tips:
               •   F2 = unselect
               •   Mentor user group email = pcb_sig@mentorug.org
               •   The free software GC-Prevue for viewing gerber files on windows can be
                   downloaded form www.graphicode.com
               •   DO NOT try to make copies of your design directories OUTSIDE of Mentor
                   environment (such as doing >cp –r mentor_dir copy_dir in unix). Pathnames
                   would be incorrect in the attribute files (I learned it the hard way)! Copy objects
                   ONLY in Design Manager.
               •   Back up often on CD.
PCB Layout Tips                                                                      2/17



Design Architect
   •   Create a directory with design or project name, such as “mentor_pacerv2”. This
       directory path is “\home\semester\2001Fall\kya\mentor_pacerv2”
   •   Schematic sheets are created using DESIGN ARCHITECT, they are kept in
       “\home\semester\2001Fall\kya\mentor_pacerv2\schematic\..”
   •   User-created logic symbols that are used in the schematic should be kept in one
       directory. I used “\home\semester\2001Fall\kya\mentor_pacerv2\kya_simlib\..”
   •   Each symbol MUST have “REF” and “COMP” properties assigned. For example
       when creating the symbol, assign REF = U? and COMP = MAX4635. When
       instantiating the symbol in a schematic, change REF to U7 and keep COMP
       unchanged.
   •   Each pin of a symbol should have PIN and PIN_NO properties assigned. For
       example PIN = IN2 and PIN_NO = 5.
   •   Be careful with power net names (for example: VCC, REG50, TEMP50,
       GROUND) defined in the schematic. Their names have to be exact in power net
       layer definition later.
   •   For certain nets, for example “power” or “high current” nets, it’s a good idea to
       define a “net_type” property for the nets, of value “power” or “high_current”.
       That way later on during PCB layout process, those nets can be easily identified
       and traced properly.
   •   Make a “test connector”. Choose a number of critical signals that would be tested
       often. Route them to a connector in the schematic, treat it like a component. The
       purpose of which is to provide an area of metal pads that you can test these
       signals with easily.
   •   To print out schematics: File > Export Graphics: Select “.eps” file format. Give
       the output file a pathname. Highlight rotate, select scaling “1X”. The scale value
       should show up as “-1”. Choose Monochrome and hit OK. This will result in a
       “eps” file with the defined pathname. I chose to print mine out in LaTEX as a
       figure, along with some editing and descriptions of the schematic.
PCB Layout Tips                                                                          3/17



Librarian
   •   To start LIBRARIAN:
               1. Double click the LIBRARIAN icon in DESIGN MANAGER
               2. Invoke LIBRARIAN “on a design”, select the design directory name
                  such as “mentor_pacerv2”
               3. This should open up the LIBRARIAN window

LIBRARIAN is used to create “geometries” for a PCB design…
   • First, create a “board geometry”:
              1. Geometries > Create Geometry > Board
              2. Board name = pacerboard; Default padstack = kyapad1; 2 signal layers
                  (top and bottom); board placement grid = 0.05; clearance = 0.01;
                  power nets = VCC and GROUND. (Note: the order of power net
                  definitions is important. Right now VCC is on Physical_2 and
                  GROUND is on Physical_3)
              3. This should open up an edit window. Create a) Board outline by Setup
                  > Edit layer. Select BOARD_OUTLINE.
              4. Also create b) Placement outline; and c) Routing Outline.
              5. Setup Board Clearances
              6. Check > Geometry > Active Geometry
              7. File > Save > to Design object > Geometries > Name = pacerboard
   • Next, create a “padstack”:
              1. Geometries > Create Geometry > Surface Pin
              2. Pin name = kyapad1; Single shape PAD, rectangular = 0.060 x 0.010;
                  Single shape SOLDER_MASK, rectangular = 0.065 x 0.015. No
                  PASTE_MASK or OTHER shapes. Click OK.
              3. Check > Geometry > Active Geometry
              4. File > Save > to Design object > Geometries > Name = kyapad1
              5. Create other “Surface Pin” pads if necessary, such as pads for 0402
                  resistors and other package size of capacitors.
   • Also, create footprint for a “component”:
              1. Geometries > Create Geometry > Component
              2. Component name = umax_10; Default padstack name = kyapad1;
                  Units in inches; Replace existing component if necessary; Enter
                  optional height and underside info; select include component in bill of
                  materials; Orientation all angle; Surface components; both surfaces.
                  Click OK
              3. This should open up an edit window. Create the component’s
                  footprint and add pin locations using the part’s spec sheets.
              4. Add silkscreen to outline the part’s shape. Add “1” to pin 1 and/or a
                  circle to specify the part’s orientation. (text height = 0.04, line width =
                  0.01, text width = 0.01).
              5. RMB > Attributes > Add Placement Outline > Both layers
              6. RMB > Attributes > Add Component Body Outline
              7. Check > Geometry > Active Geometry
PCB Layout Tips                                                                         4/17


                8. File > Save > to Design object > Geometries > Name = umax_10
                9. Repeat steps to create all necessary footprints
   •   In addition, create a “via” padstack as well:
                1. Geometries > Create Geometry > Thruhole Via
                2. Name = kyavia; drill size = 0.028, Single PAD shape circular 0.05 dia;
                    Single SIGNAL shape circular 0.05 dia; Single POWER shape circular
                    0.05 dia. No SOLDER MASK such that vias will be covered.
                3. Check > Geometry > Active Geometry
                4. File > Save > to Design object > Geometries > Name = kyavia
   •   After creating all required geometries:
                1. Check > Geometries > All
                2. File > Save > Design All
                3. File > Save > ASCII Geometries: All Geometries and replace existing
                    files in “Design Library” (or active library should be “design”).
                4. Geometries should be in “../kya/mentor_pacerv2/design_geom/”
   •   It’s a very good idea to create a component geometry as testpads:
                1. On your design, pick a number of signals that are critical in the testing
                    process. Make sure that they are routed to a “test connector” in the
                    schematic in Design Architect.
                2. Treat this “test connector” just like other components. Give it some
                    good size pads that you could probe or plug connector to. This would
                    make testing a lot easier than “poking” the pins of a chip.

LIBRARIAN is also used to create a “design catalog” for a PCB design. The purpose of
which is to make sure that all part numbers and mapping files are present for the next
design step. The following figure illustrates what a “design catalog” looks like (from
FIG11-3 of Using PCB Design Tools).




In LIBRARIAN
    • First, activate the “design catalog”:
               1. Catalogs > List Catalogs
PCB Layout Tips                                                                            5/17


               2. Highlight DESIGN => /homes/kya/mentor_pacerv2/design_maps
               3. Highlight CATALOG NAME “design”, click read to make it active
   •   Then, read in the “geometry library” (geometry meaning footprints):
               1. Geometries > List Geometry Libraries
               2. Locate /homes/kya/mentor_pacerv2/design_geom.
               3. Highlight GEOMETRY LIBRARY “design”, click read, view if
                   desired. Then close the window.
   •   Also, read in the “symbol library” (symbol meaning logic symbol in schematic):
               1. Symbols > List Symbol Libraries
               2. Symbols could be stored in /homes/kya/mentor_pacerv2/design_lib.
                   In which case, select that library and make it active.
               3. Since I defined my own “kya_simlib”, I need to link it to the
                   LIBRARIAN environment.
               4. Symbols > Add Other Library Link : type in the pathname
                   “\home\semester\2001Fall\kya\mentor_pacerv2\kya_simlib\..”
               5. Now Symbols > List Symbol Libraries > Other logic symbol libraries:
                   highlight my “kya_simlib”, click read and view if desired. Close.
   •   To create a part number in a catalog:
               1. Catalog > Create Part Number
               2. Part number = maxim 4635; Catalog name = design; Design directory;
                   Geometry = umax_10; mapping = leave blank. Click OK.
               3. This should bring up two windows: a MAP window on the left and a
                   GEOM window on the right.
               4. On the MAP window: RMB > Map Logic symbol
               5. Logic symbol name = MAX4635 (name used in Design Architect
                   symbol), Map symbol count = 1. Map symbol name = M1. Then OK.
               6. Now on the MAP window, PIN should show PIN property values,
                   PHY should show physical location of the pin, matching that of the
                   geometry definition.
               7. If PHY shows none, then you have to manually “map pins”:
                   RMB>Map Pins. Crosshair will show up on the MAP window first,
                   select a pin to be mapped. Cross hair will then show up on the GEOM
                   window, select the physical location of that pin. Repeat until all pins
                   are mapped.
               8. Finally, Check > Part Number > Active Part Number.
               9. Repeat until all part numbers are entered.
   •   To edit a part number:
               1. Catalog > List active Catalog
               2. View the part numbers in an active catalog.
               3. Select a part number to be edit, click on “Draw”

(I have trouble defining “Power pins” and assigning them as “Common pins”. I tried deleting the
power pins from logic pin definitions but it caused errors. PACKAGE didn’t like power pins.)

   •   Before exiting LIBRARIAN:
              1. Check > Catalogs.
PCB Layout Tips                                                                     6/17


                  2. Select Schematic and leave catalog name blank. OK. Catalog must
                     have a part number for each symbol.
                  3. Catalogs > Complete Catalog.
                  4. Check all boxes. OK.
                  5. It should say “Congratulations! The Design Catalog is complete.”
PCB Layout Tips                                                                           7/17



Package
   •   To start PACKAGE:
               1. Invoke PACKAGE from DESIGN MANAGER
               2. On a design, select the directory “mentor_pacerv2”
               3. Default viewpoint
   •   Once in PACKAGE:
               1. View > Root schematic sheet: to see the schematic
               2. Set up catalog search path by Setup > Catalog search path > Setup
                   search path. Then type in the path
                   “/home/semester/2001Fall/kya/mentor_pacerv2”
               3. Setup > Catalog library > Load catalog library
               4. Select “Specific Catalogs”; select “Design” Name = design; select
                   “check all part numbers found”. Click OK.
               5. Setup > Protect > Schematic
               6. Setup > Protect > Selected parts: in [package component summary
                   window], click on a schematic symbol to bring up the [package edit
                   symbol window]. Protect lines here. When finish, RMB > close
                   symbol to return to the [package component summary window].
               7. Setup > Build: swap gates NOT allowed.
               8. Check > Check Build
               9. In [package component summary window], RMB > Build
               10. No to restore unused pin net names. Use Setup build settings for all
                   gates. Click OK.
               11. It should have no errors or warnings, only notes. It should also say
                   Build done. No errors in assignment.
               12. Check > Geometries > All
               13. Save > Design Specify > Environment
               14. Save > Design Specify > Geometries
               15. Save > Design All
   •   To generate a bill of materials:
               1. Report > Bill of materials
               2. Save it as “..kya/dummy/pcb/mfg/bill_of_materials”
               3. Select both, view bill of materials. Then click OK.

NOTE: The following design objects should be updated after PACKAGE:
1. Catalogs; 2. Comps; 3. Gates; 4. Geoms; 5. Nets; 6. Pins; 7. Pkgs; 8. Pkginst; 9. Spares.
NOTE: Design hierarchy = Mentor > Company > Project > User> Design
PCB Layout Tips                                                                       8/17



Layout
   •   To start LAYOUT:
               1. Click on LAYOUT icon in DESIGN MANAGER
               2. Invoke LAYOUT on the design “mentor_pacerv2”
               3. This should bring up LAYOUT in another window. Notes should be
                  okay to ignore, but pay attention to warnings
               4. MGC > Setup > Session: choose “show palette”, then hit OK.
               5. This should bring up a palette on the right
               6. Setup > Display environment: choose “show scrolls”, then hit OK.
               7. Setup > Undo/Redo level: enter 5 for both
               8. It enables scroll bars on the layout window
   •   To change the view style of the traces:
               1. View > Change view style
               2. Choose “Outline” or “Filled” for Polygon/Trace style to see the exact
                  width/size of the traces
   •   To see “drill holes” on LAYOUT:
               1. View > Display Controls
               2. Select “Drill Holes – pins/vias”
   •   To view different layers of the board:
               1. View > layers
               2. Make the appropriate layers visible by clicking on them. A letter “V”
                  would show up next to the layer name
               3. Click on “All visible” if needed, then OK
               4. Shortcut = making a letter “L” with MMB
   •   To prepare for “component placement”:
               1. Setup Placement > Placement Grid
               2. A menu bar pops up on the lower left corner, set grid to 0.01 in. OK
               3. Setup > Automatic checking: make sure that it’s ON
   •   To add “placement area”:
               1. RMB > Placement > Add placement area > Add placement rule area
               2. Both side (or leave values as default), click OK.
               3. Click on the corners of the board to outline the shape of the placement
                  area
   •   To place component from a schematic sheet:
               1. View > Schematic sheet > Root Schematic sheet
               2. This should bring up the schematic on the right panel
               3. Make the schematic window active by clicking on it
               4. Setup > Schematic Highlighting: choose “components only”. OK
               5. Make the layout edit window active by clicking on it
               6. Setup Placement > Interactive placement > view connections: choose
                  “connections”. OK
               7. Make the schematic window active again
               8. RMB > Place Component: then choose on the schematic the
                  component to be placed on the board
PCB Layout Tips                                                                          9/17


              9. The outline of the selected component will show up on the layout edit
                  window. Move it to the desired location and click the LMB to place
                  component.
   •   To move a component to another location:
              1. Select the component.
              2. On the “Place” menu on the palette, click on move: choose the first
                  option
              3. Go back to the layout edit window and click on the new location for
                  the selected component.
   •   To move the component to the top/bottom of the board:
              1. Select the component
              2. In the Place menu on the palette, click on “Flip Comp”
   •   To “Protect/Unprotect” a component from being moved accidentally:
              1. Select the component
              2. Setup Placement > Protect components or Unprotect components
              3. A protected component should have a RED boundary
   •   To setup for “auto-routing”:
              1. Setup Routing > Routing Rules
              2. Trace Grid x=0.005, y=0.005. Allow “T-junctions” and “Diagonals”
              3. Setup Routing > Physical layers > Physical layers: to see the definition
                  of different layers
              4. Setup Routing > Layer Rules to disable/enable routing on a particular
                  layer if needed
              5. Setup Routing > Net Type Rules: select “default_net_type” and hit
                  Change
              6. Make sure that clearances set meet the manufacturer’s standard
              7. Under Setup Routing > Net Type Rules: you could also define the
                  requirements for the nets with “net_type” properties previously
                  identified in Design Architect. For example, you could change the
                  trace width to 0.01in for all nets with “net_type” property of “Power”.
              8. Select a via for AutoRouting in the middle panel
              9. Make sure that the available routing layers are highlighted. OK, then
                  close.
              10. Setup Routing > Physical layers > Via Rules
              11. Select a via to edit, highlight all the layers in the middle panel that the
                  selected via should span. Hit “Set/Del Rule”. Save and Close.
   •   To “AutoRoute”:
              1. RMB > AutoRouting > Start AutoRouter
              2. Breakout #passes = 1; Automatic #passes = 5; Pattern #passes = 5;
                  Manufacturing #passes = 5
              3. Click OK. Check the report for errors. Be very careful.
   •   To “Protect” or “Unprotect” traces:
              1. In the “Route” menu on the palette, select “protect routing” or
                  “unprotect routing”
              2. Protected traces should show up in RED
              3. To select all traces: RMB > Routing > Select > Select All Traces
PCB Layout Tips                                                                      10/17


   •   To route interactively:
                1. Setup Routing > Make sure that all angle routing is ON
               2. Setup > Make sure that Grid snap is OFF
               3. Setup > Snap to AutoRouter Grid is ON
               4. To show/hide connections need to be made: View > Show/Hide guides
               5. Configure the filter to select “guides”
               6. Click on the guide to be route.
               7. LMB, then MMB upstroke (this is the shortcut to bring up
                    RouteInteract): route traces by clicking the path.
                8. I use “Guide/ Void / Single_segment”
                9. Click LMB twice to add a via
                10. To finish a trace, use MMB, then MMB down stroke
   •   To setup “area fills”:
               1. Setup Routing > Area Fill
               2. Pick Octagon for Pad Isolation Shape. Choose “solid”. Do not keep
                    islands, but allow area fill merge.
                3. Click on “Thermal tie”
                4. For SMD and PIN: Thermal Tie/Preferred Tie-bars = 4, Minimum of
                    3. Preferred 0 and 90 degrees. Tie bar width = 0.01
                5. For VIA: choose “flood”. OK and OK.
   •   To fill and area:
                1. Select the layer to be edit. Make sure that the layer name shows up
                    accurately on the upper right box
               2. On the AreaFill Menu on the palette, click on “Add Fill”
               3. A bar will show up on the lower left corner. Use the crosshair to select
                    “the net” to make the area fill for. The net name should show up on
                    the bar.
               4. Click on the corners to make and area fill. You should be able to see
                    that appropriate connections are made with thermal tie bars.
   •   To add silkscreen layer for additional text:
               1. On right palette, select text
               2. Setup view > enter “edit layer name” as SILKSCREEN_1. Choose
                    view style.
               3. Setup text > Height – 0.04, Stroke width – 0.01, Line Spacing – 0.05.
               4. Click Prompt Text: enter text and click on the desired location.
               5. For some reason to select text, you have to set the select filter to be
                    “Text” and “Vertices”.
   •   After the board layout is complete:
               1. Check > Traces for the entire board.
               2. Once it passes check. Protect all traces (see instructions above).
   •   To save layout:
               1. File > Save > Design Specify > Traces.
               2. Exit and ready for FABLINK.
PCB Layout Tips                                                                       11/17


Important tips on layout and routing…

   •   For decoupling capacitor, place them on the opposite side of the chip. That way
       the distance between the decoupling cap, VCC and ground would be the shortest.

   •   For every chip, route power and ground first.


   •   For a PCB design where space is an issue, use blind and/or buried vias. They
       could be more expensive. Otherwise, stick with “through hole vias”.

   •   I was having problems seeing the connections to the power layers. The vias show
       up the same across all layers. One can select a via and use Report>Selected to see
       the net connection of that particular via. But that could be annoying.


   •   Instead of assigning power layers, one can assign those layers as “signal layers”.
       Once in the LAYOUT environment, manually “area fill” those “power layers”.

   •   That way, VCC and GROUND connection can be easily identified in LAYOUT.

   •   Green diamond indicates a routing/clearance problem.

   •   All power connections should have their own vias.

   •   After placement of all components, I recommend printing out a 1:1 board on
       paper and actually put your components on the footprints to check for errors. Do
       so BEFORE routing. See below for instructions on how to print out a 1:1 paper
       circuit board.
PCB Layout Tips                                                                     12/17



Fablink
   •   To start FABLINK:
               1. Click on FABLINK icon in the DESIGN MANAGER
               2. Invoke FABLINK on a design, select the design directory
                  “mentor_pacerv2”.
               3. It should open a window. Ignore warning about test points but pay
                  attention to other warnings.

There are basically three steps in FABLINK: a) create drilling data; b) create artwork
data and c) create milling data.

   •   To create drilling data:
              1. RMB > Drill > Change Drill Table > Fill Drill Table
              2. Leave as default, then OK. Close Report.
              3. RMB > Drill > Create Drill Data
              4. Drill file format = Excellon; Generate for Board; Drill Character Set =
                  ASCII; Mirror = OFF; Drill Hole Types = BOTH; Output Hole Types
                  = All. Click OK. Close Report.
              5. RMB > Drill > Simulate Drill Data
              6. Drill holes should appear in red. Show layers and vias on layout to
                  compare drill hole placements. Close window “AR$drill_plt_unplt”.
              7. Check > Drill table
              8. Report > Drill table: Include drill format yes; save and display report
                  yes; design yes. Replace file if needed. Then OK.
              9. Report should be in “/kya/mentor_pacerv2/pcb/mfg/drill_table_report”
              10. File > Save > Design Specify > Drill table.

   •   To create artwork data:
              1. RMB > Artwork > Change aperture table > fill aperture table
              2. Leave as default. Then OK
              3. RMB > Artwork > Change artwork format
              4. Change Plot offsets to manual, with x,y = (0,0). Click OK.
              5. Geometries > Open Geometries: select “Artwork Order” and open
                  “default_artwork_order”. Click OK.
              6. This opens up a blank edit window.
              7. Click on the window, then RMB > Change This Geometry.
              8. Add/Change Artwork layers to be generated. Remember that the name
                  of the layer has to be exact.
              9. When I add an artwork layer, I leave the values as default except that I
                  change “layer order number” and “layer name”. For example, the
                  artwork order for a double sided board with 2 power layers should be:
                         i.   SILKSCREEN_1
                        ii.   SOLDER_MASK_1
                       iii. SIGNAL_1, PAD_1
                       iv.    POWER_1
PCB Layout Tips                                                                           13/17


                             v.   POWER_2
                            vi.   SIGNAL_2, PAD_2
                           vii.   SOLDER_MASK_2
                          viii. SILKSCREEN_2
                  10. RMB > Artwork > Create Artwork Data
                  11. Select Gerber 274X file format; ASCII; Artwork Number all; output
                      all pins and vias; tear drops options; No to resize artwork and rescale.
                      Click OK
                  12. You can view artwork by: RMB > Artwork > Open artwork data
                  13. Report > Aperture table. Select “include artwork format” and “save
                      and display report”.
                  14. Report should be in
                      “/kya/mentor_pacerv2/pcb/mfg/aperture_table_report”
                  15. Check > Aperture table. Make sure that there’re no warnings.
                  16. File > Save > Design Specify: Aperture Table
                  17. File > Save > Artwork Data if you edit the artwork.

   •   To create milling data:
              1. Setup > Edit layer > Select Milling. Make sure that it shows up in the
                  box on the upper right corner.
              2. RMB > Milling > Change Tool
              3. Tool Diameter = 0.040; Tool compensation = right; Plunge at and
                  digitized point at nearest vertex.
              4. RMB > Milling > Start tool path
              5. Select the corners of the board with LMB. Finish going around the
                  board in counter-clockwise direction. Hit Cancel on bar when finish.
              6. RMB > Milling > Change_Milling _Table > Fill Milling Table
              7. RMB > Milling > Create_Milling_Data
              8. Default and OK
              9. Report > Milling table: Include milling format. Save and display
                  report, then hit OK
              10. Report should be in
                  “../kya/mentor_pacerv2/pcb/mfg/milling_table_report”
              11. Check > Milling table. Make sure that there’re no warnings.
              12. To view milling data: RMB > Milling > Open milling data
              13. Select appropriate file and click OK
              14. File > Save > Design Specify > Milling table
              15. File > Save > Milling data if you edit it.
   •   To generate “bill of materials”
              1. Report > Bill of Materials
              2. Leave value as default. View Bill of Materials. Click OK
   •   Before leaving FABLINK, be sure to File > Save > Design All
PCB Layout Tips                                                                      14/17



Steve’s PCB layout checklist (prior to a formal layout review meeting)…
1) Mentor design rule check: particularally important is to check for
unroutes. Then check for traces or vias that are too close. Off grid Vias
are not a concern for most board houses.

2) Make a paper circuit board (see more info below). Print it 1:1 at 1200 DPI on the laser
printer. Then hand place all the components. Make SURE that the
footprints match and that you can hand assemble the board as it is Placed.

3) Make a list in your notebook of all your clock lines. Make sure they
are routed efficiently and have an option for a series termination resistor.Use
Mentor Layout tool to HILIGHT these nets by name.

4) Do the same thing for Power and Ground nets. Make a list of names and
view them. Make sure all Power and Ground pins have short runs to the
planes and a decoupling cap close by.

5) Make a list of all your sensitive analog inputs. Make sure they don't
run near any high speed digital lines. consider routing them on inner
layers between analog reference planes.

6)Pull your design into GCPREVIEW or some other GERBER viewer that is
independant from mentor. Spend some time looking at the layout. Make
notes of things you would fix. Look especially at planes and cutouts.

7)Prepare a Board package for a quotation. Decide how many boards, How
thick is the board, how thisk is the copper, How fast you need them. In
addition, the Board house will need the following
files:

       1) Gerber files for all metal layers, All Soldermask, and silkscreen
       layers.
       2)Mechanical drawing of board showing outside dimensions, and at least
       one easily identifiable hole, and assembly instructions.
       3) a drill file. (from mentor)
PCB Layout Tips                                                                   15/17



To print out a paper circuit board using GC-Prevue:
   1. Open GC-Prevue, it’s a freeware that can be download from ww.graphicode.com
       (version v12.3.2)
   2. File > Import: then select all the artwork files (artwork_1 to artwork_10 for
       example) and also the “drill_plt_unplt” file. Hit Select.
   3. There should be green check marks next to the filenames in the “Import-Verify
       file information” window. It should also show up as “RS-274X “ file type. Hit
       OK.
   4. Leave “Import-Assign Tool Tables” window as default. Hit OK.
   5. It might say “Drill T1 was not found in table r001. Do you want to add to the
       table?” Hit Yes to All.
   6. File import Results should say 0 errors, 0 warnings and 0 messages. Hit OK.
   7. A window with all artwork layers will show up.
   8. On the toolbar, use “View all layers” and “Hide all layers”.
   9. On the left hand column, select a layer to view with LMB, then RMB to select
       “view” from the pop up menu.
   10. On the viewing window itself, RMB > Zoom to Extents to see the entire design.
   11. Never edit layer here.
   12. LMB > select area to “Zoom in”
   13. RMB > select area to “Zoom out”
   14. File > Print: Print “VISIBLE” layer. Check “Print all data in black”
   15. Check “Board 1:1” to make a paper circuit board. Otherwise, check “Fit to page”
       to print a bigger version to check traces and spacing.
   16. If necessary, check “Print separate pages for each physical layer”
   17. For bottom layer, check “print as a bottom view. Hit OK.
   18. In “Print” window, hp1: hit Properties.
   19. Under Paper/Quality: hit Advanced.
   20. For Graphic: print quality: select 600x600 dots per inch. OK to print.
PCB Layout Tips                                                                     16/17



To prepare a “Manufacturing drawing” for quotation…
   1.  Invoke Fablink from Design Manager
   2.  MGC > Setup > Session… Select Show Palette. Click OK
   3.  Geometries > Create Geometry > Drawing…
   4.  Choose ASCII Format; assign Drawing Name = assembly1; Units = inches
   5.  Click Navigator next to ASCII Geometry File: Click on the 4 arrow button to
       change to directory “$MGC_PCBPARTS”.
   6. Click on “geometries_drill_symbol_ascii”, then “sht_outline_a”. Then OK.
   7. It will make a boarder for the drawing.
   8. Geometries > Add Other Library link: Use Navigator to get to
       “$MGC_SYMBOL”, then go up 1 level using the up arrow. Select
       “drill_symbols” then OK. OK. It should add the library of the following link—
       “/home/franklin/mentorpcb2001/ae_kendall/geometries_drill_symbol/geometries/
       pcb_geoms/drill_symbols”
   9. Next go to Geometries > list Geometry Libraries: Click on Other Geometry
       Libraries, highlight and read the library. View them, it should have 8 geometry
       files. Highlight all drill symbols from “drillsymb1” through “drillsymb8”, make
       sure that all of them are read.
   10. On the Board geometry itself (not the drawing geometry), click on Drill on the
       palette. Setup Drill > Drill Table fill automatically. Then OK.
   11. Click on Create drill data, choose Excellon, default then OK.
   12. Click on Create drill schedule. Default then OK. A “drill_schedule _master”
       should pop up. Check drill size and drill count. Close the window.
   13. Back to the drawing window. Click on “ADD DRL SCH” on the Drawing
       palette.
   14. Select “drill_schedule_master” and drag it to boarder area.
   15. Click on “ADD BOARD”, a board outline should show up.
   16. Click on “ON/OFF VIEW DRL SYMBOLS”, all drill holes should show up.
   17. Click on “TEXT” on the palette, then click on “EDIT LAYER”
   18. Choose to edit the “DRAWING” layer. The word “DRAWING” should appear
       on the upper right corner.
   19. Click on “Add text Interactive”, then on the boarder area, enter your text.
   20. Typical information to be included as text in an assembly file –
           a. Stackup information: describe each artwork layer, for example: artwork1 =
                top silkscreen, artwork2 = top soldermask, artwork3 = top metal…
           b. Contact information: name of project, name, phone number, email, date…
           c. Material information: thickness of the copper layer…
           d. Other information: board thickness, number of boards needed and the
                desired completion of fabrication date.
   21. Also have to provide dimensions of the board –
           a. Board outline dimension (vertical and horizontal)
           b. Coordinates of the origin, and that of one of the holes on the board
   22. To enter Board outline dimension info, click on the Dimension button –
           a. Click either “DIM VERTICAL” or “DIM HORZNTL”
           b. Click on the 2 endpoints of the length that you want to specify one by one.
PCB Layout Tips                                                                      17/17


          c. Then click on the 3rd location to specify where you want to put the number
   23. To enter coordinates –
          a. First identify an origin, such as the lower left corner of the board.
          b. Then click on the “Shapes” button, click on “Measure”
          c. First click on the origin precisely, then click on the center of the selected
              hole.
          d. The (x,y) coordinate will show up on the bottom. Write it down.
          e. Click on Dimension > Add Pointer
          f. Enter text “Origin (0,0)”. Click OK. Then, click on the origin. Drag to
              draw lines for the pointer. Double click to finish.
          g. Repeat to specify the coordinate for the selected hole.
          h. See figure for an example of a manufacturing drawing




                  Figure: A sample manufacturing drawing

								
To top