Documents
Resources
Learning Center
Upload
Plans & pricing Sign in
Sign Out

faq

VIEWS: 22 PAGES: 4

  • pg 1
									                                  SPSS 11.5 FAQs
Question:
I have just installed SPSS 11.5 onto my PC and I do not see it on the Start Programs Menu. I see
SPSS 9.0 for Windows and expected to see SPSS 11.5 next to it. What went wrong?


Answer:
Although previous versions of SPSS for Windows were placed on the main menu of Start->Programs,
SPSS 11.5 for Windows is added as a program group called SPSS for Windows. You may be used to
seeing both SPSS 9.0 for Windows and SPSS 9.0 Production Facility (or previous versions) on the
Start->Programs menu and not notice that SPSS for Windows has been added to the section of the
menu which lists program groups, which are indicated by an arrow to the right of the program group
name on the menu. Move your cursor to SPSS for Windows on the Start Program menu and you will
see a submenu appear which includes SPSS 11.5 for Windows, SPSS 11.5 Production Facility and, if
you've installed the Maps module, SPSS Maps Geodictionary Manager and SPSS Maps Geoset
Manager.



Question:
On the SPSS Service Login Screen, I put a check in the checkbox for the distributed mode service I
wish to launch. But when I launch, another service is chosen. What is wrong?


Answer:
The highlighted option (not the checked option) is the option that is launched from this screen.
Highlight the service option you wish to run for distributed mode.



Question:
When I try to log into distributed mode through the SPSS Server Login Screen upon launch, I receive
the error message: "The specified remote server was not found". What could be wrong? How do I fix
it?


Answer:
One of the following is likely to be causing this problem:

    1) SPSS Server was not installed on the machine you chose in the screen. The solution is to
        install it.
    2) The service spsssrvr.exe is not running on the Service machine. Reboot the Service machine,
        or explicitly launch the service through Control/Alt/Delete ->Task Manager -> Processes
        window.
    3) An inappropriate license code was used to install SPSS Server. Make certain that you installed
        using a Service license code.
    4) The specified Service server does not exist on the network, or has been misspelled.
    5) You do not have permission to log on to that server.



Question:
I want to use SPSS 11.5 in distributed mode, but I want a thin client (few to no files installed on my
client machine). How do I do this?
Answer:
You will need the appropriate license codes from Customer Service or Sales. First, install SPSS to a
file server, using a site license or network license code. Second, from your client, run
\spss\setup\setup.exe off this file server (UNC is preferable to driver mapping, but either naming
convention is acceptable). Third, install SPSS Service to another server (or perhaps to the original file
server, under a different directory). By linking to the SPSS Service server, you will be able to run in
distributed mode. The \SPSS directory will be on the first file server. The \SPSSServer directory will
be on the second file server. Neither directory will be on the client.



Question:
I'm running distributed mode in SPSS 11 for Windows and I've accessed the File->Open->Data dialog
box. The dialog shows all the drives and directories of the server, not the client I'm working on.
Subsequently, if I access the File->Save/Save As dialog box I seem to have write permission
anywhere on the server disregarding any share permissions that have been established. How does
security work while logged in distributed mode?


Answer:
Data files are processed by the SPSS server. SPSS 11.5 for Windows offers no built-in security
mechanisms other than what's provided by the operating system on the client and server machines.
The application that's accessing the file system is the Server application and it has access to all
locations on the computer where it is running. Permissions do work if applied to an NTFS volume. If
one wants to create a read-only directory for data files on the SPSS Server computer, it can be
accomplished so long as that directory is on an NTFS volume. Permissions also work if applied to a
Share name that is not on the server. If one wants to create a read-only directory for data files on
another computer on the network, this can be accomplished by setting permissions for the Share
name and SPSS Server will honor them.



Question:
I am running multiple SPSS sessions at one machine. Whenever I make changes to one session
(through the Edit -> Options menu, or customized toolbars and menus), these changes seem to bleed
through into my other sessions, sometimes with catastrophic results. What is happening?


Answer:
Though you can run multiple SPSS sessions on one machine/workstation, they will all share the same
SPSS for Windows 11.5 keys in the Windows Registry. The changes mentioned in the question
above all alter the Windows Registry, and so change your settings for _all_ currently open SPSS
sessions. There is little you can do here, except 1) avoid making changes to the Windows Registry,
or, 2) make changes that will be compatible across all sessions.



Question:
Are there any standards for choosing local mode or distributed mode when running SPSS 11.5?


Answer:
Every SPSS user has the ability to run SPSS in local mode. Those sites purchasing SPSS servers
can also choose to run in distributed mode. Here are some guidelines for selecting between the two
modes:

You must run SPSS in local mode when:
-- Your data is stored on a local drive that cannot be shared across the network.
-- You are not connected to the network, such as on a notebook computer.
-- No SPSS servers are available on the network or the available servers do not have the SPSS
options you require.

You should consider running in local mode when:
-- Your data is small, say 0-2 MB in size, and is visible from your Windows PC in My Computer or
Network Neighborhood, and
-- When your computation runs acceptably fast on your desktop Windows PC.

You must run SPSS in distributed mode when:
-- Your desktop PC has insufficient memory, virtual memory, or temporary disk space to run your
analysis, or
-- Your Windows PC does not have the required database access software to communicate with the
database.
-- Your network administrator does not permit you to download large data tables to your Windows PC.

You should consider running in distributed mode when:
-- Your data is large and stored in a commercial database supported by the Data Direct technology.
Your computation runs too slow on your Windows PC and the machine running your SPSS server
machine is significantly more powerful.



Question:
After installing the SPSS Data Connectivity Pack, I noticed there was no Access listed with set of
drivers that Data Direct installs. Is it included with the Data Connectivity Pack?


Answer:
There is no Access driver installed with the drivers we get from Data Direct . However, on the CD-
ROM there is a directory called ms_odbc and it contains the Microsoft Data Access Pack. The name
of the file that needs to be run is called DATAACC.EXE. This needs to be installed on the machine
that is processing the data.



Question:
I have installed SPSS 11.5 and would like to use the Data Direct SequeLink Technologies that are
provided on the SPSS 11.5 CD ROM. I understand there are two parts to the software, the SequeLink
Client and the SequeLink Server. However, I am not sure where each component should be installed.
How do I set up the SequeLink client and server so that I can it on my local machine?


Answer:
The answer to this question is dependent on your installation of SPSS 11.5. There are three
components of SPSS 11.5. They are the client ( where the files necessary to run SPSS 11.5 are
installed), the Analytical Server (where the SPSS 11.5 Server side is installed) and the Data Server
(were the database is installed and data is stored). There are two possible ways to run SPSS 11.5,
Local Mode and Distributed Mode. When in Local Mode, all files necessary for running SPSS 11.5
are located on your hard drive and you will be connecting to the Data Server over the network without
the use of the Analytical Server. When in Distributed Mode, SPSS 11.5 is also installed on your local
computer, but processes are run from the Analytical Server. In this case, you will be connecting to the
Data Sever using the Analytical Server. You have the option of Local Mode or Distributed Mode when
launching a session of SPSS 11.5.

If you are using SPSS 11.5 in Local Mode, the SequeLink Client should be installed to your client and
the SequeLink Server should be installed to the Data Sever. If you are using SPSS 11.5 in Distributed
Mode, SequeLink client must be installed to the Analytical Server and the SequeLink Server must be
installed to the Data Server. Note, that if you are switching between the Local and Distributed Mode
from the same client machine, then install the SequeLink Client on both the client and the Analytical
Server. The SequeLink Server will remain on the Data Server.



Question:
I have created a map using the Map option, and would like to save it as a Geoset. SPSS creates
many temporary files, but which files are necessary when saving the constructed IMAP as a Geoset?

Answer:
There are five essential files that SPSS will need when saving the created MAP as a Geoset. The
following is a list of the five files, by extension, and their function:

*.tab - Describes the structure of a table. The .tab file is a text file, which the user can view or edit in
any text editor.

*.map -This file describes the graphic objects

*.dat- (or .dbf, .mdb) - This file contains the tabular data. The extension will differ based on the origin
of the file

*.ind - The index file allows the .tab file to have map objects, such as address, city or state

*.id - This is a cross reference file that links the data with the objects

								
To top