Trouble Shooting Guide

Document Sample
Trouble Shooting Guide Powered By Docstoc
					Trouble-Shooting Guide



   LifeMatch Product Line
                                                                   550 West Avenue
                                                                Stamford, CT 06902
                                           Phone (888) 329-0255, Fax (203) 328-9598




Table of Contents
A.      Molecular Lab Set-up to Run LifeMatch

     1. Work Areas

     2. Equipment

B.      DNA Assay

     1. Sample Types

     2. DNA Isolation

     3. Amplification

     4. Hybridization

C.      Antibody Assay

     1. Sample Types

     2. Sample Prep

     3. Common Assay Problems

D.      Luminex

     1. Calibration

     2. Maintenance

     3. QC


E.      Software

     1. Luminex Software

     2. LifeMatch Software




Original date: October 2004                                                      2
Revision date: March 2006
LC938.0
                                                                                550 West Avenue
                                                                             Stamford, CT 06902
                                                        Phone (888) 329-0255, Fax (203) 328-9598



                                                                      Return to Table of Contents


A. Molecular Lab Set-up to Run LifeMatch

   1. Work Areas:

       Three separate work areas are ideal:
              Pre-PCR
              Amplification
              Detection

       If the above is not possible:
               Use a laminar flow hood to isolate DNA and set up the PCR reaction. In this
               same area or room have the thermal cyclers for amplification.
               Use a separate post-PCR room for the hybridization step.

   2. Equipment:

       Dedicated equipment for each area (to eliminate/reduce the possibility of
       contamination):
               Rainin or Pipetman single channel pipettes 10ul, 20ul, 200ul and 1000ul capacity
               (Rainin or Fisher)
               Rainin or Pipetman multi channel pipettes 50ul, 200ul and 1000ul capacity
               (Rainin or Fisher)
               Vortex (Fisher or PGC Scientific)
               Mini centrifuge for quick spins (Fisher or PGC Scientific)
               Timers
               Thermometers
               Heat blocks
               Freezer and refrigerator
               15 and 50 ml conical centrifuge tubes
               1.5 and 0.5ml eppendorf tubes
               PCR tubes and caps
               Serological pipettes 1ml, 5ml and 10 ml


       Equipment unique to specific areas:
             Isolation/Pre-PCR
                      Hood
                      Eppendorf centrifuge
                      Additional equipment for isolation will depend on the methodology
                      chosen (Qiagen/Genovision, Gentra or home brew)
             Thermal cycler (Perkin Elmer or MJ)
             Post PCR
                      Power Supply (Fisher or PGC Scientific)
                      Electrophoresis equipment (Fisher or PGC Scientific)
                      UV Transilluminator (Fisher or PGC Scientific)
                      Sonicator
                      Luminex Instrument

Original date: October 2004                                                                    3
Revision date: March 2006
LC938.0
                                                                                   550 West Avenue
                                                                                Stamford, CT 06902
                                                           Phone (888) 329-0255, Fax (203) 328-9598

                                                                          Return to Table of Contents
B. DNA Assay

      1. Sample types:

                ACD vacutainer tubes (yellow top)
                EDTA vacutainer tubes (purple top)
                Frozen cells
                Frozen cord bloods
                Buffy coats
                Buccal swabs (only those collected with a brush)
      Note: Heparin tubes (green top) can not be used. Heparin is a PCR inhibitor.

      2. DNA Isolation:

                Column Extraction:
                Qiagen 96 DNA Blood Kit starting with 200ul sample (whole blood) eluted with
                200ul AE buffer from healthy individuals generally yields 4ug DNA at a
                concentration of 20ng/ul. This type of sample needs no further dilution prior to
                use in the LifeMatch Product following the requirement for 200ng DNA for the
                reaction.

                Magnetic Bead:
                MagAttract system starting with 200ul sample (whole blood) eluted in 200ul from
                healthy individuals generally yields slightly higher concentrations of DNA and is
                of higher quality (cleaner, fewer inhibitors). These samples are typically in the
                range of 9ug DNA at a concentration of 45ng/ul. This type of sample needs no
                further dilution prior to use in the LifeMatch Product following the requirement
                for 200ng DNA for the reaction.

Note: If either of the above two methodologies are applied to whole blood dried on a stain card
or buffy coats then the final amount of DNA and concentration will be significantly different. Stain
cards will be less (~1.5-7.5 ng/ul) and buffy coats will be more (~50 – 150 ng/ul). This should
be taken into consideration along with the requirements of the LifeMatch assay of 200ng per
reaction.
        It is also important to remember to follow the product insert for the DNA isolation
method of choice. For example, when using the GenoM6, the column should not be overloaded
with a large amount of buffy coat. The proper amount of starting material should be loaded
followed by the appropriate elution.

                Flexigene DNA system or any salting out/precipitating DNA extraction
                system:
                Typically these systems work with buffy coats (concentrated population of
                nucleated cells) and allow for varying volumes of starting sample. They require
                that the final pellet be re-suspended in minimum volume and that prior to use,
                the user needs to be sure that the DNA is completely in solution and the solution
                is uniform. These systems typically yield significantly larger amounts of DNA (1
                – 5 mg) and if re-suspended in 200 ul, the concentration range is 5000 – 10,000
                ng/ul. Therefore, it is essential that the user determine how much DNA is in their
                sample. It is recommended that the user run a yield gel against known standards
                to get an estimate or do an OD reading and calculate the concentration.
Original date: October 2004                                                                        4
Revision date: March 2006
LC938.0
                                                                                550 West Avenue
                                                                             Stamford, CT 06902
                                                        Phone (888) 329-0255, Fax (203) 328-9598

                                                                       Return to Table of Contents

                       Avoid over drying the DNA pellet, because if the pellet is over dried, it
                       will take longer to go into solution.
                       To dissolve the DNA one can incubate the samples over night at 37ºC or
                       room temperature, or for a couple of hours (1.5 to 2 hours) at 65ºC.

       The DNA is not in solution if:
             There is any type of texture to the solution (stringy appearance) when pipetting;
             Example – when tip is lifted out of the sample, a “string” of the sample comes
             along
             OD (Optical Density) readings on a sample change over time
             There is a pellet or string at the bottom of the tube

       Taking absorbance readings:
           Whole blood, buccal swab:
               Make a dilution of the sample (example 1:50)
               Allow dilution to incubate at room temperature overnight or at 65ºC for 1.5–2
               hours before taking a reading.
               Prior to taking the reading, mix the diluted sample well and carefully dispense
               into a quartz cuvette, making sure there are no air bubbles.
                        Readings should include 260, 280 and 320 nm (320 should be very close
                        to zero).
                        It is recommended to take a couple of readings and then calculate an
                        average concentration.
           Buffy coat, cell cultures, or tissue:
               Make a dilution of the sample (example 1:100).
Note: If the DNA sample is of high concentration, heat the sample at 37 ºC for 30 minutes to an
hour to ensure the sample is in solution before a dilution is made.
               Allow dilution to incubate at room temperature overnight or at 65ºC for 1.5–2
               hours before taking a reading.
               Prior to taking the reading, mix the diluted sample well and carefully dispense
               into a quartz cuvette, making sure there are no air bubbles.
                        Readings should include 260, 280 and 320 nm (320 should be very close
                        to zero).
                        It is recommended to take a couple of readings and then calculate an
                        average concentration.

   3. Amplification:

               Warm and thoroughly vortex all reagents (except Taq) before use
                     Standard PCR reaction volume is 50uL

                                      50 ul PCR Rxn
                                     Master Mix 15 uL
                                        Taq 0.5uL
                                  DNA sample (~200ng) uL
                                    Total volume 50 uL*
                *Adjust reaction by adding the appropriate amount of water to
                          bring the reaction volume to either 50 uL.


Original date: October 2004                                                                     5
Revision date: March 2006
LC938.0
                                                                                   550 West Avenue
                                                                                Stamford, CT 06902
                                                           Phone (888) 329-0255, Fax (203) 328-9598

                                                                          Return to Table of Contents

                If a sample is very concentrated it is recommended to make a dilution
                of the sample for use in LifeMatch rather than pipetting very small volumes.
                If a sample contains a pellet or string of DNA that is visible, first attempt to get
                the DNA into solution by heating and leaving at room temperature over night. If
                the DNA still does not go into solution then pipette from the top or middle of the
                tube and avoid the pellet or string of DNA. Keep in mind that results may be less
               than ideal. A new extraction should be done if the DNA does not go into solution.
                When setting up the PCR reaction, pipette the DNA into the PCR tubes first.
                Then add your master mix. When making your master mix always add the water
                first, master mix second, and Taq last. Thoroughly vortex the master mix before
                adding the Taq. Once the Taq is added, vortex lightly or invert the tube before
                adding to the DNA. Use a PCR capping tool to ensure caps are on tightly.

       Recommended cyclers:
            MJ
            Perkin Elmer (Must use retainer tray: Applied Biosystems #403081)
            Hybaid Express (Only use with one of the tubes recommended below)
            Eppendorf


       Recommended PCR reaction tubes:
            Tubes:
                   Corning: VWR #29442-354
                   AbGene/Marsh: AB-0451
                   Applied Biosystems: 8-strip reaction tubes part #N801-0580, 8 strip
                   format product #N801-0535
                   Eppendorf: VWR #12000-094           NOTE: Only to be used with
                       Eppendorf cycler

   4. Hybridization:

               Check PCR tubes for signs of evaporation. All tubes should be at the same level
               and caps should be on tightly.
               Warm and sonicate beads
               When cutting the Costar plate, leave one empty row on both sides of the
               samples. This will ensure that the seal will fully cover the samples and no
               evaporation will occur.
               When pipetting beads, wipe side of tip as tip is removed from vial. This will
               prevent pipetting 15uL plus a large drop on the tip.
               Prepare dilution solution/PE mixture during the 45 minute hybridization. Keep
               the solution protected from light.
               Add dilution solution/PE as soon as the cycler reaches the 56 degree forever
               step. This step is very critical and should not take longer than 5 minutes.

       Recommended hybridization products:
            CoStar 96 well plates: VWR #29444-000
            CoStar Polyethylene Sealing Tape: VWR #29443-338
            Pel-Freez Heat Equalizing Block: #90000-1AW
            Sonicator


Original date: October 2004                                                                        6
Revision date: March 2006
LC938.0
                                                                                 550 West Avenue
                                                                              Stamford, CT 06902
                                                         Phone (888) 329-0255, Fax (203) 328-9598

                                                                        Return to Table of Contents


C. Antibody Assay

   1. Sample Types:
               ACD vacutainer tubes (yellow top)
               No preservative/anticoagulant – Red top

   2. Sample Preparation:
               Prior to starting, make sure the serum samples are well mixed and there
               is no debris or fibrous material in the sample. If there is, spin the sample for 30
               seconds at 10,000g and work with the supernatant.

   3. Common Assay Problems:
               High background/Low Background:
                      Perform careful washes:
                          1. Verify that even pressure is applied to both sides of the plate
                             when placed on the manifold. The wash buffer should aspirate
                             at a steady rate (not too fast, not too slow).
                          2. When all the liquid has been removed, remove the plate from
                             the manifold and blot the bottom of the plate on an absorbent
                             material.
                   Note: Incomplete washes results in nonspecific signal or can inhibit the
                   ability of the conjugate to bind to the sensitized beads causing false
                   negatives)
            Bead Failures:
                     Check for liquid on the XY platform.
                          1. If liquid is present: Reset probe height ensuring plate is not
                               being touched as the probe goes down.
                          2. If liquid is present, but probe height seems ok, check for
                               warping of the filter plate. Plate will often have slightly curved
                               edges resulting in a punctured membrane.
                     Verify vacuum pressure is not set too high causing beads to be
                     imbedded in plate.
                     Be careful when pipetting so as not to puncture filter
                     Blot the filter plate after each wash. The liquid out of the nipples in the
                     bottom of the plate can serve as a wick and draw the liquid out of the
                     plate.
            Aspirating problem
                     Cover any unused wells with tape to improve vacuum seal.
                     Verify that even pressure is applied to both sides of the plate when
                     placed on the manifold. The wash buffer should aspirate at a steady
                     rate (not too fast, not too slow).
       Recommended Products:
            Millipore Filter Plates: Millipore #MSVBN1210
            CoStar Thermowell™ Sealers (aluminum): VWR #29445-080
            Omega BioTek E-Z 96 Vacuum Manifold: Vac-01




Original date: October 2004                                                                      7
Revision date: March 2006
LC938.0
                                                                                 550 West Avenue
                                                                              Stamford, CT 06902
                                                         Phone (888) 329-0255, Fax (203) 328-9598


                                                                        Return to Table of Contents


D. Luminex

   1. Calibration:
       Calibration should be performed for any one of the following reasons:
               Prior to every run
               If the facility is a 24/7 operation then the instrument needs to be calibrated
               every 8 hours if it is being run in the different shifts
               If the instrument has been moved.
               If the instrument has been repaired.
               If the temperature is out of range
       To ensure a successful Calibration:
               Do several primes to be sure that the system is cleared of all air pockets.
               Make sure that the cal and con beads are well mixed (single bead suspension).
               Use 4 drops of well-mixed beads, 3 will be too little and the calibration may fail.
               Follow the calibration with several primes to clear the cal and con beads as well
               as eliminate any air bubbles. (Avoids having the first sample fail.)
   2. Maintenance:
               When setting an instrument up in a lab keep it out of direct ventilation where the
               temperature will fluctuate.
               Avoid moving the instrument so as not to misalign lasers.
               When setting up an instrument allow easy access to the back of the instrument
               for maintenance purposes.
               Use the check off sheet supplied in the Luminex manual to document proper
               start up and shut down procedures.
               Visually check the instrument before each use.
               Keep the exterior and area around the instrument clean and dust free.
               Clean the sample probe monthly if running DNA only; weekly if running antibody.
               Replace all the filters and the Teflon seal of the syringe every 6 months.
               Change the sheath fluid filter annually.
   3. QC:
               Daily maintenance (no parts required-See Section F: Luminex Maintenance )
               Weekly inspection (visual check- See Section F: Luminex Maintenance )
               Monthly maintenance (no parts required- See Section F: Luminex Maintenance )
               Six month
                        The end user can do the six-month and yearly maintenance. Parts
                        required are listed below. Warranties will not be affected by performing
                        these routine maintenance checks and replacements.
               Yearly maintenance requires replacement of various parts. Parts required are
               listed below.
                        It is also recommended to schedule an annual PM with Luminex.

       Note: There are two ways an end user can void their warranty: 1) by removal of the
       outer cover of the Fluoroanalyzer or 2) by using a sheath fluid other than Luminex’s
       sheath fluid. Replacement of the below parts will not void a warranty or service
       agreement.




Original date: October 2004                                                                      8
Revision date: March 2006
LC938.0
                                                                                550 West Avenue
                                                                             Stamford, CT 06902
                                                        Phone (888) 329-0255, Fax (203) 328-9598

                                                                      Return to Table of Contents


Six-Month Maintenance:
        Part Name                 Luminex        Tepnel        Luminex Price             Action
                                   Part #      Lifecodes
                                                 Part #
   Air Filter, Base, Hepa        CN-0001-01    CN-0001-01           $74.55             Replace or
                                                                                         Clean
 Air Filter, Base [bottom of     CN-0002-01    CN-0002-01           $80.76             Replace or
           Analyzer]                                                                     Clean
    Air Filter, Intake (XY       CN-0027-01    CN-0027-01           $64.39             Replace or
           Platform]                                                                     Clean
 Syringe Seal [set of four]      CN-0014-01    CN-0014-01          $113.34              Replace

Yearly Maintenance:
        Part Name                 Luminex        Tepnel        Luminex Price             Action
                                   Part #      Lifecodes
                                                 Part #
  Sheath filter with quick       CN-0010-01    CN-0010-01          $107.94              Replace
        disconnect
 Sheath filter without quick     CN-0028-01    CN-0028-01          $74.93               Replace
        disconnect


Suggested Spare Parts:
       Part Name               Luminex Part     Tepnel        Luminex Price               Action
                                    #         Lifecodes
                                                Part #
 2 Amp Fuse [set of 10]         CN-0019-01    CN-0019-01           $65.65            As needed
       3 Amp Fuse               CN-0051-01    CN-0051-01           $60.90            As needed
Long Probe for XYPlatform       CN-0007-01    CN-0007-01          $176.52            As needed
  *Sheath Supply Bottle         CN-0011-01    CN-0011-01          $249.36            As needed
      *Waste Bottle             CN-0012-01    CN-0012-01          $220.95            As needed
    Syringe with seal           CN-0013-01    CN-0013-01          $186.81            As needed

*The sheath and waste bottle may weaken over time due to the pressure changes and bleach in
the waste. It is always a good idea to loosen the sheath cap at the end of the day and empty
the   waste     each    day.      This    could    increase  the    life   of   the   bottles.




Original date: October 2004                                                                    9
Revision date: March 2006
LC938.0
                                                                                 550 West Avenue
                                                                              Stamford, CT 06902
                                                         Phone (888) 329-0255, Fax (203) 328-9598

                                                                        Return to Table of Contents


E. Software:

   1. Luminex Software

   Run stopped before complete; no Output csv file
           For versions before 2.3, re-export the batch so new Output.csv can be found in My
           Batches folder
           For version 2.3, go to File/Run Incomplete Batch. The batch will then begin where it
           was stopped. Two csv files will be created: 1 containing the data prior to the
           interruption and 1 containing all the data both before and after the interruption.

    Template won’t import into Luminex
           Verify the idt file is being imported; not the exp file
           Some systems can take up to 20 minutes so be patient

    Override laser warm-up
           Hold [Ctrl + Alt] and click in the boxed area to the left of Start Plate.

   Determining Laser Hours
           Go to C:\Program Files\Luminex\LXR. Click on LxMaint.exe. A screen with several
           tabs will open. Click on the Detector 2 tab. On the left side there should be Red
           Laser seconds and Green Laser seconds. This is the seconds that have been used by
           the machine.

   MFIs dropping as the run progresses
           Verify sheath and waste caps are not switched
           Calibrate the instrument
                    If fails, contact Luminex
                    If passes, reinject the same plate to see if mfi values increase. If they do
                    then contact Luminex.

   Wrong template used when acquiring
           Virtually rerun the data by clicking on the Replay Batch in Developer’s Workbench
           The csv file will have a default name including the date and time of run

   Default Batch directory is not saving
           If Default Batch Directory in Luminex software is changed from C:/My Batches to
           another location on a network problems can occur. If the user tries to return to the
           original directory, it won’t save.
           It is not recommended to change the default batch directory off of the C drive. If
           done, the user must reinstall Luminex software.

   In the csv file, ERROR! appears in many cells in the Results section
   of the file.
           The user attempted to perform the Luminex analysis
           Verify the automatic Luminex analysis is turned off under Tools>Options.


Original date: October 2004                                                                     10
Revision date: March 2006
LC938.0
                                                                               550 West Avenue
                                                                            Stamford, CT 06902
                                                       Phone (888) 329-0255, Fax (203) 328-9598



                                                                     Return to Table of Contents


   Displaying the statistics box in 1.7
           Go to options
           Click ctrl+alt+a
           Type “microsphere” in the password box (no quotations)

   Common Luminex Error Messages




           The error message is Luminex's generic message that means they have no idea what
           is happening




             This series of errors may appear when using the Create Template Wizard. The Edit
             Template function will not work. A patch needs to be installed. Contact Tepnel
             Lifecodes Technical Support to obtain the patch.
Original date: October 2004                                                               11
Revision date: March 2006
LC938.0
                                                                                 550 West Avenue
                                                                              Stamford, CT 06902
                                                         Phone (888) 329-0255, Fax (203) 328-9598

                                                                       Return to Table of Contents

   Uninstalling the Luminex software
           Note: This is only required if the software is not functioning properly and
           all other options have been discussed with either Luminex or Tepnel
           Lifecodes Technical Support
       1. Backup current database
       2. Log on to the computer (not the domain) as the Administrator.
       3. IS may begin if you have selected it to startup when the computer is started. If the
           software opens, close the program before proceeding with the uninstall.
       4. In the bottom right hand corner of the screen is a picture with a green arrow in it. It
           is the SQL Service Manager. Right-click this icon, and select Open SQL Server
           Service Manager.
       5. Select the Stop button and place a check in the box at the bottom of the screen that
           says Auto-start service when OS starts.
       6. Now close that dialog, and right-click the SQL Service Manager icon again, only
           this time select Exit.
       7. Now open Windows Explorer and go to C:\MSSQL7\data\ and delete files
           IVD.mdf and IVD_log.ldf.
       8. Close Windows Explorer.
       9. Right-click on the IS icon located on the desktop, and select Delete.
       10. When asked if you would like to place the file in the recycle bin, or add/remove
           programs, select to add/remove programs.
       11. Then select the IS program and remove it. This may or may not shut down your
           computer.
       12. Remove Dev Workbench.
       13. If the computer restarted between removal of programs you may need to check that
           the SQL Service Manager is still stopped and you have exited from that program. See
           steps 3-5 above.
       14. Remove MSDE from the add/remove programs.
       15. At this point, if you wish to change the name of the computer before adding it to a
           domain, return to step 4 of “Steps to network an IS System.” Otherwise, continue
           with “Installation of the IS Software.”

   Reinstall Luminex software
           Place the latest Luminex software CD into the CD drive.
           Follow the instructions on the screen. It will take through a series of Next buttons
           and then finally to a Finish.




Original date: October 2004                                                                    12
Revision date: March 2006
LC938.0
                                                                                  550 West Avenue
                                                                               Stamford, CT 06902
                                                          Phone (888) 329-0255, Fax (203) 328-9598


                                                                          Return to Table of Contents

   2. QuickType for LifeMatch Software (QTLM)

   Batch missing after submitted through QTLM
           Check Batch Status
                If batch is still pending then click Process Now
                If batch is processed then rename the csv file and reimport
           If problem persists with automated feature, create a new database

   Automatic import not functioning
           Verify the polling is on
           Verify the Luminex connection is saved
           Delete any old batches that may be pending. These will block any new batches from
           importing automatically.

   Output.csv file will not manually import into QTLM
           Verify the correct lot is being used
           Look for double decimal points (..) anywhere in the csv file

   Group Specific typings not combing with generic results
           Verify sample IDs are the same for both DRB and DR52
           Verify alleles in generic are also present in Hi Res
           Verify Hi Res codes have been imported
           If problem persists, reimport both files under a new name

   Patient list won’t import
           Verify that the necessary number of commas are present if certain information is
           missing
               Patient ID, Patient Name, Draw Date, HLA Type
               If only Patient ID is entered then no commas need to follow. However, if the
               user enters any additional information then commas must be added as space
               savers.
           Verify that there are no extra spaces following the last sample. Do not press Enter
           after the last sample is typed.
           Verify that the date is the following format: MM/DD/YY
           Make sure there are no duplicate sample Ids (first column)

   QTLM will not save a Luminex connection
           Make sure you are running QTLM 2.2.1.
           If you are connected to the computer name, try using local.
           If you are connected to local, try using the computer name.
                If the computer’s network name is not present then open the serverlist.txt file
                found in the QuickType for Lifematch folder.
                Type the computer’s name into this list and save.
                Reopen the software and select the new listing.




Original date: October 2004                                                                       13
Revision date: March 2006
LC938.0
                                                                                   550 West Avenue
                                                                                Stamford, CT 06902
                                                           Phone (888) 329-0255, Fax (203) 328-9598

                                                                          Return to Table of Contents


   Software does not find database when first opened after
   reinstallation
            Delete Luminex folder in the registry
       1.   Go to Start/Run/and type in regedit.exe
       2.   Go to HK Key Current User
       3.   Go to Software
       4.   Go to VB and VBA Program Settings
       5.   Delete the Luminex folder by right clicking on it and selecting delete.

   Best way to input typing data for subjects and save results in an
   ASCII or Rich Text format so it could be opened on one computer
   and uploaded on to database
            'Summary Report By Panel' report option provides a txt file of the data. For more
            customized output options, the user can write SQL queries that will extract specific
            info required for downstream reporting. This requires the services of someone who is
            well versed in SQL. To perform this function, additional SQL software may need to be
            purchased to obtain high-level access to the database.

   Unable to backup database
            If database was originally created in QTLM 2.0 then it will not backup
            Start database name with letters.

    QuickType for LifeMatch 2.2 Installation/Upgrade Instructions
       GENERAL IT NOTICES
          If your computer is networked and other programs running SQL are
          present (e.g., Luminex), your database may not be “visible” to other
          computers. This is because some installations of SQL disable TCP/IP. This
          protocol can be enabled after installation using svrnetcn.exe located in
          C:\Program Files\Microsoft SQL Server\80\tools\Binn.
          If you are running Windows XP with Service Pack 2, the firewall must be
          turned off in order to communicate with SQL databases over the network.
          Please see your IT person for assistance. If IT determined for internal
          security reasons that the firewall cannot be turned off, please have the IT
          person refer to Microsoft Knowledge Base Articles 841251 & 841252 to
          create exceptions for the SQL instances.

       NOTICES FOR CURRENT QUICKTYPE FOR LIFEMATCH 2.1 USERS:
         Quick-type for Lifematch 2.1 users must have version 2.1.4 installed
         before upgrading to 2.2.0. If you are running an earlier version (e.g.,
         2.1.2), install 2.1.4 and open the software. This will make necessary
         changes to the SQL database that are needed prior to installation of 2.2.
         During the upgrade from 2.1 to 2.2.0, two files will be replaced. It is
         advised that the original files be backed up in case any problems are
         encountered. The files that will be replaced are:
                 C:\Program Files\ Quicktype for LifeMatch 2.1\encrypted.txt
                 C:\Program Files\ Quicktype for LifeMatch 2.1\data\SQLTables.sql




Original date: October 2004                                                                       14
Revision date: March 2006
LC938.0
                                                                                550 West Avenue
                                                                             Stamford, CT 06902
                                                        Phone (888) 329-0255, Fax (203) 328-9598

                                                                      Return to Table of Contents

           Part I. Installation of Quick-type for LifeMatch 2.2.0 software package.
           1. Place the Quick-Type for LifeMatch 2.2 Installation CD into the CD-Rom drive of
              the computer.
           2. In My Computer, open the CD.
           3. Run the setup.exe by double clicking on the file.
           4. You will see a “Welcome to Quicktype for LifeMatch 2.2” message. Click OK.
           5. The default path listed should be C:\Program Files\ Quicktype for LifeMatch 2.1.
              Click on computer icon to begin installation.
           6. Choose Program Group screen appears. Quicktype for LifeMatch 2.2 should be
              selected by default. If it is not, then select it. Click Continue to install data
              access components.
           7. Depending on the system files already present on your computer, version conflict
              messages may appear. Click yes to keep the current files.
           8. You will see a message that the setup was completed successfully. Click OK.

          Part II. Installation of SQL Database Engine.
       (NOTE: SKIP Part II if you have installed and run Quick-Type for LifeMatch 2.1.)
          1. Open Quicktype for LifeMatch 2.2 from Start menu> Programs> Quicktype for
              Lifematch 2.2> Quicktype for Lifematch 2.2.
          2. MSDE dialog box will appear. Click OK.
          3. The Quicktype for Lifematch Install MSDE window will appear. Select
              Browse to MSDE Set-up File.
          4. From the new window, select D: drive (or appropriate drive for CD) from
              dropdown menu. Choose MSDERelA folder on left. Select setupMSDE.exe on
              right. Click Continue.
          5. A message box will appear, Install MSDE From…? Click OK.
          6. Another MSDE Installation message will appear. Click OK.
          7. A “Preparing to Install” message will appear, and then go away once installation
              begins.
          8. When the installation is complete, select Exit from the Quicktype for
              Lifematch Install MSDE window.
          9. A message will appear asking you to re-boot the computer. Click OK.
          10. A window entitled Server: will appear. Click Close.
          11. A window will appear stating that it will close the application. Click OK.
          12. Re-boot your computer.
          13. Open the Quick-Type for LifeMatch 2.2 software as described above. At this
              point, the software will create a default database called ‘Lifematch.’

          Part III. Updating and Importing Database files.
       Note: Importing any of these codes files will OVERWRITE all similar data
       present in the database. If you have manually entered any CREGs, serological
       equivalents or DNA codes, they will be deleted. You will need to manually re-
       enter these data.

       Database files present on Installation CD. These files will be installed in your
       Quicktype for Lifematch 2.1 folder.




Original date: October 2004                                                                   15
Revision date: March 2006
LC938.0
                                                                                   550 West Avenue
                                                                                Stamford, CT 06902
                                                           Phone (888) 329-0255, Fax (203) 328-9598

                                                                           Return to Table of Contents



        File                                    Requirement
        NMDP_Generic_082805.csv                 This file was updated with 06215A-DRB.
                                                If you are using Lifematch 2.1, and have
                                                previously imported this file, you do not
                                                need to import it again. If you are
                                                installing the software for the first time,
                                                or have created a new database, you
                                                must import this file if you are using
                                                06215A-DRB, or a more recent lot.
        Hi-Res_codes_008.csv                    This file was updated with 06215A-DRB.
                                                If you are using Lifematch 2.1, and have
                                                previously imported this file, you do not
                                                need to import it again. If you are
                                                installing the software for the first time,
                                                or have created a new database, you
                                                must import this file if you are using
                                                06215A-DRB, or a more recent lot.
        creg_122005.dat                         If you are using Lifematch 2.1 and have
                                                already imported the creg.dat, you do not
                                                need to import this file. If you are
                                                installing the software for the first time,
                                                or have created a new database, you
                                                must import this file if you are doing
                                                antibody analysis. The previous creg.dat
                                                file from the Lifematch 2.1.4 installation
                                                CD will not work with the new software.
        Serological_Equivalents_120105.csv      This is an updated file and is based on
                                                Nomenclature for factors of the HLA
                                                system, 2004 (Marsh, et al., Tissue
                                                Antigens 2005: 65: 301-369). This file
                                                must be imported if you are installing the
                                                software for the first time, or have
                                                created a new database, or wish to
                                                update the list in your current database.

Note: The above files are named with the date (MMDDYY). To determine which code list is the
most recent, look for the most recent date. As for the Hi-Res file, the ending three digit number
is in numerical order.

            Updating and Importing Database files--Continued
            1. From the menu bar of the opening screen, go into Edit> General Codes.
                  a. Select Generic Codes, click Import Lifecodes Data icon. A prompt
                      will appear telling you to select a text file, click OK. Import the
                      NMDP_Generic_082805.csv file from the Quicktype for Lifematch 2.1
                      folder.
                  b. Select Hi-Res Decode and import the Hi-Res_codes_008.csv file
                      from the Quicktype for Lifematch 2.1 folder as described in Step 2
                      above.
                  c. Select Serological Codes and import the
                      Serological_equivalents_120105.csv file from the Quicktype for
                      Lifematch 2.1 folder.


Original date: October 2004                                                                        16
Revision date: March 2006
LC938.0
                                                                                  550 West Avenue
                                                                               Stamford, CT 06902
                                                          Phone (888) 329-0255, Fax (203) 328-9598

                                                                        Return to Table of Contents

           2. From the menu bar of the opening screen, go into Edit> CREG Groups. Select
              Import CREG Data, Select the file creg_122005.dat and click Open.

            Part IV. Update Experimental Data sets.
       Quicktype for Lifematch 2.2 contains a new feature that allows the user to view a list of
       alleles that are positive for a particular probe. In order to utilize this feature, changes
       have been made to the *.exp files for each lot. This installation CD contains a folder
       called New Exp Files, which contains new exp files for the following lots: 07125C-LMA,
       08095A-LMB, 12145A-LMB, 05045B-LMC, 07225A-DQB, 12085A-DQB, 09095BR-DRB1,
       06215A-DRB & 06215A-DR52. The exp files for all new lots released after January 2006
       will be in this new format and will be present on the corresponding Update CDs.
            1. Insert the Installation CD into the CD-Rom drive of the computer.
            2. On the homepage of the software, click Import New Lot Information.
            3. Click on My Computer and select the Installation CD, then select the New
                EXP Files with Specificities folder.
            4. Highlight all appropriate .exp files that need to be imported.
            5. Click Open. After each file is imported, a screen will appear stating that the
                import was successful.
            6. Click OK. If you are importing an updated exp file for one that is already in your
                database, you will get two messages asking you to overwrite data. Answer Yes
                to both. You will then get the import was successful message.

       NOTE: The process of importing exp files can take several minutes. This is
       especially true for the DRB & HLA-B files. Do not close the software if it is in
       the middle of importing an exp file.

          Part V. Linking Software to Luminex.
       NOTE: These steps only apply i) if you are installing on the Luminex computer, or a
       computer that has network access to a Luminex instrument, and ii) if you did not have
       Quick-Type for LifeMatch 2.1.
          1. Click on Create Automated Batch in the Quicktype for Lifematch 2.1 software.
          2. A prompt will appear asking you to Create a Server Listing, click OK.
          3. Once at the Luminex Connection screen, click on Edit Server List. A list of
              network nodes will appear. Select the appropriate computer (on which
              Luminex is installed) from the list.
          4. Highlight the appropriate computer as the server, IVD will appear as the Luminex
              Database. Click
          5. Save Luminex Connection.

QuickType for LifeMatch 2.2 Uninstallation Instructions
           Remove the MSDE
       Go to the Start>Settings>Control Panel>Add/ Remove Programs. Choose Microsoft
       SQL Server Desktop Engine (Lifecodes) and click Remove Program.

           Remove QuickType for Lifematch 2.2 Program
       Go to the Start>Settings>Control Panel>Add/ Remove Programs. Choose QuickType
       for LifeMatch 2.2 and click Remove Program.

           Move the Database


Original date: October 2004                                                                     17
Revision date: March 2006
LC938.0
                                                                                  550 West Avenue
                                                                               Stamford, CT 06902
                                                          Phone (888) 329-0255, Fax (203) 328-9598

                                                                        Return to Table of Contents

       Go to C:/QuickType for LifeMatch 2.2/Data. Move the lifematch_dat.mdf and
       lifematch_log.ldf files out of the data folder. Place them somewhere else on the
       computer.

           Delete Luminex Folder in Registry
           1. Go to Start/Run/and type in regedit.exe
           2. Go to HK Key Current User
           3. Go to VB and VBA Program Settings
           4. Go to Luminex
           5. Go to SQL Server
           6. Go to Database Connection and note the computer connection (serial number)
           7. Delete the Luminex folder by right clicking on it and selecting delete.

             Proceed with re-installation of QuickType for LifeMatch 2.2 Software
       A new lifematch_dat.mdf and lifematch_log.ldf will now be created. If the old files
       from the moved database are needed then follow the below steps:
             1. Create a new database (not called lifematch) and connect to it.
             2. Delete the new Lifematch database.
             3. Copy the old lifematch_dat.mdf (not the ldf file) to the data folder.
             4. Add the Lifematch database to the server.
             5. Connect to the Lifematch database.
        If the original Lifematch database is not needed then delete both the mdf and ldf files.




       Note:   For all network situations please contact Technical
       Support at ext. 563.




            Please visit www.lifematchhla.com for further assistance.




Original date: October 2004                                                                     18
Revision date: March 2006
LC938.0

				
DOCUMENT INFO
Shared By:
Categories:
Stats:
views:266
posted:3/7/2010
language:English
pages:18
Description: Trouble-Shooting Guide