An introduction to Thunderbird, part 1

Document Sample
An introduction to Thunderbird, part 1 Powered By Docstoc
					INTERNATIONAL ISLAMIC
UNIVERSITY OF MALAYSIA

    EMAIL CLIENT
MOZILLA THUNDERBIRD
                           Table of Content
Content                                                        Page No
Introduction ……………………………………………………………………                        1
Clean Installation (no existing email client) ………………………………….   1
Configuration …………………………………………………………………….                      1
Thunderbird Mail Window Elements …………………………………………              5
Mail Window                                                    5
Message Viewing Options                                        5
Receiving Mail ………………………………………………………………….                      6
Message List ………………..…………………………………………………...                    7
Reading Messages ………………………………………………………………                      7
Attaching a Signature File ………………………………………………………               8
Sending Attachments ..…………………………………………………………..                 9
Using the Personal Address Book ………………………………………………             9
Adding Names to your Personal Address Book ...……………………………... 10
Importing an Address Book .……………………………………………………                12
Message Filters …………………………………………………………………..                    13
Built-in Junk Mail Controls .……………………………………………………              14
Images ……………………………………………………………………………                           17
Themes …………………………………………………………………………..                          18
Introduction
Thunderbird is an email client. It is an open-source redesign of Mozilla's mail component.
Previously, Mozilla's mail and web browser components were combined into a single application.
Thunderbird combines the feature set sound in Mozilla Mail with several new features and
improvements. A partial list includes:
      Advanced toolbar customizations
      Support and use of extensions that allow users to add individual features to customize
       their experience.
      A large number of new themes to customize the look and feel.
      Extensive online help, including a FAQ, tips and tricks and other useful information.
      Increased security features and compatibility with Internet applications


Clean Installation (no existing email client).
           1. At theURL http://www.iiu.edu.my/email/download.shtml you will find a list
               related email files that can be downloaded from the server including Mozilla
               Thunderbird.
           2. Download the installer file from the page above, and double-click the file.
Configuration
When you open Thunderbird for the first time, you need to create a new account.
   1. First click on "Create a new account".




   2. Select “Email Account” and press Next


                                                                                                1
3. Fill in your name and email address, press next




4. Choose IMAP for the type of incoming server you are using and fill in the name of the
   incoming server, naim.iiu.edu.my, you may be asked for outgoing server as well, for
   outgoing server it is smtp.iiu.edu.my, press next.




                                                                                           2
5. Fill in the username. If your email address is uswah@iiu.edu.my then your username
   should be uswah.




6. Now you are asked what you would like to call this account, choose yourself, press next.




                                                                                              3
7. You will get a summary, check your information, and if everything is ok press finish.




8. You are immediately asked for the password to your email account, fill in and press OK,
   you can also choose if you want Thunderbird to remember the password.



                                                                                           4
Thunderbird Mail Window Elements
The Thunderbird mail window is comprised of three main panels: the Sidebar, Message List and
Message Pane. The Side bar contains your mail folders. The Message List holds your mail. Finally, the
Message Pane previews individual messages if you so choose.

Mail Window

Menu bar
Toolbar


                                               Message List
                         Sidebar


                                               Message Pane




    By dragging the borders of the panes, you can change the size and shape of all three window
    panes. You can make them wider or taller, depending on the location of the panes. It is even
    possible to hide a window pane, such as the Message Pane, by clicking on the gray dotted bar near
    the middle of the pane.

Message Viewing Options
You can change the message list and message pane. There are 3 options for viewing messages. For
instance, some people do not use the message or preview pane. By default, the classic view is
displayed.

    1. From the View menu, select Layout. The submenu opens.


By clicking Wide View, Vertical View, or the default, Classic view, you can change the way
messages are displayed in your message list.




                                                                                                   5
Classic View             Wide View                Vertical View




Receiving Mail
Your mail is stored for you at our incoming mail server, until you retrieve it. Once you have read it,
you can decide where the message will reside, either on your hard or network drive, or on the server.
You may also want to delete it (we’ll cover deleting messages later in the module).

When you first log-on to your account, new messages will appear in the Message List, formatted with
bold text. Throughout the day, Thunderbird will check the server for new incoming messages. By
default, it will check every 10 minutes. If you need to retrieve new messages immediately from the
server, click the Get Mail button.




If you wish to change the frequency with which Thunderbird checks the server, select Tools >
Account Settings… > Server Settings and adjust the minutes.




                                                                                                    6
Message List
Each row in the Message List indicates an individual message. The Message List is divided into
columns.    The columns you initially see are: Thread, Attachments, Subject, indicator for
unread/read messages, Sender, Junk Status indicator, and Date.




The subject, sender, and date columns are set by the sender of the message. The indicator for
unread/read messages is set by Thunderbird. Unread messages have a green ball-like shape in the
indicator column; the symbol converts to a dot once the message has been read. Similarly, unread
messages are bolded. If you wish to manually change the message status from “unread” to “read,”
click the green ball shape, which changes to a dot. The formatting reverts to plain text once the
message has been read.




Reading Messages
To read a message click the message in the Message List Pane and it will appear below in the
message pane.




If you have the Message pane (or Preview pane) turned off, double-clicking any message will open it.
Some Messages maybe too large to be comfortably read within the message pane window. To enlarge
your viewing area, double-click the message and it will appear in its own window.




                                                                                                  7
Attaching a Signature File
Have you ever received an email from someone which closed with their job title, department and
phone number? Would you like your email messages to automatically contain the same kind of
closing?
You can set up your Thunderbird account so that all of your outgoing messages contain this
“signature.”

The first step is to create a file in Notepad that holds your contact information.

    1. Open Notepad (Start > Programs > Accessories > Notepad).

    2. Type in your contact information, remembering to format it as you would like it to appear
        at the foot of your emails.




    3. Select File > Save. The Save As dialog box opens.

    4. Save the file to a location of your choosing, such as My Documents.




    5. Give the file a name, such as signature. Make sure that the file name ends in txt.




The second part of the process is to set the signature to attach to your outgoing email messages in
Thunderbird.

    6. Select Tools > Account Settings. The Account Settings dialog box opens.

    7. Select (check) the Attach this signature checkbox.




                                                                                                 8
    8. Click Choose. The Choose a file dialog box opens.

    9. Navigate to the signature file that you just created.

    10. Click Open.




    11. Click OK. The dialog box closes.

Each new email message you compose will display your custom signature information.

Sending Attachments
To attach a file to an outgoing mail message:

    1. In the Compose window, click the Attach tool                            or select

        File > Attach > File(s). The Attach File(s) dialog box opens.

    2. Type the name of the file you want to attach, or select a file from one of the drives that
        you want to attach.
    3. Click Open. The filename appears in the Attachments area.


Using the Personal Address Book


Use the Personal Address Book to add specific names and email addresses of your choice. You can
create mailing lists and edit existing individual address entries.

To open the address book:

    1. On the toolbar, click the Address Book icon.




                                                                                                    9
Adding Names to your Personal Address Book

In Thunderbird, adding an entry to the Personal Address Book is called adding a card. Address
book cards can be used to store information such as names, postal addresses, email addresses,
and phone numbers.

The easiest way to add entries to your address book is to use an existing email that you have
received.

   1. Open an email from someone that you wish to add to the address book.
   2. In the From field, click their address. A shortcut menu appears.




   3. Select Add to Address Book. The New Card dialog box appears where you can complete the
       contact information.

To manually add a name/card to your personal address book:

   1. On the toolbar, click the Address Book icon. The Address Book dialog box opens.
   2. Click the New Card tool. The New Card dialog box opens.




   3. Enter the contact information.

   Each New Card dialog box has three tabs, but only two fields on the first tab are required:
   Display name and Email address.

      Contact Tab

            o   Name: Enter the following information:




                                                                                                 10
       o   First and Last (first and last name of person as you want it to appear in the
           address book).
       o   Display (the name that appears in the "To" field of the Compose window).
       o   Nickname (a shortcut or alias for the real name).
       o   Email address (primary and additional address).
       o   Prefers to receive messages formatted as: If you know this recipient can read
           HTML-formatted messages (such as messages that include links, images, or
           tables), choose HTML. If this recipient can only read messages sent as plain text
           (no formatting), then choose Plain Text. If you don't know or are not sure,
           choose Unknown. If you choose Unknown, Thunderbird Mail & Newsgroups
           determines the sending format based on the Mail & Newsgroups Send Format
           settings in the Preferences dialog box. If Mail & Newsgroups still can't determine
           the correct format, Mail & Newsgroups will prompt you to choose a sending
           format when you send the message. The default setting is Unknown.
       o   Phones (enter phone numbers for this person)


   Address Tab: Type additional information such as street address, phone number, and
    URL.

           Tip: If you enter address information, Thunderbird displays a Get Map button
           next to the address when you view this entry's address book card in your address
           book. Clicking the Get Map button displays a web page that contains a map to
           the address.




   Other Tab: Stores any additional information you want.




                                                                                           11
   4. Click OK. The card/name is added to the address book.

Importing an Address Book
If you have you have an address book from a previous mail program, you can import its entries
into the Address Book window as a new address book. Keep in mind that when you upgrade a
user profile from an earlier version of Mozilla or Netscape, your address book may be
automatically included, so there's no need to import them. Netscape 4.79 address books do need
to be imported.

   You can import address books from Netscape Communicator, Mozilla, Eudora, Outlook,
   Outlook Express, or text files (LDIF, tab-delimited (.tab), comma-separated (.csv), or text
   (.txt) formats). When you import an address book, Thunderbird creates a new address book
   with the imported entries.

   To import an address book, begin from the Mail window:

   1. On the menu bar, select Tools > Import. The Import Wizard opens.

   2. Follow the instructions to import address books.

   3. Choose what client you want to import from and press next.




                                                                                                 12
Message Filters
Message filters allow you to manage and organize your messages. You can create message filters that
Thunderbird Mail uses to automatically perform certain actions on incoming messages based on
criteria you specify. For example, you can create a message filter that automatically moves incoming
messages to a particular folder.

To access this feature:

    1. From the menu bar, select Tools > Message Filters. The Message Filters dialog box opens.

    2. Click New. The Filter Rules dialog box opens.

        You use the Filter Rules dialog box to specify the types of messages to act on, and the action
        you want the filter to perform.

    3. Type a name for the filter.

    4. Select the matching option you want Mail to use: "all of the following” conditions (criteria)
        you choose, or "any of the following" conditions.

    5. Use the drop-down lists to choose the search criteria (for example, "Subject," "Sender,"
        "contains," "doesn't contain") and then type the text or phrase you want to match.

    6. Click More to add criteria and Fewer to remove them.

    7. Select the checkbox to choose the action you want the filter to perform on the messages (for
        example, Move to Folder).

    8. Choose a destination folder in which to store the messages, or create a new folder.

        The following graphic displays a filter that will move any incoming messages with the subject
        containing “deadletter” to the deadletter folder.




                                                                                                   13
    9. Click OK to confirm your settings.

    10. Click the Close button in the Message Filters dialog box. The filter begins filtering incoming messages
           immediately.




Built-in Junk Mail Controls

You train the junk mail filter by marking unwanted messages as junk. Once trained, Thunderbird
detects and marks subsequent junk mail automatically. Once the junk mail is marked, you decide the
course of action. You can ignore it, have it moved to the Junk folder, or even have it automatically
deleted.

If a message gets by the filter, you can mark it as junk and Thunderbird will remember it and mark
similar messages as junk in the future. On the other hand, if the filter erroneously marks a message as
junk, remove the junk icon and Thunderbird will not mark similar messages as junk mail again.

To view junk mail controls:




                                                                                                           14
1. From the menu bar, select Tools > Junk Mail Controls. The Junk Mail Controls dialog box
    opens.

2. The first screenshot you can choose which account these settings will apply for, as some
    accounts require their own filter settings.




3. In the second screenshot below you see the junk controls are turned off by default, so the first
    thing you want to do is check the box which says "Enable junk mail controls."




                                                                                                15
    4. Messages that have been marked as junk mail will display a small icon.
    5. If a junk message is not marked by the filter and ends up in your inbox, you can train
         Thunderbird to identify it as junk.

To mark such a message as junk:

In the Junk status field, click the Junk status indicator for the corresponding message. The icon toggles
to a trash can, marking the message as junk and training Thunderbird to mark subsequent similar messages.




   Marked as
   junk




                                                                                                            16
Conversely, if a message in incorrectly marked as junk, clicking the Junk status icon will reclassify it as
non-junk. Thunderbird will then recognize subsequent messages of this nature and will not mark them
as junk.




  Marked as non-
  junk

You can also mark junk mail as junk or non-junk by clicking the Junk button on the toolbar.

By marking junk mail as “junk,” you are again training                                  Thunderbird to
recognize other such junk messages that you may receive in                              the future.

Images

Another trick for preventing spam is to disable remote images from loading. This ensures
spammers cannot embed secret images in their e-mail and track you when you open them. Go to
Edit > Options > Advanced (for some this might be Tools > Options > Advanced) and disable
"Loading of remote images", this will help alleviate your "Spam problem."




                                                                                                         17
Themes
If you do not like Thunderbird’s look or theme, you can change it! Changing the theme changes the
look of buttons, dialog boxes, menus, and other items. There is no change in functionality.

To change the theme:

            Select Tools > Themes. The Themes dialog box opens.




You can check for updates to themes and search for themes at the Mozilla Thunderbird site.

If you find a theme you like:

    1. Download it to your computer.

    2. Clicking the Install button. The theme is added to the collection.

    3. Select the new theme.


    4. Click Use Theme.                             . The new theme is applied.



Note: The theme change takes effect when Thunderbird is restarted.




                                                                                              18