UVOD U PROGRAMIRANJE WIN32 APLIKACIJA by bzs12927

VIEWS: 0 PAGES: 5

									UVOD U PROGRAMIRANJE WIN32 APLIKACIJA

 Microsoft Windows je operativni sistem koji pomaže korisniku da interaguje sa personalnim
 računarom (PC). Programeri koji žele da kreiraju aplikacije koje korisnici mogu da koriste na
 platformi MS Windows zasnivaju se na biblioteci koja se naziva Win32.

 Win32 je biblioteka tipova podataka, konstanti, funkcija i klasa koje se koriste da se kreiraju
 aplikacije za operativni sistem Microsoft Windows.

 Da biste kreirali osnovnu aplikaciju potreban vam je kompajler koji radi pod operativnim
 sistemom Microsoft Windows. Win32 biblioteka je napisana u C-u, koji je primarni jezik
 Microsoft Windows operativnih sistema. Svi programi na ovom kursu biće napisani u C++. Vi
 nećete videti razliku između C i C++ u tim programima. Mada su sve strukture biblioteke
 Win32 uglavnom C objekti, koristićemo Win32 kao da je C++ biblioteka. To znači da kadgod je
 potrebno primenjivaćemo C++ pravila.

Kreiranje WIN32 programa
 Svi Win32 programi prevashodno izgledaju i ponašaju se na isti način baš kao C++ programi,
 postoje samo male razlike koje se odnose na kreiranje programa u zavisnosti od kompajlera
 koji koristite. Na ovom kursu prevashodno će se koristiti Microsoft Visual C++ 6.

 Osnovni Win32 program ima sadržaj koji je zajednički za sve Win32 programe. Razlike se
 javljaju kada počnete da dodajete određene objekte koji se nazivaju resursi.

Korišćenje Borland C++ Buildera
 Da biste kreirali Win32 program pomoću Borland C++ Buildera, morate da kreirate tzv.
 konzolnu aplikaciju pomoću Console Wizarda. Vodite računa da ne izaberete nijednu opciju koju
 nudi Console Wizard. Pošto mišem kliknete na OK, biće prikazan polu-prazan fajl koji sadrži
 uključivanje tzv. hedera windows.h biblioteke i deklaraciju funkcije WinMain(). Sada ste
 spremni za dalji rad.

 Radno okruženje Borland C++ Buildera je vrlo pogodno za rad ali raspolaže vrlo oskudnim
 šablonom za kreiranje Win32 aplikacije.

Demonstracija
   1. Pokrenite Borland C++ Builder (5 ili 6).
   2. U meniju izaberite File -> New... ili File -> New -> Other...




   3. U okviru za dijalog New Items, kliknite na Console Wizard a zatim na OK
   4. U Console Wizardu proverite da ste selektovali samo opciju C++:




   5. Kliknite mišem na OK.
      Na ekranu ćete videti sledeći kôd:


      //---------------------------------------------------------------------------

      #include <windows.h>
      #pragma hdrstop

      //---------------------------------------------------------------------------

      #pragma argsused
      WINAPI WinMain(HINSTANCE hInstance, HINSTANCE hPrevInstance,
                     LPSTR lpCmdLine, int nCmdShow)
      {
          return 0;
      }
      //---------------------------------------------------------------------------

   6. Snimite aplikaciju u novi folder pod nazivom Win32A
   7. Snimite prvi fajl kao Main.cpp a projekat kao SimpleWindow


Korišćenje Microsoft Visual C++
 Da biste kreirali Win32 aplikaciju pomoću Microsoft Visual C++, aktivirajte opciju New (5 i 6
 verzije) ili New Project (.Net verzija) i selektujte Win32 application (5 i 6) ili Win32 Project
 (.Net) stavku.

 Microsoft Visual C++ obezbeđuje brže i kompletnije kreiranje Win32 aplikacije. Na primer, on
 obezbeđuje tzv. kostur aplikaciju koja sadrži sav kôd koji je osnovnoj aplikaciji potreban. Pošto
 na ovom kursu izučavamo Win32, krenućemo težim putem koji se sastoji u kreiranju aplikacije
 „od nule”.

   1. Pokrenite Microsoft Development Environment.
   2. U glavnom meniju izaberite File -> New... ili File -> New -> Project...
   3. U okviru za dijalog New ili New Project kliknite ili Win32 Application ili kliknite Visual C++
      Projects i Win32 Project:
4. U polje Location upišite putanju gde treba aplikacija da bude smeštena, recimo
   C:\Programs\MSVC
5. U polje Name upišite naziv aplikacije, recimo Win32A, i kliknite OK
6. U sledećem okviru za dijalog Wizarda, ako koristite verziju MSVC 5 ili 6 kliknite na dugme
   An Empty Project:
  1. Kliknite mišem na Finish. Ako koristite MSVC 6 na ekranu će se pojaviti još jedan okvir za
     dijalog i u njemu kliknite na OK
  2. Da biste kreirali prvi fajl programa, ukoliko koristite MSVC 5 ili 6, u glavnom meniju
     izaberite File -> New. Ako koristite MSVC.Net, u glavnom meniju izaberite Project -> Add
     New Item...
  3. Ako koristite MSVC.Net, proverite da je Visual C++ selektovan u stablu Categories.


  4. U oba slučaja kliknite ili na C++ Source File ili C++ File (.cpp)




  5. U polju Name zamenite sadržaj nazivom fajla. U ovom slučaju zamenite ga sa Main i
     pritisnite Enter



O Windows porukama
 Računarska aplikacija je opremljena Windows kontrolama koje omogućavaju korisniku da
 interaguje sa računarom. Svaka kontrola kreira poruke i šalje ih operativnom sistemu. Da bi se
 upravljalo tim porukama njima manipuliše pointerska funkcija koja se naziva Windows
 procedura. Ta funkcija može da ima sledeći oblik:

LRESULT CALLBACK MessageProcedure(HWND hWnd, UINT uMsg, WPARAM wParam, LPARAM
lParam);

 Ta funkcija koristi kontrolu switch da izlista sve potrebne poruke i da ih redom procesira. Ona
 procesira samo one koje korisnik zahteva. Ako se javljaju neraspoređene poruke znači javiće se
 neobrađene poruke i njih treba prepustiti funkciji DefWindowProc().

 Poruka koju ćete svakako procesirati je provera da li je korisnik zatvorio prozor posle
 korišćenja. To se radi oizivanjem funkcije PostQuitMessage(). Njena sintaksa je:

VOID PostQuitMessage(int nExitCode)

 Ova funkcija prihvata jedan argument čija vrednost je tipa LPARAM. Da biste zatvorili prozor
 šaljete kao argument vrednost WM_QUIT.

 Na osnovu svega do sada rečenog, prosta Windows procedura može se definisati na sledeći
 način:

LRESULT CALLBACK WndProcedure(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam)
{
    switch(Msg)
    {
    case WM_DESTROY:
        PostQuitMessage(WM_QUIT);
        break;
    default:
        return DefWindowProc(hWnd, Msg, wParam, lParam);
    }
    return 0;
}




Pripremio Dragan Marković

								
To top