Docstoc

Time History Analysis

Document Sample
Time History Analysis Powered By Docstoc
					IES VisualAnalysis 6.0

Time History Analysis
Project Description:
This example will use the following frame to demonstrate a ground displacement time history analysis. FEATURES: Split Members Nodal Mass Time History Load Case Result Validation

Frame Geometry

Modeling the Structure
Both the beams and the columns are W24x94’s. The basic dimensions are shown on the structure and the column bases are fixed. After you have modeled the basic geometry, select all the members and split them into 5 equal segments. We also need to add some extra mass to this frame before we set up the time history case. Where the interior column crosses the beams, we need to add translational mass of 3500 K to each of the four nodes. You can add mass to a node by editing the node (double-click or select and choose Edit Node). On the Mass tab specify 3500 K under Translational mass. Similarly, specify an additional translational mass of 1750 K to the 4 nodes where the exterior columns cross the beams. Do this on both exterior columns for a total of 8 nodes.

Loading the Structure
Time History Tutorial 1

IES VisualAnalysis 6.0

If you started with the Auto-Generated project you may already have a number of service load cases created depending on your customization settings. For this tutorial we will not use these service cases and instead must create a new time history case. To do this, select Load | Load Case Manager, click the “Dynamic” tab, and select the Create Time History radio button. Name the case "Base Displacement". For time and Newmark Integration parameters, specify the number of time steps as 50, time increment as 0.05 sec, gamma as 0.5, beta as 0.25, and delta as 0. From the “Forcing function data source” drop list select “From file”. We have not created a text file that contains our displacement field over time. To do this, open a text editor such as Notepad and enter the following information. (Note: that you can leave this dialog and VisualAnalysis open while you do this.)

Displacement 0.0 1.0 2.0 3.0 0.0 5.0 -5.0 5.0 0.0 0.0 0.0 0.0

Note: The last displacement value we entered was 5in at t = 3 sec. Since we only have 50 steps with 0.05 sec increments our total time will only be 2.5 sec. The value at 2.5 sec will just be the linear interpolation between the value at 2.0 sec and 3.0 sec. Also note that the data as shown is tab delimited but can be spaced delimited or comma delimited as well.

Save the text file to a location you can locate again and call it BaseDisp.txt. You can now close Notepad (or similar) and go back to VisualAnalysis and the Forcing Function dialog. Click on the ellipsis where it says "Click button to choose file." The dialog shown below will appear.

Clicking the ellipsis in this dialog will allow you to browse for the file containing your displacement information. Once the file is selected, VisualAnalysis will automatically try to determine the contents and read it in. If the drop down box does not change to the proper information type, you can manually select the proper information type using the drop down box in the upper right corner of the dialog and VisualAnalysis will then try to re-read the file. If the file still cannot be read, please refer to the User's Guide as there may be something wrong with the format of your text file. After your data file is read-in, click OK and then click Finish in
Time History Tutorial 2

IES VisualAnalysis 6.0

the Time History Case dialog. You have now successfully created a new time history case for your structure and we are now ready to proceed with the analysis.

Analysis & Results
Now that we have our model created and the time history case defined, we should check our model for errors before setting the analysis options and actually analyzing the structure. Select Analyze | Check Model for Errors to make sure there are no problems. If something looks like a potential problem it will direct you to where to start looking. With a good model, we should set our analysis options. Go to Analyze | Analysis Options and uncheck Calculate dynamic mode shapes. The “Static Analysis” setting is not used in a time history analysis. The results are displayed at each of the specified time steps showing the response of the structure at that particular instant. Now select Analyze | Analyze Now or click the lightning bolt button on the toolbar. You can view the results for each of the service cases by switching them in the status bar while in a result view. Select the Base Displacement load case and expand the General section on the Filter tab of the Project Manager if it is not expanded already.

Time History Tutorial

3

IES VisualAnalysis 6.0

Deflected Shape due the Base Displacement at t=2.5 sec.

Similar to checking our model for errors before analyzing, we should also validate our analysis results before reporting and working with our results. From the Analyze menu, select Result Validation Checks. If no problems are found with your results, the dialog displayed below will be brought up.

Dialog Brought Up If No Problems Are Found

If problems are found, a report indicating potential problems and summarizing the basic checks VA has made to validate correct results will be brought up (See example report below.).

Time History Tutorial

4

IES VisualAnalysis 6.0

Example of Result Validation Check Report with Warning

The Result Validation Checks check translations in the model to verify that the small deflections assumed in a linear analysis are not violated. The validation checks also report the applied loads and reactions to make sure the statics balance. Lastly, the report also performs basic material strength checks. In the example report above, the displacements, loads, and P-Delta results check out. The maximum stress in at least one member exceeds the member’s yield stress so a warning is presented. There are a number of ways to view the results for time history load cases. One interesting way is to graphically plot nodes over the applied time. Select the top left node of the structure, rightclick and choose Graph Node Results. This will bring up a plot that we will adjust to show only Displacement X and Displacement Y. On the Filter Tab of the Project Manager you should have six plots. Change the top two to Displacement X and Displacement Y and the remaining plots to No Results. The plot should look as follows when you are finished.

Time History Tutorial

5

IES VisualAnalysis 6.0

Displacement Y and Displacement X for the top left node (N5).

This plot shows the displacement in the X and Y directions for node N5 over the complete time the base displacement was applied. In a similar manner, you can plot the reaction forces for the supported base nodes as well. There are three main reports specific to time history analyses; Time History Cases, Forcing Function Details, and Forcing Function Summary. Feel free to experiment with creating these reports. You can use many of the "static" reports normally available such as Member Internal Forces with time history cases as well. These reports are available at any of the various result time steps.

Time History Tutorial

6


				
DOCUMENT INFO
Shared By:
Stats:
views:342
posted:1/17/2010
language:English
pages:6
Description: Explain How to model structure for time history analysis.