Snow Leopard Conservancy – How to Create a Tracking by loe13858

VIEWS: 0 PAGES: 50

									             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



This report is generated for Joyce Robinson (SNC) by Richie Carmichael (ESRI). The report describes the
steps required to convert a tab delimitated text file into a tracking layer in ArcGlobe and generate a
video.

This document should be treated as supplementary support information. US customers are encouraged
to contact ESRI’s professional support staff through the support request form or by calling 1-888-377-
4575.

In ArcCatalog, review the tab delimited text file containing position, date and other attributes.




                                                 Page 1
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Create a new File Geodatabase. Right click on a folder, select New > File Geodatabase.




                                               Page 2
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Right click on the tab delimited text file and select Create Feature Class > From XY Table.




                                                 Page 3
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



In the Create Feature Class dialog, select WGS 1984 as the spatial reference.




                                                Page 4
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Click the browse button highlighted below to save the output as a new feature class in the previously
created File Geodatabase.




                                                Page 5
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Click OK.




                                              Page 6
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Preview the data in ArcCatalog.




                                              Page 7
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



View the Feature Class properties.




                                              Page 8
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



The two critical fields in the feature class are ESN and MessageTime. ESN will be used as the track field.
This field MUST be defined as a Text file type. The track field typically contains a unique identifier for
moving objects, like a collar id or animal name.




                                                 Page 9
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Before progressing, use ArcMap to locate and delete any erroneous data (if any). Start ArcMap and
display the Editor Toolbar.




                                               Page
                                               10
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Add the newly created Leopard feature class using the standard Add Data command.




                                              Page
                                              11
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                             December 22, 2008



The data is split. All but one point (or “event”) is located in the correct location. Select Start Editing
from the Editor menu.




                                                   Page
                                                   12
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Select the Edit Tool from the Editor Toolbar.




                                                Page
                                                13
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Drag a bounding box around the point located at 0°0’0”N latitude and 0°0’0”E longitude.




                                               Page
                                               14
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Delete the selected point. Click the Delete button.




                                                Page
                                                15
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Exit ArcMap. Click File > Exit.




                                               Page
                                               16
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Click Yes to save edits.




                                               Page
                                               17
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Click No to exit without saving the document.




                                                Page
                                                18
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Start ArcGlobe.




                                              Page
                                              19
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Check to see if the Tracking Analyst extension is enabled. Click Tools > Extensions.




                                                 Page
                                                 20
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Check Tracking Analyst (if not already).




                                               Page
                                               21
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



The default globe layers are not suitable for your area of interest. Add better content from the ArcGIS
Resource Center. Select Add Data From Resource Center from the File menu.




                                                Page
                                                22
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Click on the World Imagery thumbnail.




                                              Page
                                              23
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



When prompted click Open to load the World Imagery layer file into ArcGlobe.




                                              Page
                                              24
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Turn off (or remove) the default globe layers Continents and World Image.




                                               Page
                                               25
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Ensure that both the Tracking Analyst and Animation toolbars are displayed. If not click View > Toolbars
> Animation and View > Toolbars > Tracking Analyst.

Click the Add Temporal Data button on the Tracking Analyst toolbar.




                                                Page
                                                26
                Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                            December 22, 2008



In the Add Temporal Data Wizard select the Leopard feature class, the temporal field MessageTime and
the tracking field ESN. Note that a track field should always be used even if there is only one moving
object. A track field is a prerequisite to displaying a track in the map or globe display. A track is a line
that joins one or more events associated with a single object such as an animal or airplane.

Click Finish.




                                                  Page
                                                  27
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Double click on Leopard or right click on the layer and select Properties.




                                                 Page
                                                 28
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



The following instructions will change the way that events symbols are rendered. The most effective
method is probably a billboarded lollypop.

Uncheck Draw Leader Lines. This option, if checked, displays quite spectacular (and erroneous)
shooting white lines.

Select Draw Elevated Lines from the drop down menu and increase the Line Length to 50 pixels.

Click OK.




                                               Page
                                               29
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



In this walkthrough we don’t want to display a symbol for every event, just the most recent event based
on the current time. Click the Symbology tab in the Layer Properties dialog and uncheck Events.

To choose a symbol for the lead event, check Most Current Event and click the symbol button to display
the Symbol Selector window. Click the More Symbols button to display a list of installed styles.




                                               Page
                                               30
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Click on the Conservation style.




                                              Page
                                              31
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                            December 22, 2008



Scroll down the list of symbols, click on Bear 3, change the size to 2 and then click OK.




                                                  Page
                                                  32
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



To display tracks, check Tracks. Change the track symbol by clicking the symbol button and choosing
Highway Ramp.




                                               Page
                                               33
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Right click on the Leopard layer and select Zoom To Layer.




                                                Page
                                                34
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



By default, newly added tracking layers are defined as floating. Floating layers use height sourced from
feature geometry, an attribute field or a constant value. This is typically used to model aircraft.

Because we are tracking ground animal, we can modify the layer to be draped. Right click on the
Leopard layer and select Redefine Layer > Redefine Layer as Draped.




                                                Page
                                                35
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Display the Playback Manager by clicking the second to last button on the Tracking Analyst toolbar. Click
and drag the red pointer in the playback manager to adjust the “current time”.




                                                Page
                                                36
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



To emphasize the mountainous terrain we can modify the vertical exaggeration. Click View > Globe
Properties to display the Globe Properties window.




                                              Page
                                              37
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



In the General tab, change the exaggeration of the globe surface to 1.5. Click OK.




                                                Page
                                                38
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



To prepare the tracking layer for use in an animation, set the current time to the end time of the layer.
Drag the red current time marker to the end of the time line.




                                                 Page
                                                 39
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                        December 22, 2008



Click the Animation drop menu on the Animation toolbar. Click Create Time Layer Animation.




                                              Page
                                              40
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Select Leopard from the Layer drop down menu.

Select MessageTime as the Start Time Field.

Check Animation fields cumulatively.

Click OK.




                                              Page
                                              41
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Open the Animation Control by clicking on the last button on the Animation toolbar.




                                               Page
                                               42
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Click the Options >> button to reveal the animation properties. Change the duration to 30 seconds.
Click the Options << button again to hide the animation properties.




                                               Page
                                               43
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



Click the Play button (first button on Animation Controls window) to start the animation.

In ArcGIS Desktop 9.3, the tracking layer will not animate automatically. To trigger the tracking layer to
begin animating please click once inside the globe display. This is a bug.




                                                 Page
                                                 44
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Click the Stop button on the Animation Controls window to cease the animation.

Before progressing, it is advisable to save the globe document. To save the document, click File > Save.




                                                Page
                                                45
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



To export the animation to a video file, click Animation > Export to Video on the Animation toolbar.




                                                Page
                                                46
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                         December 22, 2008



Enter the name of the output video in the Export Animation dialog. Click Export.

If you have Apple Quicktime installed then the Save As Type drop down menu will include QuickTime
(*.mov). QuickTime movies are useful if you anticipate your movies will be played on both Windows and
Mac computers.




                                               Page
                                               47
             Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                            December 22, 2008



Assuming that AVI was selected as the Save As Type, a dialog will appear presenting a list of all installed
CODECs. I would recommend either Microsoft Video 1 or Cinepak Codec by Radius. Both are almost
universally available on all Windows computers. Cinepak provides the best compression but requires
more processing power than Microsoft Video 1.

By default, the compression quality is set to 90%. Increasing this value will improve the quality but also
increase the size of the output video. Decreasing the quality will degrade the video but result in a much
smaller video. Click OK to start the video export.




                                                 Page
                                                 48
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                          December 22, 2008



Remember to immediately click once inside the display to trigger the tracking layer to begin animating.




                                                Page
                                                49
            Snow Leopard Conservancy – Exporting a Tracking Layer to a Video in ArcGlobe

                                           December 22, 2008



The size of the output video will match the size of the globe display in ArcGlobe. Resize the ArcGlobe
application to desired size before exporting to video.

To bring the video to life, add a camera track. The easiest way to do this is to click the Camera button
(second from right on Animation toolbar) at least twice at different viewing positions. As the animation
progresses, ArcGlobe will automatically interpolate between camera positions (or “keyframes”).

Use the Animation Manager (Animation > Animation Manager) to view and/or change animation tracks
and key-frames.




End.




                                                Page
                                                50

								
To top