Level 3 Word Processing with Word

Document Sample
Level 3 Word Processing with Word Powered By Docstoc
					                Intermediate Word Processing with Word

Creating a Template from Scratch
We are going to start the workshop today with an activity that may not make much sense to you
but you just have to trust me, this is leading somewhere very useful. What we are going to begin
the day is create a template from scratch. But before we do that let me give you some
information about templates, what they are and how they work.
First of you need to know that Word is full of templates. Microsoft has already created several
templates for you and some of them are quite useful. In fact, you use a template every time you
open a new document. One of the built in templates is a template called “normal.dot.” You
probably already know that when you create and save a Word document the extension (the last
three letters in the file name, after the “.”) for that document is “.doc.” That tells your computer
that what you have here is a word processing file created by MS Word (or possibly by Word
Perfect). However, when you (or anyone else) create a template, the extension is “.dot.” (That is
“do” for document and “t” for template.) Every time you open a document, unless you tell it
otherwise, Word employs a template called “normal.dot.”
Now, what exactly is a template? A template is a pattern for your documents. When you choose
a template for a new document, you are telling Word what information – text, formatting, and
graphics-- that you want to appear in that document automatically. Think about that for a minute.
The more information that you can automatically add to a new document, the less you will have
to add manually, and the more efficient you will become in your work. That is what we are after
here, you becoming more efficient in your work. Knowing how to create and utilize templates
can drastically reduce the amount of time that you spend creating documents from scratch and
typing in information.
But templates don’t simply place information in a new document; they also enable you to create
custom editing environments for specific clients, projects, companies, agencies or whatever it is
that you create documents for. Templates can store all the information that you need to create,
edit and format a document as efficiently as possible. Let me be a little more specific. A template
might include…
      All the styles that you need for a document. (If we have time we will talk about styles a
       little later in the day.)
      All the “boilerplate” text for the document that the template will be used for. For
       example, if you type a letter to clients over and over and some or most of the information
       remains the same from client to client, you can include all of that information in your
       template and you will never have to type it again. Does that sound like a work saver?
      Graphics can be included in the template and you never have to insert them again.
      Formatting features such as choice of font, margins, borders, all those things that you do
       to make your document look just like you want it to can be included in a template and
       then you don’t have to manually format a letter. For example, if you have a particular
       document that you want to use different fonts in than you find when you open a new
       document with the normal template, you can create a template that contains those
       particular fonts as the default fonts and you don’t have to go hunting for them every time
       you begin that particular document. If you regularly create documents with tables and
       you manually enter and configure the tables every time you create your document, you
       can create a template with a table already set up in it and ready to go. You create it once
       (for the template) and you never have to create it again.
As you can see, templates can be very powerful time/work savers if you know how to create and
utilize their power. That is what you are going to learn to do in the first part of this workshop.
Let’s start off with a quick look at some of the templates that are included in Word. Open Word
and then click on File – New. The task pane opens on the right. Click Templates>on my
computer. -You will notice that there are eight tabs at the top of this dialogue box. Each tab
represents a different group of templates. Click on the “Letters and Faxes” tab and double click
on the “Contemporary Letter” template.
I want you to notice several things about this letter. First of all notice that it has some graphics in
it. You don’t have to add those graphics; they are included in the template. Also notice that there
are several styles in this template. Click on the “Company Name Here” text and look in the
Format> Styles and Formatting list box. Notice that the name of the style is “Company Name.”
Now click on the drop down arrow on that same box and you will see a list of all the styles that
are in use in this template. Each one of them serves a particular function related to this template
and the documents that you would create using it. Click on each part of the “letter” and look in
the Styles box to see what is highlighted. Every part has been saved as a style. If we took the
time to examine the other built-in templates, (and I would encourage you to do so latter) we
would discover that all of them have different fonts and graphics and formatting features related
to their purpose. And if one or more or those templates fit your work, they will save you much
time and effort. However, the chances of many of them being useful to you on a regular basis are
not very high. So, in order to tap in to the real power of templates, you have to learn to create
them yourself. Let’s create on from scratch.
We are going to do a simple letterhead template that will include some of the things that you
might want to use in the future. However, even if you never create a custom letterhead template
like the one we are going to create, you will find the processes of creating a template are pretty
much the same regardless of what you are going to include in your template.

                  Go through “Instructions for Creating A Custom
                          Letterhead Template” exercise.
Ask: where would be good places for templates at your school or office? Lead discussion.

Creating a Template Using An Existing Document
You already have “form letters” that you use on a day-to-day basis that are not templates
(although you may think of them as templates and use them as templates). Maybe you have
blank spaces in them where you fill in information that is different for each letter but much of the
information is the same from one letter to the next so you leave that information in tact. It is a
really simple thing to turn that type of document into an actual template instead of a document
that you use as a template. Now you may be wondering why you would want to do that. There
are a couple of reasons, I will give you one now and the other(s) will become apparent as we
proceed with the workshop.
If you use a document as a template, (that is, the format of the file is .doc instead of .dot) when
you are finished you either have to save the document as another file (save as) or delete the
information in the document that will changes from letter to letter. Additionally, you will
probably have to spend some time making sure everything is lined up as it should be after you
have added information to it. That is all time consuming. Once you have created a template using
the document, you never have to worry about or do any of those things. Word takes care of it for
you in the way that it handles templates. Plus, you don’t have to go hunting for the document
every time you want to use it. You will be able to see the template in the “New” dialogue box.
It’s easy and it is a work and time saver so let’s learn how to do it.
On your disk there is a file named “Discipline Referral Form.doc.” Please open that document
and we will transform it to a template. Here’s how you do it.
    1. Click “File – Save As”
    2. In the Save As dialogue box in the “Save as type” list box (see below) select “Document
       Template.”




    3. When you do that, the “Save In” location changes to the default location for all templates
       used by the program. It is important to store the templates in the designated location. If
       you do, they will appear in the new documents dialogue box and be very easy to access.
       Click on the Save button in the lower right hand corner of the dialogue box.
    4. Close the file and select “File – New.” Look at the right side of the screen in the Task
       Pane and find “Templates on My Computer.” Click on it. You should see “Discipline
       Referral Form” as one of the templates. That is all there is to creating a template. Go
       ahead and open it and let’s use it to see how it differs from just using a document as
       template.
    5. Click in the line for the date and type today’s date.
    6. Fill out the form. Fix any problems necessary.
    7. Click on File – Save and give it a name and a location and click on the button that says
       Save. Now close the file, click on file – new and open another Discipline Referral
       document using the template. As you can see, the template is in tact and ready for you to
       use. That is how you create a template from an existing document.
As you can see, to create a template from an existing document, all you do is create the
document with the appropriate blank spaces and save it as a template. Be sure that you store it in
the correct place and it will be readily available for you any time you need it. Plus, as long as
you don’t open the template as a template or fill in some information and save it as a template
again, you never have to worry about taking any of the “changing information” out of the
document. The original blanks will stay in tact from one use to the next.
(I need to tell you that that worked better than it was supposed to. It doesn’t always work quite
so flawlessly.)

Form Fields
Let’s take this particular template a step further and make it more user friendly and easier to use.
We are going to add something called fields to the template. Fields are used as placeholders for
data that might change in a document and for creating form letters and as you will see, the
template will become much easier to work with when we add these fields.
1. Click on File – Open. In the “Files of type” list box, select “Document Templates” and
   navigate to the location of your templates folder. Word 2003 stores them in “c:\Documents
   and Settings\UserName\Application Data\Microsoft\Templates.” (The Application Data
   folder is a hidden folder. You may have to show hidden folders to see this. You can do that
   in Tools > Folder Options > View > Show Hidden Files and Folders.) Find the template
   named “Discipline Referral Form.dot” and open it.
2. Click on “View – Toolbars – Form” to view the form toolbar.
3. With the cursor placed one space after the colon in the date heading, click on the ab| button
   (the text box tool) on the toolbar. A small gray box should now be visible after the date
   heading.
4. Do the same after “Referred Students:” “Referring Teacher:” “Room #:” “Time of
   Incident:” “Location of Incident:” “Detailed Description” and “Time Sent to Office.”
5. Before you make a form available to users, you always need to protect it by clicking Protect
   Form on the Forms toolbar. Protection allows users to fill in the form but prevents them
   from changing the form's layout and its standard elements. When you want to go back to
   writing or modifying the form, click Protect Form again to unprotect the form. Also, when
   you don’t protect the form it is not as user friendly and useful as it is when you protect it.
   Save and close the template.
6. Open a new document using the Discipline Referral Form.dot template. The first field
   should be highlighted and ready for you fill in. Fill it in and hit the tab key. You are taken
   directly to the next field. Continue until you have filled in all the fields. At this point you
   can either save the document (not as a template) or you can print it without saving it,
   depending on what you want to do.
7. Close the document and don’t save it. Click on File – Open, select Document Templates,
   navigate to the location of the Discipline Referral Form.dot, and open it.
8. Select View – Toolbars – Forms and un-protect the form.
9. Select the date field and click on the field properties button on the tool bar. In the “Type”
   list box select “Current Date.” (Please note that every time you open a document using this
   template, the date will be changed to the current date. This could be good or it could create
   some problems.)
10. Select each individual field, one at a time, and click on the underline button.
11. Protect the template, save it and close it. Open a new document using the template.
12. Notice that the date is already filled in for you, you don’t have to type it. Also notice that
    you can tab from field to field but you cannot get into the body of the document to make any
    changes. This is a time saver, a productivity increaser, and a way to keep someone from
    accidentally messing up your template.
Can you see how our template has developed into something quite useful and user friendly?
Well, believe it or not, we aren’t finished yet. There is a way that will make this template even
more user friendly and eliminates even more chances for time consuming and productivity
destroying errors and mistakes. We are going to create what is called a prompting form. A
prompting form is a form that asks users a series of questions and then automatically fills out the
form based on their answers. This can be very useful when it comes to filling out a document
that has a lot of “boilerplate” text surrounding a few changing entries. Here’s how you do it.
1. First, open the Discipline Referral Form.dot template as a template and be sure that the
   protection is turned off. (That is always necessary if you are going to make changes to the
   template. If you don’t turn it off, you will only be able to fill out the form fields and that is
   not what we want to do here.)
2. We are not going to change the date field, although you could if you wanted to. It seems to
   me that the date field is set up in the best manner possible… you don’t have to type
   anything. So click in the Referred Student field to select the field.
3. Select “Insert – Field,” from the “Categories” column select “Mail Merge,” and in the “Field
   Names” column select “Fillin.” (See Figure 1)
4. In the Prompt box type “Enter Student’s Name” (no quotation marks). Click OK.
5. A dialogue box will appear asking you to enter the student’s name. Don’t type anything in
   that box. Simply click OK again.
6. Repeat this process for the Referring Teacher, Room Number, time, location, detailed
   description, and time sent to office fields in the form, supplying the appropriate prompt for
   each field. (You may have to make some adjustments along the way to the alignment and
   other formatting features.) For the Referring Teacher field check the “default response to
   prompt” check box and add your name to the text box.
7. Protect the form. Save the form and close it.
8. Select File – New and open a new document based on this template. You should see the
   dialogue box asking you for the information for the first field. Supply the information and
   click OK. The dialogue for the second field will appear. Click OK. Continue until the
   dialogue boxes stop opening and the main document has the focus. You should now have a
   completed document ready to print.
As you can see, if you have a document that contains a lot of information that remains the same
from one time to the next, using templates can be a real time saver as well as a way to increase
productivity and eliminate many mistakes.
It is essential to remember that forms are best based on or used as templates. While you can
make a form a regular document, you would have to re-create the form each time you used it.
That decreases productivity and ease rather than increases it. If you want your users to be able to
access the form by choosing File – New and opening the Templates dialogue box, you must save
the form in the designated Templates folder or one of its subfolders.
Thus far in our study of Word’s form features, the only form field that we have used is a text
form field and a fillin form field. There are several other form fields that are easy to use and
might be useful to you from time to time. What you will really discover is that in cases where
these form fields will be useful, they will really be useful. Let’s take a look at them.

Text Form Field Options
   1. Select File – Open, templates and open the Discipline Referral Template if it is not
      already open. Be sure that you can see the Forms Toolbar and be sure the form is
      unlocked.
   2. Let’s start with a little bit more in depth look at the text box form field. Select the
      Referring Teacher field in you document. Click on the Field Properties button on the
      form toolbar.
   3. In the type drop down list you will find several different types of data that can go in your
      text form field.
          Regular text – used to allow entry of any key. This is the default option.
          Number – restricts entry to numeric keys only. If you use a non-numeric key, a zero
           will be placed in the field.
          Date – restricts entry to a valid date or time. If you enter an invalid number, an error
           message will alert you that an incorrect entry has been made.
          Current Date – automatically inserts the current date when the document is opened.
          Current Time – automatically insert the current time when the document is opened or
           printed.
          Calculation – sets the field to be equal to the equation that you put in the Default Text
           box. (This is especially useful in tables for doing calculations.)
   4. The Default Text box gives you the option of having a default entry in your text form
      field. You can change the default text in the document when you open it. For example, if
      you have a text box that contains the name of the city and most of the documents that you
      are going to create using this template will have Corpus Christi in this field but
      occasionally it will have another city, Corpus Christi should be your default text. Then
      the only time that you will have to type the city is when the document should have
      another city in this field. (Please note that this field is not available if either the current
      date of current time options is chosen. When Calculation is selected as the field type, the
      box will be titled “Expression” and will start with an equal sign.) Add your name as the
      default text.
   5. Maximum Length – This property sets the number of characters that can be input into the
      text box. This could be useful in a field that contains zip codes or phone numbers to
      insure that at least there won’t be too many numbers entered.
   6. Format Type – This property determines the formatting applied to the text form field. The
      options depend on the Type chosen.
   7. Add a default value for the Room Number field.

Adding Check Boxes to Your Forms
Check boxes are a very clear and handy method of indicating a selection of one or more options
that are not mutually exclusive. Check boxes let your uses quickly indicate preferences, or, by
omission, rejections among a series of elements. For example, a check box is the method of
choice when you see the phrase “Check all that apply” as in a survey or questionnaire. Let’s add
some check boxes to our form so you can see how they work.
   1. Click in front of the word “Tardy” and select the check box button on the forms toolbar.
   2. Do the same thing for each item in the list.
Now you will notice that the check boxes are empty. If you want them to be empty when the
form is opened you should leave them empty here. Before you can test your fields you must
protect the document (use the Lock button on the toolbar). Lock the document. Your cursor
should be in the text box. Add some text.
   3. Tab to the next element. In the check boxes you can either click you mouse in the box or
      you can hit the space bar to place an X in the box. If you click or space a second time the
      X disappears.
   4. Make sure the text and check boxes are empty and unlock the form. Let’s take a look at
      the properties associated with the check box.
   5. Select the first check box and click on the properties button.
          Check Box Size – If you choose the Auto radio button, the size of the check box will
           be determined by the size of the font that you are currently using. If select “Exactly”
           you can determine the exact size of the box without regards to the size of the text.
          Default Value – gives you the option of having the check box checked or not checked
           when the template is opened. The other two settings are beyond the scope of this
           workshop so I will leave you to discover them on your own (although we may cover
           macros briefly).

Adding Drop-Down Form Fields To Your Forms
Drop-down fields can be useful and functional when you want to present your user with a variety
of specific options from which only one selection can be made. Drop-down fields are useful
when the information that you are seeking is from a list of possible choices and that list remains
static for the most part. Gender is a good example. The Human Resources Department might
create a document asking your applicants to choose between three different dental plans. Using a
Drop-down list would be useful, functional, and again, eliminate chances to make a mistake.
Let’s add one to our form.
   1. Make sure the form is unlocked. Click in front of the Referring Teacher field. Hit the
      enter key twice and then move up to the middle blank line that you just created.
   2. Type “Grade Level:” and select the drop-down form field button on the tool bar. Select
      the Properties button for the drop down that you just created
   3. In the drop down item text box type the first item you want in your list. For our example
      type “9th .” Click the “Add” button.
   4. Type in the other items, (10th, 11th, 12th) clicking add after each one. Please note that
      there is a limit of 50 characters per item and a limit of 25 items for the entire list. You can
      also type in a blank space and add it if you want to have a blank line on the top of the list.
      Do that now and move it to the first position in list using the arrows.
   5. Lock the form, save it, and close it. (Be sure to leave all the prompts empty. Just click
      OK.) Select File – New and open a new document based on this template and check out
      all the features that you have added to it.



Adding Radio Buttons to Your Forms
You should all be familiar with radio buttons; you see them all the time in databases and on the
web. But did you know that you can create a template that contains radio buttons also? It is really
quite simple.
   1. Open a new document
   2. Select View – Toolbars – Control Toolbox
   3. Click on the radio button control and a radio button will be added to your document
   4. Click in the document and them click the radio button control again. Another radio button
      will be added. Add one more.
   5. Select the radio buttons and click on the properties control. In the drop down list at the
      top of the properties sheet, select optionbutton1. Change the caption property to Yes and
      the group name property to Group One.
   6. Select the optionbutton2. Change the caption property to No and the group name property
      to Group One.
   7. Add two more radio buttons to your form. Give them a different caption and name their
      group Group Two.
   8. If you want all the radio buttons to be empty when you open the form, change the value
      property on all of them to false. If the value property on any button is true, that button
      will be selected by default when you open the template.
   9. Protect the form, save it as a template, close it and open a new document using the new
      template.
There are many other controls that may be useful to you along the way. I encourage you to
explore them. You will find that in a situation where one is useful it will really increase the
productivity of its users.
                                 Merging With Word

Simple Mail Merge – Creating a Form Letter
Now we are going to turn our attention to another useful and powerful feature of Word, its ability
to merge information from external (or internal) data sources to create form letters, mailing
labels, print envelopes and send emails. This is a real time saver and “productivity increaser.”
Once you get your data sources set up the way they need to be for the purposes for which you are
going to use them, you will find that Word’s merge tools are very useful and helpful.
The first thing you have to have in order to perform a merge is a data source. I have provided
two data sources for you and we will create a third one in the course of the workshop. We are
going to start with the file called “FB-Parents.mdb” and we will start with a form letter to the
parents on the list.
   1. Open a new document using the normal.dot template (blank document)
   2. Select Tools – Letters and Mailings – Mail Merge
   3. In the Mail Merge Task Pane, select the type of document that you want to create. In this
      case we are going to create a letter. Click Next: at the bottom of the task pane.
   4. In this step you can choose to use the current document to create you merge, start from a
      template, or use an already existing document. Choose the current doc option and click
      Next at the bottom of the task pane.
   5. In this step you are going to choose your data source or create a new one. We will start by
      choosing an existing data list.
   6. Click the browse button and find the FB-Parents2000 database. A window will open
      showing all the available tables and queries that you can use as a data source. Choose the
      Master Student Table.
   7. The next window allows you to make some decisions about the records in the table
      selected in the previous window. Click OK
   8. Click Next at the bottom of the task pane.
   9. Type the letter as follows…




   10. Click Next. In this step you can preview your letters using the Recipient Navigation
       buttons at the top of the task pane. Also notice that you can choose to exclude one or
       more recipients in this step.
   11. Click Next. In this step you complete the merge. If you click the print button in the task
       pane one letter will be printed to each recipient in the database. If you choose Edit
       Individual Letters, you can choose a range of letters to use to create a new document.
       You can then edit the individual letters before you print them.
Now, not only can you use Access as a data source, you can also use Excel. You don’t have as
much latitude and power using Excel but if all you need is a simple address database, Excel
might work just fine. Let’s create the same merge document but this time use the Excel table on
the disk. (The steps are identical)
Now let’s use this feature to create set of envelopes.
   1. Open a new document, select Tools – Letters and Mailings – Mail Merge. (Use
      Envelopes and Labels to print one envelope)
   2. This time choose Envelopes and click on Envelope options…
   3. On this property sheet you choose the envelope that you are going to use and how you
      want to print it. Click OK and then Next.
   4. Use an existing list and click Browse. Find the FB Parents-2000 database and choose the
      Master Student Table.
   5. In the next step you set up your envelope.
   6. Type your return address in the upper left hand corner.
   7. This step is a bit tricky. There is a text box for the address of the recipient on the
      envelope. You have to “click around” until you find it.
   8. Once you find it, click inside of it and click on the Postal Bar Code option in the task
      pane. Hit the enter key and add Parent’s Name, enter, Street Address, enter, city, state
      zip.




   9. Click Next to preview you envelopes and next to complete the merge just like before.




I told you that we would create a merge using an internal data source. An internal data source is a
data source that you create right in Word. Here is how it works.
   1. Open a new document and select Tools – Letters and Mailing – Mail Merge
   2. On step three choose Type a new list and click Create.
   3. Create a list using the provided interface
When you close this document you will be asked if you want to save the data source. If you do,
you will be able to use it again in the future for other merges just like Access or Excel.