Docstoc

ArcGIS Server Key Features

Document Sample
ArcGIS Server Key Features Powered By Docstoc
					ArcGIS Server Key Features
Depending on what features you need, you can choose among three editions of ArcGIS Server (Advanced, Standard, and Basic). See a more detailed description of key features. Advanced Standard Basic Data Management Provides geodata services for data extraction, replication, and synchronization, as well as a framework and tools for managing large spatial datasets in an RDBMS such as IBM DB2, IBM Informix, Oracle, Microsoft Access, Microsoft SQL Server, and PostgreSQL. GIS Web Services Supports Web Services including Map, Image, Globe, locator, geoprocessing, KML, WMS, WCS, WFS and WFS-T (Advanced only). REST and SOAP access are included with all editions. Mapping Includes tools for creating rich browser-based Web mapping applications. Spatial Analysis Supports server-based analysis and geoprocessing, including vector, raster, 3D, and network analytics, as well as models, scripts, and tools. Publishing to Clients Supports a broad range of clients including ArcGIS Desktop, ArcGIS Explorer, ArcGIS for AutoCAD, and browser-based applications. Image Management Supports a complete image management system for delivering large quanties of imagery that can be consumed in desktop, mobile, web and imagery clients. Web Application Functionality Contains tools and tasks, including pan, zoom, identify features, measure distances, find addresses, query and search attributes. Application Developer Tools Includes APIs and Application Development Framework for .NET, Java, JavaScript, Flex, and Enterprise JavaBeans ADF components (Advanced only). Advanced Spatial Analysis Includes advanced spatial modeling and analysis, such as suitability analysis, cut-fill, line-of-sight, and terrain modeling. Spatial Web Editing Functionality Supports spatial editing tasks for applications, such as adding, X X X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

X

modifying and deleting map features like points, lines and polygons. Mobile Application Developer Tools Provides an out-of-the-box, configurable mobile application that allows mobile workforce to dynamically query and update server data remotely. Administered from ArcGIS Server, it is integrated with GPS and fits seamlessly into enterprise IT environment. Mobile GIS Application Functionality Provides tools to manage and deploy custom applications for use on Mobile devices including a software developer kit (SDK). Mobile applications can be deployed on Windows CE or Windows Mobile devices with the .NET Compact Framework 2.0 and Windows XP or Vista PCs with .NET Framework 2.0. X

X

What Do You Get With ArcGIS Server?
ArcGIS Server includes:
   

ArcGIS Server for the Microsoft .NET Framework and the Java Platform ArcGIS Help System ArcGIS Explorer ESRI Data & Maps

Maintenance—First year maintenance is also included in the license of ArcGIS Server. Maintenance includes technical support, updates, and many other benefits. Resources—As a member of the ArcGIS Server community, you have access to online content, blogs, sample GIS servers and services, a Code Gallery, online software development kits (SDKs), and more at the ArcGIS Server Resource Center. Licensing—ArcGIS Server can be installed on a single server or distributed across multiple servers. Each server requires a license. Use of ESRI Software is subject to the ESRI License Agreement. ArcGIS Server is offered in three editions:
  

Advanced—spatial data management, visualization (2D and 3D), and spatial analysis Standard—spatial data management and visualization (2D and 3D) Basic—spatial data management only

Each edition is available at either an Enterprise level or a Workgroup level Enterprise Workgroup Number of Users Unlimited 10 Concurrent

Data Limits

Unlimited

4 GB

For example, you might order ArcGIS Server Advanced Enterprise. If you need ArcGIS Server training, you have many training options available to you. Contact ESRI Sales for more information.

ArcGIS Server Traning:
Introduction to ArcGIS Server Instructor-Led (Classroom) What's New in ArcGIS Server at 9.2 Self-Study (Virtual Campus) Building Applications with ArcGIS Server Using the Java Platform Self-Study (Virtual Campus) Introduction to ArcGIS Image Server Instructor-Led (Classroom) Using ArcGIS Server Geoprocessing Services Self-Study (Virtual Campus) ArcGIS Server Enterprise Configuration and Tuning for SQL Server Instructor-Led (Classroom) Developing Applications with ArcGIS Server Using the Microsoft .NET Framework Instructor-Led (Classroom) Developing Applications with ArcGIS Server Using the Java Platform Instructor-Led (Classroom) ArcGIS Server Enterprise Configuration and Tuning for Oracle Instructor-Led (Classroom) Introduction to ArcGIS Online Self-Study (Virtual Campus) Introduction to ArcSDE Self-Study (Virtual Campus) ArcGIS Server: Web Administration Using the Microsoft .NET Framework Instructor-Led (Classroom) Introduction to ArcGIS Image Server 9.2 Self-Study (Virtual Campus) Authoring and Publishing Optimized Map Services Self-Study (Virtual Campus) ArcGIS Server Setup and Administration Self-Study (Virtual Campus) Building Applications with ArcGIS Server Using the Microsoft .NET Framework
$980.00 USD Go to schedule Free Free

$980.00 USD Go to schedule Free $980.00 USD Go to schedule $1,470.00 USD Go to schedule $1,470.00 USD Go to schedule $980.00 USD Go to schedule Free Free $1,470.00 USD Go to schedule Free Free Free Free

Self-Study (Virtual Campus) Publishing KML Services with ArcGIS Server 9.3 Self-Study (Virtual Campus) Authoring and Publishing Geoprocessing Services Self-Study (Virtual Campus) Introduction to the ArcGIS Mobile SDK Self-Study (Virtual Campus) Introduction to ArcGIS for Developers Self-Study (Virtual Campus) Introduction to ArcGIS Network Analyst Self-Study (Virtual Campus) Introduction to Geodatabase Replication at ArcGIS 9.2 Self-Study (Virtual Campus) Introduction to Programming ArcObjects Using the Java Platform Instructor-Led (Classroom) Imagery in an Enterprise GIS Self-Study (Virtual Campus) Implementing Tracking Server Instructor-Led (Classroom) Introduction to the Multiuser Geodatabase Instructor-Led (Classroom) Managing Editing Workflows in a Multiuser Geodatabase Instructor-Led (Classroom) GIS Portal Toolkit Instructor-Led (Classroom) Data Management in the Multiuser Geodatabase Instructor-Led (Classroom) Home | Course Catalog | My Training | Library | ESRI Press

Free Free Free Free Free Free $1,470.00 USD Go to schedule Free $1,960.00 USD Go to schedule $980.00 USD Go to schedule $1,470.00 USD Go to schedule $1,470.00 USD Go to schedule $1,470.00 USD Go to schedule

System Rquirements:
ArcGIS Server is supported on the following platforms:
      

Windows Vista and XP Professional Windows Server 2003 and 2008 (32-bit and 64-bit) Windows Server 2000 and Professional Red Hat Linux and SUSE Linux Sun Solaris HP HP-UX (32 bit and 64 bit) IBM AIX

The following Integrated Development Environments are supported:
  

Microsoft Visual Studio 2005 and 2008 Eclipse Sun Java Studio and NetBeans

Server Platform

ArcGIS Server for the Microsoft .NET Framework

Operating System Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows 2008 (32-bit) Server Standard, Enterprise & Datacenter Windows 2008 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) Sun Solaris 9 (SPARC) Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter

ArcGIS Server for the Java Platform Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows 2008 (32-bit) Server Standard, Enterprise & Datacenter Windows 2008 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition

ArcGIS Server for Mobile Applications

Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter

All Platforms


 



Server display requirements: o 1024 x 768 recommended or higher at Normal size (96dpi) o Greater than 256 color depth DVD-ROM drive is required to install the application. Some ArcGIS Server features such as GlobeServer and Geometry require OpenGL functionalities. A basic graphics card that is OpenGL 1.3 compliant is necessary to satisfy this requirement. Python 2.5.1 and Numerical Python 1.0.3 are required to support certain core Geoprocessing tools. It is recommended that Python 2.5.1 and Numerical Python 1.0.3 are installed by the ArcGIS Server setup. Users can choose to not install Python 2.5.1 and Numerical Python 1.0.3 by unselecting the Python feature during installation. The Python feature is a sub-feature of Server Object Container.

Microsoft Windows






Microsoft Internet Explorer version 6.0 or higher is required. You must obtain and install Internet Explorer version 6.0 or higher, prior to installing ArcGIS Server on Windows. Windows XP and Vista: These operating systems are supported for basic testing and application development use only. It is not recommended for deployment in a production environment. Windows Vista and Windows Server 2008: When using the ArcGIS Server .NET Manager on Vista or Windows Server 2008, the application unexpectedly errors. See KB35105 for more details.

Error: Insufficient privileges - The current logged on user does not have administrative access to the Web server
Article ID: 35105 Software: ArcGIS Server 9.3 Platforms: Windows Vista, 2008Server

Error Message
When using the ArcGIS Server .NET Manager on Vista or Windows Server 2008, the application unexpectedly errors with one of the following messages: "Insufficient privileges - The current logged on user does not have administrative access to the Web server. Administrative access is required for creating and editing Web applications. Please contact your system administrator for further assistance." "Session has expired. Session variable for ArcGISServer couldn't be retrieved." "An error has occurred on the server. For details please check the Event (Application) log on the web server. The source was not found, but some or all event logs could not be searched. Inaccessible logs: Security."

Cause
The application domain that Manager is using in IIS 7 restarted unexpectedly.

Solution or Workaround
A fix is available from Microsoft that addresses this issue. Download the fix from Microsoft Help and Support.

To Obtain Windows Server Through the University:
Microsoft Select Software for Departments Departments at UIC can
purchase Microsoft Select products licensed by the University through Urbana's Computer Center, which is a part of Campus Stores, Mail, & Receiving. For pricing information, refer to: http://www.cstores.uiuc.edu/cgi/price2.dbr?UCS0077 . For more information and to place an order for products, contact the Micro Order Center (MOC) directly at (217) 244-0139 or: http://www.cstores.uiuc.edu/moc/moc.html Faculty/Staff may purchase Microsoft products for their personal machine through the ACCC from: http://e-sales.accc.uic.edu

http://www.cstores.uiuc.edu/cgi/price2.dbr?UCS0077

Linux
  

ArcGIS Server is only supported on Linux x86, on CPUs that adhere to the x86 architecture (32-bit), with supported Linux releases. It is a requirement that the OS (binary) has not been modified. ESRI does not provide any support if products are installed on Developer's Release of an Operating System. Red Hat Enterprise Linux 4.0: o The Linux patches from RHEL AS/ES will be supported as long as the patches are supported by the webservers and they are from Red Hat without any modification to the latest kernel/glibc version. o The following package groups are required:  from Desktops section  X Window System package group with freeglut package from Extra Packages section  from Development section  Development Tools package group with gcc-g77 package from Extra Packages section  Legacy Software Development package group (Standard Packages sufficient) o Additionally, the following software package is required (package version must be at level stated or higher):



compat-openldap-2.1.30-2 SUSE Linux 10: o The Linux patches for SUSE Linux Enterprise Server will be supported as long as they are from SUSE Linux without any modification to the latest kernel/glibc version. o The following software packages are required:  from System/Libraries package group  compat package  freeglut package  Mesa package  from Development/Languages/Fortran package group  compat-g77 package  from System/X11/Utilities package group  X Window System



Supported Clients




Client display requirements: o Using hardware based graphics accelerators can improve dynamic 2D and 3D rendering performance, however all video cards may not work. o If using hardware accelerators for ArcGIS Globecontrol and ArcReader 3D, make sure your graphics card is compliant with a minimum OpenGL 1.3, and be sure to use the latest available driver. o X-Windows/Common Desktop Environment is required on all UNIX/Linux platforms. Supported Web Browsers

ArcGIS Server Supported Web Browsers
Supported Operating Systems Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) Firefox 2.0 Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 Server Standard, Enterprise & Datacenter Windows Vista SP1 Ultimate, Enterprise, Business Windows XP SP2 Professional Edition Windows 2000 SP4 Server, Advanced Server & Datacenter Internet Explorer 6.0 Windows XP SP2 Professional Edition Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 Server Standard, Enterprise & Datacenter Internet Explorer 7.0 Windows 2008 Server Standard, Enterprise & Datacenter Windows Vista SP1 Ultimate, Enterprise, Business Windows XP SP2 Professional Edition Web Browser



Supported Mobile Client Devices

Developer Solutions Requirements


Web ADF for the Microsoft .NET Framework

Supported Application/Web Servers
Supported Operating Systems Limitations Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Windows Vista and Datacenter Internet Information Server Windows Server 2008 Windows 2003 SP2 (64-bit When using the ArcGIS (EM64T)) Server Standard, (NOTE: IIS 5.0, 5.1, 6.0, and Server .NET Manager on Enterprise & Datacenter 7.0 are supported. Vista Windows 2008 (32-bit) Server The version of IIS is or Windows Server 2008, Standard, Enterprise & Datacenter dependant on the Windows the application unexpectedly Windows 2008 (64-bit (EM64T)) version errors. Server Standard, Enterprise & that IIS is running on.) See KB35105 for more Datacenter details. Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition Application/Web Server

Integrated Development Environment (IDE) requirements
Supported Operating Systems Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 (32-bit) Server Standard, Microsoft Visual Studio 2005 Service Pack Enterprise & Datacenter 1 Windows 2003 SP2 (64-bit (EM64T)) Server (Web Developer Express, Standard, Standard, Enterprise & Datacenter Professional, or Team Editions) Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows 2008 (32-bit) Server Standard, Microsoft Visual Studio 2008 (Professional Enterprise & Datacenter or Standard Editions) Windows 2008 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition IDE

.NET Framework Requirements
.NET Framework 2.0 .NET Framework 3.5 NET Framework 2.0 is installed with Visual Studio .NET 2005. The redistributable is available to developers who want to include the .NET Framework installation with their .NET applications. .NET Framework 2.0 is also provided in a DotNet20 folder on the ArcGIS Server DVD media for your convenience. NET Framework 3.5 is installed with Visual Studio .NET 2008. The redistributable is available to developers who want to include the .NET Framework installation with their .NET applications.



Web ADF for the Java Platform

Web ADF for the Java Platform If you are using the ArcGIS Server Web controls and Web templates to build Servlet or JSP based web applications, the following are required:
  

Web server Servlet engine J2SE SDK (JDK) (In some cases, the Web server includes the servlet engine and/or JDK.)

If you are using ArcGIS Server to develop or build Enterprise Java Bean (EJB) applications, the following are required:
 

J2EE compliant Application Server J2SE SDK (JDK) (In most cases, the application server includes the JDK.)

upported Application/Web Servers
Supported Operating Systems Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) Apache 2.0.58 with Tomcat Sun Solaris 9 (SPARC) 5.5.17 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows XP SP2 (32-bit) Professional Edition Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Apache 2.2.4 with Tomcat Sun Solaris 10 (SPARC) 6.0.13 Sun Solaris 9 (SPARC) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Application/Web Server Limitations

Enterprise Java Beans (EJBs) are not supported with this web server.

Enterprise Java Beans (EJBs) are not supported with this web server.

Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) JBoss 4.0.2 Sun Solaris 9 (SPARC) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Oracle Application Server Sun Solaris 10 (SPARC) 10g Release 3 (10.1.3.1.0) Sun Solaris 9 (SPARC) Red Hat Enterprise Linux AS/ES 4.0 Update 2 Oracle Application Server SUSE Linux Enterprise Server 10 10g Release 3 (10.1.3.3.0) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Red Hat Enterprise Linux AS/ES 4.0 Update 2 Sun Solaris 10 (SPARC) Sun Java System Application Sun Solaris 9 (SPARC) Server 9.1 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) Sun Solaris 9 (SPARC) Windows 2000 SP4 Server, Advanced Server & Datacenter Windows 2003 SP2 (32-bit) Enterprise Java Beans (EJBs) Tomcat 5.5.17 Server Standard, Enterprise & are not supported with this Datacenter web server. Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Windows Vista SP1 (32-bit) Ultimate, Enterprise, Business Windows XP SP2 (32-bit) Professional Edition Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) WebLogic 9.2 Sun Solaris 9 (SPARC) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Red Hat Enterprise Linux AS/ES WebLogic 10 4.0 Update 2 SUSE Linux Enterprise Server 10

Websphere Application Server 6.1.0.15

Sun Solaris 10 (SPARC) Sun Solaris 9 (SPARC) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Sun Solaris 10 (SPARC) Sun Solaris 9 (SPARC) Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit (EM64T)) Server Standard, Enterprise & Datacenter

Integrated Development Environment (IDE) requirements
IDE Eclipse 3.2 - Must be used with Web Tools Platform 1.5. - A Java runtime environment (JRE) is required to use Eclipse. A minimum of JDK 5 Update 13 is recommended. Supported Operating Systems Red Hat Enterprise Linux AS/ES 4.0 Update 2 SUSE Linux Enterprise Server 10 Windows 2003 SP2 Server Standard, Enterprise & Datacenter Windows XP SP2 Professional Edition

Java Requirements
JDK version 5 Update 13 (v1.5.0_13) is required for Java development



Mobile ADF

Supported Relational Database Management Systems (ArcSDE)


IBM DB2



INFORMIX Dynamic Server

ArcSDE Microsoft SQL Server Database Requirements

Supported Database Versions Microsoft SQL Server 2000 SP4 (32-bit) Microsoft SQL Server 2005 SP2 (32-bit) Microsoft SQL Server 2005 SP2 (64-bit) Microsoft SQL Server 2008 (32-bit) Microsoft SQL Server 2008 (64-bit)

Supported Operating Systems
Supported Operating System(s) Windows 2000 SP4 (32-bit) Server, Advanced Server & Datacenter Microsoft SQL Server 2000 SP4 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & (32-bit) Datacenter Windows XP SP2 (32-bit) Professional Edition Windows 2000 SP4 (32-bit) Server, Advanced Server & Datacenter Windows 2003 SP2 (32 bit) Server Standard, Enterprise & Microsoft SQL Server 2005 SP2 Datacenter (32-bit) Windows 2008 (32 bit) Server Standard, Enterprise & Datacenter Windows XP SP2 (32 bit) Professional Edition Windows Vista (32 bit) Ultimate, Enterprise, Business Windows 2003 SP2 (64-bit - EM64T) Server Standard, Microsoft SQL Server 2005 SP2 Enterprise & Datacenter (64-bit) Windows 2008 (64-bit - EM64T) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (32 bit) Server Standard, Enterprise & Microsoft SQL Server 2008 Datacenter (32-bit) Windows 2008 (32 bit) Server Standard, Enterprise & Datacenter Windows 2003 SP2 (64-bit - EM64T) Server Standard, Microsoft SQL Server 2008 Enterprise & Datacenter (64-bit) Windows 2008 (64-bit - EM64T) Server Standard, Enterprise & Datacenter Database

Limitations
SQL Server 2008 SQL Server 2008 is currently in beta and is supported in test environments only. It will not be certified by ESRI until it is officially released by Microsoft. Windows Vista and XP SP2 Windows Vista and XP Service Pack 2 is supported for basic testing and application development use only. It is not recommended for deployment in a production environment. Windows XP Service Pack 2 is only supported with the Developer Edition of SQL Server. Windows 64-bit servers ArcSDE 9.3 is currently a 32-bit application, which can run on Windows 64-bit servers.

ArcSDE Oracle Database Requirements
Supported Database Versions Supported Operating Systems Database Requirements Operating System Limitations

Supported Database Versions
     

Oracle 9i (32 bit) 9.2.0.7 Oracle 9i (64 bit) 9.2.0.7 Oracle 10g (32 bit) 10.2.0.3 Oracle 10g (64 bit) 10.2.0.3 Oracle 11g (32 bit) 11.1.0.6 Oracle 11g (64 bit) 11.1.0.6

Supported Operating Systems
Supported Operating System(s) Red Hat Enterprise Linux AS/ES 4.0 Update 2 Oracle 9i (32 bit) 9.2.0.7 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter HP HP-UX 11i (11.11) PA-RISC IBM AIX 5.3.0.0 Oracle 9i (64 bit) 9.2.0.7 Sun Solaris 10 (SPARC) Sun Solaris 9 (SPARC) Red Hat Enterprise Linux AS/ES 4.0 Update 2 Oracle 10g R2 (32 bit) SUSE Linux Enterprise Server 10 10.2.0.3 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter HP HP-UX 11i (11.11) PA-RISC HP HP-UX 11i v2 (11.23) Itanium Oracle 10g R2 (64 bit) IBM AIX 5.3.0.0 10.2.0.3 Sun Solaris 9 (SPARC) Sun Solaris 10 (SPARC) Red Hat Enterprise Linux AS/ES 4.0 Update 2 Oracle 11g (32 bit) 11.1.0.6 Windows 2003 SP2 (32-bit) Server Standard, Enterprise & Datacenter IBM AIX 5.3.0.0 Oracle 11g (64 bit) 11.1.0.6 Sun Solaris 9 (SPARC) Sun Solaris 10 (SPARC) Database

Database Requirements

Oracle 9i R2 (9.2.0.x) Requirements
If your database is Oracle 9i R2 (9.2.0.x) you must use the ArcSDE 9.3 for Oracle 9i R2 software. Oracle 9i Release 2 Database Patch Support Database: Oracle 9.2.0.7 or higher Oracle9iR2 Patch. This includes Oracle 9i Release 2 patch

set levels and Oracle Interim (One-Off) Patch as per Oracle Corporation's Patch Set Overview and Interim Patch documentation. See Oracle Metalink for all Oracle patch set (and Interim Patch) documentation and install instructions. ESRI recommends making a full back up of your Oracle database prior to applying any Oracle patch sets or interim patch. If functionality that was working prior to applying the Oracle patch set or interim patch stops working, return to the previous version of Oracle. Contact Oracle support as needed.

Oracle 10g R2 (10.2.0.x) Requirements
If your database is Oracle 10g R2 (10.2.0.x), you must use the ArcSDE 9.3 for Oracle 10gR2 release. NOTE: Oracle 10.2.0.3 ST_GEOMETRY users - need to apply Oracle Patch that fixes Oracle bug 6756089 Oracle 10.2.0.3 ST_GEOMETRY users - please see KB Article 34460 on ESRI support site Oracle 10.2.0.4 ST_GEOMETRY users - please see KB Article 34897 on ESRI support site ArcSDE 9.3 upgrade path to Oracle 10.2.0.4




Upgrade to ArcSDE 9.3 then upgrade to Oracle 10.2.0.4 If you need to upgrade your ArcSDE 9.2 service to Oracle 10.2.0.4 before upgrading to ArcSDE 9.3 Upgrade to ArcSDE 9.2 SP6 then upgrade to Oracle 10.2.0.4 then upgrade to ArcSDE 9.3

Required Configuration: ArcSDE 9.3 must be setup to access the Oracle10gR2 64bit database using an Oracle10gR2 32bit client whether using Direct Connect or the Application Server (See Oracle Database Upgrade Guide, 10g Release 2 (10.2) Chapter 6). Instructions for setting up ArcSDE 9.3 using the Oracle10gR2 32bit client to connect correctly to the Oracle10gR2 64bit database are as follows:
  

Install the 32bit Oracle 10gR2 (10.2.0.3) client software (see Oracle Metalink for download, install and setup instructions). Create a service name using the 32bit Oracle 10gR2 Net Manager you just installed to use in connecting to your 64bit Oracle10gR2 database. Install and setup ArcSDE 9.3 making sure you are using the correct version of the 32bit Oracle 10gR2 install. Use the 32bit Oracle 10gR2 service name you defined above for the connection to the 64bit Oracle10gR2 database. For Direct Connect the Oracle install and setup instructions for your client machines is the same as above, making sure that you are using the correct 32bit Oracle 10gR2 patch level noted above. You then use the 32bit Oracle 10gR2 service name created to connect to the already setup ArcSDE 64bit Oracle 10gR2 database.

Oracle 10g R2 Database Patch Support Oracle 10.2.0.3 or higher Oracle10gR2 Patch. This includes Oracle 10g Release 2 patch set levels and Oracle Interim (One-Off) Patch as per Oracle Corporation's Patch Set Overview and Interim Patch documentation.

See Oracle Metalink for all Oracle patch set (and Interim Patch) documentation and install instructions. ESRI recommends making a full back up of your Oracle database prior to

applying any Oracle patch sets or interim patch. If functionality that was working prior to applying the Oracle patch set or interim patch stops working, return to the previous version of Oracle. Contact Oracle support as needed.

Oracle 11g (11.1.0.6) Requirements
NOTE: Oracle 11.1.0.6 ST_GEOMETRY users - need to apply Oracle Patch that fixes Oracle bug 6756089

Operating System Limitations
HP-UX 11i (11.11) PA-RISC
 

Window System: CDE or HP VUE Mandatory HP-UX Operating System patches: PHSS_27700 PHCO_31923 PHCO_33711 PHKL_33258

Linux ArcSDE is only supported on Linux x86, on CPUs that adhere to the x86 architecture (32-bit), with supported Linux releases.

ArcSDE PostgreSQL Database Requirements
Supported Database Versions Supported Operating Systems Operating System Limitations

Supported Database Versions
PostgreSQL 8.3.0

Supported Operating Systems
Supported Operating System(s) Red Hat Enterprise Linux AS/ES 4.0 Update 2 PostgreSQL 8.3.0 Windows 2003 SP2 Server Standard, Enterprise & Datacenter Database

Operating System Limitations
Linux ArcSDE for PostgreSQL is only supported on Linux x86, on CPUs that adhere to the x86 architecture (32-bit), with supported Linux releases.

Windows ArcSDE for PostgreSQL is currently only supported as a 32 bit application. Windows XP SP2 Professional Edition Windows XP Service Pack 2 is supported for basic testing and application development use only. It is not recommended for deployment in a production environment.

Related ESRI Materials
 

ESRI Supported Environment Policy System Design Strategies: Recommended platform sizing and system configuration strategies are provided in the System Design Strategies technical reference document availabe at: System Design Strategies




				
DOCUMENT INFO