Evaluating Free and Open Source Software for Geospatial (FOSS4G

Document Sample
Evaluating Free and Open Source Software for Geospatial (FOSS4G Powered By Docstoc
					                                     Evaluating Free and Open Source Software for
                                Geospatial (FOSS4G) for Environmental Applications


                                           SAGA GIS


       SAGA is a free and open source geographic information system (GIS), with a special
'Application Programming Interface' (API) for geographic data processing. The SAGA API
supports grid data, vector data, and tables. Although some vector capabilities are included in
SAGA, it is mainly dedicated for a raster GIS processing. The huge number of raster analysis
modules is available in SAGA – it is very powerful software to work with Digital Elevation
Models. There are also included modules that perform operations on vector data.
       SAGA’s origin is from a terrain analysis tool called DiGeM. SAGA is created and
developed by a small group of developers from the Goettingen Univerisity in Germany (e.g.
Andre Ringeler, Olaf Conrad). The first SagaGIS was released in February 2004, the last one
in September 2007.
       SAGA is written in the C++ programming language. Program code relies on the GNU
General Public License. For the most part, this means that SAGA is an open source project.
The source code is readily available. The software is intended and protected to remain open
for modifications. The program can be freely distributed.

       Currently there are about 120 modules available in SAGA standard edition. This list
gives an overview of the variety of implemented methods for: terrain analysis (slope, aspect,
curvatures, curvature classification, analytical hillshading, sink elimination, flow path
analysis, catchments delineation, solar radiation, channel lines, relative altitudes) simulation
of dynamic processes (nitrogen distributions, erosion, landscape development), projections,
grid tools (merging, resampling), grid discretisation, grid calculator, geostatistics (residual
analysis, ordinary and universal kriging, single and multiple regression analysis, variance
analysis) etc.

   The major parts of the Graphic User Interface are:
   − Menu bar
   − Toolbar
   − Workspace window
   − Object properties window
   − Message window
   − Tabs




              The Cascadoss Project is financed by the European Commission                    1
              under the Sixth Framework Programme
                                     Evaluating Free and Open Source Software for
                                Geospatial (FOSS4G) for Environmental Applications


                               3D Visualization in SAGA GIS

        During this exercise we will present a sequence of analyses on the dataset for the study
area located in the Carpathian mountains. The actual study area will be the Tatra National
Park, lying on both sides of the Polish and Slovakian border. We would like to present several
analyses performed on the input digital elevation model and several additional datasets.
Operations on grids and shapefiles will be included. From the DEM, analytical hillshading
and visibility (viewshed) maps will be created. Finally, 3D visualization of the DEM for the
Tatra mountains with several additional layers overlaid, will be made.

STEP 0: Importing and displaying DEM of the Carpathians mountain
STEP 1: Importing and displaying DEM of the Dunajec Valley
STEP 2: Overlay of protected areas on the DEM
STEP 3: Creation of DEM for Tatra Mountains
STEP 4: Analytical hillshading
STEP 5: Displaying peaks in Tatra Mountains
STEP 6: Visibility analysis
STEP 7: 3D View


    !       Remember that your datasets should be prepared in one coordinate system.



STEP 0: Importing and displaying DEM of the Carpathian mountains

   1. Open SAGA GIS.
   2. In the Workspace, click on Modules tab. Choose Import/Export Grids via GDAL –
       Import Raster via GDAL. Use “Carphips1.tif” as input file. Click OK. This is a DEM
       for Carpathians.
   3. In the Workspace, click on Data* tab. Double-click on “Carphips1.tif”. It will be
       added to display as a new map.
   4. A map window appears. Maximize it.
   5. In the Workspace, click on Maps* tab. Select the new map. In the Object Properties
       window, change Name of the map to “Carpathians” and click Apply.
   6. Click on Data* tab and select the “Carphips1.tif”.
   7. Edit display properties in the Object Properties window. Choose Graduated
       Colors/Color. A window with available color scales appears. Use the default
       greyscale. Adjust manually the shades of grey used on the map. Click OK. In the
       Object Properties Window, click Apply.
   8. Choose menu File/Shapes/Load shape. Load “Study_frame.shp”. Double click on the
       Study_frame dataset in the Data* tab. Add it as a layer to the Carpathian DEM.
   9. Zoom out by choosing the zooming tool and clicking it with the right mouse button in
       the display window, until the whole DEM is visible. Zoom in, if needed, by clicking
       with the left mouse button in the display window.
   10. In the Object Properties window/Display, set Fill Style: Transparent, Outline color:
       red. Outline size: 3. Click Apply. The area of interest is visible: Dunajec Valley.



              The Cascadoss Project is financed by the European Commission                    2
              under the Sixth Framework Programme
                                    Evaluating Free and Open Source Software for
                               Geospatial (FOSS4G) for Environmental Applications




STEP 1: Importing and displaying DEM of the Dunajec Valley

   1. Load DEM of the study area – a small part of the Carpathians’ DEM for the Dunajec
      Valley: In the Workspace, click on the Modules tab. Choose Import/Export Grids via
      GDAL – Import Raster via GDAL. Use “dem_dunajec75.tif” as input file. Click OK.
   2. In the Workspace, click on the Data* tab. Double-click on “dem_dunajec75.tif”. It
      will be added to the display as a new map.
   3. In the Workspace, click on Maps* tab. Select a new map. In the Object Properties
      window, change Name of the map to “Dunajec DEM” and click Apply.
   4. Edit display properties (color scale) in the Object Properties window if needed. First,
      click on Data* tab and select the “dem_dunajec75.tif”.

STEP 2: Overlay of protected areas on the DEM

   1. Load shapefile with protected areas in the Dunajec Valley study area: In menu File
      choose Shapes/Load Shapes: “protected_areas.shp.”.
   2. Click on Data* tab. Select “protected_areas.shp”. Double-click on it. Choose to add it
      to the “Dunajec DEM” map. The protected areas will be overlain on the DEM for the
      study area.
   3. In the Object Properties window change the display properties for protected areas. Set:
      Fill Style: Backward Diagonal, Outline Size: 2. Click Apply.
   4. In the Object Properties window, in the Display:Label, select the Attribute: Namen.
      Change font color for the label to red. Click Apply. The names of the protected areas
      will be visible as labels.
   5. Click on Maps* tab. Select the map with protected areas layer and rename it as
      “Protected areas” in the Object Properties window. Click Apply.

             The Cascadoss Project is financed by the European Commission                  3
             under the Sixth Framework Programme
                                     Evaluating Free and Open Source Software for
                                Geospatial (FOSS4G) for Environmental Applications


   6. Choose File – Project/Save Project as... Choose a name for the project and save it.




STEP 3: Creation of DEM for the Tatra Mountains

   1.   Choose “protected_areas.shp” in the Data tab. Click with “action” tool on selected
        polygons for the Tatra National Park (Polish TNP and Slovakian TANAP). Hold Shift
        to select all polygons using the “action” tool.
   2.   Use the module Shapes – Tools/Construction/New Layers from Selected Shapes
        (choose the module using the Modules menu or the Modules tab). Set
        “protected_areas.shp” as input. Click OK. The new layer with the TNP and TANAP
        borders will be added to the display as “protected_areas.shp (Selected)”.
   3.   Click on Maps* tab. Select the map with selected borders and rename it as
        “TNP/TANAP borders”. Click Apply.
   4.   Create a new DEM only for these selected polygons: Use module Shapes – Grid/Clip
        Grid with Polygon. Set the Grid system (75; 1587x1613y; 396000x5435075y), Input
        grid: “dem_dunajec75 tif” and input Polygons: “protected_areas.shp (Selected)” and
        click OK.
   5.   Click on Data* tab and click on the new DEM for the Tatra Mountains. It is now
        called “dem_dunajec75.tif”, the same as the DEM for the whole Dunajec Valley area.
        Thus, in the Object Properties window, rename the DEM for the Tatra Mountains as
        “Tatra DEM” and click Apply.
   6.   In the Data* tab double click on “Tatra DEM”. Add it to the display as a new map.
   7.   Select the Tatra DEM in Data* tab. Change the color scale in the Object Properties
        window (using Colors/Presets) to grayscale. Click OK and Apply.
   8.   In the Maps* tab select the map with Tatra DEM and rename it to “Tatra DEM” in the
        Object Properties. Click Apply.


              The Cascadoss Project is financed by the European Commission                  4
              under the Sixth Framework Programme
                                      Evaluating Free and Open Source Software for
                                 Geospatial (FOSS4G) for Environmental Applications




STEP 4: Analytical hillshading

   1.   Choose the module Terrain Analysis – Lighting/Analytical Hillshading from the
        Modules menu or Modules tab. Choose the Grid system and “Tatra DEM” as input
        elevation grid. Check “create Analytical Hillshading” and Shading Method: standard.
        Click OK. A new layer with hillshading will be created.
   2.   In the Data* tab double click on the Analytical Hillshading. Add it to the display as a
        new map.
   3.   Click on the Maps* tab. Rename the new map as Analytical Hillshading and click
        Apply.
   4.   Click with the right mouse button on the “Carpathians”, “Dunajec DEM” and
        “TNP/TANAP borders” maps and choose to close them (only the maps will be closed,
        the layers will be still available in the project).
   5.   Click on the Window/Tile Horizontally menu to have a look at the DEM and
        Analytical Hillshading maps at the same time.
   6.   In the Data* tab, double click on the Analytical Hillshading layer and choose to add it
        to the “Tatra DEM” map. Now Analytical Hillshading is overlain on DEM.
   7.   In the Data* tab click on the Analytical Hillshading layer. In the Display Options set
        Transparency to 100%. It will be on the top of DEM but transparent for the time
        being. Click Apply.
   8.   Choose File – Project/Save Project.

STEP 5: Displaying peaks in the Tatra Mountains

   1.   Choose the File – Shapes/Load shapes menu and then “Tatry peaks.shp”. The
        shapefile identifies selected peaks in the Tatra Mountains.


               The Cascadoss Project is financed by the European Commission                  5
               under the Sixth Framework Programme
                                     Evaluating Free and Open Source Software for
                                Geospatial (FOSS4G) for Environmental Applications


   2. In the Data* tab select “Tatry peaks.shp”, double-click it and choose to add it to “Tatra
      DEM” map.
   3. Close the “Analytical Hillshading” map. Leave only the “Tatra DEM” map displayed.
      Zoom out using the zooming tool and the right mouse button to fit the map to the
      display area.
   4. With the “Tatry peaks.shp” selected in the Data* tab, go to the Object Properties
      window and choose Display: Label, then change Label Attribute to Name and Font
      properties to bold, and finally click Apply.

STEP 6: Visibility analysis

   1.  A visibility (viewshed) analysis will be performed for selected points on the DEM of
       the Tatra Mountains.
   2. Choose the module Terrain Analysis – Lighting, Visibility (single point) [Interactive].
       Set the Grid system by selecting 75; 781x371y; 396525x 5437100y from the drop-
       down list, then choose “Tatra DEM” as the elevation grid. Choose “Create” to create
       Visibility. Set Height (eyesight height of the observer above the DEM) to 2 m, and
       Unit: Visibility. Click OK.
   3. A new, blank (completely black) Visibility data layer is created. In the Data* tab
       double-click it and choose to add it to the display as a new map.
   4. Click on the Window/Tile Horizontally menu to have the “Tatra DEM” map and the
       blank “Visibility” map shown on the display at the same time.
   5. Note that the module is now working in the interactive mode. This is indicated by a
       small tick which is visible next to the module’s name when you open the Modules
       menu.
   6. Click on the Tatra DEM in the Data* tab. Now, using “action” tool, click on the
       selected points of “Tatra DEM”. The Visibility map is interactively updated, revealing
       (in white) areas visible (within the range of “cyber-view”☺) from the selected points
       on DEM. You can click on different points on DEM to see the differences in visibility
       ranges at these points. Note that sometimes it is better to zoom in on the DEM and
       then precisely choose the desired point, since sometimes landforms having different
       elevations (like peak or depression) may be located very close to each other and it is
       easy to make a mistake when trying to choose a peak.
   7. Finally decide on one specific point – one of the peaks indicated – to create a visibility
       map for that peak. Zoom in on the DEM to be sure you select the right peak (peaks are
       in bright shade on the grid; the actual DEM peak you want to choose may be a bit
       apart from the peak indicated by a point in the shapefile).
   8. Click on the selected observation point (peak) on the DEM map. The Visibility data
       layer is updated. Visible areas receive a value of 1 (white color), while invisible areas
       receive a value of 0 (black color).
   9. Edit the display options of the Visibility map. Click on the Visibility data layer in the
       Data* tab. In the Object Properties window, change black color to white and white to
       red (you have to set the colors in the window that appears when you click on Colors).
       Click OK and Apply.
   10. Terminate execution of the Visibility module (un-check it in the Modules menu).
   11. Click on the Maps* tab. Rename the final visibility map as “Visibility”.
   12. Save the project.



              The Cascadoss Project is financed by the European Commission                    6
              under the Sixth Framework Programme
                                      Evaluating Free and Open Source Software for
                                 Geospatial (FOSS4G) for Environmental Applications




STEP 7: 3D View

   1.   The final part of the exercise is 3D visualization.
   2.   First, in the Data tab, click on the Analytical Hillshading layer and set its transparency
        to 0%. Now it covers the DEM completely on the “Tatra DEM” map. Zoom out to see
        it, if needed.
   3.   In the Data* tab, double-click on the Visibility layer and choose to add it to the “Tatra
        DEM” map.
   4.   Maximize the “Tatra DEM” map.
   5.   Having Visibility layer selected in the Data* tab, in the Object Properties window, set
        the Transparency to 70% in the Display options, and click Apply.
   6.   Add the layer with borders of TNP/TANAP to the display. Double-click on
        “protected_areas.shp (Selected)” in the Data* tab and add it as a new layer to the
        “Tatra DEM” map.
   7.   In the Display options, set the Fill Style to Transparent; Outline Color to any color
        desired; Outline Size: 2, and click Apply.
   8.   Click on “Tatry_peaks.shp” in the Data* tab. In the Object Properties window
        deactivate the labels for the peaks by choosing [none] in the Display Label – Attribute.
        Change also the Display Size of the peak symbol: change the Default Size to 2. Click
        Apply.
   9.   Choose Map – Show 3D View. In the 3D View properties page, set the Grid system by
        selecting 75; 781x371y; 396525x 5437100y from the drop-down list, then choose
        “Tatra DEM” as the elevation grid. Check: Shift Left/Right: 0, Up/Down: 30, In/Out:
        160. Exaggeration: 4; Background color: any color desired. Click OK.




               The Cascadoss Project is financed by the European Commission                     7
               under the Sixth Framework Programme
                                  Evaluating Free and Open Source Software for
                             Geospatial (FOSS4G) for Environmental Applications


10. The DEM with analytical hillshading for the Tatra Mountains is now visualized in 3D.
    The borders of TNP and TANAP are visible, as well as the peaks and a viewshed from
    the selected observation point (peak).
11. Now it is possible to investigate changes in the 3D View, to rotate, zoom, shift, change
    properties if needed. The toolbar for 3D View, as well as the 3D View menu can be
    used for this purpose.
12. When you’re finished playing with the possible options, save the project and terminate
    the SAGA GIS application.




           The Cascadoss Project is financed by the European Commission                   8
           under the Sixth Framework Programme