Hola, Visual Basic

Document Sample
Hola, Visual Basic Powered By Docstoc
					       Realizado por:   MC Javier Hernán López Valdez                24/12/2009


Practica1 “Entorno de Programación
visual”
Cuando ejecute el programa de instalación de Visual Basic, le permitirá colocar los
elementos del programa en un grupo de programas ya existente o crear un nuevo grupo
de programas y nuevos elementos de programa para Visual Basic en Windows.
Entonces estará preparado para iniciar Visual Basic desde Windows.

3 formas para iniciar Visual Basic desde Windows

   1. Haga clic en Inicio en la barra de tareas.

   2. Seleccione Todos los Programas, luego Microsoft Visual Studio 6.0           y por
      último Microsoft Visual Basic 6.0.

   1. Haga clic en Inicio en la barra de tareas, Seleccione Programas.
   2. Utilice el Explorador de Windows para encontrar el archivo ejecutable de Visual
      Basic.

   1. Haga doble clic en el icono de Visual Basic.

También puede crear un acceso directo a Visual Basic y hacer doble clic en él.

Cuando inicie Visual Basic por primera vez, verá el entorno integrado de desarrollo,
como se muestra en la figura 1.1.

Figura 1.1 El entorno integrado de desarrollo de Visual Basic




                                                                                     1
       Realizado por:    MC Javier Hernán López Valdez                  24/12/2009

El entorno integrado de desarrollo de Visual Basic (IDE) consta de los siguientes
elementos.

Barra de menús
Presenta los comandos que se usan para trabajar con Visual Basic. Además de los
menús estándar Archivo, Edición, Ver, Ventana y Ayuda, se proporcionan otros menús
para tener acceso a funciones específicas de programación como Proyecto, Formato o
Depuración.

Menús contextuales
Contienen accesos directos a acciones que se realizan con frecuencia. Para abrir un
menú contextual, haga clic con el botón secundario del mouse en el objeto que está
usando. La lista específica de opciones disponibles en el menú contextual depende de la
parte del entorno en la que se hace clic con el botón secundario del mouse. Por ejemplo,
el menú contextual que aparece cuando hace clic con el botón secundario del mouse en
el cuadro de herramientas le permite mostrar el cuadro de diálogo Componentes, ocultar
el cuadro de herramientas, acoplar o desacoplar el cuadro de herramientas, o agregar
una ficha personalizada al cuadro de herramientas.

Barras de herramientas
Proporcionan un rápido acceso a los comandos usados normalmente en el entorno de
programación. Haga clic en un botón de la barra de herramientas para llevar a cabo la
acción que representa ese botón. De forma predeterminada, al iniciar Visual Basic se
presenta la barra de herramientas Estándar. Es posible activar o desactivar otras barras
de herramientas adicionales para modificar, diseñar formularios desde el comando
Barras de herramientas del menú Ver.

Las barras de herramientas se pueden acoplar debajo de la barra de menús o pueden
"flotar" si selecciona la barra vertical del borde izquierdo y la arrastra fuera de la barra
de menús.

Cuadro de herramientas
Proporciona un conjunto de herramientas que puede usar durante el diseño para colocar
controles en un formulario. Además del diseño del cuadro de herramientas
predeterminado, puede crear su propio diseño personalizado si selecciona Agregar ficha
en el menú contextual y agrega controles a la ficha resultante.

Para obtener más información Para aprender más acerca de los controles específicos,
vea "Formularios, controles y menús" y "Usar los controles estándar de Visual Basic".
Para obtener información acerca de cómo agregar controles al cuadro de herramientas,
vea "Agregar controles a un proyecto" en "Administrar proyectos".

Ventana Explorador de proyectos

                                                                                          2
       Realizado por:   MC Javier Hernán López Valdez               24/12/2009

Enumera los formularios y módulos del proyecto actual. Un proyecto es la colección de
archivos que usa para generar una aplicación.

Para obtener más información Para obtener información acerca de proyectos, vea
"Administrar proyectos".

Ventana Propiedades
Enumera los valores de las propiedades del control o formulario seleccionado. Una
propiedad es una característica de un objeto, como su tamaño, título o color.

Para obtener más información Para obtener información acerca de propiedades, vea
"Descripción de las propiedades, métodos y eventos" en "Formularios, controles y
menús".

Examinador de objetos
Enumera los objetos disponibles que puede usar en su proyecto y le proporciona una
manera rápida de desplazarse a través del código. Puede usar el Examinador de objetos
para explorar objetos en Visual Basic y otras aplicaciones, ver qué métodos y
propiedades están disponibles para esos objetos, y pegar código de procedimientos en su
aplicación.

Para obtener más información Para obtener más información acerca del uso del
Examinador de objetos para ver procedimientos, vea "Descripción de objetos" en
"Programar con objetos". Para obtener más información acerca del uso de
complementos para ampliar el entorno de programación de Visual Basic, vea "Usar
asistentes y complementos" en "Administrar proyectos".

Diseñador de formularios
Funciona como una ventana en la que se personaliza el diseño de la interfaz de su
aplicación. Agregue controles, gráficos e imágenes a un formulario para crear la
apariencia que desee. Cada formulario de la aplicación tiene su propia ventana
diseñador de formulario.

Para obtener más información Para aprender a agregar controles a una aplicación, vea
"Su primera aplicación con Visual Basic", más adelante en este mismo capítulo. Para
aprender más acerca del diseño de la interfaz, vea "Crear la interfaz de usuario".

Ventana Editor de código
Funciona como un editor para escribir el código de la aplicación. Se crea una ventana
editor de código diferente para cada formulario o módulo del código de la aplicación.

Para obtener más información Para aprender más acerca de cómo escribir código y el
uso del editor de código, vea "Fundamentos de programación".



                                                                                     3
       Realizado por:   MC Javier Hernán López Valdez                24/12/2009


Ventana Posición del formulario
La ventana Posición del formulario (figura 1.2) le permite colocar los formularios de su
aplicación utilizando una pequeña representación gráfica de la pantalla.

Figura 1.2 La ventana Posición del formulario




_________________________________             _________________________________

 MC Javier Hernán López Valdez                     FIRMA DEL ALUMNO (A)




                                                                                      4
        Realizado por:     MC Javier Hernán López Valdez                24/12/2009


Práctica 2 “primer programa visual”
Hay tres pasos principales para crear una aplicación en Visual Basic:

   1. Crear la interfaz.

   2. Establecer propiedades.

   3. Escribir el código.

Para ver cómo se realiza esto, siga los pasos del siguiente procedimiento para crear una
aplicación sencilla que consiste en un cuadro de texto y un botón de comando. Cuando
haga clic en el botón de comando aparecerá el mensaje "!Hola, mundo!" en el cuadro de
texto.

Crear la interfaz
Los formularios son la base para crear la interfaz de una aplicación. Puede usar
formularios para agregar ventanas y cuadros de diálogo a la aplicación. También puede
usarlos como contenedores de elementos que no son parte visible de la interfaz de la
aplicación. Por ejemplo, puede tener un formulario en su aplicación que sirva como
contenedor para gráficos que quiera presentar en otros formularios.

El primer paso para generar una aplicación de Visual Basic consiste en crear los
formularios que van a ser la base de la interfaz de su aplicación. Después dibuje los
objetos que van a componer la interfaz en los formularios que ha creado. Para esta
primera aplicación, usaremos dos controles del cuadro de herramientas.

Botón                            Control

                                 Cuadro de texto

                                 Botón de comando



Para dibujar un control mediante el cuadro de herramientas

   1. Haga clic en la herramienta del control que ha elegido dibujar; en este caso el
      cuadro de texto.

   2. Mueva el puntero dentro del formulario. El puntero adoptará la forma de cruz,
      como se muestra en la figura 2.3.

        Figura 2.3 Dibujar un cuadro de texto con el cuadro de herramientas




                                                                                      5
       Realizado por:   MC Javier Hernán López Valdez                 24/12/2009




   3. Coloque la cruz donde quiera que aparezca la esquina superior izquierda del
      control.

   4. Arrastre la cruz hasta que el control tenga el tamaño deseado. (Arrastrar
      significa mantener presionado el botón primario del mouse mientras mueve un
      objeto con el mouse.)

   5. Suelte el botón del mouse.

       El control aparecerá en el formulario.

Otra forma sencilla de agregar un control a un formulario es hacer doble clic en el botón
de ese control en el cuadro de herramientas. Esto crea un control con un tamaño
predeterminado situado en el centro del formulario; ahora puede mover el control a otra
ubicación del formulario.

Cambiar el tamaño, movimiento y bloqueo de controles

Observe que en las esquinas del control aparece unos pequeños cuadros rectangulares
llamados controladores de tamaño; en el siguiente paso usará estos controladores para
cambiar el tamaño del control. También puede usar el mouse, el teclado y comandos de
menú para mover controles, bloquear y desbloquear la posición de los controles, y
ajustar sus posiciones.

Para cambiar el tamaño de un control

   1. Seleccione el control que quiera cambiar el tamaño; para ello, haga clic en él con
      el mouse.

       Aparecerán en el control los controladores de tamaño.

   2. Sitúe el puntero del mouse en un controlador de tamaño y arrástrelo hasta que el
      control tenga el tamaño elegido.

       Los controladores de las esquinas cambiarán el tamaño de controles horizontal y
       verticalmente, mientras que los controladores de los lados cambiarán el tamaño
       sólo en una dirección.

                                                                                       6
       Realizado por:    MC Javier Hernán López Valdez                24/12/2009

   3. Suelte el botón del mouse.

       –o bien–

       Use MAYÚS con las teclas de dirección para cambiar el tamaño del control
       seleccionado.

Para mover un control

      Use el mouse para arrastrar el control a otra ubicación del formulario.

       –o bien–

       Use la ventana Propiedades para cambiar las propiedades Top y Left.

Cuando seleccione un control, puede usar CTRL con las teclas de dirección para mover
el control una unidad de la cuadrícula cada vez. Si la cuadrícula está desactivada, el
control se mueve un píxel cada vez.

Para bloquear la posición de todos los controles

      En el menú Formato, elija Bloquear controles.

       –o bien–

       Haga clic en el botón Alternar bloqueo de controles de la barra de herramientas
       Editor de formularios.

Esto bloqueará todos los controles del formulario en sus posiciones actuales, de forma
que no los podrá mover accidentalmente una vez que estén en la ubicación deseada. Se
bloquearán los controles sólo en el formulario seleccionado; los controles de otros
formularios no se ven afectados. Es un comando de alternar, por lo que puede usarlo
también para desbloquear las posiciones de los controles.

Para ajustar la posición de controles bloqueados

      Puede "arrastrar" el control que tiene el enfoque si presiona la tecla CTRL y la
       tecla de dirección adecuada.

       –o bien–

       Puede cambiar las propiedades Top y Left del control en la ventana Propiedades.

Ya tiene la interfaz de la aplicación "¡Hola, mundo!", como se muestra en la figura 2.4.

Figura 2.4 La interfaz de la aplicación "¡Hola, mundo!"




                                                                                           7
       Realizado por:   MC Javier Hernán López Valdez                 24/12/2009




Establecer propiedades
El siguiente paso consiste en establecer las propiedades de los objetos que ha creado. La
ventana Propiedades (figura 2.5) proporciona una manera fácil de establecer las
propiedades de todos los objetos de un formulario. Para abrir la ventana Propiedades,
elija el comando Ventana Propiedades del menú Ver, haga clic en el botón Ventana
Propiedades de la barra de herramientas o utilice el menú contextual del control.

Figura 2.5 La ventana Propiedades




La ventana Propiedades consta de los siguientes elementos:

      Cuadro del objeto: presenta el nombre del objeto para el que puede establecer
       propiedades. Haga clic en la flecha situada a la derecha del cuadro Objeto para
       presentar la lista de objetos del formulario actual.

      Fichas de orden: elija entre una lista alfabética de propiedades o una vista
       jerárquica dividida en categorías lógicas, como las que tratan de la apariencia,
       fuentes o posición.




                                                                                       8
        Realizado por:    MC Javier Hernán López Valdez                24/12/2009

        Lista de propiedades: la columna de la izquierda presenta todas las propiedades
         del objeto seleccionado. Puede modificar y ver los valores en la columna de la
         derecha.

Para establecer propiedades desde la ventana Propiedades

   1. En el menú Ver, elija Propiedades o haga clic en el botón Propiedades de la
      barra de herramientas.

         La ventana Propiedades presenta los valores del formulario o control
         seleccionado.

   2. En la lista Propiedades, seleccione el nombre de una propiedad.

   3. En la columna de la derecha, escriba o seleccione el nuevo valor de la propiedad.

         Las propiedades enumeradas tienen una lista predefinida de valores. Puede
         presentar la lista si hace clic en la flecha hacia abajo que hay a la derecha del
         cuadro Valores o puede recorrer la lista haciendo doble clic en un elemento de la
         lista.

En el ejemplo "¡Hola, mundo!" necesitará cambiar los valores de tres propiedades. Use
el valor predeterminado para las demás propiedades.

       Objeto                   Propiedad               Valor

       Form                     Caption                 ¡Hola, mundo!

       TextBox                  Text                    (Vacío)

       CommandButton            Caption                 Aceptar



Establecer la propiedad Icon

Todos los formularios en Visual Basic tienen un icono genérico predeterminado que
aparece cuando minimiza ese formulario. Sin embargo, probablemente cambiará este
icono por uno que ilustre el uso del formulario en su aplicación. Para asignar un icono a
un formulario, establezca la propiedad Icon para ese formulario. Puede usar iconos de
32 x 32 píxeles que eran estándar en las versiones de Microsoft Windows de 16 bits y
que se utilizan también en Windows 95 y Windows NT, así como los iconos de 16 x 16
píxeles empleados en Windows 95.

Escribir código
La ventana Editor de código es el lugar donde escribe el código de Visual Basic para su
aplicación. El código consta de instrucciones del lenguaje, constantes y declaraciones.
Mediante la ventana Editor de código puede ver y modificar rápidamente el código de
su aplicación.


                                                                                        9
       Realizado por:   MC Javier Hernán López Valdez                 24/12/2009

Para abrir la ventana Código

      Haga doble clic en el formulario o el control para el que desea escribir código.

       –o bien–

       En la ventana Explorador de proyectos, seleccione el nombre de un formulario o
       un módulo y elija Ver código.

La figura 2.6 muestra la ventana Editor de código que aparece cuando hace doble clic en
el control botón de comando y los eventos de ese comando.

Figura 2.6 La ventana Editor de código




Puede elegir presentar todos los procedimientos en la misma ventana Código o
presentar un único procedimiento cada vez.

Para presentar todos los procedimientos en la misma ventana Código

   1. En el menú Herramientas, seleccione Opciones.

   2. En la ficha Editor del cuadro de diálogo Opciones, active la casilla de
      verificación situada a la izquierda de Ver módulo completo de forma
      predeterminada. La casilla de verificación a la izquierda de Separador de
      procedimientos agrega o quita una línea separadora entre los procedimientos.

       –o bien–

       Haga clic en el botón Ver módulo completo en la esquina inferior izquierda de la
       ventana Editor de código.

Para presentar un procedimiento cada vez en la ventana Código

   1. En el menú Herramientas, seleccione Opciones.




                                                                                          10
        Realizado por:   MC Javier Hernán López Valdez                24/12/2009

   2. En la ficha Editor del cuadro de diálogo Opciones, desactive la casilla de
      verificación que hay a la izquierda de Ver módulo completo de forma
      predeterminada.

        –o bien–

        Haga clic en el botón Ver procedimiento en la esquina inferior izquierda de la
        ventana Editor de código.

La ventana Código incluye los siguientes elementos:

       Cuadro de lista Objeto: presenta el nombre del objeto seleccionado. Haga clic en
        la flecha de la derecha del cuadro de lista para presentar una lista de todos los
        objetos asociados con el formulario.

       Cuadro de lista Procedimiento: enumera los procedimientos o eventos de un
        objeto. El cuadro presenta el nombre del procedimiento seleccionado, en este
        caso Click. Elija la flecha que hay a la derecha del cuadro para presentar todos
        los procedimientos del objeto.

Crear procedimientos de evento

El código en una aplicación de Visual Basic se divide en bloques menores llamados
procedimientos. Un procedimiento de evento, como los que creará aquí, contiene código
que se ejecuta cuando se produce un evento (como cuando un usuario hace clic en un
botón). Un procedimiento de evento de un control combina el nombre real del control
(especificado en la propiedad Name), un carácter de subrayado (_) y el nombre del
evento. Por ejemplo, si quiere que un botón de comando llamado Command1 invoque
un procedimiento de evento cuando se haga clic en él, utilice el procedimiento
Command1_Click.

Para crear un procedimiento de evento

   1. En el cuadro de lista Objeto, seleccione el nombre de un objeto del formulario
      activo. (El formulario activo es el formulario que actualmente tiene el enfoque.)

        Para este ejemplo, elija el botón de comando, Command1.

   2. En el cuadro de lista Procedimiento, seleccione el nombre de un evento del
      objeto seleccionado.

        Aquí, el procedimiento Click ya está seleccionado puesto que es el
        procedimiento predeterminado para un botón de comando. Observe que ahora se
        presenta en la ventana Código una plantilla para el procedimiento de evento.

   3. Escriba el siguiente código entre las instrucciones Sub y End Sub:
   4.     Text1.Text = "¡Hola, mundo!"

        El procedimiento de evento debería parecerse a éste:



                                                                                      11
       Realizado por:   MC Javier Hernán López Valdez               24/12/2009

       Private Sub Command1_Click ()
          Text1.Text = "¡Hola, mundo!"
       End Sub

Observará que aquí el código simplemente cambia la propiedad Text del control
llamado Text1 para que sea "¡Hola, mundo!". La sintaxis de este ejemplo tiene el
formato objeto.propiedad, donde Text1 es el objeto y Text la propiedad. Puede usar esta
sintaxis para cambiar los valores de las propiedades de cualquier formulario o control
como respuesta a los eventos que se producen mientras se ejecuta su aplicación.

Para obtener más información Para obtener información acerca de la creación de otros
tipos de procedimientos, vea "Introducción a los procedimientos" en "Fundamentos de
programación".

Ejecutar la aplicación
Para ejecutar la aplicación, elija Iniciar en el menú Ejecutar, haga clic en el botón
Iniciar de la barra de herramientas o presione F5. Haga clic en el botón de comando que
ha creado en el formulario y verá cómo aparece "¡Hola, mundo!" en el cuadro de texto.




_________________________________             _________________________________

   MC Javier Hernán López Valdez                    FIRMA DEL ALUMNO (A)




                                                                                    12
       Realizado por:    MC Javier Hernán López Valdez                      24/12/2009


Práctica 3 “Minicalculadora”
En este ejemplo se muestra una calculadora elemental que permite hacer las cuatro
operaciones aritméticas (Figura 3.1). Los ficheros de este proyecto se pueden llamar
minicalc.vbp y minicalc.frm.
El usuario introduce los datos y clica sobre el botón correspondiente a la operación que
desea realizar, apareciendo inmediatamente el resultado en la caja de texto de la
derecha.




                           Figura 3.1 Minicalculadora elemental

La Tabla 3.1 muestra los objetos y las propiedades más importantes de este ejemplo.




                  Tabla 3.1 Objetos y propiedades del ejemplo minicalculadora

A continuación se muestra el código correspondiente a los procedimientos que
gestionan los eventos de este ejemplo.

Option Explicit

Private Sub cmdDiv_Click()
 txtResult.Text = Val(txtOper1.Text) / Val(txtOper2.Text)
 lblOp.Caption = "/"
End Sub

Private Sub cmdProd_Click()
 txtResult.Text = Val(txtOper1.Text) * Val(txtOper2.Text)
 lblOp.Caption = "*"
End Sub

Private Sub cmdResta_Click()
 txtResult.Text = Val(txtOper1.Text) - Val(txtOper2.Text)
 lblOp.Caption = "-"
End Sub


                                                                                         13
       Realizado por:   MC Javier Hernán López Valdez               24/12/2009




Private Sub cmdSuma_Click()
 txtResult.Text = Val(txtOper1.Text) + Val(txtOper2.Text)
 lblOp.Caption = "+"
End Sub


En este ejemplo se ha utilizado repetidamente la función Val() de Visual Basic. Esta
función convierte una serie de caracteres numéricos (un texto formado por cifras) en el
número entero o de punto flotante correspondiente. Sin la llamada a la función Val() el
operador + aplicado a cadenas de caracteres las concatena, y como resultado, por
ejemplo, “3+4” daría “34”. No es lo mismo los caracteres “1” y “2” formando la cadena
o string “12” que el número 12; la función val() convierte cadenas de caracteres
numéricos –con los que no se pueden realizar operaciones aritméticas- en los números
correspondientes –con los que sí se puede operar matemáticamente-. Visual Basic 6.0
transforma de modo automático números en cadenas de caracteres y viceversa, pero este
es un caso en el que dicha transformación no funciona porque el operador “+” tiene
sentido tanto con números como con cadenas.




_________________________________             _________________________________

   MC Javier Hernán López Valdez                    FIRMA DEL ALUMNO (A)




                                                                                    14
       Realizado por:   MC Javier Hernán López Valdez                     24/12/2009


Práctica 4 “Unidades de Temperatura”
La Figura 4.1 muestra un programa sencillo que permite ver la equivalencia entre las
escalas de temperaturas en grados centígrados y grados Fahrenheit. Los ficheros de este
proyecto se pueden llamar Temperat.vbp y Temperat.frm.

En el centro del formulario aparece una barra de desplazamiento vertical que permite
desplazarse con incrementos pequeños de 1º C y grandes de 10º C. Como es habitual,
también puede cambiarse el valor arrastrando con el ratón el cursor de la barra.
Los valores máximos y mínimo de la barra son 100º C y -100º C.
A ambos lados de la barra aparecen dos cuadros de texto (color de fondo blanco) donde
aparecen los grados correspondientes a la barra en ambas escalas. Encima aparecen dos
rótulos (labels) que indican la escala de temperaturas correspondiente. Completan la
aplicación un botón Salir que termina la ejecución y un menú File con la única opción
Exit, que termina asimismo la ejecución del programa.




                             Figura 4.1 Equivalencia de temperatura.

La Tabla 4.1 indica los controles utilizados en este ejemplo junto con las propiedades y
los valores correspondientes.




                     Tabla 4.1 Controles y propiedades de la practica 3




                                                                                       15
       Realizado por:    MC Javier Hernán López Valdez                 24/12/2009

Por otra parte, el código con el que este programa responde a los eventos es el contenido
en los siguientes procedimientos:

Option Explicit

Private Sub cmbSalir_Click()
 Beep
 End
End Sub

Private Sub mnuFileExit_Click()
 End
End Sub

Private Sub vsbTemp_Change()
 txtCent.Text = vsbTemp.Value
 txtFahr.Text = 32 + 1.8 * vsbTemp.Value
End Sub

Sobre esta cuarta práctica se puede comentar lo siguiente:

1. Se ha utilizado la propiedad Value de la barra de desplazamiento, la cual da el valor
actual de la misma con respecto a los límites inferior y superior, previamente
establecidos (-100 y 100).
2. Mediante el procedimiento cmdSalir_Click, se cierra el programa, gracias a la
instrucción End. El cometido de Beep no es otro que el de emitir un pitido a través del
altavoz del ordenador, que indicará que en efecto se ha salido del programa.
3. La función mnuFileExit_Click() y activa desde el menú y termina la ejecución sin
emitir ningún sonido.
4. Finalmente, la función vsbTemp_Change() se activa al cambiar el valor de la barra de
desplazamiento; su efecto es modificar el valor de la propiedad text en las cajas de texto
que muestran la temperatura en cada una de las dos escalas.




_________________________________              _________________________________

   MC Javier Hernán López Valdez                      FIRMA DEL ALUMNO (A)



                                                                                       16
   Realizado por:   MC Javier Hernán López Valdez   24/12/2009


Práctica 5 “Uso de Arreglos”




                                                                 17