Lab Instructions - DOC by azadf8w

VIEWS: 117 PAGES: 5

									Lab Instructions
Lab 4, due 7:00 pm October 6, 2008
EES5053/GEO4093: Remote Sensing, UTSA

Student Name: ___________________




Digital Image Processing I: Atmospheric Correction, Radiance, Reflectance,
                        NDVI from Landsat Image



Objective: In this lab, you will learn something about overlaying a vector file on an
image, creating Region of Interest (ROI), making a mask based on ROI, and doing a
simple atmospheric correction (DOS).

Part I: Concepts and short questions:
Refraction;

Atmospheric scattering;

Absorption and major atmospheric windows for remote sensing on Earth surface;

Reflectance, spectral reflectance, albedo;

Explain why we see blue sky in middle day and why we see orange and red sky in sunset or sunrise;

Solid angle and radiance;

Explain why we need to do atmospheric correction in land and ocean remote sensing;

Part II

1. Preparation:
   (1). Copy the data directory Lab4 in the server (\\129.115.25.240\XIE_misc\Fall08-RS\) into your
   local computer under c:\UserData_ENVI\yourname. Please always remember to output your results to
   your lab directory (i.e. Lab4 for today’s lab) not to the default ENVI directory.

    (2). Today we will use a new ETM+ image (p27r40_July8_2002.img). Open this image as R(b7),
   G(b4), B(b2) for Display 1 and R(b3), G(b2), B(b1) for Display 2. This is the image acquired on July
   8, 2002, just after the big flood event of 2002. The July 2002 floods in south Texas resulted from
   unprecedented precipitation rates in excess of 3 inches per hour, much like a tropical system, which
   resulted in 9 deaths, and over 48,000 homes and nearly one billion dollars in damage. In the
   succeeding labs, you will classify and compute the flooding areas.


                                                                                                          1
2. Get a sense of the image
Open the image in ENVI. You can see this image has the same coordinate system as the image you used
for Lab 2 and 3, but in different year and time. Two big differences, however, are (1) this image include
band 6, the thermal band (11.45 μm), which will provide you the temperature information of each pixel
(we will use it later in another lab); and (2) this image is the entire scene of a ETM+ image about 180 km
x 180 km in dimension, while the image you used in Labs 2 and 3 was a subscene of a entire scene.

Now, load RGB (742) in Display 1 and RGB (321) in Display 2. Link the two images, using Link
Display. San Antonio is in the upper left portion of the image. The figure below shows you a vector layer
(highway) overlaying on top of the RGB (742) image, indicating the location of San Antonio.




                                                                                    Figure 1

To open a vector layer, you can simply from Vector in the ENVI Main Menu or from Overlay in the
Main window of your display image. Let’s do it from the Main window. Click Overlay -> Vectors, a new
window of Vector Parameter is opened. Go to File -> Open Vector File, under the Lab4, you should select
road-UTM_.evf, which is highway vector file in ENVI vector file format. Click OK, you should see the
vector file overlaying on the image.

Question 1: explore the image and give a general interpretation about what you see from the image, for
example, water (flooding), clouds, vegetation, …and their color differences in 742 image and in 321
image.

3. Use Region of Interest (ROI) tool and make a mask


                                                                                                             2
From the above figure 1, you can see there is a dark area surrounding your image. If you use the Cursor
Location/Value tool, you will find pixel values of the area are zero. So if you want to do statistics or
further image processing, you should exclude this area. One way to do this is to make a mask to exclude
the dark area for further processing.

Step 1, from the Main window, click Overlay-> Region of Interest, a ROI tool window is opened. Use this
tool, you can build a ROI where only cover the image area not the dark area outside the image. Use the
default setting in the ROI_Type, i.e. a polygon type. The polygon can draw either from the Image, Scroll,
or the Zoom window. In this exercise, you do not need to use the Zoom, so you can either select the
Image or the Scroll. Figure 2 is my ROI selected.




                                                                      Figure 2

Step 2. from the ENVI Main Menu, click Basic Tools -> Masking -> Build Mask, a new window call
Mask Definition is opened. In this window, Click Options -> Import ROIs, select the ROIs you just did.
Enter output filename: mask.img and save to your Lab4 directory. Click Apply, the Mask.img should
appear in the Available Bands List window. Open the mask image into Display Window 3.

Question 2. Show your mask image and show the pixel values of the mask image. What this value
means?

Question 3. Do a statistic on your ETM+ image, using the mask.img to exclude the dark area surrounding
the image. And show the statistics of the image. The figure 3 is an example I did based on my mask. Your
mask might differ from my mask, so your statistics might be different from what I have.




                                                                                                           3
                                                                   Figure 3

4. Atmospheric Correction
In the lectures, you learn a lot about the interactions between atmosphere and EMR. And you know that
the remotely sensed radiance includes two parts: one from the target area (which is what we want), the
other one is from the path (path radiance, which is what we do not want). The process to remove the
path radiance is called atmospheric correction. There are two types of atmospheric corrections: (1)
absolute atmospheric correction: radiative transfer-based atmospheric correction and empirical line
calibration and (2) relative radiometric correction: Dark Object Subtraction (DOS) and multiple-data
image normalization using regression. In this lab, we will do a simple DOS correction.

The principals of DOS includes (1) find the darkest object in the image; (2) assume that its spectral
reflectance should be all zero (target radiance); (3) the measured values above zero are assumed to be the
atmospheric noise (or path radiance) and uniformly distributed on the image area; (4) subtract the path
radiance from each pixel radiance of the image, then we should get a relatively atmospheric free image.
Usually these dark objects are water bodies (see below figure 4, the fresh water has very low reflectance,
meaning water absorbing most of light, especially after 0.75 µm).




                                                                                                        4
       Figure 4. Spectrum signature of different objects

        In ENVI, the DOS is called Dark Subtract, in the ENVI Main Menu, click Basic Tool -> Preprocessing ->
General Purpose Utilities -> Dark Subtract -> select your ETM+ image as the input file, click OK. A new
window called Dark Subtraction Parameters opened. Click the User Value. The default minimum value for each
band is 0, but for your image, you need to use the minimum values you just got from question 3 (similar as figure
3). Save the corrected image as p27r40_July8_2002DOS.img

Question 4: Show the statistics of your new image, using the same mask image (mask.img) you created
before.




                                                                                                               5

								
To top