Docstoc

How to build a VISITview Lession

Document Sample
How to build a VISITview Lession Powered By Docstoc
					Anthony Mostek – NOAA National Weather service and Tom Whittaker

Today‟s training
• Objective: prepare and teach teletraining lessons using VISITview
– background – overview – hands-on

• Requirements:
– basic DOS experience – Power Point, Corel Draw or something similar – Windows 98, 2000, NT, or XP computer (LINUX or MACS can be used)

VISITview Project
VISITview: teletraining / distance-learning / collaboration software aimed at the meteorological community

• History:
– Initiated 1998-1999 – Four programmers have contributed – Feedback from instructors directs changes

• Goals:
– Complement other training aids – Continue to evolve as needs are identified

VISITview Overview
• Modes
– pre-loaded lessons – via a browser (VISITview RAMSDIS Online)

• Participants
– master (instructor) – student – listener

• Client/server • Not a slide preparation tool

VISITview Terminology
• • • • Lesson – a collection of pages Page – one or more frames Frame – a single image (GIF or JPEG) Client/server – commands are initiated by the client; the VISITview server redistributes commands

• http://www.ssec.wisc.edu/visitview/terminology.html

VISITview Client-Server
• Training Sessions
– the Lesson is downloaded to your local computer before the scheduled session – the server is used to distribute the “small” commands to everyone (move pointer, turn to next page, draw text and animations, etc.)

• VISITview RAMSDIS Online
– all images are downloaded in real time from the server – the server is also used to distribute the “small” commands to everyone (move pointer, turn to next page, draw text and animations, etc.)

The Student‟s view
• Download a lesson
– make a directory, ftp the file, „run‟ it – (use a browser for VISITview RAMSDIS Online)

• Voice connection - set up a conference call via phone or yahoo messenger • Basic mechanics (“knobology”) • Starting up a session
– convenience batch files

Features for students and instructors
• Big Red Pointer
– positioning (click) – drawing
• drag for line • SHIFT+CTRL+drag for box

• On - screen help
– open (ALT+?) (in English) – close (any other key)

– change color using choice box
Help pop-up

Annotations – drawing and text
To draw free-hand, just “drag” mouse – press button and hold while moving; when you release button, drawing is sent To draw a box, hold SHIFT+CTRL and “drag” the mouse To do text, click ALT+T. A | cursor will appear. Type your text. Move it around. Change color. Press “enter” to send it to everyone (press ESC to abandon)

Animation Controls
Change color
Animate or stop Loop or Rock mode Change animation speed

Erase all

Manually set frame or fade Fade mode on/off Toggle between last two frames Single step back (<) or forward (>)

Labels are dim – example of “disabled” controls

User ID and “chat”
To initiate a chat window – ALT+C Enter a user or site ID and hit the “submit” button

Chat client window – resizable. All chatting is public – everyone sees everything.

Write here.

Other features
• Zooming – pixel replication • Enhancements – colorizing images on-thefly • Portals - frame within a frame
– 4 panels emulation – showing “large” frames

• Overlays available

From the Instructor‟s viewpoint
• Creating a lesson: your slides and the Builder • Packaging and testing • Distribution • Doing a lesson

Page and Enhancement Controls
Shows frame number and label / Select page to show Load the selected page

Get client/student status of last load
Load previous page

Load next page
Choose an enhancement to apply to the current page

When beginning, hit Next to load first page

Appears red when you have NOT loaded a selected page yet

Creating a lesson
• • • • • make your slides use the VISITview Lesson Builder check your lesson distribute your lesson run a session

Make your slides
• • • • Use Power Point Pages consist of one or more frames Each frame is a single GIF or JPEG image Image size determines VISITview window size • 640X480 is good • Portals and other issues

Use the VISITview Lesson Builder
• Start the builder (visitbuild.bat or from start/All programs/VISITview Lesson Builder) • Use “browse” to gather and organize your pages • Put labels on each page • Use “file => move” to move things around • Use “save lesson” to save it into a ZIP file

Edit menu File menu

The builder interface
Labels for pages URL for linked text or audio

Initial Big Red Pointer position
Slide through page or frame Insert Append

Page and frame thumb nails View pages, frames, portals, or overlays Browse directory and files

Append all
Browse thumbnail

File menu
Open an existing lesson in a ZIP file Start a new lesson
Save the work as a zip file

Browse for images in a directory Make an image from a URL
Import Presentation Make a Windows .EXE file drom a .ZIP file

Unzip File Exit (if changes, ask to save)

Edit Menu
Undo previous Move or Delete or Insert or Append To move page or frame: 1. select page/frame to move 2. click this Move item 3. click on destination page/frame

Copy/Delete secected page or frame

Browse for images
Insert thumbnail at selected position Append thumbnail to end (of pages or frames) Browse directories to find file names

Append all

Hints, cues, messages

Current directory

Filenames appear here when you browse. **Click to select one file **CTRL+Click to toggle one or more image files. **SHIFT+Click to select a range of files

Thumbnail of last selected file (click so see original size image)

Organize Pages and Frames
Initial red pointer position Type in page label
Page selected (magenta border)

# frames on this page

Type in linked URL or audio filename If there are frames for a loop, check to have them looping upon startup and set the speed

Original filename Slide through pages/frames

Select page or frame view

Save Lesson and Set Parameters
Choose Save Lesson under file menu

Directory name Directory contents

Specifiy filename (name.zip)

Save Cancel

Essentially, accept the defaults.

Parameter details
• Height – height of window (frame size + 120 lines for controls (e.g. 480+120=600) • Width – width of window (frame size + 20 for borders (e.g. 640+20=660) • Server hostname – name of machine running VISITview server you want to use as a promary server (e.g. www.ssec.wisc.edu) • Alternate servers – name(s) of other machines running VISITview servers you use as backups (e.g. visit.cirs.colostate.edu) Entries here make alternate batch files.

Getting assistance with VISITview
• Home page on the web (in English) http://www.ssec.wisc.edu/visitview

• Contacts ?


				
DOCUMENT INFO
Shared By:
Categories:
Stats:
views:15
posted:10/17/2008
language:English
pages:25