Documents
Resources
Learning Center
Upload
Plans & pricing Sign in
Sign Out
Your Federal Quarterly Tax Payments are due April 15th Get Help Now >>

ARRET MACRO

VIEWS: 29 PAGES: 8

ARRET MACRO

More Info
									User Manual_V6


    “FUNDING MC”, AN EXCEL PROGRAM TO CALCULATE THE RESOURCES
        NEEDED FOR THE ROLL-OUT OF MEDICAL ADULT MASCULINE
                     CIRCUMCISION: USER MANUAL

Reference: Estimating the Resources Needed and Savings Anticipated from Roll-out of Adult
Male Circumcision in Sub-Saharan Africa. Bertran Auvert, Elliot Marseille, Eline L.
Korenromp, James Lloyd-Smith, Remi Sitta, Dirk Taljaard, Carel Pretorius, Brian Williams,
James G. Kahn. PLos One, In press.


1. First level of use : To Calculate the MAMC program costs with
   the values of the model parameters


After opening the Excel file, choose the first calculation sheet titled “Model” by clicking on
the blue tab “Model” at the bottom of the screen. “Funding of medical circumcisions” is
written in the first cell A1 in the upper left corner. The list of the 30 key input parameters is
on the left and the values of these parameters are in red in column C. The value for “duration
of funding period” is in cell C2.

We define:
                A scenario as an array of the 30 key input parameters with set values.
                A setting as a scenario which is specific to a region or country.

   How to draw up a scenario?
     You can change any red value in cells C2 to C34 by clicking on the corresponding cell
      and entering the new value. Then, type “Enter” or click on another cell.
      Warning: -When the value entered is not in the correct interval, an error message
                    appears. You have to click on “Try again” and enter a number from
                    within the interval recommended on the message.
                    -A warning message appears when you try to modify some cells that
                    should not be modified.
     In cell C25, you can choose either the private (0) or the public (1) health sector. If you
      choose “0”, only values concerning the private health sector (green cells) are
      considered and used for the computations. If you choose “1”, the values considered
      are in the grey cells.
     You can modify the “initial number of circumcisers” (in orange in cell C11), but after
      the activation of the computations this value is changed because it is automatically
      adjusted on the “duration to reach maximum male circumcision prevalence”.

 How to run the simulation?
Click on the button “RUN1” located in cells G29-30. This button activates the computations.
When it is finished, the message “Done” is indicated in cell F30. Until you click on “RUN1”
after inputting the values the computations are not activated and “Not done” is written in cell
F30.
Warning: A warning message about the “Macro security” may appear when you try to
            activate the computations (“RUN1”). In this case, in the menu, go to “Tools”,
            choose “Options”, click on the tab “Security” and then on the button “Macro



                                               -1-
User Manual_V6

           Security”. After a click on the tab “Security level”, choose the lower one and then
           click “ok”. You need to restart the Excel program for this modification to take
           effect. You will then be able to activate the computations.

 How to look at the outputs?
At the end of the computations, new results for each item of the “funding and impact of
funding” appear in blue in cells F3 to F22. When it is written “see graph x”, it means that the
results for this item are given as a graph which can be found on the sheet called “Graphs”.
 How to look at the graphs?
 To access the graph, just click on the blue tab “Graphs” at the bottom of the screen.

 How to look at the numeric values used to build the graphs?
The annual numeric values used to build the graphs are on the sheet titled “Data Graphs”.
Please note that these values are given per year even if the graph’s time unit is month.

 How to look at more detailed outputs?
Detailed outputs with results given for periods of different lengths are available in the
“Model” sheet in column J (yellow array).

 How to run a standard setting or scenario?
In the sheet “Input output” (orange tab), a set of 30 key input parameters are available for
each of the 16 settings which names are just above their set (cell F8, H8, J8…AJ8). To use
these data to calculate the required funding and the impact of funding in a specific setting,
you may copy the data concerning this setting (select data, then Ctrl+c or menu “Edition” /
Copy) and paste them (Ctrl+v or menu “Edition” / Paste) on the sheet “Model” in column C.
Then type “RUN1”. The blue values in column F are the results for the selected setting.

 How to save a set of key input parameters?
In order to save a set of key input parameters you can copy them from the sheet “Model”
(cells C2 to C34) and paste them in the sheet “Input output” in the place of another setting’s
data.


2. Second level of use : To Calculate the 95% Percentile Intervals of
   a setting or scenario

In order to obtain a 95% Percentile Intervals for obtained outputs use the sheet titled “Monte
Carlo” (yellow tab) .

 How to start the computations?
To start the computations, click on the button “Run Monte Carlo (1)”. The values used for
these computations are inputted in cells C2 to C34.
It is possible to delete previous results and computer calculations by clicking on “Clear Monte
Carlo”.

 How to look at the 95 % Percentile Intervals?
All of the 95% Percentile Intervals are listed in the yellow array located in columns L and N.

   How to import data in the “Monte Carlo” sheet?


                                             -2-
User Manual_V6

Copy the values of the model parameters in the sheet “Model” (cells C2 to C34) and paste
them from cell C2 on the sheet “Monte Carlo”.

 How to enter a conceivable percentage (%) of variation for each model parameter?
The value of the conceivable % of variation for each model parameter is in column H
(0.2=20%). You can modify these numbers.

 How to look at the interval obtained for each model parameter?
The values of the lower and upper bounds of the interval (calculated for each model parameter
with the value of the conceivable % variation chosen previously) are in columns E and F,
respectively.

 How to look at the randomly assigned value for each model parameter?
In column G, a value appears for each model parameter. This value is randomly assigned
from all the values included in the interval obtained previously (type F9 to see a sample of
randomly generated values).

 What does the number “n values” in cell I6 mean?
Before activating the computations, choose the number of values you believe necessary to
build a 95 % Percentile Interval and enter it in cell I6. This value is the number of random
draws that will be made. For each random draw, the values of the column G (values randomly
assigned for each model parameter) are used in the sheet “Model” in order to calculate new
outputs. At the end, we will obtain for each item of the “funding and impact of funding” as
many outputs as the number “n values” entered in I6. The 95% Percentile Intervals are built
from these outputs for each item (2.5%.of these outputs are lower than the lower bound of the
95% Percentile Interval, 2.5% are higher than the higher bound).

 What number is recommended for the “n values”?
It is recommended that the value entered in I6 be at least 100 in order to have accurate 95%
Percentile Interval estimates. The higher the number you choose, the more exact your
assessment will be but the procedure will take longer.



3. Third level of use: To calculate the outputs for both models
   (private and public) and for several settings or scenarios in one
   run


Use the sheet “Input Output”.

 How to select the settings that you are interested in?
Have a look at line 8 on the sheet called “Input Output”, where the names of the different
settings are listed in cells F8 to AJ8 (F8, H8, J8…AJ8). A number is associated with each
setting. Make a note of the setting numbers you are interested in. You can activate the
computations for consecutive settings numbers at the same time. Transfer the lower number
of the sequence of setting numbers in cell H2 and the higher in cell H3.




                                            -3-
User Manual_V6


 How to start the computations?
Click on the button “Run H2 to H3 private and public”. It will start the computations for the
settings selected.

 How to stop the computations before they are finished?
You can stop the computations whenever you want by pressing “Esc”. A message appears:
click on “End”. Then restart the Excel program in order to reset the software.

 How to look at the outputs for these settings?
The detailed outputs for these settings are located under their set of key input parameters from
line 53 to line 143. The outputs are given for both private (line 54 to 95) and public (line 102
to 143) models.

 How to add the outputs of other settings?
In order to obtain the results of all the settings that you are interested in on the same output
(i.e. adding the settings numbers that are not in a consecutive sequence), just restart the
computations, changing the number in cells H2-H3 without deleting the previously obtained
results.

 How to compare the outputs obtained for different scenarios?
Please note that all the explanations of the third level of use are based on the comparison of
several settings. However, instead of comparing different settings, it is also possible to
compare scenarios, obtained from modifying the input parameters of a specific setting (that is,
compare the outputs obtained from varying set of input parameters). To do so, copy a set of
input parameters for one setting and paste it in the place of another setting in the sheet “Input
Output” (see chapter 1, paragraph “How to save a set of key input parameters?”). Then just
use this new scenario it as if it was a new setting.

 How to delete last results?
If you don’t need previous outputs, you can delete them by clicking on “Clear Input Output”.



4. Fourth level of use: To calculate the 95% Percentile Intervals of
   the outputs of several settings or scenarios in one run

Use the sheet called “Monte Carlo”.

 How to select the settings or scenarios that you are interested in?
In cells E46-E47, enter the numbers of the settings for which you want to know the private
outputs 95% Percentile Intervals (lower number sequence in cell E46, higher number in cell
E47). Idem for cells F46-F47 and the numbers of the settings for which you want to know the
public outputs’ 95% Percentile Intervals.

 How to start the computations?
Click on the button “Run Monte Carlo (Private E46 to E47; Public F46 to F47)”.

   How to look at the detailed 95% Percentile Intervals outputs for these settings or
    scenarios?


                                              -4-
User Manual_V6

The Percentile Intervals obtained for these settings or scenarios are located on the sheet “Input
Output” under their set of key input parameters in the column “range”, either in lines 54 to 95
for the private model, or lines 102 to 143 for the public one.

 How to add the 95% Percentile Intervals of other settings or scenarios?
In order to obtain the results for all the settings or scenarios you require in the same output
(add the settings numbers which are not consecutive), do NOT click on “Clear Input output”
in the sheet “Input output” but restart the same computations with the new settings numbers
in the sheet “Monte Carlo”.




                                              -5-
User Manual_V6

                                    THE DIFFERENT SHEETS AND THEIR PURPOSE




                 SHEET            CONTENT                            BUTTON                    RESULTS OF THE
                                                                                                    MACRO
            Model          -Key Input Parameters          -Run (1)                        -Model
                           -Outputs                                                       -Graph
                           -Detailed outputs                                              -Data Graph
            Graphs         -Graph Results
            Data Graph     -Data used to build the
                           graphs
            Input Output   -Set of key input parameters   -Clear input output             Input output
                           for 16 settings                -Run H2 to H3 private and
                           -Results of “H2 to H3          public
                           private and public”
                           -Results of “Monte Carlo
                           (Private : E46 to E47;
                           Public F46 to F47)”
            Monte Carlo    -Results of “Monte Carlo       -Clear Monte Carlo              Monte Carlo
                           (1)”                           -Run Monte Carlo (1)            Input output
                                                          -Run Monte Carlo (Private :
                                                          E36 to E37 Public F36 to F37)




                                     -6-
User Manual_V6



                                          THE 30 KEY INPUT PARAMETERS


1. Duration of funding period                                       23. Private: Geographic setting level (communication,
2. Initial adult population in the geographic setting                   management, M&E)
3. Crude birth rate                                                 24. Private: Circumcision cost (inclusive)
4. Percent of newborns reaching adulthood                           25. Public: Geographic setting level (communication,
5. Life expectancy when becoming adult (without HIV)                    management, M&E)
6. Children circumcised before reaching adulthood                   26. Public: Initial investment per circumcision unit
7. Percent of males who will refuse circumcision                    27. Public: Number of circumcisers per circumcision unit
8. Duration to reach maximum male circumcision prevalence           28. Public: Initial training per circumciser
9. Initial number of circumcisers                                   29. Public: Salary of each circumciser
10. Number of circumcisions per day per circumciser                 30. Public: Circumcision cost (variable)
11. Number of working days per year
12. MC effect (reduction of female to male transmission)
13. Initial HIV prevalence among adults
14. Uncirc.male-to-female/f-to-uncirc.m transmissibility ratio
15. Percent of HIV(+) receiving treatment before ARV-eligible
16. Cost of this treatment (total)
17. Percent of HIV(+) eligible for ARVs who receive ARVs
18. Life expectancy on ARVs
19. Cost of ART (annual)
20. Percent of HIV(+) eligible for ARVs who receive non-ARV
    treatment
21. Cost of this treatment (total)
22. Discount rate (annual)




                                           -7-
User Manual_V6

  THE 23 FUNDING AND IMPACT OF FUNDING                                           THE 31 DETAILED OUTPUTS
            ITEMS: THE OUTPUTS

                                                                  1.    Cost 1-5
   1.    Circumcision prevalence (% of adult males)               2.    Average per year
   2.    Cumulative expenditure                                   3.    Cost 6-10
   3.    Discounted expenditure during the period                 4.    Average per year
   4.    If relevant, expenditure per year to maintain maximum    5.    Cost 1-10
         MC                                                       6.    Average per year
   5.    HIV incidence among adults (% of initial incidence)      7.    Cost 1-20
   6.    Number of annual HIV cases averted among adults over     8.    Average per year
         time                                                     9.    n circumcisers 1-5 (per year)
   7.    Cumulative number of HIV infections averted              10.   per 10 000 adults
   8.    Number of HIV infections averted per 100                 11.   n circumcisers 6-10 (per year)
         circumcisions                                            12.   per 10 000 adults
   9.    Cost per HIV infection averted                           13.   n circumcisers 11-20 (per year)
   10.   Annual number of AIDS cases averted among adults as      14.   per 10 000 adults
         a function of time                                       15.   Cumulative net cost at 10 years
   11.   Cumulative number of AIDS cases averted                  16.   Cumulative net cost at 20 years
   12.   Cumulative number of deaths averted (AIDS cases not      17.   Cumulative net cost at 30 years
         receiving ARVs)                                          18.   n circumcisions 1-5
   13.   Annual saving (expenditure minus cost of averted care)   19.   n circumcisions 6-10
   14.   Cumulative net cost (>0:expenses <0:saving)              20.   n circumcisions 1-10
   15.   Duration for financial breakeven                         21.   n circumcisions 1-20
   16.   Number of public circumcision units                      22.   n circumcisions 1-30
   17.   Initial number of medical circumcisers                   23.   Averted HIV 1-10
   18.   Initial number of medical circumcisers per 10 000        24.   Averted HIV 1-20
         adults                                                   25.   Averted HIV 1-30
   19.   Number of required medical circumcisers over time        26.   N circ to avoid 1 HIV 1-10
   20.   HIV prevalences (Females, Circ males, Uncirc males,      27.   N circ to avoid 1 HIV 1-20
         males)                                                   28.   N circ to avoid 1 HIV 1-30
   21.   Duration to reach maximum male circumcision              29.   Cost per HIV infection averted 1-10
         prevalence                                               30.   Cost per HIV infection averted 1-20
   22.   Initial HIV prevalence among adults                      31.   Cost per HIV infection averted 1-30
   23.   Reduction of HIV prevalence when 100% MC


                                                -8-

								
To top