Docstoc

tutorial Tutorial Create New Model 83 11 TUTORIAL CREATE NEW

Document Sample
tutorial Tutorial Create New Model 83 11 TUTORIAL CREATE NEW Powered By Docstoc
					Tutorial - Create New Model                                                                               83



11. TUTORIAL - CREATE
NEW MODEL
This tutorial is designed to lead the new user through
                                                         11.1 OVERVIEW
the features of GM-SYS. In it, we assume that the        Before we begin the step-by-step tutorial, let's stop
user has a basic understanding of the features of        and take a look at the steps we will use to create a
Windows or X-Windows. Most users will pick up            model. We will:
the basics very quickly, allowing them to manipulate
models and obtain a reasonable fit of the model re-       1) create a single block, extending from minus "in-
sponse to the data.                                          finity" (x=-30,000 km) to plus "infinity"
                                                             (x=+30,000 km), and to a specified depth (de-
The largest section of the tutorial leads the user           fault value: z=+50 km);
through the "Create New Model" procedure. Some            2) use a sample data file to import topography and
steps in that procedure may not be intuitively obvi-         observed gravity and magnetic data;
ous to the first-time user, but after having worked it    3) insert key geologic horizons extending from mi-
through once, it is relatively straight forward.




                                 Figure 11.1: Complete model SIMPLE2.

GM-SYS® v. 4.8
84                                                                     Tutorial - Create New Model
    nus infinity to plus infinity; and                     will also import topography, observed gravity data,
 4) create a detailed geologic model in the area of        and observed magnetic data and station elevations,
    interest that fits the observed data.                  although this is not required.

Steps 1 and 2 are performed using the New Model            To begin, start GM-SYS and click "OK" on the reg-
Creation dialog. Steps 3 and 4 are carried out using       istration screen; an empty Main Window will appear.
the mouse modes available in the Action Tool Box           Select New Model… from the File Menu (or click
or Action Menu. We will change views of the model          on the New Model icon at the left end of the Menu
to work first at the mega-scale, and finally at a de-      Tool Bar) to activate the New Model Creation dia-
tailed scale, looking at smaller portions of the model.    log, shown on the following page.

Our exercise will be to input a simple model with a        The New Model Creation dialog is partitioned into
basement high and overlying sediments, shown in            four sections. We will work with them in order of
Figure 11.1.                                               occurrence.

11.2 CREATE NEW MODEL                                      Cross-Section: Set the horizontal and depth extents
The "Create New Model" procedure will create the           for the model. For this exercise, the observed data
single block referred to in Step 1. In this tutorial, we   extend from 0 to 45 km along the profile and the




                                   Figure 11.2: New Model Creation dialog.

                                                                                         GM-SYS® v. 4.8
Tutorial - Create New Model                                                                                  85
model will extend from 0 to 50 km in depth. Enter
these values in the "Cross-Section" area of the dia-      1) Select the "File…" button to activate a file-se-
log, as shown in Figure 11.2.                                lection dialog and choose the file SIMPLE2.ASC
                                                             included with this tutorial. You will then be given
Azimuth/Strike Angles: An azimuth of 180° means              an opportunity to view the contents of the se-
that the profile goes from north to south, with the          lected file, as shown in Figure 11.4 on the fol-
plus X direction being due south (180° clockwise             lowing page.
from True North). The profile azimuth is not used in      2) Observe that there are seven lines of header in-
the gravity calculations, but must be entered correctly      formation prior to the beginning of the data in
if you intend to do magnetic modeling.                       this example, that all distances are supplied in
                                                             kilometers, and that Z-values are supplied as el-
In our example, the profile runs from south to north;        evations (positive upward), not as depths (posi-
i.e. the profile has an azimuth of 0º. Select the            tive downward). Also, the magnitude and di-
"Change" button and enter 0 in the Profile Azimuth           rection of the Earth's field at the time and loca-
field. We will accept the default relative strike of         tion of the survey is supplied in the header; listed
90º. That means that the strike direction will be 90°        as "Earth's field". You will need to supply this
from the direction of the profile. In our example,           information for your own magnetic modeling.
the strike is east-west.                                     Now click "OK" and return to the Import From
                                                             File dialog.
Topography, Gravity Stations, and Magnetics Sta-
tions: We will now import topography, gravity sta-
tions and magnetic stations from our sample data file.
Select the "Import From File" option in the Topogra-
phy sub-section. The dialog shown in Figure 11.3
will appear:




        Figure 11.3: Default values for the                     Figure 11.4: File viewer displaying
             Import from File dialog.                                    SIMPLE2.ASC.

GM-SYS® v. 4.8
86                                                                      Tutorial - Create New Model
  3) Now, select "+up" (elevations are positive) and        tical scale and limits on each pane to include all of
     enter "7" in the "Skip Lines" field. We will ac-       the data.
     cept the default units and default fields for X
     and Z (topo). Click "OK" to return to the New          By default, GM-SYS calculates and displays an "er-
     Model Creation dialog. Now go through the              ror curve" (calculated - observed) for the Gravity and
     same process for the Gravity Stations and Mag-         Magnetic panes. To hide these for now, you may
     netics Stations. Note that the second field (topo)     select the "Display" option from the same pop-up
     is also the appropriate field for gravity station      menus and toggle the display of the Gravity Error
     elevations (Z), but the "Z" field for Magnetics
     Stations will be "5" and the observed data (Obs)
     are in column 4.
Earth's Magnetic Field: You may now enter the val-
ues for the Earth's field strength and direction sup-
plied in the header (see Figure 11.4) by selecting the
"Change" button and filling in the appropriate fields.
Click "OK" to return to the New Model Creation dia-
log. If all of the settings are satisfactory, click "Cre-
ate".
                                                            and Magnetic Error curves off. They may be toggled
You should now have a new model on the screen like          on at any time by re-accessing these menus. If grid-
that shown in Figure 11.5, below.                           lines are present on your initial image, they may be
                                                            turned off in a similar fashion.
Click the right mouse button in each of the anomaly
panes to activate a pop-up menu and select "Auto            Now is a good time to save your newly-created
Scale". This function automatically adjusts the ver-        model.




                               Figure 11.5: Initial view of newly-created model.

                                                                                            GM-SYS® v. 4.8
Tutorial - Create New Model                                                                               87
11.3 TYING TO INFINITY
                                                        or,
The next step in entering the model from Figure 11.1
is to enter the surfaces that extend from one side of   2) Use the scroll bar on the right side of the cross-
the model to the other. In our example, there are       section pane to modify the range. Dragging the ends
two such surfaces: the top of the "Basement" block,     of the white box changes the range within the pane,
and the horizon between "Upper Sediments" and           and dragging the middle of the box shifts the view
"Lower Sediments". Both of these horizons should        upward or downward without rescaling.
be extended to "Infinity" to remove edge-effects in     You should now see a view of the model similar to
our calculations.                                       that shown below:

Select the View Menu                                    Now we need to enter the two new surfaces using
and choose Infinity.                                    the Split Block command. Note: When "splitting a
Now change the upper                                    block," the intended starting and ending points must
and lower limits of the                                 be visible on the screen before beginning Split Block.
cross-section view so that                              Thus we must first use the Add Point mode to insert
you are only looking at                                 the starting and ending points for our new surface.
the top 6 km of the model.                              The points we wish to add are circled in the figure
This may be done in one                                 above.
of two ways:
                                                        Select the Add Point mode by clicking on the "+"
1) Click the right mouse button in the vertical axis    icon on the Action ToolBar or by selecting it from
area of the cross-section pane (near the "Depth" la-    the Action Menu. Move the cursor to the surface
bel) to activate the pop-up menu and select "Change     where you want to add a point (approximately X=-
Range". Enter "-1.5 km" for the minimum depth (Z        30,000 km, Z=3.5 km) and click the mouse button to
is positive downward in GM-SYS) and "6.0 km" for        insert the point. Insert another point in a similar
the maximum depth, then click "OK".                     manner on the other side of the model (X=+30,000




                       Figure 11.6: Adding regional surfaces in the “infinity” view.


GM-SYS® v. 4.8
88                                                                    Tutorial - Create New Model
km, Z=3.5 km).
We can now move these new points to the exact co-         In the dialog box, change the block name to "Lower
ordinates desired by using the Examine function.          Sediments" and the density to 2.35 g/cm3. Click
Select Examine from the menu or the "eye" on the          "OK".
toolbar and click on one of the points that you have      HELPFUL HINT: Following the instructions above,
just added. Its coordinates will appear in the dialog     you started on the right side of the model and ended
box. Enter the values shown below:                        with a point on the left. The highlighted block was
                                                          above (to the right of) the new surface as you drew
 Point 1:          X=-30000           Z=3.5               it. While using Split Block, the new block is always
 Point 2:          X= 30000           Z=3.5               created on the right-hand side of the new surface,
                                                          when traveling along the new surface in the direc-
You are now ready                                         tion in which it was created. If you had started on
to start the Split                                        the left side of the model and ended on the right, the
Block operation.                                          new block would have been below the new surface,
                                                          instead of above. This should not be a problem, but
Select Split Block                                        you may need to Examine the blocks and enter the
from the menu or                                          proper information in the dialog box.
toolbar. Click on                                         Now, in a similar fashion, insert a new surface for
"Point 2" which you have just added on the right side     the horizon between the upper and lower sediments.
of the screen (refer to Figure 5 on the previous page).   The two ends of that surface should be:
A "rubber band" will now be
attached to your cursor (see
figure above). Move the cur-
sor to the "Point 1" that you
added on the other side of the
screen. Make sure the cursor
is exactly over the point and
click the mouse button. When
the dialog shown at right ap-
pears, choose "Accept/Edit
new block".
You should now have a new
block highlighted with its
block data displayed in the
dialog box, as shown on the
following page.

You can change the block
name and density by clicking
on the appropriate item in the
dialog box and typing in the
desired value.

                                       Figure 11.7: Examine Block dialog, allowing the user to set the
                                                  parameters for the newly-created block.

                                                                                          GM-SYS® v. 4.8
Tutorial - Create New Model                                                                                 89
                                                          11.4 SKETCHING YOUR MODEL
 Point 3:          X=-30000 km;       Z= 2.0 km
 Point 4:          X= 30000 km;       Z= 1.5 km           Looking back at Figure 11.1, we see that we still need
                                                          to build the basement high and truncate the "Lower
In the dialog box, change the block name from "Copy       Sediments" on either side of that high.
of Lower Sediments" to "Upper Sediments" and the
density to 2.50 g/cm3.                                    First, use the Add Point command to place anchor
                                                          points on both surfaces near the edge of the area of
Now we have the gross features of our model built.        interest (see Figure 11.9). Placing anchor points pre-
The surfaces that need to be tied to infinity are taken   vents changes on-screen from propagating into areas
care of and we can return to the geologic model of        off the screen. Notice that as long as you hold the
interest. We will do this through the View Menu.          mouse button down, the newly added point will move
                                                          with the cursor.
This is a good time to save your model.
                                                          Secondly, add and move points upward on the intra-
In the View Menu, select Startup. Again set the up-       sediment horizon (between upper and lower sedi-
per and lower limits of the model window to -1.5          ments) to make room for the basement high. In the
and 6.0 respectively. Your model should look like         same fashion, add and move points on the basement
the figure on the following page.                         surface until it is where you want it. Your model
                                                          should be similar to the one shown in Figure 11.9,
Now save this view so you can easily return to it.        below.
Select the View Menu and select Edit Views to acti-
vate the View List dialog. Select the Startup view,
click "Repl. w/CView" (replace with current view),
then click "OK" to close the dialog.




                               Figure 11.8: Working view of the new model.

GM-SYS® v. 4.8
90                                                                Tutorial - Create New Model




                 Figure 11.9: "Anchor points" may be used to limit the area affected
                                     by changes to a surface.

Now, create two new surfaces to truncate the "Lower   ToolBar. Move the cursor to the surface you want to
Sediments" against the "Basement", as shown in Fig-   delete and click on a point on that surface. The fig-
ure 11.10 on the following page. This will leave a    ure below shows one of the two points that would
remnant block with lower sediments above the base-    work in this example.
ment high.
                                                      A new block has now been formed joining the two
Delete the remnant block of lower sediments. Select   blocks on either side of the deleted surface. The
Delete Surface from the Action Menu or Action         blocks on either side were the "Upper Sediments"




                       Figure 11.10: Truncating the lower sediments against the base-
                             ment high, leaving a remnant block to be removed.

                                                                                     GM-SYS® v. 4.8
Tutorial - Create New Model                                                                             91




                         Figure 11.11: Select a point on the surface to be deleted.

and "Copy of Lower Sediments" (they may have
                                                         Block dialog. While the dialog is open, you may
slightly different names depending upon which di-
                                                         also change the block parameters to those shown in
rection you drew the surface using the Split Block
                                                         the table. Click "OK" when you are finished with
function). You must select the block you wish to
                                                         each block and then select another block. Note that
keep from a pop-up menu, thereby extending the
                                                         it is possible to have more than one block with the
properties of that block into the area where the other
                                                         same name.
block existed. Indicate that you wish to keep the "Up-
per Sediments" block.
                                                         You should now have a completed model which ap-
You should now use the Examine function to make
                                                         proximates the one shown below:
sure the densities, susceptibilities, and names of all
the blocks have been set to the desired values, shown
                                                         You are now ready to calculate the gravity and mag-
in the table below. For instance, change the name of
                                                         netic response to your geologic model and to start
the lowermost block from "Crustal rock" to "Base-
                                                         refining the model.
ment" by selecting Examine from the Action Menu
(or the "eye" in the Action Toolbar) and clicking the
mouse within the polygon to bring up the Examine

                                   Table 11.1 Tutorial Table
                          ÿþýüû                                   üþ
                          ÿþþýüûúýùø÷ýöõô           û÷

                          ýüûúýùø÷ýöõô       û÷

                          ýüûúýùø÷ýöõô       û÷

                          ôý÷ýöõ               û÷                 ûôûöøõô


GM-SYS® v. 4.8
92                                                                   Tutorial - Create New Model




                  Figure 11.12: Completed "roughed-out" model. Display of block labels
                                  and block parameters are turned off.


11.4.1 Applying a DC Shift
Select the Calculate function from the Menu ToolBar      (Auto mode). To enter your own DC shift value,
(calculator icon) or select Calculate from the Com-      select Gravity DC Shift or Magnetic DC Shift from
pute Menu.                                               the Profile Menu, or click the right mouse button in
When you first perform the Calculate function the        the appropriate anomaly pane and select DC Shift
calculated gravity and magnetic response may be off      from the pop-up menu. You then have the option of
the screen, as the calculated absolute gravity values    selecting Auto, entering an Absolute shift, or choos-
are of the magnitude of 5,000 mGal. A "DC shift"         ing a Station on the profile to serve as an "anchor
must be applied to the data in order to match the cal-   point", at which point GM-SYS will always force
culated curve with field data.                           the curves to match. If you choose the Station op-
By default, GM-SYS calculates an RMS difference          tion, that point is highlighted in the anomaly pane by
between the observed data and calculated response        a double arrow, as indicated in the display shown
and applies that difference to the calculated response   below.




                         Figure 11.13: Arrows indicate the location of the Station
                          used to calculate the DC Shift using the Station option.

                                                                                         GM-SYS® v. 4.8
Tutorial - Create New Model                                                                                 93
If you use the Station option for applying a DC Shift,     11.4.2 Label Placement
you should pick a station outside the area of interest,
probably at one end of the profile. If you make a          Labels are turned "on" by default, but they may ini-
change in the model which affects the gravity at this      tially appear outside of the working view. Using the
point, it will alter the entire curve in order to main-    Move Label option, the labels for each block be
tain the "fit" at this station. It is often advantageous   placed in their desired locations. Select the Move
to select a point which is normally off the screen and     Label option from the Action Menu or Action
beyond any portion of the model which is likely to         ToolBar, and click the "Snap Mode" radio button.
be altered. When modeling regional features extend-        Click the mouse in the desired block and its label
ing across the entire model, the effects of this "an-      will automatically be moved to that location. If you
chor point", and its location, should be kept in mind.     wish to change the block name, use the Examine func-
For this example, select the Auto option. After ap-        tion.
plying a DC Shift, you will want to apply Auto Scale
to each of the anomaly panes to be sure that all of the    If there is not enough room within the block to dis-
observed and calculated curves are visible. In the         play the label, the label may be moved outside of the
above display, the limits have been changed to -120        block and a pointer extended to the block. Select the
and 120 gammas.                                            "Drag Mode" radio button and place the mouse cur-
                                                           sor at the lower left-hand corner of the block name
You may now save the anomaly pane limits by se-            (above the block parameters, if they are displayed).
lecting Edit Views from the View Menu and replac-          Depress the mouse button and drag the label to its
ing the Startup with the current view.                     new location; the pointer will extend from the old
                                                           location to the new one. You may also drag the other
This is a good time to save your model.




                      Figure 11.14: Finished model, with labels positioned on-screen.

GM-SYS® v. 4.8
94                                                       Tutorial - Create New Model
end of the pointer by selecting and dragging it. When
you are happy with the placement of the labels, save
your model.

If you don't want the air block label to appear on the
screen, you may zoom out and "Snap" it to a location
well beyond the area of interest before zooming in.

Your finished model should appear something like
that shown in Figure 11.14.

Don't forget to save your model.

This concludes the Create New Model Tutorial. We
have worked through the procedure for generating a
starting model and importing data, and have devel-
oped a simple model. A more complex model can be
developed using the same simple steps introduced
here.

You may continue to explore features of GM-SYS
by manipulating the model using the Add Point, De-
lete Point, Move Point, Move Group, Split Block,
Delete Surface, and Examine functions.




                                                                     GM-SYS® v. 4.8