Documents
Resources
Learning Center
Upload
Plans & pricing Sign in
Sign Out

Fox Microsystems Aerial Sports Management System Changes and

VIEWS: 13 PAGES: 9

									Aerial Sports Management
System Changes and Enhancements
_____________________________________________________________________

Fox Microsystems

Aerial Sports Management Version 6.x
Contents: Name Changes | Screen Resolution | Data Security | Filecabinets | Tables | Reports | Network Definitions Name Changes Aerial Sports Management was previously know as "Score Plus". products:        Aerial Sports Management (3 different systems) Aerial Event Stations Aerial Photo Shop Aerial Leader Board Aerial Home Team Aerial Sports Calendar Aerial Beta Brite Control The "Aerial" name now defines a series of

We've also shortened the company name "Olympic Fox Microsystems" to simply "Fox Microsystems" The web site name has changed to www.AerialOnLine.com Check the web site for info on above...

Screen Resolution Aerial is designed to operate in a 800x600 screen resolution. If you computer is using 1024x768 or higher resolution, then Aerial windows will appear smaller than your full-screen display. Aerial's Scorekeeping Window can be adjusted to match screen resolutions of 600x480, 800x640, and 1024x768. After selecting a screen resolution, you can adjust the scorekeeping grid column width to your preferences. To adjust the Aerial Scorekeeping window, open 'Scorekeeping' and navigate to "Options > Roster Format". Your window settings will be 'remembered' and used whenever you open the Scorekeeping window.

Data Security A new folder ("Backup") has been created in the "C:\OlympicFox\Aerial\" folder, and contains a copy of the entire Aerial database. Whenever you leave the Active Meet Rosters window or Scorekeeping window, the system makes a copy of the active meet rosters. Scorekeeping: When entering scores, Aerial will make a backup copy of your work after a few scores have been entered, or, if you update automatically from the Event Stations, after each update cycle (this is not new; however all backups are now directed to the "Backup" folder). You can control the frequency of this automatic backup when scorekeeping: navigate to Options > Rosters and click the down arrow under "Backup | Restore | Archive"; then click "Display Automatic Backup Criteria". The Microsoft '.dbf' file (used by many applications, including Aerial) is subject to corruption if your computer goes down at the moment a file is being used. For this reason, Aerial makes redundant copies of your data so that, if you do experience a computer crash, you can recover with little or no data loss.

Recovering a file: A computer crash is actually rare, but it can happen (more so with older systems). If an Aerial file becomes corrupted, an error message will notifiy you of the offending file(s) when you restart Aerial. There are several ways to recover. 1. Manually: You can use Window's file copy capability to copy the offending file from the 'Backup' folder to the Aerial 'Tables' folder. Simply open the Backup folder, with the RIGHT mouse button, click on the required file, and drag to the "C:\OlympicFox\AerialTables" folder. Release the button and, selecting from the pop-up menu, request Window to make a copy (do NOT 'Move') of the file. Restart Aerial. or, 2. Using Aerial: Restart Aerial and, with the Main Menu visible, navigate to Options > Database and select the file you want to restore from the drop-down list under "Restore Backup or Corrupted File".

It is possible (although unlikely) that a corrupted file will not allow Aerial to restart (because the Aerial Main Menu uses the offending file). In this case, you will need to used method #1 above. To further guard agains mishap when scorekeeping, we recommend using two scorekeeping computers. (Note that Aerial enables roster comparison between dual scorekeeping computers, either over a network, or by using floppy diskettes.) And for critical meets, keeping a manual scoresheet is a good idea (Aerial will print a blank scorekeeping form).

Filecabinets The Active Meet Rosters Window and the Tables Window now displays: (1) a filecabinet graphic with several drawers, and (2) a wastebasket graphic. You can 'open' the drawers, pull out file folders, and return file folders to the drawers. This approach was implemented to make it easy for people, especially the inexperienced, to organize and access their data. After starting Aerial, move the mouse cursor to the "Filecabinet" menu item; a sub-menu appears listing four different filecabinets. Currently (9/04) only the Active Meet Rosters and Tables use a filecabinet graphic; Team Lists and Home Team will be implemented in the future. Accessing files: Move the mouse cursor over a drawer to view its contents; a contents list of file folders will appear. To "pull out" a file folder, click and drag an item from the contents list to the Aerial "desktop" (the large blue area to the left of the filecabinet). Or simply click the item in the contents list. From some drawers, Aerial will make a copy of the file folder, and from others, the folder will be physically moved. Return a folder, or group of folders, to a drawer by clicking a folder tab and dragging to a drawer. Deleting file folders: You can drag an item from the contents list to the wastebasket, or drag folders from the Aerial desktop to the wastebasket. Opening a file folder: To open a file folder for editing purposes, double-click its tab. You can display an abbreviated list of gymnasts by double-clicking the body of a folder. You can open multiple lists simultaneously. (Note you can more the lists by dragging them by their title bars.) This is advantageous if you want to move gymnasts from one session to another (you can also move gymnasts when the roster is opened for editing). Click a gymnast to select; the gymnast will be highlighted with red. You can select: Multiple gymnasts randomly by holding down the 'ALT' key while clicking gymnasts. A range of gymnasts by holding down the "SHIFT" key when clicking the first and last of the range. A range of gymnasts by holding down the left mouse button and dragging the cursor over the gymnasts you wish to select.

Once selected, click on a highlighted gymnast and drag to another list. The selected gymnast(s) will be moved. The format of the abbreviated list is selectable. Select Tools > Format Folder Lists. Active Meets: Its a good idea, if you are dealing with multiple meets simultaneously, to keep them in the Active drawer, and pull out only the one for the meet your are currently running. (The term "meet" refers to an entire meet, which can be composed of multiple "sessions", each session having its own roster.) Waiting Lists: For popular meets that tend to overflow, you can create a waiting list. This is done when you begin a new meet; check the "Waiting List" check box next to the meet name. The Waiting List is used like any other roster, but is kept in its own drawer (Wait List). You can pull it out and, using the abbreviated folder list feature, drag gymnasts from the waiting list to a session whenever openings occur. Archive: To archive a meet, just drag its folder(s) to the Archive drawer. A meet can be archived only once, although it is possible to delete a meet from the Archive drawer (you need to know the password; see the manual), and then re-enter it. You can pull a meet from the Archive drawer to the Aerial desktop, if you wish to view past results; in this case a copy is made. The original Archive Window no longer exists. Tables We've put the most important tables into one filecabinet. You can access the Tables filecabinet in the same way you access the Active Meet Rosters filecabinet. The new Tables Window can be accessed from the Main Menu or from the Active Meet Rosters Window. You can simultaneously open tables as long as they are from different drawers. Thus you can concurrently open a "Levels" table and an Age-Divisions table. As with prior versions, tables are defined by their Sanctioning Organization and Type-of-Meet. In addition, please note that the Levels table and Age-Divisions table are interrelated: a level must exist in the Lavels table before it can be added to the Age-Divisions table. You can create new tables for an existing Sanction/Type-of-Meet, or create a new set of tables for a newly defined Sanction/Type-of-Meet combination. To delete a table, drag it to the wastebasket. The "Clubs" window (used to define clubs) no longer exists. All clubs are now in the 'Clubs' drawer. If you want to add new clubs, move the mouse cursor to the clubs drawer, then click on the "New Clubs" entry in the drawer's contents list. Whenever you select a Levels or Age-Divisions table, the system makes note of it, and displays the last tables selected at the top of the window. When you exit the Tables window, Aerial will ask if you want to apply the selected tables to your current meet roster.

Home Team and Team Lists windows 11/3/04: These windoes are currently being changed to resemble the File Cabinet graphics as used by the Active Meet Rosters and Tables windows Aerial and Aerial Home Team (a stand-alone program) make it possible for clubs attending a meet to e-mail team lists to the host club; the team lists contain embedded codes for adding, scratching or changing gymnast info. Thus, addending clubs can effectively update the host's meet roster. Team lists can be sent and re-sent as

changes occur. This cuts down on meet roster errors.

Defining Award Reports The window for defining award reports has been replaced. As before, select the report you want to define; the report will be placed in a "report queue." You can then designate whether or not you want the report to be automatically run after all scores are in. To do this, click the "Auto Run" column; it will toggle between 'Yes' and 'No'. You can also enter a description of the report. If you check the checkbox in the 'Pri' column, the description will be used as a subtitle for the report. To define the details of your report, you can use either the "Quick Report" method, or the "Power Report" method. Each method will display its own window for defining parameters. The 'Quick' report window presents you with the most commonly used options. If, however, you need report details not available to the 'Quick' method, then activate the "Power Report" option. The 'Power' report window enables you to use an English-like sentence structure to define criteria for your report. The sentence structure is built up by clicking on the key words of the sentence and selecting values from the drop-down list. In this way, Aerial guides you in defining a report criterion. You can define multiple report criteria. When you do this, your report will consist of multiple sections, each section corresponding to its criterion. 11/3/04: Several 'bugs' are being worked out Network Definitions Window The Network Definitions Window now displays network assignments for each session simultaneously. You can see at a glance which sessions are, or are not, defined, and the computer ids used by your network. Each session's network definitions can be expanded or collapsed. Click the blue down arrow to expand a session, or up arrow to collapse the list. Moving the cursor across the session header will cause the list to expand; it will collapse when the cursor is move away. You can also select a menu item to expand or collapse all sessions.

Scorekeeping Window Score entry panels, used to enter scores directly into the master scorekeeping stations, are now separate windows which can be re-positioned; the grid will automatically change size to accomodate the position of the panels. 11/3/04: Score entry control panels are undergoing modification to better manage data entry..

HTML and PDF Support 11/3/04: Many reports can now be outputted as HTML (which can be uploaded to a web site) or PDF files (for e-mailing to other clubs). The user interface is still a bit rough, but I think it works.

E-Mail Support 11/3/04: This is work in progress. You will be able to create reports, either pre-meet or post-meet -- HTML or PDF -- and e-mail them to other clubs without leaving the Aerial environment. Completed meet rosters (.dbf files) can be e-mailed to attending clubs.

Aerial Sport Management Version 5.1
Navigation To help you move conveniently between the many Aerial windows, we added a Start button which, when clicked, will pop-up a Start Menu; select a menu item to open the corresponding function. This means you no longer need to return to the Aerial main menu to access other functions. You can customize each start menu to better suit the way you work. You can delete or add menu items. To delete an item, just drag it to the right of the menu. To add items, click the blue triangle in the lower-right corner of the menu; a list of all possible menu item will be displayed. Clicking a list item will cause it to 'pop' to the first empty location in the Start Menu. Or, drag an item to an empty location. You can also drag items within the Start Menu. If you drag an item and release it on top of another, the two will exchange places. We've not yet defined default Start Menus for all windows. You may need to add menu items. Certificate Plus! We created a stand-alone program to print individualized meet certificates for gymnasts or their families. These contain the gymnast's picture, score summary (including all judges scores when multiple judges are used), placements, custom header/footer texts and any special recognitions, and basic meet information. Certificate Plus! accepts the completed meet roster after the meet. Pictures can be snapped with a digital camera, or obtained from any digital source. A "certificate editor" enables you to select from a variety of options specified by the purchaser. We tried this out several weeks ago, and, at $5/certificate, made an extra $350 by meet's end.

Display Resolution We've changed several Aerial windows to use 800x600 as a default screen resolution. If you are using 640x480, you may need to increase to 800x600. The new resolution creates a larger format for the high-res displays. Scoresheet Beta Version 5.1, in addition to the original scorekeeping window, contains a 'beta' release of the new scorekeeping window. The screen resolution for the Scoresheet can be user-controlled. You can select 640x800, 800x600 or 1024x768. You can also permanently re-adjust the grid column widths and heights. When the scorekeeping window is open, navigate to "Options > Display Formatting" if you want to change screen resolutions or re-adjust columns. Also, requestors and control panels will re-open at the position you last left them. If you use the Score Entry Panel (ie, multiple judge inputs), and the roster is visible, the roster height will increase or decrease if you drag the Score Entry panel up or down. You can access the new beta scorekeeping window through the Start Menu; click the Start button and select "Scorekeeping/Beta"

Age-Divisions Table There is also a new ('Beta' release) Age-Divisions table. The new display is simplified, and the Age-Divisions table will display all levels/classes simultaneously (it would show only one level before). Or, you can elect to display a single level/class. The new beta release is not yet complete; we need to finish the "Equal Age Groups" option.

Message Express You can now direct a message, or series of messages, to all scoreboards simultaneously. (Before this enhancement, each message of a series has to be addressed to a single scoreboard.)

Help Tips We imporved the help tips. This is now a "mini-manual" which addresses the most frequently asked questions. There is a "Help Tip" button on each Aerial window. You can add your own help tips. With the Help Tip window open, shift-click the blue "UP" arrow, and enter the text of your choice. You can re-sequence tips by shift-clicking the blue "DOWN" arrow and re-numbering the tips in the displayed list.

"Cutting & Pasting" gymnast records When working with session rosters, you can select gymnast records, or entire teams, and move them to another session by dragging the highlighted group to the appropriate session tab above the roster. To select individual gymnasts, hold down the Shift key and click on the gymnast's name. To select an entire team, hold down the Shift key and click on the team name. Selected records will become highlighted with red. Drag the highlighted group to a new session tab.

Event Stations FX Music Selector To accomodate both the "Old" and "New" compulsory fx music being used at the same meet, we added an "Old/New" selector. To display this selector (when using the fx Event Station to play floor music) click the blue "DOWN" arrow in the FX Music control panel, then click the "Old/New" button (click the blue "UP" arrow to re-size the panel). The Old/New selector contains an "Old" button, a "New" button and three "Level" buttons, one each for levels 4, 5 and 6. Click either "Old" or "New" to select the appropriate music. You do not need to select a level, this will be automatically selected when you select a gymnast for scoring. You can select either "Old" or "New" before or after selecting a gymnast. Compulsory music files must be stored in the "C:\OlympicFox\EventStation\Audio\GeneralOne" folder, and must be carefully named. The "old" (USAG 1997) floor music must be named "Level4Old.wav", "Level5Old.wav" and "Level6Old.wav", respectively, for Levels 4, 5 and 6. Similarly, for the "new" (USAG 2001) fx music, the music files must be named "Level4New.wav", "Level5New.wav", "Level6New.wav", and saved to the same folder. After selecting the correct music (its name will appear in the fx Control Panel), you can begin playing the music by clicking the "Start" button, or pressing the F1 function key. Sub-Menus We added sub-menus to three of the Aerial menu buttons, to give you direct access to various windows. These

menus have been added to the "Rosters", "Tables" and "Directories" buttons. If you click the button without clicking in the sub-menu, the old "cover" page will be displayed. You can also navigate directly to other windows using the new Start Menu.

Aerial Sports Management Version 5.0
System Name. We changed the "Score Plus" name to "Aerial Sports Management", or "Aerial" for short, because: 1 - The system does more than meet scoring, and 2 - We wanted to avoid name confusion User Interface. We increased the use of Form, Folder & File Cabinet icons as a means of intuitively guiding people, especially first-time users, in the organization of their data, and established a more standardized 'look' for the various windows. You can select sessions by clicking the tabs of the folder icon in the Main Menu window; the selected session becomes the currently active meet roster. Double-clicking a tab will open the roster for editing. Clicking the folder icon body will open the Active Meet Roster window, or shift-click to bring up a meet selection requestor. Reports. To help you select and control the report you want after your meet, we've enhanced the 'Automatic Reports' window. When selecting a report, a full-sized sample of each is displayed as you move the mouse cursor over the report names. You can select from a large array of control parameters for each report. The report can be run immediately, save for later use, or placed in an "Auto-Run" queue to be automatically run after all scores have been entered. The Automatic Reports window can be accessed from either the Scorekeeping or Planning window. Home Team. The Home Team window is redesigned. You can select gymnasts for a meet and e-mail your team list to the host club. To facilitate changes, you can send your team list more than once, specifying whether gymnasts are to be scratched or added, or specify changes in data. The team lists can be automatically applied to the meet roster if the host is using Aerial. "Home Team" has been implemented as a stand-alone program for clubs that do not host meets, but want to electronically connect with those that do. The Home Team window will export to other formats (ProScore, Excel, Lotus, CSV or custom). The Gym Sonics module can be included to play fx music during practice sessions. Event Stations. Event Station software does not need to be running when you send meet rosters from the master scorekeeping station; when started, the Event Station software will find the new rosters. You can update Event Station rosters during the meet from the master station (i.e., scratch or add a gymnast, or change data such as a name spelling ro incorrect level). This assumes your Event Stations are networked. If not networked, Event Station operators can make changes to their rosters. Message Express. For clubs using networked Event Stations, Message Express enables you to send text streams from the master stations to the scoreboards. Scoreboards can be independently addresses, and can appear to interact. This can be used before or after your meets for announcements, local merchant advertising, ad-hoc messages, or even pre-meet entertainment. Message Express can also initiate audio through your club's stereo system. Awards Display. If you use networked Event Stations, and your awards location is near the scoreboards, the meet emcee can use the master station's "Awards" window to (1) announce awards and (2) visually display award information on the scoreboards. You can display the event on one scoreboard, the level/class and division on another, and scroll the gymnast's name, score and rank on still another scoreboard. The visual display helps audiences keep track of the process. Intercom. With networked Event Stations, operators can use a priority e-mail system to communicate with one-another, and with the master station.

Trampoline and Tumbling. This has been a major enhancement. Aerial will now manage both T&T and Artistic gymnastics. Our first 'live' test was the California State Championship, and it second 'outing' was the Region 1/Region 2 meet. It performed quite well, but I suspect T&T people will be requesting additional features.

Score Plus! Version 4.61
1. Age Division Analysis now has the option of showing divisions by age as an aid in balancing divisions or summarized. 2. Test and Synchronize Network 3. Channel 2 4. Inter-Station Messaging 5. Dynamic Roster Updates 6. Uploading Rosters to Event Stations

Score Plus! Version 4.6
Reports and Awards We've added a "Reports and Awards" window. You can used this window to: 1. Select and print reports or award labels after scoring has been completed, or 2. Set up reports before your meet for running automatically after all scores are in Option 2 (above) makes it easy for the scorekeeper, who simply starts the "Automatic Reporting" process with a single button click, and follows on-screen directions for loading paper or labels. When using the "Reports and Awards" window, you (1) select the report you want (an example of each is displayed as you move your mouse cursor over the menu of reports), and then (2) select various options for the report you selected. You then (3) save the report as a 'general report' or save it to the 'Automatic Reporting' queue for printing after all scores are in. You can print (or preview) a report simply by selecting it and clicking the 'Print' or 'Preview' button. The old 'Manual Controls' are still there, and you can use these controls to manipulate your roster data and print reports. Note that the Manual Controls pop-up menu has a push-pin icon which, if you click, the pop-up menu will remain displayed; otherwise, the menu beomes hidden when you move away from it. Both the Reports and Awards window and Manual Controls can be accessed from the Scorekeeping window (select 'Tools > Reports and Awards' or 'Tools > Manual Controls'). The Reports and Awards window can also be accessed from the Planning window, but can can only be used to set up reports for after-meet printing. See the included manual pages for additional details.

Score Plus! Version 4.5
We've been focusing on the user-interface, and have tried to make it more intuitive, especially for the first time or novice user. Defining a Meet You can now define a new meet roster by either (1) Opening the Meet Rosters window and entering meet and gymnast info, or (2) open the Teams Master List, enter individual teams and then select gymnasts to be included in your meet roster. (You can still update the Teams Master List from completed meet rosters.)

Tools Menus The Tools menus for the Meet Rosters, Scoring and Teams Master List windows have been modified in order to make it easier to find the things you need. Transferring Meet Rosters to Event Stations For those using networked Event Stations, you can now transfer meet rosters directly into the Event Stations from the master scorekeeping computer; the transferred rosters will replace any existing rosters. This is intended to be done prior to the meet, and makes transfer to the Event Stations much quicker. Before this change, it was necessary to send the rosters to the Event Station's computer, then run over the the Event Stations, start it up, and "Import a Roster". We are working on a change which will enable you to modify Event Station rosters from the master scorekeeping computer while the meet is in progress. This feature will enable the master scorekeeper to scratch gymnasts, change gymnast info (such as level, division or name spellings), add a late-arriving or overlooked gymnast, or change competitor numbers at any or all Event Stations. (Currently, only the Event Station operators can modify their rosters.) Inter-Station Messaging Event Station operators can electronically exchange messages with one-another and with the master scorekeeping computer operator. When the messaging feature is activated (navigate to the Event Station's Options > Networking, or Score Plus!'s Options > Environment), a telephone icon will appear on the display; it will blink when a message has been received. Clicking the icon will open a messageing window, enabling you to read or send messages. The Messaging feature requires a networked environment.

Score Plus! Version 4.1
File Cabinet Index You can now choose to view the index to the meet roster's file cabinet as either a table, or as folder icons, one for each meet. Select with the options buttons near the bottom of the page

Version 4.0
Event Station Networking. This is an early release. We've "bench tested" both wireless and wire-line automatic transfers of scores from the Event Stations to the Master Scorekeeping computer with good results. However, we are not comfortable with recommending the use of any new feature at a critical meet until we have personally "field tested" the feature (using it at a meet), which we will be doing this fall. If you want to use Event Station networking, we suggest you experiment with it well before your meet. You will need to (1) have your network environment established (a Windows function), (2) mark, on each Event Station computer, the "C:\OlympicFox" folder as "sharable", and (3) set up the Score Plus! software (on the Master Scorekeeping computer) for networking (from Main Menu, click "Options", select the "Networking" tab and enter the names of the Event Station computers used at each event). Flights Dividing rotations into 'flights' is useful when running large capital cup meets with dual set of equipment The 'flights' feature has not yet been "field tested".


								
To top