Docstoc

ERwin 3

Document Sample
ERwin 3 Powered By Docstoc
					Frequently Asked Questions ERwin 4.0
January 10, 2001

ERwin Technical Support
How can I contact Technical Support at Computer Associates directly? If you need technical support, you can visit the Computer Associates Technical Support web site. Point your browser to http://esupport.ca.com. On the esupport home page, select ERwin from the product list to display the ERwin Resources page. For online support, point your browser to http://esupport.ca.com, then select StarTCC from the list of support options on the left side of the screen. If you have not registered for StarTCC you will be required to do so. StarTCC will allow you to easily enter and check the status of your issue. For telephone support, click the "Contact Us" link on the top of the esupport home page to find the telephone number for your calling area.

New Features
What are the new features for ERwin 4.0?  Workplace Changes and Enhancements There are many workplace changes and enhancements in ERwin 4.0 that include a redesigned workplace with a Diagram Window and Model Explorer, redesigned and dockable toolbars, drawing objects, and a new menu structure. The Model Explorer The ERwin 4.0 Model Explorer provides an organized, ordered view of your model and its contents. The Model Explorer enables you to create, display, navigate, and modify your model using a model, subject area, or domains pane. Menu Structure Redesign In ERwin 4.0 the menu structure is redesigned to accommodate new options and to resemble the menu structure of other popular Windows-based applications. Items from the ERwin 3.5.2 Tasks menu have been moved to the ERwin 4.0 Tools menu. The ERwin 3.5.2 Server menu has been moved to the Database menu, and items from the ERwin 3.5.2 Edit menu have been moved to a new Model menu in ERwin 4.0. Support for Design Layers ERwin 4.0 supports the application development process in new ways that enable you to capture business requirements as well as the exact design of your physical database. You can now create independent logical and physical models with unique notation and display options. You can create logical/physical models, convert ERwin 3.5.2 models to the logical/physical format, and save* models in ERwin 3.5.2 format. You can also split ERwin 3.5.2 models into separate logical and physical models, derive new models from existing models, and link a model to its source so that changes can be synchronized.
Save As 3.5.2 is supported in ERwin 4.0. There are several points to consider when you save an ERwin 4.0 data model in ERwin 3.5.2 format. Any new ERwin 4.0 objects or properties, such as transformed objects, drawing objects, model and object history records, source model links, naming and data standards, summary tables, alternate keys, and report templates will not be preserved.









Deriving a Model Page 1 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

You can support an application development process that requires model derivation using the ERwin 4.0 Derive New Model wizard. You can derive a logical model from a physical model, and one or more physical models from a logical model. The source and derived models are linked for future synchronization, and history is traced in the derived model.  Transforms A transform is a method by which you can apply a design layer decision and maintain a record of the decision for the process that you are modeling. For example, you can refine the physical model to improve query performance by applying a transform to two tables and creating a single denormalized table. Nine different transform types support a wide range of features including automation, traceability and the preservation of object properties. Model History and Traceability You can save historical information for your model, entities, attributes, tables and columns. You can track meaningful changes to derived and transformed models, as well as routine information about the creation and revision dates of your models using the History feature. Click the History tab in the Model Properties dialog to set the options for tracing the history of model objects. Complete Compare Changes and Enhancements The Complete Compare feature has been redesigned. You can use Complete Compare to bidirectionally synchronize a model and a database or script file. New wizards guide you through the process of importing model information into ERwin and exporting changes to a database or script file. Forward Engineering Enhancements Forward Engineering has been moved to the Tools menu for Physical Models, and the list of supported databases has been expanded. Reverse Engineering Enhancements Reverse Engineering has been moved to the Tools menu. The template selection dialog has been redesigned to include reverse engineering to either a physical or logical/physical data model, and the list of target databases has been expanded. Report Template Builder The Report Template Builder is a powerful reporting tool that you can use to easily and quickly create reports about your model. You can create reusable report templates and export reports in .txt (.CSV), HTML, and RTF formats. You can publish HTML output from the Report Template Builder on a Web server or company intranet, replacing features formerly supported by the ERwin Web Publisher software. Naming Standards Editor You can use the features in the ERwin Naming Standards Editor to develop model naming standards for your organization. Use the editor to define naming standards, build a word glossary, check model names for accuracy, and name model objects in models derived from other models.













Page 2 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001



Datatype Standards Editor You can use the Datatype Standards Editor to edit the datatype mapping for your logical and physical models. For physical models, you can edit the default datatype that ERwin automatically attaches to each column. For logical models, you can add logical datatypes and assign the datatypes to the attributes in the logical model. New ERwin 4.0 Macros In ERwin, you can use the ERwin Macro Toolbox to review predefined ERwin macros and use the macros to customize built-in trigger templates, create override RI trigger templates, or write new SQL triggers or stored procedures. ERwin 4.0 includes new macros designed to make it easy to distinguish between their application in the logical and physical model types.



Installation
When installing ERwin, the installation program could not create the Program Items or Program Group. If you are installing ERwin on Windows NT, you must have the appropriate permissions to create a program group. Your system administrator can assign these permissions in the Administrators, Power Users, and Server Operators groups. Contact your administrator if you need to upgrade your permissions to allow you to create a program group.

Database Connectivity
Does ERwin include connection software? ERwin, like most SQL enabled products, relies on external "middleware" to connect to your DBMS. ERwin itself does not ship with connection software for supported databases. The manufacturer of your DBMS typically supplies native client connection software. ODBC drivers may be obtained from your DBMS manufacturer, Microsoft, or a third-party driver manufacturer such as Merant (Intersolv). How Does ERwin connect to my database? ERwin connects to your database using native DBMS connection software or through Windows ODBC standard drivers. You can read more about the software required for database connectivity in the ERwin online help. On the ERwin Help menu, choose Help Topics, click the Index tab and search on "Target Server:connection table". ERwin 4.0 supports generic ODBC, which can be used to connect to any target server that is not directly supported by ERwin. On the ERwin Help menu, choose Help Topics, click the Index tab and search on "ODBC:Generic" for more information. Can I use 16-bit connection software to connect ERwin 4.0 to a target database? ERwin 4.0 can only be installed on a 32-bit operating system such as Windows 95, Windows 98, Windows 2000, and Windows NT 4.0. Therefore, it requires 32-bit connection software. How do I install the connection software? Use the install program supplied by the manufacturer of the client connection software.

Page 3 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

How can I tell if the connection software is already installed? The following could be the guidelines to determine whether or not your connection software is installed: A) you are having difficulty connecting to your database with ERwin, B) you do not remember installing the client software previously, or C) you have not connected previously. The most obvious indication is if in the physical model, launching Database Connection under the Database menu does not show a Connection Box. If you find that your connection software is not installed, please use the installation program that comes with the connection software. Attempting to install connection software by copying files to different directories in response to error messages from ERwin is almost always ineffectual and frustrating. To which target servers does ERwin connect using native connectivity? ERwin can connect directly to Oracle, Microsoft SQL Server, Sybase SQL Server, Informix, and SQL Base. For all native (direct) connections, the appropriate networking software, such as TCP/IP, must be installed on the workstation. DBMS client software is available from the DBMS manufacturer and must also be installed and configured. DBMS client software is not packaged with ERwin. What do I need to connect to Oracle?  Net8i (for Oracle 8, 8i), Net8 (for Oracle 8 or 7.x) or SQL*NET 2.x (Oracle 7.x).  The $ORACLE_HOME/BIN for your operating system should be in the path, e.g. for Windows NT the path is \ORANT\BIN. For more information, refer to the Oracle SQL*NET, Net8, Net8i manuals and/or your system administrator. What do I need to connect to MS SQL Server?  Microsoft's Open Client Software.  The open client installation directory must be in the path. Note: ERwin does not currently support NT Authentication or NT Security. What do I need to connect to Sybase?  Sybase Open Client installed and configured for your client workstation.  The Open client installation directory (e.g. \SYBASE\BIN) in the path. ERwin 4.0 supports connections via CTLIB and DBLIB. For more information refer to the Sybase manuals and/or your system administrator. What do I need to connect to Informix?  Informix-Net for your operating system provided by Informix for your Informix Server version.  Proper version Informix ODBC drivers for the Informix Server to which you are connecting. What do I need to connect to SQLBase?  SQLBase Client Software. What do I need to connect to SQL AnyWhere?  Install and configure the ODBC driver for SQL AnyWhere. Contact Your Database Administrator for detailed information on configuration parameters.

Page 4 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

What do I need to connect to Access 2000?  Create an ODBC data source for Access 2000 using its ODBC. When I try to Reverse Engineer from Microsoft Access 97 I get an "Error 340". This error means the Microsoft re-distributable Data Access Objects (DAO) have not been installed on your workstation. ERwin 4.0 and 3.5.x use DAO to connect to MS Access database and DAO is provided as part of the ERwin install. What do I need to do if I use ODBC connectivity? Once an ODBC driver is installed, an ODBC data source must be created. An ODBC data source is a logical name for a specific database location. The ODBC data source is the database name chosen from the drop down list box in the ERwin connection dialog box. You can read more about creating an ODBC data source in the ERwin online help. On the ERwin Help menu, choose Help Topics, click the Index tab and search on "ODBC:defining a data source". For more information concerning installing and configuring ODBC, please refer to the ODBC driver installation manual and/or your system administrator. I believe I've done a successful installation of my client software, but ERwin still cannot find the connection software when I try to connect. ERwin finds the connection software using the operating system's path. Check your path by going to a DOS prompt and typing "PATH". Most software installation programs usually put their location at the beginning of the path in the environment. Though this may be in your AUTOEXEC.BAT file, or your environment in Windows NT, your path may have changed when you logged in to your network and the location may no longer be available to ERwin. Checking the path with the "PATH" command will show you exactly what your path is at that time. You may have installed the connection software to a network drive. The network drive needs to be available so ERwin can find the connection software.
Also check the following:



Did you exit from all other software when you ran the installation? If some .dll files were being used by another program, such as MS Office, they may not have been overwritten with the newer DLLs that your connection software may need. If this is the case, exit from all other software and run the installation again. Did you just install a new software package since you last connected? When installing any new software on your system, if the location information is added at the beginning of the path, the name of your client connection software may be pushed off the end. DOS sees only the first 128 characters of the PATH statement. Go to a DOS prompt and type PATH to see what is "live" in the path.



Page 5 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

Schema Generation/Reverse Engineering
After reverse engineering, my ERwin diagram does not have relationship lines. Reverse engineering from SQL DDL scripts requires explicit SQL commands that define the foreign keys. Just because a column in one table has the same name as a column in another table does not mean that ERwin will assume a relationship. Such commands are usually found in SQL ALTER TABLE statements. ERwin will use the sp_foreignkey statements in the DDL to draw the relationship lines. ERwin 3.0 introduced the ability to infer relationships from indexes and same name keys. If you select this option, ERwin 4.0 will infer the relationships by examining the column names and indexes of each table. If two tables have a column with the same name, and one table has a unique index but the other does not, ERwin assumes the column with the unique index is a Primary Key. If a table has more than one unique index, ERwin infers the Primary Key and Relationships based on the criteria list in the ERwin help system. Search on "inferring" in the ERwin help to find this section. Remember that the inferring process is an educated guess by ERwin and it may not reflect the true relationship that you might think. Reverse engineering foreign keys through ODBC requires the ODBC driver to be at least LEVEL 2 compliant. A LEVEL 1 ODBC driver will not retrieve foreign key information from the database catalog. (Please contact the ODBC driver manufacturer for information regarding the availability of LEVEL 2 or higher drivers.) Reverse engineering Xbase databases will not retrieve foreign key information. Most Xbase databases do not support referential integrity constraints. Such constraints are usually found in application code and ERwin reverse engineering retrieves only from the database catalog, not the application code. I was generating an Access Database, but I got the message "Execution Failed". When forward-engineering to a Microsoft Access 7 database, be sure all relationships are named. Otherwise, you will see an "Execution Failed" message. SQL DDL generated by ERwin results in "Table or View Does Not Exist" errors from the server. Most likely, you are trying to modify or drop a table or view that doesn't exist or you do not have privileges to access the object. SQL DDL generated by ERwin results in "<object> Already Exists" errors from the server. Most likely, you are trying to CREATE an object that already exists. If this message appears after an ALTER TABLE statement that is defining a foreign key, look at the statement that immediately precedes the offending statement. If it is identical to the problem statement, you must choose the constraint name option from the "other options" group on the schema generation dialog box. Choosing this option will use the relationship physical name to uniquely name the foreign key constraints. This also requires uniquely named verb phrases.

Page 6 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

Miscellaneous:  When Reverse Engineering Red Brick 4.0 Major Table physical storage parameters, the segment specification is not in the same order as when forward-engineered. Red Brick 4.0 does not store any information regarding the order of the storage segments. Therefore, ERwin does not have enough information to determine the segment order. You should verify the segment order prior to forward engineering.  When generating to Oracle with the index storage option OPTIMAL, the following error occurs: ora-02143, Invalid Storage Option. Oracle documentation states that the OPTIMAL storage option is valid only for Rollback Segments.  When you drop a Clipper table using an ODBC connection, ERwin does not drop the indexes defined for the table. The DROP TABLE statement generated by ERwin does not drop Clipper indexes. You must drop the indexes manually in Clipper.  Because of limitations in the current Paradox 5.0 ODBC driver, ERwin cannot forward engineer the following Paradox 5.0 datatypes: Autoincrement, BDC, BDC(), Binary, Formatted Memo(), Logical, Long Integer, Memo(), OLE(), Time and Time Stamp. To remedy this problem, use ERwin to generate the schema with alternative datatypes and then manually change the datatypes in Paradox.  When using ERwin on a platform with an ATI graphics card that supports higher color and resolution options (e.g. 32k colors and/or 800x600 resolution), ERwin may drop characters from the display. We recommend that you use a 256-color display driver.

Diagram Display
How do I turn off the migration of foreign keys in the logical model? In the logical model, right mouse click (RMB) on the diagram background, select Entity Display, and uncheck the “Show Migrated Attributes” option. How do I get only part of my primary key to migrate? ERwin enforces the IDEF1X method of data modeling. According to IDEF1X, the primary key of a referenced table must migrate to the referencing table. A primary key is defined as an attribute or collection of attributes that uniquely identifies an entity, and a foreign key is a reference to a primary key. There is no provision for referencing only part of a primary key in IDEF1X. The workaround is to not have a relationship and enforce the business rule using a custom trigger. If you only need a unique identifier in one table but do not need to migrate this key to any other child tables, make it an Alternate Key or an Inversion Entry instead of a primary key. With 4.0, you do have an option to migrate either the PK (Primary Key) or the AK (Alternate Key). Alternatively, you can mark the attribute as logical only in the column editor. The attributes will still migrate, but in your physical model the column name will not appear. The schema is generated from the physical model so this column will not be generated. This is applicable only in the Logical/Physical models and not for Logical or Physical models.

Page 7 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

Miscellaneous
I pressed F1 for Help, but nothing happened. If you pressed F1 to use context-sensitive help in ERwin but received no response, you may be out of segments in memory. Shut down other applications and then try again. Where is the Dictionary Manager? The ERwin Dictionary and ERX file format have been discontinued in ERwin 4.0. Data exchange with ERwin 4.0 models can be accomplished through the XML or ERwin API functionality. How do I embed my ERwin diagram into another application? On the Edit menu, choose Select All, then choose Copy. In the Copy dialog, select the Copy option to copy the selected objects to the Windows clipboard. The clipboard image can now be pasted into another Windows application. You can also use the ERwin 4.0 Report Template Builder to generate the diagram picture as HTML. Your HTML report output can also be used in other documents. How can I distribute my ERwin diagram in read only mode? There is a read only version of ERwin called ERwin Navigator** that is available for use with ModelMart. You can read and create reports on models in the same way that you can with ERwin, but you cannot Forward Engineer, Reverse Engineer, or alter models. You can also create a report with the diagram as a picture containing annotations. You can publish HTML output from the Report Template Builder on a Web server or company intranet. The report can also be saved in RTF format.
**The version compatible with ERwin 4.0 will be available later, around the same time as ModelMart.

Where did my ERwin toolbox go? You can toggle the display of the ERwin toolbox on and off by pressing CTRL-T (press the control and T keys simultaneously). If you recently changed your video driver from a higher resolution (e.g. 800 x 600) to a lower resolution (e.g. 640 x 480), you may have to edit your ERWIN40.INI file. The ERWIN40.INI file is located in the WINDOWS directory. The TOOLBOX = X,Y entry determines the location of the toolbox. Exit ERwin and open the ERWIN40.INI file using NOTEPAD. Change the X value to 100 and the Y value to 100, save your changes and restart ERwin. The toolbox should then be visible. With ERwin 4.0, you may also view or hide various other toolbars under the View, Toolbars menu. When I open my model, I see a message stating that my file is read only. Whenever ERwin opens a file, that file is marked as read only. This is to prevent a second user from editing and saving a file that the first user has opened. If ERwin does not exit cleanly (for example, shutting off the computer with ERwin and Windows still running), the file will remain marked as read only. To recover, close the file, go to File Manager, highlight the read only file, choose Properties on the File menu, and clear the checkbox next to the read only attribute. Alternatively, you can do this with the DOS Attrib command.

Page 8 of 9

Frequently Asked Questions ERwin 4.0
January 10, 2001

ERwin creates a backup file when your xxxxx.er1 file is first opened. The file is in your ERwin directory and named xxxxxx.bk1. If you have any suspicion that your model may be damaged by an abnormal exit (for example by shutting off your computer in the middle of a Windows session or by a power failure), it may pay to rename your .bk1 file as an xxxxx.er1 file before changing the read only status of your original file and opening it. Once you open the original model, the .bk1 file will be overwritten. The .bk1 file will contain your ERwin model as of the time you opened it in your last session.

Printing
Some of my printed diagram pages have a black background. This particular problem has been traced to certain HP printer drivers that were shipped with HP LaserJet 4 printers. Please download a file named L4WIN3.ZIP or later from Hewlett Packard's web site. Note: Choosing raster in the printer driver setup is a quick fix for this, but may slow printing. I am trying to print through a plotter but the diagram is only printing halfway before hanging. Why? ERwin was tested using HP's 750c DesignJet Plotter. Printer and plotter drivers are notoriously out of date on PCs and networks for a variety of reasons. If you are not using the latest version for your particular plotter, please download the latest version from your plotter vendor and try again.

Reporting
Has Reporting changed since the previous version (3.5.2)? ERwin 4.0 includes the Report Template Builder, a powerful reporting tool that you can use to create graphical and text reports about your model easily and quickly. You can create reusable report templates and export reports in TXT (.CSV), HTML, and RTF formats. You can publish HTML output from the Report Template Builder on a Web server or company intranet, replacing features formerly supported by the ERwin Web Publisher and RPTwin software. Select Report Builder from the Tools menu to start the Report Template Builder.

Client Support
Support for Visual Basic and Power Builder has been discontinued in ERwin 4.0.

Page 9 of 9


				
DOCUMENT INFO
Shared By:
Categories:
Stats:
views:2351
posted:11/21/2009
language:English
pages:9