Docstoc

LEAP OFFICE

Document Sample
LEAP OFFICE Powered By Docstoc
					LEAP OFFICE

Introduction LEAP Office 2000 is complete Indian language software for office application. It has been developed in collaboration with Mithi.com Pvt. Ltd. LEAP Office 2000 has a number of features to make the use of Indian languages extremely easy. It provides a number of tools to increase the efficiency of the user. These include multilingual Spellchecker, keyboard shortcuts, search and replace, online keyboard and official language dictionaries. New technologies like the Internet have been well adopted by LEAP Office 2000. It incorporates the facility to send an Indian language E-mail without going to a separate editor. Creating web Pages using LEAP Office 2000 is as simple as creating any other document. Language intelligence is inbuilt into LEAP Office 2000 at many fonts such that at any given instance it is possible to know in which language the user is working. The multilingual Spellchecker takes an intelligent decision to check the spellings of the text as per the language. The official language dictionaries come handy for official language terminology. Languages Supported by LEAP Office Leap Office supports Assamese, Bengali, English, Gujarati, Hindi, Kannada, Malayalam, Marathi, Oriya, Punjabi, Sanskrit, Tamil, Telegu, and Diacritic Roman Script. Leap Office Supports different types of Keyboard Layout Leap office supports different types of keyboard layout for the Indian Languages. The popular keyboards among them are: 1. Inscript keyboard (Indian Language Phonetic keyboard) 2. Phonetic English keyboard 1. Inscript keyboard (Indian Language Phonetic keyboard) The Inscript keyboard ( strongly recommended the use of this key board) has been carefully designed to help the user .The Inscript keyboard allows all the Indian script, to be typed in a uniform manner. This means that a person knowing how to type in one script can immediately type in any other, since the keystrokes remain the same. The Inscript overlay simplifies the learning process while facilitating fast typing, through alternate hand action. All this is accomplished by mirroring the scientific phonetic structure of the Indian script alphabet on the keyboard, in a logical manner. The Inscript overlay is same for all the Indian scripts, and contains the basic characters required for all of them. In the Inscript overlay the following English overlay Characters are available in their usual places:

1234567890-,. Inscript Keyboard overlay has been optimized both for touch typing as well as sight-typing. It is easier to type the basic characters from the first three rows themselves. Other characters in the forth row have very low frequencies. It contains some conjunct characters in the shift positions, each of which give out two or three basic characters. 2. Phonetic English Keyboard In case of phonetic English Keyboard, one can type his text in English, and he will get an immediate feedback of the transliterated text in the language of the current context. One can key in the characters as he would normally pronounce them (using the mapping table provided) and the end output will be the text in the Indian Language of your choice. This keyboard is meant for three types of users: 1. Those whose mother-tongue is an Indian Language, who can speak it and who do not know how to write it. 2. Those who have learnt the language orally but have not mastered the written skills. 3. Those who feel comfortable with a QWERTY keyboard and do not want to key in a text using the INSCRIPT keyboard.  How to type Assamese Characters using the Inscript keyboard The Inscript Keyboard overlay allows the following basic characters in Assamese to be typed in.

Eõ F G $Jô $K÷ $Oô Pö Tö U V Y Zõ [ý ^ » _ ` b a
 The Vowels

H L Qö Wý \ö ¾ c÷

Iø Mõ AÕ $Rô S X ]

The Second row contains the 5 short vowels in Assamese. Matra is given in the Unshift position, while the corresponding vowel is given in the Shift position. This is convenient since the Matras are used more often than the vowels.

A C,

S A, D %, F +, G =

(Shift position)

å#ç å# #Ë ×# #Ç (Unshift position) % Vowel has got no corresponding Matra as its sound is inherently present in each consonant. A Halant sign has to be used to remove the inherent % sound from a
consonant. The Halant sign is used often for combining consonants, and is thus given in the unshift position. There are 5 pairs of short and long vowels in Assamese. All the short vowels are given in the 2nd row, and the corresponding long vowels are given in the 3rd row. One needs to remember the positions of the short vowels in the 2nd row. Position of a long vowel is in the key above the corresponding short vowel. Short Vowels Second row

A C, å#ç
Long vowels Third row

S A, D %, F +, G = å# #Ë ×#

(Shift position)

#Ç

(Unshift position)

D, W B, E %ç, R <, T > (Shift position) å#ì, é#, #ç, #Ý, #É (Unshift position)
Q  Nasal Signs and Nasal Consonants Assamese has 5 Nasal consonants consonants Frist row C

I

,

AÕ, S, X

and

].

The Nasal

] , X and S are provided in the left half of the first row.

] ( Unshift position) V X ( Unshift position) C S (Shift position)
The Nasal consonants and used infrequently in Assamese, are provided in the Shift positions of two keys in the right pad.

Iø

AÕ

I, ( Shift position )ø }AÕ ( Shift position) Anuswar #e is given in the Unshift position, while Chandrabindu #g which
U is used less often, is given in the Shift position of the same key.

#e (Unshift position) X #g (Shift position)
X



Consonant Pad

The Consonant Pad is in the right half of the keyboard. Assamese has 5 Consonant Vargs, each having 5 consonants. These consonants are accommodated in the right pad of the keyboard. Each Varg contains a pair of Primary consonants, a pair of Secondary consonants and a Nasal consonant. Primary varg1 varg 2 varg 3 varg 4 varg 5 Secondary Nasal

Eõ F $Jô K÷ $Oô Pö Tö U Y Zõ Eõ ( Unshift K) F ( Shift K) G (Unshift I) H (Shift I)

GH L Mõ Qö Rô V Wý [ý \ö

Iø AÕ S X ]

The two pairs of each Varg are kept in two vertical keys as shown below. varg1:

This arrangement is not only easy to remember but also places the Primary consonants, which are more used, in the 2nd row.  The Non-Varg consonants

After the first 5 Vargs of Assamese, come the Non-Varg consonants. These are also accommodated in the consonant pad on the right half of the overlay.

^ ` »

» b

_ a

¾ c÷

is the most often used consonant amongst these, and is thus provided in the 2nd row. (Unshift J)

» Assamese has the ¾ and _ consonants as shown below. 1st row (Unshift B) ¾, (Unshift N) _ ^ and Ì^ consonants are accommodated on the right half of the overlay. ^ ( Shift ? )
Second row

Ì^ ( Unshift / ) ` which is similar to a, though less frequent, is provided on its Shift position. b which has the same pronunciation as ` is provided on the Shift position of the adjacent
key. 1st row 

` (Shift M), a (Unshift M), b (Shift <)
Nukta

Nukta (NUK) character is used for deriving two additional consonants in Assamese:

QÍö $RÍô
Nukta Third row

#Ì

(Unshift ] )  Viram Viram is provided on the Shift position of full-stop. Frist row (Shift >)  Visarg

*

Visarg which is an aspiration sign, is used infrequently in Assamese. It is provided in the Shift position of a key in the 4th row. Fourth row (Shift _ )  Halant (Hashant) Halant

#f

#f

#Ë is typed to indicate a half character. A Halant #Ë sign is used to remove the inherent % sound from a consonant. c÷Pöçd = c÷ Pö #ç Tö #Ë ^ç[ýd = ^ #ç [ý Tö #Ë [ýj = [ý Eõ #Ë a #Ë
 Conjunct Keys For convenience of typing, some Conjunct characters are provided in the Shift positions of some keys in the 4th row. The action of these keys is equivalent to typing the two or three characters comprising each of the corresponding conjuncts. Fourth row 5

pû,

6

y, 7 lù, 8 `Ò



Conjunct list

The halant sign ( in the unshift position . D For Example:

#Ë

) is used for combining consonants , and thus it is given

#Ë

( unshift position)

yÔ = Eõ #Ë » GÐ = G #Ë » ³V = X #Ë V sú = AÕ #Ë $K÷
 Rakar When the Halant is followed by a , a Rakar gets formed. This Rakar is also available directly as a Conjunct key. The key for Rakar is # ( shift position). For example

»

GÐç] = G #Ë» #ç ] [ýq = [ý L #Ë» YÒçS = Y #Ë» S
 Reph When is followed by a Halant, a Reph gets formed. This Reph is also available directly as a Conjunct key. The Reph has to be typed before the consonant on which it is shown.

»

Eïõ = »Ë Eõ Fï = »Ë F Gï = »Ë G
 How to type Assamese Characters using the Phonetic English Keyboard Below is given a mapping table for the Transliterator where the English Character set is mapped onto the Indian language set. The mapping is as user-friendly as possible so as to enable a fast, accurate and speedy data-entry. Against each character its approximate value in English is also given along with an example. k c kh ch g gh Ng

Eõ F

G
j

H
jh

Iø
Nj

$Jô $K÷
T t p Th th ph r D d

L
Dh dh bh w

Mõ AÕ
N

$Oô Tö U Y
P

Pö Qö $Rô
n m

S

V
b l

Wý X

Zõ [ý \ö ] »
Sh

^
sh

_
s

¾
h

`
kSh

b
R

a
DH

c÷
Y

l


QÍö $RÍô
Vowels

Ì^

In the case of Vowels, a simple convention has been followed. Indian languages have both long and short vowels. The short vowels have been mainly shown by the lowercase character whereas uppercase is used for the long vowels. Indian languages have both Matras and Full vowels corresponding to these matras. The normal rule is that when the Vowel is preceded by a Consonant, it has a Matra Value. Otherwise the vowel has the Full Vowel Value. These combinations would be taken care by the engine normally. The mapping of the vowels are given below. a A i HRI I

%
u

%ç /#ç
U AY

+ /×# @/ #Ê
AW o

< / #Ý

= /#Ç
e

>/#É B / é#
Chandrabindu Anuswar

A/ å#
 .M M 

C / å#ç

D/ å#ì

Nasal Markers

#g #e

Conjunct Characters

yÔ] = kram

X³V = nand
 How to Create a plain new document 1. Select the New item in the File menu. 2. Select Create a Plain New Document option. A plain new untitled document will be opened. or press CTRL+N ( keyboard shortcuts) * If you have made changes to the currently open document, LEAP Office will prompt you and ask if you want to save the changes made to it.  Set the default language 1. Select the Options item in the Tools menu. The Options dialog box will be displayed. 2. Click on the down arrow key in the Default Language box. A list of languages will be displayed. 3. Select a language. 4. Click OK.  Show/Hide the Onscreen Keyboard

1. Select the Onscreen Keyboard item in the View menu. or Press SHIFT+ALT+K (Shortcut key).  Define own Keyboard Shortcuts

1. Select the Keyboard Shortcuts item from the Tools menu. 2. Select a language in the Language for Shortcut(s) box. 3. Enter the shortcut in the Enter Shortcut box. 4. Define text you would like to enter in the document when you type the shortcut in the Enter Expansion box. 5. Click on the Add button. The shortcut and its expanded form will be displayed in the box. 6. Click on the Close button. The shortcut is now available for use while entering or editing text in the language for which it was defined.  Get Translation of official words/terms used in English

1. Select the Translation Dictionary item in the Tools menu. or Press F8 (Shortcut key). 2. Click on the Select Translation dictionary box to get a list of the translation dictionaries supported by LEAP Office and select one of the dictionaries. 3. Enter the English word for which you want the equivalent Indian language word in the Enter text to be translated box. 1. The Select word to be translated box will get filled with words which begin with the word you have entered. Click to select the word which is closest to the English word for which you want the Indian language translation. 2. The Select phrase to be translated box will get filled with the phrases which contain the word you want translated. Click to select the English phrase you

want translated to its equivalent Indian language phrase. 3. The translation of the selected English phrase will appear in the Translation box. Click to select a translated phrase. 7. Click on the Copy button to copy the translation into the document.  Add own words to the Translation dictionary

1. Enter the English word or phrase you want to add to the Translation dictionary in the Enter English phrase box in the Add own words to Translation dictionary group. 2. Enter the equivalent Indian language word or phrase in the Enter Indian language phrase box. 3. Click on the Add button to add the words to the Translation dictionary.  Undo the last change while editing

Select the Undo item in the Edit menu. or Press CTRL+Z (Shortcut key).  Get Synonyms of Indian language words

1. Select the Synonym Dictionary item in the Tools menu. or Press F9 (Shortcut key). 2. Click on the Select Synonym dictionary box to get a list of the synonym dictionaries supported by LEAP Office and select one of the dictionaries. 3. Enter the word for which you want a synonym, in the Enter the word to look up box. 4. The Select a phrase to look up box will get filled with words or phrases which sound similar to the word you have entered. Click to select a word or phrase which is closest to the word you want to look up. 5. The synonyms of the selected word or phrase will appear in the Synonyms of selected phrase box. Click to select the synonym of your choice. 6. Click on the Copy button to copy the selected synonym in your document. 7. Click on the Close button to close the Synonym Dictionary Bar.



Reformat documents using Find and Replace

1. Select the Find and Replace item in the Edit menu. or Press F3 (Shortcut key). 2. Click on the Format button below the 'Search for' box. Above action will pop-up a Menu with three items - Character, Paragraph, Style. Following is a list of attributes that you can modify by selecting the item. a. Character : Language, font, font size, colour, effects - Bold, Italic, etc., superscript, subscript, character width (tracking), line spacing (leading). b. Paragraph : Paragraph alignment c. Style : Text formatted in a particular style. Selecting any of the above items will take you to the Text Attributes box. Select the options to specify the search attributes. 3. Specify the attributes for the search text. 4. Click on the Format button below the 'Replace by' box.  Change the colour of text

Select the Character item in the Text menu. or Press CTRL+SHIFT+C (Shortcut key). Click the down arrow key in the Colour box. Select from a predefined list of colours. The preview portion in the dialog box will display the sample text with the colour selected. Click OK.  Spell Checker

1. Place the caret in the story from where you would like to start the spelling check in the document. 2. Select the Spell Check item in the Tools menu. or Press F7 (Shortcut key). The Spell Check Bar will be displayed, it will close automatically when the Spell Check is over.  Cut and Paste text

1. Select the text you want to cut. 2. Select the Cut item from the Edit menu. or Press CTRL+X (Shortcut key). 3. Place the caret in the document where you want to paste the text. 4. Select the Paste item in the Edit menu. or Press CTRL+V (Shortcut key).  Copy and Paste

1. Select the text you want to copy. 2. Select the Copy item from the Edit menu. or Press CTRL+C (Shortcut key). 3. Place the caret in the document where you want to paste the text.

4. Select the Paste item in the Edit menu. or Press CTRL+V (Shortcut key).  Insert graphics from other programs

1. Open the graphic in the application that created it. 2. Select and Copy the graphic ( or the portion you want to copy). 3. In LEAP Office select the Paste item in the Edit menu. or Press ALT+INS (Shortcut key). 4. Paste the graphic into the document.



Insert Shapes (Rectangle, Circle etc.,) in a document

1. Select the Shapes item in the Insert menu. A sub menu will pop up displaying the shapes ( Line, Rectangle, Rounded Rectangle or Ellipse) you can insert into your document. 2. Select the shape that you want to insert. The shape of the cursor will change accordingly. 3. Click the cursor in the document, to fix the starting point of the shape, and drag the mouse with the left button pressed, till the end point.  Fill Colour for the Shapes

1. Switch to the frame mode. Select the Frame item in the Edit menu. The buttons on the Properties Bar will change to show the Frame Properties. 2. Select the shape(s) in the document. The buttons on the Frame Properties Bar will change. 2. Click the down arrow on the Fill button on the Frame Properties Bar. A colour palette will be displayed. 3. Click on the colour you want to fill the selected shape with.  Set Outline Colour for the Shapes

1. Switch to the frame mode. Select the Frame item in the Edit menu. The buttons on the Properties Bar will change to show the Frame Properties. 2. Select the shape(s) in the document. The buttons on the Frame Properties Bar will change. 3. Click the down arrow on the Line Fill button on the Frame Properties Bar. A colour palette will be displayed. 4. Click on a colour to set the outline colour of the shape.  Save the document

1. Select the Save item in the File menu. or Press CTRL+S (Shortcut key). * If the document has not been previously saved a Save As dialog box will be displayed. Enter the file name under which you would like to save the current document

in the File Name box. Select the drive and directory in which you want to save the document in and click Save.  Save a copy of the currently active document under a different name

1. Select the Save As item in the File menu. The Save As dialog box will be displayed. 2. Enter the file name under which you would like to save the current document in the File Name box. 3. Select the drive and directory to save the document. 4. Click Save.  Exchange Indian language text with other Windows applications Using the Export command (Exchange text as RTF or HTML document) 1. Select Indian language text that you want to copy. 2. Select the Export item in the File menu. An Export dialog box will be displayed. 3. Click the down arrow key in the Export Files of Type box. 4. Select RTF text in this box ( to export the text in RTF format). or Select HTML text ( to export text as HTML). 5. Select the drive and directory in which you want to save the RTF or HTML document. 6. Enter a file name in the File Name box to save the RTF or HTML file as. 4. Click Export.  E-mail a document 1. After Creating the document. Select the Send Mail item in the File menu. A Send Mail dialog box having the following options will be displayed. a. RTF document - If sent as a RTF document, fonts used in the document need to be installed on the recipient's computer. Fonts are also available on the Internet for a free download at www.cdac.org.in. Another facility provided by LEAP Office is to send the font installation exe along with the email itself. You can do this the first time for every recipient. b. LP2 file - This option will send your LEAP Office document as an attachment in the mail. To be able to read your document, the recipient needs to have LEAP Office or LEAP Office Office installed on his/her computer. LEAP Office Lite (Trial Copy) is available on the Internet for a free download at www.cdac.org.in c. HTML document - This also needs fonts on the recipient's PC as explained above. d. ISCII document - This is for recipients who have a editor, word processor or GIST card which can recognize ISCII format e. BMP document (Monochrome). - Sends a monochrome Windows bitmap as an attachment. This is preferred for recipients who neither have fonts nor have LEAP Office. They can just view the mail and cannot do any editing on it. This generally has a smaller size than the JPEG attachment. The first visible page contents are sent.

f. JPEG document (Monochrome) - Similar to the Windows BMP but is also supported on non Windows platforms. *Tip : A BMP document is smaller in size than a JPEG document. 3. Click on the Send button. The E-mail client window will be opened. (This window and other subsequent windows or dialogs presented will be dependent on the E-mail client software that has been installed on your computer). Your document will be sent as an attachment. (The format is dependent on the option that you select in Step 3 above). Enter the E-mail address that you want to send to and other necessary options. Click OK.


				
DOCUMENT INFO
Shared By:
Categories:
Stats:
views:20644
posted:11/7/2009
language:English
pages:13