Docstoc

Backup on SBS 2008 std Fails after drive change - Tech-Archive.net

Document Sample
Backup on SBS 2008 std Fails after drive change - Tech-Archive.net Powered By Docstoc
					                             Backup on SBS 2008 std Fails after drive change

Backup on SBS 2008 std Fails after drive change

Source:
http://www.tech−archive.net/Archive/Windows/microsoft.public.windows.server.sbs/2010−02/msg01137.html



      • From: "Andyba" <andy_baguley@xxxxxxxxxxx>
      • Date: Thu, 25 Feb 2010 14:22:16 −0000

Std SBS 2008 installed in Jan. Fully patched.

Backup to two USB drives, both configured in SBS backup as Backup Drive 1,
and 2.

Plan was to rotate them on a weekly basis. One in service, one off site.

Invariably the backup fails on the evening of the day the drive is swapped.

Am backing up C: System, E: Exchange database, and F: Client files. Swap
file on D: is excluded.

Day 1. Backup successful on Backup drive 1

Day 2. Drives exchanged by office staff. Drive 2 now connected. Backup did
not finish successfully see event log.

The first error I see in the Application log is. It is about 2hr 10min after
the backup started:−

Log Name: Application
Source: VSS
Date: 23/02/2010 01:09:03
Event ID: 12293
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXXXX−SBS.xxxxxx.local
Description:
Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy
Provider {b5946137−7b9f−4925−af80−51abd60b20d5}. Routine details
EndPrepareSnapshots({2137c400−b79f−49f5−8d04−a6ef32313cdb}) [hr =
0x80070017].

Operation:
Executing Asynchronous Operation



Backup on SBS 2008 std Fails after drive change                                                    1
                           Backup on SBS 2008 std Fails after drive change
Context:
Current State: DoSnapshotSet
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event>
<System>
<Provider Name="VSS" />
<EventID Qualifiers="0">12293</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010−02−23T01:09:03.000Z" />
<EventRecordID>152359</EventRecordID>
<Channel>Application</Channel>
<Computer>XXXXXX−SBS.xxxxxx.local</Computer>
<Security />
</System>
<EventData>
<Data>{b5946137−7b9f−4925−af80−51abd60b20d5}</Data>
<Data>EndPrepareSnapshots({2137c400−b79f−49f5−8d04−a6ef32313cdb})</Data>
<Data>0x80070017</Data>
<Data>

Operation:
Executing Asynchronous Operation

Context:
Current State: DoSnapshotSet</Data>
<Binary>2D20436F64653A20434F52534E50534330303030313630392D2043616C6C3A20434F52534E50534330303
</EventData>
</Event>

Then follows:

Log Name: Application
Source: ESE
Date: 23/02/2010 01:09:13
Event ID: 2007
Task Category: ShadowCopy
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXX−SBS.xxxxxx.local
Description:
Information Store (1652) Shadow copy instance 14 aborted.

For more information, click http://www.microsoft.com/contentredirect.asp.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event>
<System>
<Provider Name="ESE" />
<EventID Qualifiers="0">2007</EventID>

Backup on SBS 2008 std Fails after drive change                                     2
                         Backup on SBS 2008 std Fails after drive change
<Level>2</Level>
<Task>16</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010−02−23T01:09:13.000Z" />
<EventRecordID>152363</EventRecordID>
<Channel>Application</Channel>
<Computer>XXXXXX−SBS.xxxxxx.local</Computer>
<Security />
</System>
<EventData>
<Data>Information Store</Data>
<Data>1652</Data>
<Data>
</Data>
<Data>14</Data>
</EventData>
</Event>

And Two logged events both:

Log Name: Application
Source: MSExchangeIS
Date: 23/02/2010 01:09:13
Event ID: 9782
Task Category: Exchange VSS Writer
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXX−SBS.xxxxxx.local
Description:
Exchange VSS Writer (instance 41059afb−2727−478a−8445−e708b23026c1:14) has
unsuccessfully completed the backup of storage group 'First Storage Group'.
No log files have been truncated for this storage group.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event>
<System>
<Provider Name="MSExchangeIS" />
<EventID Qualifiers="49193">9782</EventID>
<Level>2</Level>
<Task>41</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010−02−23T01:09:13.000Z" />
<EventRecordID>152361</EventRecordID>
<Channel>Application</Channel>
<Computer>XXXXXX−SBS.xxxxxx.local</Computer>
<Security />
</System>
<EventData>
<Data>41059afb−2727−478a−8445−e708b23026c1:14</Data>
<Data>First Storage Group</Data>
<Binary>46756C6C00</Binary>

Backup on SBS 2008 std Fails after drive change                               3
                             Backup on SBS 2008 std Fails after drive change
</EventData>
</Event>

About 8hrs later I then start seeing loads of:−

Log Name: System
Source: disk
Date: 22/02/2010 09:00:24
Event ID: 7
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: XXXXXX−SBS.xxxxxx.local
Description:
The device, \Device\Harddisk1\DR3, has a bad block.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event>
<System>
<Provider Name="disk" />
<EventID Qualifiers="49156">7</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010−02−22T09:00:24.664Z" />
<EventRecordID>231609</EventRecordID>
<Channel>System</Channel>
<Computer>XXXXXX−SBS.xxxzxxx.local</Computer>
<Security />
</System>
<EventData>
<Data>\Device\Harddisk1\DR3</Data>
<Binary>030080000100000000000000070004C0000100009C0000C00000000000000000007E0000000000006E2E4D
</EventData>
</Event>

Some entries refer to \Device\Harddisk1\DR3

I hope that these are pointing to the USB backup disks, and not the main
drives!! I think they are as they only seem to exist on days when the backup
has failed, and the situation has not been corrected. They stop when I
re−configure. (remove and then add the USB drive within the backup config)

If left with no attendance, I get roughly the same errors on Day 3

Day 4 it fails with Backup error :
The creation of the shadow copy on the backup destination failed.
Unknown error (0x8004230f)

Now if on Day 5 I remove Drive 2 from the server backup configuration, and then add
the same physical drive back into the schedule, again as Backup Drive 2,

Backup on SBS 2008 std Fails after drive change                                       4
                            Backup on SBS 2008 std Fails after drive change

then manually run a backup it runs fine. No failure. Did not even disconnect
the drive from the server.

Seems to happen on both backup drives. It's the changeover that causes the
problem.

I've even re−configured the backup from scratch with both drives connected,
and then removed one to let the backup sequence begin with the other.

Assistance very much appreciated.

TIA



.




Backup on SBS 2008 std Fails after drive change                                5

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:4
posted:2/13/2013
language:English
pages:5