Docstoc

Pengenalan Komponen Dasar

Document Sample
Pengenalan Komponen Dasar Powered By Docstoc
					Created By Uus Rusmawan



                                     BAB 2
                               PROJECT DAN FORM

Produk Microsoft telah banyak digunakan di dunia termasuk di Indonesia maka
komponen dasar VB.NET pun bagi kita tidak asing lagi terlebih bagi mereka yang
sudah terbiasa menggunakan VB 6.0 karena cara penggunaannya hampir sama.

2.1 Memulai VB.NET

1.   Klik Menu Start
2.   All Programs
3.   Microsoft Visual Studio .Net 2003
4.   Microsoft Visual Studio .Net 2003




                           Gambar 2.1 Memulai VB.NET

2.2 Membuat Project Baru

1.   Klik Menu File
2.   Pilih New
3.   Pilih Project




                      Gambar 2.2 Membuat project baru

4.   Cara lainnya adalah dengan melakukan klik pada ikon New Project di bagian
     bawah sesaat setelah VB.NET diaktifkan.




                      Gambar 2.3 Membuat project baru

5.   Pilih WindowsAplication
6.   OK




                                                                                 7
Created By Uus Rusmawan




                       Gambar 2.4 Memberi nama project

Pada kotak Name: Anda dapat menuliskan nama project atau membiarkannya
sesuai kondisi default, dan perhatikan pula kotak Location, karena di posisi tersebut
akan dibentuk nama folder sesuai dengan nama project yang ditulis dalam kotak
Name.

1.3 Komponen Dasar VB.NET

1.   Balok Menu
2.   Balok Standart
3.   ToolBox
4.   Form
5.   Solution Explorer Windows
6.   Properti Windows




                     Gambar 2.5 Komponen dasar VB.NET



8
Created By Uus Rusmawan



2.4 Menambah Form

1.    Klik menu Project
2.    Add Windows Form




                     Gambar 2.6 Menambah form baru

Cara lain untuk menambah form adalah:

1.    Klik kanan mouse pada nama project
2.    Pilih Add
3.    Klik Add windows Form




                     Gambar 2.7 Menambah form baru

Ketika muncul menu, nama form dapat mengganti sesuai kebutuhan atau
membiarkan namanya sesuai nilai default yaitu Form?.vb.

2.5    Menghapus Form

1.    Klik kanan nama form
2.    Pilih Delete
3.    Pilih Yes




                                                                  9
Created By Uus Rusmawan




                          Gambar 2.8 Menghapus Form

2.6    Mengetengahkan Form

1.    Klik Form
2.    Klik StartPosition di jendela properti
3.    Pilih CenterScreen




                       Gambar 2.9 Mengetengahkan form

2.7    Memaksimalkan Ukuran Form

1.    Klik Form
2.    Klik WindowState di jendela properti
3.    Pilih Maximized




                   Gambar 2.10 Memaksimalkan ukuran form

2.8    Mengubah Nama Form

1.    Klik Form
2.    Klik properti File Name
3.    Tulis nama form (jangan menggunakan spasi)


10
Created By Uus Rusmawan




                     Gambar 2.11 Mengubah nama form

Cara lain mengubah nama form adalah:

1.   Double klik form
2.   Klik properti (Name)
3.   Tulis nama form




                     Gambar 2.12 Mengubah nama form

Cara ketiga mengubah nama form :

1.   Klik Menu Project
2.   Add Windows Form
3.   Tulis Nama Form
4.   Open




                      Gambar 2.13 Memberi nama form


                                                      11
Created By Uus Rusmawan



5.     Open

2.9     Memberi Judul Form

1.     Klik Form
2.     Klik Properti Text
3.     Tulis Judul Form




                        Gambar 2.14 Mengubah Judul Form

2.10    Memilih Form Startup

1.     Klik menu project
2.     Pilih ????? Properties..(di sub menu paling bawah)
3.     Pilih form yang akan dijadikan StartUp




                        Gambar 2.15 Memilih StartUpForm


Cara lain memilih StartUp Form adalah

1.     Klik kanan nama project
2.     Pilih properti
3.     Pilih nama form yang akan dijadikan StartUp
4.     Klik Apply
5.     Klik Ok




12
Created By Uus Rusmawan




                      Gambar 2.16 Memilih StartUp Form

2.11 Membuat Menu

Pembahasan tentang menu sengaja dibicarakan lebih awal agar pada bab
berikutnya Anda tinggal mencobanya. Cara pembuatannya adalah sebagai berikut
(dengan asumsi dalam satu project ada dua buah form yaitu Form1 dan Form2
dimana Form1 akan dijadikan menu utama)

1.   Jika ToolBox tidak terlihat di layar klik Ikon ToolBox




                           Gambar 2.17      ikon ToolBox

2.   Klik dua kali ikon MainMenu




                         Gambar 2.18 Ikon MainMenu



                                                                          13
Created By Uus Rusmawan



3.   Tulis menu sesuai kebutuhan




                        Gambar 2.19 Merancang menu

4.   Klik dua kali menu Barang
5.   Tulis coding di bawah ini

Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles MenuItem2.Click
       ‘definisikan Form sebagai Form1
       Dim Form As New Form1
       ‘tampilkan form paling atas (menyebabkan form lain tidak dapat digunakan)
       Form.TopMost() = True
       ‘tampilkan form1
       Form.ShowDialog()
       Form.Dispose()
End Sub

Dengan beberapa petunjuk di atas diharapkan         pembaca   dapat   melakukan
memodifikasi project dan form secara mandiri.




14

				
DOCUMENT INFO
Shared By:
Tags:
Stats:
views:39
posted:11/20/2012
language:
pages:8
Description: Bagi yang mau jadi programmer