ProEngineer/ProMechanica Crash Course by u0bnRc

VIEWS: 7 PAGES: 5

									                       ProEngineer/ProMechanica Crash Course

Objective
Develop, design, and analyze a 3-D model.

Procedure Outline
    Create new part file.
    Develop 2-D sketch.
    Extrude/Revolve/…. the 2-D sketch into a 3-D solid part.
    Create new assembly file.
    Add 3-D parts together to create a 3-D subassembly/assembly.
    Create and Run a Design Study Analysis.

Create New Part File
Open ProE and click on File>New (or new icon), select Part and name the file (the
default will be something like prt0001, change this).
First thing to do is set the model into the desired units.
Select Edit>Setup, the Menu Manager will appear to the right of the screen. Select the
option for Units and highlight the desired units, then click on Set and click the option
required (if this is done prior to any sketching either option will suffice) and click Close.
Important: This step will need to be repeated for each new part or assembly!!

Develop 2-D Sketch
Now you are ready to make the first sketch. Click the top icon,      , on the right tool
chest (right tool chest is the group of commands on the right side of the screen). You
now have to decide your desired sketch orientation. This is done by selecting a datum or
object surface as your sketch surface and another reference as the top, bottom, etc…
Once you have decided on your orientation you will enter the sketching view. Use the
icons located on the right side of the screen to create any 2-D shape. Define each shape
by the appropriate dimensions using the dimension tool. Be sure all lines are connected
and once finished with the sketch click on the green check mark to bring the sketch back
to the model view.

Extrude/Revolve/… the 2-D Sketch into a 3-D Solid Part
You can now extrude/revolve/… your 2-D sketch by utilizing the commands
located on the bottom right hand side of the screen. Using these tools you will set
the depth at which to extrude your sketch, or what angle to revolve the sketch….
Once satisfied, again click on the green check mark to accept your modification.
You can now also use the commands located between the sketch/datum tools and
the extrusion/revolve tools to create chamfers, rounds, holes, etc… You can now
reenter the sketch mode to create more geometries to your part and repeat the steps
above. Be sure to save your part file. An extrusion can be made to add material to
your part or remove material from your part. This is done by selecting the
appropriate condition in the flyout located near the bottom left once in extrusion
mode. For example, to make a hole in an object you will enter the 2-D sketch
mode and sketch a circle. Then renter the 3-D environment and select extrude, and
select the remove material option and extrude to the appropriate depth, or through
all the material.

Create New Assembly File
Use the same step as you would to create a new part file to create an assembly file.
Simply select the Assembly option instead of the Part option. REMEMBER TO SET
THE MODEL TO THE APPROPRIATE UNITS. Use the icon located almost half
way down the right hand side of the screen to place a new component to the assembly.
This will open a dialog box that lets your browse to the desired part or assembly file you
wish to add to this assembly. Once you add a part it will want you to constrain the part.
If it is the first part to the assembly you can just accept the part where it is and constrain
every part from then on in relation to the first part. To constrain the part click on
Placement near the bottom left and you will see the options for constraints. There is an
automatic option that does a good job, but if it is not doing what you want it to do,
change the automatic option to the appropriate condition. Once you have assembled all
the parts you are ready to save it and enter the Mechanica portion of ProE.

Create and Run a Design Study Analysis
To enter Mechanica select Applications>Mechanica from the top toolbar. A menu
manager will pop up in the top right portion of the screen. Make sure structure is the
mode of analysis and the FEM option is not checked. Click OK and you will enter the
Mechanica portion of ProE. Please be aware that this is not the only order that may be
followed, but you must select the materials before you mesh your assembly. Therefore,
assigning materials will be the first thing explained here. To assign materials you must
first select the materials that will be needed for your assembly. To do this click on this
icon      . You will now see your material library. To add a material to the model select
in and click the arrow pointing to the right. You will also need to create your own
material to represent the poplar wood. To do this select File>New, and input the
appropriate properties. Do not worry about the thermal properties since we are only
considering structural analyses. Search the internet for material properties on poplar
wood (matweb.com) and enter the information. Although wood is not isotropic, it may
be easier to use an average of values or assume everything is in the same direction and
use those values. Once you enter the properties save the file to the library as well as the
model, that way if you work on the model on different computers the material properties
will be stored within the model. Once you have moved the appropriate materials to the
model click OK to return to the model. Now you have to assign the materials you just
selected to the appropriate part. This is done by clicking the icon      , located just below
the previous one. This will bring up a menu in the top right where you will select the part
(multiple parts of the same material can be selected by ctrl + clicking each part) and
assign it the appropriate material using the drop down box in the menu. Do this for each
part (if you forget a part ProE will tell you it can’t mesh or do an analysis.). When you
assign the material to the part you should see a tag image attached to each part that has a
material assigned to it.

From here you can either go ahead and mesh your model or install constraints, loads,
etc… I will start with meshing the model. This is done by clicking the icon     or by
selecting AutoGEM>Create from the top toolbar. This will bring up a small menu that
should have All with Properties already listed, make sure this is so and then click create.
After a few seconds you should see your model in a blue color with lines moving through
it. A message box with the attributes of the mesh will also appear, the mesh should be
sufficient so go ahead and click close. Close the AutoGEM control box as well, saving
the mesh is a good idea so go ahead and do that as well. Once you save it you will notice
the model returns to its normal view, don’t worry, your mesh is still there.

You are now ready to add your loads and your constraints. The first icon in the top right,
    , will allow you to add loads to the model. Under the Reference drop down list you
can select surfaces, lines, or points. Select the one that applies to your model, most likely
a surface. Then you can select the surface in the model by left clicking it. Then assign a
numerical value for the load. As you can see it asks for x, y, and z components, therefore
for a straight up and down load set the x and z components to zero and let y equal the
appropriate load value. Once everything looks good confirm this by clicking OK.

You can now create your constraints by limiting the displacement of certain part faces,
edges, or points. Click the icon    to bring up the displacement constraint menu. Under
references there is a drop down box that allows you to select surfaces, edges/curves, or
points. Select what is appropriate and select the corresponding surface, edge, or point in
the model. At the bottom of the menu are the options for the displacement constraint. It
defaults to not allowing any motion at all, but that can be modified by selecting the other
options for each coordinate direction. Once you have selected the required constraints
accept them by clicking OK.

You are now ready to perform an analysis. Click the icon , located next to the create
mesh icon. This will pop up the Analysis and Design Studies menu. Click on File>New
Static… to create a new analysis. This will show a new menu where you can select your
analysis options, but the defaults are sufficient so just click OK. This will bring you back
to the previous menu; now click on the green flag to start your analysis. Go ahead and
click yes to any message that pops up. The solver will run in the background, but you
can monitor the status by clicking Info>Status in the top toolbar of the menu box. It will
either say Run Completed at the bottom of the solver or Fatal Error Occurred if
something went wrong. If you get a Fatal Error Occurred message double check your
constraints to make sure you have enough displacement constraints to prevent rigid body
motion. The icon farthest to the right in the Analysis and Design Studies menu is where
you can review your results. Click this menu and select what kind of results you want to
see (stresses, displacements …). If you want to animate your solution you can click on
the Display Options tab and check the animate check box. Once you select the options
you want go ahead and click OK and Show. You will now a contour plot corresponding
to the solution of the simulation.

Develop and Engineering Drawing of your Model
The last step concerning your ProE development is to create an engineering drawing of
you model. This of this drawing as something you would give to a machinist to create
the components of your model. Therefore, each part would need the appropriate
dimensions and any corresponding features (drill and tap features, chamfer angles …).
The first step is to click File>New in ProE, this time select Drawing and fill in an
appropriate name. A new menu box will appear asking you to select a default model as
well as a page template style. Size A will give you standard page size (8.5” by 11”).
Once you click OK a drawing page will be shown with two representations of whatever
model you selected as your default. To create dimensions select Insert>Dimension>New
Reference…, now left click on two points or lines in which you want to list a distance
for. Once you left clicked on the two points of interest, middle click to create your
dimension. It is important to remember that these dimensions are representations of you
model; you can not edit your model dimensions from a drawing. If you want to add a
different model to your drawing you will do the following:
Select File>Properties, you will see a menu in the top right, select Drawing Models and
then Add Model. Browse to the model you wish to also draw. To create a new drawing
view select Insert>Drawing View>General (typically select general) then you can set up
the orientation and the appropriate model in the menu box that appears.

A good drawing should also have a bill of materials (BOM). A bill of materials lists what
parts are used in the model and the quantity of each. Creating a bill of materials can be
tricky in ProE, but I will try my best to outline the steps below.

The first thing to do is create a table. Decide what about your model you want listed in
the table, usually you should have an index number (which will be used for the balloons),
the name of the part, and the quantity of the part used in the model. So therefore we are
going to first create a table with three columns and two rows to start with. The first row
will be a label for the column, and the second row will become a repeated row dependent
on the parts in the model. Therefore, select Table>Insert>Table from the top toolbar. A
new menu will appear in the top right, just keep the defaults and make the table as
follows, click a point in the drawing where you want to make your table (the table can be
moved after this, so any location is fine). Next you will select the column widths by
clicking your mouse after the number of units wide you want each column. For example,
if I want three columns all 8 units wide I will click my mouse after the 8 until I have 3
columns, then click done on the menu on the top right, now I make my row heights in the
same fashion. I just want them to be 1 unit high so I will click my mouse after the one
and create two rows. After you click done on the menu a second time your 3 column 2
row table will be visible. Go ahead and label the columns by double clicking in each cell
and writing the appropriate label, like Part Index, Part Name, Part Quantity. Now we will
create our repeated region in the second row. Select Table>Repeat Region in the top
toolbar and a new menu will appear to the right. Click the first option, Add. Now you
will click the bottom left cell of the table and then the bottom right cell of the table.
Although only the bottom left cell will be highlighted in red, you’re repeat region is the
entire second row. Go ahead and click done, now if you click the any of the bottom cells
in the table the entire row will highlight in an orange color, showing the repeat region.

The next thing to do is assign the type of description to each column. To do this double
click in each cell that is set as your repeated region. For example we will set the first
column as the index, which is just a numbering of each part used in the model. Double
click on the lower left cell, this will show a report symbol dialogue box. To set this
column as the index single click rpt, (you will notice as soon as you click on this a new
set of symbols are displayed, to go back simply click on UP) next click on index. The
symbol box will disappear and in the lower left cell you will see the lettering rpt.index.
Next we will enter the name of the part in the middle column. In the same fashion double
click the middle cell of the second row. Now click abs, then mbr, then name. You
should now see abs.mbr.name. Think of this as assembly, member, name. Now we will
put the quantity in the remaining column. Double click on the last cell, and then click rpt
and qty. Written in that cell should be rpt.qty.

Now we will edit the parameters of this BOM so that the parts are not repeated for each
instance they are used. Select Table>Repeat Region…, and then click on Attributes. A
small box will appear wanting you to select the repeat region you wish to edit. Click on
the any lower cell of our table to highlight the entire repeat region. Once you have done
that you will see the editable attributes. We will change the first section to No
Duplicates. Once you click done the table should update with the applicable values, if
not right click anywhere on the drawing and select Regenerate Draft. Remember when
right clicking you have to hold down the right mouse button to bring up the menu. You
should now see your nice bill of materials.

Now we will create balloons that will point to each part and display their corresponding
index number in the table. Select Table>BOM Balloons… from the top toolbar. Set
region will already by highlighted in the menu that appears. Therefore, we need to select
the repeat region in which we want balloons created for. Pick the repeat region we just
created by left clicking anywhere within the repeat region. Select OK in the small box
and select Create Balloon and now it is asking for you to select the view in which you
want the balloons to connect to. Select any view you wish. There should be balloons
connecting to the individual parts of your model in the view you selected. Each balloon
can be moved as you wish.

That should be just about all you really need to do. ProE is a hard program just to pick
up and use, there are a lot of quirky things within the program that may not make sense at
first. Just play around with it and the more and more you use it the more familiar things
will become. If you have any questions you can e-mail me at cgriffin@mix.wvu.edu and
we’ll have a little review when you get back from break on Monday and Tuesday night at
5pm and 6pm again.

Remember what I said about making two models, one to use as your drawing base with
the nuts and bolts, and another without them with just bonded interfaces to do your
analysis on. You can go ahead and try to do your analysis on the nuts and bolts design,
but you may run into meshing problems and interface problems. And always remember
to CHECK YOUR UNITS.

								
To top