Kyds Excel Shortcut Keys

Document Sample
Kyds Excel Shortcut Keys Powered By Docstoc
					Introduction

I intend this to be a complete list of Excel shortcut keys when a worksheet is active.

Most of these key combinations perform the same task in both New Excel (version 2007 and
after) and Classic Excel (earlier versions). Where the tasks differ, "XL-C:" indicates the Classic
Excel result and "XL-N:" indicates the New Excel version.

In addition to the All Shortcuts sheet, this workbook includes a Dialogs sheet. This shows all
shortcut keys I've found that launch dialogs in Excel. Notice that in some cases, you can use
more than one key combination to launch the same dialog. For example, both F5 and Ctrl+G
launch the Go To dialog.

Please email me your additions or corrections. When I make corrections I'll update the
workbook and alert everyone who subscribes to my newsletter.

Note: I don't own a Mac. But if Mac users want to send me additions or corrections for Macs,
I make this info available as well.

Charley Kyd, Excel MVP
Kyd@ExcelUser.com
Introduction

I intend this to be a complete list of Excel shortcut keys when a worksheet is active.

Most of these key combinations perform the same task in both New Excel (version 2007 and
after) and Classic Excel (earlier versions). Where the tasks differ, "XL-C:" indicates the Classic
Excel result and "XL-N:" indicates the New Excel version.

In addition to the All Shortcuts sheet, this workbook includes a Dialogs sheet. This shows all
shortcut keys I've found that launch dialogs in Excel. Notice that in some cases, you can use
more than one key combination to launch the same dialog. For example, both F5 and Ctrl+G
launch the Go To dialog.

Please email me your additions or corrections. When I make corrections I'll update the
workbook and alert everyone who subscribes to my newsletter.

Note: I don't own a Mac. But if Mac users want to send me additions or corrections for Macs,
I make this info available as well.

Charley Kyd, Excel MVP
Kyd@ExcelUser.com
ExcelUser Keyboard Shortcuts, New Excel (XL-N) and Classic Excel (XL-C)
  Key         Default                    Shift                    Ctrl                    Alt                 WinKey            Shift+WinKey      Ctrl+WinKey              Ctrl+Shift
Function Keys
                                                                                                       Display or hide the                     Switch to the
                                                                                                       Start menu.                             program that
                                                                                                                                               displayed a message
                                                                                                                                               in the notification
                                                                                                                                               area.
F1      Help                    Help (Context            XL-C: Show/Hide        XL-C: Create a chart    Display Windows Help.
                                Sensitive)               TaskPane               sheet of selected data.
                                                         XL-N: Show/Hide        XL-N: Insert a chart
                                                         Ribbon                 object

F2      Toggle Enter and Edit   Insert or edit a         XL-N: Print preview    Save As dialog
        Modes                   comment.
F3      Paste Name dialog       Insert Function dialog   XL-C: Define Name                                                                                           Create Names dialog
                                                         dialog
                                                         XL-N: Name Manager
                                                         dialog
F4      In sheet: Re-Do. In     Find Next (from last     Close active window.   Close Excel                                                                          Find Previous (from
        formula bar: Toggle     search)                                                                                                                              last search)
        relative & absolute
        cell references
F5      Go To dialog            Find dialog              Restore window

F6      XL-C: Next pane of      Previous pane of split   Next workbook          Switch to VBA IDE if                                                                 Previous workbook
        split windows           windows                  window                 open                                                                                 window
        XL-N: Also ribbon,      XL-N: Also ribbon,
        Zoom, & task pane       Zoom, & task pane
F7      Spelling dialog         XL-N: Show Research      Move window with
                                pane                     arrow keys. (Esc to
                                                         stop.)
F8      Toggle Extend           Add another range to     Resize window          Macro dialog
        selection mode.         selection mode
F9      Calculate Now           Calculate active sheet Minimize window


F10     XL-C: Toggle menu bar Activate Right Click       Toggle Maximize &
        XL-N: Toggle ribbon   (Context) Menu.            Restore window
        keytips

F11   XL-C: Create chart        Insert new worksheet. Insert XL 4 Macro         Opens and shows VBA
      sheet                                           sheet                     IDE
      XL-N: Create chart
      object
F12   Save As dialog            Save                     Open dialog                                                                                                 Print dialog
Number Keys
1!         1       !   Format dialog for the                                                                               Apply number format:
                       selected object: cell,                                                                              #,##0.00
                       chart, etc.
2@         2       @   Toggle bold                                                                                         Apply the time format:
                       formatting.                                                                                         h:mm AM/PM

3#         3       #   Toggle italic format.                                                                               Apply the date format:
                                                                                                                           d-mmm-yy

4$         4       $   Toggle underlining.                                                                                 Apply the currency
                                                                                                                           format:
                                                                                                                           $#,##0.00_);[Red]($#,#
                                                 Start the program                                                         #0.00)
5%         5       %   Toggle strikethrough.                               Start a new instance    Switch to the last      Apply the percentage
                                                 pinned to the taskbar
                                                                           of the program          active window of the    format: 0%
                                                 in the position
                                                                           pinned to the taskbar   program pinned to
                                                 indicated by the
6^         6       ^   Shift from hiding,                                  in the position         the taskbar in the      Apply the exponential
                                                 number. If the program
                       displaying, and using                               indicated by the        position indicated by   format: 0.00E+00
                                                 is already running,
                       placeholders for                                    number.                 the number.
                                                 switch to that program.
                       objects.
7&         7       &   Display or hide the                                                                                 Apply the outside
                       Standard toolbar.                                                                                   border to the selected
                                                                                                                           cells.
8*         8       *   Displays or hide the                                                                                Select the current
                       outline symbols.                                                                                    region.

9(         9       (   Hide the selected                                                                                   Unhide any hidden
                       rows.                                                                                               rows within the
                                                                                                                           selection.
0)         0       )   Hide the selected                                                                                   Unhide any hidden
                       columns.                                                                                            columns within the
                                                                                                                           selection.
Letter Keys
A       a      A       Select all. With                                                                                    Insert the argument
                       insertion point after a                                                                             names and
                       function in the                                                                                     parentheses for a
                       formula bar, display                                                                                function, after you
                       the Function                                                                                        type a valid function
                       Arguments dialog.                                                                                   name in a formula
B      b       B       Toggle bold               Set focus on a
                       formatting.               notification.
C      c       C       Copy. Used twice,
                       displays clipboard.
D   d   D   Fill (Copy) Down - If a XL-C: Data menu         Show the desktop.
            single cell is selected, XL-N: Alt, D key combo
            copy the cell
            immediately above it.
            If a range is selected,
            copy the uppermost
            cell into the lower
E   e   E   cells.                   XL-C: Edit menu        Open My Computer.
                                     XL-N: Alt, E key combo

F   f   F   Find Dialog           XL-C: File menu          Search for a file or                           Search for computers. Font Drop Down List
                                  XL-N: Alt, F key combo   folder.

G   g   G   Go To Dialog                                   Cycle through gadgets.

H   h   H   Replace Dialog        XL-C: Help menu
                                  XL-N: Alt, H key combo

I   i   o   Toggle Italics        XL-C: Insert menu
                                  XL-N: Alt, I key combo
J   j   J
K   k   K   Insert Hyperlink
L   l   L   XL-C: Create List                              Lock your computer if                                               XL-N: Toggle AutoFilter
            XL-N: Create Table                             you are connected to a
                                                           network domain, or
                                                           switch users if you are
                                                           not connected to a
                                                           network domain.
M   m   M                                                  Minimize all windows.     Restores minimized
                                                                                     windows.

N   n   N   New Workbook                                   OneNote Clipping Tool

O   o   O   File Open dialog      XL-C: Format menu                                                                            Select all cells with
                                  XL-N: Alt, O key combo                                                                       comments.

P   p   P   Print dialog                                   Choose a presentation                                               XL-C: Point size drop
                                                           display mode.                                                       down list
                                                                                                                               XL-N: Font tab of
                                                                                                                               Format Dialog
Q   q   Q
R   r   R   Fill Right                                     Open the Run dialog
                                                           box.
S   s   S   Save or Save As
T   t   T   XL-N: Insert Table    XL-C: Tools menu       Cycle through                                                         XL-N: Toggle Total row
                                  XL-N: Alt, T key combo programs on the                                                       in Table
                                                         taskbar.
U       u                        U                 Underline                                          Open Ease of Access   XL-N: Toggles
                                                                                                      Center.               expanding and
                                                                                                                            collapsing the formula
                                                                                                                            bar.
V       v                        V                 Paste                     XL-C: View menu
                                                                             XL-N: Alt, V key combo

W       w                        W                 Close Workbook            XL-C: Window menu
                                                   Window                    XL-N: Alt, W key combo

X     x                 X                          Cut
Y     y                 Y                          Redo last action
Z     z                 Z                          Undo last action
Keys Near the 10-Key Pad
-     Minus             Toggles the Add mode       Delete dialog             Toggle Excel's Window
                                                                             control
+       Plus                                       Insert dialog
*       Multiply                                   Go To Current Region

/     Divide                                       Go To Current Array
Punctuation Keys
`~    ` (Left Quote)             ~ (Tilde)         Alternate between                                                        (~) Apply the General
                                                   displaying cell values                                                   number format.
                                                   and displaying
                                                   formulas in the
                                                   worksheet.
-_      - (En Dash, minus)       _ (Em Dash)       Delete dialog             Toggle Excel's Window                          Remove all borders
                                                                             control                                        from the selected cells.

=+      = (Equal Sign) Start a   + (Plus Sign)     Calculate all sheets in   Autosum a range of                             (+) Display the Insert
        formula                                    all open workbooks        cells.                                         dialog box to insert
                                                                                                                            blank cells.
[{      [ (Left Bracket)         { (Left Brace)    Select only cells that                                                   ( { ) Select all cells that
                                                   are directly referred                                                    are directly or
                                                   to by formulas in the                                                    indirectly referred to
                                                   selection. (Go To                                                        by formulas in the
                                                   Special dialog,                                                          selection. Highlight
                                                   Precedents.)                                                             Indirect Cell
                                                                                                                            Precedents.
]}      ] (Right Bracket)        } (Right Brace)   Select only cells with                                                   ( } ) Select all cells with
                                                   formulas that refer                                                      formulas that refer
                                                   directly to the active                                                   directly or indirectly
                                                   cell. (Go To Special                                                     to the active cell.
                                                   dialog, Dependents.)                                                     Highlight Indirect Cell
                                                                                                                            Dependents.
\|      \ (Backslash)           | (Pipe)                 In a selected row,                                                                                  In a selected column,
                                                         select the cells that                                                                               select the cells that
                                                         don't match the                                                                                     don't match the
                                                         formula or static value                                                                             formula or static value
                                                         in the active cell.                                                                                 in the active cell.
;:      ; (Semicolon)           : (Colon)                Enter the current date. Select only visible cells                                                   Enter the current time.
                                                                                  in selection
'"      ' (Single Quote)        " (Double Quote)         Copy the formula         Format Style dialog                                                        Copy the value from
                                                         from the cell above                                                                                 the cell above the
                                                         the active cell into the                                                                            active cell into the
                                                         formula bar.                                                                                        formula bar.
,<      , (Comma)               < (Less-Than Symbol)                                                                                                         Copy the formula in
                                                                                                                                                             the cell above the
                                                                                                                                                             active cell to the
                                                                                                                                                             active cell.
.>      . (Period or Decimal)   > (Greater-Than          Move clockwise to the                                                                               Copy the formula in
                                Symbol)                  next corner of the                                                                                  the cell to the left of
                                                         selection                                                                                           the active cell to the
                                                                                                                                                             active cell.
?/      ? (Question Mark)       / (Forward Slash)        Select current multi-
                                                         cell array.
Other Keys
Arrow Move up one cell.         Extend selection up      Move up to the last       Close the AutoFilter list Maximize active       Stretch active            Move up to the first
Up                              one cell.                cell in the area.         for the current column window.                  window to the top         cell in the area and
                                                                                                                                   and bottom of the         extend the selection.
                                                                                                                                   screen.
Arrow   Move down one cell.     Extend selection down Move down to the last Display AutoComplete             Restore active window Minimize active           Move down to the last
Down                            one cell.             cell in the area.     list                                                   window.                   cell in the area and
                                                                                                                                                             extend the selection.

Arrow   Move left one cell.     Extend selection left    Move left to the last                               Maximize the window        Move a window from   Move left to the first
Left                            one cell.                cell in the area.                                   to the left side of the    one monitor to       cell in the area and
                                                                                                             screen.                    another.             extend the selection.

Arrow   Move right one cell.    Extend selection right   Move right to the last                              Maximize the window        Move a window from   Move right to the last
Right                           one cell.                cell in the area.                                   to the right side of the   one monitor to       cell in the area and
                                                                                                             screen.                    another.             extend the selection.

Back-  Delete one character     Collapse selection to    Scroll to display the     Undo
space to the left in the        the active cell.         active cell
       formula bar
Delete Clear selection and      Cut selection            Clear to the end of the
       activate the formula                              line
       bar. Clear one
       character to the right
       in the formula bar.
End      Toggle End mode.         Extend selection to       Select bottom right                                                            Extend the selection
         (Scroll Lock on: Move    the last cell in the row. cell of the used range.                                                        to the bottom-right
         to lower-right corner                                                                                                             cell of the used range.
         of window.)
Enter    Complete cell entry.     Enter value and move Fill selected range              Redo. In formula bar:                              Array-enter the
Return                            up in selected range. with the entry in the           Start a new line in the                            formula(s)
                                                        active cell.                    same cell.
Esc      Cancel most dialogs      Cancel most dialogs   Display the Windows                                                                Display the Windows
         and modes                and modes             Start Menu                                                                         Task Manager

Home     Move to the first cell Extend selection to        Select the first cell in a                                                      Extend the selection
         in a row. (Scroll Lock the first cell in the row. window or pane.                                                                 to the first cell in a
         on: Move to upper-                                                                                                                window or pane.
         left corner of window.)

Insert   Toggle Overwrite    Paste                Copy
         mode while editing.
Page     Move down one page Extend selection down Move to the next                      Page Right                                         Extend selection to
Down                         one page.            sheet in a workbook.                                                                     the next sheet in a
                                                                                                                                           workbook.
Page     Moves one screen up      Extend selection up       Move to the previous        Page Left                                          Extend selection to
Up       in a worksheet.          one page.                 sheet in a workbook.                                                           the previous sheet in a
                                                                                                                                           workbook.
Space- In a dialog box,         Select entire selected Select entire selected           Display the Control       Preview the desktop.     Select the entire
bar      perform the action for row(s) in a worksheet. column(s) in a                   menu for the Excel                                 worksheet. If
         the selected button,                          worksheet.                       window.                                            worksheet contains
         or selects or clears a                                                                                                            data, select current
         check box.                                                                                                                        region; press keys a
                                                                                                                                           second time to select
                                                                                                                                           entire worksheet.
                                                                                                                                           When an object is
                                                                                                                                           selected, selects all
                                                                                                                                           objects on a
                                                                                                                                           worksheet.
Tab      Move: Right one cell Move to the previous          Move to the next       Switch to the next                                      Move to the previous
         in a worksheet.         cell in a row or a         workbook or window. program                                                    workbook or window.
         Between unlocked        dialog.                    Switch to the next tab                                                         Switch to the previous
         cells in a protected                               in a dialog box.                                                               tab in a dialog box.
         worksheet. To the
         next option in a dialog
         box.
Pause/                                                                                                            Display the System
Break                                                                                                             Properties dialog box.
                                     Send additions or corrections.
       Alt+Shift            Ctrl+Alt             Ctrl+Shift+Alt




New Sheet            Insert a new XL4
                     Macro sheet.



Save                 Open dialog             Print Dialog

                     XL-N: New Name
                     dialog


Close Excel          Close Excel             Close Excel



                     XL-N: Refresh All
                     PivotTables




                     Calculate all           Rebuild the
                                             dependency tree, then
                                             calculate all.
smart-tag menu



Open Script Editor
                 Paste Special




Toggle Excel's
Window control
Ungroup rows or       Move to the left
columns. Ungroup      between nonadjacent
selected PivotTable   selections
items.
Group rows or         Move to the right
columns. Group        between nonadjacent
selected PivotTable   selections
items.
Extend Selection Page
Right

Extend Selection Page
Left




 Switch to the          Indent text
 previous program
Shortcuts to Excel 2003 and 2007 Dialogs                                              Send additions or corrections.
          Shortcut              XL 11 Command                     Title                     Description

Ctrl+O                       File, Open                Open                  Open a worksheet
Ctrl+F12
Ctrl+P                       File, Print               Print                 Print a document
Ctrl+Shift+F12
F12                          File, Save As               Save As             Save a workbook as new file
Ctrl+S                       File, Save or File, Save As Save or Save As     Save or Save As


Ctrl+- (hyphen)              Edit, Delete              Delete                Deletes selected files
Ctrl+- (minus)
Ctrl+F                       Edit, Find                Find                  Find
Shift+F5
Ctrl+H                       Edit, Replace             Replace               Replace
F5                           Edit, Go to               Go To                 Go to cell or range name
Ctrl+G

Ctrl+Shift+= (equal)         Insert, Cells             Insert                Inserts cells in worksheet
Ctrl++ (plus)
Shift+F3                     Insert, Function          Insert Function       Quick access to worksheet functions
Ctrl+K                       Insert, Hyperlink         Insert Hyperlink      Insert Hyperlink
Ctrl+Shift+F3                Insert, Name, Create      Create Names          Create names from row and column
                                                                             labels
Ctrl+F3                      Insert, Name, Define      Define Name (XL 11)   Define a range name
                                                       Name Manager (XL12)   Manage range names
Ctrl+Alt+F3                                            New Name              Define a range name
F3                           Insert, Name, Paste       Paste Name            Pastes a defined name into a formula.


Ctrl+1                       Format dialog             Format                Displays the format dialog for selected
                                                                             object: cell, chart, drawing object, etc.

Ctrl+Shift+F                 Format, Cells, Font       Format Cells          In XL12, opens the Format Cells dialog
Ctrl+Shift+P                                                                 with the Font tab selected
Alt+' (apostrophe)           Format, Style             Style                 Format Style dialog box

Alt+F8                       Tools, Macro              Macro                 Opens the Macro dialog.
Alt+F11                      Tools, Macro, Visual      VBE (window)          Opens VBA's Visual Basic Editor (VBE)
                             Basic Editor
F7                           Tools, Spelling           Spelling              Spelling dialog.

Ctrl+L                       Data, List, Create List   Create List           Create List (XL 11)
Ctrl+T (XL 12)                                                               Create Table (XL 12)

Ctrl+A                                                 Function Arguments    Provides help using the function
--with insertion point to
the right of a function in
a formula

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:21
posted:9/15/2012
language:English
pages:15