Docstoc

Standard Reports Hyperion 9 Interactive Reporting Web Client

Document Sample
Standard Reports Hyperion 9 Interactive Reporting Web Client Powered By Docstoc
					Data
Warehouse
T U T O R I A L   G U I D E


                                 Hyperion 9
           Interactive Reporting Web Client




                              University of California
                                       Santa Barbara
                                             Hyperion 9
   Interactive Reporting Web Client

                                         Table of Contents


TABLE OF CONTENTS.................................................................................................. 2

GETTING STARTED ...................................................................................................... 4

Logon to the Hyperion Workspace .................................................................................. 4

Logoff the Hyperion Workspace ...................................................................................... 7

Navigate within the Hyperion Workspace........................................................................ 8

STANDARD REPORT BASICS.................................................................................... 11

Open a Standard Report ............................................................................................... 11

Process a Standard Report ........................................................................................... 13

Navigating the Report Sections..................................................................................... 17

Print a Standard Report................................................................................................. 20

Save a Standard Report as a PDF................................................................................ 21

Export Results to Excel ................................................................................................. 22

HYPERION BASICS ..................................................................................................... 24

Build a Query ................................................................................................................ 24

Sort Results................................................................................................................... 31

Create a Formatted Report ........................................................................................... 35

MODIFYING A STANDARD REPORT ......................................................................... 42

Delete a Column ........................................................................................................... 42

Add a New Column ....................................................................................................... 44

Save a Standard Report to the Hyperion Workspace.................................................... 49


                                                                2
Save a Standard Report to Your Workstation ............................................................... 51

Open a Report Saved to Your Workstation ................................................................... 53

Local Filters................................................................................................................... 57

Add a Query Limit.......................................................................................................... 60




                                                                3
                                                                                                       Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                                 Getting Started
                    Logon to the Hyperion Workspace


   1. Open a supported web browser and connect to http://wh.isc.ucsb.edu/. (The Interactive
      Reporting Web Client is a plug-in that must be installed in the browser and does not work
      with all browsers. Check the Data Warehouse web page for installation instructions and a
      compatibility matrix.)

   2. Logon to the Hyperion Workspace by clicking on the hyperion insight logon button.




   3. Enter your Hyperion/Brio/Data Warehouse user name and password. You should have
      been sent this name and password when you requested a Data Warehouse account with
      Hyperion. It may be different than your Directory/Espresso/UCSB Net ID. Click on the
      Log On button.




                                              4
    Hyperion 9 Interactive Reporting Web Client




5
                         Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

The Hyperion Workspace window will be displayed with a list of folders on the left side and
possibly the same on the right side, similar to the Windows Explorer.




Click on the plus sign or double-click on a folder to display the contents of the folder. Some
folders contain more folders:




                                                 6
                                                        Hyperion 9 Interactive Reporting Web Client

TIP: Set the Workspace to always open to a particular folder by setting a default startup folder.
Choose Preferences from the Edit menu and then Select … to pick your default startup folder:




                     Logoff the Hyperion Workspace


To logoff and disconnect from Hyperion Workspace, click on the Log Off button in the toolbar:




You will automatically be logged off the Workspace after some period of inactivity.

Macintosh users will also need to Logoff from the active Terminal Server session via the
START tab in the lower left corner of the session.




                                                7
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                                 Getting Started
             Navigate within the Hyperion Workspace


   Within the Hyperion Workspace, you can

   •   Click once on the plus signs next to the folders with subfolders to view the lowest level
       folder.




   •   Click once on a folder to see the reports listed in the pane on the right:




                                                 8
                                                    Hyperion 9 Interactive Reporting Web Client

•   A brief description of each report appears in the Description column of the workspace:




•   If the entire description isn’t displayed, right-click on the report name and choose
    Properties… (Macintosh users can highlight the report name and choose Properties
    from the File menu.)




•   The entire description will be displayed:




•   Notice the My Reports folder in the list of folders. This is where you can save your own
    queries back to the Workspace:
                                             9
                                                                         Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




   •   To search for a report using a key word, click on the search icon:




   •   Type a word or two in the Keywords field and then click on Search Now:




   •   Results of your search appear in a new tab in the workspace:




   •   You can open a report from the search results by double-clicking on it or return to the full
       list of reports by clicking on the Explore tab on the lower left, next to the Search tab.




                                               10
                                                      Hyperion 9 Interactive Reporting Web Client


                                Report
                       Standard Report Basics
All screen snapshots in the Tutorial Exercises make references to Standard Reports created
using a tutorial database about books.

The Order Tracking Report, Start from Scratch Tutorial and Book Inquiry Report by Order No
can be found in the Tutorial folder after logging on to the Hyperion Workspace.

********************************************************************************************

                          Open a Standard Report

Tutorial Exercise 1a: Open the Demo Payroll Expense Report.

1. From the Hyperion Workspace, look for the Demo Payroll Expense Report in the Tutorial
   folder.




2. Double-click on the Demo Payroll Expense Report. Alternatively right-click on the Demo
   Payroll Expense Report and choose Open As Interactive Reporting Web Client from
   the pop-up menu. (Macintosh users: double-click on the report name. The file should open as
   an Interactive Reporting Web Client if you are using the terminal server.)




                                              11
                                                                           Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

The report opens in a separate window, but doesn’t look like much:




If the report looks like this instead:




 then the Interactive Reporting Web Client needs to be installed. Refer to the link on
 wh.isc.ucsb.edu for instructions on installing the IRWC plug-in.

 In the next section, we’ll process the report.
                                                  12
                                                       Hyperion 9 Interactive Reporting Web Client


                       Standard Report Basics
                        Process
                        Process a Standard Report


Tutorial Exercise 1b: Process the Demo Payroll Expense Report.

1. The Standard Reports you retrieve from the Hyperion Workspace are templates and do NOT
   contain results. When a report is opened, a “No results set available, report has not been
   calculated” message will be displayed:




Most standard reports will open with a window that looks like the one above. This is because
most of the standard reports require one or more filters (what department do you want? what
month do you want?) before the report can be displayed.

2. Click on the Process button in the toolbar. (Click somewhere on the word “Process” rather
   than on the little black triangle next to the word):




                                              13
                                                                            Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




3. You will be prompted to enter choices specific to the report you have selected.

   For the Demo Payroll Expense Report you will need to enter two filters: ledger date and
   department code.

4. When prompted for Ledger Date, enter 200102 in the text box as this is the only month for
   which we have fake payroll data in the Data Warehouse. As noted in the prompt box, the
   format for the ledger date should be YYYYMM.




5. Click the Green Check button to highlight your entry and then click OK.




                                               14
                                                        Hyperion 9 Interactive Reporting Web Client




6. A second limit/filter for Department Code (known as Fin Department Code in the DW)
   appears. Type STRZ in the box, click the green check mark and then and click OK.




7. The Hyperion Server will now pass the filters you have entered (as well as your username
   and password) to the Data Warehouse Server to retrieve the appropriate results for the report.


   You may notice a                    message at the bottom of your screen or an hourglass
   icon indicating that your request is being processed.

   TIP: To stop or interrupt a query while it is processing, press the ALT and End keys until
   the query is cancelled. It may take several minutes to interrupt a long-processing query. This
   tiny fake payroll query should only take a few seconds. The END key is found above the
   arrow keys.

                                               15
                                                                             Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

   The report will be displayed when ready:




                                              16
                                                          Hyperion 9 Interactive Reporting Web Client


                         Standard Report Basics
                      Navigating the Report Sections


After a report has been processed and displayed, there is typically at least one section of the
report intended to be printed or converted to a PDF. Additionally the raw results can be exported
to Excel, or you can modify the query to include alternate columns or filters. The key to jumping
between sections is the discreet section name in the upper left corner:




Click on this text and it displays a drop-down list of all the sections for the document:




In this example, there are two formatted reports, the Payroll Expense Report and the DOS Code
and Title Code Descriptions report that displays all the codes and descriptions used in the main
report. These reports can be printed or saved as PDFs.




                                                 17
                                                                                Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




The Results section shows the raw, unformatted results. This is often the section that is exported
to Excel:




The Query section is where you can add more columns, change filters, etc.:




                                                18
                                                         Hyperion 9 Interactive Reporting Web Client




In the rest of this section, we’ll go into more detail on how to print, save to PDF and export to
Excel. Working in the query section is covered later in Hyperion Basics.




                                                 19
                                                                               Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

Standard Report Basics
                           Print a Standard Report


After a report has been processed and displayed, it can be printed. The section displayed after
processing is usually the printable report and labeled with the report name. You might notice that
the pagination on the printable report isn’t sorted until you print or scroll to the bottom of the
report:




1. Click on Printer icon in the menu bar:




2. or choose Print… from the File menu.




3. The report should print in the correct layout, but if necessary, use the Page Setup function to
   modify the orientation of the page before printing:




                                                20
                                                         Hyperion 9 Interactive Reporting Web Client


                 Save a Standard Report as a PDF

Saving a report as a PDF can be useful for Macintosh users who are having trouble printing via
Remote Desktop, or for emailing a report as an attachment for someone who doesn’t have
Hyperion or for saving a digital copy of a report.

1. While viewing the printable, formatted report, choose Export       Section… from the File
   menu:




Click on the pulldown for Save as type and scroll down to find PDF (*.pdf):




Be sure to pay attention to where you are saving the file.




                                                21
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

Standard Report Basics
                            Export Results to Excel


After a report has been processed and displayed, the results can be exported to Excel.

1. Navigate to the Results section of the processed Standard Report.




2. Click on File in the menu bar and select Export Section…




3. The Export Section window will be displayed. Select a directory on your local drive to save
   the results to and change the File Name if desired. Change the Save as type pulldown to
   Excel (*.xls). Click Save.




                                               22
                                                        Hyperion 9 Interactive Reporting Web Client




4. When finished with the report, click on the red X in the upper right corner to close the report
   window.

5. Click No at the Save Changes prompt.

6. The Hyperion Workspace window should still be open in your browser so you can open
   another report or log off.




                                                23
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                                 Hyperion Basics

Tutorial Exercise 2a: Use the Start from Scratch Tutorial to create a simple query (similar to
the one in the Order Tracking Report) about orders for bookstores in California. The exercise
will make some references to the Order Tracking Report, so it is recommended that you process
and print the Order Tracking report and have a copy in front of you. When prompted, enter
today’s data in mm/dd/yy format in the Order Date filter and click OK to Store State = CA.

By learning how to construct a simple query in Hyperion, you will work with different elements
in the query Section and develop a greater understanding and familiarity when navigating around
a standard report.

                                     Build a Query


1. From the Hyperion Workspace, open the Start from Scratch Tutorial document in the
   Tutorial folder.


2. The document will open in a separate window and may take several seconds to be displayed.




   There are some key items to note:

       a. Section Title Bar




                                              24
                                                 Hyperion 9 Interactive Reporting Web Client

   The Section Title bar (a horizontal banner running across the top of each section)
   displays the name of the section you are currently viewing (Query) and includes the
   Section Objects (e.g. Request, Filters, Sort) associated with this particular section.

b. Request, Filter and Sort Palettes




   The Request Line holds the items you want to see in your report.

   The Filter Line holds the items used to restrict the request to particular records, e.g.,
   which department? which month?

   The Sort Line holds sort order for the results.

   If any of three palettes aren’t shown, toggle them on by clicking on the link on the
   right:




c. Column List




   The Column List consists of all the data items you can use in your report. Each
   standard report has at least one query section. Sometimes the query section will
   contain one Column List as in the example above. Other query sections will look
   more complicated:




                                         25
                                                                        Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




3. From looking at the Order Tracking Report, we can see that the data items we need for the
   query are:

            Book Title                 Order Date        Store Address     Book Price
            Author Last Name           Order No          Store City        Qty Sold
            Author First Name          Store Name        Store State

4. Move the items above to the Request Line.

   An item can be added to the Request Line in a couple of ways. Select the item and….

       •   Drag it from the Column List to the Request Line.

                                                OR

       •   Right mouse click (Mac users:        + mouse click) and choose the Add Selected
           Items option.




                                               26
                                                          Hyperion 9 Interactive Reporting Web Client




TIPS: Multiple items from a Column List can also be selected together and then added to the
Request Line simultaneously.

       •   To select a series of adjacent items, select the first item then        and click on the
           last item.




       •   To select a series of non-adjacent items, select the first item then         and click on
           the subsequent item(s).




                                                 27
                                                                                  Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




5. When you have completed adding all the appropriate items needed for the query, your
   Request Line should look similar to this (the order of the items does not matter):




6. We only want orders for bookstores in California, so we need to place a Filter on the item
   Store State. (Typical filters you might need on real data are for department code and ledger
   date.)

   A new filter can be added to the Filter palette in a couple of ways:
     a) Double- click on Store State in the Column List to select it

                                          or

      b) Drag Store State from the Column List to the Filter palette.

                                         or

      c) Click to highlight Store State in the Column List and then Right-click
         (Mac users:        + mouse click) and choose the Filter… option.




                                               28
                                                     Hyperion 9 Interactive Reporting Web Client




7. The Filter Box will be displayed:




8. Type in “CA” in the text box (below the “= Equal”) and click on the Green Check button
      and then OK.




                                             29
                                                                          Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




9. The new limit is displayed on the Filter palette.




10. Our query is now complete. We are ignoring the Sort palette because it often makes more
    sense to sort in either the Results section or in the report. Click on the Process button to
    submit the query. Do not click on the triangle next to the word “Process.” Click on the word
    or the icon instead.

Congratulations! You’ve created your first query! In the next section we’ll learn how to sort the
results.




                                                30
                                                         Hyperion 9 Interactive Reporting Web Client


                                Hyperion Basics
                                     Sort Results


Tutorial Exercise 2b: Sort the results in alphabetic order by Book Title.

1. Results will be displayed in the Results section.




There are some key items to note:

       a. Section Title Bar



The Section Title bar (a horizontal banner running across the top of each section) displays the
name of the section (e.g. Results) you are currently viewing and includes the Section Objects
(e.g. Filter, Sort, Outliner) associated with this particular section. The Filter and Sort in the
results page are in addition to the filter and sort in the query section.

       b. Palettes
                                                31
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

       Make the sort and filter palettes visible by clicking on the Filters(0) and Sort(0) links in
       the upper right on the section title bar:




           The Filter palette allows you to filter the results further.

           Filters placed on the results are known as a local filter since it is done on your
           workstation and you do not have to re-submit your query.

           The Sort Line allows you to sort the results locally (i.e. on your workstation, so you
           do not have to re-submit your query) by placing items in the sort palette.

           When you sort more that one column at a time, the left to right order of the item on
           the Sort line dictates the sort order and creates a nested effect. For example, the item
           on the far left is sorted first. Items to the right are then sorted in order, each within
           the categories of the preceding item.


       c. Results Table




           The Results Table displays the (unformatted) data retrieved by the query in columns
           and rows.

           Each column corresponds to an item on the Request Line in the Query section. Each
           row corresponds to a record.

       d. Data Layout




           The items in the Data Layout Palette correspond to the columns in the Results
           Table as well as the items on the Request Line in the Query section.

           TIP: If the Data Layout Palette is not displayed, click on the Data Layout link in
           the section title bar to view it.

                                                 32
                                                         Hyperion 9 Interactive Reporting Web Client

       e. Row Count


           The first number indicates the total number of rows displayed in the Results Table.
           The second number indicates the total number of rows retrieved by the Query.

           NOTE: The two numbers will differ when you filter the results via the use of Local
           Filters.

2. The simplest way to sort is to double-click on the name of the column:




3. Alternatively, select the Book Title column by clicking on the gray bar above the column
   name. This will highlight the entire column.



4. Click on the sort ascending or sort descending button:




5. If you wish to sort multiple columns, click on the gray bar above the column to highlight the
   column as in step 3. Drag the selected column into the Sort Line. Select the next column to
   be sorted and drag it next to the first column, etc. until you have all the sorts you need. The
   upward-pointing triangle after each column name in the sort palette indicates that the column
   will be sorted in ascending order. Double-click on the triangle to change the sort order to sort
   descending. Sometimes the Sort button              changes to Sort Now when Hyperion
                                                 33
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

   ascertains that you are still working on setting up your sorts. Click on the Sort Now button
   when you are ready to sort.




6. The Results Table should now be sorted.




TIP: To sort in descending order, double click on Book Title on the Sort Line and the triangle
becomes a downward-pointing triangle and then click on the Sort Now button.




                                               34
                                                        Hyperion 9 Interactive Reporting Web Client


                                Hyperion Basics
                        Create a Formatted Report


Tutorial Exercise 2c: Create a simplified version of the Order Tracking Report. The exercise
will make some references to the Order Tracking Report, so it is recommended that you have a
printout of the report in front of you.

By learning how to construct a simple report with groups and totals, you will be able to modify
the Standard Reports to suit your needs.

1. From the Results link on the upper left, select the Report section.




2. Alternatively, from the Insert menu bar, choose the New Report option.




3.   A new section named Report will be displayed:




                                               35
                                                                             Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




There are some key items to note:

       a. Section Title Bar



           The Section Title bar (a horizontal banner running across the top of each section)
           displays the name of the section (e.g. Report) you are currently viewing and includes
           the Section Objects (e.g. Expression, Groups, Table and Sort) associated with this
           particular section. Toggle on the Sort palette by clicking on the link.

       b. Sort and Data Function Palettes




           The Sort Line allows you to order the content of the report.

           When you sort more that one column at a time, the left to right order of the item on
           the Sort line dictates the sort order and creates a nested effect. For example, the item
           on the far left is sorted first. Items to the right are then sorted in order, each within the
           categories of the preceding item.


                                                  36
                                                 Hyperion 9 Interactive Reporting Web Client

   The Data Function Line (a.k.a the Expression Bar) allows users to define and apply
   equations using JavaScript syntax. Unless you are doing a lot of report customization
   and formatting, we recommend that you toggle this palette off.

   TIP: If any of the palettes are not displayed, click on the appropriate link in the
   section title bar to toggle it on.

c. Report Content Pane




   The Report Content Pane is the area when the report is displayed. When you insert
   a Report section, a 3x3 table is displayed with the column headings Col 1, Col 2 and
   Col 3. When you begin to construct the report, this default table will disappear.

d. Report Group, Table Dimension and Table Fact Palettes




   The Report Group Palette allows you to define a group header. A group header
   defines the overall or highest levels used to group data in a report.

   When you designate an item as a group header (e.g. break value), you are instructing
   Hyperion to organize and group the data (both dimensions and facts) according to
   the group header. Each of the dimensions and facts are repeated within each group.
   For a real world example, imagine needing a report that showed ledger detail by
   month for a particular object code. The group in this case would be month-or
   whatever element came after the word “by.”

   The Table Dimension Palette allows you to define descriptive data that make up the
   body of the report. Usually, data items that are text-based are designated as
   dimensions.

   The Table Facts Palette allows you to define the measurable or quantifiable data that
   makes up the body of the report. Usually, data items that are numeric-based are
   designated as facts. By default, a subtotal for each fact is calculated and placed on the
   last row of the fact column.

                                        37
                                                                       Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


           If you have a descriptive numeric value that should not be calculated, designate it as a
           dimension rather than a fact. For example, an invoice number is numeric, but you
           would never want invoice numbers to be totaled. For a real world example, the most
           common elements that belong in the Facts Palette are amounts like expenditure
           amount, appropriation amount, etc.

           TIP: If any of the palettes are not displayed, click on the appropriate Section Objects
           of the missing Palettes to toggle it on and view it.

4. From the View menu, choose the Section/Catalog option.




5. A Section/Catalog Pane will be displayed on the left side of the screen.




There are some key items to note:

       a. Section Pane




                                                38
                                                         Hyperion 9 Interactive Reporting Web Client




       The Section Pane is the upper gray pane and lists all the sections in the document. You
       can navigate to a section by clicking on the Section Name.

       b. Catalog Pane




       The Catalog Pane is the lower white pane and contains the columns from the Results
       section you can use to build a report.

6. Drag Book Title from the Report Catalog Pane into the Report Group Palette.
   This works best if you drag the item just to the right of the colon after the Report
   Group1(Results).




7. The Report window should look similar to the screen snapshot below with Book Title as
   group header.




                                                39
                                                                               Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




8. Drag Order Date, Order No, Store Name, Store Address, Store City and Book Price from the
   Report Catalog Pane into the Table Dimensions Palette. These columns will provide the
   descriptive data elements of our report.

   Drag Qty Sold from the Report Catalog Pane into the Table Facts Palette. This column
   will provide the measurable or quantifiable data element of our report.




   NOTE: Even though Book Price is a numeric value, it is designated as a dimension (rather
   than a fact) since it is not a column for which we want/need to have a subtotal.

9. Your report should look like this (though the titles may be in a different order since we did
   not sort the report groups.)




                                                40
                                                        Hyperion 9 Interactive Reporting Web Client



   NOTE: Formatting the report (such as adding a report title, reducing the font size for the
   group header, change the color of the column headers, etc.) is not very difficult in Hyperion.
   You can click on Help in menu bar and select Contents. You may have to allow blocked
   content in your browser to allow the active-x help application to run. From the Overview
   page, click on the Contents tab and navigate to the Report Designer section to find
   additional information.

10. Close the active window without saving.

Now that you’re familiar with the basic sections of a report, we’ll learn how to modify a standard
report in the next section.




                                               41
                                                                             Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                   Modifying a Standard Report
The collection of Standard Reports can be used as a Starter Set for you to build on and modify
according to your departmental and reporting needs. You have the ability to filter and analyze
data in a Standard Report as well as the privileges to add, delete and modify columns, filters and
sorts.

********************************************************************************************

                                   Delete a Column

Tutorial Exercise 3a: Delete the Book Price column from the Order Tracking Report.

1. From the Report Catalog tree, click on Order Tracking Report in the Tutorial folder.




2. Before you can make any modifications to a Standard Report, you must first process the
   report.

3. When prompted, enter in today’s date for the Order Date and select the Store State to be
   CA.

4. When the Standard Report is displayed, toggle on the Table Palettes if they are not already
   displayed.




                                                42
                                                       Hyperion 9 Interactive Reporting Web Client




5. Two palettes similar to the ones below should be displayed at the bottom of your report. The
   items in the Table Dimensions and Table Facts palettes are columns that have been pre-
   selected for the Standard Report.




6. Select the Book Price item to delete and right mouse click (Mac users:       + mouse click).
   Choose the Remove option.




   NOTE: In this exercise we are only deleting Book Price from the Report section. Book
   Price is still an existing column in the Results section and an item on the Request Line in
   the Query section.




                                              43
                                                                            Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                     Modifying a Standard Report
                                 Add a New Column


There are two steps involved in adding a new column to a Standard Report:

    I. Modify and Re-Process the query to include the new item
   II. Add the new column to the Standard Report

********************************************************************************************

Tutorial Exercise 3b: Add a new column (Book Type) to the Order Tracking Report.

Step I: Modifying the query to include the new data item

1. Navigate to the Query section of the Standard Report by clicking on the section link as we
   have been doing previously, or now that the section catalog is visible, click on the query
   section:




   TIP: You do not have to process the Standard Report first in order to add new data items.
   However, if this is the first time you are using this report, it is a good idea to process the
   Standard Report so that you have an idea of what columns have been pre-selected and
   understand how they are used in the Standard Report.


2. A Request Line similar to the one below should be displayed at the top of the Query
   section. The items in the Request Line have been pre-selected for the report by the report
   author (usually someone from the Data Warehouse team).




3. Select Book Type from the Column List and drag it to the Request Line. Place Book Type
   anywhere in the request palette. Wherever you put it, Hyperion will add the column on at the
   far right no matter what so don’t spend time fussing with it. Columns can be rearranged later
   in the results or report sections.


                                                44
                                                         Hyperion 9 Interactive Reporting Web Client




4. Since we have modified the query, we will need to process it again. Click on the Process
   button.

   When prompted, enter in today’s date for the Order Date and select the Store State to be
   CA.

5. When the processing is completed, the Results section will be displayed. Columns in the
   Results section match or reflect the items on the Request Line in the Query section.

   Scroll to the far right of the Results Table to see the newly added Book Type column. No
   matter where you place items in the Request line of the query, new items will always be
   added to the end of the column list.




Step II: Add the new data item to the Standard Report

1. If the section catalog isn’t already available, click on View in the menu bar and select
   Section/Catalog.




2. The Section/Catalog Pane will be displayed on the left of your screen.

3. In the Section Pane, click on the Order Tracking Report section.




                                                45
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




4. Toggle on the Table Palettes if they not already displayed.




5. Two palettes similar to the ones below should be displayed at the bottom of your report. The
   items in the Table Dimensions and Table Facts Palettes are items that have been pre-
   selected in the Standard Report.




6. In the Catalog Pane, select Book Type.




                                              46
                                                       Hyperion 9 Interactive Reporting Web Client




7. Since Book Type is a descriptive data item, drag and drop it from the Catalog Pane to the
   Table Dimensions palette and place it between Order No and Store Name.




8. The Order Tracking Report is updated to reflect the addition of Book Type.

   NOTE: Some report formatting might be required when adding new column(s) to a report.

   Formatting the report (such as adding a report title, reducing the font size for the group
   header, change the color of the column headers, etc.) is not very difficult in Hyperion. From
   the View menu, select Toolbars Formatting:




   The formatting toolbar should look familiar and behaves as expected. Highlight items in the
   report and then change the font size, style, color, etc. using the toolbar.

                                               47
                                                                             Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


   You can also click on Help in menu bar and select Contents. You may have to allow
   blocked content in your browser to enable the active-x help application to run. From the
   Overview page, click on the Contents tab and navigate to the Report Designer section to
   find additional information.




                                              48
                                                         Hyperion 9 Interactive Reporting Web Client


                   Modifying a Standard Report
  Save a Standard Report to the Hyperion Workspace


If you make changes to a Standard Report that you would like to keep and use in the future, you
can save your changes to your local drive or save them directly to the Hyperion Workspace. You
don’t have permission to write over any of the standard reports in the Workspace so don’t worry
about accidentally changing the “corporate” documents.

********************************************************************************************

Tutorial Exercise 3c: Save the revised Order Tracking Report to the Hyperion Workspace.

1. From the File menu select Save to Repository As…




2. The Hyperion Workspace dialogue box opens displaying the folder from which you
   originally opened the report. You will get an error message if you try to save the report here.




                                                49
                                                                              Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

3. Click on the pull-down and select the Root folder. (The root folder is the highest level.)




4. Select My Reports by double-clicking on it.




You have a choice to save your report in the folder that was created for your user name or a
folder that was created for your department. If you save the report in your department folder, be
aware that other Hyperion users in your department have the ability to modify or delete your
report, just as they would a shared Word or Excel file.

5. Once you’ve navigated to the folder of your choice, you can modify the name of the report
   and add a description:




6. Click Save.

7. To reopen your saved report, navigate to the My Reports folder in the Hyperion Workspace.
   You can also delete the saved report by right-clicking on it in the Hyperion Workspace and
   choosing Delete.




                                                50
                                                         Hyperion 9 Interactive Reporting Web Client


       Save a Standard Report to Your Workstation

We recommend saving your personal queries back to the Hyperion Workspace as taught in the
previous section. However, it’s also possible to save your modified queries to your local
workstation. This method is a bit more cumbersome when you re-open your locally saved query
(see next section) but it couldn’t hurt to save a copy of any particularly valuable query templates
to your workstation in case there’s ever a catastrophic failure with the Hyperion server. The
Hyperion server is backed up nightly so a mid-day crash could result in loss of your personal
report.

1. Click on File in the menu bar and select Save As…




   By default, the only the Query and Report sections are saved as templates (i.e. the results
   are not saved). This method of saving is recommended and will keep your reports from
   filling up your hard disk space.

2. Type in Order Tracking Report with Book Type for the File Name and click on the Save
   button. Brio.Insight documents are saved with the extension *.bqy.




                                                51
                                                                               Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client

   TIP: To easily locate your Hyperion documents, create a folder on your desktop or local
   directory specifically for your *.bqy files.

3. Keep the active window open for Tutorial Exercise 3d.




                                              52
                                                       Hyperion 9 Interactive Reporting Web Client


                  Modifying a Standard Report
          Open a Report Saved to Your Workstation


It’s less cumbersome to save your personal reports back to the Hyperion Workspace in the My
Reports section, but you may need to open a .bqy file from another user or you might prefer to
keep a spare copy locally.
********************************************************************************************

1. Open the web browser in which the Hyperion Interactive Reporting Web Client plug-in has
   been installed. Browsers without the plug-in will not be able to open a saved .bqy file. You
   do not have to log in to the Data Warehouse or even be on a DW web page. Whatever page
   your browser opens to is fine. Instructions are shown for Internet Explorer 7. Exact menu
   items and windows may differ for other versions/browsers.

2. From the File menu, choose Open…




3. When the Open dialog box is displayed, click on the Browse… button.




                                               53
                                                                             Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




4. Navigate to the folder where you saved the Order Tracking Report with Book Type file.




5. Use the pull-down menu for Files of type to select the All Files option:




                                               54
                                                      Hyperion 9 Interactive Reporting Web Client




6. You should now see any *.bqy files you have saved. Select the file you want and click on the
   Open button.




7. At the Open Page dialog box, click OK:




                                              55
                                                                           Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




8. The Hyperion Workspace login window appears. Login as usual. The report should open
   normally although you will now have two sets of toolbars, one for the browser and one for
   Hyperion:




You can avoid all this messiness by saving your reports back to the Hyperion Workspace in the
My Reports section rather than saving the bqy files to your workstation. See the earlier section,
Save a Standard Report to the Hyperion Workspace, for detailed instructions.




                                                56
                                                          Hyperion 9 Interactive Reporting Web Client


                   Modifying a Standard Report
                                      Local Filters


Using Local Limits is a good way to manage and filter the results and analyze different
scenarios. Local filters in the Results section are applied by Hyperion, not the Data Warehouse
server, so you do not need to re-process your query. All associated reports built with the results
(in which a Local Filter has been applied) will also exclude the data accordingly.

********************************************************************************************

Tutorial Exercise 3d: Filter the results in the Order Tracking Report to only include orders of
books that have the word “computer” in their titles.

1. Navigate to the Results section of the Standard Report.




   TIP: In order to apply a local filter to a standard report, you first need to process the report.

2. Toggle on the Filter palette if it’s not already displayed.




3. Select the column to place a local Filter on by clicking on the gray bar above the Book Title
   name. This will highlight the entire column.




4. Drag the selected column into the Filter palette.

5. A Limit: Book Title dialog box will be displayed.




                                                 57
                                                                                Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client




6. Click on the pull-down arrow to the right of the “= Equal” to select “Contains:”




7. Type “computer” in the text entry box and click on the Green Check button          and then
   OK.




                                              58
                                                         Hyperion 9 Interactive Reporting Web Client




8. Hyperion will apply the Local Limit to the Results Section and also to all associated Report
   Section(s). At the bottom of the Results Section, a row count is displayed showing how
   many rows of the original results remain.



9. To get back the original results, select Book Title on the Filter palette and right mouse click
   (Mac users:        + mouse click). Choose Remove.




10. Close the active window without saving.




                                                59
                                                                               Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


                   Modifying a Standard Report
                                 Add a Query Limit


Tutorial Exercise 4: Modify the Book Inquiry Report by Order No, so that we will be prompted
for Store Name as a new Query Limit for the report (rather than Order No). Save the revised
report to the desktop.

1. From the Hyperion Workspace, click on Book Inquiry Rpt by Order No in the Tutorial folder.

2. Click on the Process button. When Filter: Order No dialog box is displayed, click OK to
   accept the highlighted Order No.


   TIP: You do not have to process the Standard Report first in order to add new query limit
   items. However, if this is the first time you are using this report, it is a good idea to process
   the Standard Report so that you have an idea of what limits have been pre-selected and
   understand how they are used in the Standard Report.

3. If the Sections pane isn’t already visible left of the report, click on View in the menu bar and
   select Section/Catalog.

4. In the Section Pane, click on the Book Inquiry Report by Order No to highlight it.

   Right mouse click (Mac users:          + mouse click) and choose the Rename Section…
   option.




5. When the Section Label dialog box is displayed, modify the label to Book Inquiry Report by
   Store Name.




6. In the Section Pane, click on Query section.


7. Toggle on the Filter palette if it’s not already displayed.

                                                 60
                                                           Hyperion 9 Interactive Reporting Web Client


8. The filter palette shows two filters: Author Order and Order No.




9. Select the Order No item on the Limit Line and right mouse click (Mac users:              +
   mouse click). Choose Remove.




10. Double-click Store Name in the Column List or drag it from the Column List to the Filter
    palette.

11. When the Filter: Store Name dialog box is displayed, type News & Brews in the text box
    (below the “=Equal” box).

   Click on the Green Check button          and then OK.




   TIP: Filters are not case sensitive. Typing in either “News & Brews” or “news & brews” will
   return the same results.

12. The new filter is displayed in the Filter palette.



                                                  61
                                                                                Last updated: 4/15/10
Hyperion 9 Interactive Reporting Web Client


   Currently, Store Name is static limit. Hyperion will filter store name to News & Brew every
   time the query is processed.

13. Click on the Process button Notice that you are not prompted to input a store name.

14. To change the Store Name filter so that every time the report is processed, we will be
    prompted to input a store name,

           a. Select Store Name on the Filter palette and right mouse click (Mac users:            +
              mouse click). Choose the Variable Filter option.




           b. Notice that “V(1)” is now appended to the limit filed to indicate that it is now a
              variable limit.

15. Click on the Process button.

16. When prompted, type in “Barnum’s” in the text box (below the “=Equal” box).

   Click on the Green Check button            and then OK.


   TIP: Limit entries are not case sensitive. Typing in either “Barnum’s” or “barnum’s” will
   return the same results.

17. Save the modified query to your local workstation or back to your personal folder in My
    Reports.

18. Close the active window.




                                                   62

				
DOCUMENT INFO
Shared By:
Categories:
Tags:
Stats:
views:33
posted:8/31/2012
language:English
pages:62
Dr. Slord Suniverse Dr. Slord Suniverse Research Director http://www.redshoesconsulting.com/
About Life is short. Talk is cheap. Results matter.