Help for GeoGebra - DOC by S724LnGK

VIEWS: 86 PAGES: 68

									GeoGebra Help 3.0
Last modified: October 15, 2007

Authors
Markus Hohenwarter, markus@geogebra.org
Judith Preiner, judith@geogebra.org


GeoGebra Online
Website: www.geogebra.org
Help Search: http://www.geogebra.org/help/search.html
Contents
GeoGebra Help 3.0 ........................................................................ 1
Contents ......................................................................................... 2
1.     GeoGebra とは?.................................................................... 5
2.     例 ............................................................................................ 6
     2.1.     三角形と角度................................................................... 6
     2.2.     1次関数 y = m x + b ....................................................... 6
     2.3.     3点 A, B, C の重心 ......................................................... 7
     2.4.     線分 AB を 7:3 の比に内分する ....................................... 8
     2.5.     2変数の連立1次方程式 ................................................. 8
     2.6.     x の関数のグラフの接線 .................................................. 9
     2.7.     多項式関数を調べる ...................................................... 10
     2.8.     積分............................................................................... 10
3.     幾何的入力 ............................................................................ 11
     3.1. 一般的な注意................................................................. 11
       3.1.1. コンテキストメニュー ........................................... 11
       3.1.2. 表示と非表示 ......................................................... 12
       3.1.3. 残像 ....................................................................... 12
       3.1.4. ズーム ................................................................... 12
       3.1.5. 軸の比率 ................................................................ 12
       3.1.6. 作図手順 ................................................................ 14
       3.1.7. ナビゲーションバー .............................................. 14
       3.1.8. 再定義 ................................................................... 14
       3.1.9. プロパティダイアログ ........................................... 15
     3.2. モード ........................................................................... 15
       3.2.1. 一般のモード ......................................................... 16
       3.2.2. 点 .......................................................................... 19
       3.2.3. ベクトル ................................................................ 20
       3.2.4. 線分 ....................................................................... 20
       3.2.5. 半直線 ................................................................... 20
       3.2.6. 多角形 ................................................................... 21
       3.2.7. 直線 ....................................................................... 21
        3.2.8.       2次曲線 ................................................................ 22
        3.2.9.       弧と扇形 ................................................................ 23
        3.2.10.      数値と角度 ............................................................ 24
        3.2.11.      真偽値 ................................................................... 25
        3.2.12.      軌跡 ....................................................................... 25
        3.2.13.      幾何的変換 ............................................................ 26
        3.2.14.      テキスト ................................................................ 27
        3.2.15.      イメージ ................................................................ 29
        3.2.16.      イメージのプロパティ ........................................... 29
4.     数式入力 ............................................................................... 31
     4.1. 一般的な注意................................................................. 31
       4.1.1.  値の変更 ................................................................ 31
       4.1.2.  アニメーション ..................................................... 31
     4.2. 直接入力........................................................................ 32
       4.2.1.  数値と角度 ............................................................ 32
       4.2.2.  点とベクトル ......................................................... 33
       4.2.3.  直線 ....................................................................... 33
       4.2.4.  2次曲線 ................................................................ 34
       4.2.5.  x の関数 ................................................................. 34
       4.2.6.  オブジェクトのリスト ........................................... 35
       4.2.7.  算術演算 ................................................................ 35
       4.2.8.  真偽値変数 ............................................................ 37
       4.2.9.  真偽値演算 ............................................................ 37
     4.3. コマンド........................................................................ 38
       4.3.1.  一般的なコマンド .................................................. 38
       4.3.2.  真偽コマンド ......................................................... 38
       4.3.3.  数値 ....................................................................... 39
       4.3.4.  角度 ....................................................................... 41
       4.3.5.  点 .......................................................................... 42
       4.3.6.  ベクトル ................................................................ 43
       4.3.7.  線分 ....................................................................... 44
       4.3.8.  半直線 ................................................................... 44
       4.3.9.  多角形 ................................................................... 45
       4.3.10. 直線 ....................................................................... 45
       4.3.11. 2次曲線 ................................................................ 46
       4.3.12. 関数 ....................................................................... 47
       4.3.13. 媒介変数表示された曲線 ....................................... 48
        4.3.14.      弧と扇形 ................................................................ 48
        4.3.15.      イメージ ................................................................ 49
        4.3.16.      テキスト ................................................................ 50
        4.3.17.      軌跡 ....................................................................... 50
        4.3.18.      数列 ....................................................................... 50
        4.3.19.      幾何的変換 ............................................................ 51
5.     印刷とエクスポート.............................................................. 54
     5.1. 印刷............................................................................... 54
       5.1.1. ドローイングパッド .............................................. 54
       5.1.2. 作図手順 ................................................................ 54
       5.1.3. ドローイングパッドを画像へ ................................ 55
     5.2. ドローイングパッドをクリップボードへ ...................... 56
     5.3. ウェブページ用作図手順 ............................................... 56
     5.4. ウェブページ用動的ワークシート ................................. 57
6.     オプション ............................................................................ 59
     6.1.     点をつかむ .................................................................... 59
     6.2.     角度の単位 .................................................................... 59
     6.3.     小数点 ........................................................................... 59
     6.4.     連続性 ........................................................................... 59
     6.5.     点のスタイル................................................................. 59
     6.6.     直角のスタイル ............................................................. 60
     6.7.     座標............................................................................... 60
     6.8.     ラベル付け .................................................................... 60
     6.9.     フォントサイズ ............................................................. 60
     6.10.     言語 ........................................................................... 60
     6.11.     ドローイングパッド .................................................. 60
     6.12.     設定の保存 ................................................................ 60
7.     ツールとツールバー.............................................................. 61
     7.1.     ユーザー定義のツール .................................................. 61
     7.2.     ツールバーのカスタマイズ ........................................... 62
8.     JavaScript インターフェイス ................................................ 62
9.     Index ..................................................................................... 63
1. GeoGebra とは?
GeoGebra は, 幾何, 代数, 解析を結びつけた動的な数学ソフトウェ
アです. フロリダ大西洋大学 (Florida Atlantic University) の Markus
Hohenwarter により, 学校で学んだり教えたりするために開発され
ました.

一方では, GeoGebra は動的な幾何システムです. 点, ベクトル, 線
分, 直線, 2次曲線や関数を用いた作図が出来, 後から動的にそれら
を変更できます.

他方では, 等式や座標を直接入力できます. こうして GeoGebra は,
数値, ベクトル, 点を変数として扱う能力を持ち, 関数の微分や積分
を計算することができ, 根や極値のようなコマンドを提供します.

これらふたつの観点は Geogebra の特徴です: 数式ウィンドウの式
が幾何ウィンドウのオブジェクトに対応し, その逆もまた対応しま
す.
2. 例
GeoGebra の可能性を知るために, いくつかの例を見てみましょう.


2.1. 三角形と角度
ツールバーのモード       新規の点 を選択します. ドローイングパッ
ドの上で3回クリックし, 三角形の3頂点 A, B, C を作成します. そ
の後, モード     多角形 を選択し, 続けて点 A, B, C をクリックしま
す. 三角形 poly1 を閉じた多角形にするために, 最初の点 A をもう一
度クリックします. 数式ウィンドウには三角形の面積が表示されま
す.

三角形のすべての角度を得るためには, ツールバーのモード           角度
を選択し, 三角形をクリックします.

そして  移動 モードを選択し, 頂点を動的にドラッグして三角形
を修正します. 数式ウィンドウと座標軸が必要なければ, 「表示」メ
ニューを用いてそれらを非表示にします.


2.2. 1次関数 y = m x + b
さて, 1次関数 y = m x + b において m と b の異なる値を試してみ
て, その意味に注目してみます. そのために, 画面下部の入力フィー
ルドに次の等式を入力して, 各行の最後で Enter キーを押します.
     m = 1
     b = 2
     y = m x + b
これで, 入力フィールドを用いて, あるいは, 直接数式ウィンドウに
おいて数値を右クリック (MacOS: Apple+クリック) し「再定義」を
選択することで, m や b の値を変更できます. 次の m と b の値を試
してみます.
     m = 2
     m = -3
     b = 0
     b = -1
次のようにしても, m や b を簡単に変更できます.
   矢印キー (アニメーション を参照).
   スライダー: m や b を右クリック (MacOS: Apple+クリック)
    し, 「オブジェクトの表示/非表示」を選択する (           スライ
    ダー モードも参照).
同様にして, 次のような2次曲線の方程式を調べることもできます.
   楕円:     x^2/a^2 + y^2/b^2 = 1
   双曲線:    b^2 x^2 – a^2 y^2 = a^2 b^2
   円:      (x - m)^2 + (y - n)^2 = r^2


2.3. 3点 A, B, C の重心
3点の重心を作図してみます. まず入力フィールドに次の直線を入
力し, 各行の最後で Enter キーを押します. もちろん, ツールバーの
対応するモード (モード を参照) を使用すれば, マウス操作でこの作
図が可能です.
     A = (-2, 1)
     B = (5, 0)
     C = (0, 5)
     M_a = 中点[B, C]
     M_b = 中点[A, C]
     s_a = 直線[A, M_a]
     s_b = 直線[B, M_b]
     S = 交点[s_a, s_b]

別の方法として, S1 = (A + B + C) / 3 のように直接重心を計算する
こともでき, 両方の結果をコマンド 関係[S, S1] を用いて比較するこ
ともできます.

続いて, S = S1 が正しいかどうかを, 別の位置にある A, B, C に対
しても確かめてみます. そのためには, マウスでモード          移動 を
選択して, 点をドラッグします.
2.4. 線分 AB を 7:3 の比に内分する
GeoGebra ではベクトルの演算が可能なので, これは容易な作業で
す. 次の式を入力フィールドに入力し, 各行の最後で Enter キーを押
します.
     A = (-2, 1)
     B = (3, 3)
     s = 線分[A, B]
     T = A + 7/10 (B - A)
次のようにしても, これと同じことを行えます.
     A = (-2, 1)
     B = (3, 3)
     s = 線分[A, B]
     v = ベクトル[A, B]
     T = A + 7/10 v

次のステップは, 数値 t を導入することです. つまり,          スライダ
ー を用いて点 T を T = A + t v のように再定義します (  再定義
を参照). t を変更すると, 点 T がある直線に沿って移動することがわ
かります. その直線は媒介変数表示で, g: X = T + s v と入力できま
す (直線 を参照).


2.5. 2変数の連立1次方程式
x と y に関する2つの1次関数は, 2本の直線と見なせます. 連立方
程式の解は, これら2直線の交点です. 入力フィールドに次のように
入力し各行の最後で Enter キーを押すだけで交点は得られます.
       g: 3x + 4y = 12
       h: y = 2x - 8
       S = 交点[g, h]

方程式を変更するには, 式を右クリック (MacOS: Apple+クリック)
し,   再定義を選択します.      移動 モードではマウスを用いて直
線をドラッグでき,      点の回りの回転 では直線を点の回りに回転
できます.
2.6. x の関数のグラフの接線
GeoGebra には関数 f(x) のグラフの x = a における接線を求めるコ
マンドがあります. 次の式を入力フィールドに入力し, 各行の最後で
Enter キーを押します.
       a = 3
       f(x) = 2 sin(x)
       t = 接線[a, f]
数値 a を変化させると (アニメーション を参照), 関数 f のグラフに
沿って接線が移動します.

関数 f のグラフ上のある点 T における接線を得るには, 別の方法も
あります.
     a = 3
     f(x) = 2 sin(x)
     T = (a, f(a))
     t: X = T + s (1, f'(a))
これは f のグラフ上の点 T を与え, 接線 t を媒介変数表示で与えま
す.

ところで, 関数のグラフの接線は幾何的にも作図できます:
   モード     新規の点を選択し, 関数 f のグラフ上でクリック
    し, 関数 f のグラフ上の点 A を新たに作成する.
     モード    接線 を選択し, 関数 f のグラフと点 A を順に選
      択する.
では,  移動 を選択し, 点 A をグラフに沿ってマウスでドラッグ
みましょう. このように接線が動的に変化する様子を見ることもで
きます.
2.7. 多項式関数を調べる
GeoGebra を用いると, 多項式関数の根, 極値, 変曲点を調べられま
す. 次の式を入力フィールドに入力し, 各行の最後で Enter キーを押
します.
     f(x) = x^3 - 3 x^2 + 1
     R = 根[f]
     E = 極値[f]
     I = 変曲点[f]

  移動 では, 関数 f のグラフをマウスでドラッグできます. この状
況では, f の始めの2つの導関数にも興味があります. 次の式を入力
フィールドに入力し, 各行の最後で Enter キーを押すことで, これら
の導関数を得られます.
    微分[f]
    微分[f, 2]


2.8. 積分
積分の導入のために, GeoGebra では関数 f の下方和と上方和を長
方形で表示することができます. 次の式を入力フィールドに入力し,
各行の最後で Enter キーを押します.
        f(x) = x^2/4 + 2
        a = 0
        b = 2
        n = 5
        L = 下方和[f, a, b, n]
        U = 上方和[f, a, b, n]
a, b, n の値を修正することで, (アニメーション ,    スライダー を
参照) , 下方和と上方和における, これらの値の効果を見ることがで
きます. 数値 n の増分を 1 に変更するためには, 数値 n を右クリッ
ク (MacOS: Apple+クリック) し, 「プロパティ」を選択します.

 定積分は, コマンド 積分[f, a, b] で与えられ, 不定積分 F は F = 積分
[f] により得られます.
3. 幾何的入力
この章では, マウスを用いて GeoGebra のオブジェクトを作成した
り修正したりする方法を説明します.


3.1. 一般的な注意
 幾何ウィンドウ (右側) は, 点, ベクトル, 線分, 多角形, 関数のグラフ
, 直線や2次曲線の幾何的表現を表示します. マウスがオブジェクト
の上にあるとき, オブジェクトは強調表示され, 説明が現れます.
 注意: 幾何ウィンドウはドローイングパッドとも呼ばれることもあ
ります.

GeoGebra には, 幾何ウィンドウにおけるマウスによる入力に対す
る反応の仕方に応じて, いくつかのモードがあります(モード を参
照) . 例えば, ドローイングパッドでクリックすると新規の点を作成
できたり (モード      新規の点 を参照) , オブジェクトの交点を求め
たり (モード      2つのオブジェクトの交点を参照) , 円を作成した
り (モード     円 を参照) します.

注意: 数式ウィンドウでオブジェクトをダブルクリックするとその
編集フィールドが開きます.

3.1.1. コンテキストメニュー
オブジェクトを右クリックすることで, コンテキストメニューが現
れ, 例えば, オブジェクトの数式記法 (極座標, 直交座標, 陰関数, 陽
関数,...) を選べます. 他に, コンテキストメニューには, 名前の変
更,   再定義 や   消去もあります.

プロパティをコンテキストメニューから選ぶと, ダイアログウィン
ドウが現れ, 例えば, 色, サイズ, 線の太さ, 線のスタイルやオブジェ
クトの塗りを変更できます.
3.1.2. 表示と非表示
幾何的オブジェクトは描画させる (表示) ことも, させない (非表示)
こともできます. モード   オブジェクトの表示/非表示 か コンテ
キストメニューを用いて,この状態を変更できます. 数式ウィンドウ
の各オブジェクトの左にあるアイコンは, 現在の表示の状態を示し
ています ( 表示 か  非表示).

注意: モード C 表示/非表示のチェックボックス を用いて, ひと
つあるいは複数のオブジェクトを表示したり非表示にしたりできま
す.

3.1.3. 残像
幾何オブジェクトは, 移動中に画面に残像を残すことができます.
コンテキストメニュー を用いて残像のオンとオフを切り替えられま
す.

注意: 表示メニューの再描画を実行すると, すべての残像が消えま
す.

3.1.4. ズーム
ドローイングパッドで右クリック (MacOS: Apple+クリック) する
と現れるコンテキストメニューから, ズームイン(モード       ズーム
インを参照) や ズームアウト(モード ズームアウトを参照) がで
きます.

注意: ズーム範囲を指定するには, ドローイングパッドで右クリッ
ク (MacOS: Apple+クリック) して, マウスをドラッグします.

3.1.5. 軸の比率
ドローイングパッドで右クリック (MacOS: Apple+クリック) し, プ
ロパティを選んでコンテキストメニューを出すと, 次の操作ができ
ます.
   x 軸と y 軸の比率の変更
   座標軸それぞれの表示/非表示
   軸のレイアウト (例えば目盛り, 色や線のスタイル) の修正
3.1.6. 作図手順
対話的な作図手順 (表示, 作図手順 メニュー) は, すべての作図のス
テップを示す一覧表です. ウィンドウの下部にあるナビゲーション
バーを用いて, 一度作成された作図を1ステップずつ再実行するこ
とができます. 作図のステップを新たに挿入したり, 順序を変更した
りすることさえできます. より詳しくは作図手順のヘルプメニュー
を参照して下さい.

注意: 表示メニューのブレークポイントを用いると, いくつかのス
テップをブレークポイントに設定でき, オブジェクトをグループ化
できます. ナビゲーションバーで作図を操作するときに, グループ化
されたオブジェクトは一度に現れます.

3.1.7. ナビゲーションバー
GeoGebra には, 一度作成された作図のステップを操作するための
ナビゲーションバーがあります. 幾何ウィンドウの下部にナビゲー
ションバーを表示するためには, 表示メニューから作図手順の操作
を選択します.

3.1.8. 再定義
オブジェクトは, そのコンテキストメニューを用いると再定義でき
ます. この方法は, 作図を後から変更するのに大変便利です. 移動
を選択し, 数式ウィンドウのオブジェクトをダブルクリックしても,
再定義ダイアログを開くことができます.

例:
自由点 A を直線 h 上に配置するためには, 点 A に対して再定義を
選び, ダイアログに現れる入力フィールドに 点[h] と入力します. こ
の点を直線上から取り除いて, 再び自由な状態にするには, どこか自
由な座標に再定義します.

別の例は, 2点 A と B を通る直線 h を線分に変更することです. 再
定義を選び, ダイアログに現れる入力フィールドに 線分[A, B] と入
力します. また, 反対に, 直線に戻すこともできます.
オブジェクトの再定義は, 作図を変更するのにとても多機能な道具
です. 作図手順において, 作図のステップの順序を変更するのにも使
えることに注意しておきます.

3.1.9. プロパティダイアログ
プロパティダイアログにより, オブジェクトのプロパティ (例えば,
色や線のスタイル) を変更できます. プロパティダイアログを開くに
は, オブジェクトを右クリック (MacOS: Apple+クリック) しプロパ
ティを選択するか, 編集メニューからプロパティを選択します.

 プロパティダイアログでは, オブジェクトはその型 (例えば, 点, 直
線や円) で整理され, 多数のオブジェクトを操作しやすくしています
. 右側のタブの中にある選択されたオブジェクトのプロパティを変
更できます. オブジェクトのプロパティの変更が終了したらプロパ
ティダイアログを閉じて下さい.


3.2. モード
以下のモードは, 幾何メニューのツールバーで有効にすることがで
きます. 別のモードを含むメニューが欲しいときは, アイコンの右下
角の小さい矢印をクリックします.
注意: すべての作図モードにおいて, ドローイングパッドをクリッ
クすれば, 新規の点が簡単に作成できます.
オブジェクトのマーク
オブジェクトのマークとは, マウスでそのオブジェクトをクリック
することです.
オブジェクトの名前の簡単な変更
選択されているか, 新規に作成したオブジェクトの名前を変更する
には, 単にタイプを開始すると名前の変更ダイアログが開きます.
3.2.1. 一般のモード

   移動
このモードでは, 自由なオブジェクトをマウスでドラッグできます.
 移動 モードでオブジェクトを選択すると, 次の操作ができます.
  Del キーを押してオブジェクトを消去.
  矢印キーを用いてオブジェクトを移動 (アニメーションを参
     照).
注意: Esc キーを押しても移動モードが有効になります.

Ctrl キーを押したままクリックすると, いくつかのオブジェクトを
同時に選択できます.

複数のオブジェクトを選択する別の方法は, マウスの左ボタンを押
したままマウスで長方形の選択領域を指定することです. 選択され
たオブジェクトのひとつをマウスでドラッグすることで, 選択され
たすべてのオブジェクトを移動できます.

この選択領域の指定は, グラフィックウィンドウにおける図の印刷
やエクスポート, そして動的なワークシートに対しても使われます (
印刷とエクスポート を参照).


   点の回りの回転
回転の中心の点をまず選択します. それから, 自由なオブジェクト
をマウスでドラッグすると, この点の回りに回転できます.


   関係
2つのオブジェクトをマークして, それらの関係の情報を得ます (
コマンド 関係 も参照).


   ドローイングパッドの移動
ドローイングパッドをドラッグすると, 座標系の原点の画面上での
位置を移動できます.
注意: Shift キー (PC: Ctrl キーでもよい) を押しながらドラッグして
もドローイングパッドを移動できます.

 このモードでは, 各座標軸をマウスでドラッグすると, その比率を
変更できます.
 注意: 座標軸の比率の変更は, 他のどのモードにおいても, Shift キー
(PC: Ctrl キーでもよい) を押しながら座標軸をドラッグすれば可能
です.


   ズームイン
ドローイングパッドのどの場所でもクリックすると, ズームインし
ます (ズーム も参照).


   ズームアウト
ドローイングパッドのどの場所でもクリックすると, ズームアウト
します (ズーム も参照).


   オブジェクトの表示/非表示
オブジェクトをクリックすると, それを表示したり非表示にしたり
します.
注意: 非表示にされるべきすべてのオブジェクトは, 強調表示され
ます. 施した変更は, ツールバーの別のモードに移り次第適用されま
す.


   ラベルの表示/非表示
オブジェクトをクリックすると, そのラベルを表示したり非表示に
したりします.


   表示スタイルのコピー
 このモードでは, 表示のプロパティ (例えば, 色, 大きさや線のスタ
イル) を, あるオブジェクトから別のオブジェクトへコピーできます
. そうするためには, まずプロパティのコピー元のオブジェクトを選
択します. 続いて, そのプロパティを適用したいすべてのオブジェク
トを選択します.
  オブジェクトの消去
オブジェクトをクリックすると, それを消去します.
3.2.2. 点

   新規の点
ドローイングパッドをクリックすると, 新規の点を作成します.
注意: 点の座標は, マウスボタンを放したときに確定します.

線分, 直線, 多角形, 2次曲線, 関数のグラフや曲線をクリックする
と, そのオブジェクトの上に点を作成します (コマンド点も参照). 2
つのオブジェクトの交点でクリックすると, 交点を作成します (コマ
ンド交点も参照).

   2つのオブジェクトの交点
2つの方法で, 2つのオブジェクトの交点を作成できます.
   2つのオブジェクトをマークすると, (可能ならば) すべての
    交点を作成します.
   2つのオブジェクトの交点をクリックすると, その交点のみ
    が作成されます.

線分, 半直線や弧に対しては, その延長との交点を作成するかどう
かを指定できます (プロパティダイアログを参照). これにより, オブ
ジェクトの延長との交点も作成できます. 例えば, 線分や半直線の延
長は直線です.


   中点/中心
次のものをクリックします.
   2点をクリックすると, それらの中点を得ます.
   線分をクリックすると, その中点を得ます.
   2次曲線をクリックすると, その中心を得ます.
3.2.3. ベクトル

    2点を結ぶベクトル
ベクトルの始点と終点をマークします.


    始点を決めたベクトル
点 A とベクトル v をマークすると, 点 B = A + v と, 点 A から B へ
のベクトルを作成します.

3.2.4. 線分

    2点を結ぶ線分
2点 A と B をマークすると, A と B を結ぶ線分を確定します. 数式
ウィンドウには, 線分の長さが表示されます.


    始点と長さで決まる線分
線分の始点となる点 A をクリックします. その後現れるウィンドウ
で, 長さ a を指定します.

注意: このモードは, 長さ a で終点が B である線分を作成しますが,
これらは,     移動 モードで始点 A の回りに回転すれば交換できま
す.

3.2.5. 半直線

    2点を通る半直線
2点 A と B をマークすると, A を始点とし, B を通る半直線を作成
します. 数式ウィンドウには対応する直線の方程式が表示されます.
3.2.6. 多角形

   多角形
多角形の頂点となる最低3点をマークします. 続いて, 最初の点を
クリックして多角形を閉じます. 数式ウィンドウには, 多角形の面積
が表示されます.


   正多角形
正多角形の隣り合う2頂点 A と B をマークし, その後現れるダイア
ログの入力フィールドに数値 n を入力すると, n 頂点を持つ正多角
形を作成します (点 A と B を頂点に含む).

3.2.7. 直線

   2点を通る直線
2点 A と B をマークすると, A と B を通る直線を確定します. この
直線の方向ベクトルは (B - A) となります.


   平行線
直線 g と点 A をマークすると, g に平行で A を通る直線を確定しま
す. この直線の方向ベクトルは, 直線 g の方向ベクトルです.


   垂線
直線 g と点 A をマークすると, 直線 g に垂直で A を通る直線を作
成します. この直線の方向ベクトルは, g の法線ベクトルに等しいも
のです (コマンド 法線ベクトル も参照).


   垂直二等分線
線分の垂直二等分線は, 線分 s または2点 A と B により作成できま
す. 作成された直線の方向ベクトルは, 線分 s または AB の法線ベク
トルに等しいものです (コマンド 法線ベクトル も参照).
   角の二等分線
角の二等分線は, 2つの方法で定められます.
   3点 A, B, C をマークすると, B を頂点とする内角の二等分
     線を作成します.
   2直線をマークすると, それらの二等分線を作成します.
注意: 角の二等分線の方向ベクトルは, 常に長さ 1 です.


   接線
2次曲線の接線は, 2つの方法で作成できます.
   点 A と 2次曲線 c をマークすると, A を通り c に接するす
    べての接線を作成します.
   直線 g と2次曲線 c をマークすると, c に接し, g に平行な
    すべての接線を作成します.

点 A と関数 f をマークすると, x = x(A) で f のグラフに接する接線
を作成します.


   極線/直径
このモードでは, 2次曲線の 極線 または 直径 を作成します.
   点と2次曲線をマークすると, 極線 を得ます.
   直線またはベクトルと2次曲線をマークすると, 直径 を得ま
    す.

3.2.8. 2次曲線

   中心と円周上の点で決まる円
点 M と点 P をマークすると, 中心 M で P を通る円を定めます. こ
の円の半径は MP の距離です.


   中心と半径で決まる円
点 M をマークした後に, ウィンドウが現れて入力フィールドに半径
を入力するよう促されます.
   3点を通る円
3点 A, B, C をマークすると, これらの点を通る円を定めます. 3
点が同一直線上にあるときは, 円はこの直線に退化します.


   5点を通る2次曲線
5点をマークすると, それらを通る2次曲線を作成します.
注意: これら5点のうちのどの4点も同一直線上にないときに限り,
2次曲線は定義されます.

3.2.9. 弧と扇形
注意: 弧の数式としての値はその長さです. 扇形の数式としての値
はその面積です.

   半円
2点 A と B をマークすると, 線分 AB の上に半円を作成します.


   中心と弧上の2点で決まる円弧
3点 M, A, B をマークすると, 中心 M, 始点 A, 終点 B の円弧を作成
します.
注意: 点 B は弧の上にある必要はありません.


   中心と弧上の2点で決まる扇形
3点 M, A, B をマークすると, 中心 M, 始点 A, 終点 B の扇形を作成
します.
注意: 点 B は弧の上にある必要はありません.


   3点を通る外接円弧
3点をマークすると, これらを通る 外接円弧 を作成します.


   3点を通る外接扇形
3点をマークすると, これらを通る 外接扇形 を作成します.
3.2.10. 数値と角度

   距離/長さ
このモードでは, 2点, 2直線または点と直線の距離を求められま
す. 線分や円周の長さも求められます.


   面積
このモードでは, 多角形, 円または楕円の面積を求められ, 幾何ウィ
ンドウの動的なテキストとして表示されます.


   傾き
このモードでは, 直線の傾きを求められ, 幾何ウィンドウの動的な
テキストとして表示されます.


   スライダー
注意: GeoGebra では, スライダーは自由な数値や角度のグラフィカ
ルな表示にすぎません.

ドローイングパッドの任意の場所をクリックすると, 数値や角度に
対するスライダーが作成されます. ウィンドウが現れて, 名前, 数値
や角度の区間 [最小, 最大], スライダーの揃えや幅 (単位はピクセル)
を指定できます.
注意: 既に存在する自由な数値や角度を表示することで(コンテキス
トメニュー や, モード   S オブジェクトの表示/非表示 を参照),
簡単にスライダーを作成できます..

スライダーの位置は, 画面上の固定された位置にも, 座標系に対し
て固定された位置にもできます (数値や角度のプロパティを参照).


   角度
このモードでは, 次のものが作成できます.
   3点のなす角
   2線分のなす角
   2直線のなす角
        2ベクトルなす角
        多角形のすべての内角

角度の大きさを最大 180 度に制限したいならば, プロパティダイア
ログで優角 (180 度より大きい角) を許すのチェックを消して下さい
.

         大きさを決めた角度
2点 A と B をマークし, その後現れるウィンドウの入力フィールド
に角の大きさをタイプします. このモードでは点 C と角度θを作成
します. θは角 ABC です.

    3.2.11. 真偽値

         オブジェクトの表示/非表示のチェックボックス
ドローイングパッドでクリックすると, いくつかのオブジェクトを
表示したり非表示にしたりするチェックボックス (真偽値の変数) が
作成されます. その後現れるウィンドウで, どのオブジェクトがこの
チェックボックスの影響を受けるかを指定できます.

    3.2.12. 軌跡

         軌跡
点 A に依存している点 B (訳注: A が変化すると B もそれに応じて
変化する) の軌跡を描きたいとき, 点 B をマークするとその軌跡が
描画されます.
注意: 点 A は何かオブジェクト (例えば直線, 線分, 円) の上になく
てはなりません.

例:
        f(x) = x^2 - 2 x - 1 と入力フィールドにタイプします.
        新規の点 A を x 軸上に配置します (モード 新規の点 , コ
         マンド 点 を参照).
        点 A に依存する点 B = (x(A), f'(x(A))) を作成します.
     モード     軌跡 を選択し, 続いて点 B と点 A をクリックし
      ます.
     点 A を x 軸に沿ってドラッグすると, 点 B がその軌跡の直
      線に沿って動きます.

3.2.13. 幾何的変換
以下の幾何的変換は, 点, 直線, 2次曲線, 多角形とイメージに対し
て使用できます.


      点に関する鏡映
最初に, 鏡映を施したいオブジェクトをマークします. 次に, 鏡映の
中心となる点をクリックします.


      直線に関する鏡映
最初に, 鏡映を施したいオブジェクトをマークします. 次に, 鏡映の
対称軸となる直線をクリックします.


      中心と角度で決まる回転
最初に, 回転したいオブジェクトをマークします. それから, 回転の
中心となる点をクリックします. その後ウィンドウが現れ, そこで回
転角を指定します.


      ベクトルで決まる平行移動
最初に, 平行移動したいオブジェクトをマークします. その後, 平行
移動量を表すベクトルをクリックします.


      点を中心とした拡大
最初に, 拡大したいオブジェクトをマークします. それから, 拡大の
中心となる点をクリックします. その後ウィンドウが現れ, 拡大の倍
率を指定します.
3.2.14. テキスト

   テキスト
このモードを用いると, 静的あるいは動的なテキストまたは, LaTeX
形式の数式を幾何ウィンドウに作成できます.
   ドローイングパッドをクリックして, その位置に新規のテキ
    ストフィールドを作成します.
   点をクリックして, 新規のテキストフィールドを作成すると,
    その位置はこの点に相対的になります.

その後ダイアログが現れ, テキストを入力できます.
注意: 動的なテキストを作成するために, オブジェクトの値を使用
することもできます.

入力                  説明
“This is a text”    単純なテキスト (静的)
“点 A = ” + A        点 A の値を用いた動的テキスト
“a = ” + a + ”cm”   線分 a の値を用いた動的テキスト

テキストの位置は, 画面上の固定された位置にも, 座標系に対して
固定された位置にもできます (テキストの プロパティ を参照).
LeTeX 数式
GeoGebra では数式を書くこともできます. そのためには, テキ
スト モードのダイアログで, チェックボックス「LaTeX 数式」をチ
ェックし, 数式を LaTeX の文法で入力します.
ここに LaTeX の重要なコマンドをいくつか説明します. さらなる情
報は LaTeX の解説を見て下さい.

    LaTeX の入力                結果
    a \cdot b                a b
                             a
    \frac{a}{b}
                             b
    \sqrt{x}                   x
                             n
    \sqrt[n]{x}                  x
    \vec{v}
LaTeX の入力                結果
\overline{AB}            AB
x^{2}                    x2
a_{1}                    a1
\sin\alpha + \cos\beta   sin   cos 
                          b
\int_{a}^{b} x dx         xdx
                         a


                          i
                              n      2
\sum_{i=1}^{n} i^2            i 1
3.2.15. イメージ

      イメージの挿入
このモードでは, 作図にイメージを加えることができます.
   ドローイングパッドでクリックして, イメージの左下隅を指
    定します.
   点をクリックすると, その点をイメージの左下隅として指定
    します.
その後, ファイルを開くダイアログが現れて, 挿入したいイメージ
のファイルを選びます.

3.2.16. イメージのプロパティ
位置
イメージの位置は, 画面上の固定された位置, または, 座標系に対し
て固定された位置にもできます (イメージのプロパティを参照). こ
の後者の方法は, イメージの四隅のうち最大3点までを指定するこ
とで実現できます.
   1つ目の隅 (イメージの左下隅)
   2つ目の隅 (イメージの右下隅)
     注意: この隅は1つ目の隅が既に指定されているときのみ指
     定できます. これは, イメージの幅を制御します.
   4つ目の隅 (イメージの左上隅)
     注意: これは, 1つ目の隅が既に指定されているときのみ指
     定できます. これは, イメージの高さを制御します.
注意: コマンド隅も参照.

例:
3点 A, B, C を作成し, 隅の点の効果を見てみましょう.
    点 A をイメージの1つ目の隅, 点 B を2つ目の隅に設定し
      ます.   移動 モードで点 A と B をドラッグすると, とても
      簡単にその影響を見ることができます.
     点 A をイメージの1つ目の隅, 点 C を4つ目の隅に設定す
      ると, 点のドラッグがイメージにどう影響するかが見られま
      す.
     最後に, 3つすべての隅を設定すると, 点のドラッグがイメ
      ージをどう歪めるかを見ることができます.

既にイメージの位置と大きさをどう変化させるかを見てみました.
ある点 A にイメージを結び付けて, その幅を 3, 高さを 4 に設定した
いときは, 次のようにすることができます.
   1つ目の隅: A
   2つ目の隅: A + (3, 0)
   4つ目の隅: A + (0, 4)
注意: 移動 モードで点 A をドラッグしても, イメージはその大
きさを保ちます.
背景画像
イメージを背景画像に設定することができます (イメージのプロパ
ティを参照). 背景画像は座標系の背後にあり, マウスではもはや選
択できません.
注意: イメージの背景画像の設定を変更したいときは, 編集メニュ
ーのプロパティを選びます.
透過率
イメージの背後にあるオブジェクトや軸が見えるようにするため,
イメージを半透明にできます. イメージの透過率を 0%から 100%に
指定できます (イメージのプロパティを参照).
4.   数式入力
この章では, キーボードを用いて GeoGebra のオブジェクトを作成
したり修正したりする方法を説明します.


4.1. 一般的な注意
固定されていたり, 依存性のあるオブジェクトの値, 座標や方程式
は, 数式ウィンドウ (左側) に表示されます. 自由なオブジェクトは
他のどのオブジェクトにも依存していないので, 直接変更できます.

GeoGebra の画面の下部にある入力フィールドを用いて, オブジェ
クトを作成したり修正したりできます (直接入力, コマンドを参照).
注意: 入力フィールドにオブジェクトの定義をタイプした後は, 必
ず Enter キーを押して下さい.

4.1.1. 値の変更
自由なオブジェクトは直接変更できますが, 依存性のあるオブジェ
クトはそうではありません. 自由なオブジェクトの値を操作するに
は, 新しい値を入力フィールドに入力します(直接入力を参照).
例: 既にある数値 a = 3 の値を変更したいときは, 入力フィールドに
a = 5 とタイプして Enter キーを押して下さい.

注意: あるいは, 数式ウィンドウにおいて, コンテキスト メニューの
「再定義」を選択したり, 数式ウィンドウにおいて,    移動モード
でオブジェクトをダブルクリックしても, 同じことが行えます.

4.1.2. アニメーション
角度の数値を連続的に変更するためには,         移動 モードを選択し
ます. そして, 数値や角度をクリックし, + や - のキーを押します.

これらのキーを押し続けると, アニメーションが行われます.
例: ある点の座標が, P = (2 k, k) のように数値 k に依存していると
き, k が連続的に変わると, この点はある直線に沿って動きます.
  移動モードで矢印キーを用いると, 自由なオブジェクトを移動
することができます (アニメーション, モード 移動を参照).
注意: このオブジェクトのプロパティ ダイアログを用いると, 移動
の増分を調整できます.

以下のショートカットがあります.
   Ctrl + 矢印キーでは, 10 ずつ変化します.
   Alt + 矢印キーでは, 100 ずつ変化します.

注意: 直線上の点は, + や - キーを用いると, その直線に沿って移動
できます(アニメーションを参照).


4.2. 直接入力
GeoGebra は, 数値, 角度, 点, ベクトル, 線分, 直線, 2次曲線, 関数,
媒介変数表示された曲線を扱えます. ここでは, これらのオブジェク
トを入力フィールドに座標や方程式で入力する方法を説明します.

注意: オブジェクトの名前には, 添字を含めることもできます. 例え
ば, A1 あるいは SAB は A_1 や s_{AB} のように入力されます.

4.2.1. 数値と角度
数値と角度は, 記号 "." を小数点として用います.

例: 数値 r を, r = 5.32 と入力することで得られます.
注意: 円周率πと, オイラー定数 e も, 入力フィールドの横のドロッ
プダウンメニューから選択して, 方程式や計算に使用できます.

角度は, 度数 (°)かラジアン (rad) で入力します. 定数πはラジアン
の値に有用で, pi としても入力できます.

例: 角度αは, 度数法 (α = 60°) あるいは弧度法 (α = pi/3) で入力
できます.

注意: GeoGebra 内部では, すべての計算を弧度法で行います. 記号
°は, 度数をラジアンに変換する定数 pi/180 にすぎません.
スライダーと矢印キー
自由な数値や角度は, スライダーとして幾何ウィンドウに表示でき
ます (モード スライダー を参照). 矢印キーを用いて, 数式ウィン
ドウの数値や角度も変更されます (アニメーションを参照).
区間の端の値
自由な数値や角度は, 区間 [最小, 最大] に制限することができます (
プロパティダイアログを参照). この区間は               スライダーにも使用
できます.

依存性のある角度に対しては, 優角 (180 度より大きい角) を許すか
どうか指定できます (プロパティダイアログを参照).

4.2.2. 点とベクトル
点とベクトルは, 直交座標系または極座標系で入力できます (数値
と角度を参照).
注意: 大文字のラベルは点を表し, 小文字のラベルはベクトルを表
します.

例:
        点 P やベクトル v を直交座標系で入力するには, P = (1, 0)
         や, v = (0, 5) とします.
        極座標系で入力するには, P = (1; 0°) や v = (5; 90°) とし
         ます.

4.2.3. 直線
直線は, x と y の1次関数, あるいは, 媒介変数表示で入力します. ど
ちらの場合でも, 以前に定義した変数 (例えば, 数値, 点, ベクトル)
が使用できます.
注意: 式の最初に, コロンを後に付けた直線の名前を入力すること
ができます.

例:
        直線 g を1次関数で入力するには, g : 3x + 4y = 2 とタイプ
         します.
        媒介変数表示で直線 g を入力するには, 媒介変数 t (t = 3) を
         定義してから, g: X = (-5, 5) + t (4, -3) と入力します.
        最初に変数 m = 2 と b = -1 を定義します. それから, 方程式
         g: y = m x + b と y 切片形式で入力できます.
x軸とy軸
2つの座標軸は, x 軸 と y 軸 という名前で, コマンドに利用できま
す.
例: コマンド 垂線[A, x 軸] は, x 軸に垂直で, 与えられた点 A を通る
直線を作成します.

4.2.4. 2次曲線
 2次曲線は, x と y の2次方程式で入力します. 以前に定義した変数
(例えば, 数値, 点, ベクトル) が利用できます. 式の最初に, コロンを
後に付けた2次曲線の名前を入力することができます.

例:
        楕円 ell:    ell: 9 x^2 + 16 y^2 = 144
        双曲線 hyp:   hyp: 9 x^2 – 16 y^2 = 144
        放物線 par:   par: y^2 = 4 x
        円 k1:      k1: x^2 + y^2 = 25
        円 k2:      k2: (x–5)^2 + (y+2)^2 = 25

注意: 2つの変数 a = 4 と b = 3 を事前に定義してあるとき, 楕円を
ell: b^2 x^2 + a^2 y^2 = a^2 b^2 と入力できます.

4.2.5. x の関数
x の関数を入力するときに, 以前に定義した変数 (例えば, 数値, 点,
ベクトル) と他の関数を使用できます.
例:
    関数 f: f(x) = 3 x^3 – x^2
    関数 g: g(x) = tan(f(x))
    無名関数: sin(3 x) + tan(x)

すべての組込み関数 (例えば, sin, cos, tan) は, 算術演算の節で説明
します (算術演算を参照).
GeoGebra では, 関数の積分と微分を得るためにコマンドが使用で
きます.

コマンド f'(x) や f''(x), ... も, あらかじめ定義されている関数 f(x) の
導関数を求めるために利用できます.
例: 最初に関数 f を, f(x) = 3 x^3 - x^2 で定義します. それから, 関数
g を得るために, g(x) = cos(f'(x + 2)) とタイプします.

さらに, 関数はベクトルにより平行移動でき (平行移動を参照), 自由
な関数のグラフは, マウスで移動できます ( 移動を参照).
関数の区間への制限
関数を区間 [a, b] に制限するためには, コマンド 関数 を使って下さ
い (コマンド関数を参照).

4.2.6. オブジェクトのリスト
 中括弧を用いて, いくつかのオブジェクトのリストを作成できます
(例えば, 点, 線分, 円).

例:
        L = {A, B, C} は, 事前に定義した3点 A, B, C の
         リストを与えます.
        L = {(0, 0), (1, 1), (2, 2)} は, 入力された名前
         のない3点のリストを作成します.

4.2.7. 算術演算
数値, 座標や等式を入力するために (直接入力を参照), 括弧を用いた
算術演算を利用できます. GeoGebra では次の演算が利用できます.

         演算                  入力
         和                   +
         差                   -
         積                   * または スペースキー
         内積                  * または スペースキー
         商                   /
         累乗                  ^ または 2
         演算                     入力
         階乗                     !
         ガンマ関数                  gamma( )
         括弧                     ( )
         x 座標                   x( )
         y 座標                   y( )
         絶対値                    abs( )
         符号                     sgn( )
         平方根                    sqrt( )
         立方根                    cbrt( )
         0 と 1 の間の乱数            random( )
         指数関数                   exp( ) または ℯx
                                ln( ) または log(
         自然対数
                                )
         2 の対数                  ld( )
         常用対数                   lg( )
         余弦                     cos( )
         正弦                     sin( )
         正接                     tan( )
         逆余弦                    acos( )
         逆正弦                    asin( )
         逆正接                    atan( )
         双曲余弦                   cosh( )
         双曲正弦                   sinh( )
         双曲正接                   tanh( )
         逆双曲余弦                  acosh( )
         逆双曲正弦                  asinh( )
         逆双曲正接                  atanh( )
         入力された数以下の最大の整
                                floor( )
         数
         入力された数以上の最小の整
                                ceil( )
         数
         四捨五入                   round( )

例:
         2点 A と B の中点 M は, M = (A + B) / 2 と入力できます.
     ベクトル v の長さは, l = sqrt(v * v) と計算できます.

注意: GeoGebra では, 点やベクトルの計算もできます.

4.2.8. 真偽値変数
GeoGebra では, 真偽値の変数 "真" と "偽" を利用できます.

例: 入力フィールドに a = 真 あるいは b = 偽 とタイプして, Enter
キーを押します.
チェックボックスと矢印キー
自由な真偽値変数は, ドローイングパッド上にチェックボックスと
して表示できます (モード  チェックボックスとオブジェクトの表
示/非表示を参照). 矢印キーを用いて, 数式ウィンドウの真偽値変
数も変更できます (アニメーションを参照).

4.2.9. 真偽値演算
GeoGebra では, 次の真偽値演算ができます.

            演算        例                   型
                                          数値, 点, 直線,
等しい         ≟ or ==   a ≟     b or a == b
                                          2次曲線 a, b
                                          数値, 点, 直線,
等しくない       ≠ or !=   a ≠     b or a != b
                                          2次曲線 a, b
小さい         <         a   <   b           数値 a, b
大きい         >         a   >   b           数値 a, b
以下          ≤ or <=   a   ≤   b or a <= b 数値 a, b
以上          ≥ or >=   a   ≥   b or a >= b 数値 a, b
かつ          ∧         a ∧ b             真偽値 a, b
または         ∨         a ∨ b             真偽値 a, b
否定          ¬ or !    ¬a or !a          真偽値 a
平行          ∥         a ∥b              直線 a, b
垂直          ⊥         a ⊥b              直線 a, b
4.3. コマンド
コマンドを用いると, 新規にオブジェクトを作成したり, 存在する
オブジェクトを修正したりできます. コマンドの結果には, ラベルと
その後に "=" を記述することで, 名前を付けられます. 下の例では,
新規の点に S という名前を付けています.

例: 2つの直線 g と h の交点を求めるためには, S = 交点[g, h] と入
力します (コマンド交点を参照).

注意: オブジェクトの名前には, 添字も使用できます: A1 や SAB は
A_1 や S_{AB}と入力します.

4.3.1. 一般的なコマンド
関係
関係[オブジェクト a, オブジェクト b]: メッセージボックスに
    オブジェクト a と b の関係を表示します.
    注意: このコマンドは, 2つのオブジェクトが等しいかどう
    か, 点が直線や2次曲線上にあるかどうか, 直線が2次曲線
    に接したり通るかどうかを判定します.
消去
消去[オブジェクト a]: オブジェクト a と, それに依存するすべて
    のオブジェクトを消去します.
要素
要素[リスト L, 数値 n]: リスト L の n 番目の要素

4.3.2. 真偽コマンド
If[条件, a, b]: 条件が 真 ならば, オブジェクト a のコピーを与
    え, 偽 ならば, オブジェクト b のコピーを与えます.
If[条件, a]: 条件が 真 ならば, オブジェクト a のコピーを与え,
    偽 ならば, 未定義のオブジェクトを与えます.
4.3.3. 数値
長さ
長さ[ベクトル v]: ベクトル v の長さ
長さ[点 A]: A の位置ベクトルの長さ
長さ[関数 f, 数値 x1, 数値 x2]: 関数 f のグラフの, x = x1 か
    ら x = x2 までの長さ
長さ[関数 f, 点 A, 点 B]: 関数 f のグラフ上の点 A と B の間の
    グラフの長さ
長さ[曲線 c, 数値 t1, 数値 t2]: t1 から t2 までの曲線の長さ
長さ[曲線 c, 点 A, 点 B]: 曲線上の点 A と B の間の曲線の長
    さ
長さ[リスト L]: リスト L の長さ (リストの要素の数)
面積
面積[点 A, 点 B, 点 C, ...]: 点 A, B, C, ... で定義される多角
    形の面積
面積[2次曲線 c]: 2次曲線 c (円または楕円) の面積
距離
距離[点 A, 点 B]: 2点 A と B の距離
距離[点 A, 直線 g]: 点 A と 直線 g の距離
距離[直線 g, 直線 h]: 直線 g と h の距離
注意: 交わる直線に対しては距離は 0 です. この関数は, 平行線に対
     してだけ意味のある値を与えます.
剰余関数
剰余[数値 a, 数値 b]: 数 a を数 b で割った余り
整数の商
整数商[数値 a, 数値 b]: 数 a を数 b で割った整数の商
傾き
傾き[直線 g]: 直線 g の傾き
注意: このコマンドは, 傾きの三角形も描画します. この三角形のサ
     イズも変更できます (プロパティダイアログを参照).
曲率
曲率[点 A, 関数 f]: 関数 f のグラフ上の点 A における曲率
曲率[点 A, 曲線 c]: 曲線 c 上の点 A における曲率
半径
半径[円 c]: 円 c の半径
円周
円周[2次曲線 c]: 2次曲線 c の円周 (円または楕円)
外周
外周[多角形 poly]: 多角形 poly の外周の長さ
Parameter
Parameter[放物線 p]: 放物線 p の parameter (準線と焦点の距離
     )
第1軸の長さ
第1軸長さ[2次曲線 c]: 2次曲線 c の第1軸の長さ
第2軸の長さ
第2軸長さ[2次曲線 c]: 2次曲線 c の第2軸の長さ
離心率
離心率[2次曲線 c]: 2次曲線 c の離心率
積分
積分[関数 f, 数値 a, 数値 b]: 関数 f(x) の 数値 a から b まで
     の定積分
注意: このコマンドは, 関数 f のグラフと x 軸との間の領域も描画し
     ます.
積分[関数 f, 関数 g, 数値 a, 数値 b]: 関数 f(x) - g(x) の数値
     a から数値 b までの定積分
注意: このコマンドは, 関数 f と g のグラフの間の領域も描画します
     .

注意: 不定積分も参照
下方和
下方和[関数 f, 数値 a, 数値 b, 数値 n]: 区間 [a, b] における
     , 長方形 n 個による, 関数 f の下方和.
注意: このコマンドは, 下方和の長方形も描画します.
上方和
上方和[関数 f, 数値 a, 数値 b, 数値 n]: 区間 [a, b] における
     , 長方形 n 個による, 関数 f の上方和.
注意: このコマンドは, 上方和の長方形も描画します.
反復
反復[関数 f, 数値 x0, 数値 n]: 初期値 x0 に対して, 関数 f を
    n 回反復して適用します.
    例: f(x) = x^2 と定義して, コマンド 反復[f, 3, 2] を
    実行すると, 結果は (32)2 = 81 となります.
最小と最大
最小[数値 a, 数値 b]: 数値 a と b の最小値
最大[数値 a, 数値 b]: 数値 a と b の最大値
Affine Ratio
AffineRatio[点 A, 点 B, 点 C]: 同一直線上にある点 A, B, C
       の affine ratio λを与える. ここで, C = A + λ * AB である.
複比
複比[点 A, 点 B, 点 C, 点 D]: 同一直線上にある4点 A, B, C,
    D の複比λを与える. ここで, λ = AffineRatio[B, C, D] /
    AffineRatio[A, C, D] である.

4.3.4. 角度
角度
角度[ベクトル v1, ベクトル v2]: 2つのベクトル v1 と v1 のな
     す角度 (0°から 360°)
角度[直線 g, 直線 h]: 2直線 g と h の方向ベクトルのなす角度
     (0°から 360°)
角度[点 A, 点 B, 点 C]: 線分 BA と BC で作られる角度 (0°か
     ら 360°). 点 B が頂点.
角度[点 A, 点 B, 角度 α]: 頂点を B として,点 A から大きさα
     で作られる角度.
注意: 点 回転[A, α, B] も作成されます.
角度[2次曲線 c]: 2次曲線 c の第1軸の回転角 (コマンド 軸 を
     参照) .
角度[ベクトル v]: x 軸とベクトル v のなす角度.
角度[点 A]: x 軸と点 A の位置ベクトルのなす角度
角度[数値 n]: 数値 n を角度に変換する (結果は 0 と 2pi の間).
角度[多角形 poly]: 多角形 poly のすべての内角

4.3.5. 点
点
点[直線 g]: 直線 g 上の点
点[2次曲線 c]: 2次曲線 c (例えば円, 楕円, 双曲線) 上の点
点[関数 f]: 関数 f のグラフ上の点
点[多角形 poly]: 多角形 poly 上の点
点[ベクトル v]: ベクトル v 上の点
点[点 P, ベクトル v]: 点 P とベクトル v の和
中点と中心
中点[点 A, 点 B]: 点 A と B の中点
中点[線分 s]: 線分 s の中点
中心[2次曲線 c]: 2次曲線 c (例えば円, 楕円, 双曲線) の中心
焦点
焦点[2次曲線 c]: 2次曲線 c の (すべての) 焦点
頂点
頂点[2次曲線 c]: 2次曲線 c の (すべての) 頂点
重心
重心[多角形 poly]: 多角形 poly の重心
交点
交点[直線 g, 直線 h]: 直線 g と h の交点
交点[直線 g, 2次曲線 c]: 直線 g と2次曲線 c のすべての交点
    (最大 2 個)
交点[直線 g, 2次曲線 c, 数値 n]: 直線 g と2次曲線 c の n 番
    目の交点
交点[2次曲線 c1, 2次曲線 c2]: 2次曲線 c1 と c2 のすべての
    交点 (最大 4 個)
交点[2次曲線 c1, 2次曲線 c2, 数値 n]: 2次曲線 c1 と c2
    の n 番目の交点
交点[多項式 f1, 多項式 f2]: 多項式関数 f1 と f2 のグラフのす
    べての交点
交点[多項式 f1, 多項式 f2, 数値 n]: 多項式関数 f1 と f2 のグ
    ラフの n 番目の交点
交点[多項式 f, 直線 g]: 多項式関数 f のグラフと直線 g のすべ
    ての交点
交点[多項式 f, 直線 g, 数値 n]: 多項式関数 f のグラフと直線
    g の n 番目の交点
交点[関数 f, 関数 g, 点 A]: 関数 f と g のグラフの交点の近似
    値を, 初期値として点 A を用いてニュートン法で求める.
交点[関数 f, 直線 g, 点 A]: 関数 f のグラフと直線 g の交点の
    近似値を, 初期値として点 A を用いてニュートン法で求める
    .

注意: モード    2つのオブジェクトの交点 も参照
根
根[多項式 f]: 多項式 f のすべての根 (点として)
根[関数 f, 数値 a]: 関数 f の根を, 初期値として数値 a を用いて
    ニュートン法で求める.
根[関数 f, 数値 a, 数値 b]: 関数 f の, 区間 [a, b] におけるひと
    つの根を, Regula Falsi 法で求める.
極値
極値[多項式 f]: 多項式 f のすべての極値 (点として)
変曲点
変曲点[多項式 f]: 多項式 f のすべての変曲点

4.3.6. ベクトル
ベクトル
ベクトル[点 A, 点 B]: 点 A から点 B へのベクトル
ベクトル[点 A]: 点 A の位置ベクトル
方向ベクトル
方向ベクトル[直線 g]: 直線 g の方向ベクトル
注意: 方程式 ax + by = c で定まる直線は, 方向ベクトル (b, -a) を持
     ちます.
単位ベクトル
単位ベクトル[直線 g]: 直線 g の長さ 1 の方向ベクトル
単位ベクトル[ベクトル v]: 与えられたベクトル v と同じ方向と向
   きを持つ長さ 1 のベクトル
法線ベクトル
法線ベクトル[直線 g]: 直線 g に垂直なベクトル
注意: 方程式 ax + by = c で定まる直線は法線ベクトル (a, b) を持ち
     ます.
法線ベクトル[ベクトル v]: ベクトル v の法線ベクトル.
注意: ベクトル (a, b) の法線ベクトルは, (-b, a) です.
単位法線ベクトル
単位法線ベクトル[直線 g]: 直線 g の, 長さが 1 である法線ベクト
   ル
単位法線ベクトル[ベクトル v]: ベクトル v の, 長さが 1 である法
   線ベクトル
曲率ベクトル
曲率ベクトル[点 A, 関数 f]: 円 A における, 関数 f のグラフの曲
   率ベクトル
曲率ベクトル[点 A, 曲線 c]: 点 A における, 曲線 c の曲率ベク
   トル

4.3.7. 線分
線分
線分[点 A, 点 B]: 点 A と B を結ぶ線分
線分[点 A, 数値 a]: 始点が点 A で, 長さが a である線分
注意: 線分の終点も作成されます.

4.3.8. 半直線
半直線
半直線[点 A, 点 B]: 点 A を始点とし, 点 B を通る半直線
半直線[点 A, ベクトル v]: 点 A を始点とし, 方向ベクトル v を
   持つ半直線
4.3.9. 多角形
多角形
多角形[点 A, 点 B, 点 C,...]: 与えられた点 A, B, C, ... で定
   まる多角形
多角形[点 A, 点 B, 数値 n]: 正 n 角形 (点 A と B を頂点に含む
   )

4.3.10. 直線
直線
直線[点 A, 点 B]: 2点 A と B を通る直線
直線[点 A, 直線 g]: 点 A を通り, 直線 g に平行な直線
直線[点 A, ベクトル v]: 点 A を通り, 方向ベクトル v を持つ直
    線
垂線
垂線[点 A, 直線 g]: 点 A を通り, 直線 g に垂直な直線
垂線[点 A, ベクトル v]: 点 A を通り, ベクトル v に垂直な直線
垂直二等分線
垂直二等分線[点 A, 点 B]: 線分 AB の垂直二等分線
垂直二等分線[線分 s]: 線分 s の垂直二等分線
角の二等分線
角の二等分線[点 A, 点 B, 点 C]: 点 A, B, C で定まる角の二等
     分線
注意: 点 B が角の頂点
角の二等分線[直線 g, 直線 h]: 直線 g と h のなす両方の角の二
     等分線
接線
接線[点 A, 2次曲線 c]: 点 A を通り, 2次曲線 c に接する (すべ
    ての) 接線
接線[直線 g, 2次曲線 c]: 直線 g に平行で 2次曲線 c に接する
    (すべての) 接線
接線[数値 a, 関数 f]: 関数 f(x) のグラフの, x = a における接線
接線[点 A, 関数 f]: 関数 f(x) のグラフの, x = x(A) における接線
接線[点 A, 曲線 c]: 点 A における, 曲線 c の接線
漸近線
漸近線[双曲線 h]: 双曲線 h の両方の漸近線
準線
準線[放物線 p]: 放物線 p の準線
軸
軸[2次曲線 c]: 2次曲線 c の第1軸と第2軸
第1軸
第1軸[2次曲線 c]: 2次曲線 c の第1軸
第2軸
第2軸[2次曲線 c]: 2次曲線 c の第2軸
極線
極線[点 A, 2次曲線 c]: 2次曲線 c の 点 A に関する 極線
直径
直径[直線 g , 2次曲線 c]: 2次曲線 c の 直線 g に関する 直径
直径[ベクトル v, 2次曲線 c]: 2次曲線 c の 方向ベクトル v に
    関する 直径

4.3.11. 2次曲線
円
円[点   M,   数値 r]: 中心 M 半径 r の円
円[点   M,   線分 s]: 中心 M で, 半径が線分 s の長さに等しい円
円[点   M,   点 A]: 中心 M で, 点 A を通る円
円[点   A,   点 B, 点 C]: 3点 A, B, C を通る円
Osculating Circle
OsculatingCircle[点 A, 関数 f]: 関数 f のグラフの, 点 A に
     おける osculating circle
OsculatingCircle[点 A, 曲線 c]: 曲線 c のグラフの, 点 A に
     おける osculating circle
楕円
楕円[点 F, 点 G, 数値 a]: 焦点が F と G で, 第1軸 (長軸) の長
    さが a である楕円
注意: 条件: 2a > 距離[F, G]
楕円[点 F, 点 G, 線分 s]: 焦点が F と G で, 第1軸 (長軸) の長
     さが線分 s の長さに等しい楕円
双曲線
双曲線[点 F, 点 G, 数値 a]: 焦点が F と G で, 第1軸の長さが
     a である双曲線
注意: 条件: 0 < 2a < 距離[F, G]
双曲線[点 F, 点 G, 線分 s]: 焦点が F と G で, 第1軸の長さが
     線分 s の長さに等しい双曲線
放物線
放物線[点 F, 直線 g]: 焦点が F で 準線が g である放物線
2次曲線
2次曲線[点 A, 点 B, 点 C, 点 D, 点 E]: 5点 A, B, C, D, E
     を通る2次曲線
注意: どの4点も同一直線上にない必要があります.

4.3.12. 関数
微分
微分[関数 f]: 関数 f(x) の導関数
微分[関数 f, 数値 n]: 関数 f(x) の n 次導関数

注意: 微分[f] の代わりに f'(x), 同様に, 微分[f, 2] の代わりに f''(x) を
使用できます.
積分
積分[関数 f]: f(x) の不定積分

注意: 定積分を参照
多項式
多項式[関数 f]: 展開された多項式関数 f
   例: 多項式[(x - 3)^2] は, x2 - 6x + 9 を与えます.
テイラー多項式
テイラー多項式[関数 f, 数値 a, 数値 n]: 関数 f の x = a にお
   ける n 次までの級数展開
関数
関数[関数 f, 数値 a, 数値 b]: 関数 f を区間 [a, b]に制限した関
    数. [a, b] の外では定義されない.
場合分けを含む関数
真偽値関数 If (コマンド If 参照) を用いて, 場合分けを含む関数を作
成できます.
注意: このように定義された関数も, 「通常の」関数のように, 微分
や積分をしたり, 交点を求めることができます.

例:
f(x) = If[x < 3, sin(x), x^2] とすると, 関数 f は, x < 3 に
おいては sin(x) であり, x ≥ 3 では x2 を与える関数になります.

4.3.13. 媒介変数表示された曲線
曲線[式 e1, 式 e2, 媒介変数 t, 数値 a, 数値 b]: 区間 [a,
      b] を動く媒介変数 t を用いて, 直交座標系における x 座標が
      式 e1 で, y 座標が式 e2 で定められる媒介変数表示された曲
      線
例: c = 曲線[2 cos(t), 2 sin(t), t, 0, 2 pi]

微分[曲線 c]: 曲線 c の微分

注意: 媒介変数表示された曲線は, 関数と同様に, 算術演算の式に使
用できます.
例: 入力 c(3) は, 媒介変数の値が 3 で定まる, 曲線 c 上の点を与え
ます.

注意: モード   新規の点 においてマウスを用いても, 曲線上に点を
配置することができます (モード 新規の点 を参照. コマンド 点 も参
照). 区間の両端 a と b は動的なので, スライダーで変更させること
もできます (モード スライダー を参照).

4.3.14. 弧と扇形
注意: 弧の数式としての値はその長さです. 扇形の数式としての値
はその面積です.
半円
半円[点 A, 点 B]: 線分 AB の上にある半円
円弧
円弧[点 M, 点 A, 点 B]: 中心 M, 開始点 A, 終点 B である円弧
注意: 点 B は弧上にある必要はありません.
外接円弧
外接円弧[点 A, 点 B, 点 C]: 3点 A, B, C を通る円弧
弧
弧[2次曲線 c, 点 A, 点 B]: 2点 A と B の間の2次曲線 (円ま
    たは楕円) の弧
弧[2次曲線 c, 数値 t1, 数値 t2]: 次の形の2次曲線の, 2つ
    の媒介変数の値 t1 と t2 の間の弧:
   円: (r cos(t), r sin(t)). r は円の半径
   楕円: (a cos(t), b sin(t)). a と b は第1軸と第2軸の長さ
扇形
扇形[点 M, 点 A, 点 B]: 中心 M で, 2点 A, B の間の弧を持つ
     扇形
注意: 点 B は弧上にある必要はありません.
外接扇形
外接扇形[点 A, 点 B, 点 C]: 3点 A, B, C を通る弧を持つ扇形
扇形 2
扇形 2[2次曲線 c, 点 A, 点 B]: 2次曲線 c (円または楕円) 上
     の2点 A と B の間の弧を持つ扇形
扇形 2[2次曲線 c, 数値 t1, 数値 t2]: 次の形の2次曲線の,
     2つの媒介変数の値 t1 と t2 の間の弧を持つ扇形:
   円: (r cos(t), r sin(t)). r は円の半径
   楕円: (a cos(t), b sin(t)). a と b は第1軸と第2軸の長さ

4.3.15. イメージ
隅
隅[イメージ pic, 数値 n]: イメージ pic の最大 4 つある隅のう
    ち n 番目の隅
4.3.16. テキスト
名前
名前[オブジェクト]: 与えられたオブジェクトの名前を表すテキス
    ト
    注意: このコマンドは, 名前が変更される可能性のあるオブ
    ジェクトに対して, 動的テキストにおいて使用されます.

4.3.17. 軌跡
軌跡
軌跡[点 Q, 点 P]: 点 P に依存する点 Q の軌跡
    注意: 点 P は, オブジェクト (例えば直線, 線分, 円) の上にあ
    る必要があります.

4.3.18. 数列
数列
数列[式 e, 変数 i, 数値 a, 数値 b]: 数値 a から b までを動
    く添字 i を用いた式 e で生成されるリストを作成する.
    例: L = 数列[(2, i), i, 1, 5] とすると, y 座標が 1 か
    ら 5 まで動く点のリストを作成します.
数列[式 e, 変数 i, 数値 a, 数値 b, 数値 s]: 数値 a から b
    まで, 増分 s で動く添字 i を用いた式 e で生成されるリスト
    を作成する.
    例: L = 数列[(2, i), i, 1, 5, 0.5] とすると, y 座標
    が 1 から 5 まで 0.5 ずつ増加する点のリストを作成する.

注意: 区間の両端 a と b は動的なので, スライダーで変更させるこ
ともできます (モード{スライダー}を参照).
その他の数列コマンド
要素[リスト   L, 数値 n]: リスト L の n 番目の要素
長さ[リスト   L]: リスト L の長さ
最小[リスト   L]: リスト L の要素の最小値
最大[リスト   L]: リスト L の要素の最大値
反復
反復数列[関数 f, 数値 x0, 数値 n]:
   初期値 x0 に対して, 関数 f を n 回反復して適用し, 長さ n+1
   のリストを作成する.
   例: f(x) = x^2 と定めたとき, コマンド L = 反復数列[f,
   3, 2] は, リスト L = {3, 32, (32)2} = {3, 9, 81} を与えます.

4.3.19. 幾何的変換
新しい名前に, 以下コマンドの結果を代入すると, 移動されたオブ
ジェクトのコピーが作成されます.
注意: コマンド 鏡映[A, g] は, 点 A の位置を変更します. B = 鏡映[A,
g] とすると, 新規の点 B が作成され, 点 A は変更されません.
平行移動
平行移動[点 A, ベクトル v]: 点 A をベクトル v だけ平行移動し
     ます.
平行移動[直線 g, ベクトル v]: 直線 g をベクトル v だけ平行移
     動します.
平行移動[2次曲線 c, ベクトル v]: 2次曲線 c をベクトル v だ
     け平行移動します.
平行移動[関数 c, ベクトル v]: 関数 f をベクトル v だけ平行移
     動します.
平行移動[多角形 poly, ベクトル v]: 多角形 poly をベクトル v
     だけ平行移動します.
注意: 新しい頂点と線分も作成されます.
平行移動[イメージ pic, ベクトル v]: イメージ pic をベクトル
     v だけ平行移動します.
平行移動[ベクトル v, 点 P]: ベクトル v を点 P へ平行移動しま
     す.

注意: モード     ベクトルで決まる平行移動 も参照
回転
回転[点 A, 角度 phi]: 座標系の原点の回りに, 点 A を角度 phi
    だけ回転する.
回転[ベクトル v, 角度 phi]: ベクトル v を角度 phi だけ回転す
    る.
回転[直線 g, 角度 phi]: 直線 g を角度 phi だけ回転する.
回転[2次曲線 c, 角度 phi]: 座標系の原点の回りに, 2次曲線 c
     を角度 phi だけ回転する.
回転[多角形 poly, 角度 phi]: 座標系の原点の回りに, 多角形
     poly を角度 phi だけ回転する.
注意: 新しい頂点と線分も作成されます.
回転[イメージ pic, 角度 phi]: 座標系の原点の回りに, イメー
     ジ pic を角度 phi だけ回転する.
回転[点 A, 角度 phi, 点 B]: 点 A を, 点 B の回りに角度 phi だ
     け回転する.
回転[直線 g, 角度 phi, 点 B]: 直線 g を, 点 B の回りに角度
     phi だけ回転する.
回転[2次曲線 c, 角度 phi, 点 B]: 2次曲線 c を, 点 B の回り
     に角度 phi だけ回転する.
回転[多角形 poly, 角度 phi, 点 B]: 多角形 poly を, 点 B の回
     りに角度 phi だけ回転する.
注意: 新しい頂点と線分も作成されます.
回転[イメージ pic, 角度 phi, 点 B]: イメージ pic を, 点 B の
     回りに角度 phi だけ回転する.

注意: モード   中心と角度で決まる回転 も参照
鏡映
鏡映[点 A, 点 B]: 点 A を点 B に関して鏡映する.
鏡映[直線 g, 点 B]: 直線 g を点 B に関して鏡映する.
鏡映[2次曲線 c, 点 B]: 2次曲線 c を点 B に関して鏡映する.
鏡映[多角形 poly, 点 B]: 多角形 poly を点 B に関して鏡映する.
注意: 新しい頂点と線分も作成されます.
鏡映[イメージ pic, 点 B]: イメージ pic を点 B に関して鏡映す
     る.
鏡映[点 A, 直線 h]: 点 A を直線 h に関して鏡映する.
鏡映[直線 g, 直線 h]: 直線 g を直線 h に関して鏡映する.
鏡映[2次曲線 c, 直線 h]: 2次曲線 c を直線 h に関して鏡映す
     る.
鏡映[多角形 poly, 直線 h]: 多角形 poly を直線 h に関して鏡映
     する.
注意: 新しい頂点と線分も作成されます.
鏡映[イメージ pic, 直線 h]: イメージ pic を直線 h に関して鏡
    映する.

注意: モード   点に関する鏡映, モード      直線に関する鏡映も参
照
拡大
拡大[点 A, 数値 f, 点 S]: 点 A を, 点 S を中心として 倍率 f で
     拡大する
拡大[直線 h, 数値 f, 点 S]: 直線 h を, 点 S を中心として 倍率
     f で拡大する
拡大[2次曲線 c, 数値 f, 点 S]: 2次曲線 c を, 点 S を中心と
     して 倍率 f で拡大する
拡大[多角形 poly, 数値 f, 点 S]: 多角形 poly を, 点 S を中心
     として 倍率 f で拡大する
注意: 新しい頂点と線分も作成されます.
拡大[イメージ pic, 数値 f, 点 S]: イメージ pic を, 点 S を中
     心として 倍率 f で拡大する

注意:   D 点を中心とした拡大 も参照
5. 印刷とエクスポート
5.1. 印刷
5.1.1. ドローイングパッド
ファイルメニューに, ドローイングパッドの印刷プレビューがあり
ます. ここで, 印刷出力のタイトル, 著者, 日付, 縮尺 (単位は cm) を
指定できます.

注意: プレビューウィンドウで変更をした場合, Enter を押して下さ
い.

5.1.2. 作図手順
作図手順の印刷プレビューウィンドウを開くためには, まず表示メ
ニューの作図手順を開きます. すると, 現れたウィンドウのファイル
メニューに印刷プレビューがあります.

注意: ここでは, 作図手順の名前, 定義, コマンド, 数式やブレークポ
イントといった列を, 表示したり非表示にしたりできます (作図手順
の表示メニューも参照).

作図手順の印刷プレビューウィンドウでは, 印刷の前にタイトル,
著者, 日付を入力することができます.

作図手順ウィンドウの下部にナビゲーションバーがあります. これ
により, 作図をステップごとに操作することができます (ナビゲーシ
ョンバーを参照).
注意: ブレークポイント (表示メニュー) の列を用いると, いくつか
の作図のステップをプレークポイントとして定義して, オブジェク
トをグループ化することができます. ナビゲーションバーで作図を
操作しているときに, グループ化したオブジェクトは一度に表示さ
れます.
5.1.3. ドローイングパッドを画像へ
ファイルメニューのエクスポートにドローイングパッドを画像へと
いうアイテムがあります. ここでは, 出力ファイルの縮尺 (単位は
cm) や解像度 (単位は dpi) を指定することができます. ドローイン
グパッドを図としてエクスポートするときには, 以下のフォーマッ
トを選ぶことができます:
PNG – Portable Network Graphics
このフォーマットはピクセルグラフィックのフォーマットです. 解
像度 (dpi) が高くなればなるほど, 品質は良くなります (通常は
300dpi で十分です). 品質が落ちることを避けるため, PNG グラフィ
クスは後からサイズを変更するべきではありません.

PNG グラフィックファイルは, ウェブページ (html) や, マイクロソ
フト Word で使用するのに適しています.
注意: Word の文書に PNG グラフィックファイルを挿入(ファイル
メニューイメージの挿入)するときはいつでも, サイズが 100%にな
っていることを確認して下さい. そうでなければ, cm 単位で与えら
れたサイズが変わってしまいます.
EPS – Encapsulated Postscript
このフォーマットはベクトルグラフィックのフォーマットです.
EPS 画像は, 品質を落とすことなくサイズを変更できます. EPS 画
像ファイルは, Corel Draw のようなベクトルグラフィックプログラ
ムや, LaTeX のような専門的な組版システム向けに適しています.

EPS グラフィックの解像度は, 常に 72dpi です. この値は, 実際のサ
イズを cm 単位で計算するためだけに使用され, イメージの品質に
は影響がありません.

注意: 塗りつぶされた多角形や, 2次曲線に半透明の効果を用いた
場合, EPS には変換できません.
SVG – Scaleable Vector Graphic
(上の EPS フォーマットを見てください)
EMF – Enhanced Meta Format
(上の EPS フォーマットを見てください)
PSTricks
LaTeX で利用できる, PostScript 画像を生成するパッケージのフォ
ーマットです.


5.2. ドローイングパッドをクリップボード
     へ
ファイルメニューのエクスポートにドローイングパッドをクリップ
ボードへというアイテムがあります. この機能は, ドローイングパッ
ドのスクリーンショットを, クリップボードに PNG (PNG フォーマ
ットを参照) 画像としてコピーします. この画像は, 別のプログラム
(例えばマイクロソフト Word) に貼り付けることができます.

 注意: あるサイズ (単位は cm) で作図の画像をエクスポートするた
めには, ファイルメニューのエクスポートにあるドローイングパッ
ドを画像へ (ドローイングパッドを画像へを参照) を使用して下さい
.


5.3. ウェブページ用作図手順
「作図手順のエクスポート」ウィンドウを開くためには, まず表示
メニューから作図手順を開く必要があります. そうすると, ファイル
メニューにウェブページへエクスポートが現れます.

注意: エクスポートウィンドウでは, ウェブページへエクスポート
する前に, 作図手順のいくつかの列を表示したり非表示にしたりで
きます (作図手順の表示メニューを参照).

作図手順のエクスポートウィンドウでは, 作図のタイトル, 著者や
日付を入力でき, 手順とともにドローイングパッドや数式ウィンド
ウの画像をエクスポートするかどうかを選べます.

注意: エクスポートした HTML ファイルは, どのようなインターネ
ットブラウザ (例えば Mozilla や Internet Exploror) でも閲覧可能で,
どのようなワードプロセッサシステム (例えば FrontPage や Word)
でも編集できます.
5.4. ウェブページ用動的ワークシート
ファイルメニューのエクスポートに, 動的なワークシートをウェブ
ページへ (html) というアイテムがあります.

エクスポートウィンドウの上部では, 動的なワークシートのタイト
ル, 著者や日付を入力できます.

一般タブでは, 動的なワークシートの上や下にテキストを付け加え
られます (例えば, 作図の説明や作業など). 作図それ自体を直接ウェ
ブページに含めたり, ボタンをクリックすると開かれるようにもで
きます.

上級タブでは, 動的な作図の機能を変更したり (例えば, リセットア
イコン, ダブルクリックでアプリケーションウィンドウを開く), ユ
ーザーインターフェイスを修正したり (例えば, ツールバーを表示し
たり, 高さと幅を調整したり) できます.
注意: インターネットブラウザで全体が見えるようにするために,
高さと幅を大きすぎる値にしないようにして下さい.

動的なワークシートをエクスポートすると, いくつかのファイルが
作成されます.
   html ファイル (例えば, circle.html) – このファイルはワーク
    シート自体を含んでいます.
   GGB ファイル (例えば, circle_worksheet.ggb) – このファイ
    ルは, GeoGebra の作図を含んでいます.
   geogebra.jar (複数のファイル) – これらのファイルは
    GeoGebra とワークシートを対話的にします.

すべてのファイル (例えば, circle.html, circle_worksheet.ggb と
geogebra.jar のファイル) は, 動的なワークシートを動作させるため
に, ひとつのフォルダ (ディレクトリ) に置かれている必要がありま
す. もちろん, すべてのファイルを別のフォルダにコピーしても構い
ません.

注意: エクスポートされた HTML ファイル (例えば circle.html) は,
どのようなインターネットブラウザ (例えば Mozilla, Internet
Exploror, Safari) でも閲覧することができます. 動的な作図を動作さ
せるためには, Java がコンピュータにインストールされている必要
があります. Java は http://www.java.com から無料で取得できます.
学校のコンピュータネットワークでワークシートを使用したいなら
ば, 学校のネットワーク管理者に, Java をインストールするよう依
頼して下さい.

 注意: 動的なワークシートに含まれるテキストは, エクスポートし
た HTML ファイルを開くことで, 多くのワードプロセッサシステム
(例えば FrontPage, Word) で編集できます.
6.   オプション
オプションメニューでは, 大域的なオプションを変更できます. オ
ブジェクトの設定を変更したいときは, コンテキストメニューを使
います.


6.1. 点をつかむ
点をグリッドに沿わせるか沿わせないかに応じて, 点をつかむをオ
ンかオフにします.


6.2. 角度の単位
角度の単位をを度 (°) で表示するか, ラジアン (rad) で表示するか
決めます.
注意: 入力は常に度数法でも弧度法でも可能です.


6.3. 小数点
数値を, 小数第何位まで表示するかを調整します.


6.4. 連続性
Geogebra のオプションメニューで, 連続性 heuristic のオンとオフ
ができます. このソフトウェアは, 交点 (直線-2次曲線, 2次曲線-2
次曲線) が, 元の交点になるべく近くなるような near-to-heuristic を
用いて, 交点がジャンプするのを防いでいます.

注意: 初期状態では, この heuristic はオフになっています. ユーザー
が定義したツール (ユーザー定義のツールを参照) に対しても, 常に
オフになっています.


6.5. 点のスタイル
点をドットで表示するか, 十字で表示するか決めます.
6.6. 直角のスタイル
直角を長方形で表示するか, ドットで表示するか, 他の角度と同様
に表示するか決めます.


6.7. 座標
点の座標を A = (x, y) と表示するか, A(x | y) と表示するか決めます.


6.8. ラベル付け
新規に作成されたオブジェクトのラベルを, 表示するか非表示にす
るか指定します.
注意: 自動の設定にすると, 新規のオブジェクトが作成されたとき
に数式ウィドウが開いていれば, ラベルを表示します.


6.9. フォントサイズ
ラベルとテキストのフォントサイズ (pt) を決めます.


6.10. 言語
GeoGebra は多言語化されています. ここでは, 現在の言語の設定を
変更できます. これは, コマンド名を含むすべての入力と, すべての
出力に影響します.


6.11. ドローイングパッド
ダイアログを開き, ドローイングパッドのプロパティ (例えば, 座標
のグリッドや軸, 背景色) を設定します.


6.12. 設定の保存
オプションメニューの設定を保存を選択すると, Geogebra は好み
の設定 (オプションメニュー, 現在のツールバーとドローイングパッ
ドの設定) を記憶します.
7.   ツールとツールバー
7.1. ユーザー定義のツール
既にある作図を元にして, GeoGebra の独自ツールを作成すること
ができます. そのツールの作図を準備した後, ツールメニューの新規
ツールの作成を選択して下さい. ダイアログが現れ, ツールの出力と
入力オブジェクトが指定でき, ツールバーアイコンとコマンドの名
前を選べます.

例: 正方形-ツール
    開始点 A と B から正方形を作図します. 他の2頂点を作成
     し, それらを     多角形ツールで結び, 正方形 poly1 を得ます
     .
    ツールメニューの新規ツールの作成を選択します.
    出力オブジェクトを指定します: 正方形をクリックするか,
     ドロップダウンメニューから選択します.
    入力オブジェクトを指定します: GeoGebra は自動的に, 入
     力オブジェクトを指定します (ここでは点 A と B). ドロップ
     ダウンメニューを用いたり, 作図の中でクリックして, 入力
     オブジェクトを選択して, この指定を修正することもできま
     す.
    新規のツールのツール名とコマンド名を指定します. ツール
     名は GeoGebra のツールバーに現れ, コマンド名は
     GeoGebra の入力フィールドで使用することができます.
    ツールバーアイコンの画像を指定することができます.
     GeoGebra はツールバーボタンに合うように, 自動的に画像
     のサイズを変更します.

 注意: 新規のツールは, マウスを用いても, 入力フィールドのコマン
ドとしても使用することができます. すべてのツールは, 自動的に
"GGB" 作図ファイルに保存されます.

ツールメニューのツールの管理を用いると, ツールを消去したり,
名前やアイコンを修正したりできます. 選択したツールを,
GeoGebra Tools File ("GGT") に保存することができます. このファ
イルは, 後から使用することができ (ファイルメニューの開く), 別の
作図にそのツールを読み込むことができます.
 注意: "GGT" ファイルを開いても, 現在の作図は変更されませんが,
"GGB" ファイルを開くと変更されます.


7.2. ツールバーのカスタマイズ
ツールメニューのツールバーのカスタマイズを選択して,
GeoGebra のツールバーのツールをカスタマイズできます. これは,
動的なワークシートに対して特に有用で, ツールバーにおいて利用
可能なツールを制限できます.
注意: 現在のツールバーの設定は, GGB ファイルとして, 作図とと
もに保存されます.




8. JavaScript インターフェイス
注意: GeoGebra の JavaScript インターフェイスは, HTML の編集
経験のあるユーザーにとって興味のあるものです.

動的なワークシートを強化し, 対話性を高めるために, GeoGebra ア
プレットは JavaScript インターフェイスを提供します. 例えば, 動
的な作図の新しい配置をランダムに生成するボタンを作成できます.

例や GeoGebra アプレット と JavaScript の使用についての情報は,
文書 GeoGebra Applets and JavaScript (「ヘルプ」内の
http://www.geogebra.org) を見て下さい.
9. Index
 —2—                      —O—
2次曲線, 34                 osculating circle, コマンド, 46
2次曲線, コマンド, 47
2つのオブジェクトの交点,             —P—
 モード, 19                 parameter, コマンド, 40
2点を通る直線, モード, 21
2点を通る半直線, モード, 20         —X—
2点を結ぶ線分, モード, 20         x 座標, 36
2点を結ぶベクトル, モード,          x 軸, 34
 20
2の対数, 36                  —Y—
 —3—                     y 座標, 36
                         y 軸, 34
3点を通る円, モード, 23
3点を通る外接円弧, モード,           —あ—
 23
                         値, 変更, 31
3点を通る外接扇形, モード,
 23                      アニメーション, 31
                         余り, 39
 —5—                     一般のモード, モード, 16
                         移動, 51
5点を通る2次曲線, モード,
                         移動, モード, 16
 23
                         イメージ, 29
 —A—                     イメージ, 位置, 29
                         イメージ, 隅, 49
affine ratio, コマンド, 41
                         イメージ, 挿入, 29
 —I—                     イメージ, 透過率, 30
                         イメージの挿入, モード, 29
if, コマンド, 48
                         イメージ, 背景, 30
 —J—                     サイズ, 11
                         色, 11
JavaScript, 62           印刷, 54
                         印刷, 作図手順, 54
印刷, ドローイングパッド, 54   オプション, フォントサイズ,
エクスポート, 56           60
エクスポート, ウェブページ      オプション, ラベル付け, 60
 用作図手順, 56          オプション, 連続性, 59
エクスポート, 動的ワークシ
 ート, 57
                     —か—
エクスポート, ドローイング      外周, コマンド, 40
 パッド, 55            階乗, 36
エクスポート, ドローイング      外接円弧, コマンド, 49
 パッドをクリップボードへ,      外接扇形, コマンド, 49
 56                 回転, コマンド, 51
円弧, コマンド, 49        拡大, コマンド, 53
円, コマンド, 46         角度, 32
円周, コマンド, 40        角度, コマンド, 41
扇形, 48              角度, 上下限, 33
扇形 2, コマンド, 49      角度の単位, オプション, 59
扇形, コマンド, 49        角度, モード, 24
大きさを決めた角度, モード,     角度, 優角, 33
 25                 角の二等分線, コマンド, 45
オブジェクトの消去, モード,     角の二等分線, モード, 22
 18                 傾き, コマンド, 39
オブジェクトの表示/非表示       傾き, モード, 24
 のチェックボックス, 25      括弧, 36
オブジェクトの表示/非表示,      下方和, コマンド, 40
 モード, 17            関係, コマンド, 38
オプション, 59           関係, モード, 16
オプション, 角度の単位, 59    関数, 34
オプション, 言語, 60       関数, 区間への制限, 35
オプション, 座標のスタイル,     関数, コマンド, 47, 48
 60
                    関数, 指数, 36
オプション, 小数点, 59
                    ガンマ関数, 36
オプション, 設定の保存, 60
                    管理, ツール, 61
オプション, 直角のスタイル,
                    幾何ウィンドウ, 11
 60
                    幾何的変換, 51
オプション, 点のスタイル, 59
                    軌跡, 25
オプション, 点をつかむ, 59
                    軌跡, コマンド, 50
オプション, ドローイングパ
                    軌跡, モード, 25
 ッド, 60
鏡映, コマンド, 52       三角関数, 逆正弦, 36
極, 座標, 33          三角関数, 逆正接, 36
曲線, 48             三角関数, 逆双曲正弦, 36
極線, コマンド, 46       三角関数, 逆双曲正接, 36
極線/直径, モード, 22     三角関数, 逆双曲余弦, 36
極値, コマンド, 43       三角関数, 逆余弦, 36
曲率, コマンド, 39       三角関数, 正弦, 36
曲率ベクトル, コマンド, 44   三角関数, 正接, 36
距離, コマンド, 39       三角関数, 双曲正弦, 36
距離, モード, 24        三角関数, 双曲正接, 36
切り上げ, 36           三角関数, 双曲余弦, 36
切り捨て, 36           三角関数, 余弦, 36
言語, オプション, 60      算術演算, 35
交点 コマンド, 42        残像, 12
弧, コマンド, 49        軸, x 軸, y 軸, 34
コマンド, 38           軸, コマンド, 46
根, コマンド, 43        軸, 比率, 12
コンテキストメニュー, 11     四捨五入, 36
                   指数関数, 36
 —さ—               自然対数, 36
差, 35              始点と長さで決まる線分, モ
最小値, コマンド, 41       ード, 20
最大値, コマンド, 41      始点を決めたベクトル, モー
再定義, 11, 14         ド, 20
作図手順, 14           重心, コマンド, 42
作図手順, 印刷, 54       準線, コマンド, 46
作図手順, ウェブページ用, エ   商, 35
 クスポート, 56         上下限, 角度, 33
作図手順, エクスポート, 56   上下限, 数値, 33
座標, 33             消去, 11
座標, x 座標, 36       消去, コマンド, 38
座標, y 座標, 36       小数点, オプション, 59
座標, 極, 33          焦点, コマンド, 42
座標, 直交, 33         上方和, コマンド, 41
座標のスタイル, オプション,    常用対数, 36
 60                剰余関数, コマンド, 39
三角関数, 34           真偽値, 演算, 37
真偽値, コマンド, 38         —た—
真偽値, 変数, 37
新規の点, モード, 19        第1軸, コマンド, 46
垂線, コマンド, 45         第1軸の長さ, コマンド, 40
垂線, モード, 21          第2軸, コマンド, 46
垂直二等分線, コマンド, 45     第2軸の長さ, コマンド, 40
垂直二等分線, モード, 21      楕円, コマンド, 46
数式, 27               多角形, コマンド, 45
数値, 32               多角形, 正多角形, モード, 21
数値, 上下限, 33          多角形, モード, 21
ズーム, 12              多項式, コマンド, 47
ズームアウト, モード, 17      単位ベクトル, コマンド, 44
ズームイン, モード, 17       単位法線ベクトル, コマンド,
数列, 50                44
                     単純化, 多項式, 47
数列, その他のコマンド, 50
                     中心と角度で決まる回転, モ
隅, コマンド, 49
                      ード, 26
スライダー, モード, 24
                     中心と半径で決まる円, モー
正弦, 36
                      ド, 22
制限, 関数を区間へ, 35
                     中点, コマンド, 42
整数の商, コマンド, 39
                     中点, モード, 19
正接, 36
                     頂点, コマンド, 42
正多角形, モード, 21
                     長方形の選択領域, 16
積, 35
                     直線, 33
積分, コマンド, 40, 47
                     直線, コマンド, 45
積分, 定積分, 40
                     直線, スタイル, 11
接線, コマンド, 45
                     直線, 線分に変換, 再定義, 14
接線, モード, 22
                     直線に関する鏡映, モード, 26
絶対値, 36
                     直線, 太さ, 11
設定の保存, オプション, 60
                     直角のスタイル, オプション,
漸近線, コマンド, 46
                      60
線分, コマンド, 44
                     直径, コマンド, 46
線分, 直線に変換, 再定義, 14
                     直交, 座標, 33
双曲線, コマンド, 47
                     ツール, 管理, 61
挿入, イメージ, モード, 29
                     ツールバー, カスタマイズ, 62
挿入, テキスト, 27
                     ツールバーのカスタマイズ,
添字, 32, 38
                      62
                     ツール, ユーザー定義, 61
テイラー多項式, コマンド, 47    名前の変更, 11
テキスト, 27             入力フィールド, 32
テキストの挿入, モード, 27     塗り, 11
手順, 14
手順, エクスポート, 56        —は—
点, 33                場合分けを含む関数, コマン
展開, 多項式, 47           ド, 48
点, コマンド, 42          媒介変数表示された曲線, 48
点, 直線上から取り除く, 再定     背景画像, 30
 義, 14               半円, コマンド, 49
点, 直線上に配置, 再定義, 14   半円, モード, 23
点に関する鏡映, モード, 26     半径, コマンド, 40
点のスタイル, オプション, 59    半直線, コマンド, 44
点の回りの回転, モード, 16     反復, 51
点を中心とした拡大, モード,      反復, コマンド, 41
 26                  非表示, 12
点をつかむ, オプション, 59     微分, コマンド, 47
透過率, イメージ, 30        表示, 12
動的ワークシート, エクスポ       表示スタイル, コピー, 17
 ート, 57              表示スタイルのコピー, モー
ドローイングパッド, 11         ド, 17
ドローイングパッド, 印刷, 54    フォーマット, 表示スタイル
ドローイングパッド, エクス        のコピー, モード, 17
 ポート, 55             フォントサイズ, オプション,
ドローイングパッド, オプシ        60
 ョン, 60              複比, コマンド, 41
ドローイングパッド, クリッ       符号, 36
 プボードへ, エクスポート,      ブレークポイント, 14, 54
 56                  プロパティ, 15
ドローイングパッドの移動,        プロパティ, ダイアログ, 15
 モード, 16             平行移動, コマンド, 51
                     平行線, モード, 21
 —な—
                     平方根, 36
内積, 35               ベクトル, 33
長さ, コマンド, 39         ベクトル, コマンド, 43
ナビゲーションバー, 14, 54    ベクトルで決まる平行移動,
名前, コマンド, 50          モード, 26
変換, 幾何的, 51         —ら—
変曲点 コマンド, 43
方向ベクトル, コマンド, 43   ラベル付け, オプション, 60
法線ベクトル, コマンド, 44   ラベルの表示/非表示, モー
放物線, コマンド, 47       ド, 17
                   乱数, 36
 —ま—               離心率, コマンド, 40
                   リスト, 35
面積, 2つの関数のグラフの
                   立方根, 36
 間の, 39
                   累乗, 35
面積, コマンド, 39
                   連続性, オプション, 59
面積, 定積分, 39
面積, モード, 24         —わ—
モード, 15
モード, 一般のモード, 16    和, 35

 —や—                —漢字—
ユーザー定義のツール, 61     中心と円周上の点で決まる円,
要素, コマンド, 38        モード, 22
余弦, 36             中心と弧上の2点で決まる円
                    弧, モード, 23
                   中心と弧上の2点で決まる扇
                    形, モード, 23

								
To top